Subject: RE: [Megaco] IPV4 Address range

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 4 Sep 2001 08:18:01 -0400

Unbelievable.  You have no idea how many people looked at this
text for just this kind of error, and now, almost a year later,
you spot it.  Yes, it should be 255, sigh.

Terry, need a Implementor's Guide note on this one for sure!

Brian

> -----Original Message-----
> From: Andrew Russell-laing [mailto:[email-masked]]
> Sent: Tuesday, September 04, 2001 8:07 AM
> To: [email-masked]
> Subject: [Megaco] IPV4 Address range
> 
> 
> 
> 
> 
> Can someone please identify whether the RFC3015 text encoding 
> of the IPV4address
> (format nnn.nnn.nnn.nnn   where the range of nnn is 0-225) is 
> correct or is the
> 225  a typo error.
> 
> These nnn values are 8 bit address segments so shouldn't the 
> range be 0-255.
> 
> Thanks
> 
> Andrew Russell-Laing
> Cov x2734
> 
> 
> 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Tue, 04 Sep 2001 10:37:02 -0400

I am just as amazed that no one has noticed this before.  I'll put in IG!

--
Waiting for the other shoe to drop but hoping its a one legged man.
------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: "Paul Long" <[email-masked]>
Date: Wed, 5 Sep 2001 19:28:40 -0500

Actually, ... :-) this was reported back in May (see attached), but I guess
it never actually made it into the IG.

Paul Long
ipDialog, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Terry L Anderson
Sent: Tuesday, September 04, 2001 9:37 AM
To: Rosen, Brian
Cc: Russell-Laing, Andrew; [email-masked]
Subject: Re: [Megaco] IPV4 Address range

Subject: Re: IPv4 address improperly defined
From: "Christian Groves" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>, "megaco ietf" <[email-masked]>
Date: Tue, 15 May 2001 09:07:46 -0500

Hello Jeff,

Thankyou for your email. It is a bug that was missed. I have added the
following to the Implementors' Guide to cover this:
6.88 Error in ABNF IPv4 address syntax

Description:	The value of the Ipv4 is incorrect. It should be 0..255 not
0.225.
Reference:	Subject: IPv4 address improperly defined
Date: Mon, 14 May 2001 12:45:24 -0400
From: [email-masked]
To: "[email-masked]" <[email-masked]>, [email-masked]
 [Begin Correction]
B.2 ABNF Syntax Specification
…
V4hex                = 1*3(DIGIT) ; "0".."2255"

…
[End Correction]

Regards, Christian

[email-masked] wrote:
>
> Hi,
>
> I would assume that you've already discovered this bug, but if not...
>
> -Jeff Gilles
> Catapult Communications
>
>   ------------------------------------------------------------------------
>                   Name: Erratum.doc
>    Erratum.doc    Type: Microsoft Word Document (application/msword)
>               Encoding: base64