Subject: [Megaco] Should an Audio Mixer be a Termination?

From: "Miao, Kai" <[email-masked]>
Date: Mon, 10 Sep 2001 18:43:39 -0400

To be sure, an audio mixer sources and sinks streams. But, in a DSP whose
job is to process media streams, every functional module sources and sinks
streams. 

Unlike RTP and TDM terminations which are endpoints (so the concept of
termination seems to apply), it is not apparent that a mixer in a gateway or
server is any type of endpoint.  

So, on what basis do we make an audio mixer a termination?

Can someone clarify this?

Thanks.
Kai Miao

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 10 Sep 2001 19:01:19 -0400

"Endpoint" is an MGCP term, and the source of considerable confusion when
Megaco was getting started.  A termination is, as the standard says, a
source or sink for media.  It doesn't have to be an endpoint in the MGCP
sense.

It would be nice if we could stick to the view that audio mixers are
modelled by contexts rather than terminations, but Roni Evan has identified
cases where that would require context properties which Megaco/H.248 doesn't
currently support.  We end up either deferring his functionality to H.248v2
or doing some creative modelling.

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Monday, September 10, 2001 6:44 PM
To: 'megaco'
Subject: [Megaco] Should an Audio Mixer be a Termination?

Thanks.
Kai Miao

---

From: "Miao, Kai" <[email-masked]>
Date: Fri, 14 Sep 2001 15:26:08 -0400

Have we made clear all the properties that belong to a mixer termination? I
would like a list of them if they have been (or partially) determined.
 
Also, could you someone send to me the detailed requirements for
conferencing which have been developed so far?
 
Thanks,
Kai

-----Original Message----- 
From: Miao, Kai [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Monday, September 10, 2001 6:44 PM 
To: 'megaco' 
Subject: [Megaco] Should an Audio Mixer be a Termination? 

Thanks. 
Kai Miao 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
http://www1.ietf.org/mailman/listinfo/megaco
<http://www1.ietf.org/mailman/listinfo/megaco>

---

From: "Even ,Roni" <[email-masked]>
Date: Mon, 17 Sep 2001 09:55:45 +0200

Hi,
The current view is not to have a mixer termination but to define the mix in
the party termination (RTP or TDM) by using the stream descriptor. There is
a need to add some properties that will help with defining the level, this
is still a work in progress. We discussed on this list the requirements for
an MCU decomposition requirements

Thanks
Roni Even

-----Original Message-----
From: Miao, Kai [mailto:[email-masked]]
Sent: Friday, September 14, 2001 9:26 PM
To: 'megaco'
Subject: RE: [Megaco] Should an Audio Mixer be a Termination?

 
Thanks,
Kai

-----Original Message----- 
From: Miao, Kai [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Monday, September 10, 2001 6:44 PM 
To: 'megaco' 
Subject: [Megaco] Should an Audio Mixer be a Termination? 

Thanks. 
Kai Miao