Subject: [Megaco] More about Packages

From: Niraj Kedar <[email-masked]>
Date: Fri, 28 Sep 2001 04:55:32 -0700 (PDT)

Thanks Brian for the earlier clarification on
Packages. 

Does it mean that Packages are implemented through the
various Descriptors provided by the protocol? In that
case why does the protocol use Packages? Descriptors
could as well have been used. The explaination that
Package is an extension mechanism for the protocol is
justifiable. But that job could have been taken by the
Descriptors. So the clear demarcation between the two
is still not clear to me. Can U please clarify
further?

regards,
Niraj Kedar
L&T Infotech Ltd,
Bangalore,
India

P.S.: I am using this new account because of space
constraints with the earlier one.

>>>>>>>>>>>>>
> I would like to know specifically what is meant by
> Realization of Packages by a Termination (or MG).
It means that the package is implemented on the
termination.
Not all packages have to be implemented on all
terminations.
Not all terminations have the same set of packages
realized
on them.

> Looking at some of the existing Packages, I have
some
> questions. 
 
> When defining Properties in Packages, one of the
> fields is "Possible Values" and another is "Defined
> In". The former lists all possible values (range)
that
> the property may take. And the later names the
> descriptor name, that the property is defined in. 
> 
> Does this mean that the actual value of a property,
> that it may take at any instance of time, is stored
in
> the Descriptor and not in the Package?
Yes.  The package is not a container implemented at
run time.  It is a descriptive mechanism describing a
set of properties, events, signals and statistics
that are implemented as a complete set (if you
implement
part of a package, you implement all of it).

> 
> Does it mean that Packages define and elaborate a
> Property but dont contain its exact value (at an
> instance of time as requested through the AuditValue
> command)?
The package describes a set of "new" properties
(which are implemented in TerminationState or
LocalControl),
events (which are implemented in EventDescriptor, 
ObservedEventDescriptor, and EventBufferDescriptor), 
signals (which are implemented in SignalDescriptor),
and/
or statistics (which are implemented in
StatisticsDescriptor).
It's a way to extend the definition of the protocol,
but
not require all terminations on all gateways to
implement
all possible properties, events, signals and
statistics. 

Does that clear up your confusion?

__________________________________________________
Do You Yahoo!?
Listen to your Yahoo! Mail messages from any phone.
http://phone.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 28 Sep 2001 08:07:46 -0400

I feel like we are having problems communicating.

A descriptor is a set of objects.  Each of these
objects has a purpose, and something defines
each of the objects, along with it's parameters if any.
The object definition includes, among other things,
on which descriptor it is implemented.
The descriptors are real protocol structures.  The
protocol operates on these structures, and the objects
are implemented on these structures.

A package is a documentation mechanism - it groups
a set of individual definitions of new objects.
The package is only the definition of a set of new
objects.

All of the objects are actually implemented on
the existing descriptors.  I can't define all possible
objects in each of the descriptors, or it wouldn't
be an extension mechanism.  We define new packages
all the time, but the set of descriptors stay constant -
the package defines a new set of objects which can
be implemented on the existing descriptors.

Packages are implemented (realized) as a group -
if you implement any of the objects, you implement
all of them.

Brian

> -----Original Message-----
> From: Niraj Kedar [mailto:[email-masked]]
> Sent: Friday, September 28, 2001 7:56 AM
> To: [email-masked]
> Subject: [Megaco] More about Packages
> 
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 28 Sep 2001 10:09:17 -0400

Packages are a means for protocol specification.  At run time the properties
etc. that packages specify appear within descriptors.

-----Original Message-----
From: Niraj Kedar [mailto:[email-masked]]
Sent: Friday, September 28, 2001 7:56 AM
To: [email-masked]
Subject: [Megaco] More about Packages

regards,
Niraj Kedar
L&T Infotech Ltd,
Bangalore,
India

some
 
that
in