Subject: AW: [Megaco] Packed Encoding Rules

From: Winter Johannes <[email-masked]>
Date: Fri, 28 Sep 2001 12:09:15 +0200

Hello Troy,

I don't agree with your opinion. 
H.225 (v4) has the option to import Megaco Signal Descriptor and Package
Descriptor for a stimulus control of a H.323 entity. 
Within H.225 these descriptors have to be coded using PER. 
So, in my opinion, the result would be that for a communication both ecoding
rules, the BER and the PER, have to be implemented for a stimulus controled
H.323 entitiy. 
There is also a similar situation, if an H.323 implementation is stimulus
controled by using Annex L of H.323. Also in this case, the Megaco data has
to be PER coded. 
If we would allow PER for Megaco (as an option!) we could avoid such an
additional conversion from BER to PER (and vice versa). 
Any other opinions?

With best regards

Johannes

> -----Ursprüngliche Nachricht-----
> Von: Troy Cauble [mailto:[email-masked]]
> Gesendet am: Montag, 10. September 2001 17:26
> An: Leis Peter
> Cc: [email-masked]'
> Betreff: Re: [Megaco] Packed Encoding Rules
> 
> 
> For what it's worth, I'd rather not see this.
> I think this protocol has more than enough variations
> already.
> 
> I don't see how this aids interoperability with H.323.  
> Yes H.323 has PER.  But it's PER of different data.  
> You'll still have to parse it and translate it.
> 
> -troy
> 
> Leis Peter wrote:
> > 
> > hi list,
> > 
> > what is the opinion about the following proposal:
> > 
> > we suggest to add (as an option) the possiblity to allow 
> Packed Encoding Rules PER for
> > binary encoding of H.248 (in addition to BER).
> > 
> > advanatages:
> > - greater interoperability between H.323 entities and H.248 entities
> > - PER encoded messages consume less transport capacity
> > 
> > This could be reached via an additional default port.
> > Only some minor changes in H.248 Section 9, Annex A, Annex 
> D and Annex H
> > would be neccessary.
> > 
> > If you agree I would submit an official proposal.
> > 
> > Peter
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 28 Sep 2001 07:57:28 -0400

I too am strongly opposed to more encoding options.
We have already seen that incompatibility is the result
of having the two choices we have now, and without
the expected benefits (text is both smaller and
faster than BER, but not by much).

Brian

> -----Original Message-----
> From: Winter Johannes [mailto:[email-masked]]
> Sent: Friday, September 28, 2001 6:09 AM
> To: 'Troy Cauble'; LEIS PETER; [email-masked]'
> Subject: AW: [Megaco] Packed Encoding Rules
> 
> 
> Hello Troy,
>