Subject: [Megaco] H.248 Annex M.1 (Advanced Announcement Server)

From: CHATRAS Bruno FTRD/DAC/ISS <[email-masked]>
Date: Mon, 3 Sep 2001 18:12:46 +0200

Hello,
Two quick questions about Annex M.1

1) What should happen if the MGC sets the NotifyCompletion parameter when
requesting the PlayAndCollect (aasdc/playcol) signal? Should both the
PlayCollect Success (aasdc/pcolsucc) and Signal Completion (g/sc)events be
reported at the same time?

2) What should happen if the MGC sends a Modify command requesting the
application of two signals (i.e. to be played simultaneously), both of which
being the PlayAndCollect signal? What are the rules for processing the digit
buffer ?  (I know that it is unlikely that an MGC will do that, but I just
want to understand the mechanisms for supporting multiple signals, when
signals are something else than "MG generated media stream"). 

Regards,
Bruno

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 3 Sep 2001 21:34:34 -0400

Hi.  I realize this annex presents an extreme example of the view of
"signals" as operations rather than media events, so it is good to get the
rules straight.

-----Original Message-----
From: CHATRAS Bruno FTRD/DAC/ISS
[mailto:[email-masked]]
Sent: Monday, September 03, 2001 12:13 PM
To: [email-masked]'
Subject: [Megaco] H.248 Annex M.1 (Advanced Announcement Server)

Hello,

[PTT] Assuming the MGC enables both events, I assume both would be reported.

[PTT] My personal view is that the digit events are made available to every
operation which is interested in them.  This could include DTMF digit
events, if enabled.

Regards,
Bruno

---

From: CHAPRON Jean-Emmanuel FTRD/DAC/ISS <[email-masked]>
Date: Tue, 4 Sep 2001 10:40:11 +0200

Good Day,
 
You exactly point out my concern about this annex: Signals are here not "MG
generated media streams", as described in the standard (section 6.2), but
used for launching scripts. 
This is not the first time that signals are used for other purposes than
simply requesting "MG generated media streams" (e.g: Q.1950, where signals
are used to send ATM signalling messages), and these different uses create
an ambiguity that should be deleted.
 
As far as the protocol lacks a mechanism enabling the MGC to request the MG
to launch scripts and send signalling messages, I propose to explicitly
describe such mechanisms either in the Implementor's Guide, or in version 2.
I see two solutions:
 
(1) creating one or more new descriptor(s) containing the set of scripts
and/or signalling messages the MG has to launch/send. That way, the Signal
Descriptor could be definitely used for "MG generated media streams", as
described in section 6.2
 
(2) modifying the definition of a "Signal" in the core protocol. This
definition would enable the use of the Signal Descriptor for:
    + sending the famous "MG generated media streams"
    + running scripts
    + sending signalling messages
    + others??
 
Whatever the adopted solution is, the most important IMHO is that created
packages and profiles conform to the definitions contained in the
H.248/MEGACO standard. 
 
Any thoughts? 

               ``` 
              (o o) 
----------oOO--(_)-OOo-------------- 
Jean-Emmanuel CHAPRON 
FRANCE TELECOM R&D 
DAC/ACE 
38-40 rue du général Leclerc 
92794 Issy-les-Moulineaux Cedex 9 - France 
Tel: +33 1 45 29 64 50 
------------------------------------- 

-----Original Message----- 
From: CHATRAS Bruno FTRD/DAC/ISS 
[ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Monday, September 03, 2001 12:13 PM 
To: [email-masked]' 
Subject: [Megaco] H.248 Annex M.1 (Advanced Announcement Server) 

Hello, 

Regards, 
Bruno 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
http://www1.ietf.org/mailman/listinfo/megaco
<http://www1.ietf.org/mailman/listinfo/megaco>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 4 Sep 2001 12:52:19 -0400

In fact, no modification to section 6 is necessary.  If you look at the
tabulation of descriptor types in section 6.2.4, the definition of the
signals descriptor reads as follows:

"Describes signals and/or actions to be applied (e.g.   Busy Tone) to the
Terminations."

Annex M.1 describes actions as well as signals.

-----Original Message-----
From: CHAPRON Jean-Emmanuel FTRD/DAC/ISS
[mailto:[email-masked]]
Sent: Tuesday, September 04, 2001 4:40 AM
To: Taylor, Tom-PT [NORSE:B881:EXCH]; [email-masked]'
Subject: RE: [Megaco] H.248 Annex M.1 (Advanced Announcement Server)

Good Day,

 

 
Any thoughts? 

               ``` 
              (o o) 
----------oOO--(_)-OOo-------------- 
Jean-Emmanuel CHAPRON 
FRANCE TELECOM R&D 
DAC/ACE 

-----Original Message----- 

Hello,

---

From: CHAPRON Jean-Emmanuel FTRD/DAC/ISS <[email-masked]>
Date: Wed, 5 Sep 2001 14:01:17 +0200

Ok, but I think there is still an ambiguity:
 
As it is mentionned in section 1.2 of the Annex M.1 draft, this annex
describes "complex operations [that] are like pre-defined scripts".
According to your answer, must we understand that those scripts can be
considered as "actions"? 
 
If yes, why is it written, still in section 1.2 - Annex M.1, that scripts
are an "extension of the "signal" concept" ?
 
So, extension or not extension?

               ``` 
              (o o) 
----------oOO--(_)-OOo-------------- 
Jean-Emmanuel CHAPRON 
FRANCE TELECOM R&D 
DAC/ACE 

-----Original Message----- 
From: CHAPRON Jean-Emmanuel FTRD/DAC/ISS [
mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Tuesday, September 04, 2001 4:40 AM 
To: Taylor, Tom-PT [NORSE:B881:EXCH]; [email-masked]' 
Subject: RE: [Megaco] H.248 Annex M.1 (Advanced Announcement Server) 

Good Day, 

  

Any thoughts? 

               ``` 
              (o o) 
----------oOO--(_)-OOo-------------- 
Jean-Emmanuel CHAPRON 
FRANCE TELECOM R&D 
DAC/ACE 

-----Message d'origine----- 
De : Tom-PT Taylor [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Envoyé : mardi 4 septembre 2001 03:35 
À : 'CHATRAS Bruno FTRD/DAC/ISS'; [email-masked]' 
Objet : RE: [Megaco] H.248 Annex M.1 (Advanced Announcement Server) 

-----Original Message----- 

Hello, 

Regards, 
Bruno

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 5 Sep 2001 08:26:36 -0400

You're right: I should use the word "action" instead of "operation" and
remove the part about "extension".

-----Original Message-----
Sent: Wednesday, September 05, 2001 8:01 AM

 

               ``` 
              (o o) 
----------oOO--(_)-OOo-------------- 
Jean-Emmanuel CHAPRON 
FRANCE TELECOM R&D 
DAC/ACE 

-----Original Message----- 

Good Day, 

  

Any thoughts? 

               ``` 
              (o o) 
----------oOO--(_)-OOo-------------- 
Jean-Emmanuel CHAPRON 
FRANCE TELECOM R&D 
DAC/ACE 

-----Original Message----- 

Hello, 

Regards, 
Bruno