Subject: [Megaco] Megaco Packages

From: Niraj Kedar <[email-masked]>
Date: Tue, 25 Sep 2001 03:40:43 -0700 (PDT)

Hi,

I would like to know specifically what is meant by
Realization of Packages by a Termination (or MG).
Looking at some of the existing Packages, I have some
questions. 

When defining Properties in Packages, one of the
fields is "Possible Values" and another is "Defined
In". The former lists all possible values (range) that
the property may take. And the later names the
descriptor name, that the property is defined in. 

Does this mean that the actual value of a property,
that it may take at any instance of time, is stored in
the Descriptor and not in the Package?

Does it mean that Packages define and elaborate a
Property but dont contain its exact value (at an
instance of time as requested through the AuditValue
command)?

How is a Package generally implemented as?

regards,
Niraj Kedar,
L&T Infotech Ltd,
Bangalore,
INDIA.

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger. http://im.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 25 Sep 2001 08:13:12 -0400

> Realization of Packages by a Termination (or MG).
It means that the package is implemented on the termination.
Not all packages have to be implemented on all terminations.
Not all terminations have the same set of packages realized
on them.

> the Descriptor and not in the Package?
Yes.  The package is not a container implemented at
run time.  It is a descriptive mechanism describing a
set of properties, events, signals and statistics
that are implemented as a complete set (if you implement
part of a package, you implement all of it).

> instance of time as requested through the AuditValue
The package describes a set of "new" properties
(which are implemented in TerminationState or LocalControl),
events (which are implemented in EventDescriptor, 
ObservedEventDescriptor, and EventBufferDescriptor), 
signals (which are implemented in SignalDescriptor), and/
or statistics (which are implemented in StatisticsDescriptor).
It's a way to extend the definition of the protocol, but
not require all terminations on all gateways to implement
all possible properties, events, signals and statistics. 

Does that clear up your confusion?