Subject: [Megaco] Question on Audit

From: Steven Weisz <[email-masked]>
Date: Mon, 10 Sep 2001 13:32:59 -0400

Hi List,

I have a simple question: Let's say we issue an AuditValue command on a
specific termination with the audit item set to Audit DigitMap. I my
termination does not have a Digit Map defined on it what should the MG reply
with? Should we reply with an empty digit map descriptor, or no digit map
descriptor at all. 

Also, expanding on this, what if the MGC asks for an audit on any other
valid audit item for which the MG does not have anything set. Do we again
send an empty descriptor or do we just not send anything at all?

Thanks,

Steven 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Mon, 10 Sep 2001 15:03:41 -0400

Steven,

Referring to the ABNF, I believe that auditItem is in
auditReturnParameter for the purpose of returning
empty descriptors.  I think this answers your empty/none
question.

The real problem is that some of the descriptors have two
empty forms, the auditItem form and another form in 
auditReturnParameter.

See the June, July thread 'IG 6.79 "Cancelling Event Detection" breaks ABNF'.
I'm attaching one message from that thread below.

-troy

> send an empty descriptor or do we just not send anything at all?

Subject: Re: IG 6.79 "Cancelling Event Detection" breaks ABNF
From: Troy Cauble <[email-masked]>
To: "Rosen, Brian" <[email-masked]>
Cc: Tom-PT Taylor <[email-masked]>, "[email-masked]'" <[email-masked]>, MEGACO list <[email-masked]>
Date: Fri, 08 Jun 2001 11:19:24 -0400

A summary of the problems discussed in this thread.

1) In the text encoding, some empty descriptors have the form
   "Signals {}" while others have "Events".

In a Termination Audit:

2) There are two line encodings for an empty Signals descriptor
   (text and ASN.1).

3) There are two line encodings each for an empty Events descriptor
   or Event Buffer descriptor (ASN.1 only).

4) In the text encoding, EventsToken and EventBufferToken each
   have reduce/reduce conflicts because they can represent either
   an auditItem token or an empty descriptor in the auditReturnParameter.

-troy

"Rosen, Brian" wrote:
> 
> I agree with Tom; we did a pass over the ABNF to try to make
> all of the empty forms not have braces.  The choice was
> completely arbitrary, and as I recall, we decided since it
> didn't make any real difference, shorter was better.
> If we missed one, we goofed.
> 
> Tom, the problem here seems to be real.  As Troy says, you will get
> a reduce conflict in a rules-based parser with this ambiguity.
> I'm pretty sure you can ignore the problem, but it's poor design
> practice.  You will recall all of the effort Abdallah and Nancy
> went through to test out these kinds of things as we developed
> the ABNF.  The IG change wasn't verified in the same way, thus
> we have this problem.  We need to decide what to do.
> 
> Brian
> 
> > -----Original Message-----
> > From: Troy Cauble [mailto:[email-masked]]
> > Sent: Thursday, June 07, 2001 6:39 PM
> > To: Tom-PT Taylor
> > Cc: Rosen, Brian; Christian Groves; MEGACO list
> > Subject: Re: IG 6.79 "Cancelling Event Detection" breaks ABNF
> >
> >
> > > Tom-PT Taylor wrote:
> > >
> > > I'm the one responsible for all this.  I suppose I should
> > dig up the thread.
> > > Anyway, the intention was definitiely to provide a way of
> > signalling empty
> > > descriptors.  I think we chose rather arbitrarily between
> > the desc{} and desc
> > > form, opting for the latter.
> >
> > Well, an empty Signals Descriptors already uses desc{},
> > shouldn't we go for the symmetry?  Didn't we just change
> > the original protocol for symmetry reasons?  This would
> > be just changing the IG.
> >
> > -troy
> >

---

From: Mike Broome <[email-masked]>
Date: Mon, 10 Sep 2001 16:09:00 -0400

The example call flow in Appendix A of RFC 3015 has an example of this
case.  See steps 19 and 20 on pp. 174-175.  The MGC sends an AuditValue
command asking for -- among other things -- the Digitmap descriptor for
the termination on MG2.  That termination does not have a Digitmap so
MG2 returns just the name of the descriptor ("Digitmap") indicating
there is no Digitmap.

Mike

-- 
Mike Broome
Cisco Systems, RTP, NC
mbroome(at)cisco.com