Subject: RE: [Megaco] How to send empty Quoted string in ASN.1?

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 12 Sep 2001 08:35:40 -0400

This is a trick question.  The Annex B quotedString production requires at
least one character.  That means you should really be encoding the presence
or absence of the string parameter itself, and any syntax production which
forces you to return a zero-length quotedString is in error.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, September 12, 2001 3:16 AM
To: [email-masked]
Subject: [Megaco] How to send empty Quoted string in ASN.1?

Hello,
     In ABNF , empty Quoted String can be send as empty Quotes.

     To send the same in ASN.1 , we can do one of the following :-
     a) length of string as zero will serve the purpose .
     b) length as two and empty quotes in the string.

Which of these is the correct strategy?

Thanks & Regards,
Monika

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Wed, 12 Sep 2001 10:52:13 -0400

Tom,

IG 6.55 changed quotedString to allow for no characters 
within the double quotes.

Monika,

"quotedString" is an ABNF construct.  In ASN.1 quoting a
String VALUE is unnecessary, regardless of the string's 
length.

-troy

> Tom-PT Taylor wrote: