Subject: [Megaco] Problem Regarding Choose as Parameter Value

From: [email-masked]
Date: Wed, 5 Sep 2001 16:20:10 +0530

Hi,

I have a query regarding Choose as Parameter Value. In rfc 3015
section A.2 (ASN.1 Syntax) mentions that empty sequence of Value
in the PropertyParm Structure will be interpreted as CHOOSE by the MGC.

But i couldnot find any such explanation in section A.3 (ABNF syntax).
Shall i assume that we have to use '$' to represent CHOOSE in this case?

for example is the following syntax valid

{ <pckg name/item name> { <param name> = $ } }

Regards,
Rahul

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 5 Sep 2001 07:16:42 -0400

Yes, you use '$" to specify choose in the ABNF.

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, September 05, 2001 6:50 AM
> To: [email-masked]
> Subject: [Megaco] Problem Regarding Choose as Parameter Value
> 
> 
> 
> 
> Hi,
>