Subject: RE: [Megaco] DigitMap question

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 25 Sep 2001 11:03:40 -0400

Should work.  If both the dtmf std and/or etd events plus the ce
event are present, you should get the events for the digits
and the digitmap.

I don't really understand WHY you would bother with the digitmap
though, what you can't do is to avoid the Notify for the digits.
So you are getting all the Notifies - why add the ce?

Brian

> -----Original Message-----
> From: Dan Elbert [mailto:[email-masked]]
> Sent: Tuesday, September 25, 2001 10:57 AM
> To: [email-masked]
> Subject: [Megaco] DigitMap question
> 
> 
> Hi
> 
> I'm trying to find a way to "echo" digits dialed in a phone back to a
> display (using the IpPhone display package) while minimizing 
> traffic on the
> newtwork and latency ( I don't want to send each digit to the 
> MGC and wait
> for the display signal to come back), and using a digitmap.
> What should be the behavior of the MG if a digitmap is 
> active, and an events
> descriptor is received which include both the digit map 
> completion event AND
> the individual digits, and for each individual digit there is 
> attached an
> embedded signal displaying that digit to the display ?
> I cannot figure out from the spec if in this case the 
> individual digits will
> still be reported, or only the completion event.
> 
> Dan Elbert
> RADVISION
> 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 25 Sep 2001 11:17:02 -0400

Sorry, I think you lose.  The ce avoids having to put std/etd in the
EventsDescriptor.  If you do put them in, then you get the
Notifies for them.

Brian

> Sent: Tuesday, September 25, 2001 11:09 AM
> To: 'Rosen, Brian'; [email-masked]
> Subject: RE: [Megaco] DigitMap question
> 
> 
> I was hoping that I could avoid the Notifies for the digits, 
> based in :
> 
>    *  the events in the package containing the specified digit map
>       completion event other than the completion event itself are not
>       individually notified
> 
> the spec is not completely clear on this, it mentions the 
> case that all the
> events in the package (including ce) are requested with 
> wildcard, but it
> doesn't say anything about specifically requesting the digits 
> along with the
> ce.
> 
> Dan
> 
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Tuesday, September 25, 2001 11:04 AM
> To: 'Dan Elbert'; [email-masked]
> Subject: RE: [Megaco] DigitMap question
>