Subject: [Megaco] Problem in binary Encoding of Local/Remote descriptor

From: Prasad Nayak <[email-masked]>
Date: Tue, 4 Sep 2001 14:28:54 +0530

Hi,
   In RFC 3015, ASN.1 grammar for "LocalRemoteDescriptor" is 

   LocalRemoteDescriptor ::= SEQUENCE
   {
        propGrps        SEQUENCE OF PropertyGroup,
        ...
   }

   PropertyGroup ::= SEQUENCE OF PropertyParm

   PropertyParm ::= SEQUENCE
   {
        name            PkgdName,
        value           SEQUENCE OF OCTET STRING,
        extraInfo       CHOICE
                {
                        relation        Relation,
                        range           BOOLEAN,
                        sublist         BOOLEAN
                } OPTIONAL,
        ...
   }

This says, local/Remote descriptor is list of PropertyParm

In ANNEX C, the tag-value pairs are given for local and remote descriptor.
My question is, how i should map this tag-value to PropertyParm ??

Example :: Let us consdier table C.1 (General Media Attributes). the first
attribute (first row) is 

PropertyID : Media
Tag        : 1001  
Type       : Enumeration 
Value      : Audio(0), Video(1), Data(2)

Now how to map (assign) the tag and value of this attribute to PropertParm (
PropertyParm given in ASN.1 grammar).

Pls, anybody give soultion to do this mapping.

Regards,
Prasad

NetBrahma Technologies
Internext Networking Software
Email : [email-masked]
URL : www.netbrahma.com
Tel : +91 80 5521451

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Tue, 4 Sep 2001 17:37:14 +0530

Hello,

Example :-

     table C.1 (General Media Attributes)

     PropertyID : Media
     Tag        : 1001
     Type       : Enumeration

This in ASN.1 will be :-
_____________________

tag = a0 (name)
length
value = 1001 (tag for Property id media)
     tag = a1 (Value : sequence of)
     length
          value = 04 (octet string)
          length
               value =   type of value (octet string - double wrapped) ENUM in
this case
               length
                    value = 1(video)

regards,
Monika Puri

Prasad Nayak <[email-masked]> on 09/04/2001 02:28:54 PM

To:   "[email-masked]'" <[email-masked]>
cc:    (bcc: Monika Puri/HSS)

Subject:  [Megaco] Problem in binary Encoding of Local/Remote descriptor

Hi,

PropertyID : Media
Tag        : 1001
Type       : Enumeration

Regards,
Prasad

NetBrahma Technologies