Subject: Re: [Megaco] How to send empty Quoted string in ASN.1?

From: [email-masked]
Date: Thu, 13 Sep 2001 12:24:14 +0530

Hi Troy & All,
     As in section E.6.2 , empty Quoted string is allowed under parameter "ds".
     How to send empty string in case of ASN.1?
     In ABNF , this can be send as a quoted string (empty) .

     In ASN.1 , we can do one of the following :-
     a) length of string specified as zero
     b) length of string as two and empty quotes ("") in the string.

     Which of these is correct ?

Regards,
monika

Troy Cauble <[email-masked]> on 09/12/2001 08:22:13 PM

Please respond to Troy Cauble <[email-masked]>

To:   Tom-PT Taylor <[email-masked]>
cc:   Monika Puri/HSS@HSS, [email-masked]

Subject:  Re: [Megaco] How to send empty Quoted string in ASN.1?

Tom,

IG 6.55 changed quotedString to allow for no characters
within the double quotes.

Monika,

"quotedString" is an ABNF construct.  In ASN.1 quoting a
String VALUE is unnecessary, regardless of the string's
length.

-troy

> Tom-PT Taylor wrote:
>
> This is a trick question.  The Annex B quotedString production requires at
> least one character.  That means you should really be encoding the presence
> or absence of the string parameter itself, and any syntax production which
> forces you to return a zero-length quotedString is in error.
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, September 12, 2001 3:16 AM
> To: [email-masked]
> Subject: [Megaco] How to send empty Quoted string in ASN.1?
>
> Hello,
>      In ABNF , empty Quoted String can be send as empty Quotes.
>
>      To send the same in ASN.1 , we can do one of the following :-
>      a) length of string as zero will serve the purpose .
>      b) length as two and empty quotes in the string.
>
> Which of these is the correct strategy?
>
> Thanks & Regards,
> Monika
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Thu, 13 Sep 2001 11:02:45 -0400

Monika,

The zero length string is correct.
Quotes should not be used for ASN.1 encoding of any 'ds'
VALUES, empty or not.

All,

I think that Monika has pointed out a minor bug in E.6.2.  
The reference to quotedString should be removed.  It's
specific to ABNF and superfluous for ABNF given the type
String.

-troy