Subject: [Megaco] Annex G - Label key question

From: Dan Elbert <[email-masked]>
Date: Wed, 26 Sep 2001 09:29:18 -0500

Hi
I'm trying to gain better understanding into the use of the "label" field in
the packages derived from "Label Key Package".
It doesn't seems to me that either the MG nor the MGC need the "label"
information. For example, for the "Function Key Package" the keys have
either a well known meaning by key id, or a dynamic meaning (fxxx) but the
mapping of "key id" to "function" is done by the MGC and there is no need
for the "label" information. 
For the "Soft Key Package" is the same, in this case there is display but is
not directly connected to the label anyway.
Can someone provide me with insight about the intended use of this property
?

Thanks,

Dan Elbert
RADVISION

-----Original Message-----
From: Dan Elbert [mailto:[email-masked]]
Sent: Tuesday, September 25, 2001 3:07 PM
To: [email-masked]'; [email-masked]'
Subject: [Megaco] IP Phone call flow

Hi
Is there any document showing an example of call flows which use the Annex G
packages for an IP Phone ?
Thanks,

Dan Elbert
RADVISION

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: "Blatherwick, Peter" <[email-masked]>
Date: Fri, 28 Sep 2001 13:07:22 -0400

Reasoning behind the "label" is twofold: 1) provide a means to identify the intent of a specific key, which is definable from the MGC side (allows for example MGC to discover previously configured key meanings at add/move/change or restart/handoff/failover); 2) provide a container for label text which could be used for self-labeling keys in some implementations (vendor choice).  On first point, it is not necessarily the case that all useful keys are assigned a "well known" id -- the ids defined in Annex G Function Key are a small subset of potential key names (the set we could agree on, does not even include handsfree key for example), yet within a given system there may be several keys which do have functional common names attached to them (e.g. handsfree key, speed dial, mute ...).    

From the Label Key Package description:
"
This package defines the basic behavior of labeled key user interface elements. Key labels may be used, for example, to provide information to the MGC regarding pre-configured telephone key assignments, allowing telephone moves and changes outside the initial administrative domain without requiring re-configuration of keys.  May also be used to provide static label information on the telephone user interface, identifying key function to the user without the need for manual labeling.  
"

From the Function Key Package description:
"
Function keys may have well known names (keyid) associated with function, for example "hookswitch", "hold", etc.  These well know names identify the purpose of the particular key on the actual device.  Function keys may also be assigned a label identifier by the MGC.  This approach avoids assumptions and/or the requirement for application level knowledge of device-specific configuration of the physical resources to derive intended function of keys.  
"

That help?

-- Peter

-----Original Message-----
From: Dan Elbert [mailto:[email-masked]]
Sent: September 26, 2001 10:29
To: [email-masked]'
Subject: [Megaco] Annex G - Label key question

Hi

Thanks,

Dan Elbert
RADVISION

-----Original Message-----
From: Dan Elbert [mailto:[email-masked]]
Sent: Tuesday, September 25, 2001 3:07 PM
To: [email-masked]'; [email-masked]'
Subject: [Megaco] IP Phone call flow

Hi

Dan Elbert
RADVISION