Subject: [Megaco] maintaining the order of events

From: Troy Cauble <[email-masked]>
Date: Wed, 05 Sep 2001 11:15:04 -0400

IG 6.22 struck the following statement from section 9.1
on the grounds that it was specific to UDP.

	"On a given Termination, there should normally be at
	at most one outstanding Notify command at any time."

But I could find no similar spec in Annex D, "Transport over IP".
I think we need such a requirement, at least in Lockstep mode
(section 7.1.9) if not all modes.

Lockstep mode (7.1.9) and the MGC rules in 10.1 are insufficient
to guarantee that two events from an MG will reach the MGC in
the order they happened.

-troy

_______________________________________________
Megaco mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Thu, 20 Sep 2001 14:05:04 -0400

> to guarantee that two events from an MG will reach the MGC in

Apparently I was insane when I wrote this.
IG 6.22 did not strike this sentence, it modified it.

There is no issue here.
-troy