Subject: [Megaco] Empty signals descriptor necessary?

From: John Stock <[email-masked]>
Date: Thu, 14 Feb 2002 16:01:52 -0800

I see that this was asked some time ago, but couldn't find a reply.  Sorry
for asking again.

When a signal (such as ringing) is given on a termination and KeepActive is
not specified, the signal is supposed to be ceased when an event (e.g.
offhook) is detected on the termination.

However in the call flow examples, an empty signals descriptor is sent for
the purpose of canceling the signal.  Is this necessary?  Here is the
example:

From MGC to MG2:

   MEGACO/1 [123.123.123.4]:55555
   Transaction = 50006 {
      Context = 5000 {
         Modify = A5555 {
            Events = 1235 {al/on},
            Signals { } ; to turn off ringing
         }
      }
   }

Thank you.

John Stock
Systems Engineer
Advanced Fibre Communications
1465 N. McDowell Blvd.
Petaluma, CA 94954
Tel. 707-792-6249

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle"<[email-masked]>
Date: Fri, 15 Feb 2002 03:25:23 -0500

You are correct -- events will halt signals.  However, it doesn't hurt
anything to halt all signals explicitly as well.

Kevin

-----Original Message-----
From: John Stock [mailto:[email-masked]]
Sent: Thursday, February 14, 2002 7:02 PM
To: [email-masked]'
Subject: [Megaco] Empty signals descriptor necessary?

From MGC to MG2:

Thank you.

John Stock
Systems Engineer

---

From: "Kevin Boyle"<[email-masked]>
Date: Fri, 15 Feb 2002 03:25:23 -0500

Kevin

-----Original Message-----
From: John Stock [mailto:[email-masked]]
Sent: Thursday, February 14, 2002 7:02 PM
To: [email-masked]'
Subject: [Megaco] Empty signals descriptor necessary?

From MGC to MG2:

Thank you.

John Stock
Systems Engineer