Subject: [Megaco] Precise definition of MODE=sendonly

From: "Benton, Graham" <[email-masked]>
Date: Wed, 13 Feb 2002 14:24:55 -0500

I'm not certain about the correct interpretation when the MGC sends a
MODE=sendonly for a stream in a termination.
 
Does MODE=sendonly indicate that 
1) a termination should not receive any data 
or 
2) that it may receive data, but not pass the data into the context?
 
The subtlety has come to light when the MG is asked to detect digits when
the MODE=sendonly.  Obviously, if 1) is the correct interpretation, the
termination is not receiving data, it cannot detect digits.
 
There is a statement in Section 7.1.7 that states "Signals and Events are
not affected by Mode".  This seems to imply 2) is correct, but may also
simply mean that the MG should not change the Events and Signals it was
previously told to detect or generate.
 
I've also noted that the example in Appendix A1.1 shows  a MODE=sendrecv
before detecting offhook and collecting digits.  Could this equally have
been MODE=sendonly?
 
Graham Benton
Siemens ICN

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 21 Feb 2002 08:11:56 -0500

2) applies.  That is what we meant when we added that phrase you quote from
7.1.7.  Don't trust the Appendix -- v2 has a number of corrections.

-----Original Message-----
From: Benton, Graham [mailto:[email-masked]]
Sent: Wednesday, February 13, 2002 8:25 PM
To: [email-masked]'
Subject: [Megaco] Precise definition of MODE=sendonly

 

 
Graham Benton
Siemens ICN

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 21 Feb 2002 08:11:56 -0500

-----Original Message-----
From: Benton, Graham [mailto:[email-masked]]
Sent: Wednesday, February 13, 2002 8:25 PM
To: [email-masked]'
Subject: [Megaco] Precise definition of MODE=sendonly

 

 
Graham Benton
Siemens ICN