Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service Graceful ly?

From: "Kevin Boyle"<[email-masked]>
Date: Tue, 26 Feb 2002 23:01:52 -0500

Why wouldn't you send both in the same transaction?  Then you would have
covered both cases.

Kevin

-----Original Message-----
From: Zhang, Yuyong [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 9:27 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]'
Subject: [Megaco] How MGC to Put a Trunk Group out of Service
Gracefully?

Hi Folks,

I have a question about how a MGC to put a Trunk Group out Service
Gracefully.

There are two options I see as the following:

Context = - {
                  ServiceChange = TG1/* {
                        ServiceMethod = Gracefully}
               }

Context = * {
                  ServiceChange = TG1/* {
                        ServiceMethod = Gracefully}
               }  

Since it is the graceful, that means MGC want to put the trunk out of
service as soon as all the contexts are cleared on this Trunk Group.

My question is that some of the CICs in the Trunk gourp has an active
context, some of them doesn't. Therefore the first option above doesn't take
care of those who have active contexts, the second option doesn't take care
of those who doesn't have active context. 

What is the solution here? Oh this kind of graceful blocking a trunk group
is not supported in MEGACO.

Please give your comments.

Regards,

Yuyong

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Usha Iyer" <[email-masked]>
Date: Wed, 27 Feb 2002 09:54:17 +0530

RE: [Megaco] How MGC to Put a Trunk Group out of Service Gracefully?Hi , 
   Pls correct me if i'm wrong , but i was under the impression that ServiceMethod = Graceful was only used in the MG->MGC direction as an indication to the MGC to clear up the contexts within the time specifed. 
     To put  a termination/set of terminations OOS, MGC clears up the contexts first and then sends SC with ServiceMethod Forced  ( so it would be addressing the terminations in null context )

Reg,
usha
  
  ----- Original Message ----- 
  From: Kevin Boyle 
  To: Zhang, Yuyong ; Tom-PT Taylor ; [email-masked]' 
  Sent: Wednesday, February 27, 2002 9:31 AM
  Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service Gracefully?

  Why wouldn't you send both in the same transaction?  Then you would have covered both cases. 

  Kevin 

  -----Original Message----- 
  From: Zhang, Yuyong [mailto:[email-masked]] 
  Sent: Tuesday, February 26, 2002 9:27 PM 
  To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
  Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
  Gracefully? 

  Hi Folks, 

  Context = - { 
                    ServiceChange = TG1/* { 

  Context = * { 
                    ServiceChange = TG1/* { 

  Regards, 

  Yuyong

---

From: "Usha Iyer" <[email-masked]>
Date: Wed, 27 Feb 2002 09:54:17 +0530

Reg,
usha
  
  ----- Original Message ----- 
  From: Kevin Boyle 
  To: Zhang, Yuyong ; Tom-PT Taylor ; [email-masked]' 
  Sent: Wednesday, February 27, 2002 9:31 AM
  Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service Gracefully?

  Kevin 

  -----Original Message----- 
  From: Zhang, Yuyong [mailto:[email-masked]] 
  Sent: Tuesday, February 26, 2002 9:27 PM 
  To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
  Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
  Gracefully? 

  Hi Folks, 

  Context = - { 
                    ServiceChange = TG1/* { 

  Context = * { 
                    ServiceChange = TG1/* { 

  Regards, 

  Yuyong