Subject: RE: [Megaco] Question on defining bitrate of G.723.1

From: Dan Elbert <[email-masked]>
Date: Tue, 19 Feb 2002 16:33:42 +0200

Can you use the ptime (packetization time) attribute in SDP to specify the
bitrate ?

Dan Elbert
RADVISION

-----Original Message-----
From: Manuel Poza [mailto:[email-masked]]
Sent: Tuesday, February 19, 2002 12:31 PM
To: [email-masked]
Subject: [Megaco] Question on defining bitrate of G.723.1

Hi, all!

I have a question regarding to the G.723.1 codec.

In the call example in appendix A.1 in rfc 3015, the RTP profile chosen
for the RTP terminations is the number 4, that corresponds to G.723
(m=audio $ RTP/AVP 4). However, no bitrate is specified for it (5.3 and
6.3 kbps are possible for this codec). What's the reason for this?

    1) There is a default value (6.3 kbps?)
    2) G.723.1 codecs must be able  to decode any of the two modes with
no previous communication
    3) Other

Related to this, should a MG understand the following?
         m=audio $ RTP/AVP 4
         a=fmtp: 4 bitrate=6.3

Best regards and thank you in advance,

Manuel Poza

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Manuel Poza <[email-masked]>
Date: Tue, 19 Feb 2002 16:44:38 +0100

Hi, Dan, thank you for your answer,

No, I'm afraid that you can't. For a given packetization time, each mode
produces packets of different size, but the same packetization time can be
used for both bitrates.

Best regards,

Manuel Poza

---

From: Manuel Poza <[email-masked]>
Date: Tue, 19 Feb 2002 16:44:38 +0100

Best regards,

Manuel Poza