Subject: RE: [Megaco] Ringback application at terminating end

From: "Tom-PT Taylor"<[email-masked]>
Date: Sun, 24 Feb 2002 18:23:57 -0500

A signal can't be directed internally unless this is specifically provided
for in the package definition.  As an example, the Annex K announcements
have a direction parameter.  Tonegen/pt has no direction parameter, meaning
you have to do the ringback as a signal on the ephemeral directed outwards. 

-----Original Message-----
From: John Stock [mailto:[email-masked]]
Sent: Friday, February 15, 2002 8:27 PM
To: [email-masked]'
Subject: [Megaco] Ringback application at terminating end

When applying ringback tone at the terminating end (a sometimes wise and
necessary thing to do per previous conversations), is it best to apply via
signal to the ephemeral termination (externally from the context), or via
signal to the physical termination (internally towards the context)?  Is
either case legal with the protocol?

John Stock
Systems Engineer
Advanced Fibre Communications
1465 N. McDowell Blvd.
Petaluma, CA 94954
Tel. 707-792-6249

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Mon, 25 Feb 2002 10:26:53 -0500

OK.  Signals are applied to Terminations with a default
direction of "outward".

Can packages be supported only on certain Terminations?

Does a box that claims to support "package XYZ tones" 
have to support them on all Termination types?

For example, many residential gateway call flows will
require all of the call progress tones played outward 
on the physical Terminations (with the possible 
exception of ringback).  The ephemeral Terminations 
won't be required to play any call progress tones.

Does claiming to support those tones require supporting
them on ephemeral connections too?

-troy

> Tom-PT Taylor wrote:
> for in the package definition.  As an example, the Annex K announcements have
> a direction parameter.  Tonegen/pt has no direction parameter, meaning you
> have to do the ringback as a signal on the ephemeral directed outwards.
>

---

From: Troy Cauble <[email-masked]>
Date: Mon, 25 Feb 2002 10:26:53 -0500

-troy