Subject: [Megaco] **IN case of offhook failure

From: "vidya g" <[email-masked]>
Date: 13 Feb 2002 15:29:54 -0000

hi

   In a typical call scenario if an offhook event is detected MGC will command MG to move this context to a newly created context and apply dialtone signal and buffer all digits dialled in the termination. In case if no digits are dialed, timer will expire. In this case what do MG do.. ? MG cannot move this NULL context unless MGC ask it to do so ..  how do this case is handled .. ? I couldn't find any error code which can be used for notifying MGC about digit absence.. !! similarly if short timer expires no mechanism to intimate MGC about the expiry of timer .. !!

can any one help me resolving this
reg
vdy 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle"<[email-masked]>
Date: Thu, 14 Feb 2002 03:44:56 -0500

Actually, behavior when the start timer fires is region-dependant.  Please
remember that reorder is a North American concept.  There are many folks
here from countries other than the US and Canada, for whom giving these kind
of exact requirements may be confusing.

To determine the proper behavior in the region of the world where the
equipment is to be deployed, check with the local telecommunications
regulatory office.  They can provide details about required behaviors.

Kevin

-----Original Message-----
From: Preeti Sharma [mailto:[email-masked]]
Sent: Wednesday, February 13, 2002 11:12 AM
To: P.S.K. Chakravarthi
Cc: vidya g; [email-masked]
Subject: Re: [Megaco] **IN case of offhook failure

Adding to Chaks answer ,  in either cases the MGC would typically ask the MG
to play
the reorder tone. At this point the user (at the MG ) would hopefully hang
up putting
the terminal back in NULL context.
Preeti.

"P.S.K. Chakravarthi" wrote:

> Is MGC arming the notify on completion event?
> If so,
> MG should send with digit completion method as PM and ds =  " "
> A space between the quotes.
>
> Otherwise
> MG can buffer the timeout event and send it when MGC asks for digits as
> given above.
>
> Thanks
> Chak
>
>   ALCATEL, USA Inc.                      Email:
[email-masked]
>   1000 Coit Road Plano, Texas 75075
>   ******** The opinions expressed are not those of Alcatel USA,
Inc.********
>
> On 13 Feb 2002, vidya  g wrote:
>
> >
> > hi
> >
> >    In a typical call scenario if an offhook event is detected MGC will
command MG to move this context to a newly created context and apply
dialtone signal and buffer all digits dialled in the termination. In case if
no digits are dialed, timer will expire. In this case what do MG do.. ? MG
cannot move this NULL context unless MGC ask it to do so ..  how do this
case is handled .. ? I couldn't find any error code which can be used for
notifying MGC about digit absence.. !! similarly if short timer expires no
mechanism to intimate MGC about the expiry of timer .. !!

---

From: "Kevin Boyle"<[email-masked]>
Date: Thu, 14 Feb 2002 03:44:56 -0500

Kevin

-----Original Message-----
From: Preeti Sharma [mailto:[email-masked]]
Sent: Wednesday, February 13, 2002 11:12 AM
To: P.S.K. Chakravarthi
Cc: vidya g; [email-masked]
Subject: Re: [Megaco] **IN case of offhook failure

Inc.********

---

From: "vidya g" <[email-masked]>
Date: 14 Feb 2002 11:52:37 -0000

Hi 

     I have a doubt about the example call flow given in the annexure of RFC3015. In step 3, when MGC modifies 
the TDM termination along with the Local control properties Local properties specified looks like that of RTP.. ?
Local {
   v=0
   c=IN IP4 $
   m=audio $ RTP/AVP 0
   a=fmtp:PCMU VAD=X-NNVAD ; special voice activity
                           ; detection algorithm
                        }

So is it correct or it is a correction .. ?

vdy

---

From: "vidya g" <[email-masked]>
Date: 14 Feb 2002 11:52:37 -0000

Hi 

vdy

---

From: "Kevin Boyle"<[email-masked]>
Date: Thu, 14 Feb 2002 07:23:11 -0500

The message is in error and has been corrected in v2.  Please note that the
example call flow in Appendix A is informative in nature, and not subject to
corrections via the Implementer's Guide.  The v1 edition of the Appendix has
several errors, but these have been corrected in v2 to be more indicative of
current use of the protocol.

Kevin

-----Original Message-----
From: vidya g [mailto:[email-masked]]
Sent: Thursday, February 14, 2002 6:53 AM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]
Cc: [email-masked]
Subject: re: RE: [Megaco] **IN case of offhook failure

Hi 

     I have a doubt about the example call flow given in the annexure of
RFC3015. In step 3, when MGC modifies 
the TDM termination along with the Local control properties Local properties
specified looks like that of RTP.. ?
Local {
   v=0
   c=IN IP4 $
   m=audio $ RTP/AVP 0
   a=fmtp:PCMU VAD=X-NNVAD ; special voice activity
                           ; detection algorithm
                        }

vdy

---

From: "Kevin Boyle"<[email-masked]>
Date: Thu, 14 Feb 2002 07:23:11 -0500

Kevin

-----Original Message-----
From: vidya g [mailto:[email-masked]]
Sent: Thursday, February 14, 2002 6:53 AM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]
Cc: [email-masked]
Subject: re: RE: [Megaco] **IN case of offhook failure

Hi 

vdy