Subject: RE: [Megaco] Termination Id representation in ASN and ABNF

From: "Tom-PT Taylor"<[email-masked]>
Date: Fri, 1 Feb 2002 09:44:39 -0500

Not sure where you get your 8 character limit from, given the 64 in
pathNAME.  Just to be clear: if an MG supports both binary and text, it is
not necessary for the binary terminationIds to be bit-wise identical with
the text terminationIds.  In general I would assume that you would store a
mapping between them, or I could think of an algorithm where you have
generally numeric terminationIds with a suitable piece of text added in
front.

-----Original Message-----
From: Usha Iyer [mailto:[email-masked]]
Sent: Friday, February 01, 2002 9:37 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; meglist
Subject: Re: [Megaco] Termination Id representation in ASN and ABNF

Hi Tom/All ,
 
        Acc to the definition of termination id in ABNF , i cannot have pure
numerical terminations.  So the termination id gets limited to just 8
characters . 
 ( But why do we have this discrepancy  in  definition between ASN and ABNF
?)
 
TIA,
usha
 
----- Original Message ----- 
From: Tom-PT Taylor 
To: 'Rakesh Nigudkar' ; meglist 
Sent: Friday, February 01, 2002 7:29 PM
Subject: RE: [Megaco] Termination Id representation in ASN and ABNF

It is exactly as you have stated.  Agreed that the potential text name space
is much larger, but I would think 2**64 would be large enough to match any
real MG.

-----Original Message-----
From: Rakesh Nigudkar [mailto:[email-masked]]
Sent: Friday, February 01, 2002 8:46 AM
To: meglist
Subject: [Megaco] Termination Id representation in ASN and ABNF

Hi Tom and list,
 
Termination id is represented in ABNF as
 TerminationID        = "ROOT" / pathNAME / "$" / "*"

where pathNAME  can be of 64 bytes(max)
 
where as in ASN
 
 TerminationID ::= SEQUENCE
{
      wildcard    SEQUENCE OF WildcardField, 
      id          OCTET STRING(SIZE(1..8)),
      ...
}
-- Termination ID 0xFFFFFFFFFFFFFFFF indicates the ROOT Termination.

Does this imply that TerminationID can only be 8 octets(i.e 64 bits or 8
bytes) long in ASN while 64 bytes in ABNF?
If yes, kindly clarify on the same.
 
Regs
Rakesh

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Usha Iyer" <[email-masked]>
Date: Fri, 1 Feb 2002 20:33:36 +0530

Tom,

    The 8 character(assuming a character takes 1 byte in the system) limit comes in for  the ASN representation of TerminationId , unless, as u pointed out , there's a mapping algorithm implemented .

Regards
usha

  -----Original Message-----
  From: Usha Iyer [mailto:[email-masked]]
  Sent: Friday, February 01, 2002 9:37 AM
  To: Taylor, Tom-PT [CAR:B800:EXCH]; meglist
  Subject: Re: [Megaco] Termination Id representation in ASN and ABNF

  Hi Tom/All ,

  TIA,
  usha

  -----Original Message-----
  From: Rakesh Nigudkar [mailto:[email-masked]]
  Sent: Friday, February 01, 2002 8:46 AM
  To: meglist
  Subject: [Megaco] Termination Id representation in ASN and ABNF

  Hi Tom and list,

   
  where as in ASN

   
  Regs
  Rakesh

---

From: "Usha Iyer" <[email-masked]>
Date: Fri, 1 Feb 2002 20:33:36 +0530

Tom,

Regards
usha

  -----Original Message-----
  From: Usha Iyer [mailto:[email-masked]]
  Sent: Friday, February 01, 2002 9:37 AM
  To: Taylor, Tom-PT [CAR:B800:EXCH]; meglist
  Subject: Re: [Megaco] Termination Id representation in ASN and ABNF

  Hi Tom/All ,

  TIA,
  usha

  -----Original Message-----
  From: Rakesh Nigudkar [mailto:[email-masked]]
  Sent: Friday, February 01, 2002 8:46 AM
  To: meglist
  Subject: [Megaco] Termination Id representation in ASN and ABNF

  Hi Tom and list,

   
  where as in ASN

   
  Regs
  Rakesh