Subject: [Megaco] RE: About play ann and MODE

From: "derrick.ding" <[email-masked]>
Date: Thu, 7 Feb 2002 9:49:13 +0800

Hi,Tom-PT Taylor！
   Thanks for your patience very much.
   But I still keep my view point: Mode is used only for outside context connection.
   This is extracted from RFC3015, 7.1.7, the 2nd paragraph:

   "The allowed values for the mode property are send-only, receive-
   only, send/receive, inactive and loop-back.  "Send" and "receive" 
   are with respect to the exterior of the context, so that, for 
   example, a stream set to mode=sendonly does not pass received media 
   into the context. The default value for the mode property is 
   "Inactive".  Signals and Events are not affected by mode. "

So if A, B are in a same context, from the above explanation, Mode has no effect on the media flow between A and B.
Eager for your help!

Thanks and best regards!

2002-02-06 08:23:00 you write：
>I wouldn't argue Megaco interpretation from MGCP: we very much added our own
>semantics.  In particular, we anticipated the specific possibility that you
>might want to play out multiple signals at once (e.g. announcement over busy
>tone), and similarly play out announcements over (gain-reduced) conversation
>in the background.
>
>mode=sendonly prevents media from entering at A.  That means the only media
>that could pass from A to B would be by way of an inward-directed
>announcement.  In the ordinary case, therefore, mode=sendonly at A is enough
>to do the job.
>
>
>
>-----Original Message-----
>From: derrick.ding [mailto:[email-masked]]
>Sent: Wednesday, February 06, 2002 3:19 AM
>To: Taylor, Tom-PT [CAR:B800:EXCH]
>Cc: Megaco; Jackson.liu; mark.tao; newmon wei; coming.ling
>Subject: Re: [Megaco] RE: About play ann
>
>
>Hi,Tom-PT Taylor！
>   Thanks for your help.And I'd like to give another proof here. 
>   Megaco comes from MGCP. In MGCP, signal is also a descriptor of an
>endpoint. Whenever an endpoint is played announce, a signal descriptor is
>needed only and there's no topology concept in MGCP.
>   So "prevent A from sending media to B" is done by MG automatically.
>
>!!!And I have a question about your reply, :-)
>   In my opinion, to give a sendOnly descriptor here cannot prevent A from
>sending media to B. Because Mode is used only for outside context connection
>mode instead of inner context. If you wanna modify the connection mode in a
>context, you should modify topology.
>   
>
>2002-02-05 12:27:00 you write：
>>I wouldn't do either.  I assume they are using topology to prevent A from
>>sending media to B while B is playing out the announcement.  The point is
>>valid, but use of topology is unnecessary.  Instead just make A sendOnly
>>while the announcement is played out.
>>
>>-----Original Message-----
>>From: derrick.ding [mailto:[email-masked]]
>>Sent: Tuesday, February 05, 2002 7:23 AM
>>To: Taylor, Tom-PT [CAR:B800:EXCH]
>>Cc: Megaco
>>Subject: About play ann 
>>
>>
>>Hi,Tom-PT！
>>   I have a question about play announcement on MGC side, need your help so
>>much.
>>
>>   When Termination A is connected with Termination B, like this:
>>MGC:
>>   Transaction = 50001{
>>    Context = 3{
>>        Add = B
>>        Add = A 
>>    }
>>   }
>>
>>   Now play announcement to B, Should MGC play announcement to B dirrectly,
>>or modify topology first, then play announcement to B(the latter is adopted
>>by TS.23205). ABNF is as following:
>>1.one choice:
>>MGC:
>>   Transaction = 50002{
>>    Context = 3{
>>        Modify = B{
>>           signal(an/ann1)
>>         }        
>>    }
>>   } 
>>
>>2. the other choice:
>>MGC:
>>   Transaction = 50002{Topology{
>>                               A,B,Isolate
>>                               }
>>                       Context = 3{
>>                                  }
>>                      }
>>
>>   Transaction = 50003{
>>    Context = 3{
>>        Modify = B{
>>           signal(an/ann1)
>>         }        
>>    }
>>   } 
>>
>>I think both are right. And in my opinion, I prefer the first one because
>of
>>its simplicity.
>>
>>Thanks and Best Regards           
>>
>>            derrick.ding
>>            [email-masked]
>>
>>
>>_______________________________________________
>>Megaco mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/megaco
>
>
>            derrick.ding
>            [email-masked]
>
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco

            derrick.ding
            [email-masked]

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "derrick.ding" <[email-masked]>
Date: Thu, 7 Feb 2002 9:49:13 +0800

Hi,Tom-PT Taylor！

Thanks and best regards!

            derrick.ding
            [email-masked]

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 7 Feb 2002 03:34:36 -0500

I won't carry this discussion much further, since it deals with a very small
point.  I've capitalized the key phrase in your quotation below.  My
argument is that if termination A isn't passing received media into the
context, you've achieved what you need: termination A won't interfere with
termination B.  Kevin Boyle happens to be sitting beside me, and points out
that you may instead be concerned that termination B will interfere with
termination A.  The point to remember here is that signals pass outwards
unless explicitly directed toward the interior (like Annex K announcements).
Hence B doesn't interfere with A either.

-----Original Message-----
From: derrick.ding [mailto:[email-masked]]
Sent: Thursday, February 07, 2002 2:49 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Megaco
Subject: [Megaco] RE: About play ann and MODE

Hi,Tom-PT Taylor£¡
   Thanks for your patience very much.
   But I still keep my view point: Mode is used only for outside context
connection.
   This is extracted from RFC3015, 7.1.7, the 2nd paragraph:

   "The allowed values for the mode property are send-only, receive-
   only, send/receive, inactive and loop-back.  "Send" and "receive" 
   are with respect to the exterior of the context, so that, for 
   example, A STREAM SET TO A=SENDONLY DOES NOT PASS MEDIA INTO THE CONTEXT.
   The default value for the mode property is 
   "Inactive".  Signals and Events are not affected by mode. "

So if A, B are in a same context, from the above explanation, Mode has no
effect on the media flow between A and B.
Eager for your help!

Thanks and best regards!

2002-02-06 08:23:00 you write£º
>Hi,Tom-PT Taylor£¡
>2002-02-05 12:27:00 you write£º
>>Hi,Tom-PT£¡

            derrick.ding
            [email-masked]

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 7 Feb 2002 03:34:36 -0500

-----Original Message-----
From: derrick.ding [mailto:[email-masked]]
Sent: Thursday, February 07, 2002 2:49 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Megaco
Subject: [Megaco] RE: About play ann and MODE

Hi,Tom-PT Taylor£¡

Thanks and best regards!

            derrick.ding
            [email-masked]