Subject: RE: [Megaco] Silence Suppression

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 12 Feb 2002 03:00:12 -0500

You're right: I was careless.  As a matter of fact, silence suppression is
an attribute of the payload type.  draft-ietf-avt-profile-new-xx.txt
indicates that you include payload type-specific parameters in an a=fmtp:
line.  You get such parameters from the payload specification document.  The
MIME type registration document draft-ietf-avt-rtp-mime-xx.txt summarizes
the parameters available for the payloads it registers.  To get silence
suppression for the payload type G729D, for instance, you include the annexb
parameter with a value "yes" (which is actually the default).  Thus Local or
Remote looks like:

Media={Stream=1{ Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 96
a=rtmap:96 G729D
a=fmtp:96 annexb=yes
}}}

-----Original Message-----
From: Shambhu Dayal Rai [mailto:[email-masked]]
Sent: Monday, February 11, 2002 5:22 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: 'Safa Mohammad'; [email-masked]
Subject: Re: [Megaco] Silence Suppression

I guess Safa is asking about Silence suppression not echo cancelation.

I feel silence suppression can be specified in the SDP of Local or Remote
descriptors something like..

Media={Stream=1{ Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 0
a=SilenceSupp:on
}}}

-Shambhu

> Tom-PT Taylor wrote:
> 
> As per Annex E.13, you set the property in the LocalControl descriptor of
the audio stream involved:
> 
>       ...Media={Stream=1{LocalControl={...,tdmc/ec=on,...
> 
> -----Original Message-----
> From: Safa Mohammad [mailto:[email-masked]]
> Sent: Saturday, February 09, 2002 12:28 AM
> To: [email-masked]
> Subject: [Megaco] Silence Suppression
> 
> Hi,
> 
> How to specify SS when using ABNF encoding?
> 
> Thanks,
> 
> Safa
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

-- 
-------------------------------------------------------------------
Shambhu Dayal Rai                              [email-masked] 
Infosys - India SQA Team              91-80-8520362 Ext. : 6561
-------------------------------------------------------------------

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Safa Mohammad <[email-masked]>
Date: Tue, 19 Feb 2002 15:35:39 -0800

draft-ietf-avt-rtp-mime-06.txt does specify attributes to set SS for g729 and
g723.
Where to find the attributes used to set VAD (voice activity detection )
for the other payload types registered in draft-ietf-avt-rtp-mime-06.txt ?

Thanks,

Safa

---

From: Safa Mohammad <[email-masked]>
Date: Tue, 19 Feb 2002 15:35:39 -0800

Thanks,

Safa