Subject: [Megaco] VDY:>> MGC Failure

From: "vidya g" <[email-masked]>
Date: 19 Feb 2002 15:57:04 -0000

hi 
   I have some doubts regading failure of MGC.

oOo  case one:
    Primary MGC failed when MG is in active state ( running state ) then MG detects peer failure and 
try to connect to secondary MGC. But in this case new MGC doesn't know about the call contexts and all
activities happened in MG. In such a case what MG do..? should he cancel all active calls and start from 
scratch or just maintain all the calls and whenever MGC request for audit give the details .. ?

oOo  case two:
     Primary MGC wants MG to connect to a new MGC. In this case we can maintain all calls provided PrimMGC
passes all information related to the MG activities to new MGC and then relinquishes the control ... 
( in that case what would be the protocol between primary MGC and directed MGC .. ? )
If this case works, what do we do with unresponded requests from MG .. do we need to expect the response
for them from new MGC or we need to drop all unresponded requests and send it again .. ?

oOo  case three :

     Primary MGC goes down and secondary also is not reachable, and according to RFC we need to try all
possible listed MGC in a loop and the if we are able to connect to primary again, start conversation .. in 
this case what do we so with the unresponded requests from the MGC before it goes down .. ? 

   What I feel is RFC doesn't talk about the state of the calls and other requests if MGC goes down and 
connect to new MGC ...

oOo
   One more doubt is if a service change message is coming for ROOT termination, can that message contain 
more some other transactions also .. ? or for the transaction which contains service change command for
ROOT termination contain more than one action .. ?

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "P.S.K. Chakravarthi" <[email-masked]>
Date: Tue, 19 Feb 2002 10:57:14 -0600 (CST)

My comments are inline

Thanks
Chak

  ALCATEL, USA Inc.                      Email: [email-masked]
  1000 Coit Road Plano, Texas 75075
  ******** The opinions expressed are not those of Alcatel USA, Inc.********

> scratch or just maintain all the calls and whenever MGC request for audit give the details .. ?
Chak:
In this case MG should not cancel any context. 
MG should even send the pending responses to the New MGC. 
New MGC will accept the pending responses if
transaction level equalization is done between primary and secondary.  If
there is no transaction level equalization, then new MGC rejects the
responses (I mean MGC stack will not pass those responses to MGC
apllication) So MGC application after long timer will send SUBTRACT to
clear the contexts.
So in this there should be any problem for those calls which are not
having any pending responses from MG.

> for them from new MGC or we need to drop all unresponded requests and send it again .. ?
Chak:
If you do not have transaction level equalization between primary and
secondary, you need to either drop the calls for which responses are
pending by sending SUBTRACT or re-transmit the requests from NEW MGC after
receiving SVC from MG.
> this case what do we so with the unresponded requests from the MGC before it goes down .. ? 
Chak: In this case MG should send SVC with disconnected method.  After
receiving SVC MGC should AUDIT all the terminations and initiate necessary
clean-up.

> ROOT termination contain more than one action .. ?
Chak: Protocol does not limit this.  But I could not able to find any
usage for such a transaction.

---

From: "P.S.K. Chakravarthi" <[email-masked]>
Date: Tue, 19 Feb 2002 10:57:14 -0600 (CST)

My comments are inline

Thanks
Chak

Chak:

Chak: