Subject: RE: [Megaco] Termination Id representation in ASN and ABNF

From: "Tom-PT Taylor"<[email-masked]>
Date: Fri, 1 Feb 2002 08:59:54 -0500

It is exactly as you have stated.  Agreed that the potential text name space
is much larger, but I would think 2**64 would be large enough to match any
real MG.

-----Original Message-----
From: Rakesh Nigudkar [mailto:[email-masked]]
Sent: Friday, February 01, 2002 8:46 AM
To: meglist
Subject: [Megaco] Termination Id representation in ASN and ABNF

Hi Tom and list,
 
Termination id is represented in ABNF as
 TerminationID        = "ROOT" / pathNAME / "$" / "*"

where pathNAME  can be of 64 bytes(max)
 
where as in ASN
 
 TerminationID ::= SEQUENCE
{
      wildcard    SEQUENCE OF WildcardField, 
      id          OCTET STRING(SIZE(1..8)),
      ...
}
-- Termination ID 0xFFFFFFFFFFFFFFFF indicates the ROOT Termination.

Does this imply that TerminationID can only be 8 octets(i.e 64 bits or 8
bytes) long in ASN while 64 bytes in ABNF?
If yes, kindly clarify on the same.
 
Regs
Rakesh

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Usha Iyer" <[email-masked]>
Date: Fri, 1 Feb 2002 20:07:07 +0530

Hi Tom/All ,

        Acc to the definition of termination id in ABNF , i cannot have pure numerical terminations.  So the termination id gets limited to just 8 characters . 
 ( But why do we have this discrepancy  in  definition between ASN and ABNF ?)

TIA,
usha

  -----Original Message-----
  From: Rakesh Nigudkar [mailto:[email-masked]]
  Sent: Friday, February 01, 2002 8:46 AM
  To: meglist
  Subject: [Megaco] Termination Id representation in ASN and ABNF

  Hi Tom and list,

   
  where as in ASN

   
  Regs
  Rakesh

---

From: "Usha Iyer" <[email-masked]>
Date: Fri, 1 Feb 2002 20:07:07 +0530

Hi Tom/All ,

TIA,
usha

  -----Original Message-----
  From: Rakesh Nigudkar [mailto:[email-masked]]
  Sent: Friday, February 01, 2002 8:46 AM
  To: meglist
  Subject: [Megaco] Termination Id representation in ASN and ABNF

  Hi Tom and list,

   
  where as in ASN

   
  Regs
  Rakesh

---

From: Troy Cauble <[email-masked]>
Date: Fri, 01 Feb 2002 11:11:45 -0500

The ABNF and ASN.1 TerminationIDs are different namespaces.
How you translate between the two is application specific.

For example, a scheme with only two endpoints might allow
this ABNF
	endpoint/1 or endpoint/2
and this ASN.1
	0x666 or 0x777

What's the relationship?  That's APPLICATION SPECIFIC.
(Not defined by the protocol.)  Make up your own schema.

-troy

> 
> Hi Tom/All ,
>  
>         Acc to the definition of termination id in ABNF , i cannot have pure numerical terminations.  So
> the termination id gets limited to just 8 characters .

---

From: Troy Cauble <[email-masked]>
Date: Fri, 01 Feb 2002 11:11:45 -0500

-troy

---

From: "Ranjith Mukundan" <[email-masked]>
Date: Sun, 03 Feb 2002 20:10:50 +0530

agreed that abnf and asn.1  are both  in different name spaces and that 2^64 # of TID can cater to any MG that
we know of.

All we are trying to do is to get to the bottom of the apparent discrepancy between the two endocing schemes
for the same parm (ie, TID in this case).

thx, ranjith..

---

From: "Ranjith Mukundan" <[email-masked]>
Date: Sun, 03 Feb 2002 20:10:50 +0530

thx, ranjith..