Subject: [Megaco] Silence Suppression

From: Safa Mohammad <[email-masked]>
Date: Fri, 08 Feb 2002 15:27:31 -0800

Hi,

How to specify SS when using ABNF encoding?

Thanks,

Safa

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Sun, 10 Feb 2002 04:27:29 -0500

As per Annex E.13, you set the property in the LocalControl descriptor of
the audio stream involved:

      ...Media={Stream=1{LocalControl={...,tdmc/ec=on,...

-----Original Message-----
From: Safa Mohammad [mailto:[email-masked]]
Sent: Saturday, February 09, 2002 12:28 AM
To: [email-masked]
Subject: [Megaco] Silence Suppression

Hi,

Thanks,

Safa

---

From: Carl Rutter <[email-masked]>
Date: Mon, 11 Feb 2002 08:18:19 -0500

Shambhu,

I'm very inteserted in this option as well.

Is the attribute SilenceSupp defined somewhere
or is this your suggestion?

Carl

-----Original Message-----
From: Shambhu Dayal Rai [mailto:[email-masked]]
Sent: Sunday, February 10, 2002 11:22 PM
To: Tom-PT Taylor
Cc: 'Safa Mohammad'; [email-masked]
Subject: Re: [Megaco] Silence Suppression

I guess Safa is asking about Silence suppression not echo cancelation.

I feel silence suppression can be specified in the SDP of Local or Remote
descriptors something like..

Media={Stream=1{ Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 0
a=SilenceSupp:on
}}}

-Shambhu

> Tom-PT Taylor wrote:

-- 
-------------------------------------------------------------------
Shambhu Dayal Rai                              [email-masked] 
Infosys - India SQA Team              91-80-8520362 Ext. : 6561
-------------------------------------------------------------------

---

From: "Wayne Cutler" <[email-masked]>
Date: Mon, 11 Feb 2002 14:29:43 +0000

Carl/Tom,

I don't think that Silence Suppression is defined in a H248 package and so
SDP would/could be used.

However, I would have thought that Silence Suppression ought to be part of
the TDM Cicruit Package which currently has
Gain and Echo Control as its properties.

A further point is that SDP also permits gain and echo control to be
specified using an "a- parameter" and so there is the nasty case
where a GW could get Gain/Echo Control specified in one or both of the TDM
Circuit Package or SDP block. So :-

1) are GWs supposed to look at the a-parameters just to make sure that
Gain/Echo isn't being asked for in the absence of the TDM Circuit Package,
2) if Gain/Echo are in two places, what happens if they don't align? GW
rejects the command?
3) Is there any work in progress to extend the TDM Circuit Package to sweep
up Silence Suppression.

Regards,
Wayne.

------------
This e-mail and any attachments are confidential.  If you are not the intended recipient, please notify us immediately by reply e-mail and then delete this message from your system. Do not copy this e-mail or any attachments, use the contents for any purpose, or disclose the contents to any other person: to do so could be a breach of confidence.

---

From: "Wayne Cutler" <[email-masked]>
Date: Mon, 11 Feb 2002 14:29:43 +0000

Carl/Tom,

Regards,
Wayne.

------------

---

From: Carl Rutter <[email-masked]>
Date: Mon, 11 Feb 2002 09:56:24 -0500

All great questions,
I agree the TDM Circuit Package would be a good place for it.
I look forward to hearing peoples responses.

Carl

-----Original Message-----
From: Wayne Cutler [mailto:[email-masked]]
Sent: Monday, February 11, 2002 9:30 AM
To: Carl Rutter <crutter; [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Silence Suppression

Carl/Tom,

Regards,
Wayne.

------------
This e-mail and any attachments are confidential.  If you are not the
intended recipient, please notify us immediately by reply e-mail and then
delete this message from your system. Do not copy this e-mail or any
attachments, use the contents for any purpose, or disclose the contents to
any other person: to do so could be a breach of confidence.

---

From: Carl Rutter <[email-masked]>
Date: Mon, 11 Feb 2002 09:56:24 -0500

All great questions,

Carl

-----Original Message-----
From: Wayne Cutler [mailto:[email-masked]]
Sent: Monday, February 11, 2002 9:30 AM
To: Carl Rutter <crutter; [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Silence Suppression

Carl/Tom,

Regards,
Wayne.

------------

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 12 Feb 2002 03:00:12 -0500

You're right: I was careless.  As a matter of fact, silence suppression is
an attribute of the payload type.  draft-ietf-avt-profile-new-xx.txt
indicates that you include payload type-specific parameters in an a=fmtp:
line.  You get such parameters from the payload specification document.  The
MIME type registration document draft-ietf-avt-rtp-mime-xx.txt summarizes
the parameters available for the payloads it registers.  To get silence
suppression for the payload type G729D, for instance, you include the annexb
parameter with a value "yes" (which is actually the default).  Thus Local or
Remote looks like:

Media={Stream=1{ Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 96
a=rtmap:96 G729D
a=fmtp:96 annexb=yes
}}}

-----Original Message-----
From: Shambhu Dayal Rai [mailto:[email-masked]]
Sent: Monday, February 11, 2002 5:22 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: 'Safa Mohammad'; [email-masked]
Subject: Re: [Megaco] Silence Suppression

Media={Stream=1{ Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 0
a=SilenceSupp:on
}}}

-Shambhu