Subject: Re: RE: [Megaco] Is MEGACO compatible with MGCP?

From: "derrick.ding" <[email-masked]>
Date: Thu, 21 Feb 2002 9:54:24 +0800

Hi,Rosen, Brian！
   Actually we have tried to design a MGC to support MGCP and MEGACO in order to access MEGACO MG and MGCP MG. But it does be a hard work. And we nearly give it up now. 
   You are right that it's not hard to build a normal call model(one endpoint to one endpoint), but still need a consideration. Such as how to deal with contextId(megaco) and connectionId(MGCP), it's totally different thing. And Ephermeral Termination in MEGACO is only a descriptor of the PT in MGCP.
   But when MGC process hold&retrieve a call, make a conference call and process handover request, it's so hard to build a general model which can be used for all cases. What we have to do is to enumerate all the possible cases we can imagine and try to induce a model. But how can we enumerate all the cases: such as first hold then make a conference then hold then retrieve then handover, it all depends on the user. :-(
   In fact, I really hope someone will design a general MGC model to handle MGCP and MEGACO.
hehe, :-) 

2002-02-20 15:14:00 you write：
>Depends on which end.  Generally, Megaco is a superset of MGCP.  This isn't
>entirely true,
>but it's pretty close.  If you implement an MG on the MGCP model, the MGC
>could send you
>a Megaco command that has no meaning in your call model.  On the other hand,
>if you
>did this in an MGC, then your MGC probably wouldn't send some kinds of
>Megaco commands,
>but the MG would never notice.
> 
>I think this is pretty uninteresting.  The important part is that if you
>wanted to, you could
>pretty straightforwardly build an MG that spoke MGCP and Megaco which would
>interwork
>with any MGC that spoke one of them.  Similarly you could build an MGC that
>spoke 
>MGCP and Megaco which would interwork with an MG that spoke either.  It's
>not hard
>to do either.  It's not trivial.
> 
>Generally speaking, for many of the kinds of MGs and MGCs people are
>building today,
>the protocols are pretty interchangeable.  I think it's easier to build some
>kinds of devices
>with Megaco than with MGCP, but YMMV.  They are not compatible however - the
>details
>are different.
> 
>Brian
>
>-----Original Message-----
>From: Don Stanwyck [mailto:[email-masked]]
>Sent: Wednesday, February 20, 2002 12:44 PM
>To: [email-masked]
>Subject: RE: [Megaco] Is MEGACO compatible with MGCP?
>
>
>My expectation is that it is reasonable to implement a Megaco call model and
>control it with MGCP at the interface, but it would be more difficult to
>implement an MGCP call model and control it with Megaco at the interface.
> 
>Don Stanwyck
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of Liu,
>Gary
>Sent: Wednesday, February 20, 2002 9:53 AM
>To: 'Kevin Boyle'; [email-masked]
>Subject: RE: [Megaco] Is MEGACO compatible with MGCP?
>
>
>The answer should be possible. We have worked with an MG vendor, which is
>using MEGACO as internal model but externally using MGCP protocol. It is
>totally transparent to the MGC, which is MGCP controller.
>
>-----Original Message-----
>From: Kevin Boyle [mailto:[email-masked]]
>Sent: Wednesday, February 20, 2002 11:29 AM
>To: Carr, Steve; David Suh; [email-masked]
>Subject: RE: [Megaco] Is MEGACO compatible with MGCP?
>
>
>
>The question was whether a Megaco MGC could control a MGCP MG, or vice
>versa.  The answer is no.  If both the MGC and the MG speak the same
>protocol, then interworking between a Megaco termination and an MGCP
>endpoint is only a matter of using SDP to set up bearer and getting the MGCs
>to speak to each other (or to itself, as the case may be).
>
>As for doing both MGCP and Megaco out of the same box, I agree that it is
>possible, but care must be taken when designing the software to handle the
>different connection models at the same time.  The Megaco  connection model
>is far more sophisticated (and complex) than MGCP's, and that would have to
>be taken into consideration.
>
>Kevin 
>
>-----Original Message----- 
>From: Carr, Steve [ mailto:[email-masked]
><mailto:[email-masked]> ] 
>Sent: Tuesday, February 19, 2002 7:09 PM 
>To: Boyle, Kevin [NCRTP:3Z30:EXCH]; David Suh; [email-masked] 
>Subject: RE: [Megaco] Is MEGACO compatible with MGCP? 
>
>
>It should be possible to design an MGC that talks both Megaco and MGCP, and 
>selects one or the other based on provisioning. Then you could enable 
>interworking between the two, an MGCP endpoint calls an Megaco endpoint or 
>vise versa. 
>
>-----Original Message----- 
>From: Kevin Boyle [ mailto:[email-masked]
><mailto:[email-masked]> ] 
>Sent: Tuesday, February 19, 2002 12:41 PM 
>To: David Suh; [email-masked] 
>Subject: RE: [Megaco] Is MEGACO compatible with MGCP? 
>
>
>No.  The H.248 connection model is completely incompatible with the MGCP 
>connection model.  Both the MGC and the MG must be one or the other. 
>
>Kevin 
>
>-----Original Message----- 
>From: David Suh [ mailto:[email-masked] <mailto:[email-masked]> ] 
>Sent: Tuesday, February 19, 2002 12:21 PM 
>To: [email-masked] 
>Subject: [Megaco] Is MEGACO compatible with MGCP? 
>
>
>I know this is a basic question. 
>(Considering MEGACO talks about terminations and contexts and MGCP talks 
>about endpoints and connections.) 
>
>Is an MGCP MGC compatible with a MEGACO MG? 
>Is an MEGACO MGC compatible with a MGCP MG? 
>
>I need an answer to say that I got it from the experts on the MEGACO mailing
>
>list. 
>
>----------------------------------------------------------------------------
>
>--- 
>David W. Suh 
>[email-masked] 
>----------------------------------------------------------------------------
>
>--- 
>
>
>_______________________________________________ 
>Megaco mailing list 
>[email-masked] 
>https://www1.ietf.org/mailman/listinfo/megaco
><https://www1.ietf.org/mailman/listinfo/megaco>  
>
>_______________________________________________ 
>Megaco mailing list 
>[email-masked] 
>https://www1.ietf.org/mailman/listinfo/megaco
><https://www1.ietf.org/mailman/listinfo/megaco>  
>
>
>
>This e-mail and any attachments are confidential. If you are not the
>intended recipient, please notify us immediately by reply e-mail and then
>delete this message from your system. Do not copy this e-mail or any
>attachment, use the contents for any purposes, or disclose the contents to
>any other person: to do so could be a breach of confidence.

            derrick.ding
            [email-masked]

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Matt Holdrege <[email-masked]>
Date: Thu, 21 Feb 2002 02:01:01 -0800

All you need is a well thought out abstraction layer between the protocol 
driver and your internal call control. Then you can throw other protocols 
such as H.323, SIP, etc. on as well.

At 05:54 PM 2/20/2002, derrick.ding wrote:
>Hi,Rosen, Brian£¡
>    Actually we have tried to design a MGC to support MGCP and MEGACO in 
> order to access MEGACO MG and MGCP MG. But it does be a hard work. And we 
> nearly give it up now.
>    You are right that it's not hard to build a normal call model(one 
> endpoint to one endpoint), but still need a consideration. Such as how to 
> deal with contextId(megaco) and connectionId(MGCP), it's totally 
> different thing. And Ephermeral Termination in MEGACO is only a 
> descriptor of the PT in MGCP.
>    But when MGC process hold&retrieve a call, make a conference call and 
> process handover request, it's so hard to build a general model which can 
> be used for all cases. What we have to do is to enumerate all the 
> possible cases we can imagine and try to induce a model. But how can we 
> enumerate all the cases: such as first hold then make a conference then 
> hold then retrieve then handover, it all depends on the user. :-(
>2002-02-20 15:14:00 you write£º

---

From: Matt Holdrege <[email-masked]>
Date: Thu, 21 Feb 2002 02:01:01 -0800