Subject: [Megaco] [Q] Forward Bearer Establishment for AAL2

From: 김현곤 <[email-masked]>
Date: Tue, 5 Feb 2002 15:00:39 +0900

Dear All,

I have a question about the forward bearer establishment using AAL2 signaling.

Suppose that MG1 is the originating MGW and MG2 is the terminating MGW.

the following picture shows the sequence of this scenario.

                  MG1                             MGC                                 MG2
                    |                                    |                                       |
                    |                                    |   --- 1. ADD.req  ---->   |
                    |                                    |    <--- 2. ADD.resp ---   |
                    |  <--- 3. ADD.req ---    |                                       |
                    |   ---- 4. ADD.resp --> |                                       |
                    |   --------------  5. ERQ -------------------> |
                    |   <---------------- 6. ECF -----------------  | 

1. MG sends ADD.req to MG2.
   For example, 
              Add
             Local {
             C= ATM - -
             M = audio $/$/$/$ ...
             }
2. MG2 reply to MGC.
    For example,
             Add Reply
             Local {
             C = ATM NSAP 0123456789...
             M = audio 1/1/2/1 AAL2/ITU 1 AAL2/custom 100 AAL2/ITU 2
             }

     But, the above example is not correct.
     this ADD replay can't have any connection information about AAL2 path (in the example, 1/1/2/1), 
     because the AAL2 Path between MG1 and MG2 shall be assigned by MG1 at step 5.
     This is my question. "What information should be included in this reply?"

I have searched all of materials for this, but all that i found is only about bnc-id..
All materials didn't have any clues about this problem..

If you have encountered this problem and found any solution,
please give me some advices.... 
If possible, let me know the full scenario for forward bearer establishment using AAL2 signaling.

From Korea.

Thanks in advance..

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Fri, 8 Feb 2002 18:22:35 +0530

Hi Tom/ Christian

The MEGACO ATM package draft "draft-rosen-megaco-atm-package-00" has already
expired.

There was a mention of Q.1950.....this recommendation also proposes some ATM
related packages.
Is this list of ATM packages, the only valid list for MEGACO ATM support ?
Are these packages also part of some RFC/ IETF draft ?

Please reply...

Thanks,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

---

From: [email-masked]
Date: Fri, 8 Feb 2002 18:22:35 +0530

Hi Tom/ Christian

Please reply...

Thanks,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Sun, 10 Feb 2002 03:53:09 -0500

There is a fair amount of interest in this topic at the moment.  The
Tappenden draft was introduced at IETF 52.  I am aware of other work in
progress.  It seems like a good time to consolidate this work into something
coherent.

I should mention an architectural subtlety with respect to the Q.1950
packages.  The architecture on which they are premised is described in
Q.1902.1.  It actually has three control levels as opposed to our two:

                         ____________________
                         |                  |
                         |  Call Service    |
                         |    Function      |
                         |                  |
                         --------------------
                                  |
                                  | Call Bearer
                                  | Control (Q.1950)
                                  |
                         _________|__________
                         |                  |
                         |  Bearer Control  |
                         |     Function     |
                         |                  |
                         --------------------
                                  |
                                  | Megaco/H.248
                                  | (Out of scope of BICC)
                                  |
                  ________________|_________________
                  |      _________|__________   MG |
                  |      |                  |      |
                  |      |   Media Control  |      |
                  |      |     Function     |      |
                  |      |                  |      |
                  |      --------------------      |
                  |               |                |
                  |               | Internal       |
                  |               | Interface      |
                  |               |                |
                  |      _________|___________     |
                  |      |                   |     |
                  |      | Media Mapping/    |     |
                  |      | Switching Function|     |
                  |      |                   |     |
                  |      --------------------      |
                  ----------------------------------

The Bearer Control Function is introduced to meet the requirements for ATM
control.  In implementations, it could be co-located either with the Call
Service Function or the Media Gateway Function.

I could see an alternative architecture where the Call Service Function
talks directly to both the Bearer Control Function and the Media Control
Function, but this is the one SG 11 has chosen.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, February 08, 2002 1:53 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] [Q] Forward Bearer Establishment for AAL2

Hi Tom/ Christian

Please reply...

Thanks,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Sun, 10 Feb 2002 03:53:09 -0500

____________________
                         |                  |
                         |  Call Service    |
                         |    Function      |
                         |                  |
                         --------------------
                                  |
                                  | Call Bearer
                                  | Control (Q.1950)
                                  |
                         _________|__________
                         |                  |
                         |  Bearer Control  |
                         |     Function     |
                         |                  |
                         --------------------
                                  |
                                  | Megaco/H.248
                                  | (Out of scope of BICC)
                                  |

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, February 08, 2002 1:53 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] [Q] Forward Bearer Establishment for AAL2

Hi Tom/ Christian

Please reply...

Thanks,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

---

From: [email-masked]
Date: Tue, 12 Feb 2002 18:05:14 +0530

Hi Tom

Thanks for the reply....

I had some further clarifications...would appreciate if you can comment:

1.   Assuming the BCF is NOT part of the MG.
How does BCF detect "Generic Bearer Connection package" events - like BNC change
etc.?
Option 1: BCF has a seperate interface to the underlying MG hardware platform.
Option 2: BCF gets this information through H.248 interface. But, in the absence
of a valid "ATM package" this is not supported for ATM calls.

2.   The Q.1950 procedures are quite similar to H.248/ MEGACO and so is also
mentioned in the document. Is this similarity intented to enable existing MG
applications to easily encapsulate the BCF functionality?
But, then what happens to the MGC(CSF)<-->MG(MGF+BCF) interface ?
In this case would the packages supported on this interface be a super set of
the two sets (H.248 pkgs + Q.1950 pkgs)?
Or is it only the Q.1950 packages?

3.   Assuming BCF is part of the CSF. The H.248 needs to have a comprehensive
set of packages completely mapping the already defined Q.1950 packages.

4.   What does ATM support in a Media Gateway mean in the current scenario?
Does that mean supporting a call purely on the basis of SDP information shared
between MGC and MG. It is the responsibility of the MGC to obtain the events
like BNC change (established, modified) from the BCF functionality independent
of the MG.

Regards,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

"Tom-PT Taylor" <[email-masked]> on 02/10/2002 02:23:09 PM

To:   Kapil Nayar/HSS@HSS
cc:   [email-masked]

Subject:  RE: [Megaco] [Q] Forward Bearer Establishment for AAL2

                         ____________________
                         |                  |
                         |  Call Service    |
                         |    Function      |
                         |                  |
                         --------------------
                                  |
                                  | Call Bearer
                                  | Control (Q.1950)
                                  |
                         _________|__________
                         |                  |
                         |  Bearer Control  |
                         |     Function     |
                         |                  |
                         --------------------
                                  |
                                  | Megaco/H.248
                                  | (Out of scope of BICC)
                                  |

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, February 08, 2002 1:53 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] [Q] Forward Bearer Establishment for AAL2

Hi Tom/ Christian

Please reply...

Thanks,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

---

From: [email-masked]
Date: Tue, 12 Feb 2002 18:05:14 +0530

Hi Tom

Thanks for the reply....

Regards,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

To:   Kapil Nayar/HSS@HSS
cc:   [email-masked]

                         ____________________
                         |                  |
                         |  Call Service    |
                         |    Function      |
                         |                  |
                         --------------------
                                  |
                                  | Call Bearer
                                  | Control (Q.1950)
                                  |
                         _________|__________
                         |                  |
                         |  Bearer Control  |
                         |     Function     |
                         |                  |
                         --------------------
                                  |
                                  | Megaco/H.248
                                  | (Out of scope of BICC)
                                  |

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, February 08, 2002 1:53 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] [Q] Forward Bearer Establishment for AAL2

Hi Tom/ Christian

Please reply...

Thanks,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

---

From: [email-masked]
Date: Wed, 13 Feb 2002 10:54:22 +0530

Hi Vidya

Actually the BCF, CSF, MGF etc. are nothing but short forms for the components
as described in the related figure.
CSF  -    Call Service Function
BCF  -    Bearer Control Function
MCF  -    Media Control Function

These components are part of the Q.1902 definition of a typical BICC network's
Service Node.
Actually, the TIPHON architecture defines 2-levels Media Gateway Controller
(MGC) and Media Gateway (MG), whereas BICC introduces 3-levels CSF, BCF and MGF.

Cheers...
-Kapil

hi Kapil

     I am new to Megaco and am trying to study the MG system. I am
not getting some of the jargons like BCF, CSF, MGF and things like that .. can
you tell me some reference material where I will get such basic things ..

regs
vdy

To:   Kapil Nayar/HSS@HSS
cc:   [email-masked]

                         ____________________
                         |                  |
                         |  Call Service    |
                         |    Function      |
                         |                  |
                         --------------------
                                  |
                                  | Call Bearer
                                  | Control (Q.1950)
                                  |
                         _________|__________
                         |                  |
                         |  Bearer Control  |
                         |     Function     |
                         |                  |
                         --------------------
                                  |
                                  | Megaco/H.248
                                  | (Out of scope of BICC)
                                  |

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, February 08, 2002 1:53 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] [Q] Forward Bearer Establishment for AAL2

Hi Tom/ Christian

Please reply...

Thanks,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

---

From: [email-masked]
Date: Wed, 13 Feb 2002 10:54:22 +0530

Hi Vidya

Cheers...
-Kapil

hi Kapil

regs
vdy

To:   Kapil Nayar/HSS@HSS
cc:   [email-masked]

                         ____________________
                         |                  |
                         |  Call Service    |
                         |    Function      |
                         |                  |
                         --------------------
                                  |
                                  | Call Bearer
                                  | Control (Q.1950)
                                  |
                         _________|__________
                         |                  |
                         |  Bearer Control  |
                         |     Function     |
                         |                  |
                         --------------------
                                  |
                                  | Megaco/H.248
                                  | (Out of scope of BICC)
                                  |

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, February 08, 2002 1:53 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] [Q] Forward Bearer Establishment for AAL2

Hi Tom/ Christian

Please reply...

Thanks,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Sat, 16 Feb 2002 06:48:55 -0500

I'm still learning about this stuff.  It will take a week or two before I've
worked through the call flows that would let me answer your questions.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, February 12, 2002 1:35 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] [Q] Forward Bearer Establishment for AAL2

Hi Tom

Thanks for the reply....

1.   Assuming the BCF is NOT part of the MG.
How does BCF detect "Generic Bearer Connection package" events - like BNC
change
etc.?
Option 1: BCF has a seperate interface to the underlying MG hardware
platform.
Option 2: BCF gets this information through H.248 interface. But, in the
absence
of a valid "ATM package" this is not supported for ATM calls.

In this case would the packages supported on this interface be a super set
of

3.   Assuming BCF is part of the CSF. The H.248 needs to have a
comprehensive
set of packages completely mapping the already defined Q.1950 packages.

4.   What does ATM support in a Media Gateway mean in the current scenario?
Does that mean supporting a call purely on the basis of SDP information
shared
between MGC and MG. It is the responsibility of the MGC to obtain the events
like BNC change (established, modified) from the BCF functionality
independent
of the MG.

Regards,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

To:   Kapil Nayar/HSS@HSS
cc:   [email-masked]

                         ____________________
                         |                  |
                         |  Call Service    |
                         |    Function      |
                         |                  |
                         --------------------
                                  |
                                  | Call Bearer
                                  | Control (Q.1950)
                                  |
                         _________|__________
                         |                  |
                         |  Bearer Control  |
                         |     Function     |
                         |                  |
                         --------------------
                                  |
                                  | Megaco/H.248
                                  | (Out of scope of BICC)
                                  |

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, February 08, 2002 1:53 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] [Q] Forward Bearer Establishment for AAL2

Hi Tom/ Christian

Please reply...

Thanks,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Sat, 16 Feb 2002 06:48:55 -0500

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, February 12, 2002 1:35 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] [Q] Forward Bearer Establishment for AAL2

Hi Tom

Thanks for the reply....

Regards,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com

To:   Kapil Nayar/HSS@HSS
cc:   [email-masked]

                         ____________________
                         |                  |
                         |  Call Service    |
                         |    Function      |
                         |                  |
                         --------------------
                                  |
                                  | Call Bearer
                                  | Control (Q.1950)
                                  |
                         _________|__________
                         |                  |
                         |  Bearer Control  |
                         |     Function     |
                         |                  |
                         --------------------
                                  |
                                  | Megaco/H.248
                                  | (Out of scope of BICC)
                                  |

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, February 08, 2002 1:53 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] [Q] Forward Bearer Establishment for AAL2

Hi Tom/ Christian

Please reply...

Thanks,
-Kapil Nayar
Hughes Software Systems
www.hssworld.com