Subject: RE: RE: [Megaco] RE: Local control descriptor: mode

From: "Tom-PT Taylor"<[email-masked]>
Date: Mon, 25 Feb 2002 15:16:22 -0500

I would hope someone else would have an opinion on this topic.  It's a
little hard to call a consensus if only a couple of people are involved in
the discussion.

-----Original Message-----
From: Sean Leahy [mailto:[email-masked]]
Sent: Monday, February 25, 2002 4:18 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: 'derrick.ding'; Megaco
Subject: RE: RE: [Megaco] RE: Local control descriptor: mode

Tom,
     The point about an incomplete remote descriptor seems only tenuously
related to the original question about the local control descriptor mode
==sendrecv && no remote descriptor present.

     The decision about when to send the required mode and remote
descriptor attributes is surely a controller issue whereas a decision about
the validity of a received remote descriptor is an issue for the MG -
however the preceding question is resolved.

Regards,
Sean Leahy

"Tom-PT Taylor"<[email-masked]>@ietf.org on 25/02/2002 02:27:06

Sent by:  [email-masked]

To:   "'derrick.ding'" <[email-masked]>
cc:   Megaco <[email-masked]>

Subject:  RE: RE: [Megaco] RE: Local control descriptor: mode

I think this is an invitation to undetected call failures.  Suppose part of
the Remote Descriptor is specified, but not enough to start sending
packets.
So the MG does not send packets, and the user experiences "can hear, can't
be heard".  At least if the MG flags an error condition, there should be a
log somewhere so the condition can be debugged.

-----Original Message-----
From: derrick.ding [mailto:[email-masked]]
Sent: Sunday, February 24, 2002 8:59 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Megaco
Subject: Re: RE: [Megaco] RE: Local control descriptor: mode

Hi,Tom-PT Taylor£¡
      I don't think it's hard for MG to make a decision.
      Mode and remote descriptor are two key parameters for MG to connect
remote termination. So MG will judge (mode ==sendrecv && remotedescriptor
present) every time before remote connection.
      And as sean leahy said,  the GW stores attributes provided by the MGC
and acts when the combination of attributes determine it do so.

2002-02-24 18:17:00 you write£º
>I certainly don't feel on firm ground arguing one side or the other on
this
>point.  The asymmetry in call flow that you point out is a fact, but it is
>easy enough to modify the mode from receiveOnly to sendReceive when you
come
>back to add that Remote Descriptor.  What tips the balance in my mind is
the
>fact that at some point the MG has to decide whether or not it should be
>transmitting packets, and it's harder to do if mode is not the parameter
>controlling the decision.
>
>
>-----Original Message-----
>From: Sean Leahy [mailto:[email-masked]]
>Sent: Thursday, February 14, 2002 9:42 AM
>To: Taylor, Tom-PT [CAR:B800:EXCH]; derrick.ding; Wayne Cutler
>Cc: Megaco
>Subject: Re: [Megaco] RE: Local control descriptor: mode
>
>
>Re:  "it's confusing/invalid for the GW to be told "sendrecv" without a
>corresponding Remote Descriptor":
>
>Alternatively: it should not be confusing given the view that the GW
stores
>attributes provided by the MGC and acts when the combination of attributes
>determine it do so. I am sure there are other cases where attibutes
>provided to the MG are not relevent immediately or in all intermediate
>states (e.g. The Echo Cancellation property in the TDM Circuit package may
>be set but at present there may be a simplex (or even loopback)
connection.
>We would expect the MG to retain the information but only act on it when
it
>becomes appropriate).
>
>We  posit a design that ADDs an ephemeral at one end of a connection
>without a remote descriptor and then provides the remote descriptor via a
>MODIFY. The MGC does not expect an Error 411 to this ADD request simply
>because the mode in the Local Control descriptor is set to SendRecv but
>there is no remote descriptor !
>
>There is an inherent requirement to support an ADD with the remote
>descriptor/capabilities not immediately known at one end of a connection:
>
>-    When an MGC allows the MG to choose the connection address for the
>ephemeral, it cannot know the full connection details that need to be
>provided to the other end until after the first ADD is successfully
>performed. Therefore, whichever end receives the first ADD request can
>never have a Remote Descriptor.
>
>-    In contrast, the second ADD is provided with the Remote Descriptor as
>it is available once the connection details have been determined by the MG
>in response to the first ADD request.
>
>-    i.e. There is an inherent protocol asymmetry in the two ADD cases
>(first and second) that we expect the MG to be capable of understanding.
>
>Note also : Appendix A of RFC 3015 has an example (at 'A.1.1 Programming
>Residential GW Analog Line Terminations for Idle Behaviour') where the MGC
>programs a Termination in the NULL context. The MGC provides a Local
>Control descriptor mode of SendReceive with Echo Cancellation
>characteristics, a Local descriptor but no Remote Descriptor.
>
>Sean Leahy
>
>
>
>"Wayne Cutler" <[email-masked]>@ietf.org on 06/02/2002 09:02:25
>
>Sent by:  [email-masked]
>
>
>To:   [email-masked]
>cc:   Megaco <[email-masked]>
>
>Subject:  Re: [Megaco] RE: Local control descriptor: mode
>
>>In my opinion, Error 441 Missing Remote or Local Descriptor applies here.
>>Unfortunately I can't find the text to support that opinion.  I therefore
>>have to put the question to the list: what do other people think?
>
>I would agree with you. In the original example, it's confusing/invalid
for
>the  GW to be told "sendrecv" without a
> corresponding Remote Descriptor.
>
>Wayne.
>
>
>
>------------
>This e-mail and any attachments are confidential.  If you are not the
>intended recipient, please notify us immediately by reply e-mail and then
>delete this message from your system. Do not copy this e-mail or any
>attachments, use the contents for any purpose, or disclose the contents to
>any other person: to do so could be a breach of confidence.
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco
>
>
>
>"Tom-PT Taylor"<[email-masked]>@ietf.org on 05/02/2002 17:16:51
>
>Sent by:  [email-masked]
>
>
>To:   "derrick.ding" <[email-masked]>
>cc:   Megaco <[email-masked]>
>
>Subject:  [Megaco] RE: Local control descriptor: mode
>
>
>
>In my opinion, Error 441 Missing Remote or Local Descriptor applies here.
>Unfortunately I can't find the text to support that opinion.  I therefore
>have to put the question to the list: what do other people think?
>
>
>-----Original Message-----
>From: derrick.ding [mailto:[email-masked]]
>Sent: Tuesday, February 05, 2002 1:00 AM
>To: Taylor, Tom-PT [CAR:B800:EXCH]
>Cc: Megaco
>Subject: Local control descriptor: mode
>
>
>Hi,Tom-PT£¡
>     A question about Local control descriptor: mode
>
>     When MGC apply for RTP resource to MG without the remote RTP SDP, and
>MGC set the Local control descriptor of Ephermeral termination as
>SendRecv(not RecvOnly). As following shows:
>    Transaction = 100003{
>      Context = 3 {
>         Add = $ {
>              Media {
>                Stream = 1 {
>                   LocalControl {
>                        Mode = SendRecv
>                         }
>                   Local {
>             v=0
>             c=IN IP4 $
>             m=audio $ RTP/AVP 4
>             a=ptime:30
>                         }
>                        }
>                    }
>                  }
>        }
>     }
>
>What is suggested that MG should do? There are several choice on MG side:
>1. since there's no remote port to connect, MG reply Add Error to MGC.
>
>2. since there's no remote port to connect, MG ignore it, send reply with
>Local SDP to MGC, and keep the mode.
>   When modify command with Remote RTP SDP comes, MG will connect the
local
>port with remote port. This time mode is not mandatory.
>Like this:
>      Transaction = 100004{
>      Context = 3 {
>        modify = A4445 {
>              Media {
>                Stream = 1 {
>                   Remote {
>             v=0
>             c=IN IP4 125.125.125.111
>             m=audio 1111 RTP/AVP 4
>                         }
>                        }
>                    }
>                  }
>        }
>     }
>
>Now what's the correct operation on MG side?
>
>Thanks and Best Regards
>
>            derrick.ding
>            [email-masked]
>
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco
>
>
>
>
>
>------------
>This e-mail and any attachments are confidential.  If you are not the
>intended recipient, please notify us immediately by reply e-mail and then
>delete this message from your system. Do not copy this e-mail or any
>attachments, use the contents for any purpose, or disclose the contents to
>any other person: to do so could be a breach of confidence.

            derrick.ding
            [email-masked]

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Mon, 25 Feb 2002 15:44:18 -0500

I've spoken out before against "incomplete descriptors".
I think they're a PITA with no advantages.

On the other hand, the concept seems well established
in H.248 Descriptors.  (I believe Tom was one of the 
people who pushing "empty vessel programming" in response 
to my complaints about an MG having to DEDUCE what kind 
of Termination the MGC is hinting at.)  So an exception
for the 'mode' would make things less consistent.

The choices are rigged.  There aren't any good ones, IMO.

-troy

---

From: Troy Cauble <[email-masked]>
Date: Mon, 25 Feb 2002 15:44:18 -0500

-troy

---

From: Christian Groves <[email-masked]>
Date: Tue, 26 Feb 2002 13:59:13 +1100

G'Day Tom,

I don't see that setting Mode = send/rec whilst not having a remote
descriptor is a big problem. I like the idea that the MG will start
sending media when it has enough information in the remote descriptor.
If your MG can't support this behaviour then it can always send the
error code.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Tue, 26 Feb 2002 13:59:13 +1100

G'Day Tom,

Regards, Christian