Subject: [Megaco] **IN case of offhook failure

From: "vidya g" <[email-masked]>
Date: 13 Feb 2002 15:29:54 -0000

hi

   In a typical call scenario if an offhook event is detected MGC will command MG to move this context to a newly created context and apply dialtone signal and buffer all digits dialled in the termination. In case if no digits are dialed, timer will expire. In this case what do MG do.. ? MG cannot move this NULL context unless MGC ask it to do so ..  how do this case is handled .. ? I couldn't find any error code which can be used for notifying MGC about digit absence.. !! similarly if short timer expires no mechanism to intimate MGC about the expiry of timer .. !!

can any one help me resolving this
reg
vdy 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "P.S.K. Chakravarthi" <[email-masked]>
Date: Wed, 13 Feb 2002 09:54:21 -0600 (CST)

Is MGC arming the notify on completion event?
If so,
MG should send with digit completion method as PM and ds =  " "
A space between the quotes.

Otherwise
MG can buffer the timeout event and send it when MGC asks for digits as
given above.

Thanks
Chak

  ALCATEL, USA Inc.                      Email: [email-masked]
  1000 Coit Road Plano, Texas 75075
  ******** The opinions expressed are not those of Alcatel USA, Inc.********

---

From: "P.S.K. Chakravarthi" <[email-masked]>
Date: Wed, 13 Feb 2002 09:54:21 -0600 (CST)

Otherwise

Thanks
Chak

---

From: Preeti Sharma <[email-masked]>
Date: Wed, 13 Feb 2002 11:12:26 -0500

Adding to Chaks answer ,  in either cases the MGC would typically ask the MG to play
the reorder tone. At this point the user (at the MG ) would hopefully hang up putting
the terminal back in NULL context.
Preeti.

---

From: Preeti Sharma <[email-masked]>
Date: Wed, 13 Feb 2002 11:12:26 -0500