Subject: RE: [Megaco] Re: notify and service change

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 6 Feb 2002 08:15:10 -0500

The H.245 signalling is carried as event notifications and signals within
Megaco/H.248 messages.

-----Original Message-----
From: YH [mailto:[email-masked]]
Sent: Wednesday, February 06, 2002 5:16 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: Re: [Megaco] Re: notify and service change

Sorry for not clear here. I referred to the desciption in H.248 Annex M4,
are
those H.245 messages carried by Megaco/H.248 or in a saparated path (by
Sigtran
(STCP))?

 H.324 Terminal
MG                                          MGC/SGC
      ----
-----------------------                         ------
      |    |<-- H.223/H245 -->| M | LC0|-----------|<--H.245 sig -->|  *   |
      |    |                                | U |                          |
Megaco            ------
      ----                               |  X|                          |
or
Sigtran??
                                           ----------------------

Tom-PT Taylor wrote:

> I'm a little confused about the combination of "H.248 Terminal" and "MG".
> I'm assuming you mean an ISDN terminal terminating on an MG, so the
complete
> diagram looks like this:
>
> Terminal                      MG                         MGC
>                                         /---->
>                         _____________  /Packetized  ______
>     ____ B-channel data |           | /   Media     |
>     |   |    (speech)   |           |/              |
>     |   |<--------------|...........|               |
>     |   |               |           |               |
>     |   |D-channel data |           |               |
>     |   | (Q.931 sig)   |           |Q.931/IUA/SCTP |
>     |   |<--------------|...........|-------------->|
>     |   |               |           |               |
>     -----               |           |               |
>                         |           | H.248 control |
>                         |           |<------------->|
>                         |           |               |
>                         -------------               -------
>
> Note that the changing of Q.931 transport from Q.921 to IUA/SCTP is not
part
> of the MG function -- it is a Signalling Gateway (SG) function instead.
> Obviously, however, both those functions are performed by the same device.
>
>
> -----Original Message-----
> From: YH [mailto:[email-masked]]
> Sent: Tuesday, February 05, 2002 1:22 AM
> To: Taylor, Tom-PT [CAR:B800:EXCH]
> Cc: [email-masked]
> Subject: Re: [Megaco] Re: notify and service change
>
> Thanks Tom. My major concern is the signaling flow between an H.248
terminal
> and
> the MG & MGC. So, I interpret your message is yes, that the Megaco is
> capable to
> carry relayed signaling originated from the H.248 terminal. Please correct
> me if
> I misunderstand your message.
>
> Thank you.
>
> Yude
>
> Tom-PT Taylor wrote:
>
> > There are two typoes of signalling involved here.  It makes sense for
the
> MG
> > to relay the H.245 signalling at the H.248 level, but PRI or other call
> > signalling should use a Sigtran interface.
> >
> > -----Original Message-----
> > From: YH [mailto:[email-masked]]
> > Sent: Monday, February 04, 2002 1:36 AM
> > To: [email-masked]
> > Subject: Re: [Megaco] Re: notify and service change
> >
> > Thanks Tom, it's been great helps.
> >
> > Is it legal for an MG issues a notify or serviceChange first before a
> > termination is added by an add command from the MGC?
> >
> > I am thinking about a scenario where an  h324 mux may only be physically
> > located in the MG,  no mux facility in the MGC. Then, the MG has to
relay
> > the
> > signaling into the MGC (if it is also a signaling MG) before the
signaling
> > can
> > be processed. It'll be nice to see that the Megaco has such
capabilities,
> > then
> > there is only one Megaco interface needed, no other signaling paths
> > required.
> >
> > Thank you.
> >
> > _________________________________________________________
> > Do You Yahoo!?
> > Get your free @yahoo.com address at http://mail.yahoo.com
> >
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/megaco
>
> _________________________________________________________
> Do You Yahoo!?
> Get your free @yahoo.com address at http://mail.yahoo.com
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: YH <[email-masked]>
Date: Thu, 07 Feb 2002 10:29:58 +1100

Thanks Tom for your patient and explanations, it is indeed appreciated.

Yude

---

From: YH <[email-masked]>
Date: Thu, 07 Feb 2002 10:29:58 +1100

Yude