Subject: [Megaco] Question on defining bitrate of G.723.1

From: Manuel Poza <[email-masked]>
Date: Tue, 19 Feb 2002 11:31:21 +0100

Hi, all!

I have a question regarding to the G.723.1 codec.

In the call example in appendix A.1 in rfc 3015, the RTP profile chosen
for the RTP terminations is the number 4, that corresponds to G.723
(m=audio $ RTP/AVP 4). However, no bitrate is specified for it (5.3 and
6.3 kbps are possible for this codec). What's the reason for this?

    1) There is a default value (6.3 kbps?)
    2) G.723.1 codecs must be able  to decode any of the two modes with
no previous communication
    3) Other

Related to this, should a MG understand the following?
         m=audio $ RTP/AVP 4
         a=fmtp: 4 bitrate=6.3

Best regards and thank you in advance,

Manuel Poza

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Paul Long" <[email-masked]>
Date: Tue, 19 Feb 2002 12:53:07 -0600

Manuel,

I don't know what the answer is regarding Megaco; however, if an H.323 EP
supports G.723.1, it is required to be able to receive and transmit both bit
rates--the rate is always signaled inband on a per-frame basis
(http://packetizer.com/g723impl.html).

This I-D presents the example in your email, but I don't know what force it
has on Megaco, being just an I-D and all:
http://search.ietf.org/internet-drafts/draft-ietf-avt-rtp-mime-06.txt

According to the maxim, "be liberal in what you receive," it would be
prudent to handle either rate in the same stream.

Paul Long
ipDialog, Inc.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Manuel Poza
> Sent: Tuesday, February 19, 2002 4:31 AM
> To: [email-masked]
> Subject: [Megaco] Question on defining bitrate of G.723.1
>
>
> Hi, all!
>

---

From: "Paul Long" <[email-masked]>
Date: Tue, 19 Feb 2002 12:53:07 -0600

Manuel,

Paul Long
ipDialog, Inc.

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Wed, 20 Feb 2002 18:04:38 +0100

Hi all,

Looking at the draft of the NAS pkg I dont understand  why
it says that the user requests outgoing service is outside
the scope of the document (See 8.5 procedures).

Initially when the user calls a ISP (Internet Service Provider)
the MG does not know that it is a data call.

The MGC must tell the MG that it is a data call and
inform of  the IP of the BroadBand Access server of that ISP.
(I guess this is the third case of an outgoing NAS Call).
Then the MG will act accordingly and ( e.g. the modem may need a special
configuration ) pass the PPP packets
of the user to the broadband access server for the authentication
of the user (transparently to the MG). Then all data packets will
be sent to the Broadband server (which will send them to the ISP).

The MG usually does not know of ISP numbers or broadband access
server. It is the MGC which has all the information. In the worst case
the MGC will enroute the traffic as a normal call.

I think this is a common scenario...
Am I missing something ?

Thanks
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Wed, 20 Feb 2002 18:04:38 +0100

Hi all,

Thanks
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL