Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service Graceful ly?

From: "Kevin Boyle"<[email-masked]>
Date: Tue, 26 Feb 2002 23:01:52 -0500

Why wouldn't you send both in the same transaction?  Then you would have
covered both cases.

Kevin

-----Original Message-----
From: Zhang, Yuyong [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 9:27 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]'
Subject: [Megaco] How MGC to Put a Trunk Group out of Service
Gracefully?

Hi Folks,

I have a question about how a MGC to put a Trunk Group out Service
Gracefully.

There are two options I see as the following:

Context = - {
                  ServiceChange = TG1/* {
                        ServiceMethod = Gracefully}
               }

Context = * {
                  ServiceChange = TG1/* {
                        ServiceMethod = Gracefully}
               }  

Since it is the graceful, that means MGC want to put the trunk out of
service as soon as all the contexts are cleared on this Trunk Group.

My question is that some of the CICs in the Trunk gourp has an active
context, some of them doesn't. Therefore the first option above doesn't take
care of those who have active contexts, the second option doesn't take care
of those who doesn't have active context. 

What is the solution here? Oh this kind of graceful blocking a trunk group
is not supported in MEGACO.

Please give your comments.

Regards,

Yuyong

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle"<[email-masked]>
Date: Tue, 26 Feb 2002 23:47:38 -0500

There is no restriction in the spec on the direction Graceful may be sent.

Kevin

-----Original Message-----
From: Usha Iyer [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 11:24 PM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]; Zhang Yuyong; Taylor, Tom-PT
[CAR:B800:EXCH]; [email-masked]
Subject: Re: [Megaco] How MGC to Put a Trunk Group out of Service
Gracefully?

Hi , 
   Pls correct me if i'm wrong , but i was under the impression that
ServiceMethod = Graceful was only used in the MG->MGC direction as an
indication to the MGC to clear up the contexts within the time specifed. 
     To put  a termination/set of terminations OOS, MGC clears up the
contexts first and then sends SC with ServiceMethod Forced  ( so it would be
addressing the terminations in null context )

Reg,
usha
  
----- Original Message ----- 
From: Kevin Boyle 
To: Zhang, Yuyong ; Tom-PT Taylor ; [email-masked]' 
Sent: Wednesday, February 27, 2002 9:31 AM
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service
Gracefully?

-----Original Message----- 
From: Zhang, Yuyong [mailto:[email-masked]] 
Sent: Tuesday, February 26, 2002 9:27 PM 
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
Gracefully? 

Hi Folks,

---

From: "Kevin Boyle"<[email-masked]>
Date: Tue, 26 Feb 2002 23:47:38 -0500

Kevin

-----Original Message-----
From: Usha Iyer [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 11:24 PM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]; Zhang Yuyong; Taylor, Tom-PT

Hi , 

Reg,
usha
  
----- Original Message ----- 
From: Kevin Boyle 
To: Zhang, Yuyong ; Tom-PT Taylor ; [email-masked]' 
Sent: Wednesday, February 27, 2002 9:31 AM
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service
Gracefully?

-----Original Message----- 
From: Zhang, Yuyong [mailto:[email-masked]] 
Sent: Tuesday, February 26, 2002 9:27 PM 
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
Gracefully? 

Hi Folks,

---

From: Raphael Tryster <[email-masked]>
Date: Wed, 27 Feb 2002 07:44:06 +0200

Kevin,

I take it that, regarding this point, you disagree with
draft-hss-megaco-control-association-state-machine-00.txt, which allows
Graceful to be sent only by the MG.  You wrote a couple of weeks ago that a
study group would be put together for these issues.  What is the status?

Raphael Tryster

	-----Original Message-----
	From:	Kevin Boyle [SMTP:[email-masked]]
	Sent:	Wednesday, 27 February, 2002 6:48 AM
	To:	Usha Iyer; Zhang Yuyong; Tom-PT Taylor; [email-masked]
	Subject:	RE: [Megaco] How MGC to Put a Trunk Group out of
Service Graceful ly?

	There is no restriction in the spec on the direction Graceful may be
sent.

	Kevin

	-----Original Message-----
	From: Usha Iyer [mailto:[email-masked]]
	Sent: Tuesday, February 26, 2002 11:24 PM
	To: Boyle, Kevin [NCRTP:3Z30:EXCH]; Zhang Yuyong; Taylor, Tom-PT
	[CAR:B800:EXCH]; [email-masked]
	Subject: Re: [Megaco] How MGC to Put a Trunk Group out of Service
	Gracefully?

	Hi , 
	   Pls correct me if i'm wrong , but i was under the impression that
	ServiceMethod = Graceful was only used in the MG->MGC direction as
an
	indication to the MGC to clear up the contexts within the time
specifed. 
	     To put  a termination/set of terminations OOS, MGC clears up
the
	contexts first and then sends SC with ServiceMethod Forced  ( so it
would be
	addressing the terminations in null context )

	Reg,
	usha
	  
	----- Original Message ----- 
	From: Kevin Boyle 
	To: Zhang, Yuyong ; Tom-PT Taylor ; [email-masked]' 
	Sent: Wednesday, February 27, 2002 9:31 AM
	Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service
	Gracefully?

	Why wouldn't you send both in the same transaction?  Then you would
have
	covered both cases. 
	Kevin 
	-----Original Message----- 
	From: Zhang, Yuyong [mailto:[email-masked]] 
	Sent: Tuesday, February 26, 2002 9:27 PM 
	To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
	Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
	Gracefully? 

	Hi Folks, 
	Since it is the graceful, that means MGC want to put the trunk out
of 

	My question is that some of the CICs in the Trunk gourp has an
active 
	context, some of them doesn't. Therefore the first option above
doesn't take

	care of those who have active contexts, the second option doesn't
take care 
	of those who doesn't have active context. 
	What is the solution here? Oh this kind of graceful blocking a trunk
group 
	is not supported in MEGACO. 
	Please give your comments. 
	Regards, 
	Yuyong 
	_______________________________________________ 
	Megaco mailing list 
	[email-masked] 
	https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Wed, 27 Feb 2002 07:44:06 +0200

Kevin,

Raphael Tryster

	-----Original Message-----
	From:	Kevin Boyle [SMTP:[email-masked]]
	Sent:	Wednesday, 27 February, 2002 6:48 AM
	To:	Usha Iyer; Zhang Yuyong; Tom-PT Taylor; [email-masked]
	Subject:	RE: [Megaco] How MGC to Put a Trunk Group out of
Service Graceful ly?

	Kevin

	-----Original Message-----
	From: Usha Iyer [mailto:[email-masked]]
	Sent: Tuesday, February 26, 2002 11:24 PM
	To: Boyle, Kevin [NCRTP:3Z30:EXCH]; Zhang Yuyong; Taylor, Tom-PT
	[CAR:B800:EXCH]; [email-masked]
	Subject: Re: [Megaco] How MGC to Put a Trunk Group out of Service
	Gracefully?

	Hi , 

	Reg,
	usha

	-----Original Message----- 
	From: Zhang, Yuyong [mailto:[email-masked]] 
	Sent: Tuesday, February 26, 2002 9:27 PM 
	To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
	Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
	Gracefully? 

	Hi Folks,

---

From: "Kevin Boyle"<[email-masked]>
Date: Wed, 27 Feb 2002 22:31:08 -0500

I do disagree with the draft -- not just on this point.  In my opinion, the
draft is a bit excessive, and is incomplete.  Don't get me wrong -- it was a
noble effort to try and bring some clarity to a very gray area, but I do not
think it adequately covers ServiceChange, as it leaves several key points
undefined, and what it does cover is very heavy.

I am working currently on getting something put together that will focus the
effort, so that we aren't just scatter-shooting at the current holes in the
document.  Because I'm traveling, I haven't had as much time as I would have
liked recently to get this organized and get an initial draft put together
to help lead the group.  I hope to get this done in the next couple of
weeks.

There is supposed to be a kickoff of this work at the IETF meeting in
Minneapolis.  I still don't know if I will be able to attend at this time.
If I am, I will use the meeting as an opportunity to introduce this effort,
with a follow-up to the list to put the group together.  If I cannot attend,
I will see if I can get something to Tom for the meeting, and then recruit
from the list.

Since you seem to pop up a lot on ServiceChange, am I to assume that you are
interested in participating in this group? :)

Kevin

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Wednesday, February 27, 2002 12:44 AM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]; Usha Iyer; Zhang Yuyong; Taylor, Tom-PT
[CAR:B800:EXCH]; [email-masked]
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service Graceful
ly?

Kevin, 

-----Original Message----- 
From:   Kevin Boyle [SMTP:[email-masked]] 
Sent:   Wednesday, 27 February, 2002 6:48 AM 
To:     Usha Iyer; Zhang Yuyong; Tom-PT Taylor; [email-masked] 
Subject:        RE: [Megaco] How MGC to Put a Trunk Group out of Service
Graceful ly? 

-----Original Message----- 
From: Usha Iyer [mailto:[email-masked]] 
Sent: Tuesday, February 26, 2002 11:24 PM 
To: Boyle, Kevin [NCRTP:3Z30:EXCH]; Zhang Yuyong; Taylor, Tom-PT 

Hi , 

----- Original Message ----- 
From: Kevin Boyle 
To: Zhang, Yuyong ; Tom-PT Taylor ; [email-masked]' 
Sent: Wednesday, February 27, 2002 9:31 AM 
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service 
Gracefully? 

-----Original Message----- 
From: Zhang, Yuyong [mailto:[email-masked]] 
Sent: Tuesday, February 26, 2002 9:27 PM 
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
Gracefully? 

Hi Folks,

---

From: "Kevin Boyle"<[email-masked]>
Date: Wed, 27 Feb 2002 22:31:08 -0500

Kevin

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Wednesday, February 27, 2002 12:44 AM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]; Usha Iyer; Zhang Yuyong; Taylor, Tom-PT

Kevin, 

-----Original Message----- 
From:   Kevin Boyle [SMTP:[email-masked]] 
Sent:   Wednesday, 27 February, 2002 6:48 AM 
To:     Usha Iyer; Zhang Yuyong; Tom-PT Taylor; [email-masked] 
Subject:        RE: [Megaco] How MGC to Put a Trunk Group out of Service
Graceful ly? 

-----Original Message----- 
From: Usha Iyer [mailto:[email-masked]] 
Sent: Tuesday, February 26, 2002 11:24 PM 
To: Boyle, Kevin [NCRTP:3Z30:EXCH]; Zhang Yuyong; Taylor, Tom-PT 

Hi , 

----- Original Message ----- 
From: Kevin Boyle 
To: Zhang, Yuyong ; Tom-PT Taylor ; [email-masked]' 
Sent: Wednesday, February 27, 2002 9:31 AM 
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service 
Gracefully? 

-----Original Message----- 
From: Zhang, Yuyong [mailto:[email-masked]] 
Sent: Tuesday, February 26, 2002 9:27 PM 
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
Gracefully? 

Hi Folks,

---

From: "Zhang, Yuyong" <[email-masked]>
Date: Thu, 28 Feb 2002 12:20:35 -0800

Hi there,
 
Though it works to send both to block a Trunk Group, but from a MG
implementation, it is not efficient to go through NULL contxt and all the
active contexts to find out CICs in the Trunk Group.
 
Let's look at the possible Trunk Group operations a MGC can ask MG to do.
 
Forced or Graceful
     MGC want to block a Trunk Group either forced or Graceful. In this
case, MG does not care what the context MGC used in 
     the Message. The operation implies what a MG should do. If a CIC is in
an active context, then MG block it if is forced. Or 
     wait for clearance then blocked it if it is Graceful.
 
Restart
     To restart a Trunk Group, the trunk group has to be blocked previously.
Therefore, all the CiCs has to be in NULL context.
 
As a conclusion, we can define a message scheme for Trunk Group Blocking as
the following:
 
1. Forced  or Graceful, the context (NULL or ALL) are insignificant to MG,
MG should use the operation and the Trunk Group
    Information to process.
2. Restart, the context has to be NULL.
 
Please give your thoughts.
 
Regards,
 
Yuyong

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 8:02 PM
To: Zhang, Yuyong; Tom-PT Taylor; [email-masked]'
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service Graceful
ly?

Kevin 

-----Original Message----- 
From: Zhang, Yuyong [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Tuesday, February 26, 2002 9:27 PM 
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
Gracefully? 

Hi Folks, 

Context = - { 
                  ServiceChange = TG1/* { 

Context = * { 
                  ServiceChange = TG1/* { 

Regards, 

Yuyong 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>

---

From: "Zhang, Yuyong" <[email-masked]>
Date: Thu, 28 Feb 2002 12:20:35 -0800

Hi there,

 
Forced or Graceful
 
Restart

 
 
Regards,
 
Yuyong

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 8:02 PM
To: Zhang, Yuyong; Tom-PT Taylor; [email-masked]'
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service Graceful
ly?

Kevin 

-----Original Message----- 

Hi Folks, 

Context = - { 
                  ServiceChange = TG1/* { 

Context = * { 
                  ServiceChange = TG1/* { 

Regards, 

Yuyong

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 28 Feb 2002 15:31:48 -0500

At the moment this just looks like hacking: continuing in this direction
would produce a very irregular protocol.  Is there a more general
requirement here to operate on a given termination regardless of the context
it is in?  

Something new in the way of syntax would have to wait now until
Megaco/H.248v3.

-----Original Message-----
From: Zhang, Yuyong [mailto:[email-masked]]
Sent: Thursday, February 28, 2002 3:21 PM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]; Zhang, Yuyong; Taylor, Tom-PT
[CAR:B800:EXCH]; [email-masked]'
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service Graceful
ly?

Hi there,

 
Forced or Graceful
 
Restart

 
 
Regards,
 
Yuyong

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 8:02 PM
To: Zhang, Yuyong; Tom-PT Taylor; [email-masked]'
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service Graceful
ly?

-----Original Message----- 
From: Zhang, Yuyong [mailto:[email-masked]] 
Sent: Tuesday, February 26, 2002 9:27 PM 
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
Gracefully? 

Hi Folks,

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 28 Feb 2002 15:31:48 -0500

-----Original Message-----
From: Zhang, Yuyong [mailto:[email-masked]]
Sent: Thursday, February 28, 2002 3:21 PM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]; Zhang, Yuyong; Taylor, Tom-PT

Hi there,

 
Forced or Graceful
 
Restart

 
 
Regards,
 
Yuyong

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 8:02 PM
To: Zhang, Yuyong; Tom-PT Taylor; [email-masked]'
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service Graceful
ly?

-----Original Message----- 
From: Zhang, Yuyong [mailto:[email-masked]] 
Sent: Tuesday, February 26, 2002 9:27 PM 
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
Gracefully? 

Hi Folks,

---

From: "Zhang, Yuyong" <[email-masked]>
Date: Thu, 28 Feb 2002 13:39:35 -0800

G'day, Tom and list!

I agree with you in general that a syntax change should be done in the new
version of the protocol to avoid the irregularity of the protocol. Maybe in
the V3, we should consider the possibility to allow operation on
terminations regradles of the context for applications such as the Trunk
Group operations.

Is there any other way for a MGC to block a Trunk group other than the one
mentioned in this thread? Trunk Group Blocking is a basic and normal
procedure for PSTN trunks, shouldn't we have some clean procedures in MEGACO
to do that?

Please advice!

Regards,

Yuyong

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Thursday, February 28, 2002 12:32 PM
To: 'Zhang, Yuyong'; Kevin Boyle; [email-masked]'
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service
Graceful ly?

-----Original Message-----
From: Zhang, Yuyong [mailto:[email-masked]]
Sent: Thursday, February 28, 2002 3:21 PM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]; Zhang, Yuyong; Taylor, Tom-PT

Hi there,

 
Forced or Graceful
 
Restart

 
 
Regards,
 
Yuyong

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 8:02 PM
To: Zhang, Yuyong; Tom-PT Taylor; [email-masked]'
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service Graceful
ly?

-----Original Message----- 
From: Zhang, Yuyong [mailto:[email-masked]] 
Sent: Tuesday, February 26, 2002 9:27 PM 
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
Gracefully? 

Hi Folks,

---

From: "Zhang, Yuyong" <[email-masked]>
Date: Thu, 28 Feb 2002 13:39:35 -0800

G'day, Tom and list!

Please advice!

Regards,

Yuyong

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Thursday, February 28, 2002 12:32 PM
To: 'Zhang, Yuyong'; Kevin Boyle; [email-masked]'
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service
Graceful ly?

-----Original Message-----
From: Zhang, Yuyong [mailto:[email-masked]]
Sent: Thursday, February 28, 2002 3:21 PM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]; Zhang, Yuyong; Taylor, Tom-PT

Hi there,

 
Forced or Graceful
 
Restart

 
 
Regards,
 
Yuyong

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 8:02 PM
To: Zhang, Yuyong; Tom-PT Taylor; [email-masked]'
Subject: RE: [Megaco] How MGC to Put a Trunk Group out of Service Graceful
ly?

-----Original Message----- 
From: Zhang, Yuyong [mailto:[email-masked]] 
Sent: Tuesday, February 26, 2002 9:27 PM 
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]' 
Subject: [Megaco] How MGC to Put a Trunk Group out of Service 
Gracefully? 

Hi Folks,