Subject: RE: [Megaco] Is MEGACO compatible with MGCP?

From: "Liu, Gary" <[email-masked]>
Date: Wed, 20 Feb 2002 11:53:10 -0500

The answer should be possible. We have worked with an MG vendor, which is
using MEGACO as internal model but externally using MGCP protocol. It is
totally transparent to the MGC, which is MGCP controller.

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Wednesday, February 20, 2002 11:29 AM
To: Carr, Steve; David Suh; [email-masked]
Subject: RE: [Megaco] Is MEGACO compatible with MGCP?

The question was whether a Megaco MGC could control a MGCP MG, or vice
versa.  The answer is no.  If both the MGC and the MG speak the same
protocol, then interworking between a Megaco termination and an MGCP
endpoint is only a matter of using SDP to set up bearer and getting the MGCs
to speak to each other (or to itself, as the case may be).

As for doing both MGCP and Megaco out of the same box, I agree that it is
possible, but care must be taken when designing the software to handle the
different connection models at the same time.  The Megaco  connection model
is far more sophisticated (and complex) than MGCP's, and that would have to
be taken into consideration.

Kevin 

-----Original Message----- 
From: Carr, Steve [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Tuesday, February 19, 2002 7:09 PM 
To: Boyle, Kevin [NCRTP:3Z30:EXCH]; David Suh; [email-masked] 
Subject: RE: [Megaco] Is MEGACO compatible with MGCP? 

It should be possible to design an MGC that talks both Megaco and MGCP, and 
selects one or the other based on provisioning. Then you could enable 
interworking between the two, an MGCP endpoint calls an Megaco endpoint or 
vise versa. 

-----Original Message----- 
From: Kevin Boyle [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Tuesday, February 19, 2002 12:41 PM 
To: David Suh; [email-masked] 
Subject: RE: [Megaco] Is MEGACO compatible with MGCP? 

No.  The H.248 connection model is completely incompatible with the MGCP 
connection model.  Both the MGC and the MG must be one or the other. 

Kevin 

-----Original Message----- 
From: David Suh [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Tuesday, February 19, 2002 12:21 PM 
To: [email-masked] 
Subject: [Megaco] Is MEGACO compatible with MGCP? 

I know this is a basic question. 
(Considering MEGACO talks about terminations and contexts and MGCP talks 
about endpoints and connections.) 

Is an MGCP MGC compatible with a MEGACO MG? 
Is an MEGACO MGC compatible with a MGCP MG? 

I need an answer to say that I got it from the experts on the MEGACO mailing

list. 

----------------------------------------------------------------------------

--- 
David W. Suh 
[email-masked] 
----------------------------------------------------------------------------

--- 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>  

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>

---

From: "Don Stanwyck" <[email-masked]>
Date: Wed, 20 Feb 2002 10:43:43 -0700

My expectation is that it is reasonable to implement a Megaco call model
and control it with MGCP at the interface, but it would be more
difficult to implement an MGCP call model and control it with Megaco at
the interface.
 
Don Stanwyck

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Liu, Gary
Sent: Wednesday, February 20, 2002 9:53 AM
To: 'Kevin Boyle'; [email-masked]
Subject: RE: [Megaco] Is MEGACO compatible with MGCP?

The answer should be possible. We have worked with an MG vendor, which
is using MEGACO as internal model but externally using MGCP protocol. It
is totally transparent to the MGC, which is MGCP controller.

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Wednesday, February 20, 2002 11:29 AM
To: Carr, Steve; David Suh; [email-masked]
Subject: RE: [Megaco] Is MEGACO compatible with MGCP?

The question was whether a Megaco MGC could control a MGCP MG, or vice
versa.  The answer is no.  If both the MGC and the MG speak the same
protocol, then interworking between a Megaco termination and an MGCP
endpoint is only a matter of using SDP to set up bearer and getting the
MGCs to speak to each other (or to itself, as the case may be).

As for doing both MGCP and Megaco out of the same box, I agree that it
is possible, but care must be taken when designing the software to
handle the different connection models at the same time.  The Megaco
connection model is far more sophisticated (and complex) than MGCP's,
and that would have to be taken into consideration.

Kevin 

-----Original Message----- 
From: Carr, Steve [mailto:[email-masked]] 
Sent: Tuesday, February 19, 2002 7:09 PM 
To: Boyle, Kevin [NCRTP:3Z30:EXCH]; David Suh; [email-masked] 
Subject: RE: [Megaco] Is MEGACO compatible with MGCP? 

It should be possible to design an MGC that talks both Megaco and MGCP,
and 
selects one or the other based on provisioning. Then you could enable 
interworking between the two, an MGCP endpoint calls an Megaco endpoint
or 
vise versa. 

-----Original Message----- 
From: Kevin Boyle [mailto:[email-masked]] 
Sent: Tuesday, February 19, 2002 12:41 PM 
To: David Suh; [email-masked] 
Subject: RE: [Megaco] Is MEGACO compatible with MGCP? 

Kevin 

-----Original Message----- 
From: David Suh [mailto:[email-masked]] 
Sent: Tuesday, February 19, 2002 12:21 PM 
To: [email-masked] 
Subject: [Megaco] Is MEGACO compatible with MGCP? 

I need an answer to say that I got it from the experts on the MEGACO
mailing 
list. 

------------------------------------------------------------------------
---- 
--- 
David W. Suh 
[email-masked] 
------------------------------------------------------------------------
---- 
---

---

From: "Don Stanwyck" <[email-masked]>
Date: Wed, 20 Feb 2002 10:43:43 -0700

Don Stanwyck

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Wednesday, February 20, 2002 11:29 AM
To: Carr, Steve; David Suh; [email-masked]
Subject: RE: [Megaco] Is MEGACO compatible with MGCP?

Kevin 

-----Original Message----- 
From: Kevin Boyle [mailto:[email-masked]] 
Sent: Tuesday, February 19, 2002 12:41 PM 
To: David Suh; [email-masked] 
Subject: RE: [Megaco] Is MEGACO compatible with MGCP? 

Kevin

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 20 Feb 2002 13:18:09 -0500

RE: [Megaco] Is MEGACO compatible with MGCP?HI All,
Interworking is always a possibility. But the basic question David asked was
"Is an MGCP MGC compatible with a MEGACO MG? Is an MEGACO MGC compatible
with a MGCP MG?" The answer is NO. A MGCP MGC cannot control an Megaco MG
and an Megaco MGC cannot control an MGCP MG. Since each of the protocol has
its own connection model and of course different protocol messages and
grammar ;-).

Regards
Madhubabu
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Liu, Gary
  Sent: Wednesday, February 20, 2002 11:53 AM
  To: 'Kevin Boyle'; [email-masked]
  Subject: RE: [Megaco] Is MEGACO compatible with MGCP?

    -----Original Message-----
    From: Kevin Boyle [mailto:[email-masked]]
    Sent: Wednesday, February 20, 2002 11:29 AM
    To: Carr, Steve; David Suh; [email-masked]
    Subject: RE: [Megaco] Is MEGACO compatible with MGCP?

    As for doing both MGCP and Megaco out of the same box, I agree that it
is possible, but care must be taken when designing the software to handle
the different connection models at the same time.  The Megaco  connection
model is far more sophisticated (and complex) than MGCP's, and that would
have to be taken into consideration.

    Kevin

    -----Original Message-----
    From: Kevin Boyle [mailto:[email-masked]]
    Sent: Tuesday, February 19, 2002 12:41 PM
    To: David Suh; [email-masked]
    Subject: RE: [Megaco] Is MEGACO compatible with MGCP?

    Kevin

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 20 Feb 2002 13:18:09 -0500

Regards
Madhubabu

    -----Original Message-----
    From: Kevin Boyle [mailto:[email-masked]]
    Sent: Wednesday, February 20, 2002 11:29 AM
    To: Carr, Steve; David Suh; [email-masked]
    Subject: RE: [Megaco] Is MEGACO compatible with MGCP?

    Kevin

    -----Original Message-----
    From: Kevin Boyle [mailto:[email-masked]]
    Sent: Tuesday, February 19, 2002 12:41 PM
    To: David Suh; [email-masked]
    Subject: RE: [Megaco] Is MEGACO compatible with MGCP?

    Kevin