Subject: [Megaco] About play ann

From: "derrick.ding" <[email-masked]>
Date: Tue, 5 Feb 2002 14:22:59 +0800

Hi,Tom-PT！
   I have a question about play announcement on MGC side, need your help so much.

   When Termination A is connected with Termination B, like this:
MGC:
   Transaction = 50001{
    Context = 3{
        Add = B
        Add = A 
    }
   }

   Now play announcement to B, Should MGC play announcement to B dirrectly, or modify topology first, then play announcement to B(the latter is adopted by TS.23205). ABNF is as following:
1.one choice:
MGC:
   Transaction = 50002{
    Context = 3{
        Modify = B{
           signal(an/ann1)
         }        
    }
   } 

2. the other choice:
MGC:
   Transaction = 50002{Topology{
                               A,B,Isolate
                               }
                       Context = 3{
                                  }
                      }

   Transaction = 50003{
    Context = 3{
        Modify = B{
           signal(an/ann1)
         }        
    }
   } 

I think both are right. And in my opinion, I prefer the first one because of its simplicity.

Thanks and Best Regards           

            derrick.ding
            [email-masked]

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 5 Feb 2002 12:27:00 -0500

I wouldn't do either.  I assume they are using topology to prevent A from
sending media to B while B is playing out the announcement.  The point is
valid, but use of topology is unnecessary.  Instead just make A sendOnly
while the announcement is played out.

-----Original Message-----
From: derrick.ding [mailto:[email-masked]]
Sent: Tuesday, February 05, 2002 7:23 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Megaco
Subject: About play ann 

Hi,Tom-PT£¡
   I have a question about play announcement on MGC side, need your help so
much.

   Now play announcement to B, Should MGC play announcement to B dirrectly,
or modify topology first, then play announcement to B(the latter is adopted
by TS.23205). ABNF is as following:
1.one choice:
MGC:
   Transaction = 50002{
    Context = 3{
        Modify = B{
           signal(an/ann1)
         }        
    }
   } 

2. the other choice:
MGC:

   Transaction = 50003{
    Context = 3{
        Modify = B{
           signal(an/ann1)
         }        
    }
   } 

I think both are right. And in my opinion, I prefer the first one because of
its simplicity.

Thanks and Best Regards           

            derrick.ding
            [email-masked]

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 5 Feb 2002 12:27:00 -0500

-----Original Message-----
From: derrick.ding [mailto:[email-masked]]
Sent: Tuesday, February 05, 2002 7:23 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Megaco
Subject: About play ann 

Hi,Tom-PT£¡

2. the other choice:
MGC:

   Transaction = 50003{
    Context = 3{
        Modify = B{
           signal(an/ann1)
         }        
    }
   } 

Thanks and Best Regards           

            derrick.ding
            [email-masked]

---

From: "derrick.ding" <[email-masked]>
Date: Wed, 6 Feb 2002 10:18:34 +0800

Hi,Tom-PT Taylor！
   Thanks for your help.And I'd like to give another proof here. 
   Megaco comes from MGCP. In MGCP, signal is also a descriptor of an endpoint. Whenever an endpoint is played announce, a signal descriptor is needed only and there's no topology concept in MGCP.
   So "prevent A from sending media to B" is done by MG automatically.

!!!And I have a question about your reply, :-)
   In my opinion, to give a sendOnly descriptor here cannot prevent A from sending media to B. Because Mode is used only for outside context connection mode instead of inner context. If you wanna modify the connection mode in a context, you should modify topology.

            derrick.ding
            [email-masked]

---

From: "derrick.ding" <[email-masked]>
Date: Wed, 6 Feb 2002 10:18:34 +0800

Hi,Tom-PT Taylor！

            derrick.ding
            [email-masked]

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 6 Feb 2002 08:23:06 -0500

I wouldn't argue Megaco interpretation from MGCP: we very much added our own
semantics.  In particular, we anticipated the specific possibility that you
might want to play out multiple signals at once (e.g. announcement over busy
tone), and similarly play out announcements over (gain-reduced) conversation
in the background.

mode=sendonly prevents media from entering at A.  That means the only media
that could pass from A to B would be by way of an inward-directed
announcement.  In the ordinary case, therefore, mode=sendonly at A is enough
to do the job.

-----Original Message-----
From: derrick.ding [mailto:[email-masked]]
Sent: Wednesday, February 06, 2002 3:19 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Megaco; Jackson.liu; mark.tao; newmon wei; coming.ling
Subject: Re: [Megaco] RE: About play ann

Hi,Tom-PT Taylor£¡
   Thanks for your help.And I'd like to give another proof here. 
   Megaco comes from MGCP. In MGCP, signal is also a descriptor of an
endpoint. Whenever an endpoint is played announce, a signal descriptor is
needed only and there's no topology concept in MGCP.
   So "prevent A from sending media to B" is done by MG automatically.

!!!And I have a question about your reply, :-)
   In my opinion, to give a sendOnly descriptor here cannot prevent A from
sending media to B. Because Mode is used only for outside context connection
mode instead of inner context. If you wanna modify the connection mode in a
context, you should modify topology.

2002-02-05 12:27:00 you write£º

            derrick.ding
            [email-masked]

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 6 Feb 2002 08:23:06 -0500

-----Original Message-----
From: derrick.ding [mailto:[email-masked]]
Sent: Wednesday, February 06, 2002 3:19 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Megaco; Jackson.liu; mark.tao; newmon wei; coming.ling
Subject: Re: [Megaco] RE: About play ann

Hi,Tom-PT Taylor£¡

            derrick.ding
            [email-masked]