Subject: [Megaco] FXO handling

From: "K.V.N. Sridhar" <[email-masked]>
Date: Thu, 7 Feb 2002 16:28:16 +0530 (IST)

Hi,

                        +--------------+
                        |              |
                        |    MGC       |
                        +--------------+
                                |
                                |
                                |
                        +----------------------+
         POTS Line      |        MG            |
  CO|-------------------|FXO                   |
                        |                      |
                        |  FXS  FXS    FXS     |
                        +----------------------+
                           |     |      |
                          /_\   /_\    /_\

I'm trying to place a call from remote CO-subscriber to the residential
phone & vice versa (please refer above diagram).

Please clarify my questions below

1. Is there any package in MEGACO to handle FXO port as
   seen in the setup above.
   (eg. Is there any way to send MEGACO message that a
   ring was detected on FXO in form of notify { Pkgid/eventid } )

2. Are there any MEGACO call flow messages for the above scenario.

3. If there is no such package how do I handle incoming & outgoing
   calls at FXO.

Cheers
sridhar

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Fri, 8 Feb 2002 08:30:30 -0500

I may miss the subtleties of the FXO and FXS designations, so I may not be
fully correct here.  Anyway, I'm not currently aware of a package to detect
ringing on the FXO line, but it should be easy enough to create one.  Your
diagram shows the right model, if I'm right in my perception: each FXS line
and the FXO line would be modelled as separate terminations.  To connect the
call to a specific extension you put it and the FXO into a common context.

-----Original Message-----
From: K.V.N. Sridhar [mailto:[email-masked]]
Sent: Thursday, February 07, 2002 11:58 AM
To: [email-masked]
Subject: [Megaco] FXO handling

Hi,

                        +--------------+
                        |              |
                        |    MGC       |
                        +--------------+
                                |
                                |
                                |
                        +----------------------+
         POTS Line      |        MG            |

Cheers
sridhar

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Fri, 8 Feb 2002 08:30:30 -0500

-----Original Message-----
From: K.V.N. Sridhar [mailto:[email-masked]]
Sent: Thursday, February 07, 2002 11:58 AM
To: [email-masked]
Subject: [Megaco] FXO handling

Hi,

                        +--------------+
                        |              |
                        |    MGC       |
                        +--------------+
                                |
                                |
                                |
                        +----------------------+
         POTS Line      |        MG            |

Cheers
sridhar