Subject: RE: [Megaco] Subtraction of terminations in case of SVC Forced fr om MG

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 4 Sep 2002 11:50:50 -0400

Absolutely.  It is the MGCs responsibility to clean up, as is stated in this
very paragraph.

Kevin

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] 
Sent: Wednesday, September 04, 2002 8:10 AM
To: 'Megaco_IETF (E-mail)
Subject: [Megaco] Subtraction of terminations in case of SVC Forced from MG

Hi all!

According to
                                                                        
 draft-ietf-megaco-h248v2-01.txt                                        

 (para.7.2.8 - ServiceChange):

         2) Forced - indicates that the specified Terminations were taken
        abruptly out of service and any established connections
        associated with them may be lost. For non-Root terminations the
        MGC is responsible for cleaning up the context (if any) with
        which the failed termination is associated.  At a minimum the
        termination shall be subtracted from the context.  The
        termination serviceState should be "out of service". For the
        root termination the MGC can assume that all connections are
        lost on the MG and thus can consider that all the terminations
        have been subtracted.

Does it mean that the MG may not subtract the terminations in case of
ServiceChange Forced method for non-Root termination and must wait for
Subtract command from the MGC?

Bella

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 4 Sep 2002 11:50:50 -0400

Kevin

-----Original Message-----

Hi all!

According to

Bella

---

From: "Harry Suede" <[email-masked]>
Date: Thu, 05 Sep 2002 13:27:22 +0800

hi

why can't MG subtract the termination on its own once the termination is out out of service (either forced or after graceful timeout). What is it that the MGC can do other that subtracting the termination from the context?

harry

----- Original Message -----
From: "Kevin Boyle" <[email-masked]>
Date: Wed, 4 Sep 2002 11:50:50 -0400 
To: [email-masked], "''Megaco_IETF (E-mail)" <[email-masked]>
Subject: RE: [Megaco] Subtraction of terminations in case of SVC Forced fr om MG

Kevin

-----Original Message-----

Hi all!

According to

Bella

-- 
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 5 Sep 2002 12:21:28 -0400

The MGC can do whatever it thinks is appropriate.  It may be that the MGC
leaves the MG state where it is and then audits to acquire diagnostic info,
as an example.  By having the MG autonomously subtract the term, that
capability is lost to the MGC.

Remember, the MGC is the CONTROLLER.  It decides the appropriate actions to
take, not the MG.

Kevin

-----Original Message-----
From: Harry Suede [mailto:[email-masked]] 
Sent: Thursday, September 05, 2002 1:27 AM
To: Boyle, Kevin [NCRTP:3R90:EXCH]; [email-masked];
'Megaco_IETF (E-mail); Taylor, Tom-PT [CAR:B602:EXCH]
Subject: RE: [Megaco] Subtraction of terminations in case of SVC Forced fr
om MG

hi

why can't MG subtract the termination on its own once the termination is out
out of service (either forced or after graceful timeout). What is it that
the MGC can do other that subtracting the termination from the context?

harry

----- Original Message -----
From: "Kevin Boyle" <[email-masked]>
Date: Wed, 4 Sep 2002 11:50:50 -0400 
To: [email-masked], "''Megaco_IETF (E-mail)"
<[email-masked]>
Subject: RE: [Megaco] Subtraction of terminations in case of SVC Forced fr
om MG

Kevin

-----Original Message-----

Hi all!

According to

Bella

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 5 Sep 2002 12:21:28 -0400

Kevin

-----Original Message-----
From: Harry Suede [mailto:[email-masked]] 
Sent: Thursday, September 05, 2002 1:27 AM
To: Boyle, Kevin [NCRTP:3R90:EXCH]; [email-masked];

hi

harry

----- Original Message -----
From: "Kevin Boyle" <[email-masked]>
Date: Wed, 4 Sep 2002 11:50:50 -0400 
To: [email-masked], "''Megaco_IETF (E-mail)"
<[email-masked]>

Kevin

-----Original Message-----

Hi all!

According to

Bella