Subject: [Megaco] SDP static and dynamic codecs

From: "Tulpule, Naren" <[email-masked]>
Date: Tue, 10 Sep 2002 16:25:12 -0700

Hi,
  my apologies if this is not the right forum for SDP questions.

In m= line, there are payload types specified after RTP/AVP.
e.g.
m=audio 1234 RTP/AVP 0 1 2 97 98 99
0, 1, 2 are static codecs (defined at
http://www.iana.org/assignments/rtp-parameters)
while 97, 98, 99 are dynamic codecs, and will be specified later in a=rtpmap
lines
e.g.
a=rtpmap:98 L16/16000/1

My question is, if the codecs are e.g. 0 (PCM mu law) and 98 (L16), will
a=ptime lines appear for both or just L16 or just PCMU or none? And where?
In other words, is this a good SDP media description:

m=audio 1234 RTP/AVP 0 98
a=ptime:40
a=rtpmap:98 L16/16000/1
a=ptime:20

What I want to describe is, choose from 2 codecs: PCMU(40 ms) or L16(20 ms).

If this is not a good description, how will you describe it?

These views are mine alone, not those of Intel or Trillium (yet ;-)
-- Naren
Narendra C. Tulpule         310-442-9222
SMTS, Trillium (an Intel company)
12100 Wilshire Bl #1800 Los Angeles CA 90025

-- Trap and rule uncle. Curl under a planet. Plan real undercut. Pull under
a trance. Turn candle real up. Plunder a cruel ant.

What do they use to ship styrofoam?

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tulpule, Naren" <[email-masked]>
Date: Wed, 11 Sep 2002 16:51:28 -0700

> m=audio 1234 RTP/AVP 0 98
[TROY]
The lowest level grouping defined in RFC 2327 is the media description
(the "m=" line and everything after it until the next "m=" line).
Multiple ptime lines are not really addressed, but I don't think you
can assume they mean what you want.
But according to 7.1.8 of H.248.1,
	A Stream Descriptor specifies a single bi-directional media stream
and
	so a single session description MUST NOT include more than one media

	description ("m=" line). A Stream Descriptor may contain additional

	session descriptions as alternatives. Each media stream for a

	termination must appear in distinct Stream Descriptors.
So I think you need to double the entire session description (SDP block)
to do what you want.
-troy

[NAREN] Thanks Troy. According to above rules, the SDP will appear as:

v=0
c=whatever
m=audio 1234 RTP/AVP 0
a=ptime:40
v=0
c=whatever
audio 1234 RTP/AVP 98
a=rtpmap:98 L16/16000/1
a=ptime:20

Do non-Troy people on the list concur?

a trance. 
   Turn candle real up. Plunder a cruel ant.

---

From: "Tulpule, Naren" <[email-masked]>
Date: Wed, 11 Sep 2002 16:51:28 -0700

[TROY]

v=0
c=whatever
m=audio 1234 RTP/AVP 0
a=ptime:40
v=0
c=whatever
audio 1234 RTP/AVP 98
a=rtpmap:98 L16/16000/1
a=ptime:20