Subject: [Megaco] Question about H.248 ADD command

From: "lpy" <[email-masked]>
Date: Mon, 23 Sep 2002 16:23:19 +0800

Dear all,
    I have a basic doubt about the Add command. Could anyone please answer it?
In draft-ietf-megaco-callflows-00.txt ,2.2 Call between Residential Gateway and Trunking Gateway,
there has written with <<In this example as mentioned earlier we doesn't assume any specific 
signaling in the other side of the Trunking gateway. This eliminates 
the complexity of reporting the address information and alerting the 
end user. The MGC then "Adds" a physical termination. The wildcard $ 
is used here to enable the Trunking gateway to choose one of its 
trunks on the other side of the Trunking gateway. The ephemeral 
termination is requested to create with the under specified SDP local 
information and the remote SDP information.

Step 9
MGC to TGW
   MEGACO/1 [216.33.33.61]: 27000
   Transaction = 1236 {
       Context = $ {
          Add = Trunk1/$  {Media {
                    LocalControl {Mode = SendRecv}},
               },

 My question is marked with  blue colour,(I consider MGC should specify the link ,not let TGW to choose)
 Please mailto: [email-masked] ,thanks a lot.

 Best regard!

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Mon, 23 Sep 2002 09:34:43 -0700

HI Liu,
The Megaco protocol supports choosing of terminations by partially
specifying the terminationId. The example is only to illustrate that option.
It is up to the MGC to decide whether to fully specify the termination ID or
get it returned from the MG by partially specifying it. In this example the
partial wildcard option was illustrated. The intention here is to indicate
that the choose ($) option can be used for physical terminations also. Hope
this helps.

Regards
Madhubabu Brahmanapally.
Syndeo Corporation
695 Campbell Technology Parkway
Campbell, CA 95008
Phone 408.376.1151
Fax 408.861.9801

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of lpy
  Sent: Monday, September 23, 2002 1:23 AM
  To: [email-masked]
  Subject: [Megaco] Question about H.248 ADD command

  Dear all,
      I have a basic doubt about the Add command. Could anyone please answer
it?
  In draft-ietf-megaco-callflows-00.txt ,2.2 Call between Residential
Gateway and Trunking Gateway,
  there has written with <<In this example as mentioned earlier we doesn't
assume any specific
  signaling in the other side of the Trunking gateway. This eliminates
  the complexity of reporting the address information and alerting the
  end user. The MGC then "Adds" a physical termination. The wildcard $
  is used here to enable the Trunking gateway to choose one of its
  trunks on the other side of the Trunking gateway. The ephemeral
  termination is requested to create with the under specified SDP local
  information and the remote SDP information.

  Step 9
  MGC to TGW

   My question is marked with  blue colour,(I consider MGC should specify
the link ,not let TGW to choose)
   Please mailto: [email-masked] ,thanks a lot.

   Best regard!

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Mon, 23 Sep 2002 09:34:43 -0700

HI Liu,

Regards
Madhubabu Brahmanapally.
Syndeo Corporation

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of lpy
  Sent: Monday, September 23, 2002 1:23 AM
  To: [email-masked]
  Subject: [Megaco] Question about H.248 ADD command

  Dear all,

  Step 9
  MGC to TGW

   Best regard!