Subject: [Megaco] digitmap

From: Usha <[email-masked]>
Date: Thu, 19 Sep 2002 15:03:10 +0800

Is * (star) supported in the DigitMap of H.248 . If not why? * is supported in MGCP

---

From: Rajeev K R <[email-masked]>
Date: Fri, 20 Sep 2002 09:41:33 +0800

Hi Usha,
Entire DTMF sequence is from Hex Values 0 to F. Keys '*' and '#' are represented by E and F respectively in this sequence.
MGCP digitmap has allowed the usage of * and # directly in the digitmap and digit string while Megaco uses E and F itself. Similarly the reported digit string in megaco will contain E and F and not * or #.

Also the MGCP uses T for timeout in digitmap (e.g.: x.T for any number of digits till timeout) but Megaco uses S (short timer) or  L( Long timer). If you want to use the same digitmap for both MGCP and megaco GWs, you need to do this conversion for one of the protocols.

Regards,
Rajeev

---

From: Rajeev K R <[email-masked]>
Date: Fri, 20 Sep 2002 09:41:33 +0800

Hi Usha,

Regards,
Rajeev