Subject: [Megaco] Packages extension

From: Fhuval Hittay <[email-masked]>
Date: Tue, 3 Sep 2002 09:19:18 +0400 (MSD)

Hello all!
In RFC there is said that "dg" package extends "tonegen" package, and does it 
mean that I can use:
   dg/pt {tl = [d0, d1]}
instead of:
   tonegen/pt {tl = [d0, d1]} ?

Also "dd" package extends "tonedet" package. And instead of:
   tonedet/std {tl = [d2, d3, d4]}
I can use:
   dd/std {tl = [d2, d3, d4]} ?

Question is: What is the difference between theese two forms of usage? Which 
ObservedEvents descriptor MG has to return if it has following EventsDescriptor:
  Events = 1 { dd/std {tl = [d2, d3, d4]}, tonedet/std {tl = [d2, d3, d4]}}
and it detects f.e. "d2" stat tone:
 ObservedEvents = 1 { dd/std {tid = d2} },
or
 ObservedEvents = 1 { tonedet/std {tid = d2} } ?

Please, answer ASAP. Thanks in advance.
----
  http://www.rambler.ru
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 03 Sep 2002 11:23:16 -0400

Hi,

         Usage of signal/event IDs apply only in the scope of the package
which defines them, or packages that extends that package.
Thus you can not use d0 in tonegen, it does not know what d0 is.

To clarify, let say there is another packages dgx which also extends
tonegen and also defines d0, like dg package, but it means something different.
If you were to use base package to access d0 then you would get the same
tonegen/pt {tl = [d0, d1]}  As you can see there is no way to distinguish
which package is being used: dg or dgx.

The answers to your questions below are:
dg/pt {tl = [d0, d1]}
dd/std {tl = [d2, d3, d4]}
Events = 1 { dd/std {tl = [d2, d3, d4]}}
ObservedEvents = 1 { dd/std {tid = d2} }

Cheers.
         Aleks

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 03 Sep 2002 11:23:16 -0400

Hi,

Cheers.
         Aleks