Subject: [Megaco] Move Command

From: "VND Wang JuLin" <[email-masked]>
Date: Thu, 26 Sep 2002 15:16:31 +0800

Hi,List,
Suppose there are two active contexts in the MG.As follows:

Context  1
Terminations:TermA and Rtp/1
Media(Rtp/1): Local: ip:10.10.0.1,port:4060
                         Remote:10.10.0.1,port:4070
                         Mode:sendrecv
Context  2
Terminations:TermB and Rtp/2 
Media(Rtp/2): Local: ip:10.10.0.1,port:4070 
              Remote:10.10.0.1,port:4060
	      Mode:sendrecv

Then MGC request TermA to be moved into Context2.(The max nubmer of terminations that context supports more than 2) 
My question is how to handle the media flows between the two physical terms in context2. 
And if MGC send Modify command on TermA with context=1 ,what error code will be triggered?

Thanks a lot!

 best  regards
>:-)Jerry Wang
tel:(8621)58541240 ext 9615
mailto:[email-masked] 
Alcatel Shanghai Bell Co.LTD

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 26 Sep 2002 09:50:50 -0400

From the point of view of the Megaco theoretical model, moving Term A into
context 2 simply creates a three-way flow of media: the context operates as
a conference bridge.  Perhaps you have an implementation problem because of
the physical design of your particular gateway?

The error code you are looking for is 435 Termination ID is not in specified
Context.

> -----Original Message-----
> From: VND Wang JuLin [mailto:[email-masked]] 
> Sent: Thursday, September 26, 2002 3:17 AM
> To: [email-masked]
> Subject: [Megaco] Move Command
> 
> 
> Hi,List,
> Then MGC request TermA to be moved into Context2.(The max 
> nubmer of terminations that context supports more than 2) 
> tel:(8621)58541240 ext 9615 mailto:[email-masked]

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 26 Sep 2002 09:50:50 -0400

---

From: "VND Wang JuLin" <[email-masked]>
Date: Fri, 27 Sep 2002 09:28:59 +0800

Exactly!The topology shows that. While I can send rtp packets after getting remote side's ip and port together with mode.But for two physical term's media flows,i don't know how without remote descriptor.Is it so-called hairpin connection?
Suppose MGC send the following message to the gateway with media descriptor on physical term.Is gateway required to create and report the ip and port info for phyical side?
 
Transaction=1{
	Context=-{
		Modify=line/1{
			Media{
Local{
v=0
c=IN IP4 $
a=fmtp:PCMU VAD=X-NNVAD
m=audio $ RTP/AVP 0
}, LocalControl{Mode=SendReceive}
			}
		}
	}
}

>From: Tom-PT Taylor [mailto:[email-masked]]
>Sent: Thursday, September 26, 2002 9:51 PM
>To: VND Wang JuLin; [email-masked]
>Subject: RE: [Megaco] Move Command
>
>

---

From: "VND Wang JuLin" <[email-masked]>
Date: Fri, 27 Sep 2002 09:28:59 +0800

Transaction=1{
	Context=-{
		Modify=line/1{
			Media{
Local{
v=0
c=IN IP4 $
a=fmtp:PCMU VAD=X-NNVAD
m=audio $ RTP/AVP 0

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 27 Sep 2002 09:35:28 -0400

Physical terminations have their own local and remote descriptor settings,
but in typical practice these are assumed to be provisioned.  A key
exception is in the case of NAS operation over ISDN, when a number of bearer
capability parameters have to be specified because they can vary from call
to call.  To see what the SDP may look like in this case you could look at
my I-D draft-taylor-mmusic-sdp-tdm-01.txt, which I really must bring to a
conclusion.

In any event, the local and remote descriptors for TDM certainly don't have
IP addresses and ports -- just a trunk or line identifier which isn't
particularly relevant because the MG already has the terminationID to work
with.

> Sent: Thursday, September 26, 2002 9:29 PM
> To: Taylor, Tom-PT [CAR:B602:EXCH]; [email-masked]
> Cc: SchwarzAlbrecht (E-mail); LeursAn (E-mail)
> Exactly!The topology shows that. While I can send rtp packets 
> after getting remote side's ip and port together with 
> mode.But for two physical term's media flows,i don't know how 
> without remote descriptor.Is it so-called hairpin connection? 
> Suppose MGC send the following message to the gateway with 
> media descriptor on physical term.Is gateway required to 
> create and report the ip and port info for phyical side?
>  
> Transaction=1{
> 	Context=-{
> 		Modify=line/1{
> 			Media{
> Local{
> v=0
> c=IN IP4 $
> a=fmtp:PCMU VAD=X-NNVAD
> m=audio $ RTP/AVP 0
> >> [email-masked] https://www1.ietf.org/mailman/listinfo/megaco
> >> 
> >
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 27 Sep 2002 09:35:28 -0400