Subject: [Megaco] Regarding ALERT/ANDISP Package

From: [email-masked]
Date: Mon, 16 Sep 2002 10:24:04 +0530

Hi Kevin/List,

In draft-boyle-megaco-alerting-03.txt,
ALERT Package Version 1defines three signals with signal ids:-
Ring           SignalID: ri (0x0001)
Ringsplash     SignalID: rs (0x0002)
Call Waiting   SignalID: cw (0x0003)

ANDISP Package Version 1,  which extends  ALERT Package Version 1 , defines
three signals with signal ids:-
Display with Alerting              SignalID: dwa (0x0001)
Generic Data Signaling        SignalID: data (0x0002)
Error Tone                         SignalID: err (0x0003)

The signal ids of the signals defined in ANDISP Package should be different from
 the ids defined in ALERT Package as the text from
Page 81 of "draft-ietf-megaco-3015corr-01.txt" prohibits to overload the
identifier defined in base package.

"Extends (Optional): existing package Descriptor

         A package may extend an existing package. The version of the
         original package must be specified. When a package extends
         another package it shall only add additional Properties,
         Events, Signals, Statistics and new possible values for an
         existing parameter described in the original package.

         An  extended package shall not redefine or overload an identifier
         defined in the original package and packages it may have
         extended (multiple levels of extension).
        <<<<<<<<<<

         Hence, if package B
         version 1 extends package A version 1, version 2 of B will not
         be able to extend the A version 2 if A version 2 defines a name
         already in B version 1. "

Thanks N Regards,
Ashish Singh
www.hssworld.com

DISCLAIMER: This message is proprietary to Hughes Software Systems
Limited (HSS) and is intended solely for the use of the individual
to whom it is addressed. It may contain  privileged or confidential
information  and should not be circulated or used for any purpose other
than for what it is intended. If you have received this message in error,
please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. HSS accepts
no responsibility for loss or damage arising from the use of the information
transmitted by this email including damage from virus.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Fri, 20 Sep 2002 09:45:27 +0530

Rajeev,

I don't see such voilation in RFC 3015 packages. The event id of dd/ce event is
being changed to 0x0004 in
"draft-ietf-megaco-3015corr-01.txt".

  PackageID: dd (0x0006)
   Version: 1
   Extends: tonedet version 1

   DigitMap Completion Event
   -------------------------
   EventID: ce, 0x0004

Regards
Ashish

Rajeev K R <[email-masked]> on 09/20/2002 07:19:30 AM

To:   Ashish Singh/HSS@HSS, [email-masked], [email-masked]
cc:

Subject:  Re: [Megaco] Regarding ALERT/ANDISP Package

>          extended (multiple levels of extension).

In the base RFC itself you can see package definitions violating this. An
example is provided below.
In almost all the packages events and signals list starts from 0x0001 even
though they are used in the base packages. But nobody has reused the text id
of base package. So maybe the statement above needs some clarification ?

Regards,
Rajeev

E.g. in tonedet package:
   PackageID: tonedet (0x0004)
   Version: 1
   Extends: None

   Start tone detected
   -------------------
   EventID: std, 0x0001

Same event 0x0001 is defined in dd also.

   PackageID: dd (0x0006)
   Version: 1
   Extends: tonedet version 1

   DigitMap Completion Event
   -------------------------
   EventID: ce, 0x0001

---

From: "Carl Rutter" <[email-masked]>
Date: Fri, 20 Sep 2002 07:51:44 -0400

Never mind I believ Rajeev
answered my question.

Carl
----- Original Message -----
From: "Carl Rutter" <[email-masked]>
To: <[email-masked]>; "Rajeev K R" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Friday, September 20, 2002 7:47 AM
Subject: Re: [Megaco] Regarding ALERT/ANDISP Package

> While we are on the topic,
>
> How about "E","F" for dd
> and
> I believe Pound and Star for tonedet?
> I think these overlap (don't have the RFC infront of me)
>
> Or are they assumed the same?
>
> Carl
> To: "Rajeev K R" <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Friday, September 20, 2002 12:15 AM
> > though they are used in the base packages. But nobody has reused the
text
> id

---

From: "Carl Rutter" <[email-masked]>
Date: Fri, 20 Sep 2002 07:51:44 -0400

Carl
----- Original Message -----
From: "Carl Rutter" <[email-masked]>
To: <[email-masked]>; "Rajeev K R" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Friday, September 20, 2002 7:47 AM
Subject: Re: [Megaco] Regarding ALERT/ANDISP Package

text