Subject: [Megaco] forbidden descriptors

From: Raphael Tryster <[email-masked]>
Date: Wed, 4 Sep 2002 15:17:16 +0200

Forbidden descriptors may be encountered on two levels:

1.	A Megaco entity receives a command with a descriptor that is not
legal for that command.  For example, a Subtract command with a media
descriptor.  Should the receiving entity
*	fail the entire command?
*	fail the command after processing the descriptors that came before
the illegal one?
*	accept the command, ignoring the illegal descriptor?

2.	A Megaco entity receives a command containing a audit descriptor
that requests the returning of some descriptors that are illegal in the
reply to that command.  For example, an AuditCapabilities command requesting
the digit map descriptor.  My intuition tells me that this case should not
be stricter than the first one, and it should be OK just to omit the illegal
descriptors from the reply.  Comments, please. 

Raphael Tryster

---

From: Raphael Tryster <[email-masked]>
Date: Wed, 4 Sep 2002 16:26:55 +0200

I should have consulted Annex L before I sent the question.  Looking at it
now, it's pretty clear you are right that the command should fail, but I
believe the correct error code is 447.  That answers my first question.  The
second is still open.

Raphael Tryster

	-----Original Message-----
	From:	Fernando Vallejo Lazaro
[SMTP:[email-masked]]
	Sent:	Wednesday, 04 September, 2002 3:12 PM
	To:	Raphael Tryster
	Cc:	[email-masked]
	Subject:	Re: [Megaco] forbidden descriptors

	Hi, 

	see my coments below 

	Raphael Tryster wrote: 

	You may reply with error code 455: Parameter illegal in this
descriptor, 
	although it is more appropiate for other case I think the semantic
is the same. 
	You should not ignore the illegal descriptor, I guess the entire
command should fail . 

		Raphael Tryster

	Regards 
	Fernando 
	-- 
	Fernando Vallejo Lazaro
	Phone:  +34 91 330 8279
	SW  Wireline ASD-Madrid
	       ALCATEL