Subject: [Megaco] Package item placement

From: "Lyn Spencer" <[email-masked]>
Date: Fri, 13 Sep 2002 11:35:19 +0100

Hi

I have a question concerning the use of packages.  If I wish to define a
package, what is it's scope.  I would like to define package items at
Context level e.g.

Context = 1{
mypackage/Item1=1
}

Is this possible?

Regards
Lyn

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 13 Sep 2002 09:39:43 -0400

Currently, you may not define package items at the Context level.  There was
a proposal to add this capability, but it was defeated under claims that
there hasn't been enough deployment experience to reliably assess the impact
that adding items at level will have.
 
Keep in mind that, even if this capability were added to the protocol, items
defined at this level should operate on the context.  Many things that are
done operate on one termination, and are, therefore, more appropriate in one
of the current locations for package items (LocalControl, Local, Remote,
Events, Signals, or Statistics).
 
Kevin

-----Original Message-----
From: Lyn Spencer [mailto:[email-masked]] 
Sent: Friday, September 13, 2002 6:35 AM
To: [email-masked]
Subject: [Megaco] Package item placement

Hi

Context = 1{
mypackage/Item1=1
}
 
Is this possible?
 
Regards
Lyn

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 13 Sep 2002 09:39:43 -0400

Kevin

-----Original Message-----
From: Lyn Spencer [mailto:[email-masked]] 
Sent: Friday, September 13, 2002 6:35 AM
To: [email-masked]
Subject: [Megaco] Package item placement

Hi

Context = 1{
mypackage/Item1=1
}
 
Is this possible?
 
Regards
Lyn

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 17 Sep 2002 13:01:38 -0400

Christian Groves had a proposal to create context packages, which he was
persuaded to defer to H.248.1 v3 because of its potentially disruptive
effect on the protocol architecture.  It's reasonable for people to start
thinking about whether such packages are needed and stating their position
on this list.  Just to be proactive: there should also be opinions on when
the ITU-T should target approval of v3 (which at the moment is just a
concept).

-----Original Message-----
From: Lyn Spencer [mailto:[email-masked]] 
Sent: Friday, September 13, 2002 6:35 AM
To: [email-masked]
Subject: [Megaco] Package item placement

Hi

Context = 1{
mypackage/Item1=1
}

Is this possible?

Regards
Lyn

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 17 Sep 2002 13:01:38 -0400

-----Original Message-----
From: Lyn Spencer [mailto:[email-masked]] 
Sent: Friday, September 13, 2002 6:35 AM
To: [email-masked]
Subject: [Megaco] Package item placement

Hi

Context = 1{
mypackage/Item1=1
}

Is this possible?

Regards
Lyn