Subject: RE: [Megaco] Subtraction of terminations in case of SVC Forced fr om MG

From: "Harry Suede" <[email-masked]>
Date: Thu, 05 Sep 2002 13:27:22 +0800

hi

why can't MG subtract the termination on its own once the termination is out out of service (either forced or after graceful timeout). What is it that the MGC can do other that subtracting the termination from the context?

harry

----- Original Message -----
From: "Kevin Boyle" <[email-masked]>
Date: Wed, 4 Sep 2002 11:50:50 -0400 
To: [email-masked], "''Megaco_IETF (E-mail)" <[email-masked]>
Subject: RE: [Megaco] Subtraction of terminations in case of SVC Forced fr om MG

Absolutely.  It is the MGCs responsibility to clean up, as is stated in this
very paragraph.

Kevin

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] 
Sent: Wednesday, September 04, 2002 8:10 AM
To: 'Megaco_IETF (E-mail)
Subject: [Megaco] Subtraction of terminations in case of SVC Forced from MG

Hi all!

According to
                                                                        
 draft-ietf-megaco-h248v2-01.txt                                        

 (para.7.2.8 - ServiceChange):

         2) Forced - indicates that the specified Terminations were taken
        abruptly out of service and any established connections
        associated with them may be lost. For non-Root terminations the
        MGC is responsible for cleaning up the context (if any) with
        which the failed termination is associated.  At a minimum the
        termination shall be subtracted from the context.  The
        termination serviceState should be "out of service". For the
        root termination the MGC can assume that all connections are
        lost on the MG and thus can consider that all the terminations
        have been subtracted.

Does it mean that the MG may not subtract the terminations in case of
ServiceChange Forced method for non-Root termination and must wait for
Subtract command from the MGC?

Bella

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

-- 
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 5 Sep 2002 10:01:01 -0700

HI Harry,
From the protocol perspective, all calls are established and teardown by the
MGC. MG merely executes the call establishment and teardown commands from
the MGC.

Regards
Madhubabu Brahmanapally.
Syndeo Corporation
695 Campbell Technology Parkway
Campbell, CA 95008
Phone 408.376.1151
Fax 408.861.9801

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Harry Suede
Sent: Wednesday, September 04, 2002 10:27 PM
To: Kevin Boyle; [email-masked]; 'Megaco_IETF (E-mail);
[email-masked]
Subject: RE: [Megaco] Subtraction of terminations in case of SVC Forced
fr om MG

hi

why can't MG subtract the termination on its own once the termination is out
out of service (either forced or after graceful timeout). What is it that
the MGC can do other that subtracting the termination from the context?

harry

----- Original Message -----
From: "Kevin Boyle" <[email-masked]>
Date: Wed, 4 Sep 2002 11:50:50 -0400
To: [email-masked], "''Megaco_IETF (E-mail)"
<[email-masked]>
Subject: RE: [Megaco] Subtraction of terminations in case of SVC Forced fr
om MG

Kevin

-----Original Message-----

Hi all!

According to

Bella

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 5 Sep 2002 10:01:01 -0700

HI Harry,

Regards
Madhubabu Brahmanapally.
Syndeo Corporation

-----Original Message-----

hi

harry

----- Original Message -----
From: "Kevin Boyle" <[email-masked]>
Date: Wed, 4 Sep 2002 11:50:50 -0400
To: [email-masked], "''Megaco_IETF (E-mail)"
<[email-masked]>

Kevin

-----Original Message-----

Hi all!

According to

Bella