Subject: [Megaco] doubts with event handling

From: milton mukhopadhyaya <[email-masked]>
Date: Mon, 30 Sep 2002 05:40:58 -0700 (PDT)

dear all,
 I have got this problem with the intrpretation of
event handling when event buffer control is in
lockstep. 
I> According to RFC:
" 1. If the EventBuffer is empty, the MG waits for
detection of events based on the new EventsDescriptor.
"
Does this mean that any event detected that is present
in the EventBuffer Descriptor would be discarded,
since RFC does not mention specifically that how to
use eventbuffer  descriptor after this?

II> "The MG then waits for a new EventsDescriptor.
While waiting for a new EventsDescriptor,any events
detected that appear in the EventsBufferDescriptor
will be placed in the EventBuffer. When a new
EventsDescriptor is received,the event processing will
repeat from step 1."
Does this mean that any event detected that is present
in the current Event Descriptor(new one has not
arrived yet and we are waiting for it)will be
discarded, as this case is not mentioned ?

Anxiously waiting for response.

                                  Mukta Vasudeva

__________________________________________________
Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!
http://sbc.yahoo.com
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 30 Sep 2002 10:17:09 -0400

Please see below, marked with [PTT].

> -----Original Message-----
> From: milton mukhopadhyaya [mailto:[email-masked]] 
> Sent: Monday, September 30, 2002 8:41 AM
> To: [email-masked]
> Subject: [Megaco] doubts with event handling
> 
> 
> dear all,

[PTT] The next event detected will be processed against the Events
descriptor rather than the EventBuffer descriptor and recognized or
discarded on that basis, so yes, if there is an event identified in the
EventBuffer descriptor which is not also in the Events descriptor, that
event will not be recognized.
> discarded, as this case is not mentioned ?

[PTT]  Same logic as above: the filter doing the selection of events is now
the EventBuffer descriptor, so the contents of the Events descriptor at this
point are irrelevant.
> http://sbc.yahoo.com _______________________________________________
> Megaco mailing list
> [email-masked]

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 30 Sep 2002 10:17:09 -0400