Subject: [Megaco] forbidden descriptors

From: Raphael Tryster <[email-masked]>
Date: Wed, 4 Sep 2002 15:17:16 +0200

Forbidden descriptors may be encountered on two levels:

1.	A Megaco entity receives a command with a descriptor that is not
legal for that command.  For example, a Subtract command with a media
descriptor.  Should the receiving entity
*	fail the entire command?
*	fail the command after processing the descriptors that came before
the illegal one?
*	accept the command, ignoring the illegal descriptor?

2.	A Megaco entity receives a command containing a audit descriptor
that requests the returning of some descriptors that are illegal in the
reply to that command.  For example, an AuditCapabilities command requesting
the digit map descriptor.  My intuition tells me that this case should not
be stricter than the first one, and it should be OK just to omit the illegal
descriptors from the reply.  Comments, please. 

Raphael Tryster

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Wed, 04 Sep 2002 15:11:41 +0200

Hi,

see my coments below

Raphael Tryster wrote:

>      legal for that command.  For example, a Subtract command with a
>      media descriptor.  Should the receiving entity
>         o fail the entire command?
>         o fail the command after processing the descriptors that came
>           before the illegal one?
>         o accept the command, ignoring the illegal descriptor?
>
>      that requests the returning of some descriptors that are illegal
>      in the reply to that command.  For example, an AuditCapabilities
>      command requesting the digit map descriptor.  My intuition tells
>      me that this case should not be stricter than the first one, and
>      it should be OK just to omit the illegal descriptors from the
>      reply.  Comments, please.
>
>

You may reply with error code 455: Parameter illegal in this descriptor,

although it is more appropiate for other case I think the semantic is
the same.
You should not ignore the illegal descriptor, I guess the entire command
should fail .

> Raphael Tryster

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Wed, 04 Sep 2002 15:11:41 +0200

Hi,

see my coments below

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 04 Sep 2002 16:39:53 +0300

Hi,

In the first case you should send 447.

Regards,

Christer Holmberg
Ericsson Finland

Fernando Vallejo Lazaro wrote:

>>   1. A Megaco entity receives a command with a descriptor that is
>>      not legal for that command.  For example, a Subtract command
>>      with a media descriptor.  Should the receiving entity
>>         o fail the command after processing the descriptors that
>>           came before the illegal one?
>>   2. A Megaco entity receives a command containing a audit
>>      descriptor that requests the returning of some descriptors that
>>      are illegal in the reply to that command.  For example, an
>>      AuditCapabilities command requesting the digit map descriptor.
>>      My intuition tells me that this case should not be stricter
>>      than the first one, and it should be OK just to omit the
>>      illegal descriptors from the reply.  Comments, please.
>>
>>
>
> You should not ignore the illegal descriptor, I guess the entire
> command should fail .
>
>>
>>
>> Raphael Tryster
>
> Regards
> Fernando
>
> --
> Fernando Vallejo Lazaro
> Phone:  +34 91 330 8279
> SW  Wireline ASD-Madrid
>        ALCATEL
>
>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 04 Sep 2002 16:39:53 +0300

Hi,

Regards,

Christer Holmberg
Ericsson Finland