Subject: [Megaco] Re: Topology Descriptor Processing Logic

From: Christian Groves <[email-masked]>
Date: Mon, 03 Feb 2003 14:34:04 +1100

Hello Shobhit,

As everything is fully specified I believe it is your first description.

Christian

[email-masked] wrote:
> 
> Hi Chris,
> 
> I have gone through the mailing list discussions
> But I still have some doubts in topology descriptor procressing
> I will be really very thankful and obliged if you help in resolving them
> 
> Assuming that we have a context C1 with terminations T1, T2 and T3
> and command comes like
> 
> Action    C1 Topolgy ( T1, T3, Isolate)
>      Command   Modify T1
>      Command   Modify T2
> 
> In this case:
> 
> Will the topology (T1, T3, Isolate) be applied before the
> command execution starts i.e. tuples of specified terminations
> will get applied before any command execution starts.
> If this understanding is correct, topology will get applied
> before execution of MODIFY T1
> 
> OR
> 
> Will the topology application be deffered till the command
> execution starts for the respective terminations that are present in tuples.
> If this understanding is correct, after MODIFY T1 gets executed,
> topology would be applied in conjunction thereof.
> Further after that, MODIFY T2 will get executed.
> 
> Thanking you in advance
> Shobhit

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 03 Feb 2003 14:34:04 +1100

Hello Shobhit,

Christian