Subject: Re: [Megaco] Re: Topology Descriptor Processing Logic

From: [email-masked]
Date: Mon, 3 Feb 2003 20:13:29 +0530

Hi Christian/list,
     Thanks a lot for clarifying all the doubts. In addition to what you have
said, I have two more questions as asked below. I beg your pardon in case these
questions have already been discussed or asked on the list before.

<<PRJ>>
     You have told that in case the topology tuple happens to be fully specified
(except $), the topology descriptor would be executed first (at the action level
befoe any command processing starts, even though the protocol command like ADD
or MODIFY with fully-specified terminations were there in the context further,
for the corresponding terminations in the topology tuples).

     If the above statement holds true, does it imply that the topology
descriptor would always be first descriptor in the entire descriptor processing
sequence that would get executed, taking into account the other descriptors
processing like events, signals, stream descriptors (for all descriptors except
topology, the processing sequence can be specified by MGC) etc. ??

     Is this implication about the "sequence of processing" valid whether MG
executes topology descriptor at the action level or at the command level (in
case of ADD $) ??

<<PRJ>>

Thanks and Regards,
Prashant Jain

Christian Groves <[email-masked]> on 02/03/2003 08:34:04 AM

To:   Shobhit Bansal/HSS@HSS
cc:   [email-masked] (bcc: Prashant Jain/HSS)

Subject:  [Megaco] Re: Topology Descriptor Processing Logic

Hello Shobhit,

As everything is fully specified I believe it is your first description.

Christian

[email-masked] wrote:
>
> Hi Chris,
>
> I have gone through the mailing list discussions
> But I still have some doubts in topology descriptor procressing
> I will be really very thankful and obliged if you help in resolving them
>
> Assuming that we have a context C1 with terminations T1, T2 and T3
> and command comes like
>
> Action    C1 Topolgy ( T1, T3, Isolate)
>      Command   Modify T1
>      Command   Modify T2
>
> In this case:
>
> Will the topology (T1, T3, Isolate) be applied before the
> command execution starts i.e. tuples of specified terminations
> will get applied before any command execution starts.
> If this understanding is correct, topology will get applied
> before execution of MODIFY T1
>
> OR
>
> Will the topology application be deffered till the command
> execution starts for the respective terminations that are present in tuples.
> If this understanding is correct, after MODIFY T1 gets executed,
> topology would be applied in conjunction thereof.
> Further after that, MODIFY T2 will get executed.
>
> Thanking you in advance
> Shobhit

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Mon, 3 Feb 2003 20:13:29 +0530

Hi Christian/list,

<<PRJ>>

<<PRJ>>

Thanks and Regards,
Prashant Jain

Hello Shobhit,

Christian

---

From: [email-masked]
Date: Thu, 13 Feb 2003 16:48:50 +0530

Hi Christian/list,

We didn't get any reply/ comments on this mail.
From the earlier discussions on the mailing list, it seems that there
definitely are some existing implementations supporting Topology descriptor.
I would request them to provide some clarity on these issues in the interest
of the MEGACO interoperability.
Unless the questions/ issues raised in this mail are inconsequential and
grossly missing something, in which case please indicate so.

Thanks in advance
Shobhit
(HSS MEGACO Team)

[email-masked] on 02/03/2003 08:13:29 PM

To:   Christian Groves <[email-masked]>
cc:   Shobhit Bansal/HSS@HSS, [email-masked] (bcc: megaco_maillist)

Subject:  Re: [Megaco] Re: Topology Descriptor Processing Logic

Hi Christian/list,

<<PRJ>>

<<PRJ>>

Thanks and Regards,
Prashant Jain

Hello Shobhit,

Christian

DISCLAIMER: This message is proprietary to Hughes Software Systems
Limited (HSS) and is intended solely for the use of the individual
to whom it is addressed. It may contain  privileged or confidential
information  and should not be circulated or used for any purpose other
than for what it is intended. If you have received this message in error,
please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. HSS accepts
no responsibility for loss or damage arising from the use of the information
transmitted by this email including damage from virus.

---

From: [email-masked]
Date: Thu, 13 Feb 2003 16:48:50 +0530

Hi Christian/list,

Thanks in advance
Shobhit
(HSS MEGACO Team)

Hi Christian/list,

<<PRJ>>

<<PRJ>>

Thanks and Regards,
Prashant Jain

Hello Shobhit,

Christian