Subject: [Megaco] Cancel Service Change (method=Graceful) mechanism

From: [email-masked]
Date: Mon, 3 Feb 2003 17:49:10 +0530

Hi

It seems the protocol doesnot define any procedure for cancelling an earlier
Service Change (method=Graceful) on a non-root termination.

Taking a practical case:
MG sends a Service Change (method=Graceful) on a termination with delay= 2
hours.
After 1 hour, MG realizes that it doesn't want to put the termination
out-of-service (after remaining 1 hour) as was earlier intended.
How to inform the MGC of the new intentions - cancel graceful..?
Sending Service Change (method =Restart) would mean that termination just came
InService and doesnot have any active descriptors, whereas this is not the case.

Solution:
MG sends Service Change (method = Graceful) delay =2 hours to inform MGC only
about the intentions.
MG sends Service Change (method = Forced) when the termination actually goes
out-of-service after 2 hours.
This ensures that if Service Change (method = Forced) never came, the intentions
of MG never got materialised.

Does any body have an alternative solution? Please suggest.

thanks,
kapil nayar
www.hssworld.com

DISCLAIMER: This message is proprietary to Hughes Software Systems
Limited (HSS) and is intended solely for the use of the individual
to whom it is addressed. It may contain  privileged or confidential
information  and should not be circulated or used for any purpose other
than for what it is intended. If you have received this message in error,
please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. HSS accepts
no responsibility for loss or damage arising from the use of the information
transmitted by this email including damage from virus.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 3 Feb 2003 14:20:20 -0500

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, February 03, 2003 7:19 AM
To: [email-masked]
Subject: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi

Taking a practical case:
MG sends a Service Change (method=Graceful) on a termination with delay= 2
hours. After 1 hour, MG realizes that it doesn't want to put the termination
out-of-service (after remaining 1 hour) as was earlier intended. How to
inform the MGC of the new intentions - cancel graceful..? Sending Service
Change (method =Restart) would mean that termination just came InService and
doesnot have any active descriptors, whereas this is not the case.

[KJBII] Why can't you use SC Restart?  The Warm Boot SC Reason indicates
that there was NO loss of state.

Solution:
MG sends Service Change (method = Graceful) delay =2 hours to inform MGC
only about the intentions. MG sends Service Change (method = Forced) when
the termination actually goes out-of-service after 2 hours. This ensures
that if Service Change (method = Forced) never came, the intentions of MG
never got materialised.

[KJBII] Ick.  So we will be required to send TWO SCs instead of one if we
use SC Graceful?  I really don't like that idea.

thanks,
kapil nayar
www.hssworld.com

DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended solely for the use of the individual to whom it is
addressed. It may contain  privileged or confidential information  and
should not be circulated or used for any purpose other than for what it is
intended. If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient, you are
notified that you are strictly prohibited from using, copying, altering, or
disclosing the contents of this message. HSS accepts no responsibility for
loss or damage arising from the use of the information transmitted by this
email including damage from virus.

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 3 Feb 2003 14:20:20 -0500

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, February 03, 2003 7:19 AM
To: [email-masked]
Subject: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi

Taking a practical case:

Solution:

thanks,
kapil nayar
www.hssworld.com

---

From: [email-masked]
Date: Tue, 4 Feb 2003 10:52:28 +0530

Hi Kevin

Thanks for your reply...
But, as per H.248.8 the definition of Service Change reason "WarmBoot" is:

"This  indicates  that  the  entity  indicated  with  the  TerminationID  is  in
ServiceState  "In-Service",  and  that it has gone through a start, or recovery,
action.  All  transactions  in process may be lost, but otherwise all states are
preserved on the termination."

with a special comment: "This reason code only applies for TerminationID root"
The protocol defines the usage of "WarmBoot" only for root termination.

Alternatives?

thanks,
-kapil

"Kevin Boyle" <[email-masked]> on 02/04/2003 12:50:20 AM

To:   Kapil Nayar/HSS@HSS, [email-masked]
cc:

Subject:  RE: [Megaco] Cancel Service Change (method=Graceful) mechanism

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, February 03, 2003 7:19 AM
To: [email-masked]
Subject: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi

Taking a practical case:

Solution:

thanks,
kapil nayar
www.hssworld.com

---

From: [email-masked]
Date: Tue, 4 Feb 2003 10:52:28 +0530

Hi Kevin

Thanks for your reply...

Alternatives?

thanks,
-kapil

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, February 03, 2003 7:19 AM
To: [email-masked]
Subject: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi

Taking a practical case:

Solution:

thanks,
kapil nayar
www.hssworld.com

---

From: [email-masked]
Date: Tue, 4 Feb 2003 11:28:06 +0530

Hi Christian

Thanks for your replies in line...
You would have read my comments to Kevin's response. We would need some changes
to the following if no other alternative is acceptable/ available:
1). Definition of reason "WarmBoot".
2). Definition of method "Restart" which currently states only "service will be
restored on the specified Terminations"

BTW, I am inquisitive - if an MG would typically send a Service Change
(method=Graceful) with finite delay for a termination in Null context. Any
comments?

thanks,
kapil nayar
www.hssworld.com

Christian Groves <[email-masked]> on 02/04/2003 05:34:44 AM

To:   Kapil Nayar/HSS@HSS
cc:   [email-masked]

Subject:  Re: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hello Kapil,

Please see my comments below.

Christian

> InService and doesnot have any active descriptors, whereas this is not the
case.

[CHG] Method = Restart, Reason Warm Boot would work as Kevin mentions.

> Does any body have an alternative solution? Please suggest.

[CHG] Why do you need to do this? The MGC should have a timer of 2 hours
associated with that termination. So the MGC knows when to subtract the
termination from the context. The MGC should not use this termination for
traffic after it has subtracted it.

---

From: [email-masked]
Date: Tue, 4 Feb 2003 15:55:49 +0530

Repeating the mail.
Didn't see it on the list...
---------------------- Forwarded by Kapil Nayar/HSS on 02/04/2003 04:01 PM
---------------------------

Kapil Nayar
02/04/2003 10:52 AM

To:   "Kevin Boyle" <[email-masked]>
cc:   [email-masked]

Subject:  RE: [Megaco] Cancel Service Change (method=Graceful) mechanism
      (Document link not converted)

Hi Kevin

Thanks for your reply...

Alternatives?

thanks,
-kapil

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, February 03, 2003 7:19 AM
To: [email-masked]
Subject: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi

Taking a practical case:

Solution:

thanks,
kapil nayar
www.hssworld.com

---

From: [email-masked]
Date: Tue, 4 Feb 2003 15:55:49 +0530

Repeating the mail.

Kapil Nayar
02/04/2003 10:52 AM

Hi Kevin

Thanks for your reply...

Alternatives?

thanks,
-kapil

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, February 03, 2003 7:19 AM
To: [email-masked]
Subject: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi

Taking a practical case:

Solution:

thanks,
kapil nayar
www.hssworld.com

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 4 Feb 2003 10:26:22 -0500

That's what I get for not looking it up first.  Try 900.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, February 04, 2003 12:22 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi Kevin

Thanks for your reply...

"This  indicates  that  the  entity  indicated  with  the  TerminationID  is
in ServiceState  "In-Service",  and  that it has gone through a start, or
recovery, action.  All  transactions  in process may be lost, but otherwise
all states are preserved on the termination."

with a special comment: "This reason code only applies for TerminationID
root" The protocol defines the usage of "WarmBoot" only for root
termination.

Alternatives?

thanks,
-kapil

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, February 03, 2003 7:19 AM
To: [email-masked]
Subject: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi

Taking a practical case:

Solution:

thanks,
kapil nayar
www.hssworld.com

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 4 Feb 2003 10:26:22 -0500

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, February 04, 2003 12:22 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi Kevin

Thanks for your reply...

Alternatives?

thanks,
-kapil

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, February 03, 2003 7:19 AM
To: [email-masked]
Subject: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi

Taking a practical case:

Solution:

thanks,
kapil nayar
www.hssworld.com

---

From: [email-masked]
Date: Tue, 4 Feb 2003 21:24:22 +0530

Hi Kevin

Thanks again for the reply.
Don't worry...it can happen with anybody...neways I didn't mean to offend you.

But, I still have a doubt - 900 would be used for 2 cases:
1).  Termination state changed from OutOfService to InService.
2).  Cancelling Graceful on an InService termination.
Is this overloading of the Service Change reason OK. Do we need any additional
text in the docs?
How do we define the state of descriptors on the terminations in both the cases
- is there any difference?

-kapil

"Kevin Boyle" <[email-masked]> on 02/04/2003 08:56:22 PM

To:   Kapil Nayar/HSS@HSS
cc:   [email-masked]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, February 04, 2003 12:22 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi Kevin

Thanks for your reply...

Alternatives?

thanks,
-kapil

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, February 03, 2003 7:19 AM
To: [email-masked]
Subject: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi

Taking a practical case:

Solution:

thanks,
kapil nayar
www.hssworld.com

---

From: [email-masked]
Date: Tue, 4 Feb 2003 21:24:22 +0530

Hi Kevin

-kapil

To:   Kapil Nayar/HSS@HSS
cc:   [email-masked]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, February 04, 2003 12:22 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi Kevin

Thanks for your reply...

Alternatives?

thanks,
-kapil

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, February 03, 2003 7:19 AM
To: [email-masked]
Subject: [Megaco] Cancel Service Change (method=Graceful) mechanism

Hi

Taking a practical case:

Solution:

thanks,
kapil nayar
www.hssworld.com