Subject: [Megaco] Subtracting a termination when EBC = LockStep

From: [email-masked]
Date: Thu, 13 Feb 2003 16:55:24 +0200

Hello,
When EBC = LockStep, there are three triggers for the MG to clean all
accumulated events from the buffer:
- The MGC sends an empty Events descriptor
- The MGC sends an empty Events buffer descriptor
- The MGC sends a Termination State descriptor with EBC = OFF.

Suppose there is a physical termination within a specific context, the EBC
= Lockstep, and there are accumulated events in the buffer.
If the MGC sends Subtract command without any request (of the 3 above) to
clean the buffer, there is a possibility that historic irrelevant events
will be notified to the MGC.

How can I avoid this situation? Should the MG put the EBC back to default
(OFF) in each Subtract command, even if MGC hasn't ordered to clean the
buffer?

Regards,
Dana H.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 13 Feb 2003 20:28:41 +0200

"If not provisioned otherwise, the properties in all descriptors except
TerminationState and LocalControl default to empty/"no value" when a
Termination is first created or returned to the null Context".

I think that covers the Subtract case.

Raphael Tryster

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Thursday, February 13, 2003 4:55 PM
To: [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: [Megaco] Subtracting a termination when EBC = LockStep

Hello,

Regards,
Dana H.

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 13 Feb 2003 20:28:41 +0200

Raphael Tryster

-----Original Message-----

Hello,

Regards,
Dana H.