Subject: [Megaco] Subtract Command after ServiceChange "Forced"

From: Maschoff Mark-P53708 <[email-masked]>
Date: Tue, 4 Feb 2003 17:35:25 -0700

In the case where a MG sends a ServiceChange - Forced to the MGC indicating that all ephemeral terminations within a Context were abruptly taken out of service (e.g., due to a failure within the MG), does Megaco insist that the MGC subsequently send a Subtract command to the MG to subtract these terminations from the context (and thus remove the Context)?  
 
Since all terminations within this Context have been taken out of service, the Context could simply be removed by the MG without the need for the Subtract command.  Is this acceptable Megaco behavior?
 
Thanks,
 
Mark

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 4 Feb 2003 20:11:42 -0500

Comments inline. [KJBII]
 
Kevin

-----Original Message-----
From: Maschoff Mark-P53708 [mailto:[email-masked]] 
Sent: Tuesday, February 04, 2003 7:35 PM
To: [email-masked]'
Subject: [Megaco] Subtract Command after ServiceChange "Forced"

In the case where a MG sends a ServiceChange - Forced to the MGC indicating
that all ephemeral terminations within a Context were abruptly taken out of
service (e.g., due to a failure within the MG), does Megaco insist that the
MGC subsequently send a Subtract command to the MG to subtract these
terminations from the context (and thus remove the Context)?  
[KJBII] Yes.  The MGC may wish to do things like audit the terminations, or
take other actions that would/could be precluded by the MG autonomously
destroying the ephemerals.  The MG is not equipped to make call processing
decisions, and therefore shouldn't.
 
Since all terminations within this Context have been taken out of service,
the Context could simply be removed by the MG without the need for the
Subtract command.  Is this acceptable Megaco behavior?
[KJBII] No.  See my reasoning above.  It is the MGC's job to control, not
the MG.  Also note that removal of all ephemeral terminations does not
destroy the context.  ALL terminations must be removed -- physical and
ephemeral alike.
 
Thanks,
 
Mark

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 4 Feb 2003 20:11:42 -0500

Comments inline. [KJBII]
 
Kevin

-----Original Message-----
From: Maschoff Mark-P53708 [mailto:[email-masked]] 
Sent: Tuesday, February 04, 2003 7:35 PM
To: [email-masked]'
Subject: [Megaco] Subtract Command after ServiceChange "Forced"

 
Thanks,
 
Mark