Subject: [Megaco] using UDP in MEGACO

From: Fhuval Hittay <[email-masked]>
Date: Tue, 15 Apr 2003 15:44:17 +0400 (MSD)

Hello all,
could anyone answer how could be avoided wrong sequence of received MEGACO 
messages when using UDP as a transport mechanism?

thanks in advance.

---------
http://www.rambler.ru/
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 21 Apr 2003 14:58:44 +0300

Hi,

> messages when using UDP as a transport mechanism?

I think the only answer to this is: don't send another message (at least not
if it contains actions for the same Context(s)/Termination(s) as the previous
message) until you have received an answer for the previous message.

Regards,

Christer Holmberg
Ericsson Finland

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 21 Apr 2003 14:58:44 +0300

Hi,

Regards,

Christer Holmberg
Ericsson Finland

---

From: "Anil Jangam" <[email-masked]>
Date: Mon, 21 Apr 2003 18:40:03 +0530

Hi Christer ,

What about the use the ALF (which also recommended when used UDP as
Transport)??
Use of ALF can solve the sequencing problem in UDP.

/anil.

----- Original Message -----
From: "Christer Holmberg" <[email-masked]>
To: "Fhuval Hittay" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, April 21, 2003 5:56 PM
Subject: Re: [Megaco] using UDP in MEGACO

> message) until you have received an answer for the previous message.

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Anil Jangam" <[email-masked]>
Date: Mon, 21 Apr 2003 18:40:03 +0530

Hi Christer ,

/anil.

---

From: "Paul Long" <[email-masked]>
Date: Mon, 21 Apr 2003 19:09:37 -0500

Anil,

FWIW, this is Brian Rosen's response to the query, "What is ALF?"

ALF is a set of techniques that allow an application, as opposed 
to a stack, affect how messages are sent to the other side.  
A typical ALF technique is to allow an application to change the 
order of messages sent when there is a queue AFTER it has queued 
them.  There is no spec.

You can JUST follow the procedures in Annex D, and nothing more,
or you can do some other things that might improve performance for
a particular application, but you can't do something that violates
the protocol specification.

Brian
<<<<<<<<<<<<

Paul

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Anil Jangam
Sent: Monday, April 21, 2003 8:10 AM
To: Christer Holmberg; Fhuval Hittay
Cc: [email-masked]; Tom-PT Taylor
Subject: Re: [Megaco] using UDP in MEGACO

Hi Christer ,

/anil.

---

From: "Paul Long" <[email-masked]>
Date: Mon, 21 Apr 2003 19:09:37 -0500

Anil,

Brian
<<<<<<<<<<<<

Paul

-----Original Message-----

Hi Christer ,

/anil.