Subject: [Megaco] [Question] About unrequested event notification

From: [email-masked]
Date: Mon, 21 Apr 2003 17:52:56 +0900

G'day.

If a MG send a event notification which is not requested by a MGC,
What shall the MGC do?

TIA.

---

From: Manuel Poza <[email-masked]>
Date: Tue, 22 Apr 2003 16:54:32 +0200

Hi, Hektor,

I think the MGC should reply with an error, possibly, error #401
(Protocol error).

Regards,
Manuel

---

From: Manuel Poza <[email-masked]>
Date: Tue, 22 Apr 2003 16:54:32 +0200

Hi, Hektor,

Regards,
Manuel

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 22 Apr 2003 19:31:19 -0400

Hi,

Exactly this question is answered in the latest IG draft which adds error 458
"Unexpected Event/RequestID". "Definition: The command was disregarded
because a notification for an Event / Request ID that the MGC did not request
was received"

ftp://standard.pictel.com/avc-site/0302_San/AVD-2292.zip
ftp://standard.pictel.com/avc-site/0302_San/TD-29.zip

Cheers.
         Aleks

At 10:54 AM 4/22/2003, Manuel Poza wrote:
>Hi, Hektor,
>
>I think the MGC should reply with an error, possibly, error #401 (Protocol 
>error).
>
>Regards,
>Manuel
>

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 22 Apr 2003 19:31:19 -0400

Hi,

Cheers.
         Aleks