Subject: RE: [Megaco] Processing Order of Context Properties and Terminati on Properties

From: "Nurit Shenhar" <[email-masked]>
Date: Thu, 3 Apr 2003 13:47:27 +0200

Kevin

In this case, what should the MG do if one of the terminations defined in the topology is illegal? (i.e belongs to another context). Should there be some session of legality check for the topology?

Nurit

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, March 27, 2003 9:54 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati on Properties

Clearly you cannot add the new term before modifying T2.  So the steps are
thus:

1. Process the TP descriptor, noting that there is a term that will be added
later in the action which will be isolated from all the other existing terms
in the context.
2. Process the Modify T2 command.
3. Process the Add command, and add the new term.  Note that because the TP
descriptor has ALREADY been processed, the term is added isolated from all
other terms in the context.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, March 27, 2003 1:48 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati
on Properties

Hi Kevin/List,
Taking the discussion a bit further, please clarify if the following
sequence for implementing Topology Descriptor is correct. Transaction
receieved: ...Context=1{Topology{$, *, isolate}, Modify=T2{...}, Add=${...}}

Processing steps:
1. Resolve the termination name i.e. select one termination conforming to
the name specified in the Add command. 2. Add this termination to the
Context. This step may involve using some information given in the Add
command. 3. If the addition of the termination is successful proceed
further. If the addition of termination to Context is not successful give a
Context Level Error in the response. 4. Apply Topology for the newly added
termination. 5. Process the Modify command. 6. Process the Add command. Some
information present in this command will be used while adding the
termination to the Context. Rest of the information is processed here.

Please correct me if I am wrong.

Regards,
Chintan...
www.hssworld.com

"Kevin Boyle" <[email-masked]> on 03/20/2003 12:14:08 PM

To:   Chintan Kaushik/HSS@HSS, David Kao <[email-masked]>
cc:   [email-masked]

Subject:  RE: [Megaco] Processing Order of Context Properties and Terminati
on
      Properties

This is not correct.  As has been repeatedly covered, the Topology
descriptor is executed before any commands, regardless of the information
available.  The difference between this statement, and what you have
expressed is this:

C=1{TP{$,*,IS},A=${...}

Topology first:
The new term is added already isolated from all other terms in the context.

Topology once "enough information" is present:
The new term is added bothway to all terms, and then topology is altered to
isolate the term from all other terms in the context.

As you can see there is a significant difference between these two
scenarios.  If the command fails, then it is up to the MGC to clean up any
potential mess that results from having executed the TP descriptor.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, March 19, 2003 11:27 PM
To: David Kao
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati
on Properties

Hi,
A small addition to what Kevin has already mentioned: -
Attempt is made to apply the Topology descriptor before any commands for
that action. However, if due to some reason this is not possible then the
Topology Descriptor is applied as soon as all the information to apply it is
known to the MG. e.g. ... Context = 1{Topology{idstr1,$,Bothway } ,Add=$
{... In this case Topology will be applied once the "Add=$" command has been
executed successfully.

Regards,
Chintan...

"Kevin Boyle" <[email-masked]> on 03/19/2003 12:30:27 AM

To:   David Kao <[email-masked]>, [email-masked]
cc:    (bcc: Chintan Kaushik/HSS)

Subject:  RE: [Megaco] Processing Order of Context Properties and Terminati
on
      Properties

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: David Kao [mailto:[email-masked]]
Sent: Monday, March 17, 2003 10:22 PM
To: [email-masked]
Subject: [Megaco] Processing Order of Context Properties and Termination
Properties

Please accept my apology if the same questions were asked and discussed
before.

The spec says, "Transactions guarantee ordered Command processing. That is,
Commands within a Transaction are executed sequentially." I have two
relevant questions based on this statement.

1. How about the processing order of context properties? Are they supposed
to be processed in the same same sequential order like the commands?

For instance, based on previously posted emails from Christian Grove,
topology descriptor should be processed before commands in an action, since
"The Topology descriptor occurs before the commands in an action." In fact,
all contextRequests come before the commands. If this is the case, is the
following generalization correct?

"In a transaction, actions are executed sequentially. In an action, context
requests (including context property modifications and context property
audits) and commands are executed sequentially."
[KJBII] Yes.  H.248 is, essentially, a left to right protocol.

2. How about the processing order of termination properties? Without a
well-defined order, different MG implementations can respond differently to
the same command. For instance, if Signals descriptor is processed before
Events descriptor can produce different results than the case when Events
descriptor is processed first. [KJBII] See above comment.

Regards,

David Kao

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Nurit Shenhar" <[email-masked]>
Date: Thu, 3 Apr 2003 13:47:27 +0200

Kevin

Nurit

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, March 27, 2003 9:54 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati on Properties

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, March 27, 2003 1:48 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati
on Properties

Hi Kevin/List,

Processing steps:

Regards,
Chintan...
www.hssworld.com

C=1{TP{$,*,IS},A=${...}

Topology first:

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, March 19, 2003 11:27 PM
To: David Kao
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati
on Properties

Hi,

Regards,
Chintan...

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: David Kao [mailto:[email-masked]]
Sent: Monday, March 17, 2003 10:22 PM
To: [email-masked]
Subject: [Megaco] Processing Order of Context Properties and Termination
Properties

Regards,

David Kao

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 4 Apr 2003 08:51:23 -0500

If one of the terms is illegal in terms of the context in question, the MG
should return an error.

Kevin

-----Original Message-----
From: Nurit Shenhar [mailto:[email-masked]] 
Sent: Thursday, April 03, 2003 6:47 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati
on Properties

Kevin

In this case, what should the MG do if one of the terminations defined in
the topology is illegal? (i.e belongs to another context). Should there be
some session of legality check for the topology?

Nurit

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, March 27, 2003 9:54 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati
on Properties

1. Process the TP descriptor, noting that there is a term that will be added
later in the action which will be isolated from all the other existing terms
in the context. 2. Process the Modify T2 command. 3. Process the Add
command, and add the new term.  Note that because the TP descriptor has
ALREADY been processed, the term is added isolated from all other terms in
the context.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, March 27, 2003 1:48 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati
on Properties

Hi Kevin/List,

Processing steps:

Regards,
Chintan...
www.hssworld.com

C=1{TP{$,*,IS},A=${...}

Topology first:

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, March 19, 2003 11:27 PM
To: David Kao
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati
on Properties

Hi,

Regards,
Chintan...

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: David Kao [mailto:[email-masked]]
Sent: Monday, March 17, 2003 10:22 PM
To: [email-masked]
Subject: [Megaco] Processing Order of Context Properties and Termination
Properties

Regards,

David Kao

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 4 Apr 2003 08:51:23 -0500

Kevin

-----Original Message-----
From: Nurit Shenhar [mailto:[email-masked]] 
Sent: Thursday, April 03, 2003 6:47 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati
on Properties

Kevin

Nurit

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, March 27, 2003 9:54 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati
on Properties

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, March 27, 2003 1:48 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati
on Properties

Hi Kevin/List,

Processing steps:

Regards,
Chintan...
www.hssworld.com

C=1{TP{$,*,IS},A=${...}

Topology first:

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, March 19, 2003 11:27 PM
To: David Kao
Cc: [email-masked]
Subject: RE: [Megaco] Processing Order of Context Properties and Terminati
on Properties

Hi,

Regards,
Chintan...

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: David Kao [mailto:[email-masked]]
Sent: Monday, March 17, 2003 10:22 PM
To: [email-masked]
Subject: [Megaco] Processing Order of Context Properties and Termination
Properties

Regards,

David Kao