Subject: [Megaco] AuditReply from MG with no specific context

From: "YAMAMOTO, Susumu" <[email-masked]>
Date: Thu, 17 Apr 2003 13:20:34 +0900

Hi all,

What type of reply message should the MG with no specific context
send back to the MGC, when receiving an AuditValue message with
ContextID=ALL and TerminationID=ROOT ?

I think we may have some choices for that, that is (a) command reply
with the audit list contains no information, (b) command reply contains
no information, and (c) action reply contains no information.

Is there any syntax error in each choice above ?
And which is the best choice from above or any other solutions ?

Thanks,
-Susumu 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "YAMAMOTO, Susumu" <[email-masked]>
Date: Fri, 18 Apr 2003 20:21:43 +0900

Hi.

Could you please give me any suggestion along your implementation for
this issue ?

It seems that every reply should not challenge the megaco standard,
and the error reply of "No TerminationID matched a wildcard" would be
possible.

Thanks in advance,
-Susumu

---

---

From: "YAMAMOTO, Susumu" <[email-masked]>
Date: Fri, 18 Apr 2003 20:21:43 +0900

Hi.

Thanks in advance,
-Susumu

---

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 21 Apr 2003 14:55:33 +0300

Hi,

> and the error reply of "No TerminationID matched a wildcard" would be

I guess you could send that. "Protocol error" would be another option, I'd
say...

Regards,

Christer Holmberg
Ericsson Finland

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 21 Apr 2003 14:55:33 +0300

Hi,

Regards,

Christer Holmberg
Ericsson Finland

---

From: "YAMAMOTO, Susumu" <[email-masked]>
Date: Wed, 23 Apr 2003 18:37:51 +0900

Hi,

Thank you for comments.

This seems rather a minor problem, but we are annoyed by such a kind
of problems whether MGC allow a certain message structure or not.

I think the MGCs should have more capabilities than MGs in actual.

Regards,
-Susumu

---

---

From: "YAMAMOTO, Susumu" <[email-masked]>
Date: Wed, 23 Apr 2003 18:37:51 +0900

Hi,

Thank you for comments.

Regards,
-Susumu

---