Subject: Re: [Megaco] Question about Megaco

From: Tom Taylor <[email-masked]>
Date: Thu, 17 Apr 2003 21:51:15 -0400

I'd say the first request is valid and appropriate.  You don't have to worry about 
the null context, since all terminations are ephemeral.

Majeed Arif-P27336 wrote:
> Tom,
> 
> I sent this question to the forum but no one reply. I will appreciate your comment.
> 
> The MG has "N" number of boards for bearer processing. The "board1" has four active calls (but has capacity to handle "M" number of calls). All terminations on the MG are ephemeral and are structured like "Term/board1/term1" thru "Term/boardn/termM". The "board1" abruptly goes out of service. Which of the following service change command from MG to MGC is more appropriate or even valid? (Suggestions for improvement are welcomed).
> 
> MEGACO/1 [10.1.33.61]: 25000
>    Transaction = 4321 {
>        Context = * { 
>            ServiceChange = Term/board1/* {Services {
>                Method=Forced }
>                }
>         }
>    } 
> 
> 
> MEGACO/1 [10.1.33.61]: 25000
>    Transaction = 4321 {
>        Context = 678 { 
>            ServiceChange = * {Services {
>                Method=Forced }
>                }
>         }
>        Context = 977 { 
>            ServiceChange = * {Services {
>                Method=Forced }
>                }
>         }
>        Context = 1274 { 
>            ServiceChange = * {Services {
>                Method=Forced }
>                }
>         }
>        Context = 170 { 
>            ServiceChange = * {Services {
>                Method=Forced }
>                }
>         }
>    }
> 
> Note: All terminations in a context span within the same board in the above example. However, the above command may not be valid when a context contains terminations, which span through out the ROOT. 
> 
> Arif
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Thu, 17 Apr 2003 21:51:15 -0400