Subject: [Megaco] ADD handling for Out-of-service termination

From: [email-masked]
Date: Thu, 3 Apr 2003 18:15:21 +0530

Hi

I have a query  related to ADD command processing for terminations involving
out-of-service terminations:
      An ADD request is received by an MG to add a termination in a context
which already has a OOS termination.
     Scenario:
     1) A termination added in a Context.
     2) MG operator puts the termination out of service
     3) MG sends Service change Forced to the MGC.
     4) Before MGC receives a ServiceChange, it has sent an ADD request(without
a Topolgy descriptor) to MG to add the termination in the
          above context.
Though it can be argued that MGC will always send substract request whenever it
receives ServiceChange Forced but
does it worth exchanging substract messages when ADD failure could have solved
the problem.
However there can be exception to this scenario where multiple terminations are
in context and only one termination is made OOS. Then
if MGC properly specifies the topology descriptor then ADD command should work.

Regards
venkat

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 4 Apr 2003 08:51:24 -0500

Having an OOS term in a context does NOT preclude addition of another term.

It is clearly stated in the spec that the MGC will subtract the OOS term.
However, if another term is added in the meantime, the MG should do as it is
told, and add the new term into the context.

Also, what does TP have to do with adding a term if one is OOS?  The term
will be subtracted imminently -- I do not see the problem here.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, April 03, 2003 7:45 AM
To: [email-masked]
Subject: [Megaco] ADD handling for Out-of-service termination

Hi

I have a query  related to ADD command processing for terminations involving
out-of-service terminations:
      An ADD request is received by an MG to add a termination in a context
which already has a OOS termination.
     Scenario:
     1) A termination added in a Context.
     2) MG operator puts the termination out of service
     3) MG sends Service change Forced to the MGC.
     4) Before MGC receives a ServiceChange, it has sent an ADD
request(without a Topolgy descriptor) to MG to add the termination in the
          above context.
Though it can be argued that MGC will always send substract request whenever
it receives ServiceChange Forced but does it worth exchanging substract
messages when ADD failure could have solved the problem. However there can
be exception to this scenario where multiple terminations are in context and
only one termination is made OOS. Then if MGC properly specifies the
topology descriptor then ADD command should work.

Regards
venkat

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 4 Apr 2003 08:51:24 -0500

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, April 03, 2003 7:45 AM
To: [email-masked]
Subject: [Megaco] ADD handling for Out-of-service termination

Hi

Regards
venkat