Subject: Re: [Megaco] Megaco CAS support

From: "Michael DiGioia" <[email-masked]>
Date: Tue, 22 Apr 2003 17:01:08 -0400

Christian,

I agree, CAS should be part of the IETF similar to the original MEGACO draft 
work that held both organizations in sync.

/mpd

>From: Aleksandr Ryabin <[email-masked]>
>To: Christian Groves <[email-masked]>, [email-masked]
>CC: Brad Steinka <[email-masked]>
>Subject: Re: [Megaco] Megaco CAS support
>Date: Tue, 22 Apr 2003 10:30:01 -0400
>
>Hi Christian,
>
>Then why are these brand new revisions of drafts were just recently 
>submitted?
>
>http://www.ietf.org/internet-drafts/draft-ietf-megaco-r2package-03.txt
>http://www.ietf.org/internet-drafts/draft-laha-megaco-cas-mntc-00.txt
>
>More over a quick look through reveals that some of the package items in 
>icas
>(ITU) the same as in r2 (IETF) up to the extent of exactly the same 
>wording.
>
>Same AVD-2316 ITU doc mentions "CAS Blocking" package in summary which
>does not seem to be defined in the document and also "conflicts" with above
>IETF "CAS Maintenance Package".
>
>There is also reference to r2 package in AVD-2316 nowhere found in ITU.
>
>Also basic CAS packages draft still available at:
>http://www.ietf.org/internet-drafts/draft-manyfolks-megaco-caspackage-02.txt
>but it is slightly different (outdated?) from AVD-2315 ITU version you have 
>specified.
>
>The recent submission of the above drafts had lead me to believe that CAS
>work is still quite "up and running" in IETF. This is all very confusing.
>When was it decided to move the work to ITU? Could someone point me out
>to some references (in IETF) of that please?
>
>My two cents on this topic: CAS is not an isolated package and in my 
>opinion
>it would be much more productive to keep it on both channels (ITU and IETF)
>and in sync, similar to some other items done so far in H.248/MEGACO.
>What other folks think about it?
>
>Also in any case can the authors of ITU and IETF CAS related packages work
>together to come up with some kind of game plan and post it to the list to 
>avoid
>any further confusion and inconsistencies?
>
>Thanks!
>         Aleks
>
>At 07:54 PM 4/21/2003, Christian Groves wrote:
>>G'Day Brad and Karl,
>>
>>I believe the intention is to move the CAS work into the ITU. The 
>>contributions
>>containing the latest drafts can be found at:
>>ftp://standard.pictel.com/avc-site/0302_San/
>>
>>AVD-2312        MF Tone Generation and Detection Packages
>>AVD-2315        Basic CAS Packages
>>AVD-2316        International CAS Packages
>>AVD-2317        Enhanced Analog Line Packages
>>
>>Regards, Christian
>>
>>Brad Steinka wrote:
>> >
>> > There were several RFC draft document that described various packages 
>>to
>> > support CAS, R1, R2, BCAS, etc.
>> > Most of these drafts have expired.
>> >
>> > Can anyone tell me what the latest RFCs are that support CAS calls and 
>>where
>> > they are in the standards process?
>> >
>> > Thanks
>> >
>> > Brad Steinka
>> > Director - Software Engineering
>> > 734 Forest Street, Building G, Suite 100
>> > Marlboro, Ma.   01752
>> > Tel:  508-480-0909  x154
>> > Email: [email-masked] <mailto:[email-masked]>
>> > Web:   www.telica.com <http://www.telica.com>
>> >
>> > _______________________________________________
>> > Megaco mailing list
>> > [email-masked]
>> > https://www1.ietf.org/mailman/listinfo/megaco
>>_______________________________________________
>>Megaco mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/megaco
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco

_________________________________________________________________
MSN 8 with e-mail virus protection service: 2 months FREE*  
http://join.msn.com/?page=features/virus

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Wed, 23 Apr 2003 10:37:22 +1000

Hello Michael and Aleksandr,

Don't shoot the messenger. I'm simply providing you with the information. I did
not decide to take the work to the ITU it was the authors of the IETF drafts.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Wed, 23 Apr 2003 10:37:22 +1000

Regards, Christian

---

From: "Ranjith Mukundan" <[email-masked]>
Date: Wed, 23 Apr 2003 09:38:53 +0530

progressing some packages on ITU and moving it out from IETF is fine.
But, leaving behind traces of the 'moved work' (or a subset there of) in
any of the WG IDs, esp, without precise citation of the existence of the
duplicate equivalent elsewhere (like the ITU) only adds to the confusion
(compounded by the lack of 'easy' access to ITU plans/charter on the
H.248 packages front).

- ranjith..

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Christian Groves
>Sent: Wednesday, April 23, 2003 6:07 AM
>To: Michael DiGioia
>Cc: [email-masked]; [email-masked]; [email-masked]
>Don't shoot the messenger. I'm simply providing you with the 
>information. I did not decide to take the work to the ITU it 
>was the authors of the IETF drafts.
>
>Regards, Christian
>
>Michael DiGioia wrote:
>> 
>> Christian,
>> 
>> I agree, CAS should be part of the IETF similar to the 
>original MEGACO 
>> draft work that held both organizations in sync.
>> 
>> /mpd
>> 
>> >More over a quick look through reveals that some of the 
>package items 
>> >in icas
>> >Same AVD-2316 ITU doc mentions "CAS Blocking" package in summary 
>> >which does not seem to be defined in the document and also 
>> >"conflicts" with above IETF "CAS Maintenance Package".
>> >
>> >The recent submission of the above drafts had lead me to 
>believe that 
>> >CAS work is still quite "up and running" in IETF. This is all very 
>> >confusing. When was it decided to move the work to ITU? 
>Could someone 
>> >point me out to some references (in IETF) of that please?
>> >
>> >opinion it would be much more productive to keep it on both 
>channels 
>> >(ITU and IETF) and in sync, similar to some other items done so far 
>> >in H.248/MEGACO. What other folks think about it?
>> >
>> >Also in any case can the authors of ITU and IETF CAS 
>related packages 
>> >work together to come up with some kind of game plan and post it to 
>> >the list to avoid any further confusion and inconsistencies?
>> >
>> >Thanks!
>> >         Aleks
>> >
>> >>contributions containing the latest drafts can be found at:
>> >> > [email-masked] https://www1.ietf.org/mailman/listinfo/megaco
>> >>[email-masked] https://www1.ietf.org/mailman/listinfo/megaco
>> >
>> >[email-masked] https://www1.ietf.org/mailman/listinfo/megaco
>>

---

From: "Ranjith Mukundan" <[email-masked]>
Date: Wed, 23 Apr 2003 09:38:53 +0530

- ranjith..