Subject: RE: [Megaco] Restriction on Modification Of Terminations

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 15 Apr 2003 11:53:46 -0400

Clearly this is an error, since, for example, the MG wouldn't want a phone
in a context just to detect off-hook.  Likewise, if that set is currently in
Null and looking for off-hook, then the MGC may wish to stop looking for
off-hook (for any of a number of reasons) by Modifying the term with an
empty Events descriptor.

Any objections to striking the "/modify" portion of the sentence via the IG?

Kevin

-----Original Message-----
From: Taylor, Tom-PT [CAR:5N00:EXCH] 
Sent: Tuesday, April 15, 2003 11:02 AM
To: [email-masked]
Subject: [Megaco] Restriction on Modification Of Terminations

I've just been proof-reading the replacement for RFC 3015 (i.e. H.248.1 v1)
prior to 
its release, and got a slight surprise.  At the end of section 6.2.1 there
is this 
sentence:

"An MGC can only release/modify Terminations
    and the resources that the Termination represents which it has
    previously seized via, e.g., the Add command."

It seems to me this precludes doing Modifies in the NULL context, but I've
seen 
various call flows that do just that.  Should we feed this back to SG 16 as 
something that should be fixed up to conform with practice?

Tom Taylor

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Srinivasan Krishnamoorthy <[email-masked]>
Date: Tue, 15 Apr 2003 13:33:35 -0400 (EDT)

Hi,

What happens in the case where a Handoff to a redundant MGC has
happened, but the contexts where originally created by a 
primary MGC.

So, shouldn't we actually allow Subtracts from the new MGC,
as well then?

Thanks,
-Srini

On Tue, 15 Apr 2003, Kevin Boyle wrote:

kboyle>Clearly this is an error, since, for example, the MG wouldn't want a phone
kboyle>in a context just to detect off-hook.  Likewise, if that set is currently in
kboyle>Null and looking for off-hook, then the MGC may wish to stop looking for
kboyle>off-hook (for any of a number of reasons) by Modifying the term with an
kboyle>empty Events descriptor.
kboyle>
kboyle>Any objections to striking the "/modify" portion of the sentence via the IG?
kboyle>
kboyle>Kevin
kboyle>
kboyle>-----Original Message-----
kboyle>From: Taylor, Tom-PT [CAR:5N00:EXCH] 
kboyle>Sent: Tuesday, April 15, 2003 11:02 AM
kboyle>To: [email-masked]
kboyle>Subject: [Megaco] Restriction on Modification Of Terminations
kboyle>
kboyle>
kboyle>I've just been proof-reading the replacement for RFC 3015 (i.e. H.248.1 v1)
kboyle>prior to 
kboyle>its release, and got a slight surprise.  At the end of section 6.2.1 there
kboyle>is this 
kboyle>sentence:
kboyle>
kboyle>"An MGC can only release/modify Terminations
kboyle>    and the resources that the Termination represents which it has
kboyle>    previously seized via, e.g., the Add command."
kboyle>
kboyle>It seems to me this precludes doing Modifies in the NULL context, but I've
kboyle>seen 
kboyle>various call flows that do just that.  Should we feed this back to SG 16 as 
kboyle>something that should be fixed up to conform with practice?
kboyle>
kboyle>Tom Taylor
kboyle>
kboyle>_______________________________________________
kboyle>Megaco mailing list
kboyle>[email-masked]
kboyle>https://www1.ietf.org/mailman/listinfo/megaco
kboyle>_______________________________________________
kboyle>Megaco mailing list
kboyle>[email-masked]
kboyle>https://www1.ietf.org/mailman/listinfo/megaco
kboyle>

---

From: Srinivasan Krishnamoorthy <[email-masked]>
Date: Tue, 15 Apr 2003 13:33:35 -0400 (EDT)

Hi,

Thanks,
-Srini