Subject: [Megaco] ADD handling for Out-of-service termination

From: [email-masked]
Date: Thu, 3 Apr 2003 18:15:21 +0530

Hi

I have a query  related to ADD command processing for terminations involving
out-of-service terminations:
      An ADD request is received by an MG to add a termination in a context
which already has a OOS termination.
     Scenario:
     1) A termination added in a Context.
     2) MG operator puts the termination out of service
     3) MG sends Service change Forced to the MGC.
     4) Before MGC receives a ServiceChange, it has sent an ADD request(without
a Topolgy descriptor) to MG to add the termination in the
          above context.
Though it can be argued that MGC will always send substract request whenever it
receives ServiceChange Forced but
does it worth exchanging substract messages when ADD failure could have solved
the problem.
However there can be exception to this scenario where multiple terminations are
in context and only one termination is made OOS. Then
if MGC properly specifies the topology descriptor then ADD command should work.

Regards
venkat

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Selvam.V" <[email-masked]>
Date: Fri, 4 Apr 2003 11:31:31 +0530

Hi,
        Is there is a need to send a subtract command.
        what will be the contextID in the subtract command.
        when the Termination is OOS, it will be returning an error for the
ADD
        request.

        Best Regards,
        selva

---

From: "Selvam.V" <[email-masked]>
Date: Fri, 4 Apr 2003 11:31:31 +0530

Hi,

        Best Regards,
        selva