Subject: [Megaco] Re: FW: Request For MIB Review (fwd)

From: "C. M. Heard" <[email-masked]>
Date: Mon, 2 Jun 2003 10:57:01 -0700 (PDT)

Megaco WG,

Bert Wijnen asked me to forward this message to the megaco
mailing list.

Mike

---------- Forwarded message ----------
Date: Mon, 2 Jun 2003 09:13:15 -0700 (PDT)
From: C. M. Heard <[email-masked]>
To: "Wijnen, Bert (Bert)" <[email-masked]>
Cc: "Mreview (E-mail)" <[email-masked]>
Subject: Re: FW: Request For MIB Review

Bert,

I think that the WG should clean this document up before asking a
MIB reviewer to spend time on it.  Even after correcting a bunch of
routine syntax errors (see 2nd attachment) the MIB module does not
even come close to compiling cleanly (see 1st attachment).  It is
clear from inspection that the document has not been checked for
compliance either with http://www.ietf.org/ID-nits.html (e.g., many
lines over 80 characters on the front page ... limit is 72) or with
draft-ietf-ops-mib-review-guidelines-01.txt (e.g., REVISION clauses
don't follow the rules in section 4.5 of that document).  I also see
that requirements information is in the DESCRIPTION clauses of the
OBJECT-GROUP definitions.  As discussed here last week, it does not
belong there (we should probably add something to section 4.8 of the
guidelines doc telling people to put implementation requirements
specs in compliance statements ONLY).

Mike

On Mon, 2 Jun 2003, Wijnen, Bert (Bert) wrote:
> Any volunteers?
> 
> Thanks,
> Bert 
> 
> -----Original Message-----
> From: Tom Taylor [mailto:[email-masked]]
> Sent: maandag 2 juni 2003 15:13
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Request For MIB Review
> 
> 
> The Megaco MIB is about to enter WG Last Call.  Could you supply
> a MIB doctor to review it?  It is available at
> http://www.ietf.org/internet-drafts/draft-ietf-megaco-mib-05.txt
> 
> Thanks,
> Tom Taylor
> [email-masked]
> Megaco WG Chair

Subject: Re: smilint -l 6 -i namelength-32 MEGACO-MIB
From: [email-masked]
To: "C. M. Heard" <[email-masked]>
Date: Mon, 2 Jun 2003 17:49:05 +0200

This is an automatically generated mail message in response to a mail message
you (or someone else who used your address) sent to <[email-masked]>.
If you want to learn more about this mail service, send a mail message with
the "Subject: help" to <[email-masked]>.

This command (smilint 0.4.2-pre1, as of Mon May 19 16:33:46 2003)
has been processed to get the following results:
smilint -m -s -l 6 -i namelength-32 MEGACO-MIB

MEGACO-MIB:62: [5] {date-year-2digits} warning: date specification `0003201200Z' contains a two-digit year representing `1900'
MEGACO-MIB:62: [2] {date-value} date specification `0003201200Z' contains an illegal value
MEGACO-MIB:147: [5] {integer-misuse} warning: use Integer32 instead of INTEGER in SMIv2
MEGACO-MIB:353: [4] {hyphen-in-label} warning: named number `dss1-ip' must not include a hyphen in SMIv2
MEGACO-MIB:891: [4] {hyphen-in-label} warning: named number `in-Service' must not include a hyphen in SMIv2
MEGACO-MIB:892: [4] {hyphen-in-label} warning: named number `out-Of-Service' must not include a hyphen in SMIv2
MEGACO-MIB:1144: [3] {notification-object-access} object `medGwyTerminationId' of notification `medGwyInvalidTerminationId' must not be `not-accessible'
MEGACO-MIB:1171: [1] {} unknown object identifier label `medGwyTerminationStatus'
MEGACO-MIB:1173: [1] {} unknown object identifier label `medGwyTerminationTestStatus'
MEGACO-MIB:1169: [3] {notification-object-type} object `medGwyTerminationStatus' of notification `medGwyTerminationStatusChange' must be a scalar or column
MEGACO-MIB:1169: [3] {notification-object-type} object `medGwyTerminationTestStatus' of notification `medGwyTerminationStatusChange' must be a scalar or column
MEGACO-MIB:1179: [3] {notification-object-access} object `medGwyGatewayId' of notification `medGwyGatewayHandoff' must not be `not-accessible'
MEGACO-MIB:1179: [3] {notification-object-access} object `medGwyGatewayControllerId' of notification `medGwyGatewayHandoff' must not be `not-accessible'
MEGACO-MIB:1190: [3] {notification-object-access} object `medGwyTerminationId' of notification `medGwyProtocolError' must not be `not-accessible'
MEGACO-MIB:449: [4] {group-membership} warning: node `medGwyGatewayRowStatus' must be contained in at least one conformance group
MEGACO-MIB:878: [4] {group-membership} warning: node `medGwyTerminationName' must be contained in at least one conformance group
MEGACO-MIB:888: [4] {group-membership} warning: node `medGwyTerminationAdminStatus' must be contained in at least one conformance group
MEGACO-MIB:909: [4] {group-membership} warning: node `medGwyTerminationOperStatus' must be contained in at least one conformance group
MEGACO-MIB:930: [4] {group-membership} warning: node `medGwyTerminationInterfaceIdentifier' must be contained in at least one conformance group
MEGACO-MIB:940: [4] {group-membership} warning: node `medGwyTerminationPropertyProfileId' must be contained in at least one conformance group
MEGACO-MIB:950: [4] {group-membership} warning: node `medGwyTerminationRowStatus' must be contained in at least one conformance group
MEGACO-MIB:1042: [4] {group-membership} warning: node `medGwyPropertyProfileProperty' must be contained in at least one conformance group
MEGACO-MIB:1052: [4] {group-membership} warning: node `medGwyTermPropertyProfileStatus' must be contained in at least one conformance group
MEGACO-MIB:1113: [4] {group-membership} warning: node `medGwyReceivedElement' must be contained in at least one conformance group
*** MEGACO-MIB~	Mon Jun  2 08:14:08 2003
--- MEGACO-MIB	Mon Jun  2 08:48:16 2003
***************
*** 8,14 ****
  
  IMPORTS
       MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE,
!      Integer32, IpAddress, Unsigned32
               FROM SNMPv2-SMI
  
       TEXTUAL-CONVENTION,
--- 8,14 ----
  
  IMPORTS
       MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE,
!      Integer32, IpAddress, Unsigned32, mib-2
               FROM SNMPv2-SMI
  
       TEXTUAL-CONVENTION,
***************
*** 352,359 ****
                   other        (2),  -- Other (none from the list below)
                   dss1-ip      (3),  -- Q931+
                   ipdc         (4),  -- IPDC
!                  megacov1     (5)   -- MEGACO/H.248 Version 1
!                  megacov2     (6)   -- MEGACO/H.248 Version 2
                   mgcp         (7)   -- MGCP
                 }
      MAX-ACCESS  read-create
--- 352,359 ----
                   other        (2),  -- Other (none from the list below)
                   dss1-ip      (3),  -- Q931+
                   ipdc         (4),  -- IPDC
!                  megacov1     (5),  -- MEGACO/H.248 Version 1
!                  megacov2     (6),  -- MEGACO/H.248 Version 2
                   mgcp         (7)   -- MGCP
                 }
      MAX-ACCESS  read-create
***************
*** 364,372 ****
  medGwyGatewaySignalingTptProtocol OBJECT-TYPE
      SYNTAX     INTEGER
                 {
!                  TCP          (1),
!                  UDP          (2),
!                  SCTP         (3),
                   other        (4)
                 }
      MAX-ACCESS  read-create
--- 364,372 ----
  medGwyGatewaySignalingTptProtocol OBJECT-TYPE
      SYNTAX     INTEGER
                 {
!                  tcp          (1),
!                  udp          (2),
!                  sctp         (3),
                   other        (4)
                 }
      MAX-ACCESS  read-create
***************
*** 401,407 ****
               up     (1),   -- ready to communicate with MGC
               down   (2),
               testing(3),   -- in some test mode
!              unknown(4),   -- status can not be determined
                         -- for some reason.
                 }
      MAX-ACCESS  read-only
--- 401,407 ----
               up     (1),   -- ready to communicate with MGC
               down   (2),
               testing(3),   -- in some test mode
!              unknown(4)    -- status can not be determined
                         -- for some reason.
                 }
      MAX-ACCESS  read-only
***************
*** 485,500 ****
  --       The relationship can be, for example, as follows:
  --
  --      MediaGatewayId                       medGwyGatewayControllerId
! --       +----------+   medGwyGatewayLinkId   +----------+
! --       |      mg1 |----------->------------>|     mgc1 |
! --       | +----------+          |            | +----------+
! --       | |      mg2 |          +------------->|     mgc2 |
! --       | | +----------+                     | | +----------+
! --       +-| |      mg3 |----------->---------->| |    mgc3  |
  --         | |          |            |          | |          |
! --         +-|          |            +----------->|          |
  --           |          |                         |          |
! --           +----------+                         +----------+
  --
  -- *****************************************************************
  
--- 485,500 ----
  --       The relationship can be, for example, as follows:
  --
  --      MediaGatewayId                       medGwyGatewayControllerId
! --       +-~-~-~-~-~+   medGwyGatewayLinkId   +~-~-~-~-~-+
! --       |      mg1 |~-~-~-~-~-~>~-~-~-~-~-~->|     mgc1 |
! --       | +-~-~-~-~-~+          |            | +~-~-~-~-~-+
! --       | |      mg2 |          +~-~-~-~-~-~-~>|     mgc2 |
! --       | | +~-~-~-~-~-+                     | | +~-~-~-~-~-+
! --       +-| |      mg3 |~-~-~-~-~-~>~-~-~-~-~->| |    mgc3  |
  --         | |          |            |          | |          |
! --         +-|          |            +~-~-~-~-~-~>|          |
  --           |          |                         |          |
! --           +~-~-~-~-~-+                         +~-~-~-~-~-+
  --
  -- *****************************************************************
  
***************
*** 521,528 ****
      medGwyGatewayControllerId             Unsigned32,         -- ro
      medGwyGatewayControllerIPAddress      IpAddress,          -- rw
      medGwyGatewayControllerPort           Integer32,          -- rw
!     medGwyGatewayControllerAdminStatus    INTEGER             -- rw
!     medGwyGatewayControllerOperStatus     INTEGER,            -- ro
  }
  
  medGwyGatewayControllerId OBJECT-TYPE
--- 521,528 ----
      medGwyGatewayControllerId             Unsigned32,         -- ro
      medGwyGatewayControllerIPAddress      IpAddress,          -- rw
      medGwyGatewayControllerPort           Integer32,          -- rw
!     medGwyGatewayControllerAdminStatus    INTEGER,            -- rw
!     medGwyGatewayControllerOperStatus     INTEGER             -- ro
  }
  
  medGwyGatewayControllerId OBJECT-TYPE
***************
*** 1245,1251 ****
      MANDATORY-GROUPS
      {
          medGwyConfigGroup,
!         medGwyStatsGroup,
      }
  
      GROUP medGwyGWControllerGroup
--- 1245,1251 ----
      MANDATORY-GROUPS
      {
          medGwyConfigGroup,
!         medGwyStatsGroup
      }
  
      GROUP medGwyGWControllerGroup

---

From: "C. M. Heard" <[email-masked]>
Date: Mon, 2 Jun 2003 10:57:01 -0700 (PDT)

Megaco WG,

Mike

---------- Forwarded message ----------
Date: Mon, 2 Jun 2003 09:13:15 -0700 (PDT)
From: C. M. Heard <[email-masked]>
To: "Wijnen, Bert (Bert)" <[email-masked]>
Cc: "Mreview (E-mail)" <[email-masked]>
Subject: Re: FW: Request For MIB Review

Bert,

Mike

  
  IMPORTS
  
       TEXTUAL-CONVENTION,
--- 8,14 ----
  
  IMPORTS
  
       TEXTUAL-CONVENTION,
***************
*** 352,359 ****
  
--- 485,500 ----
  
***************
*** 521,528 ****