Subject: [Megaco] FW: +AFs-Megaco+AF0- GW Response for package info

From: "FND-AD Wang JuLin" <[email-masked]>
Date: Fri, 13 Jun 2003 09:10:13 +0800

TDM Circuit Package is used to support TDM circuit terminations.So when it was used for rtp termination,error will be triggered. Our stack report 501 "Not implement" error in such case.

-----Original Message-----
From: Nagalakshmi H.G [mailto:[email-masked]]
Sent: Thursday, June 12, 2003 8:14 PM
To: [email-masked]
Subject: [Megaco] GW Response for package info

Hi All,
 
 A GW's response to the package is different when it is sent on the ephemeral compared to when sent on the physical termination.
 
 !/1 [10.104.1.24]:2944 T=65662{C=${A=${M{O{MO=SR,xconn/phys=E1/04/06/3,tdmc/gain=2},L{v=0
c=IN IP4 $
m=audio $ RTP/AVP 8 0
a=ptime:10
}}}}}

!/1 [10.104.21.2]:2944
P = 65662 {
        C = $ {
                A = $ {
                        ER = 442 {}; The package tdmc cannot be used for a IP termination
                }
        }
}

 But when tdmc/gain is sent on the physical , the GW does not send out a 442. 
 
 Is this a desired behaviour out of a GW ? Does Megaco speak anything about this varied response from the GW for the same package information sent (ie., based on which termination it is sent on ) ?  
 
 Appreciate your response on the same.
 
Thanks,
Nagalakshmi.

---

From: "FND-AD Wang JuLin" <[email-masked]>
Date: Fri, 13 Jun 2003 09:10:13 +0800

-----Original Message-----
From: Nagalakshmi H.G [mailto:[email-masked]]
Sent: Thursday, June 12, 2003 8:14 PM
To: [email-masked]
Subject: [Megaco] GW Response for package info

Hi All,

!/1 [10.104.21.2]:2944
P = 65662 {
        C = $ {
                A = $ {

 
 
Thanks,
Nagalakshmi.

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 13 Jun 2003 11:28:35 -0400

Actually, TDMC can apply to any termination that could support ecan and
gain.  It would depend on the implementation.
 
Quoting from H.248.1, Annex E.13:
 
"This package may be used by any termination that supports gain and echo
control. It was originally intended for use on TDM circuits but may be more
widely used.

New versions or extensions of this package should take non-TDM use into
account."

Further, I don't believe 501 would be the appropriate error code.  If a
termination doesn't support a package, wouldn't 440 ("Unsupported or Unknown
Package") be more appropriate?

Kevin

-----Original Message-----
From: FND-AD Wang JuLin [mailto:[email-masked]] 
Sent: Thursday, June 12, 2003 9:10 PM
To: Gireesh, Nagalakshmi [Business:WBNG:WT43]
Cc: [email-masked]
Subject: [Megaco] FW: +AFs-Megaco+AF0- GW Response for package info

TDM Circuit Package is used to support TDM circuit terminations.So when it
was used for rtp termination,error will be triggered. Our stack report 501
"Not implement" error in such case.

-----Original Message-----
From: Nagalakshmi H.G [mailto:[email-masked]]
Sent: Thursday, June 12, 2003 8:14 PM
To: [email-masked]
Subject: [Megaco] GW Response for package info

Hi All,
 
 A GW's response to the package is different when it is sent on the
ephemeral compared to when sent on the physical termination.
 
 !/1 [10.104.1.24]:2944
T=65662{C=${A=${M{O{MO=SR,xconn/phys=E1/04/06/3,tdmc/gain=2},L{v=0
c=IN IP4 $
m=audio $ RTP/AVP 8 0
a=ptime:10
}}}}}

!/1 [10.104.21.2]:2944
P = 65662 {
        C = $ {
                A = $ {
                        ER = 442 {}; The package tdmc cannot be used for a
IP termination
                }
        }
}

 But when tdmc/gain is sent on the physical , the GW does not send out a
442. 
 
 Is this a desired behaviour out of a GW ? Does Megaco speak anything about
this varied response from the GW for the same package information sent (ie.,
based on which termination it is sent on ) ?  

Thanks,
Nagalakshmi.   

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 13 Jun 2003 11:28:35 -0400

Kevin

-----Original Message-----
From: Nagalakshmi H.G [mailto:[email-masked]]
Sent: Thursday, June 12, 2003 8:14 PM
To: [email-masked]
Subject: [Megaco] GW Response for package info

Hi All,

 !/1 [10.104.1.24]:2944

!/1 [10.104.21.2]:2944
P = 65662 {
        C = $ {
                A = $ {

 
 
Thanks,
Nagalakshmi.