Subject: [Megaco] Max # signals in a Sequential signal list

From: Venkata Narasimha Murthy Nanduri <[email-masked]>
Date: Thu, 19 Jun 2003 17:00:18 -0700

Hi,

What can be the maximum number of signals in a Sequential signal list?

If RFC does not mention about the maximum number of signals in a list,
Can MG restrict the Maximum number of signals that it can handle in a list?

In practical scenarios, what will be the number of signals in a Sequential 
signal list?

Thanks
Venkata

Venkata Nanduri
[]

Software Engineer
Voice Gateway and Dial BU
3850 Zanker Road,
Building 1
San jose - 95134
USA

Tel: 408 853 8235
Fax: 408 525 0640
e-mail: [email-masked]

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 20 Jun 2003 13:16:36 -0400

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: Venkata Narasimha Murthy Nanduri [mailto:[email-masked]] 
Sent: Thursday, June 19, 2003 8:00 PM
To: [email-masked]
Subject: [Megaco] Max # signals in a Sequential signal list

Hi,

What can be the maximum number of signals in a Sequential signal list?
[KJBII] The protocol does not put any limit on the number of signals in a
SignalList.

If RFC does not mention about the maximum number of signals in a list, Can
MG restrict the Maximum number of signals that it can handle in a list?
[KJBII] If an MG cannot execute a given command for any reason, it should
return an Error Descriptor.  This would include receiving a SignalList that
is too large for the MG to handle.

In practical scenarios, what will be the number of signals in a Sequential 
signal list?
[KJBII] That would depend entirely upon what applications are supported by
the MGC and MG.

Thanks
Venkata

Venkata Nanduri
[]

Software Engineer

Tel: 408 853 8235
Fax: 408 525 0640

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 20 Jun 2003 13:16:36 -0400

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: Venkata Narasimha Murthy Nanduri [mailto:[email-masked]] 
Sent: Thursday, June 19, 2003 8:00 PM
To: [email-masked]
Subject: [Megaco] Max # signals in a Sequential signal list

Hi,

Thanks
Venkata

Venkata Nanduri
[]

Software Engineer

Tel: 408 853 8235
Fax: 408 525 0640

---

From: Venkata Narasimha Murthy Nanduri <[email-masked]>
Date: Fri, 20 Jun 2003 11:31:46 -0700

Hi Kevin,

Thanks for your response.

Please see inline..[VN]

>is too large for the MG to handle.

[VN] Does the standard has a error code defined for this purpose? If so, 
can you please
point me to that?

>[KJBII] That would depend entirely upon what applications are supported by

[VN] Can you please give some examples of applications and how the 
Sequential signal will be used in each case.
That will really help me understand the way Sequential signal lists will be 
used in different applications.

Thank you very much
Venkata

Venkata Nanduri
[]

Software Engineer

Tel: 408 853 8235
Fax: 408 525 0640

---

From: Venkata Narasimha Murthy Nanduri <[email-masked]>
Date: Fri, 20 Jun 2003 11:31:46 -0700

Hi Kevin,

Please see inline..[VN]

Thank you very much
Venkata

Venkata Nanduri
[]

Software Engineer

Tel: 408 853 8235
Fax: 408 525 0640