Subject: [Megaco] v2 mismatch ABNF & ASN.1 IndAudmediaParm?

From: Micael Karlberg <[email-masked]>
Date: Mon, 16 Jun 2003 15:54:20 +0200

Hi,

In draft-ietf-megaco-h248v2-04.txt there appear to be a mismatch
between the ABNF and the ASN.1 regarding indAudmediaDescriptor.
My question is: Should the definition of ABNF indAudmediaDescriptor
really be:

      indAudmediaDescriptor   = MediaToken LBRKT indAudmediaParm
                                *(COMMA indAudmediaParm) RBRKT 

The comment for indAudmediaParm and the ASN.1 IndAudMediaDescriptor 
indicates that it should be a list. Or am I missing something?

Also, see definition of mediaDescriptor!

ABNF:
----
      indAudmediaDescriptor   = MediaToken LBRKT indAudmediaParm RBRKT 
       
      ; at-most-once per item 
      ; and either streamParm or streamDescriptor but not both 
      indAudmediaParm = (indAudstreamParm / indAudstreamDescriptor /  
                         indAudterminationStateDescriptor) 

ASN.1:
-----
      IndAudMediaDescriptor ::= SEQUENCE 
      { 
          
         termStateDescr    IndAudTerminationStateDescriptor OPTIONAL, 
         streams  CHOICE 
               { 
                  oneStream      IndAudStreamParms, 
                  multiStream    SEQUENCE OF IndAudStreamDescriptor 
               } OPTIONAL, 
         ... 
      } 

Regards,
	/BMK

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 17 Jun 2003 14:18:28 -0400

I have to concur with Christian... I don't see the problem.  Is there
something in particular that you don't see represented in one encoding that
is in the other?

Kevin

-----Original Message-----
From: Christian Groves [mailto:[email-masked]] 
Sent: Monday, June 16, 2003 8:59 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] v2 mismatch ABNF & ASN.1 IndAudmediaParm?

Hello Micael,

I don't understand what the problem is nor the comments in the ASN.1 you are
referring to? If you are referring to the ::= SEQUENCE this is actually an
ASN.1 construct that says that a sequence of information elements may be
encoded, in this case "termStateDescr" & a choice of streams. This same
information is represented by the ABNF.

Regards, Christian

Micael Karlberg wrote:
> between the ABNF and the ASN.1 regarding indAudmediaDescriptor. My 
> question is: Should the definition of ABNF indAudmediaDescriptor 
> really be:
>

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 17 Jun 2003 14:18:28 -0400

Kevin

-----Original Message-----
From: Christian Groves [mailto:[email-masked]] 
Sent: Monday, June 16, 2003 8:59 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] v2 mismatch ABNF & ASN.1 IndAudmediaParm?

Hello Micael,

Regards, Christian

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 17 Jun 2003 15:30:14 -0400

Aha... I see the problem now.  In binary, you can request info about several
streams at once, but you may only request info about one stream in text.  Is
this an accurate summary?

Seeing as this would be a syntax change, we need to know if anyone would
have major heartburn over changing the syntax to fix this.  If not, I will
draft up an IG item to fix this...

Speaking personally, I think this is a beneficial change, because it makes
the syntax align between the expression of items within the media
descriptor, and the audit of items within the media descriptor, as well as
making both binary and text align in capability.

Any other comments?

Kevin

-----Original Message-----
From: Micael Karlberg [mailto:[email-masked]] 
Sent: Tuesday, June 17, 2003 1:26 PM
To: Christian Groves
Cc: [email-masked]
Subject: Re: [Megaco] v2 mismatch ABNF & ASN.1 IndAudmediaParm?

Hello Christian,

Christian Groves writes:
 > Hello Micael,
 > 
 > I don't understand what the problem is nor the comments in the ASN.1 you
are  > referring to? 

The comment ("at-most-once per item...") is in the ABNF.

 > If you are referring to the ::= SEQUENCE this is actually an ASN.1  >
construct that says that a sequence of information elements may be encoded,
in  > this case "termStateDescr" & a choice of streams. 

This is how see it also.

 > This same information is represented by the ABNF.

This I _cannot_ find!

The comment in the ABNF seems to indicate that it should be as in 
the ASN.1 but the ABNF definition of the indAudmediaDescriptor 
allow for only one value of indAudmediaParm.

Therefor my _question_ if the definition should'nt really be:

Also, the defintion of the mediaDescriptor strikes me as _very_ similar to
my "proposal":

      mediaDescriptor = MediaToken LBRKT mediaParm 
                        *(COMMA mediaParm) RBRKT 
       
      ; at-most one terminationStateDescriptor 
      ; and either streamParm(s) or streamDescriptor(s) but not both 
      mediaParm = (streamParm / streamDescriptor /  
                    terminationStateDescriptor) 

Regards,
	/BMK

 > 
 > Regards, Christian
 > 
 > Micael Karlberg wrote:
 > > 
 > > Hi,
 > > 
 > > In draft-ietf-megaco-h248v2-04.txt there appear to be a mismatch  > >
between the ABNF and the ASN.1 regarding indAudmediaDescriptor.  > > My
question is: Should the definition of ABNF indAudmediaDescriptor  > > really
be:  > > 
 > > The comment for indAudmediaParm and the ASN.1 IndAudMediaDescriptor  >
> indicates that it should be a list. Or am I missing something?  > > 

-- 
Micael Karlberg          Ericsson AB, Älvsjö Sweden
Tel:  +46 8 727 5668     EAB/UHK/KD - OTP Product Development
ECN:  851 5668           Mail: [email-masked]
Fax:  +46 8 727 5775

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 17 Jun 2003 21:19:09 -0400

Hi,

While we are on topic. The following does not allow auditing for the whole
local or remote SDP in ABNF:
         ; at-most-once
         indAudstreamParm = ( indAudlocalControlDescriptor )
         ; SDP too complex to pull out individual pieces for audit,
         ; hence no individual audit for Local and Remote

The question is why? I mean why does not it allow to audit *whole*
local or remote SDP? E.g.:
         indAudstreamParm = ( indAudlocalControlDescriptor / LocalToken / 
RemoteToken)

BTW ASN.1 does allow that, as well as individual pieces of SDPs.

Thanks
         Aleks

PS. Small nit in indAudauditReturnParameter (two slashes at the end):
       indAudauditReturnParameter = (indAudmediaDescriptor / /