Subject: [Megaco] GW Response for package info

From: "Nagalakshmi H.G" <[email-masked]>
Date: Thu, 12 Jun 2003 17:43:55 +0530

Hi All,
 
 A GW's response to the package is different when it is sent on the
ephemeral compared to when sent on the physical termination.
 
 !/1 [10.104.1.24]:2944
T=65662{C=${A=${M{O{MO=SR,xconn/phys=E1/04/06/3,tdmc/gain=2},L{v=0
c=IN IP4 $
m=audio $ RTP/AVP 8 0
a=ptime:10
}}}}}

!/1 [10.104.21.2]:2944
P = 65662 {
        C = $ {
                A = $ {
                        ER = 442 {}; The package tdmc cannot be used for
a IP termination
                }
        }
}

 But when tdmc/gain is sent on the physical , the GW does not send out a
442. 
 
 Is this a desired behaviour out of a GW ? Does Megaco speak anything
about this varied response from the GW for the same package information
sent (ie., based on which termination it is sent on ) ?  
 
 Appreciate your response on the same.
 
Thanks,
Nagalakshmi.

---

From: "Anil Jangam" <[email-masked]>
Date: Fri, 13 Jun 2003 10:50:15 +0530

MessageHi Lakshmi,

If you see the description of the 'tdmc' package, its mentioned that 'tdmc' package was originally intended to use for the TDM circuits, but my be more widely used. It also mentions that derivatives of this package should be applicable for the non-TDM circuits as well.

With this sight, reporting the some error code when applied the above property (tdmc/gain) to the 'Ephemeral' termination is normal. But the error code which you have returned (442) is not correct. The meaning of 442 is different (442 talks about syntax error). More appropriate error code you should return is 445 (see the details of 445).

hope it helps.
/anil.

  ----- Original Message ----- 
  From: Nagalakshmi H.G 
  To: [email-masked] 
  Sent: Thursday, June 12, 2003 5:59 PM
  Subject: [Megaco] GW Response for package info

  Hi All,

   A GW's response to the package is different when it is sent on the ephemeral compared to when sent on the physical termination.

   !/1 [10.104.1.24]:2944 T=65662{C=${A=${M{O{MO=SR,xconn/phys=E1/04/06/3,tdmc/gain=2},L{v=0
  c=IN IP4 $
  m=audio $ RTP/AVP 8 0
  a=ptime:10
  }}}}}

  !/1 [10.104.21.2]:2944
  P = 65662 {
          C = $ {
                  A = $ {
                          ER = 442 {}; The package tdmc cannot be used for a IP termination
                  }
          }
  }

   But when tdmc/gain is sent on the physical , the GW does not send out a 442. 

   Is this a desired behaviour out of a GW ? Does Megaco speak anything about this varied response from the GW for the same package information sent (ie., based on which termination it is sent on ) ?  

  Thanks,
  Nagalakshmi.   

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************

Visit us at http://www.mahindrabt.com

---

From: "Anil Jangam" <[email-masked]>
Date: Fri, 13 Jun 2003 10:50:15 +0530

MessageHi Lakshmi,

hope it helps.
/anil.

  ----- Original Message ----- 
  From: Nagalakshmi H.G 
  To: [email-masked] 
  Sent: Thursday, June 12, 2003 5:59 PM
  Subject: [Megaco] GW Response for package info

  Hi All,

  !/1 [10.104.21.2]:2944
  P = 65662 {
          C = $ {
                  A = $ {

  Thanks,
  Nagalakshmi.