Subject: RE: [Megaco] SDP mode and Megaco mode question

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 9 Dec 2003 18:11:35 -0500

I don't see that the MGC has to parse SDP.  I think the mode in the SDP
could be used as a suggestion, but the MGC will certainly know whether or
not it wants the media stream flowing.  That is to say, what the MGC wants
trumps what the far-end wants.

Kevin 

-----Original Message-----
From: Pascal Lambers [mailto:[email-masked]] 
Sent: Monday, December 08, 2003 5:39 PM
To: [email-masked]
Subject: Re: [Megaco] SDP mode and Megaco mode question

It would of course be interesting to know what most gateways currently do
with the "a=..." SDP mode parameter: will they deny it, even if no other
mode has been set? Are there some gateway experts reading this discussion?

I do see Christian's point here: the context prevails. You could look at the
context as as a shell around the RTP(s) it contains.

The annoying consequence is that a MGC which must talk to a Megaco MG has to
start parsing the SDP block. If  a MGC receives a message for its MG from,
say, another MGC, it has to translate the SDP mode to a local control
mode...

Kind regards,
Pascal

----- Original Message -----
From: "Christian Groves" <[email-masked]>
To: "Madhubabu Brahmanapally" <[email-masked]>
Cc: "Pascal Lambers" <[email-masked]>; "Tom Taylor"
<[email-masked]>; <[email-masked]>
Sent: Monday, December 08, 2003 10:45 PM
Subject: Re: [Megaco] SDP mode and Megaco mode question

> Hello Madhubabu,
>
> The text I proposed below was:
> "The local control mode property takes precedence over the local and
remote
> descriptors."
>
> The local control mode property will always be set as it defaults to
"inactive".
> So as the local control mode property is set it always takes precedence.
>
> Christian
>
> Madhubabu Brahmanapally wrote:
>
> > Hi Christian,
> > Does the Local control mode property takes precedence or as Tom pointed
> > out, does the MG always disregard the mode in local/remote descriptors??
> >
> > Regards
> > Madhubabu
> >
> > -----Original Message-----
> > From: Christian Groves [mailto:[email-masked]]
> > Sent: Sunday, December 07, 2003 8:56 PM
> > To: Pascal Lambers
> > Cc: Tom Taylor; Madhubabu Brahmanapally; [email-masked]
> > Subject: Re: [Megaco] SDP mode and Megaco mode question
> >
> >
> > Hello Pascal,
> >
> > I think you have pointed out an issue for the Implementors' Guide. This
> > fact
> > that the Local Control Mode overrides the SDP is common practise the
only
> > problem is that it is not clearly stated.
> >
> > I would propose that :
> > 7.1.7   LocalControl descriptor
> > ...
> > The allowed values for the mode property are send-only, receive-only,
> > send/receive, inactive and loop-back. "Send" and "receive" are with
> > respect to
> > the exterior of the Context, so that, for example, a stream set to mode
=
> > sendOnly does not pass received media into the Context. The default
> > value for
> > the mode property is "Inactive". Signals and Events are not affected by
> > mode.
> >  >>> The local control mode property takes precedence over the local and
> > remote
> > descriptors.<<<
> > ...
> >
> > Regards, Christian
> >
> > Pascal Lambers wrote:
> >
> >  > So would I, but isn't there any RFC statement to enforce this
opinion?
> >  >
> >  > Pascal
> >  >
> >  >
> >  > ----- Original Message -----
> >  > From: "Tom Taylor" <[email-masked]>
> >  > To: "Madhubabu Brahmanapally" <[email-masked]>
> >  > Cc: "'Pascal Lambers'" <[email-masked]>; <[email-masked]>
> >  > Sent: Friday, December 05, 2003 12:31 AM
> >  > Subject: Re: [Megaco] SDP mode and Megaco mode question
> >  >
> >  >
> >  >
> >  >>I would put it bluntly that the MG must ignore mode in the SDP.
> >  >>
> >  >>Madhubabu Brahmanapally wrote:
> >  >>
> >  >>
> >  >>>The Local Control Descriptor has high precedence over the SDP
> >  >>>information....
> >  >>>
> >  >>>    -----Original Message-----
> >  >>>    *From:* Pascal Lambers [mailto:[email-masked]]
> >  >>>    *Sent:* Thursday, December 04, 2003 3:05 PM
> >  >>>    *To:* [email-masked]
> >  >>>    *Subject:* [Megaco] SDP mode and Megaco mode question
> >  >>>
> >  >>>    Hello,
> >  >>>
> >  >>>    Don't know precisely how to forumulate this question clearly, so
> > let
> >  >>>    me put in in two different ways...
> >  >>>
> >  >>>    What does a MG have to do if an MGC sends a Modify with:
> >  >>>    - the Mode property of the LocalControl descriptor set to, for
> >  >>>    instance, receive-only;
> >  >>>    - a Local/Remote Descriptor with an SDP-block containing an
> >  >>>    "a=sendrecv" parameter?
> >  >>>
> >  >>>    In other words, what is the relation beween the a=sendrecv,
> >  >>>    a=sendonly, a=inactive, a=recvonly parameters of the SDP
protocol
> >  >>>    and the Mode property of the LocalControl descriptor in the
Megaco
> >  >>>    protocol?
> >  >>>
> >  >>>
> >  >>>    Can sb give some advise? Thanks!
> >  >>>    Pascal
> >  >>>
> >  >>>
> >  >>
> >  >>
> >  >>_______________________________________________
> >  >>Megaco mailing list
> >  >>[email-masked]
> >  >>https://www1.ietf.org/mailman/listinfo/megaco
> >  >>
> >  >>
> >  >>
> >  >
> >  >
> >  >
> >  >
> >  > _______________________________________________
> >  > Megaco mailing list
> >  > [email-masked]
> >  > https://www1.ietf.org/mailman/listinfo/megaco
> >  >
> >
>
>
>
>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Pascal Lambers" <[email-masked]>
Date: Thu, 11 Dec 2003 00:01:48 +0100

RE: [Megaco] SDP mode and Megaco mode questionI do think it's unavoidable for a MGC to parse the SDP...

For example, you can have MGC1 (controlling a Megaco GW + a black phone) talking to MGC2 (controlling a Sip GW + Sip Phone). Now, If the Sip phone starts doing some more complex operations it might want the Megaco side, controlled by MGC1, to change Mode. And that's exactly where the MGC2 has to parse the SDP block to make sure that it can send a LocalControlDescriptor to its Megaco gateway. Because the a=... parameter in the SDP block from the sip-side will be of no use to the Megaco GW.

Moreover, the SDP parameters o,s and t, optional according to the Megaco RFC but mandatory according to the SDP RFC, cause the same problem...

Pascal

  ----- Original Message ----- 
  From: Kevin Boyle 
  To: Pascal Lambers ; [email-masked] 
  Sent: Wednesday, December 10, 2003 12:11 AM
  Subject: RE: [Megaco] SDP mode and Megaco mode question

  I don't see that the MGC has to parse SDP.  I think the mode in the SDP could be used as a suggestion, but the MGC will certainly know whether or not it wants the media stream flowing.  That is to say, what the MGC wants trumps what the far-end wants.

  Kevin 

  -----Original Message----- 
  From: Pascal Lambers [mailto:[email-masked]] 
  Sent: Monday, December 08, 2003 5:39 PM 
  To: [email-masked] 
  Subject: Re: [Megaco] SDP mode and Megaco mode question 

  It would of course be interesting to know what most gateways currently do with the "a=..." SDP mode parameter: will they deny it, even if no other mode has been set? Are there some gateway experts reading this discussion?

  I do see Christian's point here: the context prevails. You could look at the context as as a shell around the RTP(s) it contains.

  The annoying consequence is that a MGC which must talk to a Megaco MG has to start parsing the SDP block. If  a MGC receives a message for its MG from, say, another MGC, it has to translate the SDP mode to a local control mode...

  Kind regards, 
  Pascal 

  ----- Original Message ----- 
  From: "Christian Groves" <[email-masked]> 
  To: "Madhubabu Brahmanapally" <[email-masked]> 
  Cc: "Pascal Lambers" <[email-masked]>; "Tom Taylor" 
  <[email-masked]>; <[email-masked]> 
  Sent: Monday, December 08, 2003 10:45 PM 
  Subject: Re: [Megaco] SDP mode and Megaco mode question 

  remote 
  "inactive". 
  only 
  = 
  opinion? 
  protocol 
  Megaco

---

From: Troy Cauble <[email-masked]>
Date: Wed, 10 Dec 2003 18:09:22 -0500

Pascal Lambers wrote:

> 
> I do think it's unavoidable for a MGC to parse the SDP...
>  
> For example, you can have MGC1 (controlling a Megaco GW + a black phone) 
> talking to MGC2 (controlling a Sip GW + Sip Phone). Now, If the Sip 
> phone starts doing some more complex operations it might want the Megaco 
> side, controlled by MGC1, to change Mode. And that's exactly where the 
> MGC2 has to parse the SDP block to make sure that it can send a 
> LocalControlDescriptor to its Megaco gateway. Because the a=... 
> parameter in the SDP block from the sip-side will be of no use to the 
> Megaco GW.
>  
> Moreover, the SDP parameters o,s and t, optional according to the Megaco 
> RFC but mandatory according to the SDP RFC, cause the same problem...
>  
> Pascal

Well that's not just a MGC is it?  It's interworking.
The SIP proxy portion is the reason for parsing the SDP.

A logical (pure) H.248 MGC should not have to parse the SDP.

-troy

---

From: Troy Cauble <[email-masked]>
Date: Wed, 10 Dec 2003 18:09:22 -0500

-troy

---

From: "Pascal Lambers" <[email-masked]>
Date: Thu, 11 Dec 2003 00:01:48 +0100

Pascal

  ----- Original Message ----- 
  From: Kevin Boyle 
  To: Pascal Lambers ; [email-masked] 
  Sent: Wednesday, December 10, 2003 12:11 AM
  Subject: RE: [Megaco] SDP mode and Megaco mode question

  Kevin 

  -----Original Message----- 
  From: Pascal Lambers [mailto:[email-masked]] 
  Sent: Monday, December 08, 2003 5:39 PM 
  To: [email-masked] 
  Subject: Re: [Megaco] SDP mode and Megaco mode question 

  Kind regards, 
  Pascal 

  ----- Original Message ----- 
  From: "Christian Groves" <[email-masked]> 
  To: "Madhubabu Brahmanapally" <[email-masked]> 
  Cc: "Pascal Lambers" <[email-masked]>; "Tom Taylor" 
  <[email-masked]>; <[email-masked]> 
  Sent: Monday, December 08, 2003 10:45 PM 
  Subject: Re: [Megaco] SDP mode and Megaco mode question 

  remote 
  "inactive". 
  only 
  = 
  opinion? 
  protocol 
  Megaco