Subject: RE: [Megaco] SDP mode and Megaco mode question

From: Madhubabu Brahmanapally <[email-masked]>
Date: Thu, 4 Dec 2003 15:04:20 -0800

The Local Control Descriptor has high precedence over the SDP
information....

-----Original Message-----
From: Pascal Lambers [mailto:[email-masked]]
Sent: Thursday, December 04, 2003 3:05 PM
To: [email-masked]
Subject: [Megaco] SDP mode and Megaco mode question

Hello,
 
Don't know precisely how to forumulate this question clearly, so let me put
in in two different ways...
 
What does a MG have to do if an MGC sends a Modify with:
- the Mode property of the LocalControl descriptor set to, for instance,
receive-only;
- a Local/Remote Descriptor with an SDP-block containing an "a=sendrecv"
parameter?
 
In other words, what is the relation beween the a=sendrecv, a=sendonly,
a=inactive, a=recvonly parameters of the SDP protocol and the Mode property
of the LocalControl descriptor in the Megaco protocol?

Can sb give some advise? Thanks!
Pascal

---

From: Tom Taylor <[email-masked]>
Date: Thu, 04 Dec 2003 18:31:35 -0500

I would put it bluntly that the MG must ignore mode in the SDP.

Madhubabu Brahmanapally wrote:

>     *From:* Pascal Lambers [mailto:[email-masked]]
>     *Sent:* Thursday, December 04, 2003 3:05 PM
>     *To:* [email-masked]
>     *Subject:* [Megaco] SDP mode and Megaco mode question
> 
>     Hello,
>      
>     Don't know precisely how to forumulate this question clearly, so let
>     me put in in two different ways...
>      
>     - the Mode property of the LocalControl descriptor set to, for
>     instance, receive-only;
>     - a Local/Remote Descriptor with an SDP-block containing an
>     "a=sendrecv" parameter?
>      
>     In other words, what is the relation beween the a=sendrecv,
>     a=sendonly, a=inactive, a=recvonly parameters of the SDP protocol
>     and the Mode property of the LocalControl descriptor in the Megaco
>     protocol?
>      
>      

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Thu, 04 Dec 2003 18:31:35 -0500

---

From: "Pascal Lambers" <[email-masked]>
Date: Fri, 5 Dec 2003 09:02:19 +0100

So would I, but isn't there any RFC statement to enforce this opinion?

Pascal

---

From: "Pascal Lambers" <[email-masked]>
Date: Fri, 5 Dec 2003 09:02:19 +0100

Pascal

---

From: Christian Groves <[email-masked]>
Date: Mon, 08 Dec 2003 15:55:41 +1100

Hello Pascal,

I think you have pointed out an issue for the Implementors' Guide. This fact 
that the Local Control Mode overrides the SDP is common practise the only 
problem is that it is not clearly stated.

I would propose that :
7.1.7	LocalControl descriptor
...
The allowed values for the mode property are send-only, receive-only, 
send/receive, inactive and loop-back. "Send" and "receive" are with respect to 
the exterior of the Context, so that, for example, a stream set to mode = 
sendOnly does not pass received media into the Context. The default value for 
the mode property is "Inactive". Signals and Events are not affected by mode.
 >>> The local control mode property takes precedence over the local and remote 
descriptors.<<<
...

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Mon, 08 Dec 2003 15:55:41 +1100

Hello Pascal,

I would propose that :
descriptors.<<<
...

Regards, Christian