Subject: [Megaco] about error code

From: "FND-AD Wang JuLin" <[email-masked]>
Date: Mon, 8 Dec 2003 13:10:39 +0800

Hello list,
1) Suppose a term has already been added to a specific context. When we add this term again with choose $ context, does the reply message(433 error) contain the old specific context or just the latest choose context?

As follows:
MGC to MG
MEGACO/1 [10.10.0.4] Transaction =1372  {     Context = $ {         Add = tdm/2/1 {                 Media {LocalControl {Mode = SendReceive}}                 }  ,        Add = $ {                Media {Stream=1{LocalControl {Mode = ReceiveOnly},Local { v=0   c=IN IP4 $ m=audio $ RTP/AVP 8 a=ptime:30 }}}                }  }     } 

MG reply message
!/1 [10.10.0.11] P=1372{C=${A=tdm/2/1{ER=433{"TerminationID is already in a Context"}}}}
or
!/1 [10.10.0.11] P=1372{C=416{A=tdm/2/1{ER=433{"TerminationID is already in a Context"}}}}

2) What error will be triggerred if mgc issue subtract message with choose context on all term(*)?
i.e.
MGC to MG
MEGACO/1 [10.10.0.4] Transaction =133 {
    Context = ${  
       Subtract  = *
    }}
MG reply message

!/1 [10.10.0.11] P=133{C=${S=*{ER=411{"Transaction refers to an unknown ContextID"}}}}

Thank you  very much! 

 best  regards
> :-)Jerry Wang
tel:(8621)58541240 ext 9531
MP:13621761050
mailto:[email-masked] 
Alcatel Shanghai Bell Co.LTD

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 09 Dec 2003 09:03:13 +1100

Hello Jerry,

Q.1 The specific context where the termination already resides is returned.

Q.2 Is intereresing... The protocol doesn't specifically disallow
Context=?(Sub,TID=*), it does disallow Context=a(Sub,TID=?). The reason it
disallowed choose on TID in subtract is that there's no point creating resources
and then deleting them. I think this assumption is also valid for choose of
ContextIDs for subtract commands. So as choosing a contextID in subtract is a
violation of this assumption I would say that 401 Protocol Error may be more
appropriate.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Tue, 09 Dec 2003 09:03:13 +1100

Hello Jerry,

Regards, Christian