Subject: [Megaco] wildcarding question

From: Troy Cauble <[email-masked]>
Date: Mon, 15 Dec 2003 16:01:22 -0500

Regarding 6.6.1 in the IG.

The example would have been more informative if it matched two or more
terminations.

Should
	Context = 1 { Command=*{Descriptor/s}}

return
	Context = 1 {Command=t1/1{Descriptor/s},
	             Command=t2/1{Descriptor/s}}
or
	Context = 1 {Command=t1/1{Descriptor/s}}
	Context = 1 {Command=t2/1{Descriptor/s}}

The text says "identical to repeating the command with each of the
TerminationIDs", so I think the former is correct, but I'm not positive.

Also, regarding 6.6.4, wildcard responses:
A wildcard resonse request happens at the command level.
What if wildcard response commands and non-wildcard response commands
exist in the same request context?

	Context = * { Command=*{Descriptor/s},
	              W-Command=*{Descriptor/s},
	              Command=*{Descriptor/s}}

-troy

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Thu, 18 Dec 2003 16:31:14 -0500

Anyone have an opinion???

-troy

---

From: Troy Cauble <[email-masked]>
Date: Thu, 18 Dec 2003 16:31:14 -0500

-troy

---

From: Christian Groves <[email-masked]>
Date: Mon, 22 Dec 2003 11:48:08 +1100

Hello Troy,

Please see my comments below.

Regards, Christian

> TerminationIDs", so I think the former is correct, but I'm not positive.
[CHG] I believe the former is correct.
>                   W-Command=*{Descriptor/s},

[CHG] Each command would be handled would be handled normally. The non-W 
commands would have all the instances returned and the W-command would only have 
one return with *.

---

From: Christian Groves <[email-masked]>
Date: Mon, 22 Dec 2003 11:48:08 +1100

Hello Troy,

Regards, Christian

---

From: Troy Cauble <[email-masked]>
Date: Mon, 22 Dec 2003 09:35:06 -0500

> commands would have all the instances returned and the W-command would 
> only have one return with *.
> 

Yeah, but the first and third commands should return specified contexts,
while the second should return Context=*.  So do we end up with....

Context = 1 { Command1=x1/1 { },
	      Command1=x2/1 { }},
Context = 2 { Command1=x3/1 { }},
Context = * { Command2=* { }),
Context = 1 { Command3=x1/1 { },
               Command3=x2/1 { }},
Context = 2 { Command3=x3/1 { }}

-troy

---

From: Troy Cauble <[email-masked]>
Date: Mon, 22 Dec 2003 09:35:06 -0500

-troy

---

From: Christian Groves <[email-masked]>
Date: Tue, 23 Dec 2003 10:18:37 +1100

So what is the problem is they return specific and wildcarded returns? Its a 
pretty unlikely scenario to put a Context=*{w-command=*{} in the middle of non-W 
commands.

Christian

Troy Cauble wrote:

>> [CHG] Each command would be handled would be handled normally. The 
>> non-W commands would have all the instances returned and the W-command 
>> would only have one return with *.
>>
> 
>

---

From: Christian Groves <[email-masked]>
Date: Tue, 23 Dec 2003 10:18:37 +1100

Christian