Subject: [Megaco] A question about the ITU-T H.248 R2 draft

From: Zhao Bo <[email-masked]>
Date: Wed, 03 Dec 2003 17:23:55 +0800

Hello List:
    When applying the R2 draft(H.248.25, H.248.icasc) to a network like this:
                            MGC
                              /    \
                            /       \
    R2 PBX--->MG1----MG2-->PSTN R2 switch
    
   We find the MGC can't give MG1 a complete digitmap to collect destination number from the R2 PBX
(because the complexity of PSTN, a call may be routes to any regions and contries),  and there isn't I-15 
signalling in R2 PBX. So in most case MG1 will report  the r2 address event due to time out, not digitmap 
match.  This add a significant time delay to call setup procedure and cause quite a lot of compliant.

    Can't we add a extend mechanism to H.248 R2 package, so MGC send multi R2 address event to MG?
MG can then report the destionation number part by part, and once receiving a part, MGC can send them 
to next hop.     

    H.248.icasc allows calling number to  be reported part by part, but it still require MGC have the complete
knowledge of calling number. It only tells MG the sequence to collect a know number pattern, in my case, we
don't know that.

    Best regards
Zhao Bo

*****************************************************************
This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
*****************************************************************

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Zhao Bo <[email-masked]>
Date: Thu, 04 Dec 2003 11:21:31 +0800

Guess I didn't describe my question clearly :-(. Try again:

1. MG depends the digitmap to decide if the called numbers receiving  is complete (in most practice, I-15 is not availiabe);
2. When numbers match a digitmap, everything is OK; But in many cases digitmap is not specific enough (something like x.L),  MG will have to wait for a time out;
This timeout add significant time delay to call setup procedure.

How to solve this problem? 
I think MG can send each received number to MGC, MGC can send it to next hop immediately. If some switch in the calling path decide called number is complete, it sends back a Alerting or something, MGC can then clear R2 address event, avoiding MG timeout. 

Actually, I don't like this solution, because MG will have to report many events to MGC. Can anyone give me a better solution? Or any advice?

Thanks very much!

---

From: Zhao Bo <[email-masked]>
Date: Thu, 04 Dec 2003 11:21:31 +0800

Thanks very much!

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 10 Dec 2003 19:34:58 -0500

The tradeoff will always be number of messages versus transmission delay.
If you specify larger digitmaps, then your transmission delay will be
related to the number of digits that have to be detected.  If you collect
digits one at a time in order to minimize delay, then you will have large
numbers of messages.  The MGC will have to pick the appropriate balance for
its implementation.

If you want to collect digits quickly, either use the digit package (dd or
mfd) or use a digitmap with the timer set very short.  Remember that you can
override the timer definition per digitmap.

Kevin 

-----Original Message-----
From: Zhao Bo [mailto:[email-masked]] 
Sent: Thursday, December 04, 2003 9:50 PM
To: [email-masked]
Subject: Re: [Megaco] A question about the ITU-T H.248 R2 draft

1. MG depends the digitmap to decide if the called numbers receiving  is
complete (in most practice, I-15 is not availiabe); 2. When numbers match a
digitmap, everything is OK; But in many cases digitmap is not specific
enough (something like x.L),  MG will have to wait for a time out; This
timeout add significant time delay to call setup procedure.

How to solve this problem? 
I think MG can send each received number to MGC, MGC can send it to next hop
immediately. If some switch in the calling path decide called number is
complete, it sends back a Alerting or something, MGC can then clear R2
address event, avoiding MG timeout. 

Actually, I don't like this solution, because MG will have to report many
events to MGC. Can anyone give me a better solution? Or any advice?

Thanks very much!

----- Original Message -----
From: "Zhao Bo" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, December 03, 2003 5:23 PM
Subject: [Megaco] A question about the ITU-T H.248 R2 draft

> This e-mail and its attachments contain confidential information from
HUAWEI, which is intended only for the person or entity whose address is
listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure, reproduction,
or dissemination) by persons other than the intended recipient(s) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 10 Dec 2003 19:34:58 -0500

Kevin 

-----Original Message-----
From: Zhao Bo [mailto:[email-masked]] 
Sent: Thursday, December 04, 2003 9:50 PM
To: [email-masked]
Subject: Re: [Megaco] A question about the ITU-T H.248 R2 draft

Thanks very much!