Subject: [Megaco] Query on Codec List Event in TFO Package

From: "Shridhara B" <[email-masked]>
Date: Fri, 19 Dec 2003 12:08:13 +0530

All,

The TFO package defined in 3GPP TS 29.232 V5.6.0 has Codec List Event. The
EventId is given as follows: -
EventID: distant codec_list (0x0012).

But the event name should not contain the space characters like above. Hence
it should be either, EventID: distantcodec_list (0x0012) or EventID:
distant_codec_list (0x0012).

Could you please confirm which one of the above is correct?

Thanks
Shridhara.B

---

From: "Rashim Anand" <[email-masked]>
Date: Fri, 19 Dec 2003 09:30:35 -0800

Hello Shridhara,

This is indeed a mistake. Event Id is defined by the ABNF construct ItemID
which is further defined as NAME. The rule for NAME is given in the RFC as -

NAME                 = ALPHA *63(ALPHA / DIGIT / "_" )

Consequently, there can NOT be a space in Event Id.

Could the authors of this package please clarify?

Regards,
Rashim Anand

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Shridhara B
  Sent: Thursday, December 18, 2003 10:38 PM
  To: [email-masked]
  Subject: [Megaco] Query on Codec List Event in TFO Package

  All,

  But the event name should not contain the space characters like above.
Hence it should be either, EventID: distantcodec_list (0x0012) or EventID:
distant_codec_list (0x0012).

  Thanks
  Shridhara.B

---

From: "Rashim Anand" <[email-masked]>
Date: Fri, 19 Dec 2003 09:30:35 -0800

Hello Shridhara,

Regards,
Rashim Anand

  -----Original Message-----

  All,

  Thanks
  Shridhara.B

---

From: Christian Groves <[email-masked]>
Date: Mon, 22 Dec 2003 09:49:29 +1100

Hello,

I think the original author is on holiday for a couple of weeks. I would assume 
that "distant_codec_list" is correct.

Regards, Christian

Rashim Anand wrote:

> Hello Shridhara,
>  
> This is indeed a mistake. Event Id is defined by the ABNF construct 
> ItemID which is further defined as NAME. The rule for NAME is given in 
> the RFC as -
>  
>     From: [email-masked] [mailto:[email-masked]]On Behalf
>     Of Shridhara B
>     The TFO package defined in 3GPP TS 29.232 V5.6.0 has Codec List
>     Event. The EventId is given as follows: -
>     But the event name should not contain the space characters like
>     above. Hence it should be either, EventID: distantcodec_list
>     (0x0012) or EventID: distant_codec_list (0x0012).
>      

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 22 Dec 2003 09:49:29 +1100

Hello,

Regards, Christian