Subject: [Megaco] Digit Map Completion Event

From: Tegeler Juergen <[email-masked]>
Date: Mon, 1 Dec 2003 11:14:07 +0100

Hi all,

the following question about Digit Map Completion Event came up 
while reading H.248.1 (05/2002):

Chapter 7.1.14.4:
..
Upon completion, a digit map completion event as defined in the package providing the events being mapped into the digit map shall be generated. At that point the digit map is deactivated. Subsequent events in the package are processed as follows:
*	If EventBufferControl is ON, subsequent digit events are processed in the same way as any other events;
..

Isn' t that a contradiction? What to do with digits received in the MGC after reception of Digit Map Completion event?

Best regards,

Juergen Tegeler  

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Mon, 1 Dec 2003 19:44:45 +0530

Hi,

  The statement in the RFC is to address more than one digit event being active and processing subsequent digit map completion events.  I believe there was some discussion on the list in this regard (I do not remember the thread though)

  Hope this helps...
  
Thanks,
Shashi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Tegeler Juergen
Sent: Monday, December 01, 2003 3:44 PM
To: [email-masked]
Subject: [Megaco] Digit Map Completion Event

Hi all,

Chapter 7.1.14.4:
..

Best regards,

Juergen Tegeler

---

From: [email-masked]
Date: Mon, 1 Dec 2003 19:44:45 +0530

Hi,

  Hope this helps...
  
Thanks,
Shashi

-----Original Message-----

Hi all,

Chapter 7.1.14.4:
..

Best regards,

Juergen Tegeler

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 1 Dec 2003 17:09:20 -0500

No, it is not a contradiction.  If EventBuffering is enabled, then
subsequent digit events are compared to the current EB descriptor.  If the
digit event is in the EB descriptor, then it is saved pending the next
Events descriptor.  If it is not, then it is discarded.

Remember that digitmaps are not the only mechanism for collecting digit
events.

Kevin

-----Original Message-----
From: Tegeler Juergen [mailto:[email-masked]] 
Sent: Monday, December 01, 2003 5:14 AM
To: [email-masked]
Subject: [Megaco] Digit Map Completion Event

Hi all,

the following question about Digit Map Completion Event came up while
reading H.248.1 (05/2002):

Chapter 7.1.14.4:
..
Upon completion, a digit map completion event as defined in the package
providing the events being mapped into the digit map shall be generated. At
that point the digit map is deactivated. Subsequent events in the package
are processed as follows:
*	If EventBufferControl is ON, subsequent digit events are processed
in the same way as any other events;
..

Isn' t that a contradiction? What to do with digits received in the MGC
after reception of Digit Map Completion event?

Best regards,

Juergen Tegeler

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 1 Dec 2003 17:09:20 -0500

Kevin

-----Original Message-----
From: Tegeler Juergen [mailto:[email-masked]] 
Sent: Monday, December 01, 2003 5:14 AM
To: [email-masked]
Subject: [Megaco] Digit Map Completion Event

Hi all,

Chapter 7.1.14.4:
..

Best regards,

Juergen Tegeler