Subject: [Megaco] SDP mode and Megaco mode question

From: "Pascal Lambers" <[email-masked]>
Date: Fri, 5 Dec 2003 00:05:27 +0100

Hello,

Don't know precisely how to forumulate this question clearly, so let me put in in two different ways...

What does a MG have to do if an MGC sends a Modify with:
- the Mode property of the LocalControl descriptor set to, for instance, receive-only;
- a Local/Remote Descriptor with an SDP-block containing an "a=sendrecv" parameter?

In other words, what is the relation beween the a=sendrecv, a=sendonly, a=inactive, a=recvonly parameters of the SDP protocol and the Mode property of the LocalControl descriptor in the Megaco protocol?

Can sb give some advise? Thanks!
Pascal

---

From: Madhubabu Brahmanapally <[email-masked]>
Date: Thu, 4 Dec 2003 15:04:20 -0800

The Local Control Descriptor has high precedence over the SDP
information....

-----Original Message-----
From: Pascal Lambers [mailto:[email-masked]]
Sent: Thursday, December 04, 2003 3:05 PM
To: [email-masked]
Subject: [Megaco] SDP mode and Megaco mode question

Hello,
 
Don't know precisely how to forumulate this question clearly, so let me put
in in two different ways...
 
What does a MG have to do if an MGC sends a Modify with:
- the Mode property of the LocalControl descriptor set to, for instance,
receive-only;
- a Local/Remote Descriptor with an SDP-block containing an "a=sendrecv"
parameter?
 
In other words, what is the relation beween the a=sendrecv, a=sendonly,
a=inactive, a=recvonly parameters of the SDP protocol and the Mode property
of the LocalControl descriptor in the Megaco protocol?

---

From: Madhubabu Brahmanapally <[email-masked]>
Date: Mon, 8 Dec 2003 09:57:40 -0800

Hi Christian,
Does the Local control mode property takes precedence or as Tom pointed out,
does the MG always disregard the mode in local/remote descriptors??

Regards
Madhubabu

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Sunday, December 07, 2003 8:56 PM
To: Pascal Lambers
Cc: Tom Taylor; Madhubabu Brahmanapally; [email-masked]
Subject: Re: [Megaco] SDP mode and Megaco mode question

Hello Pascal,

I think you have pointed out an issue for the Implementors' Guide. This fact

that the Local Control Mode overrides the SDP is common practise the only 
problem is that it is not clearly stated.

I would propose that :
7.1.7	LocalControl descriptor
...
The allowed values for the mode property are send-only, receive-only, 
send/receive, inactive and loop-back. "Send" and "receive" are with respect
to 
the exterior of the Context, so that, for example, a stream set to mode = 
sendOnly does not pass received media into the Context. The default value
for 
the mode property is "Inactive". Signals and Events are not affected by
mode.
 >>> The local control mode property takes precedence over the local and
remote 
descriptors.<<<
...

Regards, Christian

Pascal Lambers wrote:

> So would I, but isn't there any RFC statement to enforce this opinion?
> 
> Pascal
> 
> 
> ----- Original Message ----- 
> From: "Tom Taylor" <[email-masked]>
> To: "Madhubabu Brahmanapally" <[email-masked]>
> Cc: "'Pascal Lambers'" <[email-masked]>; <[email-masked]>
> Sent: Friday, December 05, 2003 12:31 AM
> Subject: Re: [Megaco] SDP mode and Megaco mode question
> 
> 
> 
>>I would put it bluntly that the MG must ignore mode in the SDP.
>>
>>Madhubabu Brahmanapally wrote:
>>
>>
>>>    *From:* Pascal Lambers [mailto:[email-masked]]
>>>    *Sent:* Thursday, December 04, 2003 3:05 PM
>>>    *To:* [email-masked]
>>>    *Subject:* [Megaco] SDP mode and Megaco mode question
>>>
>>>    Hello,
>>>
>>>    In other words, what is the relation beween the a=sendrecv,
>>>    a=sendonly, a=inactive, a=recvonly parameters of the SDP protocol
>>>    and the Mode property of the LocalControl descriptor in the Megaco
>>>    protocol?
>>>
>>>
>>_______________________________________________
>>Megaco mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/megaco
>>
>>
>>
> 
> 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
>

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 9 Dec 2003 18:11:33 -0500

If there are no objections, I will include this in the editor's draft of the
IG that I will take to the January SG16 meeting.

The text I have entered is this:

7.1.7	LocalControl descriptor
...
The allowed values for the mode property are send-only, receive-only,
send/receive, inactive and loop-back. "Send" and "receive" are with respect
to the exterior of the Context, so that, for example, a stream set to mode =
sendOnly does not pass received media into the Context. The default value
for the mode property is "Inactive". Signals and Events are not affected by
mode.  >>The LocalControl Mode property takes precedence over any mode
specified in the Local and Remote descriptors.<<

Does that look OK?

Kevin 

-----Original Message-----
From: Christian Groves [mailto:[email-masked]] 
Sent: Monday, December 08, 2003 4:45 PM
To: Madhubabu Brahmanapally
Cc: Pascal Lambers; Taylor, Tom-PT [CAR:5N00:EXCH]; [email-masked]
Subject: Re: [Megaco] SDP mode and Megaco mode question

Hello Madhubabu,

The text I proposed below was:
"The local control mode property takes precedence over the local and remote
descriptors."

The local control mode property will always be set as it defaults to
"inactive". 
So as the local control mode property is set it always takes precedence.

Christian

Madhubabu Brahmanapally wrote:

> Hi Christian,
> Does the Local control mode property takes precedence or as Tom 
> pointed out, does the MG always disregard the mode in local/remote
descriptors??
> I think you have pointed out an issue for the Implementors' Guide. 
> This fact that the Local Control Mode overrides the SDP is common 
> practise the only problem is that it is not clearly stated.
> 
> I would propose that :
> send/receive, inactive and loop-back. "Send" and "receive" are with 
> respect to the exterior of the Context, so that, for example, a stream 
> set to mode = sendOnly does not pass received media into the Context. 
> The default value for the mode property is "Inactive". Signals and 
> Events are not affected by mode.
>  >>> The local control mode property takes precedence over the local 
> and remote descriptors.<<< ...
> 
> Regards, Christian
> 
> Pascal Lambers wrote:
> 
>  > From: "Tom Taylor" <[email-masked]>  > To: "Madhubabu 
> Brahmanapally" <[email-masked]>  > Cc: "'Pascal Lambers'" 
> <[email-masked]>; <[email-masked]>  > Sent: Friday, 
> December 05, 2003 12:31 AM  > Subject: Re: [Megaco] SDP mode and 
> Megaco mode question  >  >  >  >>I would put it bluntly that the MG 
> must ignore mode in the SDP.
>  >>
>  >>>    Don't know precisely how to forumulate this question clearly, so 
> let
>  >>>    me put in in two different ways...
>  >>>

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 9 Dec 2003 18:11:33 -0500

Does that look OK?

Kevin 

-----Original Message-----
From: Christian Groves [mailto:[email-masked]] 
Sent: Monday, December 08, 2003 4:45 PM
To: Madhubabu Brahmanapally
Cc: Pascal Lambers; Taylor, Tom-PT [CAR:5N00:EXCH]; [email-masked]
Subject: Re: [Megaco] SDP mode and Megaco mode question

Hello Madhubabu,

Christian

descriptors??

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 9 Dec 2003 18:11:35 -0500

I don't see that the MGC has to parse SDP.  I think the mode in the SDP
could be used as a suggestion, but the MGC will certainly know whether or
not it wants the media stream flowing.  That is to say, what the MGC wants
trumps what the far-end wants.

Kevin 

-----Original Message-----
From: Pascal Lambers [mailto:[email-masked]] 
Sent: Monday, December 08, 2003 5:39 PM
To: [email-masked]
Subject: Re: [Megaco] SDP mode and Megaco mode question

It would of course be interesting to know what most gateways currently do
with the "a=..." SDP mode parameter: will they deny it, even if no other
mode has been set? Are there some gateway experts reading this discussion?

I do see Christian's point here: the context prevails. You could look at the
context as as a shell around the RTP(s) it contains.

The annoying consequence is that a MGC which must talk to a Megaco MG has to
start parsing the SDP block. If  a MGC receives a message for its MG from,
say, another MGC, it has to translate the SDP mode to a local control
mode...

Kind regards,
Pascal

----- Original Message -----
From: "Christian Groves" <[email-masked]>
To: "Madhubabu Brahmanapally" <[email-masked]>
Cc: "Pascal Lambers" <[email-masked]>; "Tom Taylor"
<[email-masked]>; <[email-masked]>
Sent: Monday, December 08, 2003 10:45 PM
Subject: Re: [Megaco] SDP mode and Megaco mode question

"inactive".
> > Does the Local control mode property takes precedence or as Tom pointed
> > out, does the MG always disregard the mode in local/remote descriptors??
> >
> > Regards
> > Madhubabu
> >
> > respect to
> > sendOnly does not pass received media into the Context. The default
> > value for

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 10 Dec 2003 22:12:28 -0500

The "optional" parts of SDP are only from the MGC->MG.  MGs MUST return
compliant SDP.  Therefore, anything sent from the MGC to the SIP client will
be compliant SDP.
 
As for your other example, it seems to me that is an implementation detail,
and that MGCs are not obligated to parse SDP.  Should they do so to be
effective implementations?  Well, that is another question altogether.
 
Kevin

  _____  

From: Pascal Lambers [mailto:[email-masked]] 
Sent: Wednesday, December 10, 2003 6:02 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Subject: Re: [Megaco] SDP mode and Megaco mode question

I do think it's unavoidable for a MGC to parse the SDP...
 
For example, you can have MGC1 (controlling a Megaco GW + a black phone)
talking to MGC2 (controlling a Sip GW + Sip Phone). Now, If the Sip phone
starts doing some more complex operations it might want the Megaco side,
controlled by MGC1, to change Mode. And that's exactly where the MGC2 has to
parse the SDP block to make sure that it can send a LocalControlDescriptor
to its Megaco gateway. Because the a=... parameter in the SDP block from the
sip-side will be of no use to the Megaco GW.
 
Moreover, the SDP parameters o,s and t, optional according to the Megaco RFC
but mandatory according to the SDP RFC, cause the same problem...
 
Pascal

----- Original Message ----- 
From: Kevin Boyle <mailto:[email-masked]>  
To: Pascal Lambers <mailto:[email-masked]>  ; [email-masked]
<mailto:[email-masked]>  
Sent: Wednesday, December 10, 2003 12:11 AM
Subject: RE: [Megaco] SDP mode and Megaco mode question

Kevin 

-----Original Message----- 
From: Pascal Lambers [mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Monday, December 08, 2003 5:39 PM 
To: [email-masked] <mailto:[email-masked]>  
Subject: Re: [Megaco] SDP mode and Megaco mode question 

Kind regards, 
Pascal 

----- Original Message ----- 
From: "Christian Groves" <[email-masked]> 
To: "Madhubabu Brahmanapally" <[email-masked]> 
Cc: "Pascal Lambers" <[email-masked]>; "Tom Taylor" 

"inactive". 

> > From: Christian Groves [mailto:[email-masked]
<mailto:[email-masked]> ] 

> >  >>>    *From:* Pascal Lambers [mailto:[email-masked]
<mailto:[email-masked]> ] 

> >  >>>    Can sb give some advise? Thanks! 
<https://www1.ietf.org/mailman/listinfo/megaco>  
<https://www1.ietf.org/mailman/listinfo/megaco>  

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 10 Dec 2003 22:12:28 -0500

Kevin

  _____  

 

Pascal

----- Original Message ----- 
From: Kevin Boyle <mailto:[email-masked]>  
To: Pascal Lambers <mailto:[email-masked]>  ; [email-masked]
<mailto:[email-masked]>  

Kevin 

-----Original Message----- 

Kind regards, 
Pascal 

----- Original Message ----- 
From: "Christian Groves" <[email-masked]> 
To: "Madhubabu Brahmanapally" <[email-masked]> 
Cc: "Pascal Lambers" <[email-masked]>; "Tom Taylor" 

"inactive".