Subject: [Megaco] wildcarding question

From: Troy Cauble <[email-masked]>
Date: Mon, 15 Dec 2003 16:01:22 -0500

Regarding 6.6.1 in the IG.

The example would have been more informative if it matched two or more
terminations.

Should
	Context = 1 { Command=*{Descriptor/s}}

return
	Context = 1 {Command=t1/1{Descriptor/s},
	             Command=t2/1{Descriptor/s}}
or
	Context = 1 {Command=t1/1{Descriptor/s}}
	Context = 1 {Command=t2/1{Descriptor/s}}

The text says "identical to repeating the command with each of the
TerminationIDs", so I think the former is correct, but I'm not positive.

Also, regarding 6.6.4, wildcard responses:
A wildcard resonse request happens at the command level.
What if wildcard response commands and non-wildcard response commands
exist in the same request context?

	Context = * { Command=*{Descriptor/s},
	              W-Command=*{Descriptor/s},
	              Command=*{Descriptor/s}}

-troy

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Carl Rutter <[email-masked]>
Date: Thu, 18 Dec 2003 16:37:13 -0500

The former case, 1 context.

CArl

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Thursday, December 18, 2003 4:31 PM
To: MEGACO list
Subject: Re: [Megaco] wildcarding question

Anyone have an opinion???

-troy

---

From: Carl Rutter <[email-masked]>
Date: Thu, 18 Dec 2003 16:37:13 -0500

CArl

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Thursday, December 18, 2003 4:31 PM
To: MEGACO list
Subject: Re: [Megaco] wildcarding question

-troy