Subject: Re: [Megaco] Descriptor processing on Termination OOS

From: [email-masked]
Date: Tue, 16 Dec 2003 11:53:15 +0530

Hi
      In my opinion keeping the descriptors alive and enabled for a
termination which is in Out of Service state
does not seems to be a valid behaviour of MG. For example if the card
containing the termination is jacked out
of the chasis then definately at the hardware level all the events and
signals get disabled.  There would be a major
disconnect wrt descriptors state if MGC does not audit the termination
since if  MGC were to audit the termination then
MG would be returning empty   descriptors in this particular case.  Now  in
this condition if the card is jacked-in and termination
is made in-service then the exact state of original descriptors no more
holds good and mgc needs to apply the descriptors again.

      Hence for a termination which is in Out-of-Service state MGC can
fairly assume that all descriptors are no more valid
and whenever the termination comes up will reapply the descriptors afresh.
This assumption holds true whether or not termination
is involved in a call.

Regards
Venkat

Tom Taylor <[email-masked]>@ietf.org on 12/01/2003 11:52:03 PM

Sent by:    [email-masked]

To:    Sampath Komanduri <[email-masked]>
cc:    [email-masked]

Subject:    Re: [Megaco] Descriptor processing on Termination OOS

The descriptors (aside from TerminationState) remain unchanged until
either the MGC changes them or the MG undergoes a cold restart.

Sampath Komanduri wrote:

> Hi all,
> Could someone pls. answer my question?
>
> Thanks,
> Sampath
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Sampath Komanduri
> Sent: Monday, November 24, 2003 5:46 PM
> To: [email-masked]
> Subject: [Megaco] Descriptor processing on Termination OOS
>
>
> Hi,
> What should be the descriptors state when a termination is service
> changed to state OOS?
> Is it ok to remove all the descriptors that are currently applied on the
> termination or
> should MG keep the information of descriptors so that they can be
> re-applied if the termination comes to in-service state again.
>
> Thanks,
> Sampath
>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
>

_______________________________________________
Megaco mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Anil Jangam \(anilj\)" <[email-masked]>
Date: Tue, 16 Dec 2003 13:33:27 +0530

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Tuesday, December 16, 2003 11:53 AM
> To: Tom Taylor
> Cc: [email-masked]
>       In my opinion keeping the descriptors alive and enabled 
> for a termination which is in Out of Service state does not 
> seems to be a valid behaviour of MG. For example if the card 
> containing the termination is jacked out of the chasis then 
> definately at the hardware level all the events and signals 
> get disabled.  There would be a major disconnect wrt 
> descriptors state if MGC does not audit the termination since 
> if  MGC were to audit the termination then
> is made in-service then the exact state of original 
> descriptors no more holds good and mgc needs to apply the 
> descriptors again.
> 
>       Hence for a termination which is in Out-of-Service 
> state MGC can fairly assume that all descriptors are no more 
> valid and whenever the termination comes up will reapply the 
> descriptors afresh. This assumption holds true whether or not 
> termination is involved in a call.

First thing, there is no provision for the MG to change the state of the
descriptor by its own. If we see the commands that can change the
descriptor state, these are commands which MGC initiate. 

In the SVC with SVCMethod = forced, its mentioned that MGC is going to
clean up the context, in which case it is to subtract the termination
from the cotext. At this point MGC can reset the descriptor state to the
default if necessary. Same logic can be applied when the SVCMethod is
graceful.
In the call flows as well, when the termination is coming back into the
service, normally a Modify is sent to MG initializing the term. 

So given this, IMO we don't have to make any assumption about the
descriptor state once its taken OOS.

> The descriptors (aside from TerminationState) remain 
> unchanged until either the MGC changes them or the MG 
> undergoes a cold restart.
> 
> Sampath Komanduri wrote:
> 
> > Hi all,
> > From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> > Of Sampath Komanduri
> > changed to state OOS? Is it ok to remove all the 
> descriptors that are 
> > currently applied on the termination or

---

From: "Anil Jangam \(anilj\)" <[email-masked]>
Date: Tue, 16 Dec 2003 13:33:27 +0530