Subject: [Megaco] Questions about H.248.17 "line test packages"(upgrade,sorry, my poor English)

From: Zhao Bo <[email-masked]>
Date: Mon, 23 Feb 2004 17:25:02 +0800

Could anyone kindly answer the following questions (I can't find the author's email address in H.248.17 text).

1. Section 1 "Scope" says:
"The detailing of results that are reported (e.g. events and statistics), as well as the timing and mechanisms used for
transmitting such records from the MG to the MGC"
Why? If a test is initiated by MGC, why not define a protocol to send the measuring result back to MGC?

2.If we have two switch connected with temination T1 and T2
    SW1--T1-------T2--SW2
Shall the H.248 signal be apllied to T1 and T2, or some extra termination, for example T3 or T4 in the following scenerio:
T3--SW1--T1-------T2--SW2--T4

3. Section 7.1.1 says:
"ITU-T Rec. O.11 describes test responder behaviour. For a description of this behaviour see
clause 9."
But neither O.11 nor H.247.17 text has a clause 9?

Best regards

Zhao Bo

Zhao Bo

*****************************************************************
This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
*****************************************************************

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 24 Feb 2004 10:05:39 +1100

Hello Zhao,

I'm the editor of H.248.17. Please see my replies below marked [CHG].

Regards, Christian

> Why? If a test is initiated by MGC, why not define a protocol to send the measuring result back to MGC?

[CHG] As the results are related to the physical characteristics of the bearer 
and not usually interesting to a MGC it was seen that a protocol other than 
H.248 (or even internal O&M of the MG) was more suitable for this information.

> T3--SW1--T1-------T2--SW2--T4

[CHG] Depends on what you want to test. If all you want to test is the link 
between T1 and T2 then you only apply signals between T1 & T2.

> But neither O.11 nor H.247.17 text has a clause 9?

[CHG] Please see the latest implementors guide for the correction.

> Zhao Bo

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

---

From: Christian Groves <[email-masked]>
Date: Tue, 24 Feb 2004 10:05:39 +1100

Hello Zhao,

Regards, Christian

---

From: Zhao Bo <[email-masked]>
Date: Fri, 27 Feb 2004 20:44:45 +0800

Hi Chrisitan:
    I studied a simple procedure as follow:

    (1)Testee MG is set to  loopback;
    (2)Tester sends a 1020Hz tone to  testee;
    (3)Tester receive the loopbacked tone, analyze the quality of tone and output a report.

    Suppose the Tester is embeded in MGW. In H.248.17 structure,  the procedure will be.
    (1)Testee MGC set the Testee MGW to loopback.
    (2)Tester MGC signals the Tester to send  1020Hz tone;
    (3)Someone ask Tester MGW to receive loopback tone and make analysis.
    (4)MGW output a report to this "someone".

    Maybe you think O&M should be that "Someone"?  If my understanding is right--in same procedure O&M and  MGC will operate same termination, I think that's quite strange:-)
    
    Best regards

---

From: Zhao Bo <[email-masked]>
Date: Fri, 27 Feb 2004 20:44:45 +0800

Hi Chrisitan:

    
    Best regards

---

From: Christian Groves <[email-masked]>
Date: Mon, 01 Mar 2004 11:28:32 +1100

Hello Zhao Bo,

I don't know why you think it is quite strange? MGC/MGs are full of O&M systems 
which supervise the performance of their internals. If there's a problem or a 
performance metric this is output to somebody, which may be another off-line system.

Christian

---

From: Christian Groves <[email-masked]>
Date: Mon, 01 Mar 2004 11:28:32 +1100

Hello Zhao Bo,

Christian

---

From: Zhao Bo <[email-masked]>
Date: Mon, 01 Mar 2004 09:57:26 +0800

Hi Christian:
    I think as a common rule, if a termination is in a call (being operated by MGC), O&M should not operate it, because the O&M operation may affect the call quality. 
    Best regards.

---

From: Zhao Bo <[email-masked]>
Date: Mon, 01 Mar 2004 09:57:26 +0800

Hi Christian: