Subject: RE: [Megaco] H.248.23 Enhanced Alerting Package.

From: Raphael Tryster <[email-masked]>
Date: Wed, 4 Feb 2004 18:26:53 +0200

Kevin Boyle answered this question recently:

Call wait patterns are generally replayed after a short amount of time (10
seconds in North America).  Note that this is not a repetition -- this is
actually a second distinct application of the signal.  There are several
feature scenarios where the second signal will not be applied -- if the
waiting party hangs up, or if the callee flashes, to name a couple.
 
As for the dt package, I believe the characterization of call wait tone as
timeout is erroneous, although previous attempts to fix it have been
rejected.  I wrote the alerting package to be local-variant unaware, leaving
it to the MG to be responsible for how the signals should be applied to its
terminations.  Note that most localities have more than one wait tone
pattern, to allow for assignable distinctive tones (similar to assigning
distinctive ringing patterns to different incoming callers).
 
I see no reason to use dt/cw if using alert/cw.  The alerting package
provides far more functionality than the dt package for both ringing and
call waiting.
 
Kevin

  _____  

	From: Raphael Tryster [mailto:[email-masked]]
<mailto:[mailto:[email-masked]]>  
	Sent: Thursday, January 08, 2004 5:39 AM
	To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
<mailto:[email-masked]> 
	Subject: call waiting signal type

	In draft_boyle_megaco_alerting_03.txt, the alert/cw signal has type
brief, whereas the standard signal dt/cw apparently has type timeout.  Is
this a matter of national protocol?  The description of alert/cw says "Call
wait patterns do not repeat".  In Israel, a call waiting signal consists of
3 short tones, repeated once a few seconds later.

	If it is a matter of national protocol, does this mean that a
particular installation will use either alert/cw or dt/cw, but not both?

	Raphael Tryster 

	-----Original Message-----
	From:	Dal Chohan [SMTP:[email-masked]]
	Sent:	Wednesday, 4 February 2004 18:12
	To:	[email-masked]
	Subject:	[Megaco] H.248.23 Enhanced Alerting Package.

	The description of the "Call Waiting" signal defined in H.248.23
specifies that call waiting patterns do not repeat - Is this correct?
	 
	I would have thought that for a Call Waiting service that it would
would make perfect sense for the "call waiting" pattern to be repeatedly
applied by the MG until it was told to stop the call waiting signal by the
MGC (c.f. ringing) . It is the MGC that determines the interval within which
the waiting call should be accepted and thus determines the overall duration
of the call waiting pattern.

	Dal Chohan

---

From: "Dal Chohan" <[email-masked]>
Date: Thu, 5 Feb 2004 09:17:59 -0000

RE: [Megaco] H.248.23 Enhanced Alerting Package.Raphael 

Thanks for the response -  but I don't see why the Call Waiting can't be repeatedly applied just like ringing. If the Callee flashes, then the detection of the event will stop the signal as per standard H.248 behaviour and if the waiting party hangs up, then the MGC will instruct the MG to stop applying the signal via a new signal descriptor.

Dal Chohan.
  ----- Original Message ----- 
  From: Raphael Tryster 
  To: 'Dal Chohan' ; [email-masked] 
  Sent: Wednesday, February 04, 2004 4:26 PM
  Subject: RE: [Megaco] H.248.23 Enhanced Alerting Package.

  Call wait patterns are generally replayed after a short amount of time (10 seconds in North America).  Note that this is not a repetition -- this is actually a second distinct application of the signal.  There are several feature scenarios where the second signal will not be applied -- if the waiting party hangs up, or if the callee flashes, to name a couple.

  As for the dt package, I believe the characterization of call wait tone as timeout is erroneous, although previous attempts to fix it have been rejected.  I wrote the alerting package to be local-variant unaware, leaving it to the MG to be responsible for how the signals should be applied to its terminations.  Note that most localities have more than one wait tone pattern, to allow for assignable distinctive tones (similar to assigning distinctive ringing patterns to different incoming callers).

  I see no reason to use dt/cw if using alert/cw.  The alerting package provides far more functionality than the dt package for both ringing and call waiting.

  Kevin 

    _____  

    In draft_boyle_megaco_alerting_03.txt, the alert/cw signal has type brief, whereas the standard signal dt/cw apparently has type timeout.  Is this a matter of national protocol?  The description of alert/cw says "Call wait patterns do not repeat".  In Israel, a call waiting signal consists of 3 short tones, repeated once a few seconds later.

    If it is a matter of national protocol, does this mean that a particular installation will use either alert/cw or dt/cw, but not both?

    Raphael Tryster 

    -----Original Message----- 
    From:   Dal Chohan [SMTP:[email-masked]] 
    Sent:   Wednesday, 4 February 2004 18:12 
    To:     [email-masked] 
    Subject:        [Megaco] H.248.23 Enhanced Alerting Package. 

    The description of the "Call Waiting" signal defined in H.248.23 specifies that call waiting patterns do not repeat - Is this correct?

    I would have thought that for a Call Waiting service that it would would make perfect sense for the "call waiting" pattern to be repeatedly applied by the MG until it was told to stop the call waiting signal by the MGC (c.f. ringing) . It is the MGC that determines the interval within which the waiting call should be accepted and thus determines the overall duration of the call waiting pattern.

      
    Dal Chohan

---

From: "Dal Chohan" <[email-masked]>
Date: Thu, 5 Feb 2004 09:17:59 -0000

Dal Chohan.
  ----- Original Message ----- 
  From: Raphael Tryster 
  To: 'Dal Chohan' ; [email-masked] 
  Sent: Wednesday, February 04, 2004 4:26 PM
  Subject: RE: [Megaco] H.248.23 Enhanced Alerting Package.

  Kevin 

    _____  

    Raphael Tryster 

    -----Original Message----- 
    From:   Dal Chohan [SMTP:[email-masked]] 
    Sent:   Wednesday, 4 February 2004 18:12 
    To:     [email-masked] 
    Subject:        [Megaco] H.248.23 Enhanced Alerting Package. 

      
      
    Dal Chohan