Subject: [Megaco] Events Descriptor with KeepActive set and an Emebdded Signals Descriptor

From: "Dal Chohan" <[email-masked]>
Date: Mon, 2 Feb 2004 12:10:34 -0000

H.248v2 clause 7.1.9 states that ; "A media gateway controller shall not send EventsDescriptors with an event both marked KeepActive and containing an embedded SignalsDescriptor"
I think that this is unnecessarily too restrictive and unduly reduces the flexibility of H.248. The judicious use of the KA flag within the Embedded Signal descriptor itself can keep the Signal currently being applied active.

The following scenario describes a practical situation where the above rule is violate. Take the case where "Automatic Metering" is applied to an analogue line and automatic meter pulses are being generated  by the MG. Now the MG is monitoring for "On-Hook" and the KA (KeepActive) flag is sent against the "On-Hook" event. Upon detection of  "On-Hook" the event is reported to the MGC by the MG and the automatic metering still continues. 

Now the MGC sends a command requesting that the MG monitor for "Off-Hook" with the KA flag set, plus an Embedded signals/event descriptor indicating that "dial tone" should be played. In addition the KA flag is set for the "enable metering" signal to ensure that the automatic metering continues when the dial tone signal is applied , and the digit map descriptor is also enabled. Now this sequence clearly violates the rule stated above.

I would therefore recommend that the sentence above is deleted from the specification unless someone can think off a good reason for keeping it, because it is unnecessarily too restrictive and reduces the flexibility of the H.248 protocol.

Regards.

Dal Chohan

---

From: Christian Groves <[email-masked]>
Date: Fri, 06 Feb 2004 08:43:08 +1100

Hello Dal,

I believe there may be some confusion over which KeepActive is being referred to 
by the text. Both the EventDescriptor and the signal descriptor can have the 
keep active flag. This text talks about the EventDescriptor keepactive flag. The 
reason the text was added was that in the case of an embedded signals descriptor 
it doesn't make sense to have a keep active flag in the EventDescriptor because 
  the embedded signals descriptor will become active at the detection of event 
and any existing signals would be subject to the keep active flags in this 
embedded descriptor. So I believe your scenarios are handled.

Regards, Christian

Dal Chohan wrote:

> H.248v2 clause 7.1.9 states that ; "A media gateway controller shall not 
> send EventsDescriptors with an event both marked KeepActive and 
> containing an embedded SignalsDescriptor"
> 
> I think that this is unnecessarily too restrictive and unduly reduces 
> the flexibility of H.248. The judicious use of the KA flag within the 
> Embedded Signal descriptor itself can keep the Signal currently being 
> applied active.
> 
> The following scenario describes a practical situation where the above 
> rule is violate. Take the case where "Automatic Metering" is applied to 
> an analogue line and automatic meter pulses are being generated  by the 
> MG. Now the MG is monitoring for "On-Hook" and the KA (KeepActive) flag 
> is sent against the "On-Hook" event. Upon detection of  "On-Hook" the 
> event is reported to the MGC by the MG and the automatic metering still 
> continues.
> 
> Now the MGC sends a command requesting that the MG monitor for 
> "Off-Hook" with the KA flag set, plus an Embedded 
> signals/event descriptor indicating that "dial tone" should be played. 
> In addition the KA flag is set for the "enable metering" signal to 
> ensure that the automatic metering continues when the dial tone signal 
> is applied , and the digit map descriptor is also enabled. Now this 
> sequence clearly violates the rule stated above.
> 
> I would therefore recommend that the sentence above is deleted from the 
> specification unless someone can think off a good reason for keeping it, 
> because it is unnecessarily too restrictive and reduces the flexibility 
> of the H.248 protocol.
> 
>  
> 
>  
> Regards.
>  
>  
> Dal Chohan

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Fri, 06 Feb 2004 08:43:08 +1100

Hello Dal,

Regards, Christian