Subject: RE: [Megaco] Query Related to Automatic Metering

From: Aleksandr Ryabin <[email-masked]>
Date: Fri, 06 Feb 2004 11:47:32 -0500

Sampath,

metd already adheres to that way as described in its
"KeepActive and EventbufferControl Procedures."

Regards,
         Aleks

>From: "Sampath Komanduri"<[email-masked]>
>To: "'Tom Taylor'"<[email-masked]>,
>    "'Kevin Boyle'"<[email-masked]>,
>    "'Aleksandr Ryabin'"<[email-masked]>
>Subject: RE: [Megaco] Query Related to Automatic Metering
>Date: Fri, 6 Feb 2004 01:14:07 -0800
>
>Hi Kevin/Aleks,
>Is my understanding correct that we are going to change the AMET and METD
>package procedures to reflect the issue raised by gsachin and agreed by Tom?
>Pls. let me know.
>Thanks,
>Sampath
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom
>Taylor
>Sent: Monday, December 22, 2003 8:53 AM
>Cc: [email-masked]
>Subject: Re: [Megaco] Query Related to Automatic Metering
>
>
>I think you make a good point.  It's desirable to keep the protocol
>intact, rather than define exceptions within individual packages.
>
>gsachin wrote:
>
> >
> >
> >
> > Hi List,
> >
> >
> > this is a query regarding Periodic report event 'pr' defined in AMET
> > package .the package procedure says that
> >
> > "the detection of event pr shall not cause the termination of the
> > signal em or signal mbp, even if the KeppActive(KA) flag is not set
> > for the pr event"
> >
> > what i feel is that the detection of the 'pr' event shall not cause
> > the termination of any of the signals.
> >
> > pls tell me if this is a correct assumption?
> >
> > if yes, then i think here the package procedures should have mandated
> > the use of KA flag with this event. Doing this will keep the protocol
> > rules intact.
> >
> >
> >
> > Regards
> > Sachin Gupta

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Aleksandr Ryabin <[email-masked]>
Date: Fri, 06 Feb 2004 11:47:32 -0500

Sampath,

Regards,
         Aleks

---

From: "Sachin Gupta" <[email-masked]>
Date: Fri, 6 Feb 2004 18:06:41 -0800

Aleks,
The "KeepActive and EventbufferControl Procedures." in the metd package does
not mandate the use of KeepActive(KA) flag.

In case MGC comes with "metering pulse detection" event without KA Flag then
what should be MGs behaviour?

A) Should it do the normal processing (i.e stop all signals), as mentioned
in the base protocol, when this event is detected?
B) Should it report an error for the command request?
C) Should it do the processing as if KA flag is there, even though call
agent has not specified it?

Do we have any scenarios where detection of this event may require stopping
of currently applied signals? If not, then shouldn't the use of KA be
mandated?

Pls clarify.

Thanks
Sachin gupta

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Aleksandr Ryabin
Sent: Friday, February 06, 2004 8:48 AM
To: [email-masked]; [email-masked]
Cc: 'Tom Taylor'; 'Kevin Boyle'
Subject: RE: [Megaco] Query Related to Automatic Metering

Sampath,

Regards,
         Aleks

---

From: "Sachin Gupta" <[email-masked]>
Date: Fri, 6 Feb 2004 18:06:41 -0800

Aleks,

Pls clarify.

Thanks
Sachin gupta

-----Original Message-----

Sampath,

Regards,
         Aleks

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 09 Feb 2004 09:39:43 -0500

Sachin Gupta,

A)

The package definition should not really care ether there are such cases, 
or not.
It is up to MGC to control and direct MG on how exactly MGC wants MG to behave.
That is if it wants it for whatever reason terminate all signals on 
detection of the
event then it will not provide KA.

Regards,
         Aleks

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 09 Feb 2004 09:39:43 -0500

Sachin Gupta,

A)

Regards,
         Aleks