Subject: [Megaco] SIP MEGACO interworking

From: Carl Rutter <[email-masked]>
Date: Thu, 26 Feb 2004 10:30:35 -0500

I have a question about dealing with differences between SIP and MEGACO
SDP formats.  I noticed there was a similar thread about this not too long
ago.
http://www.ietf.org/mail-archive/working-groups/megaco/current/msg04724.html
I believe it ended with the point that the MGC needed to do some massaging.

My specific issue is with T.38.   The "SIP Support for real-time Fax"
document
has 1 session with multiple media session-levels.  The T.38 document p34
indicates the 
media lines MUST be separated by a version descriptor.  Given the
incompatible
formats I believe the MGC must do some massaging.  
Is this correct?
Should the MG just handle both cases?
Is there a SIP/MEGACO interworking document?

Thanks,
Carl

Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922 
www.telica.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Fri, 27 Feb 2004 07:41:08 +0100

Hi,

Comments inline ([CHH])

>Carl Rutter wrote:
>>I have a question about dealing with differences between 
>>SIP and MEGACO SDP formats.  I noticed there was a similar thread about 
>>this not too long ago.
>> 
>>http://www.ietf.org/mail-archive/working-groups/megaco/currentmsg04724.html
>>My specific issue is with T.38.   The "SIP Support for 
>>real-time Fax" document has 1 session with multiple media session-levels.  The T.38 
>>document p34 indicates the media lines MUST be separated by a version descriptor.  Given the
>>incompatible formats I believe the MGC must do some massaging.  
>>Is this correct?
>I don't know about the T.38 question.  But I suspect that if you look 
>very closely at the semantics of SDP usage in MEGACO and SIP, you'll 
>find more basic reasons for an interworking MGC to massage the SDP. 
>Sure, they both borrowed the SDP *syntax*... (Actually, MEGACO twists 
>*that* pretty hard...)

[CHH] In H.248 you must, as you said, separate the m= lines (one for audio, one for t38 fax) with v= lines. In SIP you don't have to do that (you can have multiple m= lines under a single v= line) so your controller will have to do some SDP "restructuring".

[CHH] Having said that, the H.248 spec actually at one point does say that a node shall be able to handle a RFC2327 compliant SDP (which could mean multiple m= lines), which I think is a little confusing. However, we shall remember that this is not the only way where H.248 diverts from the SDP standard, and the H.248 does specify those things. There has been discussions if/how things related to the H.248 SDP handling could be clarified, though.
 
>Does the sending port have to be the receiving port?

[CHH] I don't think that the H.248 spec (nor the SDP spec) specifies that. I know that many nodes do, and eg the G.799.1 media gateway spec requires it.

>Is the m=line a preference ordered list?
>Am I expressing the list of codecs I'm willing to receive, or
>willing to send and receive?

[CHH] In H.248 I believe you are specifying the codecs you want to "reserve resources" for, and the mode property then indicates the media direction. In SDP you indicate which codecs you are able to receive (which, in practic, mostly also means the codecs you are able to send). Please note that H.248 uses SDP for "controlling" another node, and not only for offer/answer two-party negotiation.

>Must the payload types be the same in both directions?

[CHH] This issue came up at a SIPit interop event once, and the answer was no.

>Are the return SDP ("answer") codecs a subset of the initial 
>SDP ("offer")?

[CHH] Yes, and you use the ReserveValue property to indicate if you want to use one or as-many-as-possible of the given codecs.

>How do you express putting a stream "on hold"?

[CHH] That depends on where you are situated in the network, I think. "On hold" is pretty much a signalling thing, and if a node receives a "hold" indicator, and is required to eg do something specific with the media, it may use H.248 to do whatever it has to do. I see no reason to define specific H.248 "hold behaviour".

>How are multiple media streams an multiple sessions handled?

[CHH] Could you please clarify? :)

>Do you have a=rtpmap lines for static payload types?

[CHH] You can have, but you're not required to. That is basic SDP, and H.248 doesn't change that behaviour.

>Doesn't MEGACO allow you to leave out whole lines that are required in the SDP RFC and in SIP?

[CHH] Yes, and that is defined in the spec.

[CHH] The SDP issue has been discussed on the list, and at meetings, and as I said earlier, people are looking into if/how things could be clarified, including the SDP "interworking" between protocols like H.248 and SIP.

Regards,

Christer Holmberg
Ericsson Finland

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Fri, 27 Feb 2004 07:41:08 +0100

Hi,

Comments inline ([CHH])

 

Regards,

Christer Holmberg
Ericsson Finland