Subject: [Megaco] pulse dialing ?

From: Troy Cauble <[email-masked]>
Date: Mon, 02 Feb 2004 13:32:53 -0500

Are there packages for pulse dialing?

Generally, you could just use the DTMF detection packages.
A '2' is a '2', right?

But consider this US-centric example:  The *XX services,
such as *69, are supported via pulse dialing 1169.

Supporting this would require not only differentiating between
pulse dialed digits and touch-tone, but also different digit
maps for each.

Thoughts?

-troy

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 2 Feb 2004 13:47:16 -0500

I don't see where it matters if you collect *XX or 11XX.  Let's take the
example below:  In North America, starting with 1 means a call out of your
LATA.  However, there are no NPAs or NXXs in NA that begin with 1.
Therefore, the switch will know that this is a feature code since it starts
with 11.  (Of course, this is why there are no NPAs or NXXs that begin with
1).

Kevin 

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]] 
Sent: Monday, February 02, 2004 1:33 PM
To: MEGACO list
Subject: [Megaco] pulse dialing ?

But consider this US-centric example:  The *XX services, such as *69, are
supported via pulse dialing 1169.

Supporting this would require not only differentiating between pulse dialed
digits and touch-tone, but also different digit maps for each.

Thoughts?

-troy

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 2 Feb 2004 13:47:16 -0500

Kevin 

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]] 
Sent: Monday, February 02, 2004 1:33 PM
To: MEGACO list
Subject: [Megaco] pulse dialing ?

Thoughts?

-troy

---

From: "CHATRAS Bruno FTRD/DAC/ISS" <[email-masked]>
Date: Tue, 3 Feb 2004 13:32:24 +0100

I believe that using different set of packages would be more appropriate for DTMF detection and Pulse Dialing detection, as these two dialing procedures involve completly different types of resources in the MG. 

Moreover, the current wording of the DTMF package (which extends the Tone Detection package) explicitly refers to the detection of audio tones (as opposed to pulses). Use of the DTMF package for supporting pulse dialing would, as a minimum, require changes to the package description.

Use of the same package for both DTMF and pulse dialing would also have a side effect on audit procedures: Auditing the list of supported packages would not enable the MGC to know whether the MG supports DTMF detection, pulse detection, or both.

Bruno

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Kevin Boyle
Envoyé : lundi 2 février 2004 19:47
À : Troy Cauble; MEGACO list
Objet : RE: [Megaco] pulse dialing ?

I don't see where it matters if you collect *XX or 11XX.  Let's take the example below:  In North America, starting with 1 means a call out of your LATA.  However, there are no NPAs or NXXs in NA that begin with 1. Therefore, the switch will know that this is a feature code since it starts with 11.  (Of course, this is why there are no NPAs or NXXs that begin with 1).

Kevin 

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]] 
Sent: Monday, February 02, 2004 1:33 PM
To: MEGACO list
Subject: [Megaco] pulse dialing ?

But consider this US-centric example:  The *XX services, such as *69, are supported via pulse dialing 1169.

Supporting this would require not only differentiating between pulse dialed digits and touch-tone, but also different digit maps for each.

Thoughts?

-troy

---

From: "CHATRAS Bruno FTRD/DAC/ISS" <[email-masked]>
Date: Tue, 3 Feb 2004 13:32:24 +0100

Bruno

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Kevin Boyle
Envoyé : lundi 2 février 2004 19:47
À : Troy Cauble; MEGACO list
Objet : RE: [Megaco] pulse dialing ?

Kevin 

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]] 
Sent: Monday, February 02, 2004 1:33 PM
To: MEGACO list
Subject: [Megaco] pulse dialing ?

Thoughts?

-troy