Subject: Re: [Megaco] question about disconnection message from MGW

From: 杨先波 <[email-masked]>
Date: Thu, 12 Feb 2004 09:02:18 +0800

Thank for your reply, but if MGW send Disconnection indication to MGC, which means
MGW disconnected from MGC just now, now MGW restores connection with MGC, then
maybe state of the MGW  is different from what MGC regarded , so MGC need audit MGW
to sychornize with it.  All above can be found in the document: draft-ietf-megaco-callflows-02.txt,
which reads as below:

The MG issues the disconnection method of Service Change when it lost
the communication with MGC and later regains it. The MGC normally
generates an Audit message to assess the state of the terminations
before and after the disconnection. The Audit command enables MGC to
synchronize its state with the MG's state.

Though it is a draft, but I think it is reasonable. What about your opinion?
Thanks for your reply again!

-----原始邮件-----
发件人: Kevin Boyle [mailto:[email-masked]]
发送时间: 2004年2月12日 2:31
收件人: ÑîÏè²¨; [email-masked]
Title: RE: [Megaco] question about disconnection message from MGW

This would all depend upon what the MGC is trying to accomplish.  How the
MGC would use an audit depends heavily upon what function it performs.

Note that there are no requirements as to when or how audits are performed.
Audits are a tool to be used as appropriate by an implementation.

Kevin 
________________________________

	From: [email-masked] [mailto:[email-masked]] 
	Sent: Wednesday, February 11, 2004 3:28 AM
	To: [email-masked]
	Subject: [Megaco] question about disconnection message from MGW

	Hi,all
	if MGC receives a message svc.req(ROOT,Method=Disconnection) ,
	I am not sure if MGC should sends audit command after svc.reply,
	and if MGC sends audit to MGW, how MGC should use audit.reply,
	that is what should MGC deal with the reply message. Thanks a lot!
	                                   Simba

z��f��)��+-1�r����+�m����5��_��?�������+-�w��g�i�

---

From: Zhao Bo <[email-masked]>
Date: Thu, 12 Feb 2004 10:06:05 +0800

Hi, please refer to section 7.28 of H.248.1, description of ServiceChangeMethod "Disconnected":

Disconnected: always applied with the Root TerminationID, indicates that the MG lost
communication with the MGC, but it was subsequently restored to the same MGC (possibly
after trying other MGCs on a pre-provisioned list). Since MG state may have changed, the
MGC may wish to use the Audit command to resynchronize its state with the MG's.

----- Original Message ----- 
From: "杨先波" <[email-masked]>
To: "Kevin Boyle" <[email-masked]>; <[email-masked]>
Sent: Thursday, February 12, 2004 9:02 AM
Subject: Re: [Megaco] question about disconnection message from MGW

> 1r艊XXi z׮m? 0 '~ ffX) (1�r���X��X��Ǡi�"z��m��?�0�'�~���f��f��X��)ߣ����(

---

From: Zhao Bo <[email-masked]>
Date: Thu, 12 Feb 2004 10:06:05 +0800