Subject: [Megaco] Are Megaco subscribers immobile??

From: Madhubabu Brahmanapally <[email-masked]>
Date: Mon, 23 Feb 2004 10:33:38 -0800

Hi All,
The present Protocol spec doesn't address the issue of mobility of users
connected to the residential gateways. Are there any proposals for
registration of endpoints when they change their physical location (Yet
retaining their domain name,etc).  Similar to the REGISTER message in SIP. 
 
Regards
Madhubabu

---

From: Madhubabu Brahmanapally <[email-masked]>
Date: Mon, 23 Feb 2004 12:15:22 -0800

Hi Tom,
Thanks for the reply.

If the protocol doesn't provide any mechanism...everything boils down to
provisioning which defeats the purpose of mobility...Of course the protocol
is not addressing the mobility issue..

But, If new terminations/cards are added...apart from pre-provisioning
shouldn't there be a way so that the GW can scale using the protocol
interface. rather than through proprietary means...

Even now when the serviceChange when generated with "restart", it is assumed
that the terminations are pre-provisioned at the MGC. Then, How does the MGs
scale dynamically. Of course scaling down is not a problem...as the group of
terminations are already known to both entities.

Regards
Madhubabu

-----Original Message-----
From: Tom Taylor [mailto:[email-masked]]
Sent: Monday, February 23, 2004 10:50 AM
To: Madhubabu Brahmanapally
Cc: [email-masked]
Subject: Re: [Megaco] Are Megaco subscribers immobile??

I would think this contrary to the spirit of Megaco, in that the awareness
of 
services resides in the MGC alone and is not reflected in the protocol.

---

From: [email-masked]
Date: Tue, 24 Feb 2004 02:02:17 +0530

Madhubabu,
 
  Protocol might not directly address the dynamic scaling of MG's, but it is always possible that, service change with restart could be initiated, when MGC is made aware of the fact that, we are adding the new terminations and then trigger a service change with restart. This would indirectly amount to dynamic scaling of MG's with out any proprietary means.
 
Thanks,
Shashi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Madhubabu Brahmanapally
Sent: Tuesday, February 24, 2004 1:45 AM
To: 'Tom Taylor'
Cc: [email-masked]
Subject: RE: [Megaco] Are Megaco subscribers immobile??

Hi Tom, 
Thanks for the reply. 

If the protocol doesn't provide any mechanism...everything boils down to provisioning which defeats the purpose of mobility...Of course the protocol is not addressing the mobility issue..

But, If new terminations/cards are added...apart from pre-provisioning shouldn't there be a way so that the GW can scale using the protocol interface. rather than through proprietary means...

Even now when the serviceChange when generated with "restart", it is assumed that the terminations are pre-provisioned at the MGC. Then, How does the MGs scale dynamically. Of course scaling down is not a problem...as the group of terminations are already known to both entities.

Regards 
Madhubabu 

-----Original Message----- 
From: Tom Taylor [ mailto:[email-masked]] 
Sent: Monday, February 23, 2004 10:50 AM 
To: Madhubabu Brahmanapally 
Cc: [email-masked] 
Subject: Re: [Megaco] Are Megaco subscribers immobile?? 

I would think this contrary to the spirit of Megaco, in that the awareness of 
services resides in the MGC alone and is not reflected in the protocol.

---

From: [email-masked]
Date: Tue, 24 Feb 2004 02:02:17 +0530

Madhubabu,

Thanks,
Shashi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Madhubabu Brahmanapally
Sent: Tuesday, February 24, 2004 1:45 AM
To: 'Tom Taylor'
Cc: [email-masked]
Subject: RE: [Megaco] Are Megaco subscribers immobile??

Hi Tom, 
Thanks for the reply. 

Regards 
Madhubabu

---

From: Madhubabu Brahmanapally <[email-masked]>
Date: Mon, 23 Feb 2004 14:14:41 -0800

Hi Shashi,
ServiceChange can be sent from MG to those terminations that MGC is already
in aware of (and not for those which were never provisioned at the MGC).
Tom's reply seems more logical as the protocol only deals with the
Mediaprocessing, events and signals. Its not within the scope of the
protocol.
 
Regards
Madhubabu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, February 23, 2004 12:32 PM
To: Madhubabu Brahmanapally; [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Are Megaco subscribers immobile??

Madhubabu,
 
  Protocol might not directly address the dynamic scaling of MG's, but it is
always possible that, service change with restart could be initiated, when
MGC is made aware of the fact that, we are adding the new terminations and
then trigger a service change with restart. This would indirectly amount to
dynamic scaling of MG's with out any proprietary means.
 
Thanks,
Shashi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Madhubabu Brahmanapally
Sent: Tuesday, February 24, 2004 1:45 AM
To: 'Tom Taylor'
Cc: [email-masked]
Subject: RE: [Megaco] Are Megaco subscribers immobile??

Hi Tom, 
Thanks for the reply. 

Regards 
Madhubabu 

-----Original Message----- 
From: Tom Taylor [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Monday, February 23, 2004 10:50 AM 
To: Madhubabu Brahmanapally 
Cc: [email-masked] 
Subject: Re: [Megaco] Are Megaco subscribers immobile?? 

> Madhubabu 

Confidentiality Notice

The information contained in this electronic message and any attachments to
this message are intended

for the exclusive use of the addressee(s) and may contain confidential or
privileged information. If

you are not the intended recipient, please notify the sender at Wipro or
[email-masked] immediately

and destroy all copies of this message and any attachments.

---

From: Madhubabu Brahmanapally <[email-masked]>
Date: Mon, 23 Feb 2004 14:14:41 -0800

Hi Shashi,
 
Regards
Madhubabu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, February 23, 2004 12:32 PM
To: Madhubabu Brahmanapally; [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Are Megaco subscribers immobile??

Madhubabu,

Thanks,
Shashi

-----Original Message-----

Hi Tom, 
Thanks for the reply. 

Regards 
Madhubabu 

-----Original Message----- 

Confidentiality Notice