Subject: [Megaco] SIP MEGACO interworking

From: Carl Rutter <[email-masked]>
Date: Thu, 26 Feb 2004 10:30:35 -0500

I have a question about dealing with differences between SIP and MEGACO
SDP formats.  I noticed there was a similar thread about this not too long
ago.
http://www.ietf.org/mail-archive/working-groups/megaco/current/msg04724.html
I believe it ended with the point that the MGC needed to do some massaging.

My specific issue is with T.38.   The "SIP Support for real-time Fax"
document
has 1 session with multiple media session-levels.  The T.38 document p34
indicates the 
media lines MUST be separated by a version descriptor.  Given the
incompatible
formats I believe the MGC must do some massaging.  
Is this correct?
Should the MG just handle both cases?
Is there a SIP/MEGACO interworking document?

Thanks,
Carl

Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922 
www.telica.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Thu, 26 Feb 2004 11:34:27 -0500

> Is there a SIP/MEGACO interworking document?

I don't know about the T.38 question.  But I suspect that if you look 
very closely at the semantics of SDP usage in MEGACO and SIP, you'll 
find more basic reasons for an interworking MGC to massage the SDP. 
Sure, they both borrowed the SDP *syntax*... (Actually, MEGACO twists 
*that* pretty hard...)

I may be wrong.  I may be mixing in some MGCP interworking issues.  But 
I would look closely at.

Does the sending port have to be the receiving port?
Is the m=line a preference ordered list?
Am I expressing the list of codecs I'm willing to receive, or
willing to send and receive?
Must the payload types be the same in both directions?
Are the return SDP ("answer") codecs a subset of the initial SDP ("offer")?
How do you express putting a stream "on hold"?
How are multiple media streams an multiple sessions handled?
Do you have a=rtpmap lines for static payload types?

Doesn't MEGACO allow you to leave out whole lines that are required
in the SDP RFC and in SIP?

-troy

---

From: Troy Cauble <[email-masked]>
Date: Thu, 26 Feb 2004 11:34:27 -0500

-troy