Subject: [Megaco] SDP equivalents

From: Kalleitner Franz <[email-masked]>
Date: Mon, 30 Aug 2004 09:06:44 +0200

Dear Megaco-List members,

I would be interested in finding an implementation rule concerning SDP
equivalents.
As known  the SDP lines can be imbedded as octet string in the binary
encoded H248 local and remote descriptor.
Further, as PkgdName the native property tags specified in Annex C11 are
used, to address specific SDP lines (e.g v=,m=,...)

I wonder if the octet string includes the SDP description types as
v=,m=,.... since this information is already present with the property tag.
I found nowhere a clear statement if these SDP "prefixes" are still part of
the octet string or not.
It would be great if somebody could respond if variant 1 or 2 is the correct
format:

Variant 1 (with SDP line descriptor 'm='):
....
localDescriptor {
	propGps {
		{
			{
			name ´0000B00F´H   // SDP_M
			value {
					´m=audio $ RTP/AVP 96' } } } } }

Variant 2 (without SDP line descriptors 'm='):
....
localDescriptor {
	propGps {
		{
			{
			name ´0000B00F´H   // SDP_M
			value {
					´audio $ RTP/AVP 96' } } } } }

Thanks !

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Mon, 30 Aug 2004 10:14:32 -0400

In my opinion, the second form would be the right one, but let's hear from peoplke 
who have implemented binary.

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 30 Aug 2004 11:38:53 -0400

I agree, second form is the right one.
         Aleks

At 10:14 AM 8/30/2004, Tom Taylor wrote:
>In my opinion, the second form would be the right one, but let's hear from 
>peoplke who have implemented binary.
>
>Kalleitner Franz wrote:
>