Subject: [Megaco] DigitMap question

From: "FCG Wang SiHai" <[email-masked]>
Date: Fri, 13 Aug 2004 17:08:47 +0800

Hello:
     When implement DigitMap deletion, we meet a problem.
     As RFC3525 description:
      -  A DigitMap is deleted by supplying an empty value for a name that
      is already defined.  Terminations presently using the digitmap
      shall continue to use the old definition.
      Whether DigitMap descriptor format is:
      DigitMap= Dialplan0 
      or 
      DigitMap= Dialplan0{}
      
      From Annex B ABNF definition:
      digitMapDescriptor  = DigitMapToken EQUAL
                        ( ( LBRKT digitMapValue RBRKT ) /
                        (digitMapName [ LBRKT digitMapValue RBRKT ]) )
      When digitvalue is null, whether {} is needed?
     
      Thank you!
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Fri, 13 Aug 2004 14:43:13 +0530

Hi,
           When digitMapValue is null , you need not specify {}  as  '[ 
LBRKT digitMapValue RBRKT ]' is optional.
            i.e. 
            DigitMap descriptor format is:
                 DigitMap= Dialplan0 
 
regards
Rakhi

Sent by:        [email-masked]
To:     <[email-masked]>
cc:      

Subject:        [Megaco] DigitMap question

Hello:
       -  A DigitMap is deleted by supplying an empty value for a name 
that

       Thank you!

*****************    HSS-Private    *************