Subject: [Megaco] IndAudlocalControlDescriptor inconsistency

From: Hakan Mattsson <[email-masked]>
Date: Mon, 9 Aug 2004 17:55:26 +0200 (CEST)

In the ASN.1 specification of IndAudLocalControlDescriptor it is
allowed with one each of stream mode, reserve value and reserve group
plus a any number of package names:

      IndAudLocalControlDescriptor ::= SEQUENCE 
      { 
         streamMode              NULL OPTIONAL, 
         reserveValue            NULL OPTIONAL, 
         reserveGroup            NULL OPTIONAL, 
         propertyParms           SEQUENCE OF IndAudPropertyParm OPTIONAL, 
         ... 
      } 
      
      IndAudPropertyParm ::= SEQUENCE 
      { 
         name     PkgdName, 
         ... 
      } 
       
while it in the ABNF specification of indAudlocalControlDescriptor is
limited to be exactly one of stream mode, reserve value, reserve group
and package name:

      indAudlocalControlDescriptor = LocalControlToken  
                        LBRKT indAudlocalParm RBRKT 
       
      ; at-most-once per item 
      indAudlocalParm   = ( ModeToken / pkgdName / 
                      ReservedValueToken / 
                      ReservedGroupToken ) 

For example this means that it is possible to have both stream mode
and package name in ASN.1, while this is not allowed in ABNF.

To me this looks like a bug in the Megaco standard as the ASN.1
encoding and ABNF encoding is not semantically equivalent in this
case.

I suggest that the ABNF should be changed to the following in order to
be compliant with ASN.1:

      indAudlocalControlDescriptor = LocalControlToken  
                        LBRKT indAudlocalParm  *(COMMA indAudlocalParm) RBRKT 

I would appreciate if someone on the list could clarify whether this
Megaco bug is in ABNF or ASN.1.

/Håkan

---
Håkan Mattsson, Ericsson AB
High Availability Software, DBMS Internals
http://www.erlang.org/~hakan/

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Atul Khandelwal" <[email-masked]>
Date: Tue, 10 Aug 2004 10:18:35 +0530

Hi Group,

Can any one tell me where can i find a free down load for MEGACO software.
Also pls let me know which version of CISCO Call Manager/CISCO BTS supports
MEGACO,
 or any other Softswitch that supports MEGACO.
Also is there any difference between context and context id...i mean for one
context can we have two context ids,
or is it like the call from RG1 to MGC is one context and the call from RG2
to MGC is another, both with separate context ids.

Thanks
Atul

---

From: [email-masked]
Date: Tue, 10 Aug 2004 10:19:49 +0530

Hi Atul,

Yes one context is created for each MG at MGC.
You can visit following link for open source code for Megaco/H.248
                                                                            
 www.erlang.org/project/megaco/                                             

Thanks
Ashish

             "Atul Khandelwal"                                             
             <atul.khandelwal@                                             
             alliancetelephony                                          To 
             .com>                     <[email-masked]>                   
             Sent by:                                                   cc 
             megaco-bounces@ie                                             
             tf.org                                                Subject 
                                       [Megaco] MEGACO Software            
                                                                           
             08/10/2004 10:18                                              
             AM                                                            

Hi Group,

Also is there any difference between context and context id...i mean for
one

Thanks
Atul

 ***********************  HSS-Unclassified   ***********************

---

From: Hakan Mattsson <[email-masked]>
Date: Mon, 16 Aug 2004 15:45:58 +0200 (CEST)

Please, can someone clarify this issue?

I did not get any replies at all on the posting below.

/Håkan

On Mon, 9 Aug 2004, Hakan Mattsson wrote:

HM> Date: Mon, 9 Aug 2004 17:55:26 +0200 (CEST)
HM> From: Hakan Mattsson <[email-masked]>
HM> To: [email-masked]
HM> Subject: IndAudlocalControlDescriptor inconsistency
HM> 
HM> 
HM> In the ASN.1 specification of IndAudLocalControlDescriptor it is
HM> allowed with one each of stream mode, reserve value and reserve group
HM> plus a any number of package names:
HM> 
HM> 
HM>       IndAudLocalControlDescriptor ::= SEQUENCE 
HM>       { 
HM>          streamMode              NULL OPTIONAL, 
HM>          reserveValue            NULL OPTIONAL, 
HM>          reserveGroup            NULL OPTIONAL, 
HM>          propertyParms           SEQUENCE OF IndAudPropertyParm OPTIONAL, 
HM>          ... 
HM>       } 
HM>       
HM>       IndAudPropertyParm ::= SEQUENCE 
HM>       { 
HM>          name     PkgdName, 
HM>          ... 
HM>       } 
HM>        
HM> while it in the ABNF specification of indAudlocalControlDescriptor is
HM> limited to be exactly one of stream mode, reserve value, reserve group
HM> and package name:
HM> 
HM>       indAudlocalControlDescriptor = LocalControlToken  
HM>                         LBRKT indAudlocalParm RBRKT 
HM>        
HM>       ; at-most-once per item 
HM>       indAudlocalParm   = ( ModeToken / pkgdName / 
HM>                       ReservedValueToken / 
HM>                       ReservedGroupToken ) 
HM> 
HM> For example this means that it is possible to have both stream mode
HM> and package name in ASN.1, while this is not allowed in ABNF.
HM> 
HM> To me this looks like a bug in the Megaco standard as the ASN.1
HM> encoding and ABNF encoding is not semantically equivalent in this
HM> case.
HM> 
HM> I suggest that the ABNF should be changed to the following in order to
HM> be compliant with ASN.1:
HM> 
HM>       indAudlocalControlDescriptor = LocalControlToken  
HM>                         LBRKT indAudlocalParm  *(COMMA indAudlocalParm) RBRKT 
HM> 
HM> I would appreciate if someone on the list could clarify whether this
HM> Megaco bug is in ABNF or ASN.1.
HM> 
HM> /Håkan
HM> 
HM> ---
HM> Håkan Mattsson, Ericsson AB
HM> High Availability Software, DBMS Internals
HM> http://www.erlang.org/~hakan/
HM> 
HM>

---

From: Christian Groves <[email-masked]>
Date: Mon, 23 Aug 2004 13:45:24 +1000

Hello Hakan,

H.248.1 sect 7.2.5 states: "It is possible to audit multiple individual items in 
one request."

So it seems the ABNF needs to be updated to accomodate multiple properties. Your 
suggestion seems OK to me. As this is a syntax change it probably should be 
incorporate as a change to H.248.1v3.

Regards, Christian