Subject: Re: [Megaco] Ambiguity in ABNF of indAudauditReturnParameter in H.248 v2

From: Hakan Mattsson <[email-masked]>
Date: Mon, 9 Aug 2004 16:22:30 +0200 (CEST)

CHG> Hello Francois,
CHG> 
CHG> 
CHG> I'm having some problem understanding what the ambiguity is. Please see my comments below.
CHG> 
CHG> Regards, Christian
CHG> 
CHG> 
CHG> Francois Plagnard wrote:
CHG> 
CHG> 
CHG> > Hello,
CHG> > 
CHG> > 
CHG> > In H.248v2, in indAudauditReturnParameter ABNF, according to my
CHG> > understanding, there are several ambiguities.
CHG> > 
CHG> > 
CHG> > For example,
CHG> >       indAudmediaDescriptor   = MediaToken LBRKT indAudmediaParm RBRKT
CHG> > means for me that you have only 1 instance of indAudmediaParm.
CHG> >
CHG> 
CHG> [CHG] Yes I agree.

The Megaco standard is not consistent in this regard.

In the ASN.1 encoding it is allowed with one each of streamMode,
reserveValue, reserveGroup and propertyParms:

      IndAudLocalControlDescriptor ::= SEQUENCE 
      { 
         streamMode              NULL OPTIONAL, 
         reserveValue            NULL OPTIONAL, 
         reserveGroup            NULL OPTIONAL, 
         propertyParms           SEQUENCE OF IndAudPropertyParm OPTIONAL, 
         ... 
      } 
       
while the textual encoding only allows exactly one 

     indAudmediaDescriptor   = MediaToken LBRKT indAudmediaParm RBRKT

     ; at-most-once per item
     ; and either streamParm or streamDescriptor but not both
     indAudmediaParm = (indAudstreamParm / indAudstreamDescriptor /
                        indAudterminationStateDescriptor)

CHG> 
CHG> >
CHG> >
CHG> > But, its definition is :
CHG> >       ; at-most-once per item
CHG> >       ; and either streamParm or streamDescriptor but not both
CHG> >       indAudmediaParm = (indAudstreamParm / indAudstreamDescriptor /
CHG> >                          indAudterminationStateDescriptor)
CHG> > which implies that you may have several instances !
CHG> >
CHG> 
CHG> [CHG] Doesn't this imply that you "choose" one instance from the alternatives?
CHG> 
CHG> >
CHG> >
CHG> > You have the same ambiguity with :
CHG> > - indAudlocalParm
CHG> > - indAudterminationStateParm
CHG> > ...
CHG> > 
CHG> > 
CHG> > May we have 1 or several instances of them ?
CHG> > And, if we may have several instances, how are they separated ?
CHG> > 
CHG> > 
CHG> > Best regards,
CHG> > 
CHG> > 
CHG> > ===================================================================
CHG> > Francois Plagnard,
CHG> > Netbricks
CHG> > 31 rue Jean Rostand
CHG> > 91893 ORSAY -- FRANCE
CHG> > Email: francois.plagnard at netbricks.com  - WEB : www.netbricks.com
CHG> > Tel: +33 (0)1 69 33 12 57 -- Fax: +33 (0)1 69 85 54 26
CHG> > ===================================================================

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Hakan Mattsson <[email-masked]>
Date: Mon, 9 Aug 2004 18:22:17 +0200 (CEST)

Please, forget about my previous mail with this subject and read the
one with the subject "IndAudlocalControlDescriptor inconsistency"
instead.

/Håkan
---
Håkan Mattsson, Ericsson AB
High Availability Software, DBMS Internals
http://www.erlang.org/~hakan/