Subject: RE: [Megaco] Modify to do Audit hook state

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 17 Aug 2004 17:49:55 -0400

The MGC would have to include any events previously present in the Events
descriptor in order to guarantee their continued detection, yes.

Kevin 

-----Original Message-----
From: Pascal Lambers [mailto:[email-masked]] 
Sent: Tuesday, August 17, 2004 5:03 PM
To: [email-masked]
Subject: Re: [Megaco] Modify to do Audit hook state

Kevin,

"The MGC must account for these kinds of issues when it is building
messages".
By this you mean, that if the MG returns an error "termination allready
off/on hook", the MGC has no longer any guarantee as to which events are
still programmed on the termination?

If so, the strict/exact and strict/state won't be of any help I'm afraid:
the Modify will always overwrite events that were present on the termination
before... and if the MGC just sent this Modify to know whether the hook
status of a termination is still as it expected, without taking anything
else, this is a problem. Do I interpret this correctly?

Pascal

----- Original Message -----
From: "Kevin Boyle" <[email-masked]>
To: "Pascal Lambers" <[email-masked]>; <[email-masked]>
Sent: Tuesday, August 17, 2004 10:45 PM
Subject: RE: [Megaco] Modify to do Audit hook state

> The MGC must account for these kinds of issues when it is building
messages.
>
> I would note that there are two other possible values for the strict parm
> that may be of more use: 'state' and 'exact'.  If having the MG generate
> errors is a problem, then you could use one of the other two options
> instead.
>
> Kevin
>
>
>
>   _____
>
> From: Pascal Lambers [mailto:[email-masked]]
> Sent: Tuesday, August 17, 2004 4:32 PM
> To: [email-masked]
> Subject: [Megaco] Modify to do Audit hook state
>
>
> Hello,
>
> Megaco does not provide an Audit message to audit a termination's hook
> status directly. That's clear.
>
> Instead, to know whether a termination is Off Hook, the MGC must send a
> Modify with an Off Hook (strict/failWrong) Events descriptor.
Consequently,
> if the termination is already off hook, the MG will reply with an error.
Is
> it sure that in such a case the events and signals implemented on this
> termination before the Modify arrived, are still present? In other words,
is
> it sure that messages from the MGC to the MG replied to with an error do
not
> have any negative effect?
>
> Kind regards,
> Pascal
>
>
>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Pascal Lambers" <[email-masked]>
Date: Wed, 18 Aug 2004 00:04:19 +0200

RE: [Megaco] Modify to do Audit hook stateIn this case a separate Audit Hook status mechanism makes sense. It makes sure there is no influence on call related funcionality. And as long as the MGC receives the expected answer it must not take any corrective action. If I'm not mistaken, MGCP allows a separate Audit.

Pascal

  ----- Original Message ----- 
  From: Kevin Boyle 
  To: Pascal Lambers ; [email-masked] 
  Sent: Tuesday, August 17, 2004 11:49 PM
  Subject: RE: [Megaco] Modify to do Audit hook state

  The MGC would have to include any events previously present in the Events descriptor in order to guarantee their continued detection, yes.

  Kevin 

  -----Original Message----- 
  From: Pascal Lambers [mailto:[email-masked]] 
  Sent: Tuesday, August 17, 2004 5:03 PM 
  To: [email-masked] 
  Subject: Re: [Megaco] Modify to do Audit hook state 

  Kevin, 

  "The MGC must account for these kinds of issues when it is building messages". 
  By this you mean, that if the MG returns an error "termination allready off/on hook", the MGC has no longer any guarantee as to which events are still programmed on the termination?

  If so, the strict/exact and strict/state won't be of any help I'm afraid: 
  the Modify will always overwrite events that were present on the termination before... and if the MGC just sent this Modify to know whether the hook status of a termination is still as it expected, without taking anything else, this is a problem. Do I interpret this correctly?

  Pascal 

  ----- Original Message ----- 
  From: "Kevin Boyle" <[email-masked]> 
  To: "Pascal Lambers" <[email-masked]>; <[email-masked]> 
  Sent: Tuesday, August 17, 2004 10:45 PM 
  Subject: RE: [Megaco] Modify to do Audit hook state 

  messages. 
  Consequently, 
  Is 
  is 
  not