Subject: [Megaco] Virtual Media Gateways and amount of Termination IDs

From: Tamar Nemet <[email-masked]>
Date: Wed, 8 Jun 2005 12:21:56 +0300

Hello,
 
I have some questions regarding Virtual media gateway:
 
1. I have one physical media gateway (with one IP address). We can define up
to 4400 Termination IDs on this media gateway.
    Does we have to devide the termination IDs to some virtual media
gateways or we can work with no virtual media gateway ?
 
2. Does SoftSwitches uses the Virtual Media Gatway object? for what ?
 
Thanks,
Tamar
 
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Wed, 8 Jun 2005 12:53:33 +0200

There is no requirement to artificially split a large gateway into multiple
virtual MGs.  You might have other reasons for wanting to split it.  For
example, there might be different sets of global characteristics that you
want to set differently for subsets of your terminations, so you would like
to have multiple ROOTs.  Or, you might want different sets of terminations
to be controlled by different soft switches.
 
Raphael Tryster

-----Original Message-----
From: Tamar Nemet [mailto:[email-masked]]
Sent: Wednesday, June 08, 2005 11:22 AM
To: [email-masked]'
Subject: [Megaco] Virtual Media Gateways and amount of Termination IDs
 
Hello,

 
 
Thanks,
Tamar

---

From: Tamar Nemet <[email-masked]>
Date: Wed, 8 Jun 2005 13:31:07 +0300

Hello raphael,
 
 Thanks for your answer. But I can't understand how the SoftSwitch can use
multiple ROOTs if the all the Virtual Media Gateways has the same IP address
?
 
Did you see any SoftSwitch that uses the Virtual MediaGateways ?
 
Thanks,
Tamar 

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Wednesday, June 08, 2005 1:54 PM
To: 'Tamar Nemet'; [email-masked]'
Subject: RE: [Megaco] Virtual Media Gateways and amount of Termination IDs

 
Raphael Tryster

-----Original Message-----
From: Tamar Nemet [mailto:[email-masked]]
Sent: Wednesday, June 08, 2005 11:22 AM
To: [email-masked]'
Subject: [Megaco] Virtual Media Gateways and amount of Termination IDs
 
Hello,

 
 
Thanks,
Tamar

---

From: Raphael Tryster <[email-masked]>
Date: Wed, 8 Jun 2005 14:17:08 +0200

They can use different UDP ports.  The answer to your second question is No,
but I would also be interested to hear different answers from others.
 
Raphael Tryster

-----Original Message-----
From: Tamar Nemet [mailto:[email-masked]]
Sent: Wednesday, June 08, 2005 12:31 PM
To: Raphael Tryster; Tamar Nemet; [email-masked]'
Subject: RE: [Megaco] Virtual Media Gateways and amount of Termination IDs

 Hello raphael,

 
Thanks,
Tamar 
 
-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Wednesday, June 08, 2005 1:54 PM
To: 'Tamar Nemet'; [email-masked]'
Subject: RE: [Megaco] Virtual Media Gateways and amount of Termination IDs
 There is no requirement to artificially split a large gateway into multiple
 
Raphael Tryster

-----Original Message-----
From: Tamar Nemet [mailto:[email-masked]]
Sent: Wednesday, June 08, 2005 11:22 AM
To: [email-masked]'
Subject: [Megaco] Virtual Media Gateways and amount of Termination IDs
 
Hello,

 
 
Thanks,
Tamar

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 8 Jun 2005 16:59:48 -0400

Some way of addressing the VMGs independently of each other is necessary.
FQDNs is one possible way.
 
I know of several MGCs that make use of VMGs.  The main point of VMGs is to
either allow partitioned control by different MGCs, or to allow resource
pooling that is not visible to the MGC.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Tamar Nemet
Sent: Wednesday, June 08, 2005 8:06 AM
To: 'Raphael Tryster'; Tamar Nemet; [email-masked]'
Subject: RE: [Megaco] Virtual Media Gateways and amount of Termination IDs

 Can the SoftSwitch use different FQDNs for virtual media gateways and not
the ip address and port of the physical Media gateway ?
 
Tamar

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Wednesday, June 08, 2005 3:17 PM
To: 'Tamar Nemet'; [email-masked]'
Subject: RE: [Megaco] Virtual Media Gateways and amount of Termination IDs

Raphael Tryster

-----Original Message-----
From: Tamar Nemet [mailto:[email-masked]]
Sent: Wednesday, June 08, 2005 12:31 PM
To: Raphael Tryster; Tamar Nemet; [email-masked]'
Subject: RE: [Megaco] Virtual Media Gateways and amount of Termination IDs

 Hello raphael, 

 
Thanks,
Tamar 
 
-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Wednesday, June 08, 2005 1:54 PM
To: 'Tamar Nemet'; [email-masked]'
Subject: RE: [Megaco] Virtual Media Gateways and amount of Termination IDs
 
Raphael Tryster

-----Original Message-----
From: Tamar Nemet [mailto:[email-masked]]
Sent: Wednesday, June 08, 2005 11:22 AM
To: [email-masked]'
Subject: [Megaco] Virtual Media Gateways and amount of Termination IDs
 
Hello,

 
 
Thanks,
Tamar

---

From: Tamar Nemet <[email-masked]>
Date: Thu, 9 Jun 2005 13:47:42 +0300

Hello Albrecht,

Thanks for your answers, BUT I need some more information:

If my MG IP address is 10.10.10.8, how many Termination IDs can be defined
on it without using the Virtual MG object ?

Thanks,
Tamar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, June 09, 2005 1:04 PM
To: Raphael Tryster
Cc: [email-masked]'; Tamar Nemet
Subject: RE: [Megaco] Virtual Media Gateways and amount of Termination IDs

If you mean with "signaling IP@" the IP@ used for H.248 transport then NO.

1) A H.248 MG (= VMG or non-VMG) is denoted by a single H.248 Control
Association (see § F.2/H.248.1).
The Control Association is mapped on a "transport connection", in case of
IP dependent on UDP, TCP or SCTP transport.
In case of SCTP, you MAY(theoretically) use different IP@s for the "SCTP
multihoming" capability. But there are other realization possibilities as
well.

2) The H.248 Message ID may be IP@-based as well. Both IP@s are firstly
decoupled, but there are concepts (see certain H.248 Profiles), which
correlating both.

Regards
Albrecht
ALCATEL

                      Raphael Tryster

                      <raphael@tdsoft.         To:      Albrecht
SCHWARZ/DE/ALCATEL@ALCATEL, Tamar Nemet                        
                      com>                     <[email-masked]>

                                               cc:      "[email-masked]'"
<[email-masked]>                                   
                      09.06.2005 07:54         Subject: RE: [Megaco] Virtual
Media Gateways and amount of Termination IDs       

Do you mean that a physical MG might have several different signaling IP
addresses but NOT be divided into multiple virtual MGs?

Raphael Tryster

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, June 08, 2005 7:41 PM
To: Tamar Nemet
Cc: [email-masked]'; Raphael Tryster
Subject: RE: [Megaco] Virtual Media Gateways and amount of Termination IDs

Addressing IP interfaces of a H.248 MG is NO rationale for the introduction

of VMGs.
There are typically other requirements driving for VMG approaches. Even so,

the VMGs may share address space, or use disjoint IP addresses for the
diversity of IP applications served by a VoIP MG. This depends on the
specific use case and underlying network architecture.

So, please not misread § 11.1/H.248.1.

Rgds,
Albrecht
ALCATEL

                      Tamar Nemet

                      <tamar.nemet@com         To:      "'Raphael Tryster'"
<[email-masked]>, Tamar Nemet

                      match.com>               <[email-masked]>,
"[email-masked]'" <[email-masked]>

                      Sent by:                 cc:

                      megaco-bounces@i         Subject: RE: [Megaco]
Virtual Media Gateways and amount of Termination IDs

                      etf.org

                      08.06.2005 14:05

Tamar

      -----Original Message-----
      From: Raphael Tryster [mailto:[email-masked]]
      Sent: Wednesday, June 08, 2005 3:17 PM
      To: 'Tamar Nemet'; [email-masked]'
      Subject: RE: [Megaco] Virtual Media Gateways and amount of
      Termination IDs

      They can use different UDP ports.  The answer to your second question

      is No, but I would also be interested to hear different answers from
      others.

      Raphael Tryster

            -----Original Message-----
            From: Tamar Nemet [mailto:[email-masked]]
            Sent: Wednesday, June 08, 2005 12:31 PM
            To: Raphael Tryster; Tamar Nemet; [email-masked]'
            Subject: RE: [Megaco] Virtual Media Gateways and amount of
            Termination IDs

             Hello raphael,

             Thanks for your answer. But I can't understand how the
            SoftSwitch can use multiple ROOTs if the all the Virtual Media
            Gateways has the same IP address ?

            Did you see any SoftSwitch that uses the Virtual MediaGateways
            ?

            Thanks,
            Tamar

                  -----Original Message-----
                  From: Raphael Tryster [mailto:[email-masked]]
                  Sent: Wednesday, June 08, 2005 1:54 PM
                  To: 'Tamar Nemet'; [email-masked]'
                  Subject: RE: [Megaco] Virtual Media Gateways and amount
                  of Termination IDs
                  There is no requirement to artificially split a large
                  gateway into multiple virtual MGs.  You might have other
                  reasons for wanting to split it.  For example, there
                  might be different sets of global characteristics that
                  you want to set differently for subsets of your
                  terminations, so you would like to have multiple ROOTs.
                  Or, you might want different sets of terminations to be
                  controlled by different soft switches.

                  Raphael Tryster

                        -----Original Message-----

                        Sent: Wednesday, June 08, 2005 11:22 AM
                        To: [email-masked]'
                        Subject: [Megaco] Virtual Media Gateways and amount

                        of Termination IDs

                        Hello,

                        I have some questions regarding Virtual media
                        gateway:

                        1. I have one physical media gateway (with one IP
                        address). We can define up to 4400 Termination IDs
                        on this media gateway.
                            Does we have to devide the termination IDs to
                        some virtual media gateways or we can work with no
                        virtual media gateway ?

                        2. Does SoftSwitches uses the Virtual Media Gatway
                        object? for what ?

                        Thanks,
                        Tamar

---

From: "Rutter, Carlton (Carlton)" <[email-masked]>
Date: Thu, 9 Jun 2005 10:20:58 -0400

Tamar,

There is no real limit on the MG.  A high-density MG can have 40,000+
terminations.  As Kevin stated you could partitioned the control 
of the high-density MG via VMGs(if supported on the MG) by different MGCs.  
ie) One MGC can't effectively utilize all the terminations on the MG etc 

Carl

> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of Tamar Nemet
> Sent: Thursday, June 09, 2005 6:48 AM
> To: [email-masked]'; Raphael Tryster
> Cc: [email-masked]'
>                                                cc:      

                        of Termination IDs

                        Hello,

                        Thanks,
                        Tamar