Subject: RE: [Megaco] Dial Plan.

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 9 Jun 2005 12:51:23 -0400

A DigitMap can be named on Root and referenced by other terminations in
their completion events, yes.

When any completion event completes, the DigitMap is deactivated *for that
event*.  This means that no further digit reporting can occur using that
completion event until a new Events Descriptor is provided.  Digit buffering
WILL occur per the spec and any parameters contained in the completion
event.  This does NOT mean that other terminations are not able to use the
DigitMap.

A completion event on Root is nonsensical, since the MG function does not
collect digits -- a digit receiver connected to the termination is what
collects the digits.  Digit collection, therefore, is clearly tied to
individual terminations and not the MG as a whole.

Kevin

-----Original Message-----
From: Putter, Michael [Business:EXTRNL:3L40] 
Sent: Thursday, June 09, 2005 9:34 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Tamar Nemet; [email-masked]'
Subject: RE: [Megaco] Dial Plan.

Hello,

In continue to the question.
Can DigitMap be activated for the ROOT termination like other events by
Event descriptor with digit map completion event and then the digit map will
be active for a future call unless new Event descriptor with digit map
completion event will be applied for the call?
I have not found restriction in the standard for that scenario, but is it
real?
Do somebody use this way of digit map activation?

Thanks, Michael.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Kevin Boyle
Sent: Thursday, June 09, 2005 12:02 AM
To: Tamar Nemet; [email-masked]'
Subject: RE: [Megaco] Dial Plan.

MGs don't generally know about "dial plans".  They are told to collect
digits, through any of a number of means, and they report them.  The MGC is
responsible for translating the reported digits by applying the local dial
plan.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Tamar Nemet
Sent: Wednesday, June 08, 2005 5:28 AM
To: [email-masked]'
Subject: [Megaco] Dial Plan.

Hello,
 
Do you know how SoftSwitches activate the dial plan ? Does they do it per
call or they send an activation on the ROOT termination ?
 
Thanks,
Tamar

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Ashish Kumar" <[email-masked]>
Date: Tue, 14 Jun 2005 17:48:03 +0530

Hi,

I have a query about handling of Events Descriptor when Events Buffering is 
on.
Considering the following scenarios

Scenario 1
-----------
EventsBufferedDescriptor has following events
    E1, E2, E3
Buffered Events
    E1, E3

A new events descriptor is received with following events:
    E1, E2

In this case E1 will be reported.

Scenario 2
-----------
EventsBufferedDescriptor has following events
    E1, E2, E3
Buffered Events
    E1, E3

A new events descriptor is received with following events:
    E2                        (At this point active event list would have 
E2).

After this when, E2 occurs, should it be reported or buffered ?

If E2 is buffered then, wouldn't it be wrong since Event E2 was requested.
Basically in this case the behaviour is going to depend on the time when E2 
occurs.
If E2 occurs before Requested Event was received, then it will be reported.
And if it occurs after that, it will not be reported.
Is this behaviour correct ?

Regards
Ashish