Subject: RE: [Megaco] even H.248.2 has typos

From: Raphael Tryster <[email-masked]>
Date: Thu, 16 Jun 2005 22:19:45 +0200

Also for ctyp/dtone, parameter dtt has values DTMF and Sig which are both
0x000B.
For ctyp/v8bs, parameter v8bsn has values MRdrl and Crel which are both
0x0006, and Creh and Crdi which are both 0x0007.
 
Raphael Tryster

-----Original Message-----
From: Raphael Tryster 
Sent: Thursday, June 16, 2005 9:14 PM
To: 'Kevin Boyle'; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos
 
I noticed something else.  The basic Megaco packages and others, e.g.
H.248.23, do not have any identifiers of events, signals, properties and
statistics with the same values as one another.  I had the impression that
this was a requirement.  But several of the packages in H.248.2 start their
events, signals, properties and statistics identifiers at 0x0001.  Does it
matter?
 
One thing that probably does matter is that in fax package, properties
faxstate and ftrpt both have propertyID = 0x0001.
 
Raphael Tryster

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, June 16, 2005 5:45 PM
To: Raphael Tryster; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos
 
H.248.2 was revised at the November 2004 meeting of SG16.  The new spec is
dated 01/2005.
 
Kevin
 
  _____  

From: Raphael Tryster [mailto:[email-masked]] 
Sent: Thursday, June 16, 2005 12:46 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos
The revision in which I found these is dated 11/2000, which was the current
edition at least to the end of 2004.  “This Recommendation was first
approved and published as Annex F to H.248, and then renumbered as H.248.2
on 2002-03-29 without further modification”.  I don’t know what has happened
in 2005.
 
Raphael Tryster

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, June 16, 2005 5:33 PM
To: Raphael Tryster; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos
 
Are these in the revision that was recently issued?  If so, I will add an IG
item to fix these.
 
Kevin
 
  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Raphael Tryster
Sent: Thursday, June 16, 2005 12:33 PM
To: [email-masked]
Subject: [Megaco] even H.248.2 has typos
1...       In section 7.1.6 of H.248.2, ctyp property is titled
PhasereversalDetect, but the propertyID is given as v8bsup, which is copied
from the property in 7.1.3.  I assume the propertyID was intended to be
PhasereversalDetect.
 
2...       In section 8.1.2, fax property ftrpt has possible values T30,
T30ECM and T.30V34.  This is syntactically permitted, but I think for
consistency the author did not intend the last value to include a dot.
 
Raphael Tryster

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Thu, 16 Jun 2005 21:56:22 +0200

order of descriptors in remote ringback scenarioRaphael,

I checked the November draft that was for Consent in SG16, and it had at
least  the conflict of ctyp/dtone, parameter dtt values DTMF and Sig
resolved.
A lot of other cleaning and adding good functionality for more automonous
call type discrimination.

So, you should have the latest approved ITU version before you start
detailed review.

Regards

Gunnar Hellstr?m
-------------------------------------------
Gunnar Hellstr?m
Omnitor AB
Renathv?gen 2
SE 121 37 Johanneshov
SWEDEN
+46 8 556 002 03
Mob: +46 708 204 288
www.omnitor.se
[email-masked]
--------------------------------------------

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Raphael Tryster
  Sent: Thursday, June 16, 2005 10:20 PM
  To: [email-masked]
  Subject: RE: [Megaco] even H.248.2 has typos

  Raphael Tryster

  -----Original Message-----
  From: Raphael Tryster
  Sent: Thursday, June 16, 2005 9:14 PM
  To: 'Kevin Boyle'; [email-masked]
  Subject: RE: [Megaco] even H.248.2 has typos

  Raphael Tryster

  -----Original Message-----
  From: Kevin Boyle [mailto:[email-masked]]
  Sent: Thursday, June 16, 2005 5:45 PM
  To: Raphael Tryster; [email-masked]
  Subject: RE: [Megaco] even H.248.2 has typos

  Kevin

----------------------------------------------------------------------------
--

  The revision in which I found these is dated 11/2000, which was the
current edition at least to the end of 2004.  “This Recommendation was first
approved and published as Annex F to H.248, and then renumbered as H.248.2
on 2002-03-29 without further modification”.  I don’t know what has happened
in 2005.

  Raphael Tryster

  -----Original Message-----
  From: Kevin Boyle [mailto:[email-masked]]
  Sent: Thursday, June 16, 2005 5:33 PM
  To: Raphael Tryster; [email-masked]
  Subject: RE: [Megaco] even H.248.2 has typos

  Are these in the revision that was recently issued?  If so, I will add an
IG item to fix these.

  Kevin

----------------------------------------------------------------------------
--

  From: [email-masked] [mailto:[email-masked]] On Behalf
Of Raphael Tryster
  Sent: Thursday, June 16, 2005 12:33 PM
  To: [email-masked]
  Subject: [Megaco] even H.248.2 has typos

  1....       In section 7.1.6 of H.248.2, ctyp property is titled
PhasereversalDetect, but the propertyID is given as v8bsup, which is copied
from the property in 7.1.3.  I assume the propertyID was intended to be
PhasereversalDetect.

  2....       In section 8.1.2, fax property ftrpt has possible values T30,
T30ECM and T.30V34.  This is syntactically permitted, but I think for
consistency the author did not intend the last value to include a dot.

  Raphael Tryster