Subject: [Megaco] even H.248.2 has typos

From: Raphael Tryster <[email-masked]>
Date: Thu, 16 Jun 2005 18:32:30 +0200

1.       In section 7.1.6 of H.248.2, ctyp property is titled
PhasereversalDetect, but the propertyID is given as v8bsup, which is copied
from the property in 7.1.3.  I assume the propertyID was intended to be
PhasereversalDetect.
 
2.       In section 8.1.2, fax property ftrpt has possible values T30,
T30ECM and T.30V34.  This is syntactically permitted, but I think for
consistency the author did not intend the last value to include a dot.
 
Raphael Tryster

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 16 Jun 2005 11:33:14 -0400

Are these in the revision that was recently issued?  If so, I will add an IG
item to fix these.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Raphael Tryster
Sent: Thursday, June 16, 2005 12:33 PM
To: [email-masked]
Subject: [Megaco] even H.248.2 has typos

 
Raphael Tryster

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 16 Jun 2005 18:46:26 +0200

The revision in which I found these is dated 11/2000, which was the current
edition at least to the end of 2004.  “This Recommendation was first
approved and published as Annex F to H.248, and then renumbered as H.248.2
on 2002-03-29 without further modification”.  I don’t know what has happened
in 2005.
 
Raphael Tryster

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, June 16, 2005 5:33 PM
To: Raphael Tryster; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos

Kevin
 
  _____  

 
Raphael Tryster

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 16 Jun 2005 11:45:19 -0400

H.248.2 was revised at the November 2004 meeting of SG16.  The new spec is
dated 01/2005.
 
Kevin

  _____  

From: Raphael Tryster [mailto:[email-masked]] 
Sent: Thursday, June 16, 2005 12:46 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos

The revision in which I found these is dated 11/2000, which was the current
edition at least to the end of 2004.  "This Recommendation was first
approved and published as Annex F to H.248, and then renumbered as H.248.2
on 2002-03-29 without further modification".  I don't know what has happened
in 2005.
 
Raphael Tryster

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, June 16, 2005 5:33 PM
To: Raphael Tryster; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos

Kevin

  _____  

1..       In section 7.1.6 of H.248.2, ctyp property is titled
 
2..       In section 8.1.2, fax property ftrpt has possible values T30,
T30ECM and T.30V34.  This is syntactically permitted, but I think for
consistency the author did not intend the last value to include a dot.
 
Raphael Tryster

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 16 Jun 2005 21:13:56 +0200

I noticed something else.  The basic Megaco packages and others, e.g.
H.248.23, do not have any identifiers of events, signals, properties and
statistics with the same values as one another.  I had the impression that
this was a requirement.  But several of the packages in H.248.2 start their
events, signals, properties and statistics identifiers at 0x0001.  Does it
matter?
 
One thing that probably does matter is that in fax package, properties
faxstate and ftrpt both have propertyID = 0x0001.
 
Raphael Tryster

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, June 16, 2005 5:45 PM
To: Raphael Tryster; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos

Kevin
 
  _____  

Raphael Tryster

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, June 16, 2005 5:33 PM
To: Raphael Tryster; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos

Kevin
 
  _____  

 
Raphael Tryster

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 16 Jun 2005 17:15:50 -0400

Yes, there were a significant number of typographical errors in H.248.2 that
were resolved by IG items.  All these IG items were incorporated into the
revision of H.248.2.  I would suggest having a look at the more recent
document and seeing if the problems still exist.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Gunnar Hellstrom
Sent: Thursday, June 16, 2005 3:56 PM
To: Raphael Tryster; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos

Raphael,
 
I checked the November draft that was for Consent in SG16, and it had at
least  the conflict of ctyp/dtone, parameter dtt values DTMF and Sig
resolved.
A lot of other cleaning and adding good functionality for more automonous
call type discrimination.
 
So, you should have the latest approved ITU version before you start
detailed review.
 
Regards
 
Gunnar Hellström
-------------------------------------------
Gunnar Hellström
Omnitor AB
Renathvägen 2
SE 121 37 Johanneshov
SWEDEN
+46 8 556 002 03
Mob: +46 708 204 288
www.omnitor.se
[email-masked]
--------------------------------------------
  
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Raphael Tryster
Sent: Thursday, June 16, 2005 10:20 PM
To: [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos

Also for ctyp/dtone, parameter dtt has values DTMF and Sig which are both
0x000B.
For ctyp/v8bs, parameter v8bsn has values MRdrl and Crel which are both
0x0006, and Creh and Crdi which are both 0x0007.
 
Raphael Tryster

-----Original Message-----
From: Raphael Tryster 
Sent: Thursday, June 16, 2005 9:14 PM
To: 'Kevin Boyle'; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos

 
Raphael Tryster

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, June 16, 2005 5:45 PM
To: Raphael Tryster; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos

Kevin

  _____  

Raphael Tryster

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, June 16, 2005 5:33 PM
To: Raphael Tryster; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos

Kevin

  _____  

1....       In section 7.1.6 of H.248.2, ctyp property is titled
 
2....       In section 8.1.2, fax property ftrpt has possible values T30,
T30ECM and T.30V34.  This is syntactically permitted, but I think for
consistency the author did not intend the last value to include a dot.
 
Raphael Tryster

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 20 Jun 2005 13:17:14 -0400

It is stated in the base spec (clause 6.2.3, third paragraph) that each of
the package item types (properties, events, signals, statistics) exists in
its own namespace, so the binary IDs (and the text IDs) are allowed to be
reused across types.  Within a signal type, however, the IDs must be unique
within the package and its extensions.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Christian Groves
Sent: Sunday, June 19, 2005 10:27 PM
To: Raphael Tryster
Cc: [email-masked]'; Gunnar Hellstrom
Subject: Re: [Megaco] even H.248.2 has typos

Hello Raphael,

I think you have to take into account that H.248.2 was the very first set of
stand alone packages that were developed and they were being developed at
the same time as we were finalising H.248.1. So there are things like the
ordering of identifiers that could have been done better.

I think todays convention is that events, signals, properties or statistics
in a packages DO have the same numerical identifiers (eg. starting at
0x0001). They are made unique by the fact that they always appear in
different descriptors. 
However this is not a hard rule. The main thing is to be able to uniquely
identify each signal,event,statistics,property. However an event can't have
the same ID as another event. A signal can't have the same ID as another
signal etc...

Regards, Christian

Raphael Tryster wrote:

> Kevin and Gunnar,
>  
> Now I have seen the new version and see that all the typos I found 
> were already addressed there.  Sorry to have troubled you about 
> obsolete things.  There remains only the question of whether more than 
> one entity (event, signal, property or statistic) in a package can and 
> should have the same numerical identifier.  I seem to remember seeing, 
> a long time ago, a statement to the effect that events and signals are 
> similar in nature, just the direction is different.  According to that 
> statement, which I can't find now, it made sense that in the basic 
> packages, different values were chosen for all the entities in a 
> package.  Since this practice was not followed in H.248.2, my question 
> is, why the inconsistency?
>  
> Regards,
>  
> Raphael Tryster
>  
>  
> Sent: Thursday, June 16, 2005 11:16 PM
> To: Gunnar Hellstrom; Raphael Tryster; [email-masked]
> Yes, there were a significant number of typographical errors in 
> H.248.2 that were resolved by IG items.  All these IG items were 
> incorporated into the revision of H.248.2.  I would suggest having a 
> look at the more recent document and seeing if the problems still exist.
>  
> Kevin
>  
>   _____
> 
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Gunnar Hellstrom
> Subject: RE: [Megaco] even H.248.2 has typos Raphael,
>  
> I checked the November draft that was for Consent in SG16, and it had 
> at least  the conflict of ctyp/dtone, parameter dtt values DTMF and 
> Sig resolved.
> A lot of other cleaning and adding good functionality for more 
> automonous call type discrimination.
>  
> ----------------------------------------------------------------------
> --
>