Subject: RE: [Megaco] even H.248.2 has typos

From: Raphael Tryster <[email-masked]>
Date: Sun, 19 Jun 2005 18:10:12 +0200

Kevin and Gunnar,
 
Now I have seen the new version and see that all the typos I found were
already addressed there.  Sorry to have troubled you about obsolete things.
There remains only the question of whether more than one entity (event,
signal, property or statistic) in a package can and should have the same
numerical identifier.  I seem to remember seeing, a long time ago, a
statement to the effect that events and signals are similar in nature, just
the direction is different.  According to that statement, which I can't find
now, it made sense that in the basic packages, different values were chosen
for all the entities in a package.  Since this practice was not followed in
H.248.2, my question is, why the inconsistency?
 
Regards,
 
Raphael Tryster

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, June 16, 2005 11:16 PM
To: Gunnar Hellstrom; Raphael Tryster; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos
 
Yes, there were a significant number of typographical errors in H.248.2 that
were resolved by IG items.  All these IG items were incorporated into the
revision of H.248.2.  I would suggest having a look at the more recent
document and seeing if the problems still exist.
 
Kevin
 
  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Gunnar Hellstrom
Sent: Thursday, June 16, 2005 3:56 PM
To: Raphael Tryster; [email-masked]
Subject: RE: [Megaco] even H.248.2 has typos
Raphael,
 
I checked the November draft that was for Consent in SG16, and it had at
least  the conflict of ctyp/dtone, parameter dtt values DTMF and Sig
resolved.
A lot of other cleaning and adding good functionality for more automonous
call type discrimination.
 
So, you should have the latest approved ITU version before you start
detailed review.
 
Regards
 
Gunnar Hellström
-------------------------------------------
Gunnar Hellström
Omnitor AB
Renathvägen 2
SE 121 37 Johanneshov
SWEDEN
+46 8 556 002 03
Mob: +46 708 204 288
www.omnitor.se
[email-masked]
--------------------------------------------

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 20 Jun 2005 12:27:06 +1000

Hello Raphael,

I think you have to take into account that H.248.2 was the very first set of 
stand alone packages that were developed and they were being developed at the 
same time as we were finalising H.248.1. So there are things like the ordering 
of identifiers that could have been done better.

I think todays convention is that events, signals, properties or statistics in a 
packages DO have the same numerical identifiers (eg. starting at 0x0001). They 
are made unique by the fact that they always appear in different descriptors. 
However this is not a hard rule. The main thing is to be able to uniquely 
identify each signal,event,statistics,property. However an event can't have the 
same ID as another event. A signal can't have the same ID as another signal etc...

Regards, Christian

Raphael Tryster wrote:

> already addressed there.  Sorry to have troubled you about obsolete
> things.  There remains only the question of whether more than one entity
> (event, signal, property or statistic) in a package can and should have
> the same numerical identifier.  I seem to remember seeing, a long time
> ago, a statement to the effect that events and signals are similar in
> nature, just the direction is different.  According to that statement,
> which I can't find now, it made sense that in the basic packages,
> different values were chosen for all the entities in a package.  Since
> this practice was not followed in H.248.2, my question is, why the
> inconsistency?
>  
> Regards,
>  
> Raphael Tryster
>  
>  
> Yes, there were a significant number of typographical errors in H.248.2
> that were resolved by IG items.  All these IG items were incorporated
> into the revision of H.248.2.  I would suggest having a look at the more
> recent document and seeing if the problems still exist.
>  
> Kevin
>  
>   _____  
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Gunnar Hellstrom
> A lot of other cleaning and adding good functionality for more
> automonous call type discrimination.
>  
> ------------------------------------------------------------------------
>