Subject: [Megaco] Topology Questions

From: Frank Reno <[email-masked]>
Date: Thu, 2 Jun 2005 14:16:24 -0700 (PDT)

Hello List,

1. Does a topology association with wildcarded
termination IDs apply to terminations added to the
context in the future or only to those currently in
the context?

	Transaction = 1
	{
		Context = 1
		{
			Topology {a/*, b/*, oneway},
			Add = a/1, Add = b/1
		}
	}
	Transaction = 2
	{
		Context = 1
		{
			Add = a/2
		}
	}

	What is the media flow between a/2 and b/1?

2. Does a topology association between two
terminations apply to new streams created on the
terminations?

	Transaction = 1
	{
		Context = 1
		{
			Topology {t1, t2, oneway},
			Add = t1 {Media {Stream = 1{...}}}, 
			Add = t2 {Media {Stream = 1{...}}} 
		}
	}
	Transaction = 2
	{
		Context = 1
		{
			Modify = t1 {Media {Stream = 2{...}}}, 
			Modify = t2 {Media {Stream = 2{...}}} 
		}
	}

	What is the media flow between t1 and t2 for stream
2?
	Is the answer different between protocol version 1
and 2?

3. What does the reply to an audit of the topology
descriptor look like? I assume it's valid to include
an association for every pair of terminations (or
streams) but this may lead to large message. Is it
valid to only
describe the links that are missing?

	Transaction = 1
	{
		Context = 1
		{
			Topology {t1, t2, oneway},
			Add = t1, Add = t2, Add = t3, Add = t4
		}
	}
	Transaction = 2
	{
		Context = 1
		{
			ContextAudit {Topology}
		}
	}

	Is this valid?

	Reply = 2
	{
		Context = 1
		{
			Topology {
			t1, t2, oneway
			}
		}
	}

	Or must all links be specified like one of these:

	Reply = 2
	{
		Context = 1
		{
			Topology {
			t1, t2, oneway,
			t1, t3, bothway,
			t1, t4, bothway,
			t2, t3, bothway,
			t2, t4, bothway,
			t3, t4, bothway
			}
		}
	}

	Reply = 2
	{
		Context = 1
		{
			Topology {
			t1, t2, oneway,
			t3, *, bothway,
			t4, *, bothway
			}
		}
	}

cheers,
frank

__________________________________ 
Discover Yahoo! 
Use Yahoo! to plan a weekend, have fun online and more. Check it out! 
http://discover.yahoo.com/

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 28 Jun 2005 15:35:39 -0400

This issue has been around for some time.  The solution determined for V1/V2
was to echo back the TP Descriptor, as Christian stated.  A contribution
will have to be made for a fix in V3.

Kevin

-----Original Message-----
From: Christian Groves [mailto:[email-masked]] 
Sent: Sunday, June 26, 2005 8:50 PM
To: Frank Reno
Cc: [email-masked]; Boyle, Kevin [NCRTP:3Z40:EXCH]
Subject: Re: [Megaco] Topology Questions

Hello Frank,

Please see my replies below.

Regards, Christian

Frank Reno wrote:

[KJBII] snip...

> 
> 
> Here's another one...
> 
> 7. Section 7.1.18 states that "It is possible to have an action 
> containing only a Topology descriptor". In the text encoding, what 
> should the response be to such an action? The ABNF requires something 
> in the actionReply - at least one context property, command reply or 
> error descriptor.

[CHG] Another ABNF quirk to fix in v3. I would say that for v1 and v2 you
should echo back what was sent. If CHOOSE $ was indicated you should send
back the chosen terminationId.
In terms of a fix to be equivalent with the ASN.1 you probably want to make
the command reply optional ie.

actionReply			= CtxToken EQUAL ContextID LBRKT
					[ (errorDescriptor /
					commandReply /(commandReply COMMA
					errorDescriptor)) ] RBRKT