Subject: [Megaco] Handling failure of embedded events or signals

From: "Ashish Kumar" <[email-masked]>
Date: Tue, 7 Jun 2005 20:21:56 +0530

Hi,

I hope this is the right forum for this question.

I am trying to understand the possible error handling cases for the scenario when application of an embedded event or signal fails.
Following is what the specs says

{
In the case of an embedded EventsDescriptor being activated, the MG continues event processing
based on the newly activated EventsDescriptor.
NOTE 1 ? For purposes of EventBuffer handling, activation of an embedded EventsDescriptor is equivalent
to receipt of a new EventsDescriptor.
}

Existing active events descriptor will be overwritten by the embedded events descriptor because of this.
Is there a way to report the failure to the MGC, or should there be a rollback to events descriptor that was active before reporint of the event.

Considering following scenario.
An active events descriptor has one of the event as "Off Hook".
On reporting "Off Hook" event, the embedded events descriptor which has "On Hook" in the event list gets activated.
Now if application of "On Hook" fails, the termination will be in an inconsistent state untill a new EventsDesriptor is received from MGC.

Is there a way to get out of this.

Regards
Ashish

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 7 Jun 2005 15:05:56 -0400

If detection of onhook fails, you have bigger problems than the failure of
the event to be detected -- like the inability to hang up!
 
The MG can reject the command that includes the embedded Events Descriptor
at the time of receipt.  There is no way to send an autonomous error code.
The only way to report the problem once the command was accepted is to send
a ServiceChange Command for the termination.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ashish Kumar
Sent: Tuesday, June 07, 2005 10:52 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Megaco] Handling failure of embedded events or signals

Hi,

I am trying to understand the possible error handling cases for the scenario
when application of an embedded event or signal fails.
Following is what the specs says
 
{

In the case of an embedded EventsDescriptor being activated, the MG
continues event processing
based on the newly activated EventsDescriptor.

NOTE 1 − For purposes of EventBuffer handling, activation of an embedded
EventsDescriptor is equivalent
to receipt of a new EventsDescriptor.
}
 
Existing active events descriptor will be overwritten by the embedded events
descriptor because of this.
Is there a way to report the failure to the MGC, or should there be a
rollback to events descriptor that was active before reporint of the event.

Considering following scenario.
An active events descriptor has one of the event as "Off Hook".
On reporting "Off Hook" event, the embedded events descriptor which has "On
Hook" in the event list gets activated.
Now if application of "On Hook" fails, the termination will be in an
inconsistent state untill a new EventsDesriptor is received from MGC.

Regards
Ashish