Subject: [Megaco] Can MGC send RESTART after FORCED

From: "Sreenivas" <[email-masked]>
Date: Mon, 20 Jun 2005 14:31:47 -0400

Hi,

    After an MGC sends a FORCED method for ROOT termination to an MG
indicating that it is being taken out of service, would it be right for the
MGC to subsequently send a RESTART to the MG. My understanding it that after
that after the FORCED has been received by the MG, the association between
the MGC and MG is over, at which point a new association should be initiated
by the MG through re-registration starting with the Primary MGC and then the
Secondary MGC and so on.

Thx,

Sreenivas

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Wed, 22 Jun 2005 08:09:27 +0200

Hello Sreenivas,

following logic applies in my understanding:

1) MGC->MG: SC {Forced, Root, 905}
   => § F.3.10.1/H.248.1
   => triggers § F.4.1.1/H.248.1 for MGC

2) § F.4.1.1, (2), MGC:

   "When sent by the MGC, the MG shall take itself Out-of-Service, and
   terminate the control association after sending the command reply.  Note
   that an MGC cannot bring an MG back into service, even though it may
   request it to go Out-of-Service.  The MG initiates registration to the
   MGC to establish a new control association and indicate  service
   restoration, just as it would for any other registration.  ..."

I think that Annex F is here pretty clear that a subsequent Restart of the
MGC is not possible. The next step is up to the MG as indicated in §
F.4.1.1.

Best regards,
Albrecht
ALCATEL

                      "Sreenivas"                                                                                                
                      <SChiduruppa@acme         To:      <[email-masked]>                                                       
                      packet.com>               cc:                                                                              
                      Sent by:                  Subject: [Megaco] Can MGC send RESTART after FORCED                              
                      megaco-bounces@ie                                                                                          
                      tf.org                                                                                                     

                      20.06.2005 20:31                                                                                           

Hi,
    After an MGC sends a FORCED method for ROOT termination to an MG
indicating that it is being taken out of service, would it be right for the
MGC to subsequently send a RESTART to the MG. My understanding it that
after that after the FORCED has been received by the MG, the association
between the MGC and MG is over, at which point a new association should be
initiated by the MG through re-registration starting with the Primary MGC
and then the Secondary MGC and so on.

Thx,
Sreenivas_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco