Subject: RE: [Megaco] Audit on Wildcarded Context and ROOT Termination iss ue-

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 20 Jun 2005 17:13:22 -0400

There has already been a proposal for a "context list" construct to return a
shorter message for those commands that are just interested in getting a
list of contexts.  Similarly, there is a construct to allow the return of a
list of TermIDs in a command or response.  These are being worked into V3.

The construct proposed does not keep with the way the existing constructs
are built.  That list of "numbers" could be anything, and only by convention
would one know that they are supposed to be some kind of list of ContextIDs.
This level is where descriptors are placed, but this isn't a descriptor --
it's just an arbitrary list.  I believe the construct being pursued by SG16
for V3 is much better aligned with the look and feel of H.248 message
construction.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
B Venkat S.R Swamy
Sent: Monday, June 20, 2005 5:03 AM
To: [email-masked]
Cc: Jon Rowland
Subject: RE: [Megaco] Audit on Wildcarded Context and ROOT Termination
issue-

Hi

The problem with the option 1 below is that for large gateways there is lot
of redundant information mainly the "{AV=ROOT}" getting repeated
unnecessarly for each action, therefore the suggested solution is quite
optimized, repeated here with short token.

MG1 to MGC:
!/1 [124.124.124.222]:55555
p=9999{
   C=*{AV = ROOT {1, 2} }

Also with the growing interest in H248 and more and more vendors asking for
compliance with the only available test suite defined by ETSI,  there is
need to address the problems that have been reported in the ETSI test
suite(ETSI TS 101 889-2) in megaco mailinglist. Are there any plans to
define a similiar test suite in ITU-T .

B Venkat S.R Swamy
Senior Technical Leader
Flextronics Software Systems
Phone:  +91-124-2455555 Extn 3620
Fax: +91-124-2455345
web: www.flextronicssoftware.com

             "Jon Rowland"                                                 
             <Jon.Rowland@data                                             
             connection.com>                                            To 
                                       B Venkat S.R Swamy/HSS@HSS          
             06/16/2005 03:24                                           cc 
             PM                        <[email-masked]>                   
                                                                   Subject 
                                       RE: [Megaco] Audit on Wildcarded    
                                       Context and ROOT Termination issue- 

                                                                           

Option 1 is correct. Options 2 and 3 are responses to a wildcard termination
audit of wildcarded context IDs as you correctly point out.
This suggests that the ETSI spec is erroneous.

Your suggested compressed scheme doesn't really add very much over the
short-text encoding of the transaction response:
!/1 [124.124.124.124]:55555
P=9999{
C=1{AV=ROOT},
C=2{AV=ROOT}
}
Hence, I'm not sure it is justifiable given it is not back-compatible.

The general problem with this type of command, when used in conjunction with
large gateways, is that the response size can get quite large, which can be
a problem when using TCP or UDP transports. This has been addressed in V3 by
the introduction of a scheme for segmenting responses.

Jon.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
B Venkat S.R Swamy
Sent: 16 June 2005 04:57
To: [email-masked]
Subject: [Megaco] Audit on Wildcarded Context and ROOT Termination
issue-

Hi,

H.248.1 V1 and V2 section 7.2.5 say

Auditvalue on Termination ID Root with context ID All should return list of
all  ContextIds  (the  ContextID  list should be returned by using multiple
action replies, each containing a ContextID from the list).

Now  the  question  is:  How will the reply for the following scenario look
like?

Audit on termination ROOT with context * and empty audit descriptor

MGC to MG1:
MEGACO/1 [123.123.123.4]:55555
Transaction = 9999 {
    Context = * {
        AuditValue = ROOT { Audit {}}
    }
}

There are currently three options:

Option 1:

Audit on ROOT termination returning only context information:

MG1 to MGC:
MEGACO/1 [124.124.124.222]:55555
Reply = 9999 {
   Context = 1 {Auditvalue = ROOT},
   Context = 2 {Auditvalue = ROOT}
}

Option 2:
As per ETSI TS 101 889-2 section 5.1.9.1  "TP/MG/AV/BV-05"

MG1 to MGC:
MEGACO/1 [124.124.124.222]:55555
Reply = 9999 {
   Context = 1 {Auditvalue = A4444 , Auditvalue = A4445},
   Context = 2 {Auditvalue = A5444 , Auditvalue = A5445} }

Option 3:
condensed form of option 2 above :

MG1 to MGC:
MEGACO/1 [124.124.124.222]:55555
Reply = 9999 {
   Context = 1 {Auditvalue = Context {A4444 , A4445} },
   Context = 2 {Auditvalue = Context {A5444 , A5445} }, }

However the option2 and option3 can be obtained through- Audit on Wildcarded
context and Wildcarded termination with Empty Audit Descriptor.

MEGACO/1 [123.123.123.4]:55555
Transaction = 9999 {
    Context = * {
        AuditValue = * { Audit {}}
    }
}

Now considering the fact that the basic objective of Audit on ROOT
termination and Context * is to get the list of context IDs only without any
termination information, an optimized solution is suggested below.
This however requires changes in the protocol grammar.

MG1 to MGC:
MEGACO/1 [124.124.124.222]:55555
Reply = 9999 {
   Context = * {Auditvalue = ROOT {1, 2} }

Request mailing list comments on the above issue, on either accepting the
above solution or discontinuing the option of sending Audit on ROOT
Termination and Context *.

Regards,
B Venkat S.R Swamy
Senior Technical Leader
Flextronics Software Systems
Phone:  +91-124-2455555 Extn 3620
Fax: +91-124-2455345
web: www.flextronicssoftware.com

***********************  FSS-Restricted   ***********************
"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended solely for the use of the individual to whom it is
addressed. It may contain  privileged or confidential information and should
not be circulated or used for any purpose other than for what it is
intended. If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient, you are
notified that you are strictly prohibited from using, copying, altering, or
disclosing the contents of this message. HSS accepts no responsibility for
loss or damage arising from the use of the information transmitted by this
email including damage from virus."

"DISCLAIMER: This message is proprietary to Flextronics Software Systems
Limited (FSS) and is intended solely for the use of the individual to whom
it is addressed. It may contain  privileged or confidential information and
should not be circulated or used for any purpose other than for what it is
intended. If you have received this message in error, please notify the
originator immediately.
If you are not the intended recipient, you are notified that you are
strictly  prohibited  from  using, copying, altering, or disclosing the
contents of this message.  FSS  accepts no  responsibility  for loss or
damage arising from the use of  the information transmitted by this email
including damage from virus."

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

***********************  FSS-Restricted   ***********************
"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended solely for the use of the individual to whom it is
addressed. It may contain  privileged or confidential information and should
not be circulated or used for any purpose other than for what it is
intended. If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient, you are
notified that you are strictly prohibited from using, copying, altering, or
disclosing the contents of this message. HSS accepts no responsibility for
loss or damage arising from the use of the information transmitted by this
email including damage from virus."

"DISCLAIMER: This message is proprietary to Flextronics Software Systems
Limited (FSS) and is intended solely for the use of the individual to whom
it is addressed. It may contain  privileged or confidential information and
should not be circulated or used for any purpose other than for what it is
intended. If you have received this message in  error, please notify the
originator immediately. 
If you are not the intended recipient, you are notified that you are
strictly  prohibited  from  using, copying, altering, or disclosing the
contents of this message.  FSS  accepts no  responsibility  for loss or
damage arising from the use of  the information transmitted by this email
including damage from virus."

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Frank Reno <[email-masked]>
Date: Thu, 30 Jun 2005 11:08:26 -0700 (PDT)

It looks like V3 will be modified to allow empty
action replies, as these are necessary to respond to
actions with no commands. 

Perhaps empty action replies can be used to return the
list of context IDs. It would still be very compact
and it wouldn't require any additional changes to the
spec.

For example

P=1{C=1,C=2,C=3,C=4,C=5,C=6}

Instead of

P=1{C=*{CT{CLT{1,2,3,4,5,6}}}}

Frank

--- Kevin Boyle <[email-masked]> wrote:

There has already been a proposal for a "context list"
construct to return a
shorter message for those commands that are just
interested in getting a
list of contexts.  Similarly, there is a construct to
allow the return of a
list of TermIDs in a command or response.  These are
being worked into V3.

The construct proposed does not keep with the way the
existing constructs
are built.  That list of "numbers" could be anything,
and only by convention
would one know that they are supposed to be some kind
of list of ContextIDs.
This level is where descriptors are placed, but this
isn't a descriptor --
it's just an arbitrary list.  I believe the construct
being pursued by SG16
for V3 is much better aligned with the look and feel
of H.248 message
construction.

Kevin 

-----Original Message-----
From: megaco-bounces at ietf.org
[mailto:megaco-bounces at ietf.org] On Behalf Of
B Venkat S.R Swamy
Sent: Monday, June 20, 2005 5:03 AM
To: megaco at ietf.org
Cc: Jon Rowland
Subject: RE: [Megaco] Audit on Wildcarded Context and
ROOT Termination
issue-

Hi

The problem with the option 1 below is that for large
gateways there is lot
of redundant information mainly the "{AV=ROOT}"
getting repeated
unnecessarly for each action, therefore the suggested
solution is quite
optimized, repeated here with short token.

MG1 to MGC:

Also with the growing interest in H248 and more and
more vendors asking for
compliance with the only available test suite defined
by ETSI,  there is
need to address the problems that have been reported
in the ETSI test
suite(ETSI TS 101 889-2) in megaco mailinglist. Are
there any plans to
define a similiar test suite in ITU-T .

B Venkat S.R Swamy
Senior Technical Leader

                    
             "Jon Rowland"                            
                    
             <Jon.Rowland at data                     
                       
             connection.com>                          
                 To 
                                       B Venkat S.R
Swamy/HSS at HSS          
             06/16/2005 03:24                         
                 cc 
             PM                        <megaco at
ietf.org>                   
                                                      
            Subject 
                                       RE: [Megaco]
Audit on Wildcarded    
                                       Context and
ROOT Termination issue- 

                    

                    

Option 1 is correct. Options 2 and 3 are responses to
a wildcard termination
audit of wildcarded context IDs as you correctly point
out.
This suggests that the ETSI spec is erroneous.

Your suggested compressed scheme doesn't really add
very much over the
short-text encoding of the transaction response:
!/1 [124.124.124.124]:55555
P=9999{
C=1{AV=ROOT},
C=2{AV=ROOT}
}
Hence, I'm not sure it is justifiable given it is not
back-compatible.

The general problem with this type of command, when
used in conjunction with
large gateways, is that the response size can get
quite large, which can be
a problem when using TCP or UDP transports. This has
been addressed in V3 by
the introduction of a scheme for segmenting responses.

Jon.

-----Original Message-----
From: megaco-bounces at ietf.org
[mailto:megaco-bounces at ietf.org] On Behalf Of
B Venkat S.R Swamy
Sent: 16 June 2005 04:57
To: megaco at ietf.org
Subject: [Megaco] Audit on Wildcarded Context and ROOT
Termination
issue-

Hi,

Auditvalue on Termination ID Root with context ID All
should return list of
all  ContextIds  (the  ContextID  list should be
returned by using multiple
action replies, each containing a ContextID from the
list).

Now  the  question  is:  How will the reply for the
following scenario look
like?

Audit on termination ROOT with context * and empty
audit descriptor

MGC to MG1:

Option 1:

Audit on ROOT termination returning only context
information:

MG1 to MGC:

Option 2:
As per ETSI TS 101 889-2 section 5.1.9.1 
"TP/MG/AV/BV-05"

MG1 to MGC:
MEGACO/1 [124.124.124.222]:55555
Reply = 9999 {
   Context = 1 {Auditvalue = A4444 , Auditvalue =
A4445},
   Context = 2 {Auditvalue = A5444 , Auditvalue =
A5445} }

Option 3:

MG1 to MGC:
MEGACO/1 [124.124.124.222]:55555
Reply = 9999 {
   Context = 1 {Auditvalue = Context {A4444 , A4445}
},
   Context = 2 {Auditvalue = Context {A5444 , A5445}
}, }

However the option2 and option3 can be obtained
through- Audit on Wildcarded
context and Wildcarded termination with Empty Audit
Descriptor.

Now considering the fact that the basic objective of
Audit on ROOT
termination and Context * is to get the list of
context IDs only without any
termination information, an optimized solution is
suggested below.
This however requires changes in the protocol grammar.

MG1 to MGC:

Request mailing list comments on the above issue, on
either accepting the
above solution or discontinuing the option of sending
Audit on ROOT
Termination and Context *.

Regards,
B Venkat S.R Swamy
Senior Technical Leader

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com