Subject: [Megaco] CHOOSE context ID with MODIFY command

From: "Gillian Wang" <[email-masked]>
Date: Tue, 26 Jul 2005 12:12:23 +1000

Hi,

Is the CHOOSE context ID allowed to be used with MODIFY=TermA command? As I
can see one example in the draft callflow below. Any standard addresses this
issue? Section 7.2.2 of H.248 standard specifies the CHOOSE usage: "The
CHOOSE option is an error, as the Modify command may only be used on
existing Terminations." Is it only for the terminationID?

Step 7
MGC to RGW:
   MEGACO/1 [216.33.33.61]: 27000
   Transaction = 1235 {
       Context = $ {
          Modify = TermA {
                 Signals { cg/rt }}}}

Step 8
   RGW to MGC:
   MEGACO/1 [209.110.59.34]: 25000
   Reply = 1235 {
      Context = - {Modify = TermA}

Thanks for advice.

Regards
Gillian

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Tue, 26 Jul 2005 08:00:38 +0200

CHOOSE used for a context means that the MG is asked to create a new
context.  A termination cannot reside in a context that has not yet been
created, so it does not make sense to Modify it.  I think Step 7 in the
example is an error, and should refer to the null context as you see in the
reply.

Raphael Tryster

-----Original Message-----
From: Gillian Wang [mailto:[email-masked]]
Sent: Tuesday, July 26, 2005 4:12 AM
To: [email-masked]
Subject: [Megaco] CHOOSE context ID with MODIFY command

Hi,

Step 7
MGC to RGW:

Step 8
   RGW to MGC:

Thanks for advice.

Regards
Gillian