Subject: RE: [Megaco] Error reply for message with CHOOSE for context id

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 6 Jul 2005 18:04:37 -0400

Don't assume that the error is a syntax error.  There are many reasons
why a command would not parse: duplicate descriptors is one that comes
to mind that has its own error code.  The message may be syntactically
valid, but not conform to the requirements of the protocol.  This could
be a parse fail, but would not be a syntax error.  The error code should
be appropriate for the problem detected.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Kapil Nayar
Sent: Wednesday, July 06, 2005 5:39 PM
To: Tamar Nemet; [email-masked]'
Cc: Dina Galansky
Subject: Re: [Megaco] Error reply for message with CHOOSE for context id

Logically speaking the reply should have context id as CHOOSE. Since
there was a parsing error at the command level it would be natural to
assume that the command was failed before any processing - the error
code could be 442 - Syntax Error in Command.

thanks,
-kapil

--- Tamar Nemet <[email-masked]> wrote:

>  
> Hello,
>  
> If the MGC send an ADD message with CHOOSE for the context id, and 
> there is an error in the command parsing, which reply should be sent 
> by the MG ? with context id ? with CHOOSE ?
>  
> Thanks,
> Tamar
> > _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 

___________________________________________________________
Yahoo! Messenger - NEW crystal clear PC to PC calling worldwide with
voicemail http://uk.messenger.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Kapil Nayar <[email-masked]>
Date: Wed, 6 Jul 2005 23:54:45 +0100 (BST)

Agreed Kevin on the error codes.
Now refering to the problem indicated by Tamar - is it
correct to state that although logically context id
should be CHOOSE, protocol doesnot restrict the
context id value in the reply. 

thanks,
-kapil

--- Kevin Boyle <[email-masked]> wrote:

> From: [email-masked]
> [mailto:[email-masked]] On Behalf
> Of Kapil Nayar

___________________________________________________________ 
Yahoo! Messenger - NEW crystal clear PC to PC calling worldwide with voicemail http://uk.messenger.yahoo.com