Subject: RE: [Megaco] A Question about SDP

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 14 Jul 2005 11:11:49 -0400

I believe that if ptime is not specified, the ptime to be used is the
default for the codec.

That being said, the MG can return the values necessary in the SDP in
order to provide a full description, within the bounds set by the MGC.

Note that the SDP examples you gave below are illegal, as they are
missing the o=, s= and t= lines, which are required in the MG->MGC
direction.  Remember that MGs must always provide compliant SDP.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of [email-masked]
Sent: Thursday, July 14, 2005 4:10 AM
To: [email-masked]
Subject: [Megaco] A Question about SDP

Hello all:

I came across such a problem this days:

The MGC send such a local descriptor to MG :

L{
  v=0
  c=IN IP4 $
  m=audio $ RTP/AVP 0 4 /*G711u, G723*/
}

The MG support both G711u and G723 ,

but the supported Package time of G711u and G723 is different:

G711u's package time is 20, and G723's package time is 30.

IS the MGC's Local descriptor right?

If the MGC's Local descriptor is right,

what should the MG reply?
what should the  Local Descriptor be?
L{
 v=0
 c=IN IP4 xxxx
 m=audio yyyy RTP/AVP 0 4
 a=ptime:20
}

or
L{
 v=0
 c=IN IP4 xxxx
 m=audio yyyy RTP/AVP 0
 a=ptime:20
 v=0
 c=IN IP4 xxxx
 m=audio yyyy RTP/AVP 0 4
 a=ptime:30
}

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: jijo <[email-masked]>
Date: Fri, 15 Jul 2005 11:12:48 +0530

Hi All,

Anybody have done interworking with H.323 <-> SIP endpoints controlled 
by an MGC? Is it a valid case? In this case we can only one ephemeral 
termination exist in the context as there is no physical termiantion exist.
Please let me know if any draft or suggestions.

Thanks
Jijo

---

From: Tom Taylor <[email-masked]>
Date: Fri, 15 Jul 2005 08:56:36 -0400

You would have two ephemerals, if you need the gateway at all.  If the 
MG is there, it is mostly likely acting as the media portion of a 
Session Border Gateway.  It could also be a transcoder.