Subject: [Megaco] about ReserveValue

From: "Neal Zhu" <[email-masked]>
Date: Thu, 28 Jul 2005 12:32:15 +0000

i have a doublt.in this message 
MEGACO/1 [182.20.20.1]:2944 
T=369361899{C=${A=A1{M{O{MO=IN,RV=OFF,RG=OFF}},E=369098762{tonedet/std{tl=*},al/*},SG{}},A=${M{O{MO=RC,RV=OFF,RG=OFF},L{v=0

c=IN IP4 $
m=audio $ RTP/AVP 8 97
a=ptime:20
a=rtpmap:97 telephone-event
a=fmtp:97 0-15
}}}}}

mgc wants a audio call using G.711 and support RFC2833 to detect DTMF at 
the same time . what is the correct value of ReserveValue ?
ON or OFF??

_________________________________________________________________
免费下载 MSN Explorer:   http://explorer.msn.com/lccn/  

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Maridi R. Makaraju \(Raju\)" <[email-masked]>
Date: Thu, 28 Jul 2005 08:33:05 -0500

Neal,

> the same time . what is the correct value of ReserveValue ?

It should be OFF. The reason is as follows:
The H.248 spec says...
"If the value of a Reserve property is True, the MG SHALL reserve resources for all alternatives
specified in the Local and/or Remote descriptors for which it currently has resources available."

The "alternative" should be applied to each type of resource, i.e. audio codecs, DTM etc.
For DTMF there is no alternative, it's just RFC2833. So MG should allocate resources for
RFC2833 if available and return payload 97 in the response. If no RFC2833(DTMF) resources
available then it should omit payload 97 in the response.

Thanks
Raju

---

From: "Neal Zhu" <[email-masked]>
Date: Sat, 30 Jul 2005 14:46:48 +0000

how about this one :   

    m=audio 3456 RTP/AVP 0 98    
    a=rtpmap:98 PCMU/8000  
    a=gpmd:98 vbd=yes 

if mgc wants mgw to establish both a audio and a VBD connections at the 
same time ,
ReserveValue should be OFF?

audio and vbd are different type of resource? for mgw ,both of them are 
audio.

thanks 
Neal

>From: "Neal Zhu" <[email-masked]>
>To: [email-masked]
>Subject: [Megaco] about ReserveValue 
>Date: Thu, 28 Jul 2005 12:32:15 +0000
>
>i have a doublt.in this message MEGACO/1 [182.20.20.1]:2944 

>mgc wants a audio call using G.711 and support RFC2833 to detect 
>DTMF at the same time . what is the correct value of ReserveValue ?
>ON or OFF??
>

_________________________________________________________________
享用世界上最大的电子邮件系统― MSN Hotmail。  http://www.hotmail.com