Subject: [Megaco] Actions in Transactions

From: "Pascal Lambers" <[email-masked]>
Date: Wed, 7 Sep 2005 18:55:45 +0200

Hi,

Suppose a megaco message with a Transaction1 contains 2 different Actions (Action1 and Action2). Each Action contains a series of non optional Commands.
  Given the following input from the Megaco RFC 3225:

    a.. Chapter 8, Transactions: Transactions guarantee ordered Command processing. That is, Commands within a Transaction are executed sequentially [...] At the first failing Command in a Transaction, processing of theremaining Commands in that Transaction stops.
    b.. Chapter 8.2.2 TransactionReply: A TransactionRequest has been processed:
      a.. when [...] or;
      b.. when an error is encountered in processing that TransactionRequest, except when the error is in an optional command.

  Is the following reasoning correct:

    a.. As soon as a non optional Command fails in Action1, the receiver must stop parsing the subsequent part of the message (and reply with an error descriptor) and must NOT start parsing Action2: regardless of whether the Action2 is related to the same termination(s) as Action1 or not.

Kind regards,
Pascal

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 08 Sep 2005 11:12:53 +0200

That's correct.

Pascal Lambers wrote:
> ------------------------------------------------------------------------
>