Subject: RE: [Megaco] Ephemeral termination and static termination.

From: Tamar Nemet <[email-masked]>
Date: Sun, 4 Sep 2005 14:10:58 +0300

Hi Eli,
 
     If you look at section 6.2.2 (TrrminationIDs) in the H.248 standard,
you can find the following:

BM__Toc458568522BM__Toc473526642BM__Toc492885309BM__Toc498919094BM__Toc49953
4395BM__Toc499611386BM__Toc505401453 

BM__Toc303290066.2.2       TerminationIDs

Terminations are referenced by a TerminationID, which is an arbitrary schema
chosen by the MG.
TerminationIDs of physical Terminations are provisioned in the Media
Gateway. The TerminationIDs may be chosen to have structure. For instance, a
TerminationID may consist of trunk group and a trunk within the group.
A wildcarding mechanism using two types of wildcards can be used with
TerminationIDs. The two wildcards are ALL and CHOOSE. The former is used to
address multiple Terminations at once, while the latter is used to indicate
to a media gateway that it must select a Termination satisfying the
partially specified TerminationID. This allows, for instance, that a MGC
instructs a MG to choose a circuit within a trunk group. 
 
So, how can the Trunk gateway know if it should choose a link and timeslot,
or to choose an ephemeral ID ?
 
Thanks,
Tamar 

-----Original Message-----
From: Eli Liluz [mailto:[email-masked]]
Sent: Sunday, September 04, 2005 1:43 PM
To: Tamar Nemet; [email-masked]
Cc: Rima Mazorov; Michal Yachimovitz
Subject: RE: [Megaco] Ephemeral termination and static termination.

As far as I concern, in case of choose ($), the SSW always intends to an
ephemeral termination.
 
Thank you,
Eli Liluz.
 
-----Original Message-----
From: Tamar Nemet [mailto:[email-masked]]
Sent: Sunday, September 04, 2005 1:38 PM
To: Eli Liluz; Tamar Nemet; [email-masked]
Cc: Rima Mazorov; Michal Yachimovitz
Subject: RE: [Megaco] Ephemeral termination and static termination.

 Yes, you are right. Thanks for the correction.
 
 Do you know the answer ?
 
Tamar 
 
-----Original Message-----
From: Eli Liluz [mailto:[email-masked]]
Sent: Sunday, September 04, 2005 1:31 PM
To: Tamar Nemet; [email-masked]
Cc: Rima Mazorov; Michal Yachimovitz
Subject: RE: [Megaco] Ephemeral termination and static termination.
Hi.
Did you mean to write “In the second case, how can the ---?GW<---- know
if…….”?
 
Thank You,
Eli Liluz.
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Tamar Nemet
Sent: Sunday, September 04, 2005 1:15 PM
To: [email-masked]'
Cc: Rima Mazorov; Michal Yachimovitz
Subject: [Megaco] Ephemeral termination and static termination.
 
Hello,
 
The SoftSwitch can send towards trunk gateway two kinds of ADD command:
 
1. ADD to a static termination (i.e. link number and timeslot)
2. ADD with $ parameter. ( In this case the trunk gateway will chose the
link and timeslot and return it to the SoftSwitch)
 
In the second case, how can the SoftSwitch know if the ADD is for an
ephemeral termination and it should choose only an ID for the new ephemeral
or it should allocate link and timeslot and return it to the SoftSwitch  ?
 
Thanks for your answers,
Tamar
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 05 Sep 2005 16:07:09 +1000

Hello,

I would suggest that if the MGC wants a certain type of termination it 
should send enough information for the MG (trunk gateway) to determine 
it. eg. the MGC can send a partial terminationID ie. TID=TDM/$ or it 
would populate the local and remote descriptors with the appropriate 
information.

Christian

Tamar Nemet wrote:

>       6.2.2 TerminationIDs
> Terminations are referenced by a TerminationID, which is an arbitrary 
> schema chosen by the MG.
>
> Gateway. The TerminationIDs may be chosen to have structure. For 
> instance, a TerminationID may consist of trunk group and a trunk 
> within the group.
>
> TerminationIDs. The two wildcards are ALL and CHOOSE. The former is 
> used to address multiple Terminations at once, while the latter is 
> used to indicate to a media gateway that it must select a Termination 
> satisfying the partially specified TerminationID. *This allows, for 
> instance, that a MGC instructs a MG to choose a circuit within a trunk 
> group*.
>
> So, how can the Trunk gateway know if it should choose a link and 
> timeslot, or to choose an ephemeral ID ?
>
> Thanks,
>
> Tamar
>
>
>
>     *From:* Eli Liluz [mailto:[email-masked]]
>     *Sent:* Sunday, September 04, 2005 1:43 PM
>     *To:* Tamar Nemet; [email-masked]
>     *Cc:* Rima Mazorov; Michal Yachimovitz
>     *Subject:* RE: [Megaco] Ephemeral termination and static termination.
>
>     *From:* Tamar Nemet [mailto:[email-masked]]
>     *Sent:* Sunday, September 04, 2005 1:38 PM
>     *To:* Eli Liluz; Tamar Nemet; [email-masked]
>     *Cc:* Rima Mazorov; Michal Yachimovitz
>     *Subject:* RE: [Megaco] Ephemeral termination and static termination.
>
>
>     *From:* Eli Liluz [mailto:[email-masked]]
>     *Sent:* Sunday, September 04, 2005 1:31 PM
>     *To:* Tamar Nemet; [email-masked]
>     *Cc:* Rima Mazorov; Michal Yachimovitz
>     *Subject:* RE: [Megaco] Ephemeral termination and static termination.
>
>     Hi.
>
>     Did you mean to write “In the second case, how can the ---àGW<----
>     know if…….”?
>
>     Thank You,
>
>     Eli Liluz.
>
>     *From:* [email-masked]
>     [mailto:[email-masked]]*On Behalf Of *Tamar Nemet
>     *Sent:* Sunday, September 04, 2005 1:15 PM
>     *To:* [email-masked]'
>     *Cc:* Rima Mazorov; Michal Yachimovitz
>     *Subject:* [Megaco] Ephemeral termination and static termination.
>
>     Hello,
>
>     2. ADD with $ parameter. ( In this case the trunk gateway will
>     chose the link and timeslot and return it to the SoftSwitch)
>
>     In the second case, how can the SoftSwitch know if the ADD is for
>     an ephemeral termination and it should choose only an ID for the
>     new ephemeral or it should allocate link and timeslot and return
>     it to the SoftSwitch ?
>
>     Thanks for your answers,
>
>     Tamar
>
>------------------------------------------------------------------------
>