Subject: [Megaco] about Silence Suppression

From: "Neal Zhu" <[email-masked]>
Date: Fri, 02 Sep 2005 12:39:16 +0000

in rfc 3525 ANNEX C :  

Silencesupp   1008     Boolean       Silence Suppression: True/False

how to express silence suppression in SDP?for in binary ,tag 1008 can not 
be used. 

another question .in rfc 3551 , 

PT   encoding    media type  clock rate   hannels                    name   
                       (Hz)               
___________________________________________________               0    PCMU 
       A            8,000       1 ...        
13   CN          A            8,000       1 ... 

comfort noise is defined like this . 

Silence Suppression and CN are both needed to generate comfort noise ?? 
only sending CN or only sending ilence Suppression is enough ? 

thanks, 
Neal

_________________________________________________________________
与联机的朋友进行交流，请使用 MSN Messenger:  http://messenger.msn.com/cn  

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Sat, 3 Sep 2005 10:32:20 +0200

Don't use outdated RFC 3525 text anymore, please have a look in the text of
H.248.1 ("Annex C text was updated concerning PackageID ..."). Perhaps this
clarifies already your question.
   "Silence Suppression" is a dedicated OPERATION MODE for Speech
   Telephony. Either activated or disabled (via H.248) per call.
   "Comfort noise" is a dedicated voice PACKET TYPE, carrying a "noise
   descriptor" or "silence insertion descriptor" in the packet PAYLOAD.
   => "comfort noise" is typically codec-type specific (e.g., G.729B, AMR)
   or an added function (e.g., G.711)
   => codepoint "PT = 13" in case of VoRTP is thus relevant for specific
   codecs only

Regards
Albrecht

                      "Neal Zhu"                                                                                                      
                      <nealzhu@hotmail         To:      [email-masked]                                                               
                      .com>                    cc:                                                                                    
                      Sent by:                 Subject: [Megaco] about Silence Suppression                                            
                      megaco-bounces@i                                                                                                
                      etf.org                                                                                                         

                      02.09.2005 14:39                                                                                                

in rfc 3525 ANNEX C :

                       (Hz)

       A            8,000       1 ...
13   CN          A            8,000       1 ...

thanks,
Neal