Subject: [Megaco] Ephemeral termination and static termination.

From: Tamar Nemet <[email-masked]>
Date: Sun, 4 Sep 2005 13:15:24 +0300

Hello,
 
The SoftSwitch can send towards trunk gateway two kinds of ADD command:
 
1. ADD to a static termination (i.e. link number and timeslot)
2. ADD with $ parameter. ( In this case the trunk gateway will chose the
link and timeslot and return it to the SoftSwitch)
 
In the second case, how can the SoftSwitch know if the ADD is for an
ephemeral termination and it should choose only an ID for the new ephemeral
or it should allocate link and timeslot and return it to the SoftSwitch  ?
 
Thanks for your answers,
Tamar
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Eli Liluz" <[email-masked]>
Date: Sun, 4 Sep 2005 13:31:02 +0300

Hi.
Did you mean to write “In the second case, how can the ---?GW<---- know if…….”?
 
Thank You,
Eli Liluz.
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Tamar Nemet
Sent: Sunday, September 04, 2005 1:15 PM
To: [email-masked]'
Cc: Rima Mazorov; Michal Yachimovitz
Subject: [Megaco] Ephemeral termination and static termination.
 
Hello,

1. ADD to a static termination (i.e. link number and timeslot)
2. ADD with $ parameter. ( In this case the trunk gateway will chose the link and timeslot and return it to the SoftSwitch)
 
In the second case, how can the SoftSwitch know if the ADD is for an ephemeral termination and it should choose only an ID for the new ephemeral or it should allocate link and timeslot and return it to the SoftSwitch  ?
 
Thanks for your answers,
Tamar

---

From: Tamar Nemet <[email-masked]>
Date: Sun, 4 Sep 2005 13:37:41 +0300

Yes, you are right. Thanks for the correction.
 
 Do you know the answer ?
 
Tamar 

-----Original Message-----
From: Eli Liluz [mailto:[email-masked]]
Sent: Sunday, September 04, 2005 1:31 PM
To: Tamar Nemet; [email-masked]
Cc: Rima Mazorov; Michal Yachimovitz
Subject: RE: [Megaco] Ephemeral termination and static termination.

Hi.
Did you mean to write “In the second case, how can the ---?GW<---- know
if…….”?
 
Thank You,
Eli Liluz.
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Tamar Nemet
Sent: Sunday, September 04, 2005 1:15 PM
To: [email-masked]'
Cc: Rima Mazorov; Michal Yachimovitz
Subject: [Megaco] Ephemeral termination and static termination.
 
Hello,

 
 
Thanks for your answers,
Tamar

---

From: "Eli Liluz" <[email-masked]>
Date: Sun, 4 Sep 2005 13:43:00 +0300

As far as I concern, in case of choose ($), the SSW always intends to an
ephemeral termination.
 
Thank you,
Eli Liluz.
 
-----Original Message-----
From: Tamar Nemet [mailto:[email-masked]]
Sent: Sunday, September 04, 2005 1:38 PM
To: Eli Liluz; Tamar Nemet; [email-masked]
Cc: Rima Mazorov; Michal Yachimovitz
Subject: RE: [Megaco] Ephemeral termination and static termination.

 Do you know the answer ?
 
Tamar 
 
-----Original Message-----
From: Eli Liluz [mailto:[email-masked]]
Sent: Sunday, September 04, 2005 1:31 PM
To: Tamar Nemet; [email-masked]
Cc: Rima Mazorov; Michal Yachimovitz
Subject: RE: [Megaco] Ephemeral termination and static termination.
 Hi.
 
Thank You,
Eli Liluz.
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Tamar Nemet
Sent: Sunday, September 04, 2005 1:15 PM
To: [email-masked]'
Cc: Rima Mazorov; Michal Yachimovitz
Subject: [Megaco] Ephemeral termination and static termination.
 
Hello,

 
 
Thanks for your answers,
Tamar

---

From: "Eli Liluz" <[email-masked]>
Date: Sun, 4 Sep 2005 15:53:23 +0300

Hi Tamar.
 
The following text is written in chapter B1:
“Coding of wildcards
In a text encoding of the protocol, while TerminationIDs are arbitrary, by judicious choice of names, the wildcard character, "*" may be made more useful.  When the wildcard character is encountered, it will "match" all TerminationIDs having the same previous and following characters (if appropriate).  For example, if there were TerminationIDs of R13/3/1, R13/3/2 and R13/3/3, the TerminationID R13/3/* would match all of them.  There are some circumstances where ALL Terminations must be referred to.  The TerminationID "*" suffices, and is referred to as ALL. The CHOOSE TerminationID "$" may be used to signal to the MG that it has to create an ephemeral Termination or select an idle physical Termination.”
>From this text we can understand that it is the responsibility of the GW either to select an ephemeral termination or a physical termination.
Note: I can not find any application that the MG shall select a physical termination in case of $ because in the moment the SSW sends an ADD command there is a call setup process in a specific span and timeslot in the TDM side of the GW while in the IP side the GW can select any available IP address and port.
 
Thank you,
Eli Liluz.
 
-----Original Message-----
From: Tamar Nemet [mailto:[email-masked]]
Sent: Sunday, September 04, 2005 2:11 PM
To: Eli Liluz; Tamar Nemet; [email-masked]
Cc: Rima Mazorov; Michal Yachimovitz
Subject: RE: [Megaco] Ephemeral termination and static termination.
 
     Hi Eli,
 
     If you look at section 6.2.2 (TrrminationIDs) in the H.248 standard, you can find the following:

6.2.2   TerminationIDs

Terminations are referenced by a TerminationID, which is an arbitrary schema chosen by the MG.
TerminationIDs of physical Terminations are provisioned in the Media Gateway. The TerminationIDs may be chosen to have structure. For instance, a TerminationID may consist of trunk group and a trunk within the group.
A wildcarding mechanism using two types of wildcards can be used with TerminationIDs. The two wildcards are ALL and CHOOSE. The former is used to address multiple Terminations at once, while the latter is used to indicate to a media gateway that it must select a Termination satisfying the partially specified TerminationID. This allows, for instance, that a MGC instructs a MG to choose a circuit within a trunk group. 
 
So, how can the Trunk gateway know if it should choose a link and timeslot, or to choose an ephemeral ID ?
 
Thanks,
Tamar 

 
-----Original Message-----
From: Eli Liluz [mailto:[email-masked]]
Sent: Sunday, September 04, 2005 1:43 PM
To: Tamar Nemet; [email-masked]
Cc: Rima Mazorov; Michal Yachimovitz
Subject: RE: [Megaco] Ephemeral termination and static termination.

Thank you,
Eli Liluz.
 
-----Original Message-----
From: Tamar Nemet [mailto:[email-masked]]
Sent: Sunday, September 04, 2005 1:38 PM
To: Eli Liluz; Tamar Nemet; [email-masked]
Cc: Rima Mazorov; Michal Yachimovitz
Subject: RE: [Megaco] Ephemeral termination and static termination.

 Do you know the answer ?
 
Tamar 
 
-----Original Message-----
From: Eli Liluz [mailto:[email-masked]]
Sent: Sunday, September 04, 2005 1:31 PM
To: Tamar Nemet; [email-masked]
Cc: Rima Mazorov; Michal Yachimovitz
Subject: RE: [Megaco] Ephemeral termination and static termination.
 
Hi.
 
Thank You,
Eli Liluz.
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Tamar Nemet
Sent: Sunday, September 04, 2005 1:15 PM
To: [email-masked]'
Cc: Rima Mazorov; Michal Yachimovitz
Subject: [Megaco] Ephemeral termination and static termination.
 
Hello,

 
 
Thanks for your answers,
Tamar