Subject: [Megaco] Questions identified at TISPAN#8

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Wed, 14 Sep 2005 16:58:37 +0200

Hi,

During the H.248 profile work in ETSI TISPAN, the following questions have arrised:

1. Updating of MId value:
-------------------------

H.248 currently says:

"The Message Identifier (MID) of a message is set to a provisioned name (e.g. domain address/domain name/device name) of the entity transmitting the message. Domain name is a suggested default. An H.248.1 entity (MG/MGC) must consistently use the same MID in all messages it originates for the duration of control association with the peer (MGC/MG)."

The question is: is it allowed to modify the MGC/MG control association (e.g. if the IP address of the MGC changes) simply by updating the MID value? Is the MG required to detect the updated value, and perform appropriate functions?

2. Profile template: Event detection time supported:
----------------------------------------------------

The question is: does a "Yes" value mean that event detection time must ALWAYS be inserted by the MG, for the notification of ALL kind of event types? Or, can a profile define the usage (no/optional/mandatory) per package/event type?

Regards,

Christer
LM Ericsson

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "FCG SHI Hao" <[email-masked]>
Date: Thu, 15 Sep 2005 11:32:53 +0800

Hi,

H.248 currently says:

The control association should be allowed to modify by updating the MID. There are 3 conditions: 
1. When MG registers to MGC, MGC replies a response with the new MID, MG should change the control association to the new MID. 
2. MGC sends the ServiceChange message to update the MID with the Method "Restart", all the call in the MG should be deleted and  change the control association to the new MID.
3. MGC sends the ServiceChange message to update the MID with the Method "Handoff", all the call in the MG should be reserved and change the control association to the new MID.
There are any other opinions, pls tell me.

Regards,
Shi Hao

-----????-----
???: [email-masked] [mailto:[email-masked]]?? Christer Holmberg (JO/LMF)
????: 2005?9?14? 22:59
???: [email-masked]
??: [Megaco] Questions identified at TISPAN#8

Hi,

H.248 currently says:

Regards,

Christer
LM Ericsson

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Fri, 16 Sep 2005 09:50:24 +0200

Hi,

Thanks for the answers!

However, the issue was whether the MID could be changed "on the run", without any ServiceChanges or registration procedures. 

An example is that the MGC sends a "normal" transaction (e.g. with a MODIFY command) and uses a different MID value than previously used on the same control association.

Regards,

Christer

> -----Original Message-----
> From: FCG SHI Hao [mailto:[email-masked]]
> Sent: 15. syyskuuta 2005 6:33
> To: Christer Holmberg (JO/LMF); [email-masked]
> Subject: RE: [Megaco] Questions identified at TISPAN#8
> 
> 
> Hi,
> 
> "The Message Identifier (MID) of a message is set to a 
> provisioned name (e.g. domain address/domain name/device 
> name) of the entity transmitting the message. Domain name is 
> a suggested default. An H.248.1 entity (MG/MGC) must 
> consistently use the same MID in all messages it originates 
> for the duration of control association with the peer (MGC/MG)."
> 
> The question is: is it allowed to modify the MGC/MG control 
> association (e.g. if the IP address of the MGC changes) 
> simply by updating the MID value? Is the MG required to 
> detect the updated value, and perform appropriate functions?
> 
> The control association should be allowed to modify by 
> updating the MID. There are 3 conditions: 
> 1. When MG registers to MGC, MGC replies a response with the 
> new MID, MG should change the control association to the new MID. 
> 2. MGC sends the ServiceChange message to update the MID with 
> the Method "Restart", all the call in the MG should be 
> deleted and  change the control association to the new MID.
> 3. MGC sends the ServiceChange message to update the MID with 
> the Method "Handoff", all the call in the MG should be 
> reserved and change the control association to the new MID.
> ???: [email-masked] 
[mailto:[email-masked]]?? Christer Holmberg (JO/LMF)
????: 2005?9?14? 22:59
???: [email-masked]
??: [Megaco] Questions identified at TISPAN#8

Hi,

H.248 currently says:

Regards,

Christer
LM Ericsson