Subject: [Megaco] H.248.14: what if GW goes OOS?

From: "Pascal Lambers" <[email-masked]>
Date: Tue, 6 Sep 2005 21:55:42 +0200

Hello,

Suppose that both MG and MGC run with the Inactivity Timer Package (H.248.14) activated: the MGC will send down heartbeat messages in case there is no other traffic.

Now, if this MG reports to be OOS (Eg it sends ServiceChange Forced for Root): does the MG mandatorily have to stop sending down the heartbeat messages?

Kind regards,
Pascal

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Wed, 07 Sep 2005 09:35:24 +1000

Hello Pascal,

I think there's a typo in the last sentence. Assuming that you mean MGC 
(not MG):
Given that the MG has gone OOS then there's no point sending down 
heartbeat messages as the control association has most probably ended. 
So the MG should only be looking for ServiceChange commands and 
would/should discard other messages. Also as the MG is in state OOS the 
event mechanism which is used for inactivity timing would be inactive.

Regards, Christian

Pascal Lambers wrote:

> Hello,
>  
> Suppose that both MG and MGC run with the Inactivity Timer Package 
> (H.248.14) activated: the MGC will send down heartbeat messages in 
> case there is no other traffic.
>  
> Now, if this MG reports to be OOS (Eg it sends ServiceChange Forced 
> for Root): does the MG mandatorily have to stop sending down the 
> heartbeat messages?
>  
> Kind regards,
> Pascal
>  
>  
>
>------------------------------------------------------------------------
>

---

From: "Pascal Lambers" <[email-masked]>
Date: Wed, 7 Sep 2005 18:50:43 +0200

Thanks Christian. I agree and the last sentence was indeed about the MGC
sending heartbeat messages.
Kind regards,
Pascal