Subject: 回复:Re: [Megaco] a doubt about audit context of H248 V3

From: zhuning 17035 <[email-masked]>
Date: Fri, 30 Sep 2005 10:38:25 +0800

maybe u do not know what i means. in h248 V3 ,we can audit context .context and command is not in the same level .if we have a action ,in which there is a context audit but NO command. how MGW knows to audit context value or to audit context capbility??

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or em
ail immediately and delete it!
 *****************************************************************************************

----- 原邮件 -----
从: Tom-PT Taylor <[email-masked]>
日期: 星期五, 九月 30日, 2005 上午0:23
主题: Re: [Megaco] a doubt about audit context of H248 V3

> AuditValue and AuditCapability are two separate protocol commands. 
> They
> have been there from the beginning.  It isn't necessary to make the
> distinction within the descriptors when it is already made at 
> command level.
> 
> zhuning 17035 wrote:
> > 
> > 
> ...
> > 
> > It is a context level audit ,not a termination level audit.So 
> what is
> > the flag of audit type in it? i mean that how to indicate that 
> it is
> > a value audit or capbility audit in of context audit ?
> > 
> ...
> 
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 30 Sep 2005 09:11:38 -0400

Not that you were unclear, I just didn't think about it.  There does
seem to be something missing.

zhuning 17035 wrote:
> i think my expression was not clear .
> 
> in H248 V3, cotext audit is supported. there are context auditvalue and context auditcapbility.
> command is another level structure.and maybe there is no command in a action .in struct 
> ContextAttrAuditRequest there is no flag for audit type(value or capbility).
> 
> 
> ContextAttrAuditRequest	::= SEQUENCE
> {
> 	topology				NULL OPTIONAL,
> 	emergency				NULL OPTIONAL,
> 	priority				NULL OPTIONAL,
> 	…,
> 	iepscallind				NULL OPTIONAL,
> 	contextPropAud			SEQUENCE OF IndAudPropertyParm OPTIONAL,
> 	selectpriority			INTEGER(0..15) OPTIONAL,
>            -- to select given priority
> 	selectemergency			BOOLEAN OPTIONAL,
>            -- to select if emergency set/not set (T/F) 
> 	selectiepscallind			BOOLEAN OPTIONAL,
>            -- to select if IEPS set/not set (T/F)
> 	selectLogic				SelectLogic OPTIONAL    -- default is AND
> }
> 
> 
>