Subject: [Megaco] Regarding change of local ip address through modify

From: Prabuddha Chaturvedi <[email-masked]>
Date: Sat, 10 Sep 2005 18:09:43 +0200

hi all,
         I have a problem regarding change of local ip address through 
modify command.
the mod req comes for an ephemeral termination.
1.Can i change local ip address and Udp port
of already existing termination through modify. if not which error code 
shud i return.
2. Is it mandatory to send local ip address ,UDp port  in local 
descriptor part of Modify request(only term id isn't sfficient)?

Regards
Prabuddha

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Sat, 10 Sep 2005 18:34:22 +0200

Hi,

>modify command. the mod req comes for an ephemeral termination.
>1.Can i change local ip address and Udp port of already existing termination through modify. if not which 
>error code shud i return.

Don't remember the error code (I don't have the spec in front om me), but I don't think the standard prevents you from chaning to local ip address and UDP port. I am not sure I see a use-case, though, because the MGC would have to know which addresses and ports are available in the MG.

>2. Is it mandatory to send local ip address ,UDp port  in local descriptor part of Modify request(only term id isn't 
>sfficient)?

It is not mandatory to include SDP in the local descriptor, but if you do it must comply with the SDP rules.

Regards,

Christer