Subject: [Megaco] SDP: ptime - range of values

From: [email-masked]
Date: Sun, 11 Sep 2005 11:55:36 +0300

Hello,

      Can i use range of values in ptime (example: ptime: 10-40) in the
same manner as for MGCP.
The followinfg text extract from RFC 3435
   * The packetization period in milliseconds, encoded as the keyword
     "p", followed by a colon and a decimal number.  If the Call Agent
     specifies a range of values, the range will be specified as two
     decimal numbers separated by a hyphen (as specified for the "ptime"
     parameter for SDP).

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Sun, 11 Sep 2005 18:38:39 +0200

Hi,

The SDP ABNF does not, as far as I know, allow you to specify a range, and H.248 does not specify special rules for the ptime attribute. So, the answer is NO, I'd say.

Regards,

Christer

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of [email-masked]
> Sent: 11. syyskuuta 2005 11:56
> To: [email-masked]
> Subject: [Megaco] SDP: ptime - range of values 
> 
> 
> 
> 
> 
> 
> Hello,
>

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 12 Sep 2005 12:18:17 -0400

In the MGC->MG direction, the spec allows both overspecification and
underspecification of values in SDP.  See sections 7.1.1 and 7.1.8.  In
the MG->MGC direction, the MG must issue compliant SDP as stated in
7.1.8.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of [email-masked]
Sent: Sunday, September 11, 2005 4:56 AM
To: [email-masked]
Subject: [Megaco] SDP: ptime - range of values 

Hello,

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Mon, 12 Sep 2005 18:54:28 +0200

Hi,

>underspecification of values in SDP.  See sections 7.1.1 and 
>7.1.8.  In the MG->MGC direction, the MG must issue compliant SDP as stated in
>7.1.8.

I think it would be important, probably within the scope of H.248.SDP, how this overspecification is to be done, and which parameter values are allowed to be overspecified. It may be simple in the case of ptime, but when we talk about SDP parameters, and other attributes, I am sure people could come up with an endless of different kind of strange overspecificaton combinations...

Regards,

Christer

> [mailto:[email-masked]] On Behalf