Subject: [Megaco] Regarding Duplication of Transaction ID

From: "Chittapragada Srikanth XX (ST/LMD)" <[email-masked]>
Date: Mon, 5 Sep 2005 13:50:14 +0200

Hi,
	Transaction Id in megaco messages should be unique.
But if we send a message with transaction id 'X' and also a different message with the same transaction id, how should the protocol behave.

	Example:
		MGC Sends ADD Command with Transaction ID 1
		MG replies ADD with Transaction ID 1
		MGC Sends SUBTRACT Comamnd with Transaction ID 1
		How should MG behave at this stage ?
		Should it return the message with Transaction ID 1 as the response for the SUBTRACT Command or should it return any Error ?
		If it should return an Error then what should be the Error Descriptor ? Do we have any Error descriptor defined for this scenario ?

Best Regards,
Srikanth Ch

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Mon, 5 Sep 2005 16:58:39 +0200

The situation you have described is a gross error on the part of the MGC, if
it sent two different requests with the same transaction id within
LONG-TIMER seconds.  The MG treats the second request as a duplicate of the
original request and repeats the reply that it sent for the ADD.  The fact
that the second request had a different content is ignored.

Raphael Tryster

-----Original Message-----
From: Chittapragada Srikanth XX (ST/LMD)
[mailto:[email-masked]]
Sent: Monday, September 05, 2005 1:50 PM
To: [email-masked]
Subject: [Megaco] Regarding Duplication of Transaction ID

Hi,
	Transaction Id in megaco messages should be unique.
But if we send a message with transaction id 'X' and also a different
message with the same transaction id, how should the protocol behave.

	Example:
		MGC Sends ADD Command with Transaction ID 1
		MG replies ADD with Transaction ID 1
		MGC Sends SUBTRACT Comamnd with Transaction ID 1
		How should MG behave at this stage ?
		Should it return the message with Transaction ID 1 as the
response for the SUBTRACT Command or should it return any Error ?
		If it should return an Error then what should be the Error
Descriptor ? Do we have any Error descriptor defined for this scenario ?

Best Regards,
Srikanth Ch

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 9 Sep 2005 13:19:19 -0400

Indeed, the spec allows the receiver to stop parsing at the
TransactionID and just return the previously sent response.  So the
sender is going to get a very confusing reply back to the erroneous
second message.
 
Kevin

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Raphael Tryster
	Sent: Monday, September 05, 2005 10:59 AM
	To: 'Chittapragada Srikanth XX (ST/LMD)'; [email-masked]
	Subject: RE: [Megaco] Regarding Duplication of Transaction ID

	The situation you have described is a gross error on the part of
the MGC, if it sent two different requests with the same transaction id
within LONG-TIMER seconds.  The MG treats the second request as a
duplicate of the original request and repeats the reply that it sent for
the ADD.  The fact that the second request had a different content is
ignored.

	Raphael Tryster 

	-----Original Message----- 

	Hi, 
	        Transaction Id in megaco messages should be unique. 
	But if we send a message with transaction id 'X' and also a
different message with the same transaction id, how should the protocol
behave.

	        Example: 

	                How should MG behave at this stage ? 
	                Should it return the message with Transaction ID
1 as the response for the SUBTRACT Command or should it return any Error
?

	                If it should return an Error then what should be
the Error Descriptor ? Do we have any Error descriptor defined for this
scenario ?

	Best Regards, 
	Srikanth Ch