Subject: [Megaco] SDP - silence suppression

From: [email-masked]
Date: Mon, 12 Sep 2005 11:33:07 +0300

Hello,

Question1:
In case that the MGC send in the local descriptor the following (the
reservevalue=true):
m=audio $ RTP/AVP $

Can the MG respond as following?
M=audio <port number> 8, 18, 4, 13, 110
a=ptime:10
a=fmtp:18 annexb=yes
a=fmtp:4 annexa=yes
a=rtpmap:110 telephone-event/8000
a=fmtp:110 0-15

That means:
 for g.711(8) use silence suppression payloadtype 13, ptime=10 and DTMF
relay (RFC2833)
 for g.729(18) use silence suppression annexb, ptime=10 and DTMF relay
(RFC2833)
 for g.723(4) use silence suppression annexa, ptime=30 and DTMF relay
(RFC2833)

question 2:
In case that the MGC send in the local descriptor the following:
m=audio $ RTP/AVP 18

Can the MG respond as following?
m=audio <port number> 18 110
a=ptime:10
a=fmtp:18 annexb=yes
a=rtpmap:110 telephone-event/8000
a=fmtp:110 0-15

That means that the MG offer the Silence suppression and DTMF relay
(RFC2833) although the MGC didn’t request these options.

Thank you in advanced,
Arie

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 12 Sep 2005 12:28:52 -0400

1. Yes, though the commas between the codecs in the m= line constitute a
syntax error in the SDP.
2. No.  If the MGC specifies particular codecs to be used, the MG may
not add to the list.  The MG may only choose codecs if it is provided a
CHOOSE token in the command.

In general, the MG may add a= lines necessary to fully specify the SDP.
But it may not add values to items that are fully specified by the MGC
-- it may only remove values it does not support.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of [email-masked]
Sent: Monday, September 12, 2005 4:33 AM
To: [email-masked]
Subject: [Megaco] SDP - silence suppression 

Hello,

Question1:

That means:
 for g.711(8) use silence suppression payloadtype 13, ptime=10 and DTMF
relay (RFC2833)  for g.729(18) use silence suppression annexb, ptime=10
and DTMF relay
(RFC2833)
 for g.723(4) use silence suppression annexa, ptime=30 and DTMF relay
(RFC2833)

question 2:

That means that the MG offer the Silence suppression and DTMF relay
(RFC2833) although the MGC didn't request these options.

Thank you in advanced,
Arie