Subject: [Megaco] DTMF detection request

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Thu, 8 Sep 2005 16:19:42 +0200

Hi,

When I want to use the DTMF detection package, how does the Events descriptor detection request to the MG look like?

I guess I could use: Events = 1234 {dd/std {tl=*}}. I assume that would only return DTMF digits, since I use the event with dd instead of tonegen?

But, since I don't want to use the "std" event, but rather the defined DTMF events (d0, d1, etc) directly, can I use: Events = 1234 {dd/*} (i.e. I wildcard the event instead of the tone list?)?

Regards,

Christer

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 9 Sep 2005 13:19:16 -0400

You cannot use dd/* -- remember that the completion event would be
included and that would require a DigitMap.  To get the individual digit
events reported, you would need something like:

E=123{dd/d0,dd/d1,dd/d2,dd/d3,dd/d4,dd/d5,dd/d6,dd/d7,dd/d8,dd/d9,dd/ds,
dd/do}

Don't forget that if you are interested in the A,B,C or D digits, those
would have to be included too!

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Christer Holmberg (JO/LMF)
Sent: Thursday, September 08, 2005 10:20 AM
To: [email-masked]
Subject: [Megaco] DTMF detection request

Hi,

When I want to use the DTMF detection package, how does the Events
descriptor detection request to the MG look like?

I guess I could use: Events = 1234 {dd/std {tl=*}}. I assume that would
only return DTMF digits, since I use the event with dd instead of
tonegen?

But, since I don't want to use the "std" event, but rather the defined
DTMF events (d0, d1, etc) directly, can I use: Events = 1234 {dd/*}
(i.e. I wildcard the event instead of the tone list?)?

Regards,

Christer

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Sat, 10 Sep 2005 16:31:37 +0200

Hi,

So, if I understand the ABNF correct, if I want to collect DTMF digits on a specific stream, I would have to indicate the stream for EACH digit.

So, the EventsDescriptor would look like:

E=123{dd/d0{Stream=1},dd/d1{Stream=1},dd/d2{Stream=1},dd/d3{Stream=1},...etc etc etc.

Is that really correct???

Regards,

Christer

> From: Kevin Boyle [mailto:[email-masked]]
> Sent: 9. syyskuuta 2005 20:19
> To: Christer Holmberg (JO/LMF); [email-masked]
> Subject: RE: [Megaco] DTMF detection request
> 
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Sat, 10 Sep 2005 17:56:36 +0200

And on we go... :)

Another way would be to use the start tone detected event (std), so the events descriptor would look like:

E=123{dd/std{stream=1,tl=[d0,d1,d2...]}}

This way, it would be possible to define the stream id only once, for the whole list of DTMF tones, right?

Regards,

Christer

> [mailto:[email-masked]]On Behalf
> Sent: 10. syyskuuta 2005 17:32
> To: Kevin Boyle; [email-masked]
> So, if I understand the ABNF correct, if I want to collect 
> DTMF digits on a specific stream, I would have to indicate 
> the stream for EACH digit.
>

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 12 Sep 2005 12:12:21 -0400

The problem here is that it would report digits that would not normally
be of long enough duration to be considered a digit.  So, yes, it would
solve the message size problem, but would allow spurious digits to be
detected on occasion.

Kevin

-----Original Message-----
From: Christer Holmberg (JO/LMF) [mailto:[email-masked]]

Sent: Saturday, September 10, 2005 11:57 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Subject: RE: [Megaco] DTMF detection request

And on we go... :)

Another way would be to use the start tone detected event (std), so the
events descriptor would look like:

This way, it would be possible to define the stream id only once, for
the whole list of DTMF tones, right?

Regards,

Christer

> [mailto:[email-masked]]On Behalf Of Christer Holmberg 
> (JO/LMF)
> So, if I understand the ABNF correct, if I want to collect DTMF digits

> on a specific stream, I would have to indicate the stream for EACH 
> digit.
> 
> > included and that would require a DigitMap.  To get the individual 
> > digit events reported, you would need something like:
> > 
> > Don't forget that if you are interested in the A,B,C or D digits, 
> > those would have to be included too!
> > 
> > Kevin
> > 
> > [mailto:[email-masked]] On Behalf Of Christer Holmberg 
> > (JO/LMF)
> > I guess I could use: Events = 1234 {dd/std {tl=*}}. I assume that 
> > would only return DTMF digits, since I use the event with dd instead

> > of tonegen?

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 12 Sep 2005 12:10:08 -0400

Unfortunately, yes.

Kevin 

-----Original Message-----

Sent: Saturday, September 10, 2005 10:32 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Subject: RE: [Megaco] DTMF detection request

Hi,

E=123{dd/d0{Stream=1},dd/d1{Stream=1},dd/d2{Stream=1},dd/d3{Stream=1},..
.etc etc etc.

Regards,

Christer

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Mon, 12 Sep 2005 18:50:35 +0200

Hi,

>The problem here is that it would report digits that would 
>not normally be of long enough duration to be considered a digit.  So, 
>yes, it would solve the message size problem, but would allow spurious digits to be
>detected on occasion.

I don't really understand what you mean. The implementation of DTMF detection in the MG should be the same, no matter how I request it. d0, d1, d2, d3 are the same tones, no matter which way I use to request them, aren't they?

Regards,

Christer

> DTMF digits

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 12 Sep 2005 14:23:05 -0400

Digits are only valid if they exist longer than a minimum threshold
time.  A tone that lasts less than the threshold would be discarded as
noise.  By using "start tone detected", it would certainly be possible
to detect the start of a tone and report it, while the duration of that
tone would fail to meet the minimum duration for detection.

Kevin 

-----Original Message-----

Sent: Monday, September 12, 2005 12:51 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Subject: RE: [Megaco] DTMF detection request

Hi,

>solve the message size problem, but would allow spurious digits to be 

I don't really understand what you mean. The implementation of DTMF
detection in the MG should be the same, no matter how I request it. d0,
d1, d2, d3 are the same tones, no matter which way I use to request
them, aren't they?

Regards,

Christer

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Mon, 12 Sep 2005 20:39:06 +0200

Hi,

>to detect the start of a tone and report it, while the 
>duration of that tone would fail to meet the minimum duration for detection.

Ok, I understand what you mean. 

However, the tone has to be long enough in order for the MG to identify WHICH DTMF tone it is, so I wonder if the risk of reporting "false" DTMF tones is really a real-life issue?

Regards,

Christer

> not normally