Subject: RE: [Megaco] ADD to a terminationID and ADD to ephemeral

From: "Milton Mukhopadhyaya" <[email-masked]>
Date: Sat, 10 Sep 2005 01:43:50 -0700

Hi
I have another question related to adding ephemeral termination - I believe if an MG that is not capable of adding more than one ephemeral terminations in a context receives such a  request, it should send back an error reply. What would be the value of the error code in such a scenario ?
 
Regards,
Milton

________________________________

From: [email-masked] on behalf of Kevin Boyle
Sent: Fri 9/9/2005 10:19 AM
To: Raphael Tryster; Tamar Nemet; [email-masked]
Cc: Mazorov, Rima [Business:TELRD:TELRD]
Subject: RE: [Megaco] ADD to a terminationID and ADD to ephemeral

Remember, physical and ephemeral terminations are completely independent
entities.  There is not permitted to be any linkage between them.  The
only time they are related in any way is when they happen to be in a
context together.

Kevin

________________________________

        From: [email-masked] [mailto:[email-masked]]
On Behalf Of Raphael Tryster
        Sent: Monday, September 05, 2005 9:28 AM
        To: 'Tamar Nemet'; [email-masked]'
        Cc: Mazorov, Rima [Business:TELRD:TELRD]
        Subject: RE: [Megaco] ADD to a terminationID and ADD to
ephemeral

        The short answer is "yes".

        This has been discussed before in the list.  Ephemerals might be
added to a context before physical terminations, or even without any
physical terminations, e.g. in a conference server.  You can see this in
a thread called "4 Ephemeral terminations and no physical" in January
2004, and in other threads that I can't find right now.

        I am guessing that you ask this question to try to find a way
around your previous question, how to tell whether $ means choose a
physical or ephemeral termination.  This has also been discussed several
times.  Look for a thread entitled "Race condition between Modify and
Subtract", afterwards renamed "ADD with CHOOSE (was RE: [Megaco] Race
condition between Modify a nd  Subtract)", from November 2001.  Other
relevant threads are called "how to create a user-defined termination"
from July 2002, "Questions about Add" from September 2002, and "Add and
CHOOSE" frm January 2004.

        Raphael Tryster

        -----Original Message-----
        From: Tamar Nemet [mailto:[email-masked]]
        Sent: Monday, September 05, 2005 1:38 PM
        To: [email-masked]'
        Cc: Rima Mazorov
        Subject: [Megaco] ADD to a terminationID and ADD to ephemeral

         Hello,

         Does anybody know if an ADD command with ephemeral termination
can come
        before ADD command with a physical terminationID ?

        Thanks,
        Tamar

        _______________________________________________
        Megaco mailing list
        [email-masked]
        https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Jim Li" <[email-masked]>
Date: Tue, 20 Sep 2005 16:29:05 -0400

The Error code should be 434
"Max_Number_of_Terminations_in_a_Context_exceeded"
 
Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Milton Mukhopadhyaya
Sent: Saturday, September 10, 2005 4:44 AM
To: Kevin Boyle; Raphael Tryster; Tamar Nemet; [email-masked]
Cc: Mazorov, Rima [Business:TELRD:TELRD]
Subject: RE: [Megaco] ADD to a terminationID and ADD to ephemeral

Hi
I have another question related to adding ephemeral termination - I believe
if an MG that is not capable of adding more than one ephemeral terminations
in a context receives such a  request, it should send back an error reply.
What would be the value of the error code in such a scenario ?
 
Regards,
Milton

  _____  

Kevin

        Raphael Tryster

        -----Original Message-----
        From: Tamar Nemet [mailto:[email-masked]]
        Sent: Monday, September 05, 2005 1:38 PM
        To: [email-masked]'
        Cc: Rima Mazorov
        Subject: [Megaco] ADD to a terminationID and ADD to ephemeral

         Hello,

        Thanks,
        Tamar