Subject: [Megaco] a doubt about audit context of H248 V3

From: zhuning 17035 <[email-masked]>
Date: Thu, 15 Sep 2005 11:00:14 +0800

in H248.1 V3 

7.2.9        Manipulating and auditing context attributes 
................. 

An action request sent to a MG may include a request to audit attributes of a Context. context. There are two types of audit: 

Value Audit: The MGC may audit a specific Context context to determine the current value of individual context properties. The MGC may determine the current values for all existing (non-NULL) Contextscontexts by specifying ContextID ALL in the Audit request. If context attributes are added, or have been modified by the same action as the Audit request, the value/s returned shall be after the action has been applied. Context attributes can b
e used as selection criteria to filter the audit return values. It is possible to include multiple selection criteria. When multiple criteria are included, either an AND or an OR logic operation may also be included to indicate how the selection criteria are to be interpreted. If no logic operation is included, an AND logic operation is assumed. 

Capabilities Audit: The MGC may audit a specific context to determine the possible values that individual context properties can assume. The MGC may determine the possible values for the entire MG by specifying ContextID ALL in the audit request. 
............. 

It is a context level audit ,not a termination level audit.So what is the flag of audit type in it? 
i mean that how to indicate that it is a value audit or capbility audit in of context audit ? 

i think it should not depend on audit command type .Give a sample that  in a H248 message in which there is one action and two commands ,the first is auditvalue command for termination T1 and the other is audit value for termination T2. then ,if i want a context audit ,How to indicate that it is a value audit or capbility audit of context audit?? in ContextAttrAuditRequest i can not find a flag for this.

....................... 
ContextRequest                ::= SEQUENCE 
{ 
        priority                                INTEGER(0..15) OPTIONAL, 
        emergency                                BOOLEAN OPTIONAL, 
        topologyReq                                SEQUENCE OF TopologyRequest OPTIONAL, 
        …, 
        iepscallind                                BOOLEAN OPTIONAL, 
        contextProp                                SEQUENCE OF PropertyParm OPTIONAL, 
        contextList                                SEQUENCE OF ContextID OPTIONAL 
} 
-- When returning a contextList, the contextId in the ActionReply construct will 
-- return the contextId from the associated ActionRequest. 

ContextAttrAuditRequest        ::= SEQUENCE 
{ 
        topology                                NULL OPTIONAL, 
        emergency                                NULL OPTIONAL, 
        priority                                NULL OPTIONAL, 
        …, 
        iepscallind                                NULL OPTIONAL, 
        contextPropAud                        SEQUENCE OF IndAudPropertyParm OPTIONAL, 
        selectpriority                        INTEGER(0..15) OPTIONAL, 
           -- to select given priority 
        selectemergency                        BOOLEAN OPTIONAL, 
           -- to select if emergency set/not set (T/F) 
        selectiepscallind                        BOOLEAN OPTIONAL, 
           -- to select if IEPS set/not set (T/F) 
        selectLogic                                SelectLogic OPTIONAL    -- default is AND 
} 

SelectLogic            ::= CHOICE 
{ 
        andAUDITSelect                        NULL,     -- all filter conditions satisfied 
        orAUDITSelect                        NULL,     -- at least one filter condition satisfied 
      … 
} 

...................... 

thanks,
zhuning

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 29 Sep 2005 12:23:39 -0400

AuditValue and AuditCapability are two separate protocol commands.  They
have been there from the beginning.  It isn't necessary to make the
distinction within the descriptors when it is already made at command level.

zhuning 17035 wrote:
...
> 
> It is a context level audit ,not a termination level audit.So what is
> the flag of audit type in it? i mean that how to indicate that it is
> a value audit or capbility audit in of context audit ?
> 
...