Subject: [Megaco] ADD with a $ terminatinID or $ for the context ID

From: Tamar Nemet <[email-masked]>
Date: Thu, 8 Sep 2005 16:02:27 +0300

Hello,
 
If the SoftSwitch send an ADD command to the MG with $ in the contextID or
in the TerminationID, and the MG doesn't have resources to allocate for this
command. The MG shall return error which indicates that it doesn't have
resources.
 
What will be in the TerminationID/contextID in the reply ? $ ? anything else
?
 
Thanks,
Tamar
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 9 Sep 2005 13:19:21 -0400

If the MG cannot allocate a context, the error would appear at the
action level.  If it cannot allocate a termination, the error would
appear at the command level.  In the case of a failed ADD command to a
new context, the ContextID returned is that which is sent ($).
 
Example 1: T=123{C=${A=${...}}}
 
No ContextIDs:
P=123{ER=412{}}
 
No TermIDs:
P=123{C=${ER=432{}}}
 
Example 2: T=124{C=12{A=${...}}}
 
No TermIDs:
P=124{C=12{ER=432{}}}
 
Kevin

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Tamar Nemet
	Sent: Thursday, September 08, 2005 9:02 AM
	To: [email-masked]
	Cc: Mendelevich, Victoria [Business:TELRD:TELRD]
	Subject: [Megaco] ADD with a $ terminatinID or $ for the context
ID

	Hello,
	 
	If the SoftSwitch send an ADD command to the MG with $ in the
contextID or in the TerminationID, and the MG doesn't have resources to
allocate for this command. The MG shall return error which indicates
that it doesn't have resources.
	 
	What will be in the TerminationID/contextID in the reply ? $ ?
anything else ?
	 
	Thanks,
	Tamar

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Sun, 11 Sep 2005 22:21:08 +0200

Hi,
 
If you're going to return an error I guess the ID value in the reply can be whatever it was in the request...
 
Regards,
 
Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Tamar Nemet
Sent: 8. syyskuuta 2005 16:02
To: [email-masked]
Cc: Victoria Mendelevich
Subject: [Megaco] ADD with a $ terminatinID or $ for the context ID

Hello,
 
If the SoftSwitch send an ADD command to the MG with $ in the contextID or in the TerminationID, and the MG doesn't have resources to allocate for this command. The MG shall return error which indicates that it doesn't have resources.
 
What will be in the TerminationID/contextID in the reply ? $ ? anything else ?
 
Thanks,
Tamar