Subject: Re: [Megaco] Digit Map Timers

From: Anila M <[email-masked]>
Date: Mon, 06 Feb 2006 09:45:52 +0530

Hi,

I have a doubt in the example provided.

The H.248 documents says-

"If an explicit timing specifier is in effect in one alternative event
sequence, but none is given in any other candidate alternative, the
timer value set by the explicit timing specifier must be used. If all
sequences with explicit timing controls are dropped from the candidate
set, timing reverts to the default rules given above. Finally, if
conflicting timing specifiers are in effect in different alternative
sequences, the long timer shall be used."

Does this not mean that if my DigitMap consisted of: {1411S|1411x}, the
explicitly specified 'S', Short Timer will be used and if my DigitMap
consisted of: {1411S|1411xL}, the Long Timer shall be used?

Am I getting it wrong?

Regards,

Anila

Kevin Boyle wrote:

Using H.248 terminology, you want to use the Short Interdigit Timer,
rather than the Long Interdigit Timer.

Under the matching rules defined in H.248.16, the specification of 'S'
in the DigitMap will cause all timing to go short when it is encountered
in one of the still-viable digitstrings. This is due to the "shortest
possible match" nature of the extended rules. If using the base rules
defined in H.248.1, then there is no way to cause the Short Timer to
override if there are multiple strings left to match against and they do
not all specify the 'S' timer in the strings. This is due to the
"longest possible match" nature of these rules.

So, using your example, if my DigitMap consisted of: {1411S|1411x}

Then using the base rules, you would have to wait for the Long Timer to
expire due to the second digit string. Under the extended rules, the
map would match as soon as the Short Timer expired.

Kevin

________________________________

From: [email-masked] [mailto:[email-masked]]
On Behalf Of Mayhan, Heather M [NTK]
Sent: Tuesday, December 20, 2005 12:53 PM
To: [email-masked]
Subject: [Megaco] Digit Map Timers

I am trying to find out if there is a way to invoke the Critical
Digit Map Timer (~4 secs) via the Digit Map instead of the Partial Digit
Map Timer (~16 secs).

Dialing 1411 causes an extensive delay (due to Partial Digit Map
Timer) in call connection due Digit Map Sequencing not matching up.

Heather

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

--

Anila M

"Be not afraid of growing slowly, be afraid only of standing still."
-  Chinese Proverb

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message. Further, you are not to copy, disclose, or distribute this e-mail or its contents to any other person and any such actions are unlawful. This e-mail may contain viruses. Infosys has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Infosys reserves the right to monitor and review the content of all messages sent to or from this e-mail address. Messages sent to or from this e-mail address may be stored on the Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 6 Feb 2006 15:42:06 -0500

It depends if you are using the base rules in H.248.1, or the extended
rules in H.248.16.
 
If using the base rules, yes, the L timer must be used.
If using the extended rules in H.248.16, the S timer must be used.
 
Kevin

	From: Anila M [mailto:[email-masked]] 
	Sent: Sunday, February 05, 2006 11:16 PM
	To: Boyle, Kevin [NCRTP:3Z40:EXCH]
	Cc: Mayhan, Heather M [NTK]; [email-masked]
	Subject: Re: [Megaco] Digit Map Timers

	Hi,

	The H.248 documents says-
	"If an explicit timing specifier is in effect in one alternative
event sequence, but none is given in any other candidate alternative,
the timer value set by the explicit timing specifier must be used. If
all sequences with explicit timing controls are dropped from the
candidate set, timing reverts to the default rules given above. Finally,
if conflicting timing specifiers are in effect in different alternative
sequences, the long timer shall be used."
	
	Does this not mean that if my DigitMap consisted of:
{1411S|1411x}, the explicitly specified 'S', Short Timer will be used
and if my DigitMap consisted of: {1411S|1411xL}, the Long Timer shall be
used?
	
	Am I getting it wrong?
	
	Regards,
	Anila
	
	Kevin Boyle wrote: 

		Using H.248 terminology, you want to use the Short
Interdigit Timer,
		rather than the Long Interdigit Timer.
		 
		Under the matching rules defined in H.248.16, the
specification of 'S'
		in the DigitMap will cause all timing to go short when
it is encountered
		in one of the still-viable digitstrings.  This is due to
the "shortest
		possible match" nature of the extended rules.  If using
the base rules
		defined in H.248.1, then there is no way to cause the
Short Timer to
		override if there are multiple strings left to match
against and they do
		not all specify the 'S' timer in the strings.  This is
due to the
		"longest possible match" nature of these rules.
		 
		So, using your example, if my DigitMap consisted of:
{1411S|1411x}
		 
		Then using the base rules, you would have to wait for
the Long Timer to
		expire due to the second digit string.  Under the
extended rules, the
		map would match as soon as the Short Timer expired.
		 
		Kevin

			From: [email-masked]
[mailto:[email-masked]]
		On Behalf Of Mayhan, Heather M [NTK]
			Sent: Tuesday, December 20, 2005 12:53 PM
			To: [email-masked]
			Subject: [Megaco] Digit Map Timers

			I am trying to find out if there is a way to
invoke the Critical
		Digit Map Timer (~4 secs) via the Digit Map instead of
the Partial Digit
		Map Timer (~16 secs).
		
			Dialing 1411 causes an extensive delay (due to
Partial Digit Map
		Timer) in call connection due Digit Map Sequencing not
matching up.
		
			Heather

			

	-- 
	Anila M

	"Be not afraid of growing slowly, be afraid only of standing
still." -  Chinese Proverb