Subject: RE: [Megaco] question on Message Identifier (MID) of H.248 messages

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 7 Feb 2006 12:17:25 -0500

It seems to me that if you change ports, you alter the control
association.  Also, remember that the control association is not
established until the Reply from the MGC is received by the MG.  So,
during the course of the control association, the MID has not changed --
it was altered during the transition from registration to control
association.
 
Kevin

________________________________

	From: B Venkat S.R Swamy
[mailto:[email-masked]] 
	Sent: Tuesday, February 07, 2006 2:50 AM
	To: Boyle, Kevin [NCRTP:3Z40:EXCH]
	Cc: Oikonomou, Ioannis; [email-masked]
	Subject: RE: [Megaco] question on Message Identifier (MID) of
H.248 messages

	Hi
	
	However, as per the protocol, MID is used to uniquely identify
the peer entity in any control association and should not have any
relationship 
	with the transport plane address either configured or modified
through servicechange procedures(except the serviceChangeMGCID where the
control assocation changes due to HandOff)
	
	In the example mentioned below, where Port Redirection is used,
all the messages are exchanged under the umbrella of same control
association and therefore by no means the MID of entity should change
for the duration of control association. The following paragraph from
the protocol H248.1 V3, Section 8.3 also suggest this:
	"
	The Message Identifier (MID) of a message is set to a
provisioned name (e.g. domain address/domain name/device name) of the
entity transmitting the message. 
	Domain name is a suggested default. An H.248.1 entity (MG/MGC)
must consistently use the same MID in all messages it originates for the
duration of control association with the peer (MGC/MG)."
	
	Thus due to lack of clarity in the protocol in this respect ,
would recommend authors to take this as an IG item and accordingly
update the section 8.3 for the correct behaviour, keeping in view
	the possibility of port redirection.
	
	regards
	B Venkat S.R Swamy 
	Senior Technical Leader
	Flextronics Software Systems
	Phone: +91-124- 4176213
	Fax: +91-124-4300247
	web: www.flextronicssoftware.com
	 "Kevin Boyle" <[email-masked]>

				"Kevin Boyle" <[email-masked]> 
				Sent by: [email-masked] 

				01/17/2006 12:53 AM

To

"Oikonomou, Ioannis" <[email-masked]>, <[email-masked]>	

cc

Subject

RE: [Megaco] question on Message Identifier (MID) of H.248 messages	

	This is correct.
	
	Kevin

	________________________________
	
	From: [email-masked] [mailto:[email-masked]]
	On Behalf Of Oikonomou, Ioannis
	Sent: Friday, January 13, 2006 3:46 AM
	To: [email-masked]
	Subject: [Megaco] question on Message Identifier (MID) of H.248
	messages

	Hello,

	I have a question concerning the Message Identifier (MID) of
	H.248 messages:

	*       In the H.248 standard it says that:

	The Message Identifier (MID) of a message is set to a
	provisioned name (e.g. domain address/domain name/device name)
of the
	entity transmitting the message. Domain name is a suggested
default. An
	H.248.1 entity (MG/MGC) must consistently use the same MID in
all
	messages it originates for the duration of control association
with the
	peer (MGC/MG).

	*       In paragraph 3.1.1 (MGC accepting registration) of
	draft-ietf-megaco-callflows document (Madhubabu, et al.), the
following
	flow is presented:

	Step 1:
	MG to MGC:
	   MEGACO/1 [209.110.59.34]: 20000
	   Transaction = 1234 {
	       Context = - {
	           ServiceChange = ROOT {Services {
	               Method=Restart,
	               ServiceChangeAddress=15000, Profile=ResGW/1,
	                      12345677T87654320}
	           }
	       }
	   }

	Step 2: 
	MGC to MG:
	   MEGACO/1 [216.33.33.61]:2944
	   Reply = 1234 {
	      Context = - {ServiceChange = ROOT {
	        Services {ServiceChangeAddress=25000, Profile=ResGW/1 , 
	                         12345678T87654321} } }
	   }

	Step 3:
	MGC to MG:
	   MEGACO/1 [216.33.33.61]:25000
	   Transaction = 9999 {
	       Context = - {
	           Modify = * {
	                  Events = 1234 {al/of}
	           }
	       }
	   }

	Step 4:
	MG to MGC:
	   MEGACO/1 [209.110.59.34]:15000
	   Reply = 9999 {
	      Context = - {Modify = A1}
	      Context = - {Modify = A2}
	      Context = - {Modify = A3}
	   }

	Because of port redirection by both sides (MG requests at Step 1
	further communication to port 15000, MGC requests at Step 2
further
	communication to port 25000), the MID of H.248 messages is
changed:

	For MG: In Step 1 it uses "[209.110.59.34]:20000", while from
	Step 4 and on, "[209.110.59.34]:15000" is used.
	
	For MGC: In Step 2 it uses "[216.33.33.61]:2944", while from
	Step 3 and on, "[216.33.33.61]:25000" is used.

	*       Questions:

	My opinion is that the above procedure is correct; since port
	redirection is used, it makes sense that the MID is changed once
during
	the registration procedure.

	What is your opinion?

	Thank you in advance,

	Ioannis Oikonomou
	
	Siemens AE
	
	Athens, Greece

	_______________________________________________
	Megaco mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/megaco

	*********************** FSS-Restricted ***********************
	"DISCLAIMER: This message is proprietary to Flextronics Software

	Systems Limited (FSS) and is intended solely for the use of the 
	individual to whom it is addressed. It may contain privileged or

	confidential information and should not be circulated or used
for 
	any purpose other than for what it is intended. If you have
received 
	this message in error, please notify the originator immediately.

	If you are not the intended recipient, you are notified that you
are
	strictly prohibited from using, copying, altering, or disclosing
	the contents of this message. FSS accepts no responsibility for
	loss or damage arising from the use of the information
transmitted
	by this email including damage from virus."

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Wed, 8 Feb 2006 10:37:04 +0530

Hi

But the even the Annex F H248.1 V3 Section F.5.4, does not indicate the change ports as being change in the control association,

since MG on receiving the ServiceChangeAddress in the first serviceChange reply does not initiate any new registration

attempt towards MGC, but simply update its transport database so that all new message from MG to MGC are sent to

the port as mentioned in the ServiceChangeAddress.

Also as mentioned in protocol as well as your reply, the control association is established only on getting the response from MGC, therefore

if MGC wants to convey its MID, it can do so by mentioning it in the first ServiceChange reply containing the ServiceChangeAddress, but should not

change in the subsequent call control messages.

Even the call flow mentioned in the Appendix 1 of the protocol mentions that MGC replies to serviceChange with the MID, it will use for the entire

duration of control association, as mentioned below:

1) An MG registers with an MGC using the ServiceChange Command

MG1 to MGC:

MEGACO/1 [124.124.124.222]

Transaction = 9998 {

Context = - {

Method=Restart, Version=3,

ServiceChangeAddress=55555, Profile=ResGW/1}}

}}

2)The MGC sends a reply:

MGC to MG1:

MEGACO/1 [123.123.123.4]:55555-------------->MGC MID

Reply = 9998 {

Services {ServiceChangeAddress=55555, Profile=ResGW/1} } }

3) Modify from MGC

MGC to MG1:

MEGACO/3 [123.123.123.4]:55555 -----------> Same MGC MID

Transaction = 9999 {

Context = - {

Modify = A4444 {

Media { Stream = 1 {

LocalControl {

Mode = SendRecv,

tdmc/gain=2, ; in dB,

tdmc/ec=on

}, } },

Events = 2222 {al/of {strict=state}}

} } }

regards

B Venkat S.R Swamy

Senior Technical Leader

Phone: +91-124- 4176213

Fax: +91-124-4300247

02/07/2006 10:47 PM

To

B Venkat S.R Swamy/HSS@HSS

cc

Subject

It seems to me that if you change ports, you alter the control association. Also, remember that the control association is not established until the Reply from the MGC is received by the MG. So, during the course of the control association, the MID has not changed -- it was altered during the transition from registration to control association.

Kevin

From: B Venkat S.R Swamy [mailto:[email-masked]]

Subject: RE: [Megaco] question on Message Identifier (MID) of H.248 messages

Hi

However, as per the protocol, MID is used to uniquely identify the peer entity in any control association and should not have any relationship

with the transport plane address either configured or modified through servicechange procedures(except the serviceChangeMGCID where the control assocation changes due to HandOff)

In the example mentioned below, where Port Redirection is used, all the messages are exchanged under the umbrella of same control association and therefore by no means the MID of entity should change for the duration of control association. The following paragraph from the protocol H248.1 V3, Section 8.3 also suggest this:

"

The Message Identifier (MID) of a message is set to a provisioned name (e.g. domain address/domain name/device name) of the entity transmitting the message.

Domain name is a suggested default. An H.248.1 entity (MG/MGC) must consistently use the same MID in all messages it originates for the duration of control association with the peer (MGC/MG)."

Thus due to lack of clarity in the protocol in this respect , would recommend authors to take this as an IG item and accordingly update the section 8.3 for the correct behaviour, keeping in view

regards

B Venkat S.R Swamy

Senior Technical Leader

Phone: +91-124- 4176213

Fax: +91-124-4300247

01/17/2006 12:53 AM

To

cc

Subject

This is correct.

Kevin

To: [email-masked]

messages

Hello,

H.248 messages:

entity transmitting the message. Domain name is a suggested default. An

H.248.1 entity (MG/MGC) must consistently use the same MID in all

messages it originates for the duration of control association with the

peer (MGC/MG).

draft-ietf-megaco-callflows document (Madhubabu, et al.), the following

flow is presented:

Step 1:

MG to MGC:

Transaction = 1234 {

Context = - {

Method=Restart,

12345677T87654320}

}

}

}

Step 2:

MGC to MG:

Reply = 1234 {

12345678T87654321} } }

}

Step 3:

MGC to MG:

Transaction = 9999 {

Context = - {

Modify = * {

Events = 1234 {al/of}

}

}

}

Step 4:

MG to MGC:

Reply = 9999 {

}

further communication to port 15000, MGC requests at Step 2 further

communication to port 25000), the MID of H.248 messages is changed:

*       Questions:

redirection is used, it makes sense that the MID is changed once during

What is your opinion?

Thank you in advance,

Ioannis Oikonomou

Siemens AE

Athens, Greece

Megaco mailing list

[email-masked]

confidential information and should not be circulated or used for

any purpose other than for what it is intended. If you have received

If you are not the intended recipient, you are notified that you are

loss or damage arising from the use of the information transmitted

confidential information and should not be circulated or used for

any purpose other than for what it is intended. If you have received

If you are not the intended recipient, you are notified that you are

loss or damage arising from the use of the information transmitted