Subject: RE: [Megaco] ServiceChangeVersion compatibility

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 16 Feb 2006 01:36:04 -0500

Correct.  If the MGC wishes to use version 1, in must indicate so in the
SC Reply.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Pascal Lambers
Sent: Wednesday, February 15, 2006 3:04 PM
To: [email-masked]
Subject: [Megaco] ServiceChangeVersion compatibility

A question about chapter 11.3 in H.248.1 version 3:

"If the MGC supports the version indicated by the MG [...] it is
optional for the MGC to return a version in ServiceChangeReply."

 Does this mean that the spec does not provide waterproof backward
compatibility? For example: a MG using version 2 in the
ServiceChangeVersion field, sends a ServiceChange to an "old" MGC that
only supports version 1 and that does not put the ServiceChangeVersion
field in its ServiceChangReply. According to the above statement in the
spec, the MGC implicitly agrees on using version 2.

Pascal 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 16 Feb 2006 01:37:11 -0500

For the record, the most recent version of the IG is November 2004.
 
Kevin

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of B Venkat S.R Swamy
	Sent: Thursday, February 16, 2006 1:30 AM
	To: Pascal Lambers
	Cc: [email-masked]
	Subject: Re: [Megaco] ServiceChangeVersion compatibility

	Hi
	find the comments embedded[BVS]

	regards
	B Venkat S.R Swamy 
	Senior Technical Leader
	Flextronics Software Systems
	Phone: +91-124- 4176213
	Fax: +91-124-4300247
	web: www.flextronicssoftware.com
	 "Pascal Lambers" <[email-masked]>

				"Pascal Lambers"
<[email-masked]> 
				Sent by: [email-masked] 

				02/16/2006 01:34 AM

To

<[email-masked]>	

cc

Subject

[Megaco] ServiceChangeVersion compatibility	

	"If the MGC supports the version indicated by the MG [...] it is
optional 
	for the MGC to return a version in ServiceChangeReply."
	
	[BVS] It is to noted that version is optional only if MGC
supports the version indicated by MG, otherwise
	MGC should either fill the version it supports or reject the
servicechange with reason 406
	[/BVS]
	
	Does this mean that the spec does not provide waterproof
backward 
	compatibility? For example: a MG using version 2 in the
ServiceChangeVersion 
	field, sends a ServiceChange to an "old" MGC that only supports
version 1 
	and that does not put the ServiceChangeVersion field in its 
	ServiceChangReply. According to the above statement in the spec,
the MGC 
	implicitly agrees on using version 2.
	
	[BVS] As mentioned above, even for old MGC which supports V1, it
has to fill the version it supports as per the
	section 11.3 H248.1 V1(Mar 2002)+ IG Jan 2004.
	[/BVS]
	
	Pascal 

	
	*********************** FSS-Restricted ***********************
	"DISCLAIMER: This message is proprietary to Flextronics Software

	Systems Limited (FSS) and is intended solely for the use of the 
	individual to whom it is addressed. It may contain privileged or

	confidential information and should not be circulated or used
for 
	any purpose other than for what it is intended. If you have
received 
	this message in error, please notify the originator immediately.

	If you are not the intended recipient, you are notified that you
are
	strictly prohibited from using, copying, altering, or disclosing
	the contents of this message. FSS accepts no responsibility for
	loss or damage arising from the use of the information
transmitted
	by this email including damage from virus."