Subject: [Megaco] Question on default 'Topology' of a Context

From: "Bill Huang" <[email-masked]>
Date: Thu, 6 Jul 2006 13:22:36 +0200

Could some expert out there clarify the behavior of 'default Topology' of a
Context.
- The default topology for a context is (*,*,bothway) - which is clearly
stated in H.248.1 v1
- Following is a sequence of commands:
  1)  C=$ {Add=TDM1 {...    => assume MG returns C=1
  2)  C=1 {Add=TDM2 {...
  3)  C=1 {Topology{*,*,isolate, $,TDM1,oneway}, Add=$ { ...   => assume MG
returns Eph1
       Q: Does this means the currently topology is: (TDM1,TDM2,Isolate),
(Eph1,TDM2,Isolate), (Eph1,TDM1,oneway)
  4)  C=1 {Add=TDM3 { ...
       Q: Since no topology was specified, does it mean the last default
topology (*,*,isolate) for the Context applies to this 'Add' command?
       Q: If not, what's the topology of the Context?
 
Thanks, Bill
 
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Thu, 6 Jul 2006 19:56:24 +0530

Hi Bill

find my comments embedded[BVS]>>

regards

B Venkat S.R Swamy

Senior Technical Leader

Flextronics Software Systems

Phone: +91-124- 4176213

Fax: +91-124-4300247

web: www.flextronicssoftware.com

"Bill Huang" <[email-masked]>

"Bill Huang" <[email-masked]>

07/06/2006 04:52 PM

To

<[email-masked]>

cc

Subject

[Megaco] Question on default 'Topology' of a Context

Could some expert out there clarify the behavior of 'default Topology' of a Context.

- The default topology for a context is (*,*,bothway) - which is clearly stated in H.248.1 v1

2) C=1 {Add=TDM2 {...

3) C=1 {Topology{*,*,isolate, $,TDM1,oneway}, Add=$ { ... => assume MG returns Eph1

Q: Does this means the currently topology is: (TDM1,TDM2,Isolate), (Eph1,TDM2,Isolate), (Eph1,TDM1,oneway)

[BVS]>> IMO, the first tuple (*,*,isolate) applies to TDM1 and TDM2 only. the isolate does not apply for the newly added termination(Eph1),

the second tuple ($,TDM1,oneway) applies only for (Eph1, TDM1,oneway).

[/BVS]

4) C=1 {Add=TDM3 { ...

Q: Since no topology was specified, does it mean the last default topology (*,*,isolate) for the Context applies to this 'Add' command?

[BVS]>> No, the last topology is not valid for new transaction/action. If there is no topology descriptor in the new transaction/action, default topology(bothway) gets applicable for newly

added termination wrt other terminations in the context. Thus for TDM3 (TDM3,*,bothway; where * applies to TDM1, TDM2 and Eph1) topology is implicitly applied.

[/BVS]

[BVS]>> as mentioned above

[/BVS]

Thanks, Bill

Megaco mailing list

[email-masked]

*********************** FSS-Restricted ***********************

"DISCLAIMER: This message is proprietary to Flextronics Software

Systems Limited (FSS) and is intended solely for the use of the

individual to whom it is addressed. It may contain privileged or

confidential information and should not be circulated or used for

any purpose other than for what it is intended. If you have received

this message in error, please notify the originator immediately.

If you are not the intended recipient, you are notified that you are

strictly prohibited from using, copying, altering, or disclosing

the contents of this message. FSS accepts no responsibility for

loss or damage arising from the use of the information transmitted

by this email including damage from virus."

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Thu, 6 Jul 2006 20:06:21 +0530

Hi

another update [BVS##]

regards

B Venkat S.R Swamy

Senior Technical Leader

Phone: +91-124- 4176213

Fax: +91-124-4300247

B Venkat S.R Swamy/HSS@HSS

B Venkat S.R Swamy/HSS@HSS

07/06/2006 07:56 PM

To

cc

[email-masked]

Subject

Re: [Megaco] Question on default 'Topology' of a Context

Hi Bill

regards

B Venkat S.R Swamy

Senior Technical Leader

Phone: +91-124- 4176213

Fax: +91-124-4300247

07/06/2006 04:52 PM

To

<[email-masked]>

cc

Subject

2) C=1 {Add=TDM2 {...

[BVS]>> IMO, the first tuple (*,*,isolate) applies to TDM1 and TDM2 only, the isolate does not apply for the newly added termination(Eph1),

[/BVS]

[BVS##] the topology for Eph1 and TDM2 will be default which is bothway.

4) C=1 {Add=TDM3 { ...

[/BVS]

[/BVS]

Thanks, Bill

Megaco mailing list

[email-masked]

by this email including damage from virus."_______________________________________________

Megaco mailing list

[email-masked]

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 6 Jul 2006 11:21:40 -0400

Comments inline. [KJBII]
 
Kevin

________________________________

From: B Venkat S.R Swamy [mailto:[email-masked]] 
Sent: Thursday, July 06, 2006 10:26 AM
To: Bill Huang
Cc: [email-masked]
Subject: Re: [Megaco] Question on default 'Topology' of a Context

Hi Bill

regards
B Venkat S.R Swamy 
Senior Technical Leader

				07/06/2006 04:52 PM

To

<[email-masked]>	

cc

Subject

Could some expert out there clarify the behavior of 'default Topology'
of a Context.

[BVS]>> IMO, the first tuple (*,*,isolate) applies to TDM1 and TDM2
only. the isolate does not apply for the newly added termination(Eph1),
the second tuple ($,TDM1,oneway) applies only for (Eph1, TDM1,oneway).
[/BVS]
[KJBII] This is not correct.  Because the command appears in the same
action as the Topology Descriptor, the descriptor applies to the new
termination as well.  Eph1 will be isolated from the rest of the
terminations, and then will be connected one-way to TDM1. You cannot
selectively apply parts of the Topology Descriptor -- it must be applied
in its entirety.

4) C=1 {Add=TDM3 { ...

[BVS]>> No, the last topology is not valid for new transaction/action.
If there is no topology descriptor in the new transaction/action,
default topology(bothway) gets applicable for newly
added termination wrt other terminations in the context. Thus for TDM3
(TDM3,*,bothway; where * applies to TDM1, TDM2 and Eph1) topology is
implicitly applied.
[/BVS]
[KJBII] Correct. 

Q: If not, what's the topology of the Context?
[BVS]>> as mentioned above
[/BVS] 
[KJBII] The Topology would be (TDM1, TDM2, IS), (Eph1, TDM1, OW), (Eph1,
TDM2, IS), (TDM3, *, BW).

Thanks, Bill

---

From: "Bill Huang" <[email-masked]>
Date: Thu, 6 Jul 2006 17:34:17 +0200

Thanks for all the replies to this posting, the behavior is clear to me now.
Bill

  _____  

From: Kevin Boyle [mailto:[email-masked]] 
Sent: Thursday, July 06, 2006 5:22 PM
To: B Venkat S.R Swamy; Bill Huang
Cc: [email-masked]
Subject: RE: [Megaco] Question on default 'Topology' of a Context

Comments inline. [KJBII]
 
Kevin

  _____  

Hi Bill

regards
B Venkat S.R Swamy 
Senior Technical Leader
Flextronics Software Systems
Phone: +91-124- 4176213
Fax: +91-124-4300247
web: www.flextronicssoftware.com
Inactive hide details for "Bill Huang" <[email-masked]>"Bill Huang"
<[email-masked]>

	07/06/2006 04:52 PM

To

<[email-masked]>	

cc

Subject

[BVS]>> IMO, the first tuple (*,*,isolate) applies to TDM1 and TDM2 only.
the isolate does not apply for the newly added termination(Eph1),
the second tuple ($,TDM1,oneway) applies only for (Eph1, TDM1,oneway).
[/BVS]
[KJBII] This is not correct.  Because the command appears in the same action
as the Topology Descriptor, the descriptor applies to the new termination as
well.  Eph1 will be isolated from the rest of the terminations, and then
will be connected one-way to TDM1. You cannot selectively apply parts of the
Topology Descriptor -- it must be applied in its entirety.

4) C=1 {Add=TDM3 { ...
Q: Since no topology was specified, does it mean the last default topology
(*,*,isolate) for the Context applies to this 'Add' command?

[BVS]>> No, the last topology is not valid for new transaction/action. If
there is no topology descriptor in the new transaction/action, default
topology(bothway) gets applicable for newly
added termination wrt other terminations in the context. Thus for TDM3
(TDM3,*,bothway; where * applies to TDM1, TDM2 and Eph1) topology is
implicitly applied.
[/BVS]
[KJBII] Correct. 

Thanks, Bill

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Fri, 7 Jul 2006 10:12:06 +0530

Hi

comments inline [BVS#]

regards

B Venkat S.R Swamy

Senior Technical Leader

Phone: +91-124- 4176213

Fax: +91-124-4300247

"Kevin Boyle" <[email-masked]>

"Kevin Boyle" <[email-masked]>

07/06/2006 08:51 PM

To

B Venkat S.R Swamy/HSS@HSS, "Bill Huang" <[email-masked]>

cc

[email-masked]

Subject

RE: [Megaco] Question on default 'Topology' of a Context

Comments inline. [KJBII]

Kevin

To: Bill Huang

Cc: [email-masked]

Hi Bill

regards

B Venkat S.R Swamy

Senior Technical Leader

Phone: +91-124- 4176213

Fax: +91-124-4300247

07/06/2006 04:52 PM

To

<[email-masked]>

cc

Subject

of a Context.

stated in H.248.1 v1

2) C=1 {Add=TDM2 {...

returns Eph1

[/BVS]

in its entirety.

[BVS#] my comments was based on the fact that, action level properties should be applied

first before moving to any command processing as far as possible. Here for the first

tuple (*,*,isolate), the "*" gets resolved to the already existing terminations and

there is no dependancy on the commands presents in the actions. Therefore (*,*,isolate)

applies only to TDM1 and TDM2.

Now for the next tuple, the "$" has to be resolved first

before the topology can be applied, hence first the ADD command gets executed(or atleast $ resolved)

and then the topology get applied for the ($,TDM1,oneway).

Had the topology descriptor looked like($,TDM1,oneway,*,*,isolate)

then Eph1 would be included in the (*,*,isolate)also.

If however the above statements are not valid, then H248.1 topology section needs to be updated

to clarify above scenarios.

[/BVS#]

4) C=1 {Add=TDM3 { ...

implicitly applied.

[/BVS]

[KJBII] Correct.

[/BVS]

Thanks, Bill

Megaco mailing list

[email-masked]

Megaco mailing list

[email-masked]

---

From: "Bill Huang" <[email-masked]>
Date: Fri, 7 Jul 2006 07:39:14 +0200

Please see my question inline [BH#1]

  _____  

From: B Venkat S.R Swamy [mailto:[email-masked]] 
Sent: Friday, July 07, 2006 6:42 AM
To: Kevin Boyle
Cc: Bill Huang; [email-masked]
Subject: RE: [Megaco] Question on default 'Topology' of a Context

Hi 
comments inline [BVS#]

regards
B Venkat S.R Swamy 
Senior Technical Leader
Flextronics Software Systems
Phone: +91-124- 4176213
Fax: +91-124-4300247
web: www.flextronicssoftware.com
Inactive hide details for "Kevin Boyle" <[email-masked]>"Kevin Boyle"
<[email-masked]>

	07/06/2006 08:51 PM

To

cc

[email-masked]	

Subject

Comments inline. [KJBII]

Kevin

Hi Bill

regards
B Venkat S.R Swamy 
Senior Technical Leader

07/06/2006 04:52 PM

To

<[email-masked]> 

cc

Subject

[BVS#] my comments was based on the fact that, action level properties
should be applied 
first before moving to any command processing as far as possible. Here for
the first 
tuple (*,*,isolate), the "*" gets resolved to the already existing
terminations and 
there is no dependancy on the commands presents in the actions. Therefore
(*,*,isolate) 
applies only to TDM1 and TDM2.

Now for the next tuple, the "$" has to be resolved first 
before the topology can be applied, hence first the ADD command gets
executed(or atleast $ resolved)
and then the topology get applied for the ($,TDM1,oneway).

[BH#1] So to achieve the desired topology, do you mean I need to specify as
follows?  (*,*,IS), ($,*,IS), ($,TDM1,OW)?

 If however the above statements are not valid, then H248.1 topology section
needs to be updated
to clarify above scenarios. 
[/BVS#]

4) C=1 {Add=TDM3 { ...

Thanks, Bill

Megaco mailing list
[email-masked]

---

From: Christian Groves <[email-masked]>
Date: Fri, 07 Jul 2006 18:05:10 +1000

Hello,

I would support Kevin's view. The new termination is added according to 
the whole topology descriptor. H.248.1 is explicit:
/The CHOOSE wildcard in a Topology Descriptor matches the TerminationID 
that the MG assigns in the first Add Command that uses a CHOOSE wildcard 
in the same action. An existing termination that matches T1 or T2 in the 
context to which a termination is added is connected to the newly added 
termination as specified by the Topology Descriptor. If a termination is 
not mentioned within a Topology Descriptor, any topology associated with 
it remains unchanged. If, however, a new termination is added into a 
context, its association with the other terminations within the context 
defaults to bothway, unless a Topology Descriptor is given to change 
this (eg. if T3 is added to a context with T1 and T2 with topology (T3, 
T1, oneway) it will be connected bothway to T2).
/
The topology descriptor in the case given is the entire topology not 
just the $,TDM1,oneway part. The first part clearly demonstrates there 
is a relationship between the action and the first subsequent command.

Regards, Christian

Bill Huang wrote:

> ------------------------------------------------------------------------
> *From:* B Venkat S.R Swamy [mailto:[email-masked]]
> *Sent:* Friday, July 07, 2006 6:42 AM
> *To:* Kevin Boyle
> *Cc:* Bill Huang; [email-masked]
> *Subject:* RE: [Megaco] Question on default 'Topology' of a Context
>
> Hi
> comments inline [BVS#]
>
>
> regards
> B Venkat S.R Swamy
> Senior Technical Leader
> Inactive hide details for "Kevin Boyle" <[email-masked]>"Kevin 
> Boyle" <[email-masked]>
>
>
>                         *"Kevin Boyle" <[email-masked]>*
>
>                         07/06/2006 08:51 PM
>
> 	
>
> To
> 	
> [BH#1] So to achieve the desired topology, do you mean I need to 
> specify as follows?  (*,*,IS), ($,*,IS), ($,TDM1,OW)?
>  
>
>------------------------------------------------------------------------
>

---

From: Sudhanshu Garg <[email-masked]>
Date: Fri, 7 Jul 2006 13:46:37 +0530

Hi Cristian,

Please clarify if there is any specific requirement for having 
indAudcontextAttrDescriptor ("ContextAttrToken").
It is not clear from the protocol document.

As per syntax, the context audit allows the audit of new items also ie. 
IEPS, package defined context properties and it also allows the 
contextAuditSelector.

In my humble opinion, all the context level properties can be audited 
without "contextAuditProperties" also, so it is superfluous in the grammar 
(ABNF syntax).

> In ABNF syntax, the usage of indAudcontextAttrDescriptor in 
> contextAudit is not very clear as the individual audit also maps on to 
> contextAuditProperties only.
> Snip from ABNF syntax is also attached.
>     contextAudit                = ContextAuditToken LBRKT 
> (contextAuditProperties
>                           *(COMMA contextAuditProperties)) /
>                             indAudcontextAttrDescriptor         RBRKT
>
>     indAudcontextAttrDescriptor
>                                 = ContextAttrToken LBRKT 
> contextAuditProperties
>                                         *(COMMA 
> contextAuditProperties) RBRKT
>
[CNG] Context Audit allows the audit of Context attributes that are hard 
coded into the protocol. e.g. pre-v3. indAudcontextAttrDescriptor allows 
audit of package defined context properties.

Regards,
Sudhanshu.
Technical Leader
Flextronics Software Systems
Phone:  +91-124-4176301 extn 5109
Fax: +91-124-4300247
web: www.flextronicssoftware.com

***********************  FSS-Private   ***********************

---

From: <[email-masked]>
Date: Fri, 7 Jul 2006 14:28:06 +0300

Hi Christian,

This answer confuses me at little. In January 2003 I asked the list for
a similar case:
"Subject: Re: [Megaco] ALL in Topology descriptor and CHOOSE in command"

> 
> Let's assume we have 2 terminations T1 and T2 which are oneway
connected.
> Now we add a new termination T3 with the following topology settings.
> 
> Topology (T1,ALL,isolate)
>   ADD $
> 
> Which of the following results is correct?
> 
> a.) T1 is isolated from T2 and
>     T1 is isolated from T3 and
>     T2 is bothway connected to T3
> b.) T1 is isolated from T2 and
>     T1 is bothway connected to T3 and
>     T2 is bothway connected to T3
Christian's answer was 
"In accordance to 7.1.18 "The Topology descriptor occurs before the
commands in an action." it would be b)."

Is there a difference in the handling to the case Bill mentions below?
Precondition: T1 and T2 bothway connected

Topology {(ALL, ALL, isolate)(CHOOSE, T1, oneway)}
ADD $ 

a.) T1 is isolated from T2 and 
    T3 is oneway connected to T1 and
    T2 is isolated from T3
b.) T1 is isolated from T2 and
    T3 is oneway connected to T1 and
    T2 is bothway connected to T3
I think Kevin says that alternative a.) is correct. 
Based on Christian's answer to the 2003 case, I would have voted for
alternative b.)
Could you please clarify which are now the correct answers for the 2
cases?

br manfred

>-----Original Message-----
>From: ext Christian Groves [mailto:[email-masked]] 
>Sent: 07 July, 2006 11:05
>To: Bill Huang
>Cc: [email-masked]
>I would support Kevin's view. The new termination is added 
>according to the whole topology descriptor. H.248.1 is explicit:
>/The CHOOSE wildcard in a Topology Descriptor matches the 
>TerminationID that the MG assigns in the first Add Command 
>that uses a CHOOSE wildcard in the same action. An existing 
>termination that matches T1 or T2 in the context to which a 
>termination is added is connected to the newly added 
>termination as specified by the Topology Descriptor. If a 
>termination is not mentioned within a Topology Descriptor, any 
>topology associated with it remains unchanged. If, however, a 
>new termination is added into a context, its association with 
>the other terminations within the context defaults to bothway, 
>unless a Topology Descriptor is given to change this (eg. if 
>T3 is added to a context with T1 and T2 with topology (T3, T1, 
>oneway) it will be connected bothway to T2).
>/
>The topology descriptor in the case given is the entire 
>topology not just the $,TDM1,oneway part. The first part 
>clearly demonstrates there is a relationship between the 
>action and the first subsequent command.
>
>Regards, Christian
>
>Bill Huang wrote:
>
>> only. the isolate does not apply for the newly added 
>> termination(Eph1), the second tuple ($,TDM1,oneway) applies 
>only for (Eph1, TDM1,oneway).
>> [/BVS]
>> selectively apply parts of the Topology Descriptor -- it must be 
>> applied in its entirety.
>>
>> should be applied first before moving to any command 
>processing as far 
>> as possible. Here for the first tuple (*,*,isolate), the "*" gets 
>> resolved to the already existing terminations and there is no 
>> dependancy on the commands presents in the actions.
>> Therefore (*,*,isolate)
>> Now for the next tuple, the "$" has to be resolved first before the 
>> topology can be applied, hence first the ADD command gets 
>executed(or 
>> atleast $ resolved) and then the topology get applied for the 
>> ($,TDM1,oneway).
>>
>>  If however the above statements are not valid, then H248.1 topology 
>> section needs to be updated to clarify above scenarios.
>> [/BVS#]
>>   
>>
>> 4) C=1 {Add=TDM3 { ...

Subject: Re: [Megaco] ALL in Topology descriptor and CHOOSE in command
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>, <[email-masked]>
Date: Thu, 30 Jan 2003 04:11:21 +0300

Hello,

I stand by what I stated you need it inspect the topology descriptor first. 
ie.
"The Topology descriptor occurs before the commands in an action."

To complete the topology descriptor you may need to look ahead in subsequent
commands in the case their is a "?" to get the relevant TID or the topology
triple contains a TID that is introduced to the context by an additional ADD
command. So you need to be sure at least that the TID is available. To
successfully execute the topology descriptor.

The commands themselves are then executed. If they fail then a TID will be
returned with the error message and the MGC can then fix the set topology if
need be. 

Regards, Christian

[email-masked] wrote:
> 
> Hi Chris,
> 
> In earlier mails it was stated that
> 
> Section 7.1.18 means that you must consider the topology descriptor before
> addressing the
> commands. You should then use the information that is in the topology descriptor
> when you process the commands in the message.
> 
> Now with this implementation the final result should be
> T1 is isolated from T2 and
> T1 is isolated from T3 and
> T2 is bothway connected to T3
> 
> Correct me if I have some wrong interpretation
> 
> Thanks and regards
> Shobhit
> 
> Christian Groves <[email-masked]> on 01/22/2003 05:36:36 AM
> 
> To:   [email-masked]
> cc:   [email-masked] (bcc: Shobhit Bansal/HSS)
> 
> Subject:  Re: [Megaco] ALL in Topology descriptor and CHOOSE in command
> 
> Hello Manfred,
> 
> In accordance to 7.1.18 "The Topology descriptor occurs before the commands in
> an action." it would be b).
> 
> Christian
> 
> [email-masked] wrote:
> >
> > Hi all,
> >
> > Let's assume we have 2 terminations T1 and T2 which are oneway connected.
> > Now we add a new termination T3 with the following topology settings.
> >
> > Topology (T1,ALL,isolate)
> >   ADD $
> >
> > Which of the following results is correct?
> >
> > a.) T1 is isolated from T2 and
> >     T1 is isolated from T3 and
> >     T2 is bothway connected to T3
> > b.) T1 is isolated from T2 and
> >     T1 is bothway connected to T3 and
> >     T2 is bothway connected to T3
> >
> > Thanks for your help.
> >
> > best regards Manfred
> >

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 7 Jul 2006 10:07:13 -0400

Well, it matters whether or not the TP Descriptor appears in the same
action as the Add command.  While the TP Descriptor does get "applied
first", it also applies to all new terminations that are added in that
same action.  The MG needs to "remember" the TP descriptor as it
processes the rest of the action, and ensure that the terminations are
added with the topology applied at the time of entry into the context,
rather than adding the termination first then applying the topology.
There is a subtle, but important difference between these two
operations.

If the TP Descriptor is in a different action, then the TP applies to
only those terminations in the context at the time of the completion of
the action.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, July 07, 2006 7:28 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Question on default 'Topology' of a Context

Hi Christian,

connected.
Christian's answer was

Topology {(ALL, ALL, isolate)(CHOOSE, T1, oneway)} ADD $ 

alternative b.) Could you please clarify which are now the correct
answers for the 2 cases?

br manfred

>that the MG assigns in the first Add Command that uses a CHOOSE 
>wildcard in the same action. An existing termination that matches T1 or

>T2 in the context to which a termination is added is connected to the 
>newly added termination as specified by the Topology Descriptor. If a 
>termination is not mentioned within a Topology Descriptor, any topology

>associated with it remains unchanged. If, however, a new termination is

>added into a context, its association with the other terminations 
>within the context defaults to bothway, unless a Topology Descriptor is

>given to change this (eg. if
>> default topology(bothway) gets applicable for newly added termination

>> wrt other terminations in the context.
>Thus for TDM3
>> confidential information and should not be circulated or used for any

>> purpose other than for what it is intended. If you have received this

>> message in error, please notify the originator immediately.
>> strictly prohibited from using, copying, altering, or disclosing the 
>> contents of this message. FSS accepts no responsibility for loss or 
>> damage arising from the use of the information transmitted by this 
>> email including damage from virus."
>>
>>
>> Megaco mailing list
>> [email-masked]
>> confidential information and should not be circulated or used for any

>> purpose other than for what it is intended. If you have received this

>> message in error, please notify the originator immediately.
>> strictly prohibited from using, copying, altering, or disclosing the 
>> contents of this message. FSS accepts no responsibility for loss or 
>> damage arising from the use of the information transmitted by this 
>> email including damage from virus."
>>

---

From: Christian Groves <[email-masked]>
Date: Mon, 10 Jul 2006 13:43:46 +1000

Hello Manfred,

I still stand by my answer. In your case b) and the 2nd (a). The 
difference is the use of "CHOOSE, $" in the topology descriptor. It 
links the descriptor to the subsequent command.

Regards,  Christian

[email-masked] wrote:

>>----------------------------------------------------------------------
>>    
>>
>>>--
>>>Could some expert out there clarify the behavior of 'default 
>>>      
>>>
>>Topology'
>>    
>>
>>>of a Context.
>>>3) C=1 {Topology{*,*,isolate, $,TDM1,oneway}, Add=$ { ... => 
>>>      
>>>
>>assume MG 
>>    
>>
>>>returns Eph1
>>>[KJBII] This is not correct.  Because the command appears in 
>>>      
>>>
>>the same 
>>    
>>
>>>[BVS#] my comments was based on the fact that, action level 
>>>      
>>>
>>properties 
>>    
>>
>>>[BVS]>> No, the last topology is not valid for new 
>>>      
>>>
>>transaction/action.
>>    
>>
>>>added termination wrt other terminations in the context. 
>>>      
>>>
>>Thus for TDM3
>>    
>>
>>>[KJBII] The Topology would be (TDM1, TDM2, IS), (Eph1, TDM1, 
>>>      
>>>
>>OW), (Eph1,
>>    
>>
>>>--------------------------------------------------------------
>>>      
>>>
>>----------
>>    
>>
>> Subject:
>> Re: [Megaco] ALL in Topology descriptor and CHOOSE in command
>> From:
>> CC:
>> <[email-masked]>, <[email-masked]>
>>
>>
>>Hello,
>>

---

From: Christian Groves <[email-masked]>
Date: Mon, 10 Jul 2006 13:58:41 +1000

Hello Sudhanshu,

Yes there it seems that some part of the Context Auditing is superflous. 
As per my last response details the intention behind the changes. It 
seems that when is was added it to the ABNF there was some redundancy in 
the code.

Regards, Christian

Sudhanshu Garg wrote:

> As per syntax, the context audit allows the audit of new items also 
> ie. IEPS, package defined context properties and it also allows the 
> contextAuditSelector.
>
> without "contextAuditProperties" also, so it is superfluous in the 
> grammar (ABNF syntax).
>