Subject: [Megaco] Error format

From: "Wainwright, John \(Com US\)" <[email-masked]>
Date: Wed, 26 Jul 2006 06:55:52 -0700

Is the following format 'valid' for a response to an ADD request
containing an unsupported codec in the Local descriptor?  Would the same
format apply, apart from the error code and text, for any other type of
error in the SDP data within the Local descriptor ?
 
MEGACO/2 [20.0.4.32]:2084
REPLY = 269820167 {
  CONTEXT = 13 {
    ADD = port_1
  ,
    ADD = eph/00337 { 
          ERROR = 515 {"Unsupported Media Type"} 
    }
  }
} 
 
Thanks
John

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Ashish Singh <[email-masked]>
Date: Wed, 26 Jul 2006 09:36:07 -0700

Hi John,

The response is correct from syntax point of view. But H.248.8 mentions 
to include "stream ID" as Error text for this particular error code.

There are many other error codes, for which extra information is 
required. Like with error codes 433 and 435, contextID is returned, so 
that MGC can synchronize its database.

Thanks
Ashish

Wainwright, John (Com US) wrote:
> containing an unsupported codec in the Local descriptor?  Would the 
> same format apply, apart from the error code and text, for any other 
> type of error in the SDP data within the Local descriptor ?
>  
> ------------------------------------------------------------------------
>