Subject: [Megaco] Max terms in context

From: "Wainwright, John \(Com US\)" <[email-masked]>
Date: Thu, 13 Jul 2006 14:50:22 -0700

How should an MG respond to an ADD request to create an EPH termination
and to put it in a specific context if the maximum number of
terminations in the context has already been reached.  E.g in a request
to ADD 2 eph terms to a context via the choose wildcard in the response
below eph/2 was created and was able to be added to the context but the
next eph was not created and could not be added due to the limit being
reached

Does this response look correct in particular the use of "-" for the
failed eph ADD even though the original request used "$"

MEGACO/2 [10.0.4.38]:2084
REPLY = 10023 {
  CONTEXT = 2 {
    ADD = eph/2
  ,
    ADD = - {
      ERROR = 434 { "Max number of Terminations in a Context exceeded" }
    }
  }
}

Thanks
John

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Fri, 14 Jul 2006 09:02:59 +0530

Hi

IMO, the use of "-" does not look appropriate and instead "$" can be returned. Protocol is however silent on this.

regards

B Venkat S.R Swamy

Senior Technical Leader

Flextronics Software Systems

Phone: +91-124- 4176213

Fax: +91-124-4300247

web: www.flextronicssoftware.com

"Wainwright, John \(Com US\)" <[email-masked]>

reached

REPLY = 10023 {

CONTEXT = 2 {

ADD = eph/2

,

ADD = - {

}

}

}

Thanks

John

*********************** FSS-Restricted ***********************

"DISCLAIMER: This message is proprietary to Flextronics Software

Systems Limited (FSS) and is intended solely for the use of the

individual to whom it is addressed. It may contain privileged or

confidential information and should not be circulated or used for

any purpose other than for what it is intended. If you have received

this message in error, please notify the originator immediately.

If you are not the intended recipient, you are notified that you are

strictly prohibited from using, copying, altering, or disclosing

the contents of this message. FSS accepts no responsibility for

loss or damage arising from the use of the information transmitted

by this email including damage from virus."

---

From: "Jon Rowland" <[email-masked]>
Date: Fri, 14 Jul 2006 11:01:03 +0100

Hi folks,
 
I disagree. The protocol is not silent on this: section 8.2.2 (H.248.1
v2 01/2004) has the following text:
 
8.2.2 TransactionReply
...
The ContextID paramater must specify a value to pertain to all Responses
for the action. The ContextID may be all, specific, or null.
 
Hence CHOOSE ($) is not permitted on a failed ADD response, and NULL (-)
should be used instead. The response should reflect the current context
the termination is in.
 
All that said, I believe I've seen implementations that return $ and it
would be a pedantic MGC parser that objected to such on the response.
 
Cheers,
Jon.

________________________________

From: B Venkat S.R Swamy [mailto:[email-masked]] 
Sent: 14 July 2006 04:33
To: Siemens - John Wainwright
Cc: [email-masked]
Subject: Re: [Megaco] Max terms in context

Hi

IMO, the use of "-" does not look appropriate and instead "$" can be
returned. Protocol is however silent on this.

regards
B Venkat S.R Swamy 
Senior Technical Leader

Thanks
John

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Fri, 14 Jul 2006 15:56:27 +0530

Hi Jon

The query was for the termination-id in the second Add command and not for the context Id.

The Context-id in the example below was anyway 2.

regards

B Venkat S.R Swamy

Senior Technical Leader

Phone: +91-124- 4176213

Fax: +91-124-4300247

"Jon Rowland" <[email-masked]>

"Jon Rowland" <[email-masked]>

07/14/2006 03:31 PM

To

B Venkat S.R Swamy/HSS@HSS, "Siemens - John Wainwright" <[email-masked]>

cc

<[email-masked]>

Subject

RE: [Megaco] Max terms in context

Hi folks,

I disagree. The protocol is not silent on this: section 8.2.2 (H.248.1 v2 01/2004) has the following text:

8.2.2 TransactionReply

...

The ContextID paramater must specify a value to pertain to all Responses for the action. The ContextID may be all, specific, or null.

Hence CHOOSE ($) is not permitted on a failed ADD response, and NULL (-) should be used instead. The response should reflect the current context the termination is in.

All that said, I believe I've seen implementations that return $ and it would be a pedantic MGC parser that objected to such on the response.

Cheers,

Jon.

Sent: 14 July 2006 04:33

Cc: [email-masked]

Hi

regards

B Venkat S.R Swamy

Senior Technical Leader

Phone: +91-124- 4176213

Fax: +91-124-4300247

reached

REPLY = 10023 {

CONTEXT = 2 {

ADD = eph/2

,

ADD = - {

}

}

}

Thanks

John

---

From: "Jon Rowland" <[email-masked]>
Date: Fri, 14 Jul 2006 12:10:43 +0100

Apologies - I had misread the original question!

From: B Venkat S.R Swamy [mailto:[email-masked]] 
Sent: 14 July 2006 11:26
To: Jon Rowland
Cc: Siemens - John Wainwright; [email-masked]
Subject: RE: [Megaco] Max terms in context

Hi Jon

The query was for the termination-id in the second Add command and not
for the context Id.
The Context-id in the example below was anyway 2.

regards
B Venkat S.R Swamy 
Senior Technical Leader

				"Jon Rowland"
<[email-masked]> 

				07/14/2006 03:31 PM

To

B Venkat S.R Swamy/HSS@HSS, "Siemens - John Wainwright"
<[email-masked]>	

cc

<[email-masked]>	

Subject

Hi folks,

8.2.2 TransactionReply
...

Cheers,
Jon.

Hi

regards
B Venkat S.R Swamy 
Senior Technical Leader

Thanks
John

---

From: Christian Groves <[email-masked]>
Date: Mon, 17 Jul 2006 11:46:38 +1000

I would agree the $ (CHOOSE) would be returned when a TerminationID 
could not be chosen. This is in line with other examples showing the 
wildcard * (ALL) being returned.
It probably is worth mentioning in the H.248.1v3 text.

Regards, Christian

Jon Rowland wrote:

> ------------------------------------------------------------------------
> *From:* B Venkat S.R Swamy [mailto:[email-masked]]
> *Sent:* 14 July 2006 11:26
> *To:* Jon Rowland
> *Cc:* Siemens - John Wainwright; [email-masked]
> *Subject:* RE: [Megaco] Max terms in context
>
>
> Hi Jon
>
> Inactive hide details for "Jon Rowland" 
> <[email-masked]>"Jon Rowland" <[email-masked]>
>
>
>                         *"Jon Rowland" <[email-masked]>*
>
>                         07/14/2006 03:31 PM
>
> 	
>
> To
> 	
> The ContextID paramater must specify a value to pertain to all 
> Responses for the action. *The ContextID may be all, specific, or null*.
>
> Hence CHOOSE ($) is not permitted on a failed ADD response, and NULL 
> (-) should be used instead. The response should reflect the current 
> context the termination is in.
>
> All that said, I believe I've seen implementations that return $ and 
> it would be a pedantic MGC parser that objected to such on the response.
>
> Cheers,
> Jon.
>
> ------------------------------------------------------------------------
> *From:* B Venkat S.R Swamy [mailto:[email-masked]] *
> Sent:* 14 July 2006 04:33*
> To:* Siemens - John Wainwright*
> Cc:* [email-masked]*
> Subject:* Re: [Megaco] Max terms in context
>
>
> Hi
>
> Inactive hide details for "Wainwright, John \(Com US\)" 
> <[email-masked]>"Wainwright, John \(Com US\)" 
>------------------------------------------------------------------------
>