Subject: [Megaco] Reporting dialed string cd/ds

From: Richard Sun <[email-masked]>
Date: Wed, 05 Jul 2006 01:07:42 -0400

7.1.14.5	DigitMap procedures
2) In either case, if the digit map completion event allows for detailed 
timeout reporting, the reported dial string will end with 'L', 'S', or 
'T' as appropriate.

So 'L' 'S' 'T' may be included as part of
the dialed string when a timer expired.

However, in the definition of "ds" here:
	ParameterID: ds (0x0001)
	Type: string of digit map symbols (possibly empty) returned as a 
quotedString
	Possible values: a sequence of the characters "0" through "9", "A" 
through "F", and the long duration modifier "Z".

Possible values do not include 'L' 'S' 'T'?

Is this already clearified somewhere?

Thanks,
-Richard

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Wed, 5 Jul 2006 19:05:26 +0530

Hi Richard

The detailed timeout reporting for completion events are defined in the H.248.16 ("Extended DTMF detection package" and "Enhanced DTMF detection package")

captures that the T,S and L can be appended at the end of dial strings in case of timeouts.

regards

B Venkat S.R Swamy

Senior Technical Leader

Flextronics Software Systems

Phone: +91-124- 4176213

Fax: +91-124-4300247

web: www.flextronicssoftware.com

Richard Sun <[email-masked]>

Richard Sun <[email-masked]>

07/05/2006 10:37 AM

To

[email-masked]

cc

Subject

[Megaco] Reporting dialed string cd/ds

'T' as appropriate.

ParameterID: ds (0x0001)

quotedString

Thanks,

-Richard

Megaco mailing list

[email-masked]

*********************** FSS-Restricted ***********************

"DISCLAIMER: This message is proprietary to Flextronics Software

Systems Limited (FSS) and is intended solely for the use of the

individual to whom it is addressed. It may contain privileged or

confidential information and should not be circulated or used for

any purpose other than for what it is intended. If you have received

this message in error, please notify the originator immediately.

If you are not the intended recipient, you are notified that you are

strictly prohibited from using, copying, altering, or disclosing

the contents of this message. FSS accepts no responsibility for

loss or damage arising from the use of the information transmitted

by this email including damage from virus."