Subject: Re: [MEGACO] Re-registration of MG with MGC

From: "Stephen Mell" <[email-masked]>
Date: Fri, 14 Jul 2006 17:58:09 +0100

Hello List,

The procedures detialed in F.3.8 and F.3.9 both need to be carried out 
under the auspices of an existing Control association. 

How then can the rebooted MGC (which is ignorant of the Parameters of the 
existing Control Association, in partcular the negotiated protocol 
version), issue a Service change with the correct Version number in the 
message header?

The same problem exists for transparent (layer 3) MGC failover.

This issue has been discussed before, but I don't remember it reaching a 
satisfactory conclusion.

Steve 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Sat, 15 Jul 2006 07:30:57 +0200

Stephen,

assumption behind F.3.8 and F.3.9 is an MGC "In-Service" (i.e. "no rebooted
MGC") in my understanding.

>The same problem exists for transparent (layer 3) MGC failover.

There are failover scenarios and their relation to the H.248 Control
Association defined by H.248, but not "transparent (L3) ..." failover
scenarios IMHO.
The H.248 Control Association is a logically decoupled from underlying L4
or L3 connections.
See also: H-series Supplement 7 (MGC-MG Control Association) =>
TD-224r1/WP2 (04/2006)

- Albrecht

                      "Stephen Mell"                                                                                              
                      <Stephen.Mell@ma         To:      "pankaj.kumar" <[email-masked];Albrecht.Schwarz;;;>                
                      rconi.com>               cc:      [email-masked]                                                           
                                               Subject: Re: [MEGACO] Re-registration of MG with MGC                               
                      14.07.2006 18:58                                                                                            

Hello List,

Steve _______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Mon, 17 Jul 2006 09:34:20 +0530

Hi Stephen

I think you are right, the F.3.8 and F.3.9 applies only for existing and known control association.

The same issue was raised earlier also in the list. When MGC goes down, normally MG would

initiate Disconnected procedures(for TCP on link going down, for UDP on retransmission timeout

of any request message). Restarted MGC on receiving the ServiceChange with Disconnected,

can accept the message and get to know of the negotiated version. Then either it can continue

association or send ServiceChange as per F.3.8/F.3.9

However accepting the ServiceChange with Disconnected(containing a negotiated version in the message

header) is something which is MGC's choice(since MGC does not have any context and expects Service change

with message header as version 1 only) and is not clearly highlighted in the protocol.

Therefore there is definate need to put some text in the Annex F of V3 to clarify these scenarios.

regards

B Venkat S.R Swamy

Senior Technical Leader

Flextronics Software Systems

Phone: +91-124- 4176213

Fax: +91-124-4300247

web: www.flextronicssoftware.com

"Stephen Mell" <[email-masked]>

"Stephen Mell" <[email-masked]>

07/14/2006 10:28 PM

To

"pankaj.kumar" <[email-masked];Albrecht.Schwarz;;;;>

cc

[email-masked]

Subject

Re: [MEGACO] Re-registration of MG with MGC

Hello List,

The procedures detialed in F.3.8 and F.3.9 both need to be carried out under the auspices of an existing Control association.

How then can the rebooted MGC (which is ignorant of the Parameters of the existing Control Association, in partcular the negotiated protocol version), issue a Service change with the correct Version number in the message header?

This issue has been discussed before, but I don't remember it reaching a satisfactory conclusion.

Megaco mailing list

[email-masked]

*********************** FSS-Restricted ***********************

"DISCLAIMER: This message is proprietary to Flextronics Software

Systems Limited (FSS) and is intended solely for the use of the

individual to whom it is addressed. It may contain privileged or

confidential information and should not be circulated or used for

any purpose other than for what it is intended. If you have received

this message in error, please notify the originator immediately.

If you are not the intended recipient, you are notified that you are

strictly prohibited from using, copying, altering, or disclosing

the contents of this message. FSS accepts no responsibility for

loss or damage arising from the use of the information transmitted

by this email including damage from virus."

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 17 Jul 2006 13:04:36 -0400

The rebooted MGC would not have a control association, and therefore
would require the MG to send a ServiceChange command to establish one.
This shouldn't be hard to detect for the MG, as the MGC would stop
replying to commands from the MG until a new registration message
(either a Restart or a Disconnected) arrived.
 
Kevin

________________________________

From: Stephen Mell [mailto:[email-masked]] 
Sent: Friday, July 14, 2006 12:58 PM
To: pankaj.kumar
Cc: [email-masked]
Subject: Re: [MEGACO] Re-registration of MG with MGC

Hello List, 

How then can the rebooted MGC (which is ignorant of the Parameters of
the existing Control Association, in partcular the negotiated protocol
version), issue a Service change with the correct Version number in the
message header? 

Steve