Subject: RE: [Megaco] Error format

From: "Wainwright, John \(Com US\)" <[email-masked]>
Date: Wed, 26 Jul 2006 11:44:47 -0700

So would a more accurate response have something like the following
	ERROR = 515 {"Unsupported Media Type.  Stream = xxx"

If "Stream = 1" can it be omitted and assumed by default ?

Thanks
John

-----Original Message-----
From: Ashish Singh [mailto:[email-masked]] 
Sent: Wednesday, July 26, 2006 11:36 AM
To: Wainwright, John (Com US)
Cc: [email-masked]
Subject: Re: [Megaco] Error format

Hi John,

The response is correct from syntax point of view. But H.248.8 mentions 
to include "stream ID" as Error text for this particular error code.

There are many other error codes, for which extra information is 
required. Like with error codes 433 and 435, contextID is returned, so 
that MGC can synchronize its database.

Thanks
Ashish

Wainwright, John (Com US) wrote:
> Is the following format 'valid' for a response to an ADD request 
> containing an unsupported codec in the Local descriptor?  Would the 
> same format apply, apart from the error code and text, for any other 
> type of error in the SDP data within the Local descriptor ?
>  
> MEGACO/2 [20.0.4.32]:2084
> REPLY = 269820167 {
>   CONTEXT = 13 {
>     ADD = port_1
>   ,
>     ADD = eph/00337 { 
>           ERROR = 515 {"Unsupported Media Type"} 
>     }
>   }
> } 
>  
> Thanks
> John
>  
>
------------------------------------------------------------------------
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
>   

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Ashish Singh <[email-masked]>
Date: Wed, 26 Jul 2006 11:55:11 -0700

I guess it will be easier for MGC to parse, if we only include 
"streamID" and no other text. IMO, error descriptor should look like:

ERROR = 515 {"xxx"}

Thanks
Ashish