Subject: [Megaco] one doubt about h248V3

From: Tony Zhang <[email-masked]>
Date: Sat, 29 Jul 2006 11:18:29 +0800

HI All：

In ABNF specification:   

   indAudsignalRequest   = signalName [LBRKT indAudsignalRequestParm

                          *(COMMA indAudsignalRequestParm) RBRKT]

indAudsignalRequestParm = sigStream / sigRequestID

I have doubt about that whether  one indAudsignalRequest can appear two or more sigRequestID(or sigStream ).

    Regards, 

Tony

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Mon, 31 Jul 2006 13:09:15 +0530

Hi

IMO, it does not make sense to have two SigRequestID for the same SignalName. Therefore a single indAudsignalRequest

shall contain multiple parameters such as StreamID and SigRequestID but not multiple times.

However a SignalList can have multiple signals, each having RequestID/StreamId,

but that requires change in the V3 grammar:

****************************************************************************************************************************

indAudsignalsDescriptor = SignalsToken LBRKT [indAudsignalParm] RBRKT

indAudsignalParm = indAudsignalList / indAudsignalRequest

indAudsignalList = SignalListToken EQUAL signalListId

[LBRKT indAudsignalListParm *(COMMA indAudsignalListParm) <<<<<<<<<<<Proposed change

RBRKT]

indAudsignalListParm = indAudsignalRequest

*******************************************************************************************************************************

regards

B Venkat S.R Swamy

Senior Technical Leader

Flextronics Software Systems

Phone: +91-124- 4176213

Fax: +91-124-4300247

web: www.flextronicssoftware.com

Tony Zhang <[email-masked]>

Tony Zhang <[email-masked]>

07/29/2006 08:48 AM

To

[email-masked]

cc

Subject

[Megaco] one doubt about h248V3

HI All：

In ABNF specification:

Regards,

Tony_______________________________________________

Megaco mailing list

[email-masked]

*********************** FSS-Restricted ***********************

"DISCLAIMER: This message is proprietary to Flextronics Software

Systems Limited (FSS) and is intended solely for the use of the

individual to whom it is addressed. It may contain privileged or

confidential information and should not be circulated or used for

any purpose other than for what it is intended. If you have received

this message in error, please notify the originator immediately.

If you are not the intended recipient, you are notified that you are

strictly prohibited from using, copying, altering, or disclosing

the contents of this message. FSS accepts no responsibility for

loss or damage arising from the use of the information transmitted

by this email including damage from virus."