Subject: [Megaco] Action fails in a transaction!!

From: "Mudit Gupta" <[email-masked]>
Date: Mon, 3 Jul 2006 15:37:54 +0530

Hi All, 
 
I have a query about the h.248 behaviour in case of optional command within an action. It's stated that if an optional command fails, the next available command in the action will be processed. My query is if we should process the next action, If the previous action fails(failure happened at action level not at the command level) and it contains optional command. 
 
E.g. if there is no termination named as aln3, what should be the expected behaviour from the behaviour given below: Behaviour 1 or Behaviour 2.  
 
Behaviour 1:  Dont process the next action, if the previous action in a txn fails and abort the txn.
 
MGC -----------------------------> MG
 
 MEGACO/2  [127.0.0.21]:8000
Transaction=5{
  Context=-{
    O-AUDITVALUE=aln3{
      Audit{
        Media
      }
    }
  }
  ,Context=*{
    O-AV=aln3{
      AT{
        Media
      }
    }
  }
}
                                          MG -------------------------------> MGC
 
                                        !/2  [127.0.0.1]:4000
                                        P=5{
                                          C=-{
                                            ER=430{
                                              "aln3"
                                            }
                                          }
                                        }
 
Behaviour 2: Process the next action, if the previous action in a txn fails.
 
MGC -----------------------------> MG
 
 MEGACO/2  [127.0.0.21]:8000
Transaction=5{
  Context=-{
    O-AUDITVALUE=aln3{
      Audit{
        Media
      }
    }
  }
  ,Context=*{
    O-AV=aln3{
      AT{
        Media
      }
    }
  }
}
                                          MG -------------------------------> MGC
 
                                        !/2  [127.0.0.1]:4000
                                        P=5{
                                          C=-{
                                            ER=430{
                                              "aln3"
                                            }
                                          },
                                          C=*{
                                            ER=430{
                                              "aln3"
                                            }
                                          }
                                        }
 
Regards,
Mudit
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Tue, 4 Jul 2006 13:11:41 +0530

Hi Mudit

why would 430 be a context level error, rather it should be command level error.

however the issue that you have raised is still valid, whether transaction processing should proceed if there is context level error, in case

context has some optional commands. Protocol is not very clear on this issue and there should be some text to clarify this scenario.

regards

B Venkat S.R Swamy

Senior Technical Leader

Flextronics Software Systems

Phone: +91-124- 4176213

Fax: +91-124-4300247

web: www.flextronicssoftware.com

"Mudit Gupta" <[email-masked]>

"Mudit Gupta" <[email-masked]>

07/03/2006 03:37 PM

To

<[email-masked]>

cc

Subject

[Megaco] Action fails in a transaction!!

Hi All,

Transaction=5{

Context=-{

O-AUDITVALUE=aln3{

Audit{

Media

}

}

}

,Context=*{

O-AV=aln3{

AT{

Media

}

}

}

}

!/2 [127.0.0.1]:4000

P=5{

C=-{

ER=430{

"aln3"

}

}

}

Transaction=5{

Context=-{

O-AUDITVALUE=aln3{

Audit{

Media

}

}

}

,Context=*{

O-AV=aln3{

AT{

Media

}

}

}

}

!/2 [127.0.0.1]:4000

P=5{

C=-{

ER=430{

"aln3"

}

},

C=*{

ER=430{

"aln3"

}

}

}

Regards,

Mudit_______________________________________________

Megaco mailing list

[email-masked]

*********************** FSS-Restricted ***********************

"DISCLAIMER: This message is proprietary to Flextronics Software

Systems Limited (FSS) and is intended solely for the use of the

individual to whom it is addressed. It may contain privileged or

confidential information and should not be circulated or used for

any purpose other than for what it is intended. If you have received

this message in error, please notify the originator immediately.

If you are not the intended recipient, you are notified that you are

strictly prohibited from using, copying, altering, or disclosing

the contents of this message. FSS accepts no responsibility for

loss or damage arising from the use of the information transmitted

by this email including damage from virus."

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 20 Jul 2006 07:29:52 -0400

I'm way behind in my reading, but I have an opinion on this one. The 
protocol does not supply a way to mark action-level specifications as 
optional. You have to accept that and the conclusion: a failure at the 
action level terminates the transaction.

The scope of option marking on a command includes that command, nothing 
else.

B Venkat S.R Swamy wrote:
> however the issue that you have raised is still valid, whether transaction 
> processing should proceed if there is context level error, in case
> context has some optional commands. Protocol is not very clear on this issue and 
> there should be some text to clarify this scenario.
> 
> 
> regards
> B Venkat S.R Swamy
> Senior Technical Leader
> Inactive hide details for "Mudit Gupta" <[email-masked]>"Mudit Gupta" 
> <[email-masked]>
> 
> 
>                         *"Mudit Gupta" <[email-masked]>*
> 
>                         07/03/2006 03:37 PM
> 
> 	
> 
> To
> 	
> <[email-masked]>
> 
> cc
> 	
> 
> Subject
> 	
> I have a query about the h.248 behaviour in case of optional command within an 
> action. It's stated that if an optional command fails, the next available 
> command in the action will be processed. My query is if we should process the 
> next action, If the previous action fails(failure happened at action level not 
> at the command level) and it contains optional command.
> 
> E.g. if there is no termination named as aln3, what should be the expected 
> behaviour from the behaviour given below: Behaviour 1 or Behaviour 2.
> 
> *_Behaviour 1:_* Dont process the next action, if the previous action in a txn 
> fails and abort the txn.
> 
> *_Behaviour 2:_* Process the next action, if the previous action in a txn fails.
> 
> ------------------------------------------------------------------------
>