Subject: 答复: [Megaco] TGW signal in null context

From: "FCG SHI Hao" <[email-masked]>
Date: Mon, 18 Sep 2006 16:05:41 +0800

I think the signal can be played on a termination which is in the null context, such as the scenario in continuity test:
MEGACO/1 [10.10.10.10]: 1000 Transaction = 1234 {
       Context = - {
          Modify = Trunk1/1/1/1  {Media {
                    TerminationState {ServiceState = test}}
            Signals = { ct/ct }
            Events = 1111 { ct/cmp } 
               }}}}  
 MEGACO/1 [10.10.10.11]: 1001
   Reply = 1234 {
      Context = '-' {
        Modify = Trunk1/1/1/1
     }
   }

-----邮件原件-----
发件人: Raphael Tryster [mailto:[email-masked]] 
发送时间: 2006年9月18日 15:09
收件人: [email-masked]
主题: [Megaco] TGW signal in null context

Can anyone think of a case in which a trunking gateway would be asked to
play a signal on a termination that is in the null context?

Alternatively, an explanantion why it could never happen?
 
Raphael Tryster
**********************************************************************************************
This e-mail contains confidential, privileged or proprietary information to VocalTec Communications.
If you received this messege by mistake, please inform us and then delete the original and all copies.
*** eSafe scanned this email for viruses, vandals, and malicious content. ***
**********************************************************************************************

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 18 Sep 2006 12:57:04 -0400

This usage would largely depend upon the implementation, but is a good
example of why it is difficult to say that something will "never" happen
in H.248.  Since the usage would depend upon the MGC implementation, the
MG must be able to handle production of signals on the terminations
while in NULL.

Kevin

-----Original Message-----
From: FCG SHI Hao [mailto:[email-masked]] 
Sent: Monday, September 18, 2006 4:06 AM
To: Raphael Tryster; [email-masked]
Subject: ??: [Megaco] TGW signal in null context

I think the signal can be played on a termination which is in the null
context, such as the scenario in continuity test:
MEGACO/1 [10.10.10.10]: 1000 Transaction = 1234 {
       Context = - {
          Modify = Trunk1/1/1/1  {Media {
                    TerminationState {ServiceState = test}}
            Signals = { ct/ct }
            Events = 1111 { ct/cmp } 
               }}}}
 MEGACO/1 [10.10.10.11]: 1001
   Reply = 1234 {
      Context = '-' {
        Modify = Trunk1/1/1/1
     }
   }

-----�ʼ�ԭ��-----
������: Raphael Tryster [mailto:[email-masked]]
����ʱ��: 2006��9��18�� 15:09
�ռ���: [email-masked]
����: [Megaco] TGW signal in null context

 
Raphael Tryster
************************************************************************
**********************
This e-mail contains confidential, privileged or proprietary information
to VocalTec Communications.
If you received this messege by mistake, please inform us and then
delete the original and all copies.
*** eSafe scanned this email for viruses, vandals, and malicious
content. ***
************************************************************************
**********************

---

From: [email-masked]
Date: Tue, 19 Sep 2006 08:00:03 +0200

Raphael,

just two other examples (besides the (1) test scenario) for TMG signals in
NULL Context:

2. CAS signalling (H.248.25/28/29)
3. DCME signalling (H.248.42)

[A TMG in real networks has typically to serve other signalling systems
besides SS7.]

A further example for AMG signals in NULL Context is e.g.:
4. Delivery of PSTN Supplementary Services (e.g. AoC, MWI, CLIP) in
"on-hook" state of the POTS terminal.

- Albrecht

                      "Kevin Boyle"                                                                                                   
                      <[email-masked]         To:      "FCG SHI Hao" <[email-masked]>, "Raphael Tryster"               
                      om>                      <[email-masked]>, <[email-masked]>                                      
                                               cc:                                                                                    
                      18.09.2006 18:57         Subject: RE: [Megaco] TGW signal in null context                                       

Kevin

-----ÓÊ¼þÔ­¼þ-----
·¢¼þÈË: Raphael Tryster [mailto:[email-masked]]
·¢ËÍÊ±¼ä: 2006Äê9ÔÂ18ÈÕ 15:09
ÊÕ¼þÈË: [email-masked]
Ö÷Ìâ: [Megaco] TGW signal in null context

Raphael Tryster