Subject: 答复: [Megaco] scope of RequestIdentifier

From: "FCG SHI Hao" <[email-masked]>
Date: Thu, 28 Sep 2006 20:36:08 +0800

Just a suggestion: for MGC, why not use the Request Identifier unique within each Gw when sends request to them? I think it is easier; for MG, any scope which is upon context is ok, because the command and signal/event descriptor process are all within the context.

-----邮件原件-----
发件人: Luke Zhang (luzhan) [mailto:[email-masked]] 
发送时间: 2006年9月28日 18:06
收件人: [email-masked]
主题: [Megaco] scope of RequestIdentifier

Hello list,

Just not sure with the scope of Request Identifier. Is it ok for me to keep the Request Identifier unique only within a single Context? or do I have to make it unique within each GW scope?

Thanks, Luke
___________________________________________________
Luke Zhang
Software Engineer, China R&D Center, Cisco Systems
14th floor, Block C, Keji Building, 900 Yishan Lu, Caohejing Hi-Tech Park, Shanghai, P.R.C, 200233                    ....

Phone : +86 (21) 2405 7082                         .....   __0
Mobile: +86 159 2133 9185                         ....   _\ <,_
Email :  <mailto:[email-masked]> [email-masked]                           ___(_)/_(_)__
___________________________________________________

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 28 Sep 2006 13:56:21 -0400

Actually, commands and Signals/Events Descriptors are within the
termination, not the context.
 
This aside, the scope of the RequestID is an implementation decision on
the part of the MGC.  I have seen a wide variety of implementations
here, but most of them just start at 1 and increment for each new Events
Descriptor sent by the MGC.  This makes the scope even broader (within
the MGC across all MGs).  Ultimately, as long as the MGC can determine
what is going on, any scope is acceptable.
 
Kevin

________________________________

From: FCG SHI Hao [mailto:[email-masked]] 
Sent: Thursday, September 28, 2006 8:36 AM
To: Luke Zhang (luzhan); [email-masked]
Subject: ??: [Megaco] scope of RequestIdentifier

Just a suggestion: for MGC, why not use the Request Identifier unique
within each Gw when sends request to them? I think it is easier; for MG,
any scope which is upon context is ok, because the command and
signal/event descriptor process are all within the context.

-----�ʼ�ԭ��-----
������: Luke Zhang (luzhan) [mailto:[email-masked]] 
����ʱ��: 2006��9��28�� 18:06
�ռ���: [email-masked]
����: [Megaco] scope of RequestIdentifier

Hello list,

Just not sure with the scope of Request Identifier. Is it ok for me to
keep the Request Identifier unique only within a single Context? or do I
have to make it unique within each GW scope?

Thanks, Luke
___________________________________________________
Luke Zhang
Software Engineer, China R&D Center, Cisco Systems
14th floor, Block C, Keji Building, 900 Yishan Lu, Caohejing Hi-Tech
Park, Shanghai, P.R.C, 200233                    ....

Phone : +86 (21) 2405 7082                         .....   __0
Mobile: +86 159 2133 9185                         ....   _\ <,_
Email : [email-masked] <mailto:[email-masked]>
___(_)/_(_)__
___________________________________________________