Subject: RE: [Megaco] Text Encoding of an Empty String

From: "Shashank Taneja" <[email-masked]>
Date: Mon, 11 Sep 2006 11:48:49 +0530

Hi B Venkat S.R Swamy,

Thanks for your response. I have a follow-up query on your suggestion.

Since a normal octet string is not required to be enclosed in quotes are
you suggesting that we mandate an empty string to be specified by ""?

Regards

Shashank

________________________________

From: B Venkat S.R Swamy [mailto:[email-masked]] 
Sent: Friday, September 08, 2006 6:00 PM
To: Shashank Taneja
Cc: [email-masked]
Subject: Re: [Megaco] Text Encoding of an Empty String

Hi

Empty quoted string shall be used as follows:

MEGACO/1 [1.2.3.5] Transaction =30 { 

Context = $ {
Add = tdm/1/1/1/4 {
Media {LocalControl {Mode = SendReceive,
abc/xx=""}}

regards
B Venkat S.R Swamy 
Senior Technical Leader
Flextronics Software Systems
Phone: +91-124- 4176213
Fax: +91-124-4300247
web: www.flextronicssoftware.com

 "Shashank Taneja" <[email-masked]>

"Shashank Taneja" <[email-masked]> 

09/08/2006 03:34 PM

To

<[email-masked]>

cc

Subject

[Megaco] Text Encoding of an Empty String

Hi All,

I would like to have some inputs on the text encoding of the Property
Parameters of type octet String, whose default value is an empty string.
Consider for example the following property, in "abc":

PropertyID: xx.
Type: Octet String.
Possible Values: A range of 0 to 128 characters.
Defined In: Local Control.
Default Value: An empty string.

Is following the right way to encode this, if the property parameter
value is the default value:

MEGACO/1 [1.2.3.5] Transaction =30 {
Context = $ {
Add = tdm/1/1/1/4 {
Media {LocalControl {Mode = SendReceive,
abc/xx=}}

Any thoughts on this would be deeply appreciated.

Thanks,

Best Regards
Shashank Taneja_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

*********************** FSS-Restricted ***********************
"DISCLAIMER: This message is proprietary to Flextronics Software 
Systems Limited (FSS) and is intended solely for the use of the 
individual to whom it is addressed. It may contain privileged or 
confidential information and should not be circulated or used for 
any purpose other than for what it is intended. If you have received 
this message in error, please notify the originator immediately. 
If you are not the intended recipient, you are notified that you are
strictly prohibited from using, copying, altering, or disclosing
the contents of this message. FSS accepts no responsibility for
loss or damage arising from the use of the information transmitted
by this email including damage from virus."

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Shashank Taneja" <[email-masked]>
Date: Thu, 14 Sep 2006 14:23:26 +0530

Hi,

Any thoughts on this argument?

Thanks

Shashank

From: Shashank Taneja [mailto:[email-masked]] 
Sent: Monday, September 11, 2006 11:49 AM
To: B Venkat S.R Swamy
Cc: [email-masked]
Subject: RE: [Megaco] Text Encoding of an Empty String

Hi B Venkat S.R Swamy,

Regards

Shashank

Hi

Context = $ {
Add = tdm/1/1/1/4 {

regards
B Venkat S.R Swamy 
Senior Technical Leader

09/08/2006 03:34 PM

To

<[email-masked]>

cc

Subject

Hi All,

PropertyID: xx.
Type: Octet String.

Thanks,

Best Regards