Subject: [Megaco] RE: Re: Error during Add Command

From: "Liu Ti,SLC Com FN RDC NA(BJ)" <[email-masked]>
Date: Mon, 4 Sep 2006 15:42:29 +0800

Hi:

Maybe it depends on how important the tone is,does the tone have important impact on the process:
I think usually that if  tonedet package is not supported by MG,the MG can still work well, only the desired tone can not be generated.

E.g. if tonedet contains a dial tone that the MG does not support, the caller may no hear that dial tone,but the caller can still dial and speak to the receiver. All the process is as normal, just in this process no dial tone is heard.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Saturday, September 02, 2006 12:00 AM
To: [email-masked]
Subject: Megaco Digest, Vol 29, Issue 1

Send Megaco mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	https://www1.ietf.org/mailman/listinfo/megaco
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific than "Re: Contents of Megaco digest..."

Today's Topics:

   1. Re: Error during Add Command (Wglastonio)
   2. Who chooses circuit between TGW and SS7? (Raphael Tryster)
   3. Re: Who chooses circuit between TGW and SS7? (Terry L Howe)
   4. RE: Who chooses circuit between TGW and SS7? (Raphael Tryster)
   5. RE: Who chooses circuit between TGW and SS7? (Terry L Howe)

----------------------------------------------------------------------

Message: 1
Date: Thu, 31 Aug 2006 13:16:15 -0300
From: Wglastonio <[email-masked]>
Subject: Re: [Megaco] Error during Add Command
To: [email-masked]
Cc: [email-masked]
Message-ID:
	<[email-masked]>
Content-Type: text/plain; charset="iso-8859-1"

Hello,
Chapter 8 (Transactions) describes:
"At the first failing command in a transaction, processing of the remaining commands in that transaction stops."

Reg,

Wg.

2006/8/31, Kevin Boyle <[email-masked]>:
>
> The command failed, therefore the context did not come into existence 
> and the termination is still in NULL.
>
> Kevin
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, August 31, 2006 10:20 AM
> To: [email-masked]
> Subject: [Megaco] Error during Add Command
>
> Hi all
>
> We see here the following :
>
> MGC sends ADD request to the MG :
>
> MEGACO/1 [xx.xx.xx.xx]:2944 
> T=369419463{C=${A=aaln/65{M{O{MO=IN,RV=OFF,RG=OFF}},E=370727168{tonede
> t/
> std{tl=*},al/*},SG{}},A=${M{O{MO=RC,RV=OFF,RG=OFF},L{v=0
>    c=IN IP4 $
>    m=audio $ RTP/AVP 8
>    a=ptime:20
>    }}}}}
>
> The MG does not support the tonedet package :
> What is the right behavior at this case :
>
> a.  Send an error message without creating a context and not process 
> the ADD request. b. Process the ADD request and add the termination to 
> a context, with an error notification regarding the Unsupported 
> Package.
>
>
> Thanks In Advance
>
> Seraya
>
>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www1.ietf.org/pipermail/megaco/attachments/20060831/b71e96e9/attachment.html

------------------------------

Message: 2
Date: Thu, 31 Aug 2006 20:24:06 +0200
From: "Raphael Tryster" <[email-masked]>
Subject: [Megaco] Who chooses circuit between TGW and SS7?
To: "Madhubabu Brahmanapally"
	<[email-masked]>,<[email-masked]>
Message-ID:
	<[email-masked]>
Content-Type: text/plain; charset="windows-1255"

I refer to draft-ietf-megaco-callflows-02.txt.  In the section on a call between SS7 trunk in TGW and RGW, the MGC receives in the IAM message the identity of the circuit that the SS7 switch has chosen to be used for the call, translates this into a termination, and tells the TGW to use that termination.  I have no problem with this.
 
For a call in the opposite direction, the draft says that the MGC asks the TGW to choose a circuit.  I would understand if the MGC then used the chosen circuit in the messages it send to SS7 to set up the call.  However, the draft says that these SS7 messages are exchanged BEFORE adding the physical termination.  How can this work?  There doesn't seem to be anything ensuring that SS7 and TGW will use the same circuit.
 
Raphael Tryster
**********************************************************************************************
This e-mail contains confidential, privileged or proprietary information to VocalTec Communications. If you received this messege by mistake, please inform us and then delete the original and all copies.
*** eSafe scanned this email for viruses, vandals, and malicious content. ***
**********************************************************************************************
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www1.ietf.org/pipermail/megaco/attachments/20060831/54e5c559/attachment.html

------------------------------

Message: 3
Date: Thu, 31 Aug 2006 11:43:20 -0600
From: Terry L Howe <[email-masked]>
Subject: Re: [Megaco] Who chooses circuit between TGW and SS7?
To: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain;	charset=ISO-8859-1;	DelSp="Yes";
	format="flowed"

The TGW is bearer only, SS7 should determine the CIC, it is signaling.

Quoting Raphael Tryster <[email-masked]>:

> I refer to draft-ietf-megaco-callflows-02.txt.  In the section on a   
> call between SS7 trunk in TGW and RGW, the MGC receives in the IAM   
> message the identity of the circuit that the SS7 switch has chosen   
> to be used for the call, translates this into a termination, and   
> tells the TGW to use that termination.  I have no problem with this.
>
> For a call in the opposite direction, the draft says that the MGC   
> asks the TGW to choose a circuit.  I would understand if the MGC   
> then used the chosen circuit in the messages it send to SS7 to set   
> up the call.  However, the draft says that these SS7 messages are   
> exchanged BEFORE adding the physical termination.  How can this   
> work?  There doesn't seem to be anything ensuring that SS7 and TGW   
> will use the same circuit.
>
> Raphael Tryster
> **********************************************************************************************
> This e-mail contains confidential, privileged or proprietary   
> information to VocalTec Communications.
> If you received this messege by mistake, please inform us and then   
> delete the original and all copies.
> *** eSafe scanned this email for viruses, vandals, and malicious 
> content. ***
> **********************************************************************************************

-- 
Terry L Howe
[email-masked]

------------------------------

Message: 4
Date: Thu, 31 Aug 2006 22:05:18 +0200
From: "Raphael Tryster" <[email-masked]>
Subject: RE: [Megaco] Who chooses circuit between TGW and SS7?
To: "Terry L Howe" <[email-masked]>,<[email-masked]>
Message-ID:
	<[email-masked]>
Content-Type: text/plain;	charset="iso-8859-1"

Does that mean the call flows document is wrong?
 
Raphael Tryster

-----Original Message-----
From: Terry L Howe [mailto:[email-masked]]
Sent: Thursday, August 31, 2006 7:43 PM
To: [email-masked]
Subject: Re: [Megaco] Who chooses circuit between TGW and SS7?

The TGW is bearer only, SS7 should determine the CIC, it is signaling.

Quoting Raphael Tryster <[email-masked]>:

> I refer to draft-ietf-megaco-callflows-02.txt.  In the section on a   
> call between SS7 trunk in TGW and RGW, the MGC receives in the IAM   
> message the identity of the circuit that the SS7 switch has chosen   
> to be used for the call, translates this into a termination, and   
> tells the TGW to use that termination.  I have no problem with this.
>
> For a call in the opposite direction, the draft says that the MGC   
> asks the TGW to choose a circuit.  I would understand if the MGC   
> then used the chosen circuit in the messages it send to SS7 to set   
> up the call.  However, the draft says that these SS7 messages are   
> exchanged BEFORE adding the physical termination.  How can this   
> work?  There doesn't seem to be anything ensuring that SS7 and TGW   
> will use the same circuit.
>
> Raphael Tryster
> **********************************************************************************************
> This e-mail contains confidential, privileged or proprietary   
> information to VocalTec Communications.
> If you received this messege by mistake, please inform us and then   
> delete the original and all copies.
> *** eSafe scanned this email for viruses, vandals, and malicious 
> content. ***
> **********************************************************************************************

-- 
Terry L Howe
[email-masked]

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco
**********************************************************************************************
This e-mail contains confidential, privileged or proprietary information to VocalTec Communications. If you received this messege by mistake, please inform us and then delete the original and all copies.
*** eSafe scanned this email for viruses, vandals, and malicious content. ***
**********************************************************************************************

------------------------------

Message: 5
Date: Thu, 31 Aug 2006 14:30:18 -0600
From: Terry L Howe <[email-masked]>
Subject: RE: [Megaco] Who chooses circuit between TGW and SS7?
To: Raphael Tryster <[email-masked]>
Cc: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain;	charset=ISO-8859-1;	DelSp="Yes";
	format="flowed"

I guess it gets down to a design decision.  In theory, you could have a TGW make routing decisions, but it doesn't seem like a good place to make that decision to me.  I would think someone else would make that decision and the TGW would just blindly set up connections and keep some DSPs busy.  The implementations I've worked on have used more centralized routing.

Quoting Raphael Tryster <[email-masked]>:

> Does that mean the call flows document is wrong?
>
> Raphael Tryster
>
> -----Original Message-----
> From: Terry L Howe [mailto:[email-masked]]
> Sent: Thursday, August 31, 2006 7:43 PM
> To: [email-masked]
> Subject: Re: [Megaco] Who chooses circuit between TGW and SS7?
>
>
>
>
> The TGW is bearer only, SS7 should determine the CIC, it is signaling.
>
>
> Quoting Raphael Tryster <[email-masked]>:
>
>> I refer to draft-ietf-megaco-callflows-02.txt.  In the section on a 
>> call between SS7 trunk in TGW and RGW, the MGC receives in the IAM 
>> message the identity of the circuit that the SS7 switch has chosen to 
>> be used for the call, translates this into a termination, and tells 
>> the TGW to use that termination.  I have no problem with this.
>>
>> For a call in the opposite direction, the draft says that the MGC 
>> asks the TGW to choose a circuit.  I would understand if the MGC then 
>> used the chosen circuit in the messages it send to SS7 to set up the 
>> call.  However, the draft says that these SS7 messages are exchanged 
>> BEFORE adding the physical termination.  How can this work?  There 
>> doesn't seem to be anything ensuring that SS7 and TGW will use the 
>> same circuit.
>>
>> Raphael Tryster
>> *********************************************************************
>> *************************
>> This e-mail contains confidential, privileged or proprietary
>> information to VocalTec Communications.
>> If you received this messege by mistake, please inform us and then
>> delete the original and all copies.
>> *** eSafe scanned this email for viruses, vandals, and malicious   
>> content. ***
>> **********************************************************************************************
>
>
>
> --
> Terry L Howe
> [email-masked]
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> **********************************************************************************************
> This e-mail contains confidential, privileged or proprietary   
> information to VocalTec Communications.
> If you received this messege by mistake, please inform us and then   
> delete the original and all copies.
> *** eSafe scanned this email for viruses, vandals, and malicious 
> content. ***
> **********************************************************************************************
>
>

-- 
Terry L Howe
[email-masked]

------------------------------

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

End of Megaco Digest, Vol 29, Issue 1
*************************************

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 5 Sep 2006 13:39:53 -0400

Maybe so, but H.248 is clear.  The command failed.  Given that it is the
only command in the action, the action failed as well.  This means that
the context did not come into existence, and the termination remained in
NULL.

Commands are the atomic blocks of H.248.  Descriptors provide the data
to be able to execute the commands.  You can't execute just the parts of
the command that you like -- commands must be executed or failed in
their entirety.

Kevin

-----Original Message-----
From: Liu Ti,SLC Com FN RDC NA(BJ) [mailto:[email-masked]] 
Sent: Monday, September 04, 2006 3:42 AM
To: [email-masked]
Subject: [Megaco] RE: Re: Error during Add Command

Hi:

Maybe it depends on how important the tone is,does the tone have
important impact on the process:
I think usually that if  tonedet package is not supported by MG,the MG
can still work well, only the desired tone can not be generated.

E.g. if tonedet contains a dial tone that the MG does not support, the
caller may no hear that dial tone,but the caller can still dial and
speak to the receiver. All the process is as normal, just in this
process no dial tone is heard.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Saturday, September 02, 2006 12:00 AM
To: [email-masked]
Subject: Megaco Digest, Vol 29, Issue 1

When replying, please edit your Subject line so it is more specific than
"Re: Contents of Megaco digest..."

Today's Topics:

Message: 1

Hello,
Chapter 8 (Transactions) describes:
"At the first failing command in a transaction, processing of the
remaining commands in that transaction stops."

Reg,

Wg.

-------------- next part --------------
An HTML attachment was scrubbed...
URL:
http://www1.ietf.org/pipermail/megaco/attachments/20060831/b71e96e9/atta
chment.html

Message: 2

I refer to draft-ietf-megaco-callflows-02.txt.  In the section on a call
between SS7 trunk in TGW and RGW, the MGC receives in the IAM message
the identity of the circuit that the SS7 switch has chosen to be used
for the call, translates this into a termination, and tells the TGW to
use that termination.  I have no problem with this.
 
For a call in the opposite direction, the draft says that the MGC asks
the TGW to choose a circuit.  I would understand if the MGC then used
the chosen circuit in the messages it send to SS7 to set up the call.
However, the draft says that these SS7 messages are exchanged BEFORE
adding the physical termination.  How can this work?  There doesn't seem
to be anything ensuring that SS7 and TGW will use the same circuit.
 
Raphael Tryster
************************************************************************
**********************
This e-mail contains confidential, privileged or proprietary information
to VocalTec Communications. If you received this messege by mistake,
please inform us and then delete the original and all copies.
*** eSafe scanned this email for viruses, vandals, and malicious
content. ***
************************************************************************
**********************
-------------- next part --------------
An HTML attachment was scrubbed...
URL:
http://www1.ietf.org/pipermail/megaco/attachments/20060831/54e5c559/atta
chment.html

Message: 3

> will use the same circuit.
************************************************************************
**********************
> *** eSafe scanned this email for viruses, vandals, and malicious 
************************************************************************
**********************

-- 
Terry L Howe
[email-masked]

Message: 4

 
Raphael Tryster

-----Original Message-----
From: Terry L Howe [mailto:[email-masked]]
Sent: Thursday, August 31, 2006 7:43 PM
To: [email-masked]
Subject: Re: [Megaco] Who chooses circuit between TGW and SS7?

> will use the same circuit.
************************************************************************
**********************
> *** eSafe scanned this email for viruses, vandals, and malicious 
************************************************************************
**********************

-- 
Terry L Howe
[email-masked]

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco
************************************************************************
**********************
This e-mail contains confidential, privileged or proprietary information
to VocalTec Communications. If you received this messege by mistake,
please inform us and then delete the original and all copies.
*** eSafe scanned this email for viruses, vandals, and malicious
content. ***
************************************************************************
**********************

Message: 5

I guess it gets down to a design decision.  In theory, you could have a
TGW make routing decisions, but it doesn't seem like a good place to
make that decision to me.  I would think someone else would make that
decision and the TGW would just blindly set up connections and keep some
DSPs busy.  The implementations I've worked on have used more
centralized routing.

>> doesn't seem to be anything ensuring that SS7 and TGW will use the 
************************************************************************
**********************
************************************************************************
**********************
> *** eSafe scanned this email for viruses, vandals, and malicious 
************************************************************************
**********************

-- 
Terry L Howe
[email-masked]