Subject: [Megaco] Message version issue

From: "FCG Long Hai" <[email-masked]>
Date: Tue, 26 Sep 2006 13:50:34 +0800

Hi all,
  There are some words in H.248.1 V2 (11.3 Negotiation of protocol
version)
  "Regardless of the version placed in the ServiceChangeVersion
parameter, the message containing the command shall be encoded as a
version 1 message."
  Would someone please help to clarify it? Does this sentence only apply
to the procedure of Negotiation of protocol version, or apply to all
cases?
  For example:
  MG and MGC had a connection, H248 protocol version 2 had been
negotiated.
  Then the GW lose the communication with MGC. After some time,
communication is OK. MG will try to send SC (DC, 900) to MGC. Which
version the message header shall be encoded? 2 or 1?
  Thanks!

BR
Long hai

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Tue, 26 Sep 2006 08:46:41 +0200

"2"

LongHai,
you omitted the first sentence of § 11.3:

   A  ServiceChange  command  from  a  MG  that registers with an MGC shall
   contain  the  version  number of the protocol supported by the MG in the
   ServiceChangeVersion parameter.

=> only related to registration (or re-registration)
=> SC method "Disconnected" is not part of registration procedures, see §
F.3.1 and § F3.2

- Albrecht

                      "FCG Long Hai"                                                                                                        
                      <Hai.a.Long@alcatel-sb         To:      <[email-masked]>                                                             
                      ell.com.cn>                    cc:                                                                                    
                                                     Subject: [Megaco] Message version issue                                                
                      26.09.2006 07:50                                                                                                      

Hi all,

BR
Long hai