Subject: [Megaco] order of execution of descriptors

From: "Arturo Martin De Nicolas \(AC/EDD\)" <[email-masked]>
Date: Tue, 12 Sep 2006 11:14:20 +0200

Hello,

I suppose the most logical way to process and execute descriptors is to
do it in the same way as they appear in the command, e.g. the Media
Descriptor before the Signal Descriptor, but does H.248 really mandate
that? Or is it that there is actually no guarantee that the descriptors
are executed in the same order as they were sent in the command?

Thanks and best regards,
Arturo
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Sudhanshu Garg <[email-masked]>
Date: Tue, 12 Sep 2006 14:57:49 +0530

Hi,

The descriptors are processed in order in which they appear in the 
command.

H.248 mandates this. Snip from section 7.2 of H.248.1 is attached below.
    "Descriptors may appear as parameters to commands in any order.
    The descriptors shall be processed in the order in which they appear.
".

Regards,
Sudhanshu.
Technical Leader
Flextronics Software Systems
Phone:  +91-124-4176301 extn 5109
Fax: +91-124-4300247
web: www.flextronicssoftware.com

"Arturo Martin De Nicolas \(AC/EDD\)" 
<[email-masked]> 
09/12/2006 02:44 PM

To
<[email-masked]>
cc

Subject
[Megaco] order of execution of descriptors

Hello, 
I suppose the most logical way to process and execute descriptors is to do 
it in the same way as they appear in the command, e.g. the Media 
Descriptor before the Signal Descriptor, but does H.248 really mandate 
that? Or is it that there is actually no guarantee that the descriptors 
are executed in the same order as they were sent in the command?
Thanks and best regards,
Arturo _______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

***********************  FSS-Private   ***********************