Subject: [Megaco] Megaco call correlate question

From: <[email-masked]>
Date: Mon, 11 Dec 2006 13:57:43 -0600

Hi, list,
 
I got a special Megaco Call flow scenario as following. I am wondering
how to correlate the call.
 
one system (Sys1) has two ip address (ip1, ip2) for share load.
 
Sys1 sent AddReq with contextId1, transId1 from ip1 to SUT(system under
test).
Sys1 received AddRly with contextId1, transId1 by ip2 from SUT.
 
Somebody think AddReq and AddRly belongs to same transaction. 
 
My question is that if you only get the capture file of this call flow.
How to correlate them?
 
Appreciate anyone can help.
 
Thanks
 
Yabin
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Wed, 13 Dec 2006 20:03:35 +0100

You may NOT rely on the ContextID (due to a potential CHOOSE operator in
the ADD.req), thus the only chance is probably the TransactionID for a
correlation function (in my understanding).

Your described network environment and use case is valid in my opinion. You
are looking at H.248-over-IP transport. Both the MGC and the MG could use
different IP interfaces (logical or physical) for Rx and Tx H.248 traffic,
leading then to different IP@s as described by you.

This aspect is also addressed by Draft H.Sup7 "Gateway Control Protocol:
Establishment Procedures for the H.248 MGC-MG Control Association" (see
e.g. § 5.2.2.2 IP Interfaces for H.248 Entities).

- Albrecht

[Background: you may realize the built the interface for the H.248 Control
Association according a single-homed IP host model, but also as multi-homed
IP host. See again H.Sup7].

                      <yabin.hu@exgate                                                                                                  
                      .tek.com>                To:      <[email-masked]>                                                               
                                               cc:                                                                                      
                      11.12.2006 20:57         Subject: [Megaco] Megaco call correlate question                                         

Hi, list,

I got a special Megaco Call flow scenario as following. I am wondering how
to correlate the call.

My question is that if you only get the capture file of this call flow. How
to correlate them?

Thanks

Yabin_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: sivapiryan <[email-masked]>
Date: Sat, 16 Dec 2006 06:33:16 +0000 (GMT)

What is the maximum and minimum size of the Megaco Message (Is there any limitation on size)
 
 ***priyan***
 
 Send free SMS to your Friends on Mobile from your Yahoo! Messenger. Download Now! http://messenger.yahoo.com/download.php

---

From: [email-masked]
Date: Sat, 16 Dec 2006 11:18:04 +0100

This depends on the underlying transport technology (H.248.1 Annex D.1, or
Annex D.2, or H.248.4, or H.248.5), and whether this technology provides
inherent segmentation or not. If case of non-segmenting transport, like in
case of UDP (= Annex D.1), then you may you explicit segmentation on
Message level according the segmentation package (see H.248.1 V3).

- Albrecht

                      sivapiryan                                                                                                        
                      <megacopriyan@ya         To:      [email-masked]                                                                 
                      hoo.co.in>               cc:                                                                                      
                                               Subject: [Megaco] Message size                                                           
                      16.12.2006 07:33                                                                                                  

What is the maximum and minimum size of the Megaco Message (Is there any
limitation on size)

***priyan***

 Send free SMS to your Friends on Mobile from your Yahoo! Messenger.
Download Now! http://messenger.yahoo.com/download.php
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco