Subject: [Megaco] V3 question - Statistics Descriptor in Modify

From: "Dani Stettiner" <[email-masked]>
Date: Tue, 27 Feb 2007 19:07:22 +0200

Hi  All

  Version 3 had set the ability to add statistics descriptor in Add
command:

7.2.1     Add

......................

The Statistics Descriptor is optional. If present, it provides the
statistics which the MGC wishes to

be collected for the termination or stream. Each time the statistic is
set, the statistic value is reset.

....................

    Obviously the text above:  "Each time the statistic is set, the
statistic value is reset"  is more appropriate for  Modify command

    (In Add it is meaningless since no statistics were accumulated yet)

Although the grammar allows statistics descriptor for Modify (as well as
other commands), Section 7.2.2 (modify) is silent about it.

Would it be right to assume the text "Each time the statistic is set,
the statistic value is reset"   is valid also for Modify and Move?

   Regards

Dan Stettiner
Software Engineer, R&D
H.248/MEGACO 

Audiocodes
Email: [email-masked]
Tel. +972-3-9764415
www.audiocodes.com
<http://www.audiocodes.com/ohttp:/www.audiocodes.com/> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Wed, 28 Feb 2007 08:24:21 +1100

Hello Dani,

Section 7.2.2 Mod isn't exactly silent :), it says: "The remaining 
parameters to Modify are the same as those to Add. Possible return 
values are the same as those to Add."

In documenting Mod and Mov rather than re-specifying everything that was 
in ADD we simply referred back to it.

Regards, Christian

Dani Stettiner wrote:
>
> Hi All
>
> Version 3 had set the ability to add statistics descriptor in Add command:
>
> 7.2.1 Add
>
> ......................
>
> Obviously the text above: “Each time the statistic is set, the 
> statistic value is reset” is more appropriate for Modify command
>
> Although the grammar allows statistics descriptor for Modify (as well 
> as other commands), Section 7.2.2 (modify) is silent about it.
>
> Would it be right to assume the text “Each time the statistic is set, 
> the statistic value is reset” is valid also for Modify and Move?
>
> Regards
>
> //Dan Stettiner///
> ///Software Engineer, R&D//
> //H.248/MEGACO ///
>
> /Audiocodes
> <mailto:[email-masked]>
> Tel. +972-3-9764415
> www.audiocodes.com <http://www.audiocodes.com/ohttp:/www.audiocodes.com/>
>
> ------------------------------------------------------------------------
>