Subject: H.248 IP Router Package; Re: [Megaco] Question on Interface Routing ...

From: [email-masked]
Date: Wed, 28 Feb 2007 15:18:37 +0100

Reinaldo,

independent of your question concerning the specific TerminationID syntax
in ES 283 018, we did look at the IP router capability:

> The scenario is a BGF with many input and output interfaces.

>      +----+
> Ifa -|    |-ifx
> Ifb -| RT |-ify   RT means routing table
> Ibc -|    |-ifz
>      +----+

The starting point is an IP-to-IP H.248 Context, and how the "Context" must
behave in order to realize an "IP router" function. The requirements for
such a functions could be firstly limited to the "IP forwarding process"
itself (see e.g. requirements set given by RFC 1812, § 5.2).

When you try to realize such a packet forwarding process, it's fairly
obvious that it's not possible to configure the two IP Terminations/Streams
via their LDs/RDs and with existing H.248 elements for such a behaviour.
On the other side, introducing e.g.  at least two properties (an "IP
forwarding" and an "IP FIB" property), then you may achieve a behaviour
very close to RFC 1812, § 5.2 IMHO.

...<snip> (no more details here about such an IP router package because
still in discussion ...)

-Albrecht

PS
Is there a requirement for such a function in an H.248 MG?
On the first glance definitely not, because this is more a
"call/session-independent function".
But we may already support session-independent functions with H.248 ...

Or, an H.248 AGW/TGW or BGW may be interconnected to an IP edge router
(ER), thus the MG is a front-end element of the ER. But on the other side
you may also embedd the ER function in the MG ... and you may use an H.248
Context for the ER traffic ... etc etc

                      Albrecht                                                                                                       
                      SCHWARZ/DE/ALCAT         To:      "Reinaldo Penno" <[email-masked]>                                        
                      EL@ALCATEL               cc:      [email-masked]                                                              
                                               Subject: Re: [Megaco] Question on Interface Routing in relation to H.248   Profile    
                      16.10.2006 15:39         for      controlling Border Gateway Functions (BGF) (ETSI ES 283 018)                 

Reinaldo,

1st H.248 vs IP RIB/FIB
   There aren't any H.248 capabilities defined so far, allowing the
   modification of IP RIB/FIB data bases. Thus, H.248 is entirely decoupled
   from IP routing protocols.

2nd TerminationID
   Don't over-interprete this TerminatinationID structure. The defined
   naming convention by ES 283 018 is rather specific because besides the
   basic "identification" function, the syntax is also a) overloaded with
   other functions (a1 -> usage of <group>; a2 -> usage of <interface>);
   and b) hierarchical (-> benefit in case of wildcarding).

   The prime purpose behind (a2) is "IP address realm" indication. Please
   note that the ipdc package (H.248.41) was not yet available when ES 283
   018 was defined.
   So, the term "interface" could mislead if interpreted as "IP interface"
   (but this isn't the definition by Table 4/ES 283 018).

- Albrecht

                      "Reinaldo Penno"

                      <rpenno@juniper.         To:      <[email-masked]>

                      net>                     cc:

                                               Subject: [Megaco] Question
on Interface Routing in relation to H.248 Profile     for
                      14.10.2006 09:00         controlling Border Gateway
Functions (BGF) (ETSI ES 283 018)

In the specification above (or TS 102 333 for that matter) there is a
proposal for the termination ID.

"5.6.1.1.1 Overview and prose specification
The Termination ID structure shall follow the guidelines of H.248 and
shall be based on four fields:
* "ip/<group>/<interface>/<id>"."

I would like to understand what "interface" means in this context when
related to routing.

The scenario is a BGF with many input and output interfaces.

     +----+
Ifa -|    |-ifx
Ifb -| RT |-ify   RT means routing table
Ibc -|    |-ifz
     +----+

Packets come from one of the input interfaces (left), a routing lookup
is done, and exit through one of the output interfaces (right).

Given the termination ID ip/1/ifx/200 and a gate with source IP a.b.c.d
and destination IP e.f.g.h associated with it, which actions should be
done?

A) One should attach the termination to interface Ifx and if packets go
through that interface (and termination) any gate actions are applied.

B) One should override the routing table in order to make sure that
packets from source a.b.c.d and destination e.f.g.h go through Ifx.

The two approaches are quite different:

The first provides a clean separation of Gate Control and routing. You
configure routing to make sure the packets you are interested on go
through the proper interface (and consequently hit the termination) when
egress/ingress the router.

The second approach means an overide of the routing table by the H.248
process. Although possible this represents a protocol layer violation
and it makes me worried about unforseen interaction between routing
protocols and H.248 driven routing table changes.

What would be the correct interpretation?

Thanks,

Reinaldo

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Reinaldo Penno" <[email-masked]>
Date: Wed, 28 Feb 2007 11:53:49 -0500

Wow! You followed up in this? I have to say I'm impressed. 

Inline.... 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Wednesday, February 28, 2007 6:19 AM
> To: Reinaldo Penno
> Cc: [email-masked]
> Subject: H.248 IP Router Package; Re: [Megaco] Question on 
> Interface Routing ...
> 
> 
> Reinaldo,
> 
> independent of your question concerning the specific 
> TerminationID syntax in ES 283 018, we did look at the IP 
> router capability:
> 
> The starting point is an IP-to-IP H.248 Context, and how the 
> "Context" must behave in order to realize an "IP router" 
> function. The requirements for such a functions could be 
> firstly limited to the "IP forwarding process"
> When you try to realize such a packet forwarding process, 
> it's fairly obvious that it's not possible to configure the 
> two IP Terminations/Streams via their LDs/RDs and with 
> existing H.248 elements for such a behaviour.

Agreed.

> On the other side, introducing e.g.  at least two properties 
> (an "IP forwarding" and an "IP FIB" property), then you may 
> achieve a behaviour very close to RFC 1812, § 5.2 IMHO.
> 
> ...<snip> (no more details here about such an IP router 
> package because still in discussion ...)

Is there a draft about it?

> "call/session-independent function".

Well, I had many discussions about this internally and externally. Reading the current specs I told these people that context/terminations should be independent of routing, but many (external) people disagree with me. My stance is that is fine to disagree as long as there is something in place to tell me how a packet should be routed within a context (and its ingress/egress terminations). 

It could be:

1. Forwarding/routing takes care of it (this would be the current behavior) based on the existing specs.
2. Some new package that tells me how to make sure packets ingress and egress through the desired interfaces (which at some layer relate to the terminations like ip/1/32).

My problem today is that some people want 1 and others 2. The people that want 2 believe that a context by definition create some sort of session dependent routing. And since the MGC cannot instantiate this (because it does see data packets), it tells the MGW to do it. And creating a context is a implicit way of doing it.

>From my perspective I just would like this stuff to be well documented and specified. 

> Or, an H.248 AGW/TGW or BGW may be interconnected to an IP 
> edge router (ER), thus the MG is a front-end element of the 
> ER. But on the other side you may also embedd the ER function 
> in the MG ... and you may use an H.248 Context for the ER 
> traffic ... etc etc
> 
> 
> 
> 
> 
> 
>                                                               
>                                                               
>          
>                       Albrecht                                
>                                                               
>          
>                       SCHWARZ/DE/ALCAT         To:      
>                                                Subject: Re: 
> [Megaco] Question on Interface Routing in relation to H.248   
> Profile    
>                       16.10.2006 15:39         for      
> controlling Border Gateway Functions (BGF) (ETSI ES 283 018)  
>                
>                                                               
>                                                               
>          
> 
> 
> 
> 
> 
> Reinaldo,
> 
> 1st H.248 vs IP RIB/FIB
> In the specification above (or TS 102 333 for that matter) 
> there is a proposal for the termination ID.
> 
> "5.6.1.1.1 Overview and prose specification The Termination 
> ID structure shall follow the guidelines of H.248 and shall 
> be based on four fields:
> I would like to understand what "interface" means in this 
> context when related to routing.
> 
> Packets come from one of the input interfaces (left), a 
> routing lookup is done, and exit through one of the output 
> interfaces (right).
> 
> Given the termination ID ip/1/ifx/200 and a gate with source 
> IP a.b.c.d and destination IP e.f.g.h associated with it, 
> which actions should be done?
> 
> A) One should attach the termination to interface Ifx and if 
> packets go through that interface (and termination) any gate 
> actions are applied.
> 
> B) One should override the routing table in order to make 
> sure that packets from source a.b.c.d and destination e.f.g.h 
> go through Ifx.
> 
> 
> The first provides a clean separation of Gate Control and 
> routing. You configure routing to make sure the packets you 
> are interested on go through the proper interface (and 
> consequently hit the termination) when egress/ingress the router.
> 
> The second approach means an overide of the routing table by 
> the H.248 process. Although possible this represents a 
> protocol layer violation and it makes me worried about 
> unforseen interaction between routing protocols and H.248 
> driven routing table changes.
>