Subject: [Megaco] Question about the H.248.19 property - volume level for video swithing

From: "Nurit Shenhar" <[email-masked]>
Date: Thu, 1 Feb 2007 12:07:26 +0200

The below defines the volume level for video swithing:

12.1.1.2    Property Name: Volume Level for Video Switching
PropertyID:                                          vollevvidsw, 0x0002
Description:                                                      This
property indicates the volume level that, when equalled or exceeded, the
MP considers the associated termination/stream to be the active speaker.
Type:
Integer
Possible values:                                     0-100 decibels.
Default:
Provisioned

Our energy threshold can get values between 0 dBm to -39 dBm, where 0
dBm refer to quarter of digital full scale in Q15 notation, thus 0x2000.

How should one convert the 0 - 100 decibels to the above scale? It seems
to us that 100 decibels is a very high level.

Thanks,

Nurit Shenhar
H.248&MGCP Team Leader

Email: [email-masked]
Tel.  +972-3-9764155
Fax. +972-3-9764223
www.audiocodes.com <http://www.audiocodes.com/> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 05 Feb 2007 16:43:27 +1100

Hello Nurit,

I agree 100 is very high. I don't think anybody has a jet engine 
attached to their MG. In packages you are not required to support all 
the values of a property. However we didn't want to set the value range 
from 0-20dB as this would limit your implementation. So if your MG only 
supports 0 - 39dB its OK that's what you use as the values.

Regards, Christian

Nurit Shenhar wrote:
> *12.1.1.2 Property Name:* Volume Level for Video Switching**
>
> Description: This property indicates the volume level that, when 
> equalled or exceeded, the MP considers the associated 
> termination/stream to be the active speaker.
>
> Type: Integer
>
> Default: Provisioned
> How should one convert the 0 – 100 decibels to the above scale? It 
> seems to us that 100 decibels is a very high level.
>
> Thanks,
>
> *//**/Nurit Shenhar/*
>
> /H.248&MGCP Team Leader/
>
> **
>
> *** *
>
> ___www.audiocodes.com_ <http://www.audiocodes.com/>
>
> ------------------------------------------------------------------------
>