Subject: [Megaco] Reg contextAttrDescriptor Structure Difference between TEXT and ASN Modes

From: "Arvind Charanyan" <[email-masked]>
Date: Wed, 30 May 2007 16:30:08 +0530

Hi,

I have a doubt regarding the implementation of the contextAttrDescriptor
in TEXT Mode. 

The ABNF definition for contextAttrDescriptor is as follows - 

contextAttrDescriptor = ContextAttrToken LBRKT (contextIdList /
propertyParm *(COMMA propertyParm)) RBRKT

which means it is a choice between contextIDList and propertyparm.

But according to ASN Grammar, the ContextRequest is defined as follows -

ContextRequest                      ::= SEQUENCE

{

             priority
INTEGER(0..15) OPTIONAL,

             emergency                                           BOOLEAN
OPTIONAL,

             topologyReq
SEQUENCE OF TopologyRequest OPTIONAL,

             ...,

             iepscallind
BOOLEAN OPTIONAL,

             contextProp
SEQUENCE OF PropertyParm OPTIONAL,

             contextList
SEQUENCE OF ContextID OPTIONAL

}

In this PropertyParm and ContextIDList are part of the sequence.

Can you please help me out by clarifying this ambiguity between ABNF and
ASN Grammar?

Thanks,

Arvind

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Jisu Bhattacharya" <[email-masked]>
Date: Wed, 30 May 2007 11:15:51 -0700

Arvind,

*contextIdList / propertyParm *(COMMA propertyParm)
*
does not mean a choice between contextIdList and propertyParm. It means that
you can have 0 to one contextIdList AND 0 to infinite number of propertyParm
(covered by the *(COMMA propertyParm)). However, it requires at least one
contextIdList or propertParm to be present.

Hope this helps.

Thanks,
Jisu

On 5/30/07, Arvind Charanyan <[email-masked]> wrote:
> The ABNF definition for contextAttrDescriptor is as follows –
>
>
>
> *contextAttrDescriptor = ContextAttrToken LBRKT (contextIdList /
> propertyParm *(COMMA propertyParm)) RBRKT*
>
>
>
> But according to ASN Grammar, the ContextRequest is defined as follows –
>
>
>
> *ContextRequest                      ::= SEQUENCE*
>
> *{*
>
> *             priority
> INTEGER(0..15) OPTIONAL,*
>
> *             emergency                                           BOOLEAN
> OPTIONAL,*
>
> *             *topologyReq
> *             …,*
> *             iepscallind
> BOOLEAN OPTIONAL,*
> *             contextProp                                         SEQUENCE
> OF PropertyParm OPTIONAL,*
>
> *             contextList
> SEQUENCE OF ContextID OPTIONAL*
>
> *}*
>
>
>

---

From: "Nguyen, An P" <[email-masked]>
Date: Wed, 30 May 2007 14:25:26 -0400

Dear Arvind,

I am trying to understand the context attribute descriptor below.

You would have 16 priority values, which are optional.

You would have emergency indicator, which are Boolean optional.

...

What is iepscallind?

Thanks,

An

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Arvind Charanyan
Sent: Wednesday, May 30, 2007 7:00 AM
To: [email-masked]
Subject: [Megaco] Reg contextAttrDescriptor Structure Difference
betweenTEXT and ASN Modes

Hi,

 

{

             priority
INTEGER(0..15) OPTIONAL,

             emergency                                           BOOLEAN
OPTIONAL,

             topologyReq

             ...,

             iepscallind
BOOLEAN OPTIONAL,

             contextProp

             contextList

}

Thanks,

Arvind

---

From: Christian Groves <[email-masked]>
Date: Thu, 31 May 2007 11:41:07 +1000

Hello An,

iepscalling is the "International Emergency preference scheme indicator" 
see ITU-T recommendation E.106.

Regards, Christian

Nguyen, An P wrote:
> …
> ------------------------------------------------------------------------
>
> *From:* [email-masked] [mailto:[email-masked]] *On 
> Behalf Of *Arvind Charanyan
> *Sent:* Wednesday, May 30, 2007 7:00 AM
> *To:* [email-masked]
> *Subject:* [Megaco] Reg contextAttrDescriptor Structure Difference 
> I have a doubt regarding the implementation of the 
> contextAttrDescriptor in TEXT Mode.
>
> * priority INTEGER(0..15) OPTIONAL,*
>
> * emergency BOOLEAN OPTIONAL,*
>
> * topologyReq SEQUENCE OF TopologyRequest OPTIONAL,*
>
> * …,*
>
> * iepscallind BOOLEAN OPTIONAL,*
>
> * contextProp SEQUENCE OF PropertyParm OPTIONAL,*
>
> * contextList SEQUENCE OF ContextID OPTIONAL*
>
> *}*
>
> Can you please help me out by clarifying this ambiguity between ABNF 
> and ASN Grammar?
>
> Thanks,
>
> Arvind
>
> ------------------------------------------------------------------------
>