Subject: [Megaco] Query regarding ServiceChangeIncomplete Flag

From: "Syed Mohd Mujahid" <[email-masked]>
Date: Fri, 20 Jul 2007 20:31:20 +0530

Hi all,

        I have the below mentioned concerns related to the usage of
ServiceChangeIncomplete (SIC) Flag.

        1.) Is the SIC flag only applicable to servicechange with method
= RESTART or is it also applicable to SC with methods = HO, FO and
Disconnect. ?

        2.) Can SIC be used for SC message on termination ID other than
ROOT?

Awaiting your ideas on these issues.

Thanks

Syed Mohd Mujahid,

Engineer,

Continuous Computing,

Bangalore.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Mon, 23 Jul 2007 13:30:10 +0200

Both question are unambiguously answered in § 7.2.8.1.10 in my understanding.
=> only Root AND only RESTART
 
-Albrecht
 
See § 7.2.8.1.10:
ITU-T Rec. H.248.1 Amendment 1 "Gateway Control Protocol: Version 3" (New)
http://www.itu.int/md/T05-SG16-070626-TD-PLEN-0394/en <BLOCKED::http://www.itu.int/md/T05-SG16-070626-TD-PLEN-0394/en> 

7.2.8.1.10   ServiceChangeIncompleteFlag

This optional flag indicates that subsequent ServiceChange Commands will be sent from the MG to the MGC indicating the state of terminations. It is only used during MG registration or restart (ServiceChange on Root with ServiceChangeMethod Restart) when the MG wants to report the entire MG and termination state to the MGC. Upon reception of this flag, the MGC shall refrain from generating commands operating on terminations other than Root to the MG. After sending the ServiceChangeIncompleteFlag in the initial registration/restart command, the MG shall send it in all subsequent ServiceChange Commands until the MG has determined that it has reported the current state of the MG and its terminations. The flag shall then be removed from the last ServiceChange Command indicating the state of the MG or its terminations. Upon the reception of this ServiceChange without the ServiceChangeIncompleteFlag, the MGC may again generate commands to the MG. When this flag is sent in an initial ServiceChange (H.248.1 Version 1) Command using the ServiceChange extension parameter "X-SC" the following is used:

Name: SIC

Type: Boolean

Possible values: ON: Flag included

NOTE - The value OFF is not required as subsequent commands will be H.248.1 Version 3 encoded.

________________________________

	From: Syed Mohd Mujahid [mailto:[email-masked]] 
	Sent: Freitag, 20. Juli 2007 17:01
	To: [email-masked]
	Subject: [Megaco] Query regarding ServiceChangeIncomplete Flag

	Hi all,

	        I have the below mentioned concerns related to the usage of ServiceChangeIncomplete (SIC) Flag.

	        1.) Is the SIC flag only applicable to servicechange with method = RESTART or is it also applicable to SC with methods = HO, FO and Disconnect. ?

	        2.) Can SIC be used for SC message on termination ID other than ROOT?

	Thanks

	Syed Mohd Mujahid,

	Engineer,

	Continuous Computing,

	Bangalore.