Subject: [Megaco] SDP Parsing at H.248

From: "Seraya Miletzki" <[email-masked]>
Date: Wed, 4 Jul 2007 19:02:25 +0300

Hi All 
 
During a test a SSW sent to the MG the following message :
 
!/1 []:2944 T=22660{C=4{MF=rtp/3{M{O{MO=RC},L{v=0
    c=IN IP4 $
    m=audio $ $ $
    a=ptime:$
    m=image $ udptl t38
    },R{v=0
    o=- 1790199449 1790199449 IN IP4 10.10.10.10
    s=-
    c=IN IP4 10.10.10.10    t=0 0
    m=audio 4350 RTP/AVP 8 101
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-15,144-159
    a=ptime:20
    a=silencesupp:off - - - -
    }}}}}
 
The MG Replies with an error on the bolded line. It has a problem with
the third $ (Choose).
The MG vendor claims that this is according the spec because of the
following : (h.248.1 Clause 7.1.8) :
When text encoding the protocol, the descriptors consist of session
descriptions as defined in SDP (RFC 2327). In session descriptions sent
from the MGC to the MG, the following exceptions to the syntax of RFC
2327 are allowed:

*            the "s = ", "t = " and "o = " lines are optional;

*            the use of CHOOSE is allowed in place of a single parameter
value; and

*            the use of alternatives is allowed in place of a single
parameter value.

And the third $ is payload type which is not  a single parameter value .

Can anyone help me clarify the issue?

thanks 

Seraya

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Wed, 4 Jul 2007 18:21:23 +0200

Are you sure that the command.request by the MGC is already correct
concerning SDP?
see When multiple session descriptions are provided in one descriptor,
the "v = " lines are required as delimiters; otherwise they are optional
in session descriptions sent to the MG. 
 
You got multiple media groups in the LD, which requiring "v=" lines as
delimiters, see 7.1.8/H.248.1.
Right?
 
Albrecht

________________________________

From: Seraya Miletzki [mailto:[email-masked]] 
Sent: Mittwoch, 4. Juli 2007 18:02
To: [email-masked]
Subject: SDP Parsing at H.248

Hi All 

 

thanks 

Seraya

---

From: "Seraya Miletzki" <[email-masked]>
Date: Wed, 4 Jul 2007 19:27:48 +0300

The command.request is what I received. It is indeed looks strange but
the parsing error I received is on the first m line. 
(maybe after the solution I will get other error)
 
Seraya

From: Schwarz Albrecht [mailto:[email-masked]] 
Sent: Wednesday, July 04, 2007 7:21 PM
To: Seraya Miletzki; [email-masked]
Subject: RE: SDP Parsing at H.248

 
Albrecht

Hi All 

 

thanks 

Seraya

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Thu, 5 Jul 2007 08:06:12 +0200

Ányway, the MGC must firstly sent a syntactically correct command request (which isn't appearently the case here), then I would start to look at possible message decoding issues).
-Albrecht 

From: Seraya Miletzki [mailto:[email-masked]] 
Sent: Mittwoch, 4. Juli 2007 18:28
To: Schwarz Albrecht; [email-masked]
Subject: RE: SDP Parsing at H.248

The command.request is what I received. It is indeed looks strange but the parsing error I received is on the first m line. 
(maybe after the solution I will get other error)
 
Seraya

Are you sure that the command.request by the MGC is already correct concerning SDP?
see When multiple session descriptions are provided in one descriptor, the "v = " lines are required as delimiters; otherwise they are optional in session descriptions sent to the MG. 
 
You got multiple media groups in the LD, which requiring "v=" lines as delimiters, see 7.1.8/H.248.1.
Right?
 
Albrecht

Hi All 

 
The MG Replies with an error on the bolded line. It has a problem with the third $ (Choose).
The MG vendor claims that this is according the spec because of the following : (h.248.1 Clause 7.1.8) :
When text encoding the protocol, the descriptors consist of session descriptions as defined in SDP (RFC 2327). In session descriptions sent from the MGC to the MG, the following exceptions to the syntax of RFC 2327 are allowed:

*            the use of CHOOSE is allowed in place of a single parameter value; and

*            the use of alternatives is allowed in place of a single parameter value.

thanks 

Seraya

---

From: Giorgos Tintikakis <[email-masked]>
Date: Thu, 05 Jul 2007 10:56:22 +0300

Hello Seraya

According to Table 6-11/H.248.39 – Media description:
*m=audio $ $ $

*is correct and corresponds to m=audio port proto fmt (request for one 
payload format)

But Albrecht is also correct,
the sdp format is not according H.248 since it includes more that media 
descriptor ("m=" line) without "v=" line as delimiter

Giorgos

Seraya Miletzki wrote:
> ------------------------------------------------------------------------
> *From:* Schwarz Albrecht [mailto:[email-masked]]
> *Sent:* Wednesday, July 04, 2007 7:21 PM
> *To:* Seraya Miletzki; [email-masked]
> *Subject:* RE: SDP Parsing at H.248
>
> the "v = " lines are required as delimiters; otherwise they are 
> optional in session descriptions sent to the MG.
> ------------------------------------------------------------------------
> *From:* Seraya Miletzki [mailto:[email-masked]]
> *Sent:* Mittwoch, 4. Juli 2007 18:02
> *To:* [email-masked]
> *Subject:* SDP Parsing at H.248
>
> Hi All
> *m=audio $ $ $*
> /When text encoding the protocol, the descriptors consist of session 
> descriptions as defined in SDP (RFC 2327). In session descriptions 
> sent from the MGC to the MG, the following exceptions to the syntax of 
> RFC 2327 are allowed:/
>
> /• the "s = ", "t = " and "o = " lines are optional;/
>
> /• the use of CHOOSE is allowed in place of a single parameter value; and/
>
> /• the use of alternatives is allowed in place of a single parameter 
> value./
>
> ------------------------------------------------------------------------
>