Subject: [Megaco] Mapping of SIP with megaco

From: "Gopalarathnam Sambasivan" <[email-masked]>
Date: Thu, 9 Aug 2007 20:19:40 +0530

Hi All,
Is there a document/standard which maps the megaco happenings with the
related SIP messages,
for a complete registartion and basic call??

orig side digits received context created -------- INVITE sent ---------->
INVITE received ---------> context created ringing

|
       SG{cg/rt} ringback tone modify<---------------180 received
-----      180 ringing <--------------------------

Some staright forward cases that are not clear
1) When the modify has to happen for providing ringing / ringback tone in
case of PRACK scenario ??
should this be PRACK and its 200 OK ???

2) When is modify the RTP be open for speech be done - 200 OK sending or
reception of ACK ???

3) How to handle re-answer scenario (called party onhook and offhook) - just
a internal treatment of timer
and then a BYE - or some SIP inbetween?

4) SDP negotiations ???????????????????????????????

Please let me know some standard for SIP-Megaco interworking and let me also
know your opinion.

Thanks & Best Regards,
Gopalarathnam.
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Thu, 09 Aug 2007 11:53:35 -0400

There's nothing available in the IETF.  The MultiService Forum (MSF) has call 
flows like this in their test case scenario documents, which unfortuantely are 
available to members only.  I don't think there are any SIP-H.248 interworking 
flows in their Interoperability Agreements, which are open to the public at 
http://www.msforum.org/techinfo/approved.shtml.

Gopalarathnam Sambasivan wrote:
> ------------------------------------------------------------------------
>

---

From: "Warren, Dan, VF-Group" <[email-masked]>
Date: Thu, 9 Aug 2007 18:35:15 +0200

Gopolarathnam
 
Not sure if this will answer all questions or if it might be a little
too specialised for you, but there has been work goin gon in 3GPP to
define a SIP-I profile for use in the mobile industry.  This has
resulted in a TR being prepared - TR 29.802 available at
http://www.3gpp.org/ftp/Specs/archive/29_series/29.802/29802-700.zip
(latest version).  This should be available publically.
 
Included in there is one side of the call flows from existing CS domain
radio interfaces into an IP capable CS domain Core network.  it shows
the Radio side signalling and identifies how this maps to SIP messages
and what is triggered on the H.248 interface to the MGW from the MSC-S
(mobile softswitch).  It also defines offer/answer model for codec
negotiation and selection and includes both originating and terminating
side signalling ladders.  From these you should be able to derive the
full call flow that you are after even if only for this specialised (but
highly applicable) call case.
 
Cheers
 
Dan

________________________________

	From: Gopalarathnam Sambasivan
[mailto:[email-masked]] 
	Sent: 09 August 2007 15:50
	To: [email-masked]
	Subject: [Megaco] Mapping of SIP with megaco

	Hi All,
	Is there a document/standard which maps the megaco happenings
with the related SIP messages,
	for a complete registartion and basic call??
	 
	orig side digits received context created -------- INVITE sent
----------> INVITE received ---------> context created ringing
	
|
	       SG{cg/rt} ringback tone modify<---------------180
received    -----      180 ringing <--------------------------
	 
	Some staright forward cases that are not clear
	1) When the modify has to happen for providing ringing /
ringback tone in case of PRACK scenario ??
	should this be PRACK and its 200 OK ??? 
	 
	2) When is modify the RTP be open for speech be done - 200 OK
sending or reception of ACK ???
	 
	3) How to handle re-answer scenario (called party onhook and
offhook) - just a internal treatment of timer
	and then a BYE - or some SIP inbetween?

	Please let me know some standard for SIP-Megaco interworking and
let me also know your opinion.
	 
	Thanks & Best Regards,
	Gopalarathnam.

---

From: Christian Groves <[email-masked]>
Date: Fri, 10 Aug 2007 12:07:23 +1000

Hello Gopalarathnam,

You may also want to take a look at the work of ETSI Tispan WG3. They 
have produced some call flows as well as a work item discussing the 
mapping between SIP/SDP and H.248/SDP.

Regards, Christian

Gopalarathnam Sambasivan wrote:
> 1) When the modify has to happen for providing ringing / ringback tone 
> in case of PRACK scenario ??
> 2) When is modify the RTP be open for speech be done - 200 OK sending 
> or reception of ACK ???
>  
> 3) How to handle re-answer scenario (called party onhook and offhook) 
> - just a internal treatment of timer
> Please let me know some standard for SIP-Megaco interworking and let 
> me also know your opinion.
>  
> Thanks & Best Regards,
> Gopalarathnam.
>

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Fri, 10 Aug 2007 05:13:16 +0200

Hi Gopalarathnam,

you may look in particular on TISPAN work item 03080 ("RACS signalling
flows"), which illustrates the mapping between SIP-to-DIAMETER-to-H.248
(which relates to reference points Gm-to-Gq'-to-Ia in my understanding).

You may omit Gq' (in specific implementations; i.e. Diameter becomes a
node-internal interface), - and then you got direct SIP-to-H.248
mapping.

/Albrecht

http://portal.etsi.org/docbox/tispan/tispan/70-NGN-Latest-Drafts/RELEASE
1/03080-NGN-R1v110.zip

SDP Mapper:
http://portal.etsi.org/docbox/tispan/tispan/70-NGN-Latest-Drafts/RELEASE
2/03062-NGN-R2v0013.zip

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]] 
> Sent: Freitag, 10. August 2007 04:07
> To: Gopalarathnam Sambasivan
> Cc: [email-masked]
> Subject: Re: [Megaco] Mapping of SIP with megaco
> 
> Hello Gopalarathnam,
> 
> You may also want to take a look at the work of ETSI Tispan 
> WG3. They have produced some call flows as well as a work 
> item discussing the mapping between SIP/SDP and H.248/SDP.
> 
> Regards, Christian
> 
> > related SIP messages, for a complete registartion and basic call??
> >  
> received