Subject: [Megaco] telephone-event in Modify message

From: "ramesh ramesh" <[email-masked]>
Date: 26 Sep 2007 04:28:11 -0000

Hi all,

      I have a doubt. Is it possible for us to send Modify Request to Media Gateway for an ephemeral endpoint with "telephone-event"? I have given the message below.Please let me know the possibility!!

TestCase:
----------

@TCID        normal_H248-CallFlow-002.tc
@TITLE       Test a basic call tx(IP) tx(TDM)
@AUTHOR      Ernesto Abad
@TEST_PHASE  DESIGN
@KEYWORDS    H.248
@RELEASE     PCR5.1
@FEATURE_ID  CD1447 - PVG - H.248 (Megaco)

// Objective of test:
//    Test a basic call tx(IP) tx(TDM) and check end-of-call stats
//

#print Start of test : H248-CallFlow-002

// Setup the TDM connection of the near side of the call.
//
#send MG1
MEGACO/1 {var mgcMid = getMgcmId}
Transaction = {var transId = newtransid} {
	Context = $ {
		Add = STM/3/0/1/VC4VC12/1/1/1/1/1{
			Media {LocalControl {Mode = SendReceive}
}}}}
#;

#receive MG1
MEGACO/1 {var mgMid = getMgmId}
Reply = {pop transId} {
	Context = {var context} {
		Add = STM/3/0/1/VC4VC12/1/1/1/1/1
	}
}
#;

#hold added TDM near

// Setup the IP connection of the near side of the call.
//
#send MG1
MEGACO/1 {pop mgcMid}
Transaction = {var transId = newtransid} {
	Context = {pop context} {
		Add = $ {
			Media {
				O{MO=SR,RG=ON,RV=ON},
				L
				{
v=0
c=IN IP4 $
m=audio $ RTP/AVP $
a=ptime:20
		 		}
			},
			E=102{nt/netfail}
		}
	}
}
#;

#receive MG1
MEGACO/1 {pop mgMid}
Reply = {pop transId} {
	Context = {pop context} {
		Add = {var IPtermId} {
			Media {
				Local {
{var sdp = getSDP}
				}
			}
		}
	}
}
#;

#hold added IP Near

// Making the TDM far end connection.
//
#send MG1
MEGACO/1 {pop mgcMid}
Transaction = {var transId = newtransid} {
	Context = $ {
		Add = STM/3/0/1/VC4VC12/1/1/1/1/2 {
			Media {LocalControl {Mode = SendReceive}
}}}}
#;

#receive MG1
MEGACO/1 {var mgMid2 = getMgmId}
Reply = {pop transId} {
	Context = {var context2} {
		Add = STM/3/0/1/VC4VC12/1/1/1/1/2
	}
}
#;

#hold Added TDM Far

// Setup the IP connection of the far side of the call.
//
#send MG1
MEGACO/1 {pop mgcMid}
Transaction = {var transId = newtransid} {
	Context = {pop context2} {
		Add = $ {
			Media {
				LocalControl {
					Mode = SendReceive
                                },
                                Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 99 101 100
a=rtpmap:101 EVRCB/8000
a=fmtp:99 silencesupp=0
a=rtpmap:101 telephone-event/8000
a=rtpmap:100 nortel-control/8000
a=ptime:20
                                },
				Remote {
{pop sdp}
				}
                        }
                }
        }
}
#;

#receive MG1
MEGACO/1 {pop mgMid2}
Reply = {pop transId} {
	Context = {pop context2} {
		Add = {var IPtermId2} {
			Media {
				Local {
{var sdp2 = getSDP}
				}
			}
		}
	}
}
#;

#hold Add IP Far

// Tell the near end the IP address of the far end.
//

// Setup the IP connection of the far side of the call.
//
#send MG1
MEGACO/1 {pop mgcMid}
Transaction = {var transId = newtransid} {
	Context = {pop context} {
		Modify = {pop IPtermId} {
			Media {
				 Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 99 101 100
a=rtpmap:99 EVRCB/8000
a=fmtp:99 silencesupp=0
a=rtpmap:101 telephone-event/8000
a=rtpmap:100 nortel-control/8000
a=ptime:20
                                },

				Remote {
{pop sdp2}
				}
                        }
                }
        }
}
#;

#receive MG1
MEGACO/1 {pop mgMid}
Reply = {pop transId} {
	Context = {pop context} {
		Modify = {pop IPtermId} {
			Media {
				Local {
{var sdp = getSDP}
	}
}}}}
#;

#hold Display nsta/x vgs and check that a call is active and using p:10

//wait 2240
#hold before subtract ip

#send MG1
MEGACO/1 {pop mgcMid}
Transaction = {var transId = newtransid} {
         Context = {pop context} {
                 Subtract = {pop IPtermId}
         } }
#;

#receive MG1
MEGACO/1 {pop mgMid}
Reply = {pop transId} {
 	Context = {pop context} {
 		Subtract = {pop IPtermId} {
			Statistics {
				nt/dur = {var dur},
				nt/os = {var os},
				nt/or = {var or},
				rtp/ps = {var ps},
				rtp/pr = {var pr},
				rtp/pl = {var pl},
				rtp/jit = {var jit},
				rtp/delay = {var delay},
				xrtp/ct = {var ct},
				xrtp/bu = {var bu},
				xrtp/bo = {var bo},
				xrtp/tpl = {var tpl},
				xrtp/pd = {var pd},
				xrtp/ir = {var ir}
			}
		}
	}
}
#;

#print nt/dur = {pop dur}
#hold before subtract tdm

#send MG1
MEGACO/1 {pop mgcMid}
Transaction = {var transId = newtransid} {
 	Context = {pop context} {
 		Subtract = STM/3/0/1/VC4VC12/1/1/1/1/1
 	} }
#;

#receive MG1
MEGACO/1 {pop mgMid}
Reply = {pop transId} {
 	Context = {pop context} {
 		Subtract = STM/3/0/1/VC4VC12/1/1/1/1/1 {
			Statistics {
				nt/dur = {var dur},
				nt/os = {var os},
				nt/or = {var or}
			}
		}
	}
}
#;
#print nt/dur = {pop dur}, nt/os = {pop os}, nt/or = {pop or}
 
#send MG1
MEGACO/1 {pop mgcMid}
Transaction = {var transId = newtransid} {
         Context = {pop context2} {
                 Subtract = {pop IPtermId2}
         } }
#;   

#receive MG1
MEGACO/1 {pop mgMid2}
Reply = {pop transId} {
 	Context = {pop context2} {
 		Subtract = {pop IPtermId2} {
			Statistics {
				nt/dur = {var dur},
				nt/os = {var os},
				nt/or = {var or},
				rtp/ps = {var ps},
				rtp/pr = {var pr},
				rtp/pl = {var pl},
				rtp/jit = {var jit},
				rtp/delay = {var delay},
				xrtp/ct = {var ct},
				xrtp/bu = {var bu},
				xrtp/bo = {var bo},
				xrtp/tpl = {var tpl},
				xrtp/pd = {var pd},
				xrtp/ir = {var ir}
			}
		}
	}
}
#;

#print nt/dur = {pop dur}
 
//#hold Check the deletion of {pop IPtermId2} in context {pop context2}
#send MG1
MEGACO/1 {pop mgcMid} 
Transaction = {var transId = newtransid} {
 	Context = {pop context2} {
 		Subtract = STM/3/0/1/VC4VC12/1/1/1/1/2
 	} }
#;

#receive MG1
MEGACO/1 {pop mgMid2}
Reply = {pop transId} {
 	Context = {pop context2} {
 		Subtract = STM/3/0/1/VC4VC12/1/1/1/1/2 {
			Statistics {
				nt/dur = {var dur},
				nt/os = {var os},
				nt/or = {var or}
			}
		}
	}
}
#;

#print nt/dur = {pop dur}, nt/os = {pop os}, nt/or = {pop or}

#print End of test : H248-CallFlowWithStats-002  

Regards
Ramesh K

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Yogesh" <[email-masked]>
Date: Wed, 26 Sep 2007 11:57:28 +0530

Hi,
 
It is possible to send Modify Request to Media Gateway for an ephemeral
endpoint with "telephone-event"

Cheers !!!

Yogesh Pathare

Senior Engineer - Testing

A R I C E N T

Presidency Tower B

Fourth Floor 

Gurgaon , India 122001

Main     +91 1243911200 Ext 5512

  _____  

From: ramesh ramesh [mailto:[email-masked]] 
Sent: Wednesday, September 26, 2007 9:58 AM
To: [email-masked]
Subject: [Megaco] telephone-event in Modify message

Hi all,

      I have a doubt. Is it possible for us to send Modify Request to Media
Gateway for an ephemeral endpoint with "telephone-event"? I have given the
message below.Please let me know the possibility!!

TestCase:
----------

// Objective of test:

#receive MG1

#hold added TDM near

#receive MG1
MEGACO/1 {pop mgMid}
Reply = {pop transId} {

#hold added IP Near

#receive MG1

#hold Added TDM Far

#receive MG1
MEGACO/1 {pop mgMid2}
Reply = {pop transId} {

#hold Add IP Far

                    Remote {
{pop sdp2}
                    }
                        }
                }
        }
}
#;

#receive MG1
MEGACO/1 {pop mgMid}
Reply = {pop transId} {

//wait 2240
#hold before subtract ip

#send MG1
MEGACO/1 {pop mgcMid}

#receive MG1
MEGACO/1 {pop mgMid}
Reply = {pop transId} {

#send MG1
MEGACO/1 {pop mgcMid}

#receive MG1
MEGACO/1 {pop mgMid}
Reply = {pop transId} {

#send MG1
MEGACO/1 {pop mgcMid}

#receive MG1
MEGACO/1 {pop mgMid2}
Reply = {pop transId} {

#receive MG1
MEGACO/1 {pop mgMid2}
Reply = {pop transId} {

Regards
Ramesh K