Subject: [Megaco] Base root package properties

From: "Seraya Miletzki" <[email-masked]>
Date: Tue, 4 Sep 2007 12:51:14 +0300

Hi all
 
The values defined at the base root package properties are : any
positive integer. According to this 0 is also a valid value.
But, there is no meaning to 0 at this properties.
The only property that has different values is : MaxNrOfContexts. Its
default value is: 1 and up.
 
I think that the other properties should have similar definition to its
value, For example : MaxTerminationsPerContext should be 2 and up and
not just any positive integer 

Please help me clarify this issue.

Thanks

Seraya

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Tue, 4 Sep 2007 17:11:57 +0200

Hi Seraya,
 
I'm tending to disagree.
 
root package properties:
 
maxNumberOfContexts
    => no issue, 0 excluded
maxTerminationsPerContext 
    => right value range could be limited, but no issue
    [Note: there are valid services with one Termination per Context, e.g. a standalone test scenario]
normalMGExecutionTime 
    => no issue, this is implementation specific, unit is ms! 
    [Note: just think about an implementation with a normal execution time of 450 µs, which has to be rounded to 0 ms!]
normalMGCExecutionTime 
    => no issue, see above
MGProvisionalResponseTimerValue 
    => no issue, again related to a particular implementation of a network ..
MGCProvisionalResponseTimerValue 
    => no issue, see above
MGCOriginatedPendingLimit 
    => no issue, this is implicit ("sth like a flow control mechanism with a 'window size'")
MGOriginatedPendingLimit 
    => no issue, this is implicit ("sth like a flow control mechanism with a 'window size'")

Conclusion: there is a possible semantic for all seven root properties with zero as possible value.
-Albrecht

________________________________

	From: Seraya Miletzki [mailto:[email-masked]] 
	Sent: Dienstag, 4. September 2007 11:51
	To: [email-masked]
	Subject: [Megaco] Base root package properties

	Hi all
	 
	The values defined at the base root package properties are : any positive integer. According to this 0 is also a valid value.
	But, there is no meaning to 0 at this properties.
	The only property that has different values is : MaxNrOfContexts. Its default value is: 1 and up.
	 
	I think that the other properties should have similar definition to its value, For example : MaxTerminationsPerContext should be 2 and up and not just any positive integer 

	Thanks

	Seraya