Subject: [Megaco] Fwd: Active MGC is deleted

From: Ashish Singh <[email-masked]>
Date: Mon, 17 Sep 2007 12:32:23 -0700

Hi List,

I was expecting some discussion over my previous mail on this topic, but 
I didn't get any response from List, so rephrasing the question.

When configuration entity deletes the MGC that is currently active, 
should MG send FORCED service change to the MGC that got deleted before 
tearing down the association with it and then contact remaining MGCs in 
the list.

IMO, MG should NOT be sending any service change to the MGC that got 
deleted and directly contact remaining MGCs in the list.

Any response will be highly appreciated.

Thanks
Ashish

Subject: [Megaco] Active MGC is deleted
From: Ashish Singh <[email-masked]>
To: Megaco List <[email-masked]>, "[email-masked]" <[email-masked]>
Date: Wed, 12 Sep 2007 11:52:08 -0700
List-Id: Media Gateway Control <megaco.ietf.org>

Hi List,

Just wanted to take your opinion on how should MG behave when configuration entity deletes the MGC that is
currently active. MG will delete the association the with current active MGC and try to re-establish the association with remaining MGCs in the list.

One thing I am not sure is whether MG should send any service change to the MGC that got deleted before tearing down the association with it. If yes, what service change method and reason should be used.

Thanks
Ashish

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 17 Sep 2007 16:22:17 -0400

Honestly, I don't see why deletion of the active MGC would/should be
allowed.  I think that ought to be restricted in the management
software.  This will lead to a lot fewer headaches and configuration
issues, and will certainly reduce the likelihood of an outage.

Kevin 

-----Original Message-----
From: Ashish Singh [mailto:[email-masked]] 
Sent: Monday, September 17, 2007 3:32 PM
To: Megaco List
Subject: [Megaco] Fwd: Active MGC is deleted

Hi List,

Thanks
Ashish

---

From: "Deepti Singh -X \(dsingh2 - Flextronics Software at Cisco\)" <[email-masked]>
Date: Tue, 18 Sep 2007 11:05:06 +0530

I agree. Deletion of an active MGC through configuration should not be
allowed. In case it is allowed and the configuration decides to delete an
active MGC from its list, it has deliberately taken up a decision not to
contact a particular active MGC in the list and proceed to the next ones in
the list. In my opinion, no Service Change request would be needed in such a
scenario since the gateway state has not change.

Deepti

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]] 
Sent: Tuesday, September 18, 2007 1:52 AM
To: Ashish Singh; Megaco List
Subject: RE: [Megaco] Fwd: Active MGC is deleted

Honestly, I don't see why deletion of the active MGC would/should be
allowed.  I think that ought to be restricted in the management software.
This will lead to a lot fewer headaches and configuration issues, and will
certainly reduce the likelihood of an outage.

Kevin 

-----Original Message-----
From: Ashish Singh [mailto:[email-masked]]
Sent: Monday, September 17, 2007 3:32 PM
To: Megaco List
Subject: [Megaco] Fwd: Active MGC is deleted

Hi List,

I was expecting some discussion over my previous mail on this topic, but I
didn't get any response from List, so rephrasing the question.

When configuration entity deletes the MGC that is currently active, should
MG send FORCED service change to the MGC that got deleted before tearing
down the association with it and then contact remaining MGCs in the list.

IMO, MG should NOT be sending any service change to the MGC that got deleted
and directly contact remaining MGCs in the list.

Thanks
Ashish

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Tue, 18 Sep 2007 10:32:24 +0200

Some comments:
The element management systems (EMS) for the primary MGC, secondary MGCs
and associated MGs must be coordinated.
This implies activities in the management plane. 
There are further interactions between an EMS and H.248 call-independent
procedures.
E.g., the ETSI TR 183 025 V2.0.0 2007-07 has such interactions in scope.

Ashish,
"deletion of an active MGC" could mean a couple of things ("when having
also the m-plane in mind").
I would assume here that the current primary MGC, which is in in-service
state, is put into out-of-service state (via configuration mgmt). Such
an OAM activity should be accompained by other management activities in
order to achieve an efficient network operation.

E.g., your question may relate the "Disable MGC" action in clause
10.5/TR 183 025.
This TR is also recommending additional management activities:

10.5	Disable MGC
This primitive is sent to a MGC and results in a MGC being taken out of
service. 
 Prior to the MGC being disabled, it is recommended that the MGC  inform
its  dependent MGs to move their control associations to an alternative
MGC via the  MGC HANDOFF procedure (section 10.18) or that all dependent
MGs are disabled prior to diabling the MGC (section 10.4).  

-Albrecht

> From: Deepti Singh -X (dsingh2 - Flextronics Software at 
> Cisco) [mailto:[email-masked]] 
> Sent: Dienstag, 18. September 2007 07:35
> To: 'Kevin Boyle'; 'Ashish Singh'; 'Megaco List'
> I agree. Deletion of an active MGC through configuration 
> should not be allowed. In case it is allowed and the 
> configuration decides to delete an active MGC from its list, 
> it has deliberately taken up a decision not to contact a 
> particular active MGC in the list and proceed to the next 
> ones in the list. In my opinion, no Service Change request 
> would be needed in such a scenario since the gateway state 
> has not change.
> 
> Deepti
> 
> Honestly, I don't see why deletion of the active MGC 
> would/should be allowed.  I think that ought to be restricted 
> in the management software.
> This will lead to a lot fewer headaches and configuration 
> I was expecting some discussion over my previous mail on this 
> topic, but I didn't get any response from List, so rephrasing 
> the question.
> 
> When configuration entity deletes the MGC that is currently 
> active, should MG send FORCED service change to the MGC that 
> got deleted before tearing down the association with it and 
> then contact remaining MGCs in the list.
> 
> IMO, MG should NOT be sending any service change to the MGC 
> that got deleted and directly contact remaining MGCs in the list.
>

---

From: "John Wainwright" <[email-masked]>
Date: Wed, 19 Sep 2007 15:16:11 -0500

Can anyone provide an interpretation of the following digitmap setup
	"9xxx | [0-9].L"

If a user dials 9123 is a match reported immediately as per "9xxx" or
does the "[0-9].L" part force the long timer to be used before reporting
the number?

Does the "L" act as a qualifier for all digits that preceded it or is it
invalid after the "."  
If it qualifies all digits then the setup shown above will use the Long
timer for all numbers dialed won't it?

Thanks
John

---

From: 王振兴 <[email-masked]>
Date: Thu, 20 Sep 2007 13:17:27 +0800

I think "9xxx|[0-9].L" means "9xxx|[0-9]L|[0-9][0-9]L|[0-9][0-9][0-9]L|……",so 9123 also can match "[0-9][0-9][0-9][0-9]L",and still have a chance to match "[0-9][0-9][0-9][0-9][0-9]L". "9123" is not a UM for this digitmap , MG must start a long timer(because the "L")for waiting next dail number.

________________________________

From: John Wainwright [mailto:[email-masked]]
Sent: 2007-9-20 (星期四) 4:16
To: Megaco List
Subject: [Megaco] Digitmap syntax

Thanks
John