Subject: [Megaco] Description method for ADR package

From: "m.Hamada" <[email-masked]>
Date: Tue, 02 Oct 2007 18:21:38 +0900

Hi all,

I have a question about the description method of ADR
(Address Reporting package) notification.

The related parameter "nrsa" is constructed from:

> observedEvent		= [TimeStamp LWSP COLON] LWSP pkgdName [LBRKT
> 					observedEventParameter *(COMMA
> 					observedEventParameter) RBRKT]
> 
> observedEventParameter	= eventStream / eventOther
> 
> eventOther			= eventParameterName parmValue
> 
> eventParameterName	= NAME
> 
> parmValue			= (EQUAL alternativeValue / INEQUAL VALUE)
> 
> alternativeValue		= (VALUE 
> 					/ LSBRKT VALUE *(COMMA VALUE) RSBRKT
> 
> VALUE				= quotedString / 1*(SafeChar / %x80-FF)

When the parameter "nrsa" includes IPv6 address, it should be
surrounded with "DQUOTE" and "BRKT" because it has the colon ":" 
that belongs to "quotedString". However, the above method is 
not applied in the case of IPv4 address.

So, if MG specifies IPv6 address "8001::1" in nrsa, then 
the description method must be the following:

ADR/RSAC{NRSA={"8001::1"},NRSP=1111}

Is my understanding correct?

Thanks,
Kind regards

Masanori Hamada
  E-mail: [email-masked]

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Wed, 03 Oct 2007 16:13:11 +1000

Hello Masanori,

Yes your understanding is correct. As H.248.37 Amd1 is still open it may 
pay to add a note to the Amendment advising on the need to use the 
quotedstring form for IPv6 addresses.

Regards, Christian

---

From: "m.Hamada" <[email-masked]>
Date: Thu, 04 Oct 2007 10:48:33 +0900

Hi Christian,

Thank you for your clarification.
I would appreciate it if you add this notation to the Ammendment.
It will serve as a useful reference.

Thanks,
Kind regards

Masanori Hamada

On Wed, 03 Oct 2007 16:13:11 +1000

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Thu, 4 Oct 2007 08:39:35 +0200

Hi  Masanori-san,
seems to be a valid aspect, perhaps we should a V4 and V6 specific
encoding example in the adr package.
May someone of the ABNF experts community confirm the generated syntax
below, I'm not really familiar with encoding aspects.
Thanks,
Albrecht

> -----Original Message-----
> From: m.Hamada [mailto:[email-masked]] 
> Sent: Dienstag, 2. Oktober 2007 11:22
> To: [email-masked]
> Subject: [Megaco] Description method for ADR package
> 
> Hi all,
> 
> So, if MG specifies IPv6 address "8001::1" in nrsa, then the 
> description method must be the following:
>

---

From: "Elad Chomsky" <[email-masked]>
Date: Tue, 9 Oct 2007 09:49:40 +0100

Hello,

I am no ABNF expert, but I think that the example below should use
square brackets instead of curly ones. The relevant ABNF rules are:

  observedEventParameter = eventStream / eventOther
  eventOther             = eventParameterName parmValue
  eventParameterName     = NAME
  parmValue              = (EQUAL alternativeValue / INEQUAL VALUE)
  alternativeValue       = (VALUE
                           / LSBRKT VALUE *(COMMA VALUE) RSBRKT
                           ; sublist (i.e., A AND B AND ...)
                           / LBRKT VALUE *(COMMA VALUE) RBRKT
                           ; alternatives (i.e., A OR B OR ...)
                           / LSBRKT VALUE COLON VALUE RSBRKT)
                           ; range

Also, the quotedString format must always be used, based on the comment
at the beginning of Annex B.2:

  ; String: A string must use the quotedString form of VALUE and can
  ; contain anything allowable in the quotedString form.

As the nrsa's type is (currently) "sub-list of string", I think that the
below IPv6 example should be encoded as:

  ADR/RSAC{ NRSA=["8001::1"], NRSP=1111 }

And an IPv4 example should be encoded as:

  ADR/RSAC{ NRSA=["80.0.1.1"], NRSP=1111 }

Thanks,
Elad

-----Original Message-----
From: Schwarz Albrecht [mailto:[email-masked]] 
Sent: Thursday, October 04, 2007 8:40 AM
To: m.Hamada; [email-masked]
Subject: RE: [Megaco] Description method for ADR package

Hi  Masanori-san,

---

From: "m.Hamada" <[email-masked]>
Date: Thu, 11 Oct 2007 16:53:19 +0900

Hi Elad-san,

I confirmed the newest ABNF of H.248.1v3.
I agree with you on this point.

Thanks,
Kind regards

Masanori Hamada

On Tue, 9 Oct 2007 09:49:40 +0100

---

From: "Elad Chomsky" <[email-masked]>
Date: Fri, 12 Oct 2007 17:17:54 +0100

Hi Michael,

I couldn't find any specific reference to this issue in the H.248.1
standard (though I must admit I haven't spent a lot of effort looking
for one). The only mention of a sub-list I could find in Annex B/H248.1
appears in the alternativeValue rule I quoted below.

I guess this can be considered for an entry in the implementors' guide.

Thanks,
Elad

-----Original Message-----
From: Michael Dell [mailto:[email-masked]] 
Sent: Friday, October 12, 2007 5:27 PM
To: m.Hamada; Elad Chomsky
Cc: [email-masked]; Schwarz Albrecht
Subject: RE: [Megaco] Description method for ADR package

Hi there

My understanding of the ABNF is that the brackets are optional here
anyway, since the sublist only contains a single value?  That is
certainly the implication, since both nrsa and nrsp are defined as
sublists, but the example shown only has brackets around the nrsa
parameter.  I would certainly agree with Elad that if brackets are
present, they should be square brackets rather than curly brackets.

Is this correct?

Regards

Mike Dell 

-----Original Message-----
From: m.Hamada [mailto:[email-masked]] 
Sent: 11 October 2007 08:53
To: Juniper - Elad Chomsky
Cc: [email-masked]; Schwarz Albrecht
Subject: Re: [Megaco] Description method for ADR package

Hi Elad-san,

Thanks,
Kind regards

Masanori Hamada

On Tue, 9 Oct 2007 09:49:40 +0100
"Elad Chomsky" <[email-masked]> wrote:

> Also, the quotedString format must always be used, based on the 
> comment at the beginning of Annex B.2:
> 
> As the nrsa's type is (currently) "sub-list of string", I think that 
> the below IPv6 example should be encoded as:
> 

> > I have a question about the description method of ADR (Address 
> > Reporting package) notification.
> > 
> > that belongs to "quotedString". However, the above method is not 
> > applied in the case of IPv4 address.
> >

---

From: "Michael Dell" <[email-masked]>
Date: Fri, 12 Oct 2007 16:26:48 +0100

Hi there

Is this correct?

Regards

Mike Dell 

-----Original Message-----
From: m.Hamada [mailto:[email-masked]] 
Sent: 11 October 2007 08:53
To: Juniper - Elad Chomsky
Cc: [email-masked]; Schwarz Albrecht
Subject: Re: [Megaco] Description method for ADR package

Hi Elad-san,

Thanks,
Kind regards

Masanori Hamada

---

From: "m.Hamada" <[email-masked]>
Date: Mon, 15 Oct 2007 17:15:03 +0900

Hi Michael and Elad,

The Type for both nrsa and nrsp are defined as "Sub-list of xxx"
in H.248.37 Amd.1 (Ed. 0.8). So, I agree the value should be always
surrounded with SBRKT even if the related value contains a single value.
This will provide the simple implementation to MGC.

That is, the description is the following:
ADR/RSAC{ NRSA=["8001::1"], NRSP=["1111"]}

I think this has need to describe in the implementation's guide and/or 
the appropriate document as Elad suggested because ABNF has limitations 
for the applied expression.

Thanks,
Kind regards

Masanori Hamada

On Fri, 12 Oct 2007 17:17:54 +0100

---

From: Christian Groves <[email-masked]>
Date: Tue, 16 Oct 2007 11:32:45 +1000

Hello all,

So what is being proposed for the IG is effectively an addition that 
says "If the type of a property or parameter is "sub-list of XXX" and 
the property/parameter contains a single value the sub-list encoding 
shall be used." For the ABNF it means that the brackets must be used, 
for the ASN.1 encoding it means that the sublist flag must be set. Is 
this what people are proposing?

My concern is that people may have implementations that are less strict 
about policing this and we may cause problems. However I guess it we 
don't hear any objections then such an IG change may be OK.

Regards, Christian

m.Hamada wrote:
>>>>> observedEvent		= [TimeStamp LWSP COLON] LWSP 
>>>>>           
>>>> pkgdName [LBRKT
>>>>         
>>>>> parmValue			= (EQUAL alternativeValue / 
>>>>>           
>>>> INEQUAL VALUE)
>>>>         
>>>>> 					/ LSBRKT VALUE *(COMMA
>>>> VALUE) RSBRKT
>>>>> VALUE				= quotedString / 
>>>> 1*(SafeChar / %x80-FF)