Subject: [Megaco] NAT traversal in Megaco

From: "Ron Gilaad" <[email-masked]>
Date: Wed, 24 Oct 2007 20:45:54 +0200

Hi all,

The fact that RTP uses a dynamic port range makes it difficult for it to
traverse firewalls and NATs, since NAT changes the source IP and RTP
port number which has been negotiated during the SDP. In order to
overcome this problem, it is possible to use a STUN server and discover
the real port. This port can then be used during the call. Do you think
that the use of STAN server for NAT traversal is required when
implementing an MG? Or maybe it is the MGC which handle this issue by
itself?

Thanks in advance,

Ron

Ron Gilaad
RAD Data Communications.
24 Raoul Wallenberg St.
Tel Aviv 69719
Tel: 972-3-6455411 
mailto:[email-masked]

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Ashish Singh <[email-masked]>
Date: Wed, 24 Oct 2007 14:43:31 -0700

Hi Ron,

*H.248.37 (IP NAPT Traversal Package) is defined to take care of this. 
This package is having a LATCH signal, which tells MG to ignore remote 
descriptor's SDP and latch to the first RTP packet coming to the local 
IP/port chosen for the call by the MG. Later on MG uses this learned IP 
address and port as remote address for sending any RTP packet.*

You will get more info in the above mentioned  package.

Thanks
Ashish

-
Ashish Singh
Redback Networks

Ron Gilaad wrote:
>
> Hi all,
>
> The fact that RTP uses a dynamic port range makes it difficult for it 
> to traverse firewalls and NATs, since NAT changes the source IP and 
> RTP port number which has been negotiated during the SDP. In order to 
> overcome this problem, it is possible to use a STUN server and 
> discover the real port. This port can then be used during the call. Do 
> you think that the use of STAN server for NAT traversal is required 
> when implementing an MG? Or maybe it is the MGC which handle this 
> issue by itself?
>
> Thanks in advance,
>
> Ron
>
>
> Ron Gilaad
>
> RAD Data Communications.
>
> 24 Raoul Wallenberg St.
>
> Tel Aviv 69719
>
> Tel: 972-3-6455411
>
> _mailto:[email-masked]
>
>
> ------------------------------------------------------------------------
>

---

From: Christian Groves <[email-masked]>
Date: Thu, 25 Oct 2007 18:16:09 +1000

Hello Ron,

There is also work ongoing in Q.3/16 on H.248.50 "NAT Traversal Toolkit" 
packages that allow ICE/STUN etc to be used.
http://ftp3.itu.int/av-arch/avc-site/2005-2008/0706_Gen/H248_50_output.zip

Regards, Christian

Ashish Singh wrote:
> IP/port chosen for the call by the MG. Later on MG uses this learned 
> IP address and port as remote address for sending any RTP packet.*
>
>> discover the real port. This port can then be used during the call. 
>> Do you think that the use of STAN server for NAT traversal is 
>> required when implementing an MG? Or maybe it is the MGC which handle 
>> this issue by itself?
>>
>> Thanks in advance,
>>
>> Ron
>>
>>
>> Ron Gilaad
>>
>> RAD Data Communications.
>>
>> 24 Raoul Wallenberg St.
>>
>> Tel Aviv 69719
>>
>> Tel: 972-3-6455411
>>
>> _mailto:[email-masked]
>>
>>