Subject: RE: [Megaco] Difference in H248.1 V2 and V3 in the Boolean Values ofEcho cancellation property in TDMC Package

From: "Arvind Charanyan" <[email-masked]>
Date: Thu, 11 Oct 2007 12:33:01 +0530

Thanks Raphael. But I would like to know how the text message would look
like. What you have mentioned in the below mail is the different
variable names in the two encoding modes.

In case of the Text Mode, how should the string be defined. Which of the
below is the allowable values in ABNF Text Message?

1.       tdmc/ec = "True" (or) "False"

2.       tdmc/ec = "On" (or) "Off"

Regards,

Arvind  

________________________________

From: Raphael Tryster [mailto:[email-masked]] 
Sent: Thursday, October 11, 2007 11:32 AM
To: Arvind Charanyan; [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Difference in H248.1 V2 and V3 in the Boolean
Values ofEcho cancellation property in TDMC Package

I believe Albrecht addressed this in a reply to my question last year,
as follows:

=> "Error" in text encoding.

The issue behind are different variable names in ASN.1 and ABNF syntax:

ASN.1             ABNF

reserveValue      vs ReservedValue

reserveGroup      vs ReservedGroup

True              vs ON

False             vs OFF

Thus, the semantical description in the main body of H.248.1 may use
both terminology and is not consistent at all places. But this is more
historical, - a matter of fact of support of two encoding schemes. This
is a very minor problem because in the end is the syntax definitive. We
need volunteers and correspondent contributions for the IMG in order to
make the text 100% consistent.

Albrecht

________________________________

From: Arvind Charanyan [mailto:[email-masked]] 
Sent: Thursday, October 11, 2007 7:32 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Megaco] Difference in H248.1 V2 and V3 in the Boolean Values
ofEcho cancellation property in TDMC Package

Hi,

In the case of TDMC Package, the Boolean values of the Echo Cancellation
property vary in H248.1 V2 and V3 specs.

In case of H248.1 V2, the values defined are tdmc/ec = "on" and "off",
whereas in case of H248.1 V3, the values defined are tdmc/ec = "True"
and "False".

Since both the specs mention the version of the package to be Version 1,
I presume that the values that can be defined for tdmc/ec shall be
"True" and "False" irrespective of the MEGACO version used.

Please let me know if my view on this issue is correct.

Thanks and Regards,

Arvind 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Raphael Tryster" <[email-masked]>
Date: Thu, 11 Oct 2007 09:17:07 +0200

I believe Albrecht's reply makes it clear that option 2 is correct for
ABNF.

Raphael Tryster

From: Arvind Charanyan [mailto:[email-masked]] 
Sent: Thursday, October 11, 2007 9:03 AM
To: Raphael Tryster; [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Difference in H248.1 V2 and V3 in the Boolean
Values ofEcho cancellation property in TDMC Package

Regards,

Arvind  

ASN.1             ABNF

True              vs ON

False             vs OFF

Albrecht

Hi,

Thanks and Regards,

Arvind

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Thu, 11 Oct 2007 09:42:35 +0200

right, option 1 (on/off). option 2 is syntactically incorrect in text
mode. The ABNF-based parsing must fail.

	From: Raphael Tryster [mailto:[email-masked]] 
	Sent: Donnerstag, 11. Oktober 2007 09:17
	To: Arvind Charanyan; [email-masked]
	Cc: Schwarz Albrecht
	Subject: RE: [Megaco] Difference in H248.1 V2 and V3 in the
Boolean Values ofEcho cancellation property in TDMC Package

	I believe Albrecht's reply makes it clear that option 2 is
correct for ABNF.

	Raphael Tryster

	From: Arvind Charanyan [mailto:[email-masked]] 
	Sent: Thursday, October 11, 2007 9:03 AM
	To: Raphael Tryster; [email-masked]
	Cc: [email-masked]
	Subject: RE: [Megaco] Difference in H248.1 V2 and V3 in the
Boolean Values ofEcho cancellation property in TDMC Package

	Thanks Raphael. But I would like to know how the text message
would look like. What you have mentioned in the below mail is the
different variable names in the two encoding modes.

	In case of the Text Mode, how should the string be defined.
Which of the below is the allowable values in ABNF Text Message?

	Regards,

	Arvind  

	From: Raphael Tryster [mailto:[email-masked]] 
	Sent: Thursday, October 11, 2007 11:32 AM
	To: Arvind Charanyan; [email-masked]
	Cc: [email-masked]
	Subject: RE: [Megaco] Difference in H248.1 V2 and V3 in the
Boolean Values ofEcho cancellation property in TDMC Package

	I believe Albrecht addressed this in a reply to my question last
year, as follows:

	The issue behind are different variable names in ASN.1 and ABNF
syntax:

	ASN.1             ABNF

	True              vs ON

	False             vs OFF

	Thus, the semantical description in the main body of H.248.1 may
use both terminology and is not consistent at all places. But this is
more historical, - a matter of fact of support of two encoding schemes.
This is a very minor problem because in the end is the syntax
definitive. We need volunteers and correspondent contributions for the
IMG in order to make the text 100% consistent.

	Albrecht

	Subject: [Megaco] Difference in H248.1 V2 and V3 in the Boolean

	Hi,

	In the case of TDMC Package, the Boolean values of the Echo
Cancellation property vary in H248.1 V2 and V3 specs.

	In case of H248.1 V2, the values defined are tdmc/ec = "on" and
"off", whereas in case of H248.1 V3, the values defined are tdmc/ec =
"True" and "False".

	Since both the specs mention the version of the package to be
Version 1, I presume that the values that can be defined for tdmc/ec
shall be "True" and "False" irrespective of the MEGACO version used.

	Thanks and Regards,

	Arvind

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Fri, 12 Oct 2007 10:54:26 +0200

Mea Culpa.
Sorry, meant option 2.

	From: Raphael Tryster [mailto:[email-masked]] 
	Sent: Donnerstag, 11. Oktober 2007 10:09
	To: Schwarz Albrecht
	Subject: RE: [Megaco] Difference in H248.1 V2 and V3 in the
Boolean Values ofEcho cancellation property in TDMC Package

	I think you reversed 1 and 2.

Raphael Tryster
Project Manager

Direct: +972 9 9703706
Fax: +972 9 9558318
[email-masked]
www.vocaltec.com

	Expanding   the   Borders   of   VoIP

	From: Schwarz Albrecht
[mailto:[email-masked]] 
	Sent: Thursday, October 11, 2007 9:43 AM
	To: Raphael Tryster; Arvind Charanyan; [email-masked]
	Subject: RE: [Megaco] Difference in H248.1 V2 and V3 in the
Boolean Values ofEcho cancellation property in TDMC Package

	right, option 1 (on/off). option 2 is syntactically incorrect in
text mode. The ABNF-based parsing must fail.

		From: Raphael Tryster
[mailto:[email-masked]] 
		Sent: Donnerstag, 11. Oktober 2007 09:17
		To: Arvind Charanyan; [email-masked]
		Cc: Schwarz Albrecht
		Subject: RE: [Megaco] Difference in H248.1 V2 and V3 in
the Boolean Values ofEcho cancellation property in TDMC Package

		I believe Albrecht's reply makes it clear that option 2
is correct for ABNF.

		Raphael Tryster

		From: Arvind Charanyan
[mailto:[email-masked]] 
		Sent: Thursday, October 11, 2007 9:03 AM
		To: Raphael Tryster; [email-masked]
		Cc: [email-masked]
		Subject: RE: [Megaco] Difference in H248.1 V2 and V3 in
the Boolean Values ofEcho cancellation property in TDMC Package

		Thanks Raphael. But I would like to know how the text
message would look like. What you have mentioned in the below mail is
the different variable names in the two encoding modes.

		In case of the Text Mode, how should the string be
defined. Which of the below is the allowable values in ABNF Text
Message?

		Regards,

		Arvind  

		From: Raphael Tryster
[mailto:[email-masked]] 
		Sent: Thursday, October 11, 2007 11:32 AM
		To: Arvind Charanyan; [email-masked]
		Cc: [email-masked]
		Subject: RE: [Megaco] Difference in H248.1 V2 and V3 in
the Boolean Values ofEcho cancellation property in TDMC Package

		I believe Albrecht addressed this in a reply to my
question last year, as follows:

		The issue behind are different variable names in ASN.1
and ABNF syntax:

		ASN.1             ABNF

		True              vs ON

		False             vs OFF

		Thus, the semantical description in the main body of
H.248.1 may use both terminology and is not consistent at all places.
But this is more historical, - a matter of fact of support of two
encoding schemes. This is a very minor problem because in the end is the
syntax definitive. We need volunteers and correspondent contributions
for the IMG in order to make the text 100% consistent.

		Albrecht

		From: Arvind Charanyan
[mailto:[email-masked]] 
		Sent: Thursday, October 11, 2007 7:32 AM
		To: [email-masked]
		Cc: [email-masked]
		Subject: [Megaco] Difference in H248.1 V2 and V3 in the
Boolean Values ofEcho cancellation property in TDMC Package

		Hi,

		In the case of TDMC Package, the Boolean values of the
Echo Cancellation property vary in H248.1 V2 and V3 specs.

		In case of H248.1 V2, the values defined are tdmc/ec =
"on" and "off", whereas in case of H248.1 V3, the values defined are
tdmc/ec = "True" and "False".

		Since both the specs mention the version of the package
to be Version 1, I presume that the values that can be defined for
tdmc/ec shall be "True" and "False" irrespective of the MEGACO version
used.

		Thanks and Regards,

		Arvind