Subject: [Megaco] Reason Text in Service Change Reason

From: "Shashank Taneja" <[email-masked]>
Date: Wed, 3 Oct 2007 17:01:31 +0530

Hi All,

I would like some clarification on the Text String in Service Change
Reason. 

For the reasons specified in H.248.8, is it mandatory to comply with the
case specified in the reason name string?

OR is it legal to specify the reason string in any case combination as
long as the words are matching?

I would appreciate your feedback on this.

Thanks

Shashank

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Deepak Bissa PNGN <[email-masked]>
Date: Wed, 3 Oct 2007 17:24:36 +0530

Hi Shashank,

Please refer to H.248.1(V3) Annex B.2 - "Everything in the ABNF and text encoding is case insensitive".

So you can specify the reason string in any case combination as long as the words are matching.

With Regards,
Deepak Bissa

-----"Shashank Taneja" <[email-masked]> wrote: -----

To: <[email-masked]>
From: "Shashank Taneja" <[email-masked]>
Date: 10/03/2007 01:31PM
Subject: [Megaco] Reason Text in Service Change Reason

Hi All,

I would like some clarification on the Text String in Service Change Reason.

For the reasons specified in H.248.8, is it mandatory to comply with the case specified in the reason name string?

OR is it legal to specify the reason string in any case combination as long as the words are matching?

Thanks

Shashank

*****Aricent-Restricted *****=

"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of
the individual to whom it is addressed. It may contain privileged or confidential information and should not be
circulated or used for any purpose other than for what it is intended. If you have received this message in error,
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for
loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: "Shashank Taneja" <[email-masked]>
Date: Wed, 3 Oct 2007 18:02:54 +0530

Hi Deepak,

Thanks for you response. 

I'm aware of the case insensitivity of ABNF. But would it be legal to
change the case of a predefined reason text (in H.248.8). Is that
allowed? This is the specific issue I would like to clarify.

Regards,

Shashank

________________________________

From: Deepak Bissa PNGN [mailto:[email-masked]] 
Sent: Wednesday, October 03, 2007 5:25 PM
To: Shashank Taneja
Cc: [email-masked]
Subject: Re: [Megaco] Reason Text in Service Change Reason

Hi Shashank,

Please refer to H.248.1(V3) Annex B.2 - "Everything in the ABNF and text
encoding is case insensitive".

So you can specify the reason string in any case combination as long as
the words are matching.

With Regards,
Deepak Bissa

To: <[email-masked]>

Hi All,

Thanks 

Shashank 

"DISCLAIMER: This message is proprietary to Aricent  and is intended
solely for the use of 
the individual to whom it is addressed. It may contain privileged or
confidential information and should not be 
circulated or used for any purpose other than for what it is intended.
If you have received this message in error, 
please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of
this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by
this email including damage from virus."

---

From: Deepak Bissa PNGN <[email-masked]>
Date: Wed, 3 Oct 2007 18:24:23 +0530

Hi Shashank,

In H.248.8-200203, you can refer to section 4.1 which says that "Parameters included in the error text shall be coded according to the principles as specified in Annexes A or B/H.248.1."

Because the Annex A/H.248.1 says about case insensitive behaviour as one of the principle of text encoding, so it should be allowed to change the case of error text as per my understanding.

With Regards,
Deepak Bissa

To: Deepak Bissa PNGN/HSS@HSS
From: "Shashank Taneja" <[email-masked]>
Date: 10/03/2007 02:32PM
cc: <[email-masked]>
Subject: RE: [Megaco] Reason Text in Service Change Reason

Hi Deepak,

Thanks for you response.

I?m aware of the case insensitivity of ABNF. But would it be legal to change the case of a predefined reason text (in H.248.8). Is that allowed? This is the specific issue I would like to clarify.

Regards,

Shashank

Hi Shashank,

Please refer to H.248.1(V3) Annex B.2 - " Everything in the ABNF and text encoding is case insensitive ".

With Regards,
Deepak Bissa

-----" Shashank Taneja " <[email-masked]> wrote: -----

To: < [email-masked] >
From: " Shashank Taneja " <[email-masked]>
Date: 10/03/2007 01:31PM
Subject: [Megaco] Reason Text in Service Change Reason

Hi All,

Thanks

Shashank