Subject: [Megaco] Significance of 'KeepActive' during sequential signal playout

From: "Deepika Mittal" <[email-masked]>
Date: Thu, 4 Oct 2007 12:12:51 +0530

Hi All,
 
What is the significance of KeepActive flag while sending sequential
signals.
 
I am playing sequential signals in the following manner :
 
Signals{dg/d1{keepActive}, an/apf{an =1}}

Kindly let me know the behavior with and without KeepActive applied to the
DTMF signal.

Regards,
Deepika  
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Ashish Singh <[email-masked]>
Date: Thu, 04 Oct 2007 11:51:07 -0700

Refer the following excerpt from RFC section <7.1.11 Signals descriptor>

"Multiple signals and sequential signal lists in the same SignalsDescriptor shall be played simultaneously."

"Signals present in the replacement descriptor and containing the
   KeepActive flag shall be continued if they are currently playing and
   have not already completed.  If a replacement signal descriptor
   contains a signal that is not currently playing and contains the
   KeepActive flag, that signal SHALL be ignored. "

So both dg/d1 and an/apf will be played simultaneously and not sequentially. If you want them to be 
played simultaneously, use sequential signal list instead.

If dg/d1 doesn't contain keepactive:
- MG will start dg/d1 signal, if dg/d1 is not already being played
- MG will stop and restart dg/d1 signal, if dg/d1 is already being played

If dg/d1 does contain keepactive:
- MG will ignore it, if dg/d1 is not already being played
- MG will not interrupt it, if dg/d1 is already being played

Hope it clarifies.

-Ashish

Deepika Mittal wrote:
> Kindly let me know the behavior with and without KeepActive applied to 
> the DTMF signal.
>  
>  
> Regards,
> Deepika  
> ------------------------------------------------------------------------
>

---

From: Ashish Singh <[email-masked]>
Date: Thu, 04 Oct 2007 12:27:22 -0700

If you meant that the signals are present in sequential signal list 
(though the syntax of the signal desc is not reflecting that), you can 
refer following old mail thread. It talks about significance of 
different signals level parameters when they are present within a 
sequential signal list.

http://www1.ietf.org/mail-archive/web/megaco/current/msg03994.html

-Ashish

Ashish Singh wrote:
> "Multiple signals and sequential signal lists in the same 
> SignalsDescriptor shall be played simultaneously."
>
> So both dg/d1 and an/apf will be played simultaneously and not 
> sequentially. If you want them to be played simultaneously, use 
> sequential signal list instead.
>
>> Kindly let me know the behavior with and without KeepActive applied 
>> to the DTMF signal.
>>  
>>  
>> Regards,
>> Deepika