Subject: [Megaco] Megaco digitmap

From: Ramesh Babu Kuppili <[email-masked]>
Date: Mon, 03 Dec 2007 14:59:48 +0530

Hi all,
 
Please let me know the interpretation of 
 
[0-9EF].L
 
in Megaco digitmap.
 
- ramesh
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Ramesh Babu Kuppili <[email-masked]>
Date: Tue, 04 Dec 2007 00:32:04 +0530

Thanks for the clarification.  So E is for '#' and F is for '*' ?  Is there a RFC that maps these?
 
Thanks once again.
 
- ramesh

 _____ 
From: John Wainwright [mailto:[email-masked]] Sent: Monday, December 03, 2007 11:25 PMTo: Ramesh Babu Kuppili; [email-masked]: RE: [Megaco] Megaco digitmap

To me this means that any of the digits 0-9, # and * are 'expected' and that the Long timer is applied after every digit is dialed.

My apologies if this interpretation is incorrect.

Regards

John

 _____ 

From: Ramesh Babu Kuppili [mailto:[email-masked]] Sent: Monday, December 03, 2007 3:30 AMTo: [email-masked]: [Megaco] Megaco digitmap

Hi all,

[0-9EF].L

in Megaco digitmap.

- ramesh

---

From: "Sriram Yagnaraman \(WT01 - TES-Mobility & Carrier Infrastructure\)" <[email-masked]>
Date: Mon, 3 Dec 2007 14:19:20 -0500

Hi Ramesh,

I think [0-9EF].L means, any number (including zero digits) of digits (from
0 to 9, E = * and F = #) followed by a long digit time out. You could check
out H.248.1 Annex E.6 DTMF Detection Package.

Regards,

Sriram

Phone: 919-905-0184 (ESN: 355)

-----Original Message-----
From: Ramesh Babu Kuppili [mailto:[email-masked]] 
Sent: Monday, December 03, 2007 2:02 PM
To: John Wainwright; [email-masked]
Subject: RE: [Megaco] Megaco digitmap

Thanks for the clarification.  So E is for '#' and F is for '*' ?  Is there
a RFC that maps these?

Thanks once again.

- ramesh

  _____  

From: John Wainwright [mailto:[email-masked]] 
Sent: Monday, December 03, 2007 11:25 PM
To: Ramesh Babu Kuppili; [email-masked]
Subject: RE: [Megaco] Megaco digitmap

To me this means that any of the digits 0-9, # and * are 'expected' and that
the Long timer is applied after every digit is dialed.

Regards

John

  _____  

From: Ramesh Babu Kuppili [mailto:[email-masked]] 
Sent: Monday, December 03, 2007 3:30 AM
To: [email-masked]
Subject: [Megaco] Megaco digitmap

Hi all,

[0-9EF].L

in Megaco digitmap.

- ramesh

---

From: "John Wainwright" <[email-masked]>
Date: Mon, 3 Dec 2007 11:54:39 -0600

To me this means that any of the digits 0-9, # and * are 'expected' and
that the Long timer is applied after every digit is dialed.

Regards

John

________________________________

Hi all,

[0-9EF].L

in Megaco digitmap.

- ramesh

---

From: "John Wainwright" <[email-masked]>
Date: Mon, 3 Dec 2007 13:14:39 -0600

Check out the digitmap example in 7.1.14.9 of the V2 document.  Also,
the DTMF generator/detection packages details.

From: Ramesh Babu Kuppili [mailto:[email-masked]] 
Sent: Monday, December 03, 2007 1:02 PM
To: John Wainwright; [email-masked]
Subject: RE: [Megaco] Megaco digitmap

Thanks for the clarification.  So E is for '#' and F is for '*' ?  Is
there a RFC that maps these?

Thanks once again.

- ramesh

	From: John Wainwright
[mailto:[email-masked]] 
	Sent: Monday, December 03, 2007 11:25 PM
	To: Ramesh Babu Kuppili; [email-masked]
	Subject: RE: [Megaco] Megaco digitmap

	To me this means that any of the digits 0-9, # and * are
'expected' and that the Long timer is applied after every digit is
dialed.

	Regards

	John

	Hi all,

	[0-9EF].L

	in Megaco digitmap.

	- ramesh

---

From: "John Wainwright" <[email-masked]>
Date: Mon, 3 Dec 2007 13:16:32 -0600

By the way I believe that E=* and F=# 

Thanks once again.

- ramesh

	From: John Wainwright

	Regards

	John

	Hi all,

	[0-9EF].L

	in Megaco digitmap.

	- ramesh

---

From: "Yanssen, Rodrigo Duarte" <[email-masked]>
Date: Mon, 3 Dec 2007 17:29:30 -0200

Follow ITU-T H.248.1 Annex 4, 5 and 6 you can find the packets related
with this mapping.

Signal name SignalID/Tone ID

DTMF character 0 d0 (0x0010)

DTMF character 1 d1 (0x0011)

DTMF character 2 d2 (0x0012)

DTMF character 3 d3 (0x0013)

DTMF character 4 d4 (0x0014)

DTMF character 5 d5 (0x0015)

DTMF character 6 d6 (0x0016)

DTMF character 7 d7 (0x0017)

DTMF character 8 d8 (0x0018)

DTMF character 9 d9 (0x0019)

DTMF character * ds (0x0020)

DTMF character # do (0x0021)

DTMF character A da (0x001a)

DTMF character B db (0x001b)

DTMF character C dc (0x001c)

DTMF character D dd (0x001d)

And these Signals ID that have a Tone ID related, is correlated with
other table where you can translate these Tone ID in Digits:

DTMF Event Symbol

d0 "0"

d1 "1"

d2 "2"

d3 "3"

d4 "4"

d5 "5"

d6 "6"

d7 "7"

d8 "8"

d9 "9"

da "A" or "a"

db "B" or "b"

dc "C" or "c"

dd "D" or "d"

ds "E" or "e"

do "F" or "f"

So The Digit * is mapping to DS that is mapping to "E or e" and the
Digit # to DO that is mapping to "F or f".

Take care which event you are using in your Network, DD/CE or DD/STD,
because each one can result in each table above.

Best Regards.

___________________________

Rodrigo Yanssen

Nokia Siemens Network

Phone:  +55-11-3908-3527

Mobile: +55-11-8674-3537 (New)

From: Ramesh Babu Kuppili [mailto:[email-masked]] 
Sent: segunda-feira, 3 de dezembro de 2007 17:02
To: John Wainwright; [email-masked]
Subject: RE: [Megaco] Megaco digitmap

Thanks once again.

- ramesh

	From: John Wainwright

	Regards

	John

	Hi all,

	[0-9EF].L

	in Megaco digitmap.

	- ramesh

________________________________________
Important notice: This e-mail and any attachment thereof contains corporate proprietary information. If you have received it by mistake, please notify us immediately by reply e-mail and delete this e-mail and its attachments from your system. Thank you. For alternate languages please go to http://www.siemens.com.ar/disclaimer/