Subject: [Megaco] Question about omitting the "strict" parameter from the Events Descriptor

From: "Beis, Grigoris" <[email-masked]>
Date: Wed, 12 Dec 2007 12:59:32 +0200

Hello,

My question has to do with the optional Events Descriptor parameters in
case of al/on and al/of events.

For the al/on and al/of events, the only EventDescriptor parameter that
can be reported is the "strict" parameter and according to H.248 this
parameter is optional. I was wondering if there is a default action
specified when this optional parameter is omitted. For example, in case
where the actual status of the line is on-hook where would the following
request E=1050367{AL/ON, AL/OF} from the MGC side lead? Would it lead to
a Notify(al/on{init=true}) report from the MG side or not?

Can one say from protocol point of view that the "strict=state" or the
"strict=exact" case is the same as not reporting the strict parameter at
all? I know that this is not mentioned in H.248.1 Annex E.9.2.

Many thanks in advance,

Greg

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Raphael Tryster" <[email-masked]>
Date: Thu, 13 Dec 2007 08:21:13 +0200

I am not sure, but I have seen an MGC that apparently assumed that the
default is "strict=exact", as it requested al/*.  If the default were
"state", such a request would always result in an immediate
notification, and if it were "failwrong", the request would always fail.
 
Raphael Tryster
 
-----Original Message-----
From: Beis, Grigoris [mailto:[email-masked]] 
Sent: Wednesday, December 12, 2007 1:00 PM
To: [email-masked]
Subject: [Megaco] Question about omitting the "strict" parameter from
theEvents Descriptor
 
Hello,

 
 
Many thanks in advance,
Greg
 
**********************************************************************************************
IMPORTANT: The contents of this email and any attachments are confidential. They are intended for the 
named recipient(s) only.
If you have received this email in error, please notify the system manager or the sender immediately and do 
not disclose the contents to anyone or make copies thereof.
*** eSafe scanned this email for viruses, vandals, and malicious content. ***
**********************************************************************************************

---

From: "Raphael Tryster" <[email-masked]>
Date: Thu, 13 Dec 2007 09:04:42 +0200

Overlooked this before; here is a definite answer to your question.
 
-----Original Message-----
From: Stephen Mell (CV/ETL) [mailto:[email-masked]] 
Sent: Friday, April 20, 2007 7:57 PM
To: Dmitry Pavlenko; karthik prabhu Balakrishnan
Cc: [email-masked]
Subject: RE: [Megaco] doubt on Originating and Terminating Suntract
 
Correction on last point.
 
In H.248v3 Annex E the default for the al/on, al/off strict parameter is
now given as "exact", however it was missing from H.248v2
So if you working in v2 it's a good idea for MGC to specify the value of
the strict parameter (treat as mandatory).
 
Steve 

 
-----Original Message-----
From: Beis, Grigoris [mailto:[email-masked]] 
Sent: Wednesday, December 12, 2007 1:00 PM
To: [email-masked]
Subject: [Megaco] Question about omitting the "strict" parameter from
theEvents Descriptor
 
Hello,

 
 
Many thanks in advance,
Greg