Subject: [Megaco] serviceChange in context

From: "RUIKAR RAHUL A" <[email-masked]>
Date: Tue, 18 Dec 2007 08:06:41 +0100

Hi,

I have query regarding Service change received from termination which is
in context.

When ServiceChange is received from any termination from context with
reason "taken out of service"

1)       Should MGC reply that ServiceChange in Context or in NULL
context..?

2)       Whether gateway will accept ServiceChange reply with context?
Since termination is taken out of service it should not accept any
traffic.

3)       I mean what will be the exact state of termination after
sending this particular ServiceChange.

Thanks in Advance.

Regards,

Rahul Ruikar

Alcatel-Lucent

Email: [email-masked]

Alcanet: 2721 4793

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Ashish Singh <[email-masked]>
Date: Mon, 17 Dec 2007 23:23:52 -0800

Rahul,

Pls. find my answers inline.

Thanks
Ashish

RUIKAR RAHUL A wrote:
>
> Hi,
>
> I have query regarding Service change received from termination which 
> is in context.
>
> reason “taken out of service”
>
> 1) Should MGC reply that ServiceChange in Context or in NULL context..?
>
After sending OOS Servicechange, termination will still be in context 
until MGC subtract it. So MGC shall send response in context only.
>
> 2) Whether gateway will accept ServiceChange reply with context? Since 
> termination is taken out of service it should not accept any traffic.
>
YES, MG shall accept the command.
>
> 3) I mean what will be the exact state of termination after sending 
> this particular ServiceChange.
>
state will be out-of-service.
> <mailto:[email-masked]>
>
> Alcanet: 2721 4793
>
> ------------------------------------------------------------------------
>

---

From: "RUIKAR RAHUL A" <[email-masked]>
Date: Tue, 18 Dec 2007 08:34:46 +0100

But it should not accept any traffic messages (commands ) after that
since it's state is "out of service"
Am I correct..?

Regards,
Rahul Ruikar
Alcatel-Lucent
-----Original Message-----
From: Ashish Singh [mailto:[email-masked]] 
Sent: Tuesday, December 18, 2007 12:54 PM
To: RUIKAR RAHUL A
Cc: [email-masked]
Subject: Re: [Megaco] serviceChange in context

Rahul,

Thanks
Ashish

context..?

---

From: "Yogesh" <[email-masked]>
Date: Tue, 18 Dec 2007 13:27:57 +0530

Hi,
 
As per my understanding, It is implementation specific,
 
If you do "Termination taken out of service" at line level,
MGC will reply that service change in NULL as well as on *
 
At DS0 level it may reply in the same context as described by Ashish. 
 
============================================================================
===================================

[10.202.2.206]:5555 [283872699 (10 ms)] !/2 <Yogi.com>:2999 T = 260{ C = -
{sc=PT/1/*  { sv { mt = fo , re = "905 Termination taken out of service" }
} }}
 
[10.202.2.206]:5555 [283872699 (10 ms)] !/2 <Yogi.com>:2999 T = 261{ C = *
{sc=PT/1/*  { sv { mt = fo , re = "905 Termination taken out of service" }
} }}
 
[283872718 (10 ms)] !/2 [10.202.2.206]:5555 P=260 {C=-{SC=pt/1/*}}
 
[283872737 (10 ms)] !/2 [10.202.2.206]:5555 P=261 {C=*{SC=pt/1/*}}
============================================================================
===================================

GW should accept the Service Change, It should not accept any traffic
message.
Termination will be out of service depending upon the nature of out of
service method ( Graceful or forceful ) and Call state.

Cheers !!!

Yogesh

Senior Engineer - Testing

A R I C E N T

Presidency Tower B

Fourth Floor 

Gurgaon , India 122001

Main     +91 1243911200 Ext 5512

  _____  

From: RUIKAR RAHUL A [mailto:[email-masked]] 
Sent: Tuesday, December 18, 2007 12:37 PM
To: [email-masked]
Subject: [Megaco] serviceChange in context

Hi,

I have query regarding Service change received from termination which is in
context.

When ServiceChange is received from any termination from context with reason
"taken out of service"

Thanks in Advance.

Regards,

Rahul Ruikar

Alcatel-Lucent

Alcanet: 2721 4793

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Tue, 18 Dec 2007 11:56:33 +0100

No, in my understanding.
See also
http://www1.ietf.org/mail-archive/web/megaco/current/msg07630.html
=>
2) Any Termination may still receive H.248 Commands in ServiceState
"OoS" in my understanding.
"... and not available for traffic" means just user plane traffic in
case of a non-Root termination IMHO.

> From: RUIKAR RAHUL A 
> Sent: Dienstag, 18. Dezember 2007 08:35
> To: Ashish Singh
> Cc: [email-masked]
> Subject: RE: [Megaco] serviceChange in context
> 
> But it should not accept any traffic messages (commands ) 
> after that since it's state is "out of service"
> Am I correct..?
> 
> 
> Regards,
> Rahul Ruikar
> Alcatel-Lucent
> After sending OOS Servicechange, termination will still be in 
> context until MGC subtract it. So MGC shall send response in 
> context only.
> >