Subject: [Megaco] Megaco Subtract question

From: Ramesh Babu Kuppili <[email-masked]>
Date: Thu, 13 Dec 2007 16:32:41 +0530

Hi Megaco Gurus,
 
I am receiving the following substract message from MGC:
 
!/1 [10.129.32.20]:2944 T=372513544{C=10{O-S=*}}
I see that the MGC is trying to subtract all terms from context 10.  But what is the "0" for.  How should the response look in this case.
 
Thanks in advance.
 
- ramesh
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Sudhanshu Garg <[email-masked]>
Date: Thu, 13 Dec 2007 16:51:18 +0530

Hi,

o- is for tell the MG that i is optional command.
So even if the command fails (for any termination), MG should execute 
further commands in the transaction.

However in this case there is no further command in the transaction so 
making the command optional has no value add.

Section 8 in H.248.1 provides the information on optional commands.

For this transaction, response will be normal as for any other subtract 
command with wildcarded termination

Regards,
Sudhanshu Garg
Engineering Project Manager
 
A R I C E N T
 
The Presidency Tower - A
351 / 2, Sector 14, M. G. Road
Gurgaon 122001, Haryana, India
 
Main     +91 124. 417.6218
Fax      +91 124.417.6224
Mobile  +91 999.950.0798

Ramesh Babu Kuppili <[email-masked]> 
12/13/2007 04:32 PM

To
[email-masked]
cc

Subject
[Megaco] Megaco Subtract question

Hi Megaco Gurus,

!/1 [10.129.32.20]:2944 T=372513544{C=10{O-S=*}}
I see that the MGC is trying to subtract all terms from context 10.  But 
what is the "0" for.  How should the response look in this case.
 
Thanks in advance.
 
- ramesh_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

***********************  Aricent-Unclassified   ***********************
"DISCLAIMER: This message is proprietary to Aricent  and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Beis, Grigoris" <[email-masked]>
Date: Thu, 13 Dec 2007 13:22:06 +0200

Hello,

It is not a zero "0" but an "O" that stands for word Optional. Please
check the Transactions section (Paragraph 8) of H.248.1 

By stating Optional-Subtract, any command that could follow the Subtract
command (in your case however, there is only one command) would be
processed,

The answer is straightforward.

BR,

Greg

________________________________

From: ext Ramesh Babu Kuppili [mailto:[email-masked]] 
Sent: Thursday, December 13, 2007 1:03 PM
To: [email-masked]
Subject: [Megaco] Megaco Subtract question

Hi Megaco Gurus,

Thanks in advance.

- ramesh