Subject: [Megaco] SDP in H248 v/s Megaco

From: atul garg <[email-masked]>
Date: Tue, 29 Jul 2008 15:41:04 +0530 (IST)

Hi,

Can someone help me with the following doubts in H.248?

1. As per my understanding ,in H.248, when the MG1 indicates to MGC (via off hook) that it wants to communicate to MG2, MGC sends an ADD Request to MG1. MG1 creates a context and Ephemereal TerminationID and allocates resources for the same. It sends this information (about media resources i.e. IP and port) to the MGC in SDP in its Local Descriptor. MGC conveys this information to MG2 via SDP’s Remote descriptor when it sends the ADD Request to MG2. MG2, in turn, allocates the resources and conveys its IP and port for communication in the ADD Reply’s SDP (Local Descriptor), which is then passed to MG1.So, whenever SDP is used to convey the connection information, it is done in the Local and Remote descriptors. 

Now the question is what is the use of tunneling SDP information in Signal and ObservedEvent Descriptor?
 
I have a large amount of network traffic, and in all the buffers, SDP information NEVER comes in Media descriptor’s local and remote. It always comes tunneled in Signal and ObservedEvent descriptors. So, can I somehow use this tunneled SDP information instead of local and remote descriptors? 

2. As per the protocol, every ADD request from MGC to MG should contain two ADD commands: 
(i)	Create a context and ADD a well-defined physical termination to it. 
(ii)	Create an Ephemereal Termination, allocate IP and port and add it to the context created in (i).
   According to this, every buffer containing ADD request must have two ADD commands. However, in H.248 traffic, I have observed that the request to add physical termination is not present along with the request for creating an ephemereal termination. Can someone explain the reason why this could be happening?

3. In H.248, NOTIFY request should be sent to the physical Termination. However, in the buffers I have, NOTIFY request is sent on the Ephemereal termination. 

In MEGACO’s traffic, I have observed that:
(i)	ADD Request always contains two commands: to add physical termination and to create andadd epemereal termination.
(ii)	NOTIFY is received on the physical termination.

Then, why doesn’t the H.248 traffic conform to the requirements mentioned in the protocol?

      Bring your gang together. Do your thing. Find your favourite Yahoo! group at http://in.promos.yahoo.com/groups/
_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Tue, 29 Jul 2008 13:06:50 +0200

Atul,

which H.248 profile specification have you implemented?

There are profiles (like 3GPP H.248 Mc profile according 29.232) using
"tunneling mechanisms" for bearer control (e.g. -> IPBCP Q.1970 with
tunnel protocol Q.1990). 
[Background: The Bearer Control Tunneling Package defined in Annex A,
section A.7 of Q.1950 defines a signal and observed event parameter in
order to pass SDP between the MG and MGC.]

Thus, pls confirm whether you use such a tunnel or not.

-Albrecht 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of atul garg
> Sent: Dienstag, 29. Juli 2008 12:11
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Megaco] SDP in H248 v/s Megaco
> 
> Hi,
> 
> 1. As per my understanding ,in H.248, when the MG1 indicates 
> to MGC (via off hook) that it wants to communicate to MG2, 
> MGC sends an ADD Request to MG1. MG1 creates a context and 
> Ephemereal TerminationID and allocates resources for the 
> same. It sends this information (about media resources i.e. 
> IP and port) to the MGC in SDP in its Local Descriptor. MGC 
> conveys this information to MG2 via SDP's Remote descriptor 
> when it sends the ADD Request to MG2. MG2, in turn, allocates 
> the resources and conveys its IP and port for communication 
> in the ADD Reply's SDP (Local Descriptor), which is then 
> passed to MG1.So, whenever SDP is used to convey the 
> connection information, it is done in the Local and Remote 
> descriptors. 
> 
> Now the question is what is the use of tunneling SDP 
> information in Signal and ObservedEvent Descriptor?
>  
> I have a large amount of network traffic, and in all the 
> buffers, SDP information NEVER comes in Media descriptor's 
> local and remote. It always comes tunneled in Signal and 
> ObservedEvent descriptors. So, can I somehow use this 
> tunneled SDP information instead of local and remote descriptors? 
> 
> (ii)	Create an Ephemereal Termination, allocate IP and port 
> and add it to the context created in (i).
>    According to this, every buffer containing ADD request 
> must have two ADD commands. However, in H.248 traffic, I have 
> observed that the request to add physical termination is not 
> present along with the request for creating an ephemereal 
> termination. Can someone explain the reason why this could be 
> happening?
> 
> 3. In H.248, NOTIFY request should be sent to the physical 
> Termination. However, in the buffers I have, NOTIFY request 
> is sent on the Ephemereal termination. 
> 
> In MEGACO's traffic, I have observed that:
> (i)	ADD Request always contains two commands: to add 
> physical termination and to create andadd epemereal termination.
> Then, why doesn't the H.248 traffic conform to the 
> requirements mentioned in the protocol?
> 
> 
> 
>       Bring your gang together. Do your thing. Find your 
> favourite Yahoo! group at http://in.promos.yahoo.com/groups/