Subject: [Megaco] Digit map syntax question

From: "Maxim Treskin" <[email-masked]>
Date: Fri, 25 Jul 2008 21:44:22 +0400

Hello

I have question about megaco digit map syntax.
Is digitmap, like "([0-9ef])" valid?
I use erlang OTP megaco stack, and it interpretes this digit map that
following numbers is valid:
"0ef", "1ef", "2ef" etc.
Is it right or there is error in megaco stack? I think that valid
number values must be:
"0", "1", "2", ..., "9", "e", "f"

Say me please, which method is right?

-- 
Maxim Treskin
_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: Sudhanshu Garg <[email-masked]>
Date: Fri, 25 Jul 2008 23:35:25 +0530

Hi,

Range (two digits separated by hyphen can be expanded into all the digits from first to last (inclusive both ends).
The digits inside square brackets represent the dialled digitmap symbol that can be given at corresponding place.

So [0-9ef] means [0123456789ef].
Therefore it represents one of the following:
"0", "1", "2", "3", "4", "5", "6", "7", "8", "9","*","#"

Regards,
Sudhanshu.
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Maxim Treskin [[email-masked]]
Sent: Friday, July 25, 2008 11:14 PM
To: [email-masked]
Subject: [Megaco]  Digit map syntax question

Hello

"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error,please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility forloss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco