Subject: [Megaco] Problem in ADD request.

From: "John Wainwright" <[email-masked]>
Date: Fri, 22 Aug 2008 11:48:13 -0500

My apologies if this is repeated but I seem to be having issues trying
to post to the Megaco list

If I get a message such as the following to create a new context and ADD
a specific termination into it 

C=${

A=AALN/1{

M{

O{MO=RC}},

SG{ALERT/RI{PATTERN=1}},

E=38463393{AL/OF{STRICT=FAILWRONG}},

}}}

What should I return for the context ID if the line is already offhook
and should the termination get added to a new context?

Should I return an error message for a specific context that was just
created with AALN/1 now in this context such as shown below, or should I
return an error message for the null context and the termination has not
been added to any context?

REPLY = 65234524 {

  CONTEXT = 5 {

    ERROR = 540 { "Unexpected initial hook state" },

    ADD = AALN/1

    }

  }

}

Thanks

John

****************************************
The information contained in this message may be confidential, privileged or protected from disclosure. If you have received it by mistake, please let us know by e-mail reply and delete it from your system; you may not copy, disseminate or disclose the contents of this message to anyone.
_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: <[email-masked]>
Date: Sat, 23 Aug 2008 01:05:30 +0530

Hi John,

I feel we should return an error with the termination in the added context. I have seen atleast one MG (Mediatrix Line GW, I believe) behave this way to an error with in an ADD command.

Thanks,
Sriram

-----Original Message-----
From: [email-masked] on behalf of John Wainwright
Sent: Fri 8/22/2008 10:18 PM
To: [email-masked]
Subject: [Megaco] Problem in ADD request.

C=${

A=AALN/1{

M{

O{MO=RC}},

SG{ALERT/RI{PATTERN=1}},

}}}

REPLY = 65234524 {

  CONTEXT = 5 {

    ADD = AALN/1

    }

  }

}

Thanks

John

---

From: "CHATURVEDI PRABUDDHA" <[email-masked]>
Date: Fri, 29 Aug 2008 07:56:09 +0200

Hi,
 
Can any one suggest what action to be taken once we receive 
SV      method = restart 
           reason  = 900" service restored"
          on a Phy termination 
          and no timer running: 
as stated in the doc H.248 "F.3.4 MG Service Restoration " -
The reason will indicate what action may be taken.
 but I find no doc or discussion on  functionality based on reasons.
 
Will the behavior include
1. subtraction of the physical termination.
or
2. The call will be preserved. 
 
Generally decision are taken based on Method "restart", hence call is
released.
 
Kindly suggest.
 
BR
Prabuddha C

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Mon, 1 Sep 2008 10:55:39 +0200

Hello Prabuddha,
 
you are right that Annex F is not going in down into more details, but I
would assume that behaviour (2) is aimed when using reason '900', which
indicates that the termination is 'InService' (IS) state again.
 
This implies that the ServiceState was before "not IS".
 
Whether the "call/session service" may be continued ("preserved") or
terminated is conditional, e.g. may
- dependent on the call phase (call establishment vs active call),
- period of "out-of-service" phase, or/and
- call service type.
 
I would assume that the general case might lead to call/bearer (or H.248
Termination) preservation, but wouldn't exclude conditions where a call
release would be a more appropriate action.
This decision is up to the MGC, - and because this H.248 entity has
exactly the knowledge about above listed conditions.
 
Such specific conditions are out of scope of Annex F/H.248.1 itself,
they could be rather detailed in H.248 profile specifications.
 
And complementary:
ETSI 183 025 call independent procedures pointing more in the direction
of (2), - and not (1) (because a SUBTRACT procedures is not indicated)
-, but would exclude the option in supporting also (1).
 
Regards,
Albrecht

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of CHATURVEDI PRABUDDHA
	Sent: Freitag, 29. August 2008 07:56
	To: [email-masked]
	Subject: [Megaco] Action to be taken on "SV Restart - Reason
900"
	Importance: High

	Hi,
	 
	 but I find no doc or discussion on  functionality based on
reasons.

	Generally decision are taken based on Method "restart", hence
call is released.
	 
	Kindly suggest.
	 
	BR
	Prabuddha C