Subject: [Megaco] Handoff initiated by new MGC

From: "Raphael Tryster" <[email-masked]>
Date: Wed, 6 Aug 2008 08:42:33 +0300

Suppose that an MG has two MGCs configured as primary and secondary, and
currently it has a control association with the primary MGC.  The two
MGCs communicate with each other in a way that allows each to detect the
failure of the other quickly, much more quickly than the MG could detect
it by retransmission timeout.  It would be efficient if the secondary
MGC, on detecting failure of the primary, could send SC Handoff to the
MG, instructing it "talk to me now".  But I believe Megaco requires the
MG to reject such a message as unauthorized.  This is really a failover
scenario, but Megaco doesn't allow it on the MGC side.

Am I overlooking something in Megaco that would allow a fast handoff /
failover?

Raphael Tryster
**********************************************************************************************
IMPORTANT: The contents of this email and any attachments are confidential. They are intended for the 
named recipient(s) only.
If you have received this email in error, please notify the system manager or the sender immediately and do 
not disclose the contents to anyone or make copies thereof.
*** eSafe scanned this email for viruses, vandals, and malicious content. ***
**********************************************************************************************

_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Wed, 6 Aug 2008 09:33:09 +0200

Raphael,

we've studied that potential MGC changeover scenario, too.
We've called it "MGC Takeover".

See 

H.248.1 Version 4 - MGC Takeover
http://ftp3.itu.ch/av-arch/avc-site/2005-2008/0801_Seo/AVD-3213.zip

or
http://www.ietf.org/mail-archive/web/megaco/current/msg07739.html

There might be good reasons for such a scenario, like a deadlock
situation on MGC level.
Or: the optimization of service/network availability performance.

-Albrecht

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Raphael Tryster
> Sent: Mittwoch, 6. August 2008 07:43
> To: [email-masked]
> Subject: [Megaco] Handoff initiated by new MGC
> 
> 
>  
> Suppose that an MG has two MGCs configured as primary and 
> secondary, and currently it has a control association with 
> the primary MGC.  The two MGCs communicate with each other in 
> a way that allows each to detect the failure of the other 
> quickly, much more quickly than the MG could detect it by 
> retransmission timeout.  It would be efficient if the 
> secondary MGC, on detecting failure of the primary, could 
> send SC Handoff to the MG, instructing it "talk to me now".  
> But I believe Megaco requires the MG to reject such a message 
> as unauthorized.  This is really a failover scenario, but 
> Megaco doesn't allow it on the MGC side.
> 
> Am I overlooking something in Megaco that would allow a fast 
> handoff / failover?
> 
> Raphael Tryster
> IMPORTANT: The contents of this email and any attachments are 
> confidential. They are intended for the named recipient(s) only.
> If you have received this email in error, please notify the 
> system manager or the sender immediately and do not disclose 
> the contents to anyone or make copies thereof.