Subject: Re: [Megaco] Context Id

From: Priya Krishnan <[email-masked]>
Date: Tue, 12 May 2009 22:55:02 -0700 (PDT)

Hi Raphael,

Thanks for your response and excellent explanation. I understand context better now. So if I am an external entity monitoring MGW and would like to know about a subscribers call/session details, then a user might have multiple context ids which must be analyzed right? So conceptually a  context is created for a user per transaction initiated by the user with diff remote physical terminations.

Thanks and regards
Geetha 

--- On Tue, 5/12/09, Raphael Tryster <[email-masked]> wrote:

> From: Raphael Tryster <[email-masked]>
> Subject: RE: [Megaco] Context Id
> To: "Priya Krishnan" <[email-masked]>, [email-masked]
> Date: Tuesday, May 12, 2009, 10:42 PM
> Hi Priya,
> 
> A termination (representing a user) can only be in one
> context at a
> time.  Typically, in a 3-party scenario, a termination
> will move between
> contexts.  Remember that when the terminations are in
> different
> gateways, the MGC will create the required contexts on each
> MG.  For
> example, suppose A, B and C are physical terminations in
> different
> gateways, and A can bounce back and forth between B and C
> by pressing
> flash.  The MGC would typically create 2 contexts on
> A's gateway, where
> each context contains an ephemeral termination, one of them
> with a
> remote descriptor pointing to B, and the other to C. 
> Each time A
> presses flash, the MGC will MOVE A's physical termination
> out of one
> context and into another.  At the same time, B's and
> C's physical
> terminations are each in their own contexts on their
> respective MGs,
> where each context also contains an ephemeral termination
> whose remote
> descriptor points to A.  As A bounces between talking
> to B and C, the
> MGC will control who hears whom by changing the Mode of
> each of the
> terminations.
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]
> On Behalf
> Of Priya Krishnan
> Sent: Wednesday, 13 May 2009 8:03 AM
> To: [email-masked]
> Subject: [Megaco] Context Id
> 
> 
> Hi All,
> 
> As a beginner in MeGaco I have one question on context ID.
> The context
> ID is not quite clear to me. Hope to get response. 
> 
> A user  can have multiple contexts right ?
> Each context indicates a particular set of related
> terminations.  For
> example, if a user is having a 3 way conf call, there are 3
> terminations
> in a context with an ID. if that user is on call waiting on
> the other
> line , he is in a different context also at the same time.
> So there are
> 2 context ids for this user at this point in time. A
> combination of
> context id, termination ID+ other info like user ID can
> recognize the
> user accurately.
> 
> Is my understanding right? Please clarify.
> 
> Thanks
> Priya
> 
> 
>       
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco
>

---

From: "Raphael Tryster" <[email-masked]>
Date: Wed, 13 May 2009 09:28:48 +0300

Depends what you mean by "transaction".  In Megaco terminology, a transaction consists of a request from MG or MGC to the other, and a reply in the opposite direction.  If you are using the term "transaction" to mean a leg of a call, e.g. the connection between subscribers A and B, then what you say will often be correct.  However, the MGC has complete freedom to decide when it needs a context and when it doesn't.  There isn't one standard way to do things.  In the 3-party example I gave below, it is typical for A switching between talking to B and C to switch between contexts.  However, it is conceivable that another MGC would put physical A and ephemerals pointing to remote B and C all in one context, and just fiddle with the mode.  Megaco just gives the MGC the tools, and the MGC can use them any way it wants to get the job done.

Regards,
Raphael

-----Original Message-----
From: Priya Krishnan [mailto:[email-masked]] 
Sent: Wednesday, 13 May 2009 8:55 AM
To: [email-masked]; Raphael Tryster
Subject: RE: [Megaco] Context Id

Hi Raphael,

Thanks and regards
Geetha