Subject: [Megaco] Uniqueness of context ID

From: Priya Krishnan <[email-masked]>
Date: Tue, 19 May 2009 22:47:03 -0700 (PDT)

Hi,

A context ID is unique within a physical MGW. But when we access a context report at MGC [example a MSS] can we identify any report at MSS using only context ID.

My thinking is since MGC connects to many MGW, it might have similar context IDs with multiple MGWs. Example there could be a context ID 2 with MGW 1 and context ID 2 with MGW 4. In that case to identify a particular context related info we might need a combination of virtual MGW address and context ID. Is this understanding right? please clarify.

Thanks and Regards
Geetha

---

From: "Raphael Tryster" <[email-masked]>
Date: Wed, 20 May 2009 08:57:59 +0300

Yes.  It is actually quite likely to occur if multiple MGs initialize at
the same time and all start assigning context IDs from 1.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Priya Krishnan
Sent: Wednesday, 20 May 2009 8:47 AM
To: [email-masked]
Subject: [Megaco] Uniqueness of context ID

Hi,

A context ID is unique within a physical MGW. But when we access a
context report at MGC [example a MSS] can we identify any report at MSS
using only context ID.

My thinking is since MGC connects to many MGW, it might have similar
context IDs with multiple MGWs. Example there could be a context ID 2
with MGW 1 and context ID 2 with MGW 4. In that case to identify a
particular context related info we might need a combination of virtual
MGW address and context ID. Is this understanding right? please clarify.

Thanks and Regards
Geetha

_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Wed, 20 May 2009 09:16:28 +0200

Like to add:
there is a unique name space of ContextID values because there is a
single CA (H.248 Control Association) between a pair of MGC and MG
entities.
(Please note that there is not any difference between a physical or
virtual MG, - there's just one CA.)

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Raphael Tryster
> Sent: Mittwoch, 20. Mai 2009 07:58
> To: Priya Krishnan; [email-masked]
> Subject: Re: [Megaco] Uniqueness of context ID
> 
> Yes.  It is actually quite likely to occur if multiple MGs 
> initialize at the same time and all start assigning context 
> IDs from 1.
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Priya Krishnan
> A context ID is unique within a physical MGW. But when we 
> access a context report at MGC [example a MSS] can we 
> identify any report at MSS using only context ID.
> 
> My thinking is since MGC connects to many MGW, it might have 
> similar context IDs with multiple MGWs. Example there could 
> be a context ID 2 with MGW 1 and context ID 2 with MGW 4. In 
> that case to identify a particular context related info we 
> might need a combination of virtual MGW address and context 
> ID. Is this understanding right? please clarify.
> 
> Thanks and Regards
> Geetha
> 
> 
>

---

From: Kevin Boyle <[email-masked]>
Date: Wed, 20 May 2009 14:16:15 -0400

I will also add that a ContextID is only unique among existing contexts on
the MG.  Once the LONG-TIMER (see Appendix D) expires for a Subtract Command
that removes the last termination from the context, that ContextID may be
re-used.  Remember that ContextIDs are assigned by the MG.

Note also that ContextIDs do not have to be unique in a physical MG.  If the
physical MG is partitioned into multiple virtual MGs, the ContextID only has
to be unique per VMG.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Schwarz Albrecht
Sent: Wednesday, May 20, 2009 3:16 AM
To: [email-masked]
Subject: Re: [Megaco] Uniqueness of context ID

Like to add:
there is a unique name space of ContextID values because there is a single
CA (H.248 Control Association) between a pair of MGC and MG entities.
(Please note that there is not any difference between a physical or virtual
MG, - there's just one CA.)

> Yes.  It is actually quite likely to occur if multiple MGs initialize 
> at the same time and all start assigning context IDs from 1.
> 
> context report at MGC [example a MSS] can we identify any report at 
> MSS using only context ID.
>