Subject: Re: [Megaco] Uniqueness of context ID

From: Priya Krishnan <[email-masked]>
Date: Thu, 21 May 2009 02:31:26 -0700 (PDT)

Thanks for the reply. So you are saying the context ID assignment is purely proprietary [I meant the combination of ISU logical ID and running number is an example of a way to assign context number]. Diff MGW choose to do this diff forms ?

Thanks
Priya

--- On Thu, 5/21/09, Tom Taylor <[email-masked]> wrote:

> From: Tom Taylor <[email-masked]>
> Subject: Re: [Megaco] Uniqueness of context ID
> To: "Priya Krishnan" <[email-masked]>, "megaco ietf" <[email-masked]>
> Date: Thursday, May 21, 2009, 2:23 AM
> Your conclusion is correct. Your
> description of the structure of the context ID 
> is implementation detail, unless you are quoting from some
> profile specification.
> 
> Priya Krishnan wrote:
> > 
> > Thanks Kevin and Schwarz for the response, 
> >  
> > It is true that context IDs are unique within one
> Vmgw. But the confusion is because of so many units/subunits
> in picture that makes a physical MGW.
> > 
> > A physical MGW can be made of multiple ISU. Within an
> ISU there could be multiple VMGW etc..
> > 
> > Also a context ID has 2 parts , first part is the
> logical ID of ISU and the second part running number
> maintained within VMGW. This makes me think that within a
> physical MGW the context IDs are unique because the first
> part [logical address of ISU] is always diff for diff ISU
> that makes context ID number different. 
> > 
> > 
> > So I guess we can assume that context ID is unique for
> one H.248 control link or control association.
> > 
> > Best Regards
> > Geetha
> > --- On Wed, 5/20/09, Kevin Boyle <[email-masked]>
> wrote:
> > 
> >> From: Kevin Boyle <[email-masked]>
> >> Subject: Re: [Megaco] Uniqueness of context ID
> >> To: "'Schwarz Albrecht'" <[email-masked]>,
> [email-masked]
> >> Date: Wednesday, May 20, 2009, 11:16 AM
> >> I will also add that a ContextID is
> >> only unique among existing contexts on
> >> the MG.  Once the LONG-TIMER (see Appendix D)
> expires
> >> for a Subtract Command
> >> that removes the last termination from the
> context, that
> >> ContextID may be
> >> re-used.  Remember that ContextIDs are
> assigned by the
> >> MG.
> >>
> >> Note also that ContextIDs do not have to be unique
> in a
> >> physical MG.  If the
> >> physical MG is partitioned into multiple virtual
> MGs, the
> >> ContextID only has
> >> to be unique per VMG.
> >>
> >> Kevin
> >>
> >> -----Original Message-----
> >> From: [email-masked]
> >> [mailto:[email-masked]]
> >> On Behalf Of
> >> Schwarz Albrecht
> >> Sent: Wednesday, May 20, 2009 3:16 AM
> >> To: [email-masked]
> >> Subject: Re: [Megaco] Uniqueness of context ID
> >>
> >> Like to add:
> >> there is a unique name space of ContextID values
> because
> >> there is a single
> >> CA (H.248 Control Association) between a pair of
> MGC and MG
> >> entities.
> >> (Please note that there is not any difference
> between a
> >> physical or virtual
> >> MG, - there's just one CA.)
> >>
> >>
> >>
> >>> -----Original Message-----
> >>> From: [email-masked]
> >>> [mailto:[email-masked]]
> >> On Behalf Of Raphael Tryster
> >>> Sent: Mittwoch, 20. Mai 2009 07:58
> >>> To: Priya Krishnan; [email-masked]
> >>> Subject: Re: [Megaco] Uniqueness of context
> ID
> >>>
> >>> Yes.  It is actually quite likely to
> occur if
> >> multiple MGs initialize 
> >>> at the same time and all start assigning
> context IDs
> >> from 1.
> >>> -----Original Message-----
> >>> From: [email-masked]
> >>> [mailto:[email-masked]]
> >> On Behalf Of Priya Krishnan
> >>> Sent: Wednesday, 20 May 2009 8:47 AM
> >>> To: [email-masked]
> >>> Subject: [Megaco] Uniqueness of context ID
> >>>
> >>>
> >>> Hi,
> >>>
> >>> A context ID is unique within a physical MGW.
> But when
> >> we access a 
> >>> context report at MGC [example a MSS] can we
> identify
> >> any report at 
> >>> MSS using only context ID.
> >>>
> >>> My thinking is since MGC connects to many MGW,
> it
> >> might have similar 
> >>> context IDs with multiple MGWs. Example there
> could be
> >> a context ID 2 
> >>> with MGW 1 and context ID 2 with MGW 4. In
> that case
> >> to identify a 
> >>> particular context related info we might need
> a
> >> combination of virtual 
> >>> MGW address and context ID. Is this
> understanding
> >> right? please 
> >>> clarify.
> >>>
> >>> Thanks and Regards
> >>> Geetha
> >>>
> >>>
> >>>        
> >>>
> _______________________________________________
> >>> Megaco mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/megaco
> >>>
> _______________________________________________
> >>> Megaco mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/megaco
> >>>
> >> _______________________________________________
> >> Megaco mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/megaco
> >>
> >> _______________________________________________
> >> Megaco mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/megaco
> >>
> > 
> > 
> >       
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/megaco
> > 
>

---

From: Tom Taylor <[email-masked]>
Date: Thu, 21 May 2009 11:42:05 +0200

Yes, that's right.

> Thanks for the reply. So you are saying the context ID assignment is purely proprietary [I meant the combination of ISU logical ID and running number is an example of a way to assign context number…
...