Subject: [Megaco] Open Source Media Gateway Controller

From: Thomas Miesch <[email-masked]>
Date: Thu, 25 Jun 2009 18:01:01 +0200

Hi All,

I would like to inform the interested people, that I have started a 
project which should conclude in a open source media gateway controller.

More information can be obtained here
www.smallmgc.org

I hope it is not considered to be inappropriate to publish this 
information in this list.
But I have read in the past questions about open source gateway 
controllers and to my knowledge there was until now only one from 
Ericcson in Erlang.
So if somebody is still interested he could have a look.

Regards
Thomas

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Fri, 26 Jun 2009 21:36:30 +0200

Thomas,

guess that any announcements about open source projects are certainly
appreciated by the H.248 community.

Got a quick look on your side, which is mentioning first MGC
applications for RGW/AGW and TGW, i.e. PSTN emulation subsystem
solutions.

Question: is your MGC code "general purpose", or already "profiled" for
these PES applications?
If "profile", is the code compliant to 
- ETSI TISPAN H.248 profile for RAGWs (-> ES 283 002)?
- ETSI TISPAN H.248 profile for TGWs (-> ES 283 024 / 283 049)?
- or any 3GPP profile?

Might be interesting for the community when evaluating the applicability
of open source code.

Regards,
Albrecht

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Thomas Miesch
> Sent: Donnerstag, 25. Juni 2009 18:01
> To: [email-masked]
> Subject: [Megaco] Open Source Media Gateway Controller
> 
> Hi All,
> 
> I would like to inform the interested people, that I have 
> started a project which should conclude in a open source 
> media gateway controller.
> 
> I hope it is not considered to be inappropriate to publish 
> this information in this list.
> But I have read in the past questions about open source 
> gateway controllers and to my knowledge there was until now 
> only one from Ericcson in Erlang.
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco
>

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Sat, 27 Jun 2009 11:07:07 +0200

Thanks!
Which H.248 message encoding mode do you support, - binary, text or
both? 

> From: Thomas Miesch [mailto:[email-masked]] 
> Sent: Samstag, 27. Juni 2009 10:25
> To: Schwarz Albrecht
> Cc: [email-masked]
> Subject: Re: [Megaco] Open Source Media Gateway Controller
> 
> Hi Albrecht,
> 
> At the moment I don't follow any profile. My goal is and was 
> to be able to do calls.
> That is possible with the version I have published.
> You see I have labeled the version as 0.006 so the project is 
> at the very beginning.
> But I think it still can be useful for some persons in a Lab.
> 
> This as to clarify the status of the project.
> 
> At the moment my code is general purpose. That is that I 
> don't follow any profile for the moment!
> 
> But as I have mentioned finally SmallMGC could take the role 
> of an AGCF in the IMS network.
> I am not sure if for that function already a profile exists.
> But for such function the ETSI TISPAN H.248 profile for RAGWs 
> (-> ES 283
> 002) is more applicable.
> So in the future it will be clearly necessary to implement 
> this profile.
> 
> On the hand hand I would also like to implement the  ETSI 
> TISPAN H.248 profile for TGWs  (-> ES 283 024 / 283 049). But 
> if this is going to happen I will decide in the future, 
> depending on the responses I receive.
> 
> 
> Regards
> Thomas
> 
> 
> 
> Schwarz Albrecht wrote:
> > Thomas,
> >
> > Question: is your MGC code "general purpose", or already "profiled" 
> > for these PES applications?
> > Might be interesting for the community when evaluating the 
> > applicability of open source code.
> >
> > Regards,
> > Albrecht
> >
> >
> >   
> started a 
> >> More information can be obtained here www.smallmgc.org
> >>

---

From: Thomas Miesch <[email-masked]>
Date: Sat, 27 Jun 2009 11:21:23 +0200

You are absolutely right. That I have never mentioned.

The Encoding is text and text only.
Binary I have never considered.
I don't know if binary encoding is really used in Networks.

Schwarz Albrecht wrote:
>>> guess that any announcements about open source projects are 
>>>       
>> certainly 
>>

---

From: Thomas Miesch <[email-masked]>
Date: Sat, 27 Jun 2009 10:25:19 +0200

Hi Albrecht,

At the moment I don't follow any profile. My goal is and was to be able 
to do calls.
That is possible with the version I have published.
You see I have labeled the version as 0.006 so the project is at the 
very beginning.
But I think it still can be useful for some persons in a Lab.

At the moment my code is general purpose. That is that I don't follow 
any profile for the moment!

But as I have mentioned finally SmallMGC could take the role of an AGCF 
in the IMS network.
I am not sure if for that function already a profile exists.
But for such function the ETSI TISPAN H.248 profile for RAGWs (-> ES 283 
002) is more applicable.
So in the future it will be clearly necessary to implement this profile.

On the hand hand I would also like to implement the  ETSI TISPAN H.248 
profile for TGWs  (-> ES 283 024 / 283 049). But if this is going to 
happen I will decide in the future, depending on the responses I receive.

Regards
Thomas

---

From: Claudio Fontana <[email-masked]>
Date: Sun, 28 Jun 2009 00:15:36 +0200

> I don't know if binary encoding is really used in Networks.

Yes, it is.