Subject: [Megaco] Regarding announcement play

From: shalu dhamija <[email-masked]>
Date: Wed, 9 Sep 2009 16:40:34 +0530 (IST)

Hi all, 

I have a question concerning the playing of announcement in H.248 messages. According to 3GPP 29.333 generic announcement package  is mandatory for playing the announcements and that too only fixed announcement play is supported. The signal parameters of this package are ‘announcement name (an)’, duration, announcement direction and number of cycles. As announcement name is the parameter which is mandatory for the MGC to specify in Add or Modify command as this parameter (an) tells MG to play the specified announcement. In H.248.7 the announcement name (an) is quoted as enumeration of announcements. My query is : 

What are the values supported by announcement name parameter?? 

Thanks and Regards, 

Shalu

---

From: Deepak Bissa <[email-masked]>
Date: Wed, 9 Sep 2009 17:31:47 +0530

Hello,
A similar query was raised earlier on mailing list and following is the content:

Troy Cauble wrote:
>
> Well, either ENUM or STRING "leaves people to define the announcements they want".
>
> But with ENUM, you pretty much have to publish a Package and go to IANA for a package number.
>
> STRINGs would allow it to be more informal.
>
> -troy

Christian Groves wrote:
>
> G'Day Tom and Rashim,
>
> I don't think list of ENUM was an error. Basically it leaves people to
> define the announcements as they want.
>
> The list could be "a,b,c" or "fred,harry,john" or "hello, this is,
> megaco".
>
> There is no "guide" to what these values are as each announcement
> system will be made up of its own phrases.
>
> Christian
>
> Tom-PT Taylor wrote:
> >
> > I think we goofed on this one.  The intent (I believe) is that the
> > announcement identifiers are local to the MG and MGC.  Hence it
> > seems more reasonable that this parameter be a text string.
> >
> > Tom Taylor
> > [email-masked]
> > Ph. +1 613 736 0961 (ESN 396 1490)
> >
> >
> > -----Original Message-----
> > From: Anand, Rashim [mailto:[email-masked]]
> > Sent: Tuesday, July 24, 2001 8:55 PM
> > To: [email-masked]'
> > Subject: [Megaco] Regarding Generic Announcement Package
> >
> > Hi,
> >    In Annex K of H.248 the announcement name parameter of the
> > generic announcement package(an) has been specified as of
> > enumeration type. However no values have been
> >
> > specified unlike for eg.
> > for the announcement direction parameter where there are 3
> > enumerated values of the parameter.
> > Can anyone guide me as to where I can find these values?
> >
> > Regards,
> > Rashim
> >
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/megaco
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/megaco

With regards,
Deepak Bissa

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of shalu dhamija
Sent: Wednesday, September 09, 2009 4:41 PM
To: megaco
Subject: [Megaco] Regarding announcement play

Hi all,

I have a question concerning the playing of announcement in H.248 messages. According to 3GPP 29.333 generic announcement package  is mandatory for playing the announcements and that too only fixed announcement play is supported. The signal parameters of this package are 'announcement name (an)', duration, announcement direction and number of cycles. As announcement name is the parameter which is mandatory for the MGC to specify in Add or Modify command as this parameter (an) tells MG to play the specified announcement. In H.248.7 the announcement name (an) is quoted as enumeration of announcements. My query is :
What are the values supported by announcement name parameter??

Thanks and Regards,
Shalu

________________________________
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error,please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: shalu dhamija <[email-masked]>
Date: Wed, 9 Sep 2009 16:26:07 +0530 (IST)

Hi all, 

  

Thanks and Regards, 

Shalu