Subject: [Megaco] MGC and virtual MG

From: Ron Ho <[email-masked]>
Date: Fri, 18 Sep 2009 14:08:58 -0400

Hi All,

I am confused about how virtual MG is bound to MGC. For a physical MG, it
can be partitioned into multiple virtual MGs. I am confused about how these
virtual MGs bind to the MGC. Do we need one-to-one mapping between MGC and
MG? In order words, I need as many virtual MGC to connect to the virtual MG.

Can I have a single MGC having multiple virtual MGs registered into it? Do I
need multiple MGC identities? (e.g. different MGC mid for each pairing with
a virtual MG) Or just one MGC mid which can be used to connect to different
virtual MG (each virtual MG has it own mid)?

How is the addressing need to be done? I understand that binding between MGC
and MG is established by a Control Association using mid which is
independent of the physical interface used. Does it mean that I can have one
IP address/port in MGC and one IP address/port in MG while having multiple
binding connections between the MGC and the virtual MG?

I am really confused.

Many thanks,
Ron

---

From: Tom Taylor <[email-masked]>
Date: Fri, 18 Sep 2009 16:13:06 -0400

You should be able to control multiple virtual MG from one MGC instance if you 
need to. I can see a simple use case for this, where the normal MGC for one of 
the virtual MGs has failed and an MGC controlling another virtual MG takes its 
place. I am sure there are other applications.

And yes, you can multiplex control associations for multiple virtual MGs over 
the same physical connection. You would have to take some care not to clear down 
the connection just because one virtual MG is doing a restart.

Ron Ho wrote:
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco

---

From: Ron Ho <[email-masked]>
Date: Mon, 21 Sep 2009 17:16:59 -0400

Thanks for the clarification. So one MGC can control multiple MGs. Does the
MGC need multiple mid, one for each MG? Or the MGC needs one only mid and
every MGs send to the same MGC using the same mid of the MGC?

On Fri, Sep 18, 2009 at 4:13 PM, Tom Taylor <[email-masked]> wrote:

> You should be able to control multiple virtual MG from one MGC instance if
> you need to. I can see a simple use case for this, where the normal MGC for
> one of the virtual MGs has failed and an MGC controlling another virtual MG
> takes its place. I am sure there are other applications.
>
> And yes, you can multiplex control associations for multiple virtual MGs
> over the same physical connection. You would have to take some care not to
> clear down the connection just because one virtual MG is doing a restart.
>
> Ron Ho wrote:
>
>> Hi All,
>>

---

From: Tom Taylor <[email-masked]>
Date: Mon, 21 Sep 2009 22:04:12 -0400

The MGC only needs one mid.

>> clear down the connection just because one virtual MG is doing a restart.
...

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Tue, 22 Sep 2009 09:15:53 +0200

You may found a lot of complementary information with respect to the H.248 Control Association in:

H.Sup7 : Gateway control protocol: Establishment procedures for the H.248 MGC-MG control association
http://www.itu.int/rec/dologin_pub.asp?lang=e&id=T-REC-H.Sup7-200805-I!!PDF-E&type=items

see e.g. § 5.2 Constitution of a control association

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Tom Taylor
> Sent: Dienstag, 22. September 2009 04:04
> To: Ron Ho
> Cc: megaco
> Subject: Re: [Megaco] MGC and virtual MG
> 
> > Thanks for the clarification. So one MGC can control multiple MGs. 
> > Does the MGC need multiple mid, one for each MG? Or the MGC 
> needs one 
> > only mid and every MGs send to the same MGC using the same 
> mid of the MGC?
> > 
> >> You should be able to control multiple virtual MG from one MGC 
> >> instance if you need to. I can see a simple use case for 
> this, where 
> >> the normal MGC for one of the virtual MGs has failed and an MGC 
> >> controlling another virtual MG takes its place. I am sure 
> there are other applications.
> >>
> >> And yes, you can multiplex control associations for 
> multiple virtual 
> >> MGs over the same physical connection. You would have to take some 
> >> care not to clear down the connection just because one 
> virtual MG is doing a restart.
> >>
> ...

---

From: Ron Ho <[email-masked]>
Date: Tue, 22 Sep 2009 09:35:46 -0400

I assume that multiple Virtual MGs within the same physical MG can have only
one ipaddress+port configured. As long as the mid of the virtual MG is
different for each virtual MG (e.g. using device name format), the same IP
connection can be used to carry multiple control associations between the
MGC and the multiple virtual MGs. Right?

If that is the case, who control the setup/tear down of the IP connection?
How MGC handover/failover and MG handover/failover are controlled? Should
there be one virtual MG designated as the master MG? Similarly, who should
receive the keep alive message (e.g. auditvalue if it is configured)? Does
the keep alive message need to be sent to all VMG or only the master MG
should receive it?

I am still confused.

Thanks,
Ron

On Tue, Sep 22, 2009 at 3:15 AM, Schwarz Albrecht <
[email-masked]> wrote:

> http://www.itu.int/rec/dologin_pub.asp?lang=e&id=T-REC-H.Sup7-200805-I!!PDF-E&type=items<http://www.itu.int/rec/dologin_pub.asp?lang=e&id=T-REC-H.Sup7-200805-I%21%21PDF-E&type=items>
>

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Tue, 22 Sep 2009 16:05:34 +0200

Ron, you should read H.Sup7 in all details.
There are two concepts here:
a) H.248 Control Association and
b) H.248 IP Transport connection (for your example of IP-based H.248 transport).
 
A singlehomed PMG could still support multiple, VMG-individual IP transport connection endpoints (due to different L4 port values).
There isn't any need at all to share a single IP transport connection endpoint by all VMG instances in a single PMG!
That might be even impossible at all ... due to different H.248 transport modes on different VMGs ... due to ServiceChange procedures with impact on the H.248 transport connection!
 
Thus, keep the difference of (a) and (b) in mind and assume VMG-individual IP transport connections.

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Ron Ho
	Sent: Dienstag, 22. September 2009 15:36
	To: Schwarz Albrecht
	Cc: megaco
	Subject: Re: [Megaco] MGC and virtual MG

	I assume that multiple Virtual MGs within the same physical MG can have only one ipaddress+port configured. 
	[[Schwarz, Albrecht]]  This condition is NOT valid.
	 As long as the mid of the virtual MG is different for each virtual MG (e.g. using device name format), the same IP connection can be used to carry multiple control associations between the MGC and the multiple virtual MGs. Right?
	
	If that is the case, who control the setup/tear down of the IP connection? How MGC handover/failover and MG handover/failover are controlled? Should there be one virtual MG designated as the master MG? Similarly, who should receive the keep alive message (e.g. auditvalue if it is configured)? Does the keep alive message need to be sent to all VMG or only the master MG should receive it?
	
	I am still confused.
	
	Thanks,
	Ron

	On Tue, Sep 22, 2009 at 3:15 AM, Schwarz Albrecht <[email-masked]> wrote:

		H.Sup7 : Gateway control protocol: Establishment procedures for the H.248 MGC-MG control association
		http://www.itu.int/rec/dologin_pub.asp?lang=e&id=T-REC-H.Sup7-200805-I!!PDF-E&type=items <http://www.itu.int/rec/dologin_pub.asp?lang=e&id=T-REC-H.Sup7-200805-I%21%21PDF-E&type=items>