Subject: Re: [Megaco] Inconsistency in Digit Map timers definition

From: Seraya Miletzki <[email-masked]>
Date: Tue, 1 Sep 2009 20:59:59 +0300

Hello Christian

This is my question. At 7.1.14.3 start timer (T) is not mentioned. If it is a valid timer - it should be.

BR

Seraya

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christian Groves
Sent: Tuesday, September 01, 2009 7:12 AM
To: Seraya Miletzki
Cc: [email-masked]
Subject: Re: [Megaco] Inconsistency in Digit Map timers definition

Hello Seraya,

As far as I know the start timer (T) is a valid part of the digit map 
syntax. The operation of the start timer is discussed elsewhere in 7.1.14

Regards, Christian

Seraya Miletzki wrote:
> WARNING: contains banned part
>   
>
> ------------------------------------------------------------------------
>
> Subject:
> Inconsistency in Digit Map timers definition
> From:
> Seraya Miletzki <[email-masked]>
> Date:
> Wed, 26 Aug 2009 18:07:02 +0300
> To:
> "[email-masked]" <[email-masked]>
>
> To:
> "[email-masked]" <[email-masked]>
>
>
> Hi
>
> At H.248/1 V3  at       7.1.14.3        DigitMap syntax - "In addition to these event symbols, the string may contain "S" and "L" inter-event timing specifiers and the "Z" duration modifier."
>
> At annex B Start timer (T) is also a valid symbol in the digitmap string.
>
>
> digitMapLetter          = DIGIT               ;Basic event symbols
>
>                           / %x41-4B / %x61-6B ; a-k, A-K
>
>                           / "L" / "S" / "T"   ;Inter-event timers
>
>                                                ; (long, short, start)
>
>                           / "Z"               ;Long duration modifier
>
>
> Need to specify the right pattern .
>
> I think that the start timer is not a valid string here -Please comment.
>
>
> Seraya
>
>   
> ------------------------------------------------------------------------
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco
>   
_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Tue, 01 Sep 2009 23:58:05 -0400

Look at 7.1.14.2 instead.

---

From: Tom Taylor <[email-masked]>
Date: Wed, 02 Sep 2009 00:02:14 -0400

Oh, and if you look at 7.1.14.3 the first thing it says is that the syntax is 
defined by Annexes A and B (not by the text that follows in clause 7.1.14.3. And 
if you look at the production digitMapLetter in Annex B you see the start timer 
'T' there.