Subject: [Megaco] Text encoding for a proprietary TerminationState Descriptor package

From: "Beis, Grigoris (NSN - GR/Athens)" <[email-masked]>
Date: Tue, 23 Feb 2010 10:51:34 +0100

Hello list,
 
We wish to create a new proprietary H.248 package for inter-company
tracing reasons.We have decided to deploy this package called in the
TerminationState Descriptor in the following manner:
 
TS{mst/trace=on{tracetype=singlecall, traceid=1234}}
 
I feel however that the above syntax is incorrect. According to the Text
encoding of H.248.1 V2 in Annex B, the correct encoding syntax must
follow one of the proposed formats:
 
1) TS{packageName/ItemID}     or
 
2) TS{packageName/ItemID=[VALUE, VALUE]}     or
 
3) TS{packageName/ItemID={VALUE, VALUE}}
 
where 
packageName:     mst
ItemID:                trace
VALUE:              tracetype=singlecall or traceid=1234

Do you think that the proposed syntax is indeed incorrect and must
follow the proposed encoding pattern or this pattern does not refer to
proprietary packages? Or am I missing something more in the Text
encoding scheme?
 
Thank you and best regards,
Greg

P.S. I paste the part of the Text Encoding explanation
 
terminationStateDescriptor = TerminationStateToken LBRKT
terminationStateParm *( COMMA terminationStateParm ) RBRKT

terminationStateParm          =(propertyParm / serviceStates /
eventBufferControl )

propertyParm         = pkgdName parmValue

pkgdName             = (PackageName SLASH ItemID)
; specific item

parmValue            = (EQUAL alternativeValue/ INEQUAL VALUE)

alternativeValue     = ( VALUE / LSBRKT VALUE *(COMMA VALUE) RSBRKT
; sublist (i.e. A AND B AND ...)

                               / LBRKT VALUE *(COMMA VALUE) RBRKT
; alternatives (i.e. A OR B OR ...)

                               /  LSBRKT VALUE COLON VALUE RSBRKT )
; range

------------------------------------------------------------------------
With my best regards, 
Grigoris Beis

Nokia Siemens Networks S.A.
COO CC PV RD ASF PCU2 SGR
Promitheos 12 Str. (Areva building)
GR-145 64 Nea Kifissia / Athens, Greece
Tel.:       +30 210 6247-763
Fax:       +30 210 6247-510
mailto: [email-masked]
------------------------------------------------------------------------

---

From: Tom Taylor <[email-masked]>
Date: Tue, 23 Feb 2010 08:46:11 -0500

I have a feeling that you need to define trace, trac etype, and traceid as 
separate ItemIds and go from there.

Beis, Grigoris (NSN - GR/Athens) wrote:
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Wed, 24 Feb 2010 10:02:32 +1100

Do you really need another package for tracing? There's already the 
following packages:
0x0097  calltrace
0x8007 threegtrace
(http://www.iana.org/assignments/megaco-h248)

Christian

Tom Taylor wrote:
> I have a feeling that you need to define trace, trac etype, and 
> traceid as separate ItemIds and go from there.
>
>> where packageName:     mst
>> With my best regards, Grigoris Beis
>>

---

From: "Beis, Grigoris (NSN - GR/Athens)" <[email-masked]>
Date: Wed, 24 Feb 2010 09:09:29 +0100

Hello Christian,

We were aware of the Nokia and 3GPP packages but we decided to introduce
a new package for tracing activation/deactivation and some other MGC-MG
inner purposes.

Greg 

-----Original Message-----
From: ext Christian Groves [mailto:[email-masked]] 
Sent: Wednesday, February 24, 2010 1:03 AM
To: Tom Taylor
Cc: Beis, Grigoris (NSN - GR/Athens); [email-masked]
Subject: Re: [Megaco] Text encoding for a proprietary TerminationState
Descriptor package

Christian

Tom Taylor wrote:
>> I feel however that the above syntax is incorrect. According to the 
>> Text encoding of H.248.1 V2 in Annex B, the correct encoding syntax 
>> must follow one of the proposed formats:
>>  
>> follow the proposed encoding pattern or this pattern does not refer 
>> to proprietary packages? Or am I missing something more in the Text 
>> encoding scheme?
>>  
>>                                / LBRKT VALUE *(COMMA VALUE) RBRKT ; 
>> alternatives (i.e. A OR B OR ...)
>>
>>                                /  LSBRKT VALUE COLON VALUE RSBRKT ) ;

>> range