Subject: [Megaco] MEGACO/H248 Statistic/QoS

From: "Flores Eugenio" <[email-masked]>
Date: Fri, 19 Feb 2010 12:24:43 -0430

Hi,

I am checking the Statistics and Quality of Service  of the H248 signaling in the NGN Network, using probes. 

I have two cases of study:

1.       Termination Statistics of media context. (SUBTRACT). Including Packets IN/OUT, Packet loss, jitter, delay.

2.       Release/End causes H248 of the calls.

So, In the case 2, I need your help. What is the mapping of the Release/End Causes for H248 (like ISUP ITU-T  q.850) or What is the best practice to check the user behavior or problems in the H248.  Now, I am seeing end causes like: MEGACO: 433 TerminationID is already in a Context, or MEGACO: 500 Internal Gateway Error, MEGACO: Timeout, etc.

                Possible Calls flow:

a.       ACCESS MEDIA GW 1 ßH248à SOFTSWITCH ß H248 àACCESS MEDIA GW 2. (Only the ACCESS MEDIA GW 1 sends the B number in the H248 signaling).

b.      b.1. PSTN ßISUPà SIGNALING GW ß SIGTRAM à SOFTSWITCH.

b.2. PSTN (VOICE E1) ßàTRUNK MEDIA GW ßH248à SOFTSWITCH ß H248 àTRUNK MEDIA GW OR ACCESS MEDIA GW. (A and B number are in ISUP/SIGTRAM signaling). 

c.       Central Office (not NGN)ßR2à TRUNK MEDIA GW ßH248à SOFTSWITCH ß H248 à TRUNK MEDIA GW OR ACCESS MEDIA GW. (A and B number are in H248 signaling)

d.      d.1. Central  Office (not NGN) ßISUPà SIGNALING GW ßSIGTRAMà SOFTSWITCH. 

d.2. Central Office (not NGN)ßVOICE E1à TRUNK MEDIA GW ßH248à SOFTSWITCH ß H248 à TRUNK MEDIA GW OR ACCESS MEDIA GW. (A and B number are in ISUP/SIGTRAM signaling). 

Thanks in advanced,

Eugenio Flores

CANTV

---

From: <[email-masked]>
Date: Sat, 20 Feb 2010 13:12:51 +0530

Hi Flores,

There could be multiple reasons for errors in the case 2 you mentioned below.  A starting point would be to capture a trace on MGC and / or MG, and take a look at H.248 message exchange.

Regards,

Jayesh

From: [email-masked] [mailto:[email-masked]] On Behalf Of Flores Eugenio
Sent: Friday, February 19, 2010 10:25 PM
To: [email-masked]
Subject: [Megaco] MEGACO/H248 Statistic/QoS
Importance: High

Hi,

                Possible Calls flow:

Thanks in advanced,

Eugenio Flores

CANTV