Subject: [Megaco] Query Regarding Long Timer in conjuction with HandOff in H.248

From: "sushil kumar" <[email-masked]>
Date: Mon, 8 Feb 2010 16:42:25 +0530

Hi All,

I need a help , what should be the behavior of MG (H.248 Protocol) in
following scenario:-

1. MGC1 established association with MG 

2. MGC1 initiate Add 1 request towards MG with transaction ID(let
transactionID be 2)

3. MG responded the Add request and should keep a copy of it for 30 sec
(LONG Timer ) so that it can response back if same transaction request comes
again.

4. Now MGC1 initiate handoff towards MGC2 (upto this point LONG timer did
not expire ) .

5. MGC2 established association with MG(upto this point LONG timer did not
expire ) .

6. Now MGC2 initiate Add 2  request towards MG with transaction ID 1( same
as above) and still LONG Timer did not expire.

What should be the expected response from MG ?

i) Should it reply this Add2 request?

    Or

ii) should in response of this request (having same transaction Id  and Long
timer did not expire ) MG  should return the same response which it saved
already?

Currently it respond with the OLD response which it already saved .

Please find the attached call flow for reference.

Thanks in advance !!

Regards

Sushil

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Mon, 8 Feb 2010 15:15:08 +0100

Your scenario might be too high level, thus I may just guess:
 
You know that there is just a single H.248 Control Association (CA) from MG perspective (a PMG or VMG).
Thus, the initial CA (with MGC1) does NOT exist anymore after the successfull changeover procedure (via handoff) to MGC2.
 
Please don't forget that the 2nd CA is different to the 1st CA (due to different MGC instances), see e.g.
ITU-T H.Sup7, § 5.2 Constitution of a Control Association.

Thus, any OLD responses from the CA with MGC1 are meaningless at the new CA with MGC2.
Both MGC entities must use a different MID anyway.

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of sushil kumar
	Sent: Montag, 8. Februar 2010 12:12
	To: [email-masked]
	Subject: [Megaco] Query Regarding Long Timer in conjuction with HandOff inH.248

	Hi All,

	I need a help , what should be the behavior of MG (H.248 Protocol) in following scenario:-

	2. MGC1 initiate Add 1 request towards MG with transaction ID(let transactionID be 2)

	3. MG responded the Add request and should keep a copy of it for 30 sec (LONG Timer ) so that it can response back if same transaction request comes again.

	4. Now MGC1 initiate handoff towards MGC2 (upto this point LONG timer did not expire ) .

	5. MGC2 established association with MG(upto this point LONG timer did not expire ) .

	6. Now MGC2 initiate Add 2  request towards MG with transaction ID 1( same as above) and still LONG Timer did not expire.

	    Or

	ii) should in response of this request (having same transaction Id  and Long timer did not expire ) MG  should return the same response which it saved already?

	Thanks in advance !!

	Regards

	Sushil