Subject: [Megaco] H.248.PIPA Package Identifier Publishing and Application; RE: H248 Question

From: "Schwarz Albrecht" <[email-masked]>
Date: Tue, 2 Feb 2010 14:15:11 +0100

Wayne,
this is indeed a question for clarification (in my understanding).
Q.3/16 got a work item H.248.PIPA on that subject, attached some old
contributions.
I've Cc'd MEGACO because there are different opinions on that topic,
which prevented progress in 2009.
 
Regards,
Albrecht

________________________________

	From: Wayne Cutler [mailto:[email-masked]] 
	Sent: Dienstag, 2. Februar 2010 09:18
	To: Schwarz Albrecht
	Subject: H248 Question 

	 
	Hi Albrecht,
	 
	Do you have a view on the following issue raised by our
developers. 
	 
	As we know, H248 permits packages to extend others. So, let's
say that packasge A has events e1 & e2 and package B extends A and adds
an event e3. 
	 
	So, the MGC may arm for A/e1, A/e2, B/e1, B/e2, Be3 (and A/e1 is
equivalent to B/e1 as is A/e2 to B/e2).
	 
	The issue is with regard to the behaviour of the GW in the event
of being armed to look for B/e1. In the event of event e1 being detected
on the GW, is it permissable 
	for the GW to report  :- 1) only B/e1 or 2) either A/e1 or B/e1
(i.e. since A/e1 is equivalent to B/e1). 
	 
	I've looked thru' the IG and the base protocol text and it is
not explicit. What do you think ?
	 
	Thanks,
	Wayne

---

From: Christian Groves <[email-masked]>
Date: Wed, 03 Feb 2010 19:15:37 +1100

Hello Albrecht,

FYI. We intend on bringing a contribution to the March Q.3/16 to again 
start progress on H.248.PIPA. Hopefully it will satisfy the different 
opinions as well as clarify the issue.

Regards, Christian

Schwarz Albrecht wrote:
>     ------------------------------------------------------------------------
>     *From:* Wayne Cutler [mailto:[email-masked]]
>     *Sent:* Dienstag, 2. Februar 2010 09:18
>     *To:* Schwarz Albrecht
>     *Subject:* H248 Question
>
>      
>     Hi Albrecht,
>      
>     Do you have a view on the following issue raised by our developers.
>      
>     As we know, H248 permits packages to extend others. So, let's say
>     that packasge A has events e1 & e2 and package B extends A and
>     adds an event e3.
>      
>     of being armed to look for B/e1. In the event of event e1 being
>     detected on the GW, is it permissable
>     I've looked thru' the IG and the base protocol text and it is not
>     explicit. What do you think ?
>      
>     Thanks,
>     Wayne
>      
>      
>
>      
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco
>