Subject: [Megaco] C-439 H.248.50 (ex H.248.NATTT): Updates - draft-ietf-avt-app-rtp-keepalive

From: Schwarz Albrecht <[email-masked]>
Date: Fri, 9 Jul 2010 15:38:03 +0200

Christian, Tommy,

guess that it remains just a last dependency (-> draft-ietf-avt-app-rtp-keepalive) concerning the consent/approval of Draft H.248.50 (ex H.248.NATTT), if C-439 would be approved.

There seems to be still some "To Do's" when looking at:
https://datatracker.ietf.org/doc/draft-ietf-avt-app-rtp-keepalive/#ballot
https://datatracker.ietf.org/doc/draft-ietf-avt-app-rtp-keepalive/#history

However, the very majority of this material is pretty stable.
The impact of this IETF draft to the H.248 kar Package is primarily related to the Signal parameter kapt, where we got seven Keepalive Packet Types.

Would you agree to such a brief summary of Draft H.248.50 status?

If yes, I could imagine to consent/approve Draft H.248.50 already at this SG16, providing some "warning information" to specific kapt values ("if required at all").
There are already meaningful applications of such a kar v1 package in my opinion.

When the IETF published finally the RFC, we may cross-check again, and, if required, provide an IG item (or even a kar v2).

Any views?

Albrecht

---

From: Christian Groves <[email-masked]>
Date: Tue, 13 Jul 2010 11:29:48 +1000

Hello Albrecht,

Whilst I would like to Consent H.248.50 as it has been around for some 
time we couldn't Consent H.248.50 with a dependency on an IETF draft. 
However the dependency is reasonably minor effectively giving the reader 
an informative hint on how a MGC communicates the use of keepalive with 
a peer MGC. Which in effect is outside the scope of the H.248 interface. 
So we could remove this reference and Consent the document.

Regards, Christian

On 9/07/2010 11:38 PM, Schwarz Albrecht wrote:
> Christian, Tommy,
> guess that it remains just a last dependency (-> 
> draft-ietf-avt-app-rtp-keepalive) concerning the consent/approval of 
> Draft H.248.50 (ex H.248.NATTT), if C-439 would be approved.
> The impact of this IETF draft to the H.248 kar Package is primarily 
> related to the Signal parameter kapt, where we got seven Keepalive 
> Packet Types.
> If yes, I could imagine to consent/approve Draft H.248.50 already at 
> this SG16, providing some "warning information" to specific kapt 
> values ("if required at all").
> When the IETF published finally the RFC, we may cross-check again, 
> and, if required, provide an IG item (or even a kar v2).
> Any views?
> Albrecht

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 13 Jul 2010 15:56:03 +0200

I do not intend to comment of whether you need the reference or not.

The current status of the document is that publication was requested on 4th February 2009. 

It went into IETF last call on 19th May 2009.

It went into IESG evaluation on 18th October 2009. That has been extended by a number of comments being made by IESG members, which have been somewhat slow in resolving. It appears there are still some open discusses, which I hope are pretty close to being resolved. Once they are cleared the document should fairly rapidly progress to the RFC editor queue.

The document does not seem to have any unpublished document dependencies or any IANA registrations, so once within the RFC editor queue its progress should be fairly rapid. It is only an 8 page document.

regards

Keith

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]] 
> Sent: Tuesday, July 13, 2010 2:30 AM
> To: Schwarz, Albrecht (Albrecht)
> Cc: Tommy Young; [email-masked]; DRAGE, Keith (Keith); Roni Even
> Subject: Re: C-439 H.248.50 (ex H.248.NATTT): Updates - 
> draft-ietf-avt-app-rtp-keepalive
> 
> Hello Albrecht,
> 
> Whilst I would like to Consent H.248.50 as it has been around 
> for some time we couldn't Consent H.248.50 with a dependency 
> on an IETF draft. 
> However the dependency is reasonably minor effectively giving 
> the reader an informative hint on how a MGC communicates the 
> use of keepalive with a peer MGC. Which in effect is outside 
> the scope of the H.248 interface. 
> https://datatracker.ietf.org/doc/draft-ietf-avt-app-rtp-keepalive/#his
> > tory However, the very majority of this material is pretty stable.
> > There are already meaningful applications of such a kar v1 
> package in 
> > my opinion.