Subject: [Megaco] Role of MGW in SIP to SIP calls

From: Priya Krishnan <[email-masked]>
Date: Wed, 14 Jul 2010 04:43:44 -0700 (PDT)

Hi All,

For a call between 2 SIP users [capable of packetizing voice info]  ,typically there is no role played by MGW actually ? Is this assumption right or is there a role for MGW.  Under such circumstances how do we obtain QoS statistics which could be taken care by intserv, diffserv technologies.

Thanks in advance
Priya

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Wed, 14 Jul 2010 13:52:40 +0200

Your assumption is incorrect: there are many H.248 IP-to-IP MG types defined, e.g. ETSI TISPAN, 3GPP, MSF or ITU-T SG11.
Such MGs may be located between two SIP devices in the IP bearer-path.
A number of H.248 statistics are defined e.g. by ETSI TS 183 018, the H.248 Ia profile V3 for border gateways.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Priya Krishnan
> Sent: Mittwoch, 14. Juli 2010 13:44
> To: [email-masked]
> Subject: [Megaco] Role of MGW in SIP to SIP calls
> 
> Hi All,
> 
> For a call between 2 SIP users [capable of packetizing voice 
> info]  ,typically there is no role played by MGW actually ? 
> Is this assumption right or is there a role for MGW.  Under 
> such circumstances how do we obtain QoS statistics which 
> could be taken care by intserv, diffserv technologies.
> 
> Thanks in advance
> Priya
> 
> 
> 
>       
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco
>

---

From: Priya Krishnan <[email-masked]>
Date: Fri, 16 Jul 2010 05:31:57 -0700 (PDT)

IMS core is my main concern where MGW is mainly for VCC and CS interoperability. For SIP-SIP which is pure IP , will MGW have statistics [will it even go through MGW] , this  is my question in particular ? 

How will  IP qos which is realized through intserv, diffserv etc.. relate to these parameters in MGW [Mos, delay , Jitter]. 

I think answer to my first question wil help for this part because if SIP-SIP always goes through MGW in IMS for various other goodies MGW has to offer [echo cancellation, any transcoding etc.. and repacketization anyways] then I have already found answers already to my second one. IP diffserv helps in prioritization and MGW helps in dealing with actual voice coding details.

Thanks in Advance for your help. Am new to both areas and trying to relate them. I dont find this ifo explicitly anywhere.

Best regards
Priya Krishnan

--- On Wed, 7/14/10, Schwarz, Albrecht (Albrecht) <[email-masked]> wrote:

> From: Schwarz, Albrecht (Albrecht) <[email-masked]>
> Subject: RE: [Megaco] Role of MGW in SIP to SIP calls
> To: "Priya Krishnan" <[email-masked]>, "[email-masked]" <[email-masked]>
> Date: Wednesday, July 14, 2010, 4:52 AM
> Your assumption is incorrect: there
> are many H.248 IP-to-IP MG types defined, e.g. ETSI TISPAN,
> 3GPP, MSF or ITU-T SG11.
> A number of H.248 statistics are defined e.g. by ETSI TS
> 183 018, the H.248 Ia profile V3 for border gateways.
>  
>

---

From: Tom Taylor <[email-masked]>
Date: Fri, 16 Jul 2010 08:59:37 -0400

SIP to SIP calls do not go through the MGW unless a transit through the CS 
network is required. But other H.248-controlled entities such as NATs or 
transcoders may lie along the path.

Priya Krishnan wrote:
> IMS core is my main concern where MGW is mainly for VCC and CS
> interoperability. For SIP-SIP which is pure IP , will MGW have statistics
> [will it even go through MGW] , this  is my question in particular ?
> 
> How will  IP qos which is realized through intserv, diffserv etc.. relate to
> these parameters in MGW [Mos, delay , Jitter].
> 
> I think answer to my first question wil help for this part because if SIP-SIP
> always goes through MGW in IMS for various other goodies MGW has to offer
> [echo cancellation, any transcoding etc.. and repacketization anyways] then I
> have already found answers already to my second one. IP diffserv helps in
> prioritization and MGW helps in dealing with actual voice coding details.
> 
> Thanks in Advance for your help. Am new to both areas and trying to relate
> them. I dont find this ifo explicitly anywhere.
> 
> Best regards Priya Krishnan
> 
>...

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Fri, 16 Jul 2010 15:57:31 +0200

Using H.248 MGs for the collection, local generation and reporting of SIP session related performance measurements, relates here to 3GPP IP-to-IP H.248 MG types (i.e. Iq, Ix but also Mn, and even Mp may be an option).
See e.g. discussion in following CT3 doc, - use case #3 is about such call individual statistics:
http://www.3gpp.org/ftp/tsg_ct/WG3_interworking_ex-CN3/TSGC3_58_Kyoto_Japan/Doc/C3-100469.zip

The MGCF entity, controlling such an IP-to-IP MG, must be either directly located in a call/session server with a SIP B2BUA instance (for your SIP-to-SIP scenarios) or "below" such an instance like an interim policy decision instance (see TISPAN Gq' to Ia ...).

> > How will  IP qos which is realized through intserv, diffserv etc.. 
> > relate to these parameters in MGW [Mos, delay , Jitter].
 
Such performance metrics are in scope of RTCP XR report types, and Draft H.248.48 would be used for that purpose.
The H.248 (IP,IP) connection model would relate to an RTP topology model according an RTP (media | transport) translator model, see
http://tools.ietf.org/html/rfc5117
or even a Back-to-Back RTP Endsystem model.
(See e.g. ETSI TR 183 068, cl. I.3.6/.7)

-Albrecht

> From: Tom Taylor [mailto:[email-masked]] 
> Sent: Freitag, 16. Juli 2010 15:00
> To: Priya Krishnan
> Cc: [email-masked]; Schwarz, Albrecht (Albrecht)
> Subject: Re: [Megaco] Role of MGW in SIP to SIP calls
> 
> SIP to SIP calls do not go through the MGW unless a transit 
> through the CS network is required. But other 
> H.248-controlled entities such as NATs or transcoders may lie 
> along the path.
> 
> Priya Krishnan wrote:
> > interoperability. For SIP-SIP which is pure IP , will MGW have 
> > statistics [will it even go through MGW] , this  is my 
> question in particular ?
> > 
> > How will  IP qos which is realized through intserv, diffserv etc.. 
> > relate to these parameters in MGW [Mos, delay , Jitter].
> > 
> > I think answer to my first question wil help for this part 
> because if 
> > SIP-SIP always goes through MGW in IMS for various other 
> goodies MGW 
> > has to offer [echo cancellation, any transcoding etc.. and 
> > repacketization anyways] then I have already found answers 
> already to 
> > my second one. IP diffserv helps in prioritization and MGW 
> helps in dealing with actual voice coding details.
> > 
> > Thanks in Advance for your help. Am new to both areas and trying to 
> > relate them. I dont find this ifo explicitly anywhere.
> > 

--- On Wed, 7/14/10, Schwarz, Albrecht (Albrecht) <[email-masked]> wrote:

> Date: Wednesday, July 14, 2010, 4:52 AM Your assumption is incorrect: 
> there are many H.248 IP-to-IP MG types defined, e.g. ETSI TISPAN, 
> 3GPP, MSF or ITU-T SG11.