Subject: [Megaco] Question on using signal parameters for stimal/stedsig signal

From: Murugesh Govindaraju <[email-masked]>
Date: Tue, 03 Sep 2013 15:44:10 +0530

Hi All,
Stimulus analogue line package (H.248.34) has a signal "Steady Signal" 
defined in it.

Following is the definition of this signal from this package:
*6.3.2 Steady Signal**
**Signal name: Steady Signal**
**Signal ID: stedsig (0x0002)**
**Description: Used by the MGC to instruct the MG to apply a steady 
signal.**
**Signal Type: OnOff**
**Duration: not applicable*

This signal has only one parameter called "sig".

What if we receive the following request from switch, which contains the 
signal parameters signalType and Duration:

MEGACO/1 Transaction = 387699 {Context = 48 {
     Modify = AL3{Media{LocalControl {   Mode = SendReceive
         }},
       Signals {
         stimal/stedsig {
           *SignalType = timeOut,
           Duration = 15,*
           sig = reversePolarity
         }
       },
       Events = 2527 {
         al/on,
         al/of,
         al/fl
       }
     }
   }
}

Here is my question:
Though the signal definition in package says that the steady signal is 
of type *"OnOf**f"*, but the switch says as "*timeOut*" and duration as 
not application, but the switch says as "15" sec.
What should be the behavior of the MG in this case?

-- 
*Thanks,
Murugesh G *

---

From: "Bhattacharjee, Arindam (Arindam)" <[email-masked]>
Date: Tue, 3 Sep 2013 17:28:02 +0000

Hi Murugesh,

Signal Type: OnOff is default type in the specification. If SignalType= timeout is specified in the message then default type OnOff is overridden.

In your case MG should apply the signal with timeout of Duration=15.

In section 7.1.11 of H248.1
If a signal of default type other than TO has its type overridden to type TO in the Signals Descriptor, the duration parameter must be present.

-Arindam

From: [email-masked] [mailto:[email-masked]] On Behalf Of Murugesh Govindaraju
Sent: Tuesday, September 03, 2013 6:14 AM
To: [email-masked]
Cc: Ramesh Kuppili
Subject: [Megaco] Question on using signal parameters for stimal/stedsig signal

Hi All,
Stimulus analogue line package (H.248.34) has a signal "Steady Signal" defined in it.

Following is the definition of this signal from this package:
6.3.2 Steady Signal
Signal name: Steady Signal
Signal ID: stedsig (0x0002)
Description: Used by the MGC to instruct the MG to apply a steady signal.
Signal Type: OnOff
Duration: not applicable

What if we receive the following request from switch, which contains the signal parameters signalType and Duration:

        }},

      Signals {

        stimal/stedsig {

          SignalType = timeOut,

          Duration = 15,

          sig = reversePolarity

        }

      },

      Events = 2527 {

        al/on,

        al/of,

        al/fl

      }

    }

  }

}
Here is my question:
Though the signal definition in package says that the steady signal is of type "OnOff", but the switch says as "timeOut" and duration as not application, but the switch says as "15" sec.
What should be the behavior of the MG in this case?
--
Thanks,
Murugesh G