Subject: [Mentoring-coordinators] Discuss New Way of Assigning Mentors

From: <[email-masked]>
Date: Mon, 1 Feb 2016 13:15:48 +0000 (UTC)

Guys,
I am thinking that it might be better to do:
1. Instead of us picking the mentor, let the mentor pick themselves by posting to the 95Mentors list.  (If no one signs up, then of course, we have to step in to help.)
BUT
2.  What WE do is that when we get informed of a mentee, then we start a conversation with them to find out exactly what they are doing, what they want, etc.  So, then, we will be able to describe the person much better in the email to the 95mentors list.
We can also let them know of Speed Mentoring, lunches & other social support.  And to connect with the mentoring team on the ground.

3.  Another thing I have noticed is that I am not sure that mentors always know what to do.   So, we might want to work more closely with the mentors to suggest ways to work with the mentee.
Thoughts? Thanks,
Nalini ElkinsInside Products, Inc.www.insidethestack.com(831) 659-8360

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 1 Feb 2016 13:25:29 +0000

Hi Nalini,

See in-line comments.

Thanks and Regards,

Dan

From: mentoring-coordinators [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, February 01, 2016 3:16 PM
To: [email-masked]
Subject: [Mentoring-coordinators] Discuss New Way of Assigning Mentors

Guys,

DR – yes, this seems like a reasonable proposal. We need to prepare a more detailed presentation of the candidate, and also set a time threshold after which we send a reminder (4 days?) and another one to intervene (another 3-4 days?)

BUT

DR – a more detailed questionnaire for the candidate?

DR – this is true for new mentors in some cases. After mentoring once or twice I assume mentors know what to do. This is not very different from what happens in many work places.

Thoughts?

DR – are newcomers redirected to a place where they can learn about the mentoring program, at registration? Maybe they are and I do not know.

Thanks,

Nalini Elkins
Inside Products, Inc.
www.insidethestack.com<http://www.insidethestack.com>
(831) 659-8360

---

From: <[email-masked]>
Date: Mon, 1 Feb 2016 13:50:22 +0000 (UTC)

Thanks, Dan.  My comments are also inline.
 
Nalini

________________________________
From: "Romascanu, Dan (Dan)" <[email-masked]>
To: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]> 
Sent: Monday, February 1, 2016 5:25 AM
Subject: RE: [Mentoring-coordinators] Discuss New Way of Assigning Mentors

Hi Nalini,
 
See in-line comments. 
 
Thanks and Regards,
 
Dan

From:mentoring-coordinators [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, February 01, 2016 3:16 PM
To: [email-masked]
Subject: [Mentoring-coordinators] Discuss New Way of Assigning Mentors
 
Guys,

 

Nalini: Yes, I think this sounds good.

BUT

Nalini:  The current set of question for the mentees is here: https://www.surveymonkey.com/r/XBWQWPW

If you have more questions to add, that is fine.  But, I think that once a conversation is started, then one always learns more.  No questionnaire can anticipate all needs.  Also, I think it is good to have a bit of a personal touch.  One of the things that the mentees appreciate is that they feel less isolated with the mentor & mentoring team.  So, I think it is good to have contact with an actual human! 

Nalini: Yes.  Some people know very well what to do.  I can also start a discussion on the 95Mentors list about "Best practices for Mentors".  Then, people who have had good success can help others.

One of the reasons that I bring this up is that mentees seem quite a bit more satisfied with the program then mentors!  This is a change from the past - and of course, good.  But, I think we need to take care of our mentors & support them more.  I will be asking mentors to come to lunch with us & I think that will help.  The more engaged people are with the program, the better they seem to feel about it.
 
Thoughts?

Nalini: There is a newcomers email list & both the IETF Secretariat & I post to that to let them know.   I also post to the 95Attendees list to let people know about mentoring.  

This time, the Latin American contingent has someone helping them with publicity for the mentoring & EDU program.  Mirjam & I have already had initial discussions with the person.  As things get closer, we will do more.  

I think Jari might help also.  I told him that we could use some more help with publicity.  So, he might blog.  He is thinking.  BTW, if anyone wants to blog about our activities - we can do a mentoring blog.  I am out of bandwidth for this but if someone thinks this would be fun & wants to commit to it, then probably would be great.  It is a bunch of work though, so I did not mention it.  Maybe we can do it in the future. Problem is that if you do it, then you have to commit to it.

Gowri will also be helping me add more "spice" to our mentoring web page on the IETF main site.  
Thanks,
 
Nalini Elkins
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 1 Feb 2016 13:57:47 +0000

Hi Nailini,

See in-line. 

Thanks and Regards,

Dan

> -----Original Message-----
> From: mentoring-coordinators [mailto:mentoring-coordinators-
> [email-masked]] On Behalf Of [email-masked]
> Sent: Monday, February 01, 2016 3:50 PM
> To: Romascanu, Dan (Dan); [email-masked]
> Subject: Re: [Mentoring-coordinators] Discuss New Way of Assigning
> Mentors
> 
> To: "[email-masked]" <[email-masked]>;
> "[email-masked]" <[email-masked]>
> From:mentoring-coordinators [mailto:mentoring-coordinators-
> [email-masked]] On Behalf Of [email-masked]

...
> 
> If you have more questions to add, that is fine.  But, I think that once a
> conversation is started, then one always learns more.  No questionnaire can
> anticipate all needs.  Also, I think it is good to have a bit of a personal touch.
> One of the things that the mentees appreciate is that they feel less isolated
> with the mentor & mentoring team.  So, I think it is good to have contact with
> an actual human!
> 

DR - yes, I agree. 

...

> One of the reasons that I bring this up is that mentees seem quite a bit more
> satisfied with the program then mentors!  This is a change from the past -
> and of course, good.  But, I think we need to take care of our mentors &
> support them more.  I will be asking mentors to come to lunch with us & I
> think that will help.  The more engaged people are with the program, the
> better they seem to feel about it.
> 
> Thoughts?
> 
> 

DR - The degree of 'immediate satisfaction' should be only one parameter to measure success. More important is on my opinion the long term effect. I personally am very happy to see two (maybe there are more) of my 'mentees' a few IETF meetings back having become active participants in the IETF. 

...

> 
> I think Jari might help also.  I told him that we could use some more help with
> publicity.  So, he might blog.  He is thinking.  BTW, if anyone wants to blog
> about our activities - we can do a mentoring blog.  I am out of bandwidth for
> this but if someone thinks this would be fun & wants to commit to it, then
> probably would be great.  It is a bunch of work though, so I did not mention
> it.  Maybe we can do it in the future. Problem is that if you do it, then you
> have to commit to it.
> 

DR - Indeed, a blog posting from Jari would be of great help IMO.

---

From: Wesley Eddy <[email-masked]>
Date: Mon, 1 Feb 2016 09:02:34 -0500

This sounds like a good idea to me.  A couple times I've asked people to 
mentor who'd either forgot they had volunteered to be on the mentoring 
list, or weren't as interested in it as they had been in the past.  This 
would help prevent that.

This will also help with the case where mentors areas of interest change 
over time, or were just never well described in the matrix that we used.

On 2/1/2016 8:15 AM, [email-masked] wrote:
> 1. Instead of us picking the mentor, let the mentor pick themselves by 
> posting to the 95Mentors list.  (If no one signs up, then of course, 
> we have to step in to help.)
>
> BUT
>
> 2.  What WE do is that when we get informed of a mentee, then we start 
> a conversation with them to find out exactly what they are doing, what 
> they want, etc.  So, then, we will be able to describe the person much 
> better in the email to the 95mentors list.
>
> We can also let them know of Speed Mentoring, lunches & other social 
> support.  And to connect with the mentoring team on the ground.
>
>
> 3.  Another thing I have noticed is that I am not sure that mentors 
> always know what to do.   So, we might want to work more closely with 
> the mentors to suggest ways to work with the mentee.
>
> Thoughts?
> Thanks,
>
> Nalini Elkins
> Inside Products, Inc.
> www.insidethestack.com
> (831) 659-8360
>
>
> _______________________________________________
> mentoring-coordinators mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mentoring-coordinators

---

From: <[email-masked]>
Date: Mon, 1 Feb 2016 14:12:30 +0000 (UTC)

Nalini: Yes!  This is a very good measure.  But, I will say that some mentors are better than others.  One issue that we have not talked about is that once in a while a mentee will tell me that their mentor did not have time for them or gave them the feeling that they were too busy.  Of course, why such a person would sign up to be a mentor is a different question.  But, it does happen.

I don't want to name names or blacklist people from being mentors.  I think that is inappropriate.  What I do in such situations is to take them under my wing personally & also try to find someone else for them.  So, I guess that is fine also.  I think if we have a good relationship with the mentees & they feel safe telling us that it is not working, then the team on the ground can deal with it.

 Thanks,

Nalini Elkins
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Original Message -----
From: "Romascanu, Dan (Dan)" <[email-masked]>
To: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Monday, February 1, 2016 5:57 AM
Subject: Re: [Mentoring-coordinators] Discuss New Way of Assigning Mentors

Hi Nailini,

See in-line. 

Thanks and Regards,

Dan

...

DR - yes, I agree. 

...

...

---

From: "Visweswaran, Gowri" <[email-masked]>
Date: Mon, 1 Feb 2016 19:56:08 +0000

Thanks Nalini and Dan, great discussion and comments.

I really like the idea of doing a mentoring blog and also if Jari can blog about our program!
I am thinking of volunteering to do the blog, would we set it up or would it be one hosted off the IETF website? I have my own personal blog and website which I am hosting myself. 

In the below case, would having more than one mentor assigned to a mentee help if one of the mentors does not have the time or there is no common ground? Perhaps 2 mentors to a mentee? 

Thanks,

Gowri

-----Original Message-----
From: mentoring-coordinators [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, February 1, 2016 9:12 AM
To: Romascanu, Dan (Dan); [email-masked]
Subject: Re: [Mentoring-coordinators] Discuss New Way of Assigning Mentors

 Thanks,

Nalini Elkins
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Original Message -----
From: "Romascanu, Dan (Dan)" <[email-masked]>
To: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Monday, February 1, 2016 5:57 AM
Subject: Re: [Mentoring-coordinators] Discuss New Way of Assigning Mentors

Hi Nailini,

See in-line. 

Thanks and Regards,

Dan

...
> 
> If you have more questions to add, that is fine.  But, I think that 
> once a conversation is started, then one always learns more.  No 
> questionnaire can anticipate all needs.  Also, I think it is good to have a bit of a personal touch.
> One of the things that the mentees appreciate is that they feel less 
> isolated with the mentor & mentoring team.  So, I think it is good to 
> have contact with an actual human!
> 

DR - yes, I agree. 

...

> One of the reasons that I bring this up is that mentees seem quite a 
> bit more satisfied with the program then mentors!  This is a change 
> from the past - and of course, good.  But, I think we need to take 
> care of our mentors & support them more.  I will be asking mentors to 
> come to lunch with us & I think that will help.  The more engaged 
> people are with the program, the better they seem to feel about it.
> 
> Thoughts?
> 
> 

...

> 
> I think Jari might help also.  I told him that we could use some more 
> help with publicity.  So, he might blog.  He is thinking.  BTW, if 
> anyone wants to blog about our activities - we can do a mentoring 
> blog.  I am out of bandwidth for this but if someone thinks this would 
> be fun & wants to commit to it, then probably would be great.  It is a 
> bunch of work though, so I did not mention it.  Maybe we can do it in 
> the future. Problem is that if you do it, then you have to commit to it.
>

---

From: <[email-masked]>
Date: Tue, 2 Feb 2016 13:57:06 +0000 (UTC)

Gowri,
My comments inline.
 Nalini

      From: "Visweswaran, Gowri" <[email-masked]>
 To: "[email-masked]" <[email-masked]>; "Romascanu, Dan (Dan)" <[email-masked]>; "[email-masked]" <[email-masked]> 
 Sent: Monday, February 1, 2016 11:56 AM
 Subject: Re: [Mentoring-coordinators] Discuss New Way of Assigning Mentors

>I am thinking of volunteering to do the blog, would we set it up or would it be one hosted off the IETF website? I have my own personal blog and website which I am hosting myself. 
Nalini:  I think it might be easier to have a link to an external web site.   Thanks for thinking of this.  One thing, though, if you do it, then it would be really, really good if you actually attended IETF meetings.  It is hard to do this remotely.  I think case studies of good mentoring experiences will be nice to do here.  But, be careful of your time!

>In the below case, would having more than one mentor assigned to a mentee help if one of the mentors does not have the time or there is no common ground? Perhaps 2 mentors to a >mentee? 
Nalini: You know, things always happen.  I probably should not have said anything.  95% of the mentors are absolutely wonderful.  That is a very high percentage.  Sometimes people get busy and it happens.   I think if the mentoring team on the ground has good communication with the mentees, then we can re-assign or add a mentor as needed.
I will call you tonight to talk about web site additions.  I have some ideas about how to show the pictures.

Thanks,

Gowri

-----Original Message-----
From: mentoring-coordinators [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, February 1, 2016 9:12 AM
To: Romascanu, Dan (Dan); [email-masked]
Subject: Re: [Mentoring-coordinators] Discuss New Way of Assigning Mentors

 Thanks,

Nalini Elkins
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Original Message -----
From: "Romascanu, Dan (Dan)" <[email-masked]>
To: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Monday, February 1, 2016 5:57 AM
Subject: Re: [Mentoring-coordinators] Discuss New Way of Assigning Mentors

Hi Nailini,

See in-line. 

Thanks and Regards,

Dan

...

DR - yes, I agree. 

...

...

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 3 Feb 2016 10:32:49 +0000

From: [email-masked] [mailto:[email-masked]]

DR – I agree with Nalini here. I believe that two mentors to a mentee would be an overkill, and would result in scaling problems and a higher percentage of problems (because of mentors relying on each other for example) than dealing with the specific low cases of problems in the current situation. What we can do is to make clear to mentees that as soon as they feel that the mentors do not have enough bandwidth, or encounter other problems, they should not be shy to report this to the mentoring coordination team, and we will help in real-time.
Regards,

Dan