Subject: [Mentoring-coordinators] Remote Attendance: Simultaneous Translation Software

From: <[email-masked]>
Date: Sat, 9 Apr 2016 11:44:53 +0000 (UTC)

Guys,

I am wondering if anyone would like to work with me to explore where simultaneous translation software is at the moment.

One thing I noticed (and that the mentees told me) is that some of our fellow attendees have difficulties with the English language presentations.  As remote hubs and remote attendance (as well as attendance from all over the world) grows, I believe this will be more and more of a challenge.

I have started exploring some solutions which seem fairly cost-effective to me.  For example:

http://translateyourworld.com/pricing2016

If anyone has ideas or would like to work with me, please let me know.   We may come up with the thought that this is too costly or that the technology is immature, but IMHO, it is worth a try.

Thanks,

Nalini Elkins
IETF Mentoring Team

Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

---

From: Carlos Marcelo Martinez Cagnazzo <[email-masked]>
Date: Sat, 09 Apr 2016 10:00:02 -0300

Are you thinking about simultaneous interpretation (as in Icann meetings) 
or translation of the meeting materials?

Sent using CloudMagic Email 
[https://cloudmagic.com/k/d/mailapp?ct=pi&cv=7.6.23&pv=9.3&source=email_footer_2]
On Sat, Apr 9, 2016 at 8:44 AM, [email-masked] 
<[email-masked]> wrote:
Guys,

I am wondering if anyone would like to work with me to explore where 
simultaneous translation software is at the moment.

One thing I noticed (and that the mentees told me) is that some of our 
fellow attendees have difficulties with the English language presentations. 
As remote hubs and remote attendance (as well as attendance from all over 
the world) grows, I believe this will be more and more of a challenge.

I have started exploring some solutions which seem fairly cost-effective to 
me. For example:

If anyone has ideas or would like to work with me, please let me know. We 
may come up with the thought that this is too costly or that the technology 
is immature, but IMHO, it is worth a try.

Thanks,

Nalini Elkins
IETF Mentoring Team

Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

_______________________________________________
NOTE WELL: This list operates according to
http://mipassoc.org/dkim/ietf-list-rules.html.
https://www.ietf.org/mailman/listinfo/vmeet

---

From: Dhruv Dhody <[email-masked]>
Date: Sat, 9 Apr 2016 10:07:40 -0300

If it is regarding interpretation, I think the first step would be - good
speech to text (english), with a possible input to etherpad like tool, that
could be corrected by minute taker.

Unless we get this step right, any translation to another language would
not work.

Thanks!
Dhruv

On Sat, Apr 9, 2016 at 10:00 AM, Carlos Marcelo Martinez Cagnazzo <
[email-masked]> wrote:

> <https://cloudmagic.com/k/d/mailapp?ct=pi&cv=7.6.23&pv=9.3&source=email_footer_2>
>
> On Sat, Apr 9, 2016 at 8:44 AM, [email-masked] <
> [email-masked]> wrote:
>
> Guys,
>

---

From: John C Klensin <[email-masked]>
Date: Sat, 09 Apr 2016 09:45:38 -0400

Nalini,

I'd encourage moving in this direction only with great care for
three reasons.  First, many (I'd hope most) of the presentations
at IETF meetings are quite technical and specific, with small
differences in wording potentially making a large difference.
Such materials are notoriously hard to translate, especially if
the translators [1] are not subject matter experts.

Second, I note that, as a remote participant who is a native
first-language English speaker, there were several discussions
and presentations that, while in English, I had a great deal of
trouble understanding, even with the assistance of being able to
look at the slides and knowing the context.   That doesn't
predict high odds of success with real-time translation, at
least unless the translators have written copies of the
presentation available (something I would not encourage for
other reasons).

Third, like others (although I still haven't caught up on all of
the threads), I think the remote participation arrangements
worked much better this time than at previous IETFs and that we
are, with some exceptions, seeing steady improvement.   At the
same time, there are what can probably be described as "rough
edges", and it may be worth concentrating on straightening them
out -- making everything work well together-- before embarking
on major new adventures, e.g., thinking about simultaneous
translation or use of remote hub approaches for active group (or
facilitated individual) participation rather than only education
and outreach.  As just one example, the question of how to find
and use whatever arrangements exist has been an impediment to
convenient and effective remote participation for years.   The
incorporation of Meetecho links into the Tools agenda is a giant
step forward.  At the same time, that agenda is not updated in
real time to reflect non-WG meetings so, for example, the
Thursday Remote Hub meeting wasn't on it at all.   Similarly,
there were no links for Meetecho or audio feeds for the Sunday
tutorials and discussions.   

I also suggest that we don't have remote mentoring (for either
remote participants or remote mentors) sorted out.  I don't know
whether that is more or less important than simultaneous
translation, but I do know that we seem to have taken small
steps in that direction already.  My general message is that it
would probably be a good idea to get at least a significant
fraction of the tasks we are started on already done and working
really smoothly before starting on something we know (I hope) to
be a major task and a difficult one.

best,
    john

[1] Human, machine, or otherwise.

--On Saturday, April 09, 2016 11:44 +0000
[email-masked] wrote:

> Guys,
> 
> I am wondering if anyone would like to work with me to explore
> where simultaneous translation software is at the moment.
> 
> One thing I noticed (and that the mentees told me) is that
> some of our fellow attendees have difficulties with the
> English language presentations.  As remote hubs and remote
> attendance (as well as attendance from all over the world)
> grows, I believe this will be more and more of a challenge.
> 
> If anyone has ideas or would like to work with me, please let
> me know.   We may come up with the thought that this is too
> costly or that the technology is immature, but IMHO, it is
> worth a try.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Sat, 9 Apr 2016 14:03:58 +0000

On 4/9/16, 10:07 AM, "vmeet on behalf of Dhruv Dhody" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

If it is regarding interpretation, I think the first step would be - good speech to text (english), with a possible input to etherpad like tool, that could be corrected by minute taker.

I really like Dhruv's suggestion.  The result would help even the native English speakers and wouldn't be limited to remote participants.

Alvaro.

---

From: John C Klensin <[email-masked]>
Date: Sat, 09 Apr 2016 16:18:31 -0400

--On Saturday, April 09, 2016 14:03 +0000 "Alvaro Retana
(aretana)" <[email-masked]> wrote:

> If it is regarding interpretation, I think the first step
> would be - good speech to text (english), with a possible
> input to etherpad like tool, that could be corrected by minute
> taker.
> 
> I really like Dhruv's suggestion.  The result would help even
> the native English speakers and wouldn't be limited to remote
> participants.

Folks, fwiw, I've run IETF sessions through good-quality speech
to text programs.  The results have not been very helpful even
when the systems have been trained with dictionaries built by
scanning most of the RFCs I've written and a selection of
others.  When run with generic voices (rather than training to
my peculiar voice and speech patterns), the systems basically go
nuts and become useless when confronted with heavily-accented
English or "unusual" sentence rhythms.   Even those
unsatisfactory results aren't real-time either -- the systems
are reasonable for recording speech and delivering text with
some considerable, and cumulative, lag.

One could improve on that with more powerful software,
dictionaries, and computers, but, for example, I don't think
IASA or AMS have a supply of free supercomputer cycles.   The
ICANN transcription efforts, at least when I was last paying a
lot of attention, were different because they involved highly
skilled human transcribers and, at least as important, the
fraction of the ICANN discussions that involve highly technical
material tends to be quite small.

I'd be happy to have written transcripts too and I'm a native
English speaker.  However, please, let's try to keep this real
and, if we have expensive ideas, to be sure we understand where
the resources might come from and what would have to be pushed
to lower priority.

    john

---

From: <[email-masked]>
Date: Mon, 11 Apr 2016 00:35:12 +0000 (UTC)

John,

I saw that you posted much of this into the other thread.  I like Dhruv's idea of getting the English right first.  And, we may want technology that is not quite there yet.  But, in any case, let's let the other thread discuss this & we can stop this one.
 Thanks,

Nalini Elkins
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Original Message -----
From: John C Klensin <[email-masked]>
To: Alvaro Retana (aretana) <[email-masked]>; Dhruv Dhody <[email-masked]>; Carlos Marcelo Martinez Cagnazzo <[email-masked]>
Cc: [email-masked]; [email-masked]
Sent: Saturday, April 9, 2016 1:18 PM
Subject: Re: [vmeet] Remote Attendance: Simultaneous Translation Software

    john

---

From: <[email-masked]>
Date: Mon, 11 Apr 2016 00:37:23 +0000 (UTC)

John,

Points well taken!

The remote mentoring actually will develop as a result of a number of the other initiatives that we are doing (I think!).  But, I am a pretty trashed at this point.  Just got home.  So, will get back on in a week or so.
 Thanks,

Nalini Elkins
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Original Message -----
From: John C Klensin <[email-masked]>
To: [email-masked]; [email-masked]
Cc: [email-masked]
Sent: Saturday, April 9, 2016 6:45 AM
Subject: Re: [Mentoring-coordinators] [vmeet] Remote Attendance: Simultaneous Translation Software

Nalini,

best,
    john

_______________________________________________
mentoring-coordinators mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mentoring-coordinators