Subject: Re: [Mentoring-coordinators] IETF Remote Mentoring : Internet Draft Review Teams : 6lo / 6tisch

From: Thomas Watteyne <[email-masked]>
Date: Mon, 9 May 2016 16:39:09 +0200

Nalini,

Speaking for 6TiSCH, we have potential mentors who speak French, Italian,
Spanish, Catalan, Dutch.

I would encourage those new IETFers not to be too shy. A fresh eye on our
documents is always very helpful, and naive questions often show that
important informaiton is missing.

After they work with their mentor, they should contact the draft authors
unicast, or even better post an e-mail on the ML.

At 6TiSCH, we often hold interim meetings over Webex. They are welcome to
attend those and remain silent.

Thomas

On Tue, Apr 19, 2016 at 3:19 PM, <[email-masked]> wrote:

> Guys,
>
> The IETF Mentoring program is starting Internet Draft review teams
> comprised of new IETFers with a remote mentor.  They will discuss via email
> & web conference.  The first or second to start will be in the 6lo / 6tisch
> areas.   We have 3 people with whom I am working to start forming the team.
>
> I made up some procedures for the teams.  We may need to revise as this is
> new.  Please let me know what you think.  Please also let me know how best
> to give feedback to the author.
>
> As soon as the team picks a draft, I will ask for a remote mentor from
> your groups.  For 6lo / 6tisch, I believe the language for the team will be
> English.  But, I am waiting for the team to confirm.
>
> I appreciate any comments on improvement.
>
>
> The following are the instructions for the team.
>
>
> Procedures for Internet Draft Review Teams
> ----------------------------------------------------------
>
> 1.  Via email:
>
> - Decide what draft to review
> - Decide what language to use for discussions
>
> (I will also be assigning you a remote mentor to work with you.   Please
> decide on the draft and language first & then I can ask for a mentor from
> that WG.   The job of the mentor will be to help answer questions & to keep
> the discussions on track.   Each mentor will participate for one meeting.
> This is to be respectful of their time.   People are busy.  But, quite a
> few will volunteer for one hour or so.)
>
> - Decide what time works for a web based live discussion (Skype, Google
> Hangout, etc).   The people involved are your team and your mentor.
>
> (I will discuss what should happen in the discussion in a moment)
>
>
> 2.  Things to consider in choosing a draft
>
> The first time your team meets, find a small draft to review.   Your team
> needs to learn to work together before you handle longer / more complicated
> drafts.  Ideally, this is a draft that can be completely discussed in one
> meeting.
>
> You will each read the draft and make up 5 questions about the draft.
> Send these to the mentor before the meeting.   Do not copy the other people
> on the team so that they can have their own thoughts and not be
> "contaminated" by questions that another person asks.   You will be
> discussing the questions all together in the live web meeting.
>
> The questions can be about something you don't understand about what the
> authors are saying, something you think is wrong, will not work, or could
> be better explained.   Please include a section number and the original
> text in the question to make it easier to discuss.
>
> The mentor will organize everyone's questions in order by section.
>
>
> 3.  The discussion itself
>
> The mentor will lead the discussion.  If there are concepts that are not
> well understood by the team, the mentor will explain.
>
> The end result of the discussion should be:
>
> - much better understanding of the draft because of the discussion
>
> - questions to pose to the email list of the WG for things that are not
> clear in the draft or are seen as incorrect
>
> - one person in the team should post these to the email list.   Please
> include that this is coming from the review team & the members.   Work with
> the team (and the mentor) by email to properly phrase your question
>
>
> 4.  After the discussion.
>
> Some teams may want to stay together and discuss a new draft.  This is
> wonderful.   There may be some people who want to stop.  That is perfectly
> fine as well.   Some people may want to join a different group to discuss
> with different people & get new perspectives.  This is also great.
>
> I may also have new people who want to join a team.
>
> So, at the end of the discussion, I will send a survey to you to find out
> what you want to do.
>
>
> 5.  Please copy me on all emails, I want to see how this is going to work
> out.  After it becomes a well defined procedure, then I can be copied only
> for problems.
>
> Please let me know any comments.
>
> Thanks,
>
> Nalini Elkins
> Inside Products, Inc.
> www.insidethestack.com
> (831) 659-8360
>

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: <[email-masked]>
Date: Mon, 9 May 2016 15:54:39 +0000 (UTC)

Thanks so much, Thomas!   I will make the introduction to you for the Portuguese / English group.
I also have another team in India / China for 6lo/6tisch/roll.   They only have an email mentor at this time.   Might you be another one?  Can I introduce you to them as well?
(I am working to get more mentors in India / China!)
 Nalini
 
      From: Thomas Watteyne <[email-masked]>
 To: [email-masked] 
Cc: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>
 Sent: Monday, May 9, 2016 7:39 AM
 Subject: Re: IETF Remote Mentoring : Internet Draft Review Teams : 6lo / 6tisch
   
Nalini,
Speaking for 6TiSCH, we have potential mentors who speak French, Italian, Spanish, Catalan, Dutch.
I would encourage those new IETFers not to be too shy. A fresh eye on our documents is always very helpful, and naive questions often show that important informaiton is missing.
After they work with their mentor, they should contact the draft authors unicast, or even better post an e-mail on the ML.
At 6TiSCH, we often hold interim meetings over Webex. They are welcome to attend those and remain silent.
Thomas
On Tue, Apr 19, 2016 at 3:19 PM, <[email-masked]> wrote:

Guys,
The IETF Mentoring program is starting Internet Draft review teams comprised of new IETFers with a remote mentor.  They will discuss via email & web conference.  The first or second to start will be in the 6lo / 6tisch areas.   We have 3 people with whom I am working to start forming the team.
I made up some procedures for the teams.  We may need to revise as this is new.  Please let me know what you think.  Please also let me know how best to give feedback to the author.
As soon as the team picks a draft, I will ask for a remote mentor from your groups.  For 6lo / 6tisch, I believe the language for the team will be English.  But, I am waiting for the team to confirm.
I appreciate any comments on improvement.

Procedures for Internet Draft Review Teams----------------------------------------------------------
1.  Via email:
- Decide what draft to review- Decide what language to use for discussions
(I will also be assigning you a remote mentor to work with you.   Please decide on the draft and language first & then I can ask for a mentor from that WG.   The job of the mentor will be to help answer questions & to keep the discussions on track.   Each mentor will participate for one meeting.  This is to be respectful of their time.   People are busy.  But, quite a few will volunteer for one hour or so.)
- Decide what time works for a web based live discussion (Skype, Google Hangout, etc).   The people involved are your team and your mentor.

2.  Things to consider in choosing a draft
The first time your team meets, find a small draft to review.   Your team needs to learn to work together before you handle longer / more complicated drafts.  Ideally, this is a draft that can be completely discussed in one meeting.
You will each read the draft and make up 5 questions about the draft.  Send these to the mentor before the meeting.   Do not copy the other people on the team so that they can have their own thoughts and not be "contaminated" by questions that another person asks.   You will be discussing the questions all together in the live web meeting.   
The questions can be about something you don't understand about what the authors are saying, something you think is wrong, will not work, or could be better explained.   Please include a section number and the original text in the question to make it easier to discuss.
The mentor will organize everyone's questions in order by section.

3.  The discussion itself
The mentor will lead the discussion.  If there are concepts that are not well understood by the team, the mentor will explain.
The end result of the discussion should be:
- much better understanding of the draft because of the discussion
- questions to pose to the email list of the WG for things that are not clear in the draft or are seen as incorrect
- one person in the team should post these to the email list.   Please include that this is coming from the review team & the members.   Work with the team (and the mentor) by email to properly phrase your question

4.  After the discussion.
Some teams may want to stay together and discuss a new draft.  This is wonderful.   There may be some people who want to stop.  That is perfectly fine as well.   Some people may want to join a different group to discuss with different people & get new perspectives.  This is also great.
I may also have new people who want to join a team.
So, at the end of the discussion, I will send a survey to you to find out what you want to do.

5.  Please copy me on all emails, I want to see how this is going to work out.  After it becomes a well defined procedure, then I can be copied only for problems.
Please let me know any comments. Thanks,
Nalini ElkinsInside Products, Inc.www.insidethestack.com(831) 659-8360

-- 
_______________________________________
Thomas Watteyne, PhDResearch Scientist & Innovator, InriaSr Networking Design Eng, Linear TechFounder & co-lead, UC Berkeley OpenWSNCo-chair, IETF 6TiSCH
www.thomaswatteyne.com_______________________________________

---

From: Vinayak Hegde <[email-masked]>
Date: Mon, 9 May 2016 21:25:53 +0530

Hi Nalini / Others,

Anand and Malathi [cc-ed] are from IISc (one of India's topmost
research universities). They have a 6TiSCH testbed and are doing some
good work with IoT protocols. I had recently given a talk at workshop
in IISc and they were interested in participating more actively. They
are already subscribed to the mailing lists and have been
participating via them.

Nalini, maybe you will need to explain the concept to them offlist.

Thanks
Vinayak

On Mon, May 9, 2016 at 8:09 PM, Thomas Watteyne
<[email-masked]> wrote:
>> This is to be respectful of their time.   People are busy.  But, quite a few
>> will volunteer for one hour or so.)
>>
>> authors are saying, something you think is wrong, will not work, or could be
>> better explained.   Please include a section number and the original text in
>> the question to make it easier to discuss.
>>
> _______________________________________________
> mentoring-coordinators mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mentoring-coordinators
>

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 9 May 2016 17:59:11 +0200

Nalini, Vinayak,

Happy to discuss with Anad and Malathi. We have regular meeting with the
OpenWSN team (which implements 6TiSCH/6lo/roll open-source). Might be an
excellent venue for them to attend.

Thomas

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: <[email-masked]>
Date: Mon, 9 May 2016 16:09:31 +0000 (UTC)

Guys,
What we were thinking is to start setting up IETF labs.  I am a very hands-on person.  I know for myself, if I don't see packets flowing & can't pull cables, etc, it is much harder for me to learn.
So, with that thought in mind, we are trying to use two WGs as a Pilot project.   The 6lo / 6tisch, etc area is one.  (TLS is the other.)
We may be able to set up labs in India and Latin America.  I am adding the Latin American contingent to this email chain.   
This is a separate discussion from the Internet Draft Review teams. So, the discussion has to be:
1.  Configuration2.  Access3. Timeline
etc.
So, what are your thoughts on this?  Are there any other people we should involve?
Thanks,
Nalini

      From: Thomas Watteyne <[email-masked]>
 To: Vinayak Hegde <[email-masked]> 
Cc: Nalini Elkins <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; S.V.R.Anand <[email-masked]>; Malati Hegde <[email-masked]>
 Sent: Monday, May 9, 2016 8:59 AM
 Subject: Re: [Mentoring-coordinators] IETF Remote Mentoring : Internet Draft Review Teams : 6lo / 6tisch
   
Nalini, Vinayak,
Happy to discuss with Anad and Malathi. We have regular meeting with the OpenWSN team (which implements 6TiSCH/6lo/roll open-source). Might be an excellent venue for them to attend.
Thomas
On Mon, May 9, 2016 at 5:55 PM, Vinayak Hegde <[email-masked]> wrote:

Hi Nalini / Others,

Thanks
Vinayak

---

From: Samita Chakrabarti <[email-masked]>
Date: Tue, 10 May 2016 01:51:51 +0000

Hi Nalini,

Sorry for a late response. Thanks a lot for organizing such mentoring effort! Having additional folks reviewing 6lo drafts are very useful.
I also copied James Woodyatt, our 6lo secretary to be in the loop.

Also, it is great to see folks interests in 6lo/6tisch!

We can certainly have a starting discussion  on the phone and then at the coming IETF – 6tisch/6lo plan to have a joint plugtest in IETF96. So you might want to join there and  talk to the  6lo developers  for possible test bed setup  in India/Latin America.

Thomas and team has been working on a tool (as far as I know) which runs tests remotely in a shared environment.

It might be better to have  some sort of activity of testbed [I,e testing something real if possible] – I,e watering plants or measuring fitness data  etc.  .
Do you/team have such plan of proposal , timeline etc. ? Who is funding for this kind of effort?

Cheers,
-Samita

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, May 09, 2016 9:10 AM
To: Thomas Watteyne; Vinayak Hegde
Cc: Samita Chakrabarti; [email-masked]; [email-masked]; Suresh Krishnan; [email-masked]; S.V.R.Anand; Malati Hegde; Christian O'Flaherty; Alvaro Retana (aretana)
Subject: IETF 6lo Lab (was Re: [Mentoring-coordinators] IETF Remote Mentoring : Internet Draft Review Teams : 6lo / 6tisch)

Guys,

This is a separate discussion from the Internet Draft Review teams.

So, the discussion has to be:

1.  Configuration
2.  Access
3. Timeline

etc.

Thanks,
Nalini

________________________________
From: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>
To: Vinayak Hegde <[email-masked]<mailto:[email-masked]>>
Cc: Nalini Elkins <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>; S.V.R.Anand <[email-masked]<mailto:[email-masked]>>; Malati Hegde <[email-masked]<mailto:[email-masked]>>
Sent: Monday, May 9, 2016 8:59 AM
Subject: Re: [Mentoring-coordinators] IETF Remote Mentoring : Internet Draft Review Teams : 6lo / 6tisch

Nalini, Vinayak,

Thomas

On Mon, May 9, 2016 at 5:55 PM, Vinayak Hegde <[email-masked]<mailto:[email-masked]>> wrote:
Hi Nalini / Others,

Thanks
Vinayak

On Mon, May 9, 2016 at 8:09 PM, Thomas Watteyne
<[email-masked]<mailto:[email-masked]>> wrote:
> On Tue, Apr 19, 2016 at 3:19 PM, <[email-masked]<mailto:[email-masked]>> wrote:
>>
>> Guys,
>>
>> www.insidethestack.com<http://www.insidethestack.com/>
>> (831) 659-8360
>
>
>
>
> --
> www.thomaswatteyne.com<http://www.thomaswatteyne.com/>
> [email-masked]<mailto:[email-masked]>

Thomas Watteyne, PhD

www.thomaswatteyne.com<http://www.thomaswatteyne.com/>
_______________________________________

---

From: "S.V.R.Anand" <[email-masked]>
Date: Tue, 10 May 2016 11:32:20 +0530

Hello Nalini, Vinayak, Thomas, and others,

We will be extremely happy to be part of this exciting effort!

In our network labs at IISc, we are building a 6TiSCH testbed which is 
expected
to provide a platform for researchers to implement and test various 
algorithms
on it. One of the objectives of the testbed is to demonstrate 
applications on
the testbed that are of interest to the industry. We hope that this will 
result
in coming up with realistic problems that can be taken up as IETF WG
activities. I must admit that we just made a beginning :)

Thomas : We will be glad to interact with you and the OpenWSN team.

Regards
Anand

On Monday 09 May 2016 09:29 PM, Thomas Watteyne wrote:
> Nalini, Vinayak,  > > Happy to discuss with Anad and Malathi. We have regular meeting 
with the OpenWSN team (which implements 6TiSCH/6lo/roll open-source). 
Might be an excellent venue for them to attend. > > Thomas > > On Mon, 
May 9, 2016 at 5:55 PM, Vinayak Hegde <[email-masked]> wrote: > 
 >     Hi Nalini / Others, > >     Anand and Malathi [cc-ed] are from 
IISc (one of India's topmost >     research universities). They have a 
6TiSCH testbed and are doing some >     good work with IoT protocols. I 
had recently given a talk at workshop >     in IISc and they were 
interested in participating more actively. They >     are already 
subscribed to the mailing lists and have been >     participating via 
them. > >     Nalini, maybe you will need to explain the concept to them 
offlist. > >     Thanks >     Vinayak > >     On Mon, May 9, 2016 at 
8:09 PM, Thomas Watteyne >     <[email-masked]> wrote: >     > 
Nalini, >     > >     > Speaking for 6TiSCH, we have potential mentors 
who speak French, Italian, >     > Spanish, Catalan, Dutch. >     > 
 >     > I would encourage those new IETFers not to be too shy. A fresh 
eye on our >     > documents is always very helpful, and naive questions 
often show that >     > important informaiton is missing. >     > >     
 > After they work with their mentor, they should contact the draft 
authors >     > unicast, or even better post an e-mail on the ML. >     
 > >     > At 6TiSCH, we often hold interim meetings over Webex. They 
are welcome to >     > attend those and remain silent. >     > >     > 
Thomas >     > >     > On Tue, Apr 19, 2016 at 3:19 PM, 
<[email-masked]> wrote: >     >> >     >> Guys, >     
 >> >     >> The IETF Mentoring program is starting Internet Draft 
review teams >     >> comprised of new IETFers with a remote mentor.  
They will discuss via email >     >> & web conference.  The first or 
second to start will be in the 6lo / 6tisch >     >> areas.   We have 3 
people with whom I am working to start forming the team. >     >> >     
 >> I made up some procedures for the teams.  We may need to revise as 
this is >     >> new.  Please let me know what you think.  Please also 
let me know how best >     >> to give feedback to the author. >     >> 
 >     >> As soon as the team picks a draft, I will ask for a remote 
mentor from >     >> your groups.  For 6lo / 6tisch, I believe the 
language for the team will be >     >> English.  But, I am waiting for 
the team to confirm. >     >> >     >> I appreciate any comments on 
improvement. >     >> >     >> >     >> The following are the 
instructions for the team. >     >> >     >> >     >> Procedures for 
Internet Draft Review Teams >     >> 
---------------------------------------------------------- >     >> 
 >     >> 1.  Via email: >     >> >     >> - Decide what draft to review 
 >     >> - Decide what language to use for discussions >     >> >     
 >> (I will also be assigning you a remote mentor to work with you.   
Please >     >> decide on the draft and language first & then I can ask 
for a mentor from >     >> that WG.   The job of the mentor will be to 
help answer questions & to keep >     >> the discussions on track.   
Each mentor will participate for one meeting. >     >> This is to be 
respectful of their time.   People are busy.  But, quite a few >     >> 
will volunteer for one hour or so.) >     >> >     >> - Decide what time 
works for a web based live discussion (Skype, Google >     >> Hangout, 
etc).   The people involved are your team and your mentor. >     >> 
 >     >> (I will discuss what should happen in the discussion in a 
moment) >     >> >     >> >     >> 2.  Things to consider in choosing a 
draft >     >> >     >> The first time your team meets, find a small 
draft to review.   Your team >     >> needs to learn to work together 
before you handle longer / more complicated >     >> drafts.  Ideally, 
this is a draft that can be completely discussed in one >     >> 
meeting. >     >> >     >> You will each read the draft and make up 5 
questions about the draft. >     >> Send these to the mentor before the 
meeting.   Do not copy the other people >     >> on the team so that 
they can have their own thoughts and not be >     >> "contaminated" by 
questions that another person asks.   You will be >     >> discussing 
the questions all together in the live web meeting. >     >> >     >> 
The questions can be about something you don't understand about what the 
 >     >> authors are saying, something you think is wrong, will not 
work, or could be >     >> better explained.   Please include a section 
number and the original text in >     >> the question to make it easier 
to discuss. >     >> >     >> The mentor will organize everyone's 
questions in order by section. >     >> >     >> >     >> 3.  The 
discussion itself >     >> >     >> The mentor will lead the 
discussion.  If there are concepts that are not >     >> well understood 
by the team, the mentor will explain. >     >> >     >> The end result 
of the discussion should be: >     >> >     >> - much better 
understanding of the draft because of the discussion >     >> >     >> - 
questions to pose to the email list of the WG for things that are not 
 >     >> clear in the draft or are seen as incorrect >     >> >     >> 
 >     >> include that this is coming from the review team & the 
members.   Work with >     >> the team (and the mentor) by email to 
properly phrase your question >     >> >     >> >     >> 4.  After the 
discussion. >     >> >     >> Some teams may want to stay together and 
discuss a new draft.  This is >     >> wonderful.   There may be some 
people who want to stop.  That is perfectly >     >> fine as well.   
Some people may want to join a different group to discuss >     >> with 
different people & get new perspectives.  This is also great. >     >> 
 >     >> I may also have new people who want to join a team. >     >> 
 >     >> So, at the end of the discussion, I will send a survey to you 
to find out >     >> what you want to do. >     >> >     >> >     >> 5.  
Please copy me on all emails, I want to see how this is going to work 
 >     >> out.  After it becomes a well defined procedure, then I can be 
copied only >     >> for problems. >     >> >     >> Please let me know 
any comments. >     >> >     >> Thanks, >     >> >     >> Nalini Elkins 
 >     >> Inside Products, Inc. >     >> www.insidethestack.com >     >> 
(831) 659-8360 >     > >     > >     > >     > >     > -- >     > 
_______________________________________ >     > >     > Thomas Watteyne, 
PhD >     > Research Scientist & Innovator, Inria >     > Sr Networking 
Design Eng, Linear Tech >     > Founder & co-lead, UC Berkeley OpenWSN 
 >     > Co-chair, IETF 6TiSCH >     > >     > www.thomaswatteyne.com 
 >     > _______________________________________ >     > >     > 
_______________________________________________ >     > 
mentoring-coordinators mailing list >     > 
[email-masked] >     > 
https://www.ietf.org/mailman/listinfo/mentoring-coordinators >     > > > 
 > > > -- > _______________________________________ > > Thomas Watteyne, 
PhD > Research Scientist & Innovator, Inria > Sr Networking Design Eng, 
Linear Tech > Founder & co-lead, UC Berkeley OpenWSN > Co-chair, IETF 
6TiSCH > > www.thomaswatteyne.com > _______________________________________

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 10 May 2016 08:25:31 +0200

Fantastic, let's plan a discussion offline.

On Tue, May 10, 2016 at 8:02 AM, S.V.R.Anand <[email-masked]>
wrote:

> on it. One of the objectives of the testbed is to demonstrate applications
> on
> > Nalini, Vinayak, > > Happy to discuss with Anad and Malathi. We have
> regular meeting with the OpenWSN team (which implements 6TiSCH/6lo/roll
> open-source). Might be an excellent venue for them to attend. > > Thomas >
> > On Mon, May 9, 2016 at 5:55 PM, Vinayak Hegde <[email-masked]>
> <[email-masked]> wrote: > >     Hi Nalini / Others, > >     Anand and
> Malathi [cc-ed] are from IISc (one of India's topmost >     research
> universities). They have a 6TiSCH testbed and are doing some >     good
> work with IoT protocols. I had recently given a talk at workshop >     in
> IISc and they were interested in participating more actively. They >
> are already subscribed to the mailing lists and have been >
> participating via them. > >     Nalini, maybe you will need to explain the
> concept to them offlist. > >     Thanks >     Vinayak > >     On Mon, May
> 9, 2016 at 8:09 PM, Thomas Watteyne >     <[email-masked]>
> <[email-masked]> wrote: >     > Nalini, >     > >     >
> >     > Spanish, Catalan, Dutch. >     > >     > I would encourage those
> new IETFers not to be too shy. A fresh eye on our >     > documents is
> always very helpful, and naive questions often show that >     > important
> informaiton is missing. >     > >     > After they work with their mentor,
> they should contact the draft authors >     > unicast, or even better post
> an e-mail on the ML. >     > >     > At 6TiSCH, we often hold interim
> meetings over Webex. They are welcome to >     > attend those and remain
> silent. >     > >     > Thomas >     > >     > On Tue, Apr 19, 2016 at 3:19
> PM, <[email-masked]> <[email-masked]>
> wrote: >     >> >     >> Guys, >     >> >     >> The IETF Mentoring program
> is starting Internet Draft review teams >     >> comprised of new IETFers
> with a remote mentor.  They will discuss via email >     >> & web
> conference.  The first or second to start will be in the 6lo / 6tisch >
> >> areas.   We have 3 people with whom I am working to start forming the
> team. >     >> >     >> I made up some procedures for the teams.  We may
> need to revise as this is >     >> new.  Please let me know what you
> think.  Please also let me know how best >     >> to give feedback to the
> author. >     >> >     >> As soon as the team picks a draft, I will ask for
> a remote mentor from >     >> your groups.  For 6lo / 6tisch, I believe the
> language for the team will be >     >> English.  But, I am waiting for the
> team to confirm. >     >> >     >> I appreciate any comments on
> improvement. >     >> >     >> >     >> The following are the instructions
> for the team. >     >> >     >> >     >> Procedures for Internet Draft
> Review Teams >     >>
> ---------------------------------------------------------- >     >> >
> >> 1.  Via email: >     >> >     >> - Decide what draft to review >     >>
> - Decide what language to use for discussions >     >> >     >> (I will
> also be assigning you a remote mentor to work with you.   Please >     >>
> >     >> that WG.   The job of the mentor will be to help answer questions
> & to keep >     >> the discussions on track.   Each mentor will participate
> for one meeting. >     >> This is to be respectful of their time.   People
> are busy.  But, quite a few >     >> will volunteer for one hour or so.)
> >     >> >     >> - Decide what time works for a web based live discussion
> (Skype, Google >     >> Hangout, etc).   The people involved are your team
> and your mentor. >     >> >     >> (I will discuss what should happen in
> the discussion in a moment) >     >> >     >> >     >> 2.  Things to
> consider in choosing a draft >     >> >     >> The first time your team
> meets, find a small draft to review.   Your team >     >> needs to learn to
> work together before you handle longer / more complicated >     >> drafts.
> Ideally, this is a draft that can be completely discussed in one >     >>
> meeting.   Do not copy the other people >     >> on the team so that they
> can have their own thoughts and not be >     >> "contaminated" by questions
> that another person asks.   You will be >     >> discussing the questions
> all together in the live web meeting. >     >> >     >> The questions can
> be about something you don't understand about what the >     >> authors are
> saying, something you think is wrong, will not work, or could be >     >>
> better explained.   Please include a section number and the original text
> in >     >> the question to make it easier to discuss. >     >> >     >>
> The mentor will organize everyone's questions in order by section. >     >>
> >     >> >     >> 3.  The discussion itself >     >> >     >> The mentor
> will lead the discussion.  If there are concepts that are not >     >> well
> understood by the team, the mentor will explain. >     >> >     >> The end
> result of the discussion should be: >     >> >     >> - much better
> questions to pose to the email list of the WG for things that are not >
> >> clear in the draft or are seen as incorrect >     >> >     >> - one
> person in the team should post these to the email list.   Please >     >>
> >     >> the team (and the mentor) by email to properly phrase your
> question >     >> >     >> >     >> 4.  After the discussion. >     >>
> >     >> Some teams may want to stay together and discuss a new draft.
> This is >     >> wonderful.   There may be some people who want to stop.
> That is perfectly >     >> fine as well.   Some people may want to join a
> different group to discuss >     >> with different people & get new
> perspectives.  This is also great. >     >> >     >> I may also have new
> people who want to join a team. >     >> >     >> So, at the end of the
> discussion, I will send a survey to you to find out >     >> what you want
> to do. >     >> >     >> >     >> 5.  Please copy me on all emails, I want
> to see how this is going to work >     >> out.  After it becomes a well
> defined procedure, then I can be copied only >     >> for problems. >
> >> >     >> Please let me know any comments. >     >> >     >> Thanks,
> >     >> >     >> Nalini Elkins >     >> Inside Products, Inc. >     >>
> www.insidethestack.com >     >> (831) 659-8360 >     > >     > >     >
> >     > >     > -- >     > _______________________________________ >     >
> >     > Thomas Watteyne, PhD >     > Research Scientist & Innovator, Inria
> >     > Sr Networking Design Eng, Linear Tech >     > Founder & co-lead, UC
> Berkeley OpenWSN >     > Co-chair, IETF 6TiSCH >     > >     >
> www.thomaswatteyne.com >     > _______________________________________
> > > > -- > _______________________________________ > > Thomas Watteyne, PhD
> > Research Scientist & Innovator, Inria > Sr Networking Design Eng, Linear
> Tech > Founder & co-lead, UC Berkeley OpenWSN > Co-chair, IETF 6TiSCH > >
> www.thomaswatteyne.com > _______________________________________
>
>
>

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 10 May 2016 06:51:37 +0000

Thumbs up!

Cheers,

Pascal

From: Thomas Watteyne [mailto:[email-masked]]
Sent: mardi 10 mai 2016 08:26
To: S.V.R.Anand <[email-masked]>
Cc: Vinayak Hegde <[email-masked]>; Nalini Elkins <[email-masked]>; [email-masked]; Pascal Thubert (pthubert) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Malati Hegde <[email-masked]>
Subject: Re: [Mentoring-coordinators] IETF Remote Mentoring : Internet Draft Review Teams : 6lo / 6tisch

On Tue, May 10, 2016 at 8:02 AM, S.V.R.Anand <[email-masked]<mailto:[email-masked]>> wrote:
Hello Nalini, Vinayak, Thomas, and others,

In our network labs at IISc, we are building a 6TiSCH testbed which is expected
to provide a platform for researchers to implement and test various algorithms
on it. One of the objectives of the testbed is to demonstrate applications on
the testbed that are of interest to the industry. We hope that this will result
in coming up with realistic problems that can be taken up as IETF WG
activities. I must admit that we just made a beginning :)

Regards
Anand

On Monday 09 May 2016 09:29 PM, Thomas Watteyne wrote:
> Nalini, Vinayak, > > Happy to discuss with Anad and Malathi. We have regular meeting with the OpenWSN team (which implements 6TiSCH/6lo/roll open-source). Might be an excellent venue for them to attend. > > Thomas > > On Mon, May 9, 2016 at 5:55 PM, Vinayak Hegde <[email-masked]><mailto:[email-masked]> wrote: > >     Hi Nalini / Others, > >     Anand and Malathi [cc-ed] are from IISc (one of India's topmost >     research universities). They have a 6TiSCH testbed and are doing some >     good work with IoT protocols. I had recently given a talk at workshop >     in IISc and they were interested in participating more actively. They >     are already subscribed to the mailing lists and have been >     participating via them. > >     Nalini, maybe you will need to explain the concept to them offlist. > >     Thanks >     Vinayak > >     On Mon, May 9, 2016 at 8:09 PM, Thomas Watteyne >     <[email-masked]><mailto:[email-masked]> wrote: >     > Nalini, >     > >     > Speaking for 6TiSCH, we have potential mentors who speak French, Italian, >     > Spanish, Catalan, Dutch. >     > >     > I would encourage those new IETFers not to be too shy. A fresh eye on our >     > documents is always very helpful, and naive questions often show that >     > important informaiton is missing. >     > >     > After they work with their mentor, they should contact the draft authors >     > unicast, or even better post an e-mail on the ML. >     > >     > At 6TiSCH, we often hold interim meetings over Webex. They are welcome to >     > attend those and remain silent. >     > >     > Thomas >     > >     > On Tue, Apr 19, 2016 at 3:19 PM, <[email-masked]><mailto:[email-masked]> wrote: >     >> >     >> Guys, >     >> >     >> The IETF Mentoring program is starting Internet Draft review teams >     >> comprised of new IETFers with a remote mentor.  They will discuss via email >     >> & web conference.  The first or second to start will be in the 6lo / 6tisch >     >> areas.   We have 3 people with whom I am working to start forming the team. >     >> >     >> I made up some procedures for the teams.  We may need to revise as this is >     >> new.  Please let me know what you think.  Please also let me know how best >     >> to give feedback to the author. >     >> >     >> As soon as the team picks a draft, I will ask for a remote mentor from >     >> your groups.  For 6lo / 6tisch, I believe the language for the team will be >     >> English.  But, I am waiting for the team to confirm. >     >> >     >> I appreciate any comments on improvement. >     >> >     >> >     >> The following are the instructions for the team. >     >> >     >> >     >> Procedures for Internet Draft Review Teams >     >> ---------------------------------------------------------- >     >> >     >> 1.  Via email: >     >> >     >> - Decide what draft to review >     >> - Decide what language to use for discussions >     >> >     >> (I will also be assigning you a remote mentor to work with you.   Please >     >> decide on the draft and language first & then I can ask for a mentor from >     >> that WG.   The job of the mentor will be to help answer questions & to keep >     >> the discussions on track.   Each mentor will participate for one meeting. >     >> This is to be respectful of their time.   People are busy.  But, quite a few >     >> will volunteer for one hour or so.) >     >> >     >> - Decide what time works for a web based live discussion (Skype, Google >     >> Hangout, etc).   The people involved are your team and your mentor. >     >> >     >> (I will discuss what should happen in the discussion in a moment) >     >> >     >> >     >> 2.  Things to consider in choosing a draft >     >> >     >> The first time your team meets, find a small draft to review.   Your team >     >> needs to learn to work together before you handle longer / more complicated >     >> drafts.  Ideally, this is a draft that can be completely discussed in one >     >> meeting. >     >> >     >> You will each read the draft and make up 5 questions about the draft. >     >> Send these to the mentor before the meeting.   Do not copy the other people >     >> on the team so that they can have their own thoughts and not be >     >> "contaminated" by questions that another person asks.   You will be >     >> discussing the questions all together in the live web meeting. >     >> >     >> The questions can be about something you don't understand about what the >     >> authors are saying, something you think is wrong, will not work, or could be >     >> better explained.   Please include a section number and the original text in >     >> the question to make it easier to discuss. >     >> >     >> The mentor will organize everyone's questions in order by section. >     >> >     >> >     >> 3.  The discussion itself >     >> >     >> The mentor will lead the discussion.  If there are concepts that are not >     >> well understood by the team, the mentor will explain. >     >> >     >> The end result of the discussion should be: >     >> >     >> - much better understanding of the draft because of the discussion >     >> >     >> - questions to pose to the email list of the WG for things that are not >     >> clear in the draft or are seen as incorrect >     >> >     >> - one person in the team should post these to the email list.   Please >     >> include that this is coming from the review team & the members.   Work with >     >> the team (and the mentor) by email to properly phrase your question >     >> >     >> >     >> 4.  After the discussion. >     >> >     >> Some teams may want to stay together and discuss a new draft.  This is >     >> wonderful.   There may be some people who want to stop.  That is perfectly >     >> fine as well.   Some people may want to join a different group to discuss >     >> with different people & get new perspectives.  This is also great. >     >> >     >> I may also have new people who want to join a team. >     >> >     >> So, at the end of the discussion, I will send a survey to you to find out >     >> what you want to do. >     >> >     >> >     >> 5.  Please copy me on all emails, I want to see how this is going to work >     >> out.  After it becomes a well defined procedure, then I can be copied only >     >> for problems. >     >> >     >> Please let me know any comments. >     >> >     >> Thanks, >     >> >     >> Nalini Elkins >     >> Inside Products, Inc. >     >> www.insidethestack.com<http://www.insidethestack.com> >     >> (831) 659-8360<tel:%28831%29%20659-8360> >     > >     > >     > >     > >     > -- >     > _______________________________________ >     > >     > Thomas Watteyne, PhD >     > Research Scientist & Innovator, Inria >     > Sr Networking Design Eng, Linear Tech >     > Founder & co-lead, UC Berkeley OpenWSN >     > Co-chair, IETF 6TiSCH >     > >     > www.thomaswatteyne.com<http://www.thomaswatteyne.com> >     > _______________________________________ >     > >     > _______________________________________________ >     > mentoring-coordinators mailing list >     > [email-masked]<mailto:[email-masked]> >     > https://www.ietf.org/mailman/listinfo/mentoring-coordinators >     > > > > > > -- > _______________________________________ > > Thomas Watteyne, PhD > Research Scientist & Innovator, Inria > Sr Networking Design Eng, Linear Tech > Founder & co-lead, UC Berkeley OpenWSN > Co-chair, IETF 6TiSCH > > www.thomaswatteyne.com<http://www.thomaswatteyne.com> > _______________________________________

Thomas Watteyne, PhD

www.thomaswatteyne.com<http://www.thomaswatteyne.com>
_______________________________________

---

From: <[email-masked]>
Date: Tue, 10 May 2016 04:18:03 +0000 (UTC)

Samita,
This is a very, very preliminary effort.   We are just testing the waters.  I actually wanted to do something small so that we could learn from the effort.
We need to make a plan to see how and if to proceed.
The idea is to have new things that IETF is working on available in a lab setting.
Funding will come from Latin America / India.  I will let them speak to that.   Again, we are in a VERY preliminary stage in our thinking on this.    We can certainly chat on the phone and in Berlin. Thanks,
Nalini ElkinsInside Products, Inc.www.insidethestack.com(831) 659-8360

      From: Samita Chakrabarti <[email-masked]>
 To: "[email-masked]" <[email-masked]>; Thomas Watteyne <[email-masked]>; Vinayak Hegde <[email-masked]> 
Cc: "[email-masked]" <[email-masked]>; S.V.R.Anand <[email-masked]>; Malati Hegde <[email-masked]>; Suresh Krishnan <[email-masked]>; "[email-masked]" <[email-masked]>; "James Woodyatt ([email-masked])" <[email-masked]>; Alvaro Retana (aretana) <[email-masked]>; "[email-masked]" <[email-masked]>; Christian O'Flaherty <[email-masked]>
 Sent: Monday, May 9, 2016 6:51 PM
 Subject: Re: [Mentoring-coordinators] IETF 6lo Lab (was Re: IETF Remote Mentoring : Internet Draft Review Teams : 6lo / 6tisch)
   
#yiv6337153160 #yiv6337153160 -- _filtered #yiv6337153160 {font-family:Helvetica;panose-1:2 11 6 4 2 2 2 2 2 4;} _filtered #yiv6337153160 {font-family:Helvetica;panose-1:2 11 6 4 2 2 2 2 2 4;} _filtered #yiv6337153160 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;} _filtered #yiv6337153160 {font-family:Tahoma;panose-1:2 11 6 4 3 5 4 4 2 4;}#yiv6337153160 #yiv6337153160 p.yiv6337153160MsoNormal, #yiv6337153160 li.yiv6337153160MsoNormal, #yiv6337153160 div.yiv6337153160MsoNormal {margin:0in;margin-bottom:.0001pt;font-size:12.0pt;}#yiv6337153160 a:link, #yiv6337153160 span.yiv6337153160MsoHyperlink {color:blue;text-decoration:underline;}#yiv6337153160 a:visited, #yiv6337153160 span.yiv6337153160MsoHyperlinkFollowed {color:purple;text-decoration:underline;}#yiv6337153160 p.yiv6337153160MsoAcetate, #yiv6337153160 li.yiv6337153160MsoAcetate, #yiv6337153160 div.yiv6337153160MsoAcetate {margin:0in;margin-bottom:.0001pt;font-size:8.0pt;}#yiv6337153160 span.yiv6337153160BalloonTextChar {}#yiv6337153160 span.yiv6337153160EmailStyle19 {color:#1F497D;}#yiv6337153160 .yiv6337153160MsoChpDefault {font-size:10.0pt;} _filtered #yiv6337153160 {margin:1.0in 1.0in 1.0in 1.0in;}#yiv6337153160 div.yiv6337153160WordSection1 {}#yiv6337153160 Hi Nalini,       Sorry for a late response. Thanks a lot for organizing such mentoring effort! Having additional folks reviewing 6lo drafts are very useful. I also copied James Woodyatt, our 6lo secretary to be in the loop.    Also, it is great to see folks interests in 6lo/6tisch!    We can certainly have a starting discussion  on the phone and then at the coming IETF – 6tisch/6lo plan to have a joint plugtest in IETF96. So you might want to join there and  talk to the  6lo developers  for possible test bed setup  in India/Latin America.    Thomas and team has been working on a tool (as far as I know) which runs tests remotely in a shared environment.    It might be better to have  some sort of activity of testbed [I,e testing something real if possible] – I,e watering plants or measuring fitness data  etc.  . Do you/team have such plan of proposal , timeline etc. ? Who is funding for this kind of effort?       Cheers, -Samita    From: [email-masked] [mailto:[email-masked]]
Sent: Monday, May 09, 2016 9:10 AM
To: Thomas Watteyne; Vinayak Hegde
Cc: Samita Chakrabarti; [email-masked]; [email-masked]; Suresh Krishnan; [email-masked]; S.V.R.Anand; Malati Hegde; Christian O'Flaherty; Alvaro Retana (aretana)
Subject: IETF 6lo Lab (was Re: [Mentoring-coordinators] IETF Remote Mentoring : Internet Draft Review Teams : 6lo / 6tisch)    Guys,    What we were thinking is to start setting up IETF labs.  I am a very hands-on person.  I know for myself, if I don't see packets flowing & can't pull cables, etc, it is much harder for me to learn.    So, with that thought in mind, we are trying to use two WGs as a Pilot project.   The 6lo / 6tisch, etc area is one.  (TLS is the other.)    We may be able to set up labs in India and Latin America.  I am adding the Latin American contingent to this email chain.       This is a separate discussion from the Internet Draft Review teams.   So, the discussion has to be:    1.  Configuration 2.  Access 3. Timeline    etc.    So, what are your thoughts on this?  Are there any other people we should involve?    Thanks,
Nalini    From: Thomas Watteyne <[email-masked]>
To: Vinayak Hegde <[email-masked]>
Cc: Nalini Elkins <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; S.V.R.Anand <[email-masked]>; Malati Hegde <[email-masked]>
Sent: Monday, May 9, 2016 8:59 AM
Subject: Re: [Mentoring-coordinators] IETF Remote Mentoring : Internet Draft Review Teams : 6lo / 6tisch    Nalini, Vinayak,    Happy to discuss with Anad and Malathi. We have regular meeting with the OpenWSN team (which implements 6TiSCH/6lo/roll open-source). Might be an excellent venue for them to attend.    Thomas    On Mon, May 9, 2016 at 5:55 PM, Vinayak Hegde <[email-masked]> wrote: Hi Nalini / Others,

Thanks
Vinayak 
> https://www.ietf.org/mailman/listinfo/mentoring-coordinators

    -- _______________________________________    Thomas Watteyne, PhD Research Scientist & Innovator, Inria Sr Networking Design Eng, Linear Tech Founder & co-lead, UC Berkeley OpenWSN Co-chair, IETF 6TiSCH    www.thomaswatteyne.com _______________________________________

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 10 May 2016 07:41:29 +0200

Nalini,

A couple of tools we have:
- we have a complete implementation of 6TiSCH/6lo/roll technology called
OpenWSN (http://www.openwsn.org) which is super active
- we have a spin off company of that project called OpenMote (
http://www.openmote.com/)
- we are giving a tutorial about OpenWSN and OpenMote at the IEEE ICT-2016
on May 16, and IEEE PIMRC on Sept 8
- we have a 2728-mote open testbed called IoT-lab (https://www.iot-lab.info/)
for people to develop/test this technology.

That ecosystem is certainly a complete starting point for some hands-on
activity around 6TiSCH/6lo/roll technology.

Thomas

On Tue, May 10, 2016 at 3:51 AM, Samita Chakrabarti <
[email-masked]> wrote:

> Hi Nalini,
>
>
>
>
>
> Sorry for a late response. Thanks a lot for organizing such mentoring
> effort! Having additional folks reviewing 6lo drafts are very useful.
>
> We can certainly have a starting discussion  on the phone and then at the
> coming IETF – 6tisch/6lo plan to have a joint plugtest in IETF96. So you
> might want to join there and  talk to the  6lo developers  for possible
> test bed setup  in India/Latin America.
>
>
>
> It might be better to have  some sort of activity of testbed [I,e testing
> something real if possible] – I,e watering plants or measuring fitness
> data  etc.  .
>
> *From:* [email-masked] [mailto:
> [email-masked]]
> *Sent:* Monday, May 09, 2016 9:10 AM
> *To:* Thomas Watteyne; Vinayak Hegde
> *Cc:* Samita Chakrabarti; [email-masked];
> [email-masked]; Suresh Krishnan;
> [email-masked]; S.V.R.Anand; Malati Hegde; Christian
> O'Flaherty; Alvaro Retana (aretana)
> *Subject:* IETF 6lo Lab (was Re: [Mentoring-coordinators] IETF Remote
> Mentoring : Internet Draft Review Teams : 6lo / 6tisch)
>
>
>
> Guys,
>
>
>
> What we were thinking is to start setting up IETF labs.  I am a very
> hands-on person.  I know for myself, if I don't see packets flowing & can't
> pull cables, etc, it is much harder for me to learn.
>
>
>
> So, with that thought in mind, we are trying to use two WGs as a Pilot
> project.   The 6lo / 6tisch, etc area is one.  (TLS is the other.)
>
>
>
> We may be able to set up labs in India and Latin America.  I am adding the
> Latin American contingent to this email chain.
>
>
>
> ------------------------------
>
> *From:* Thomas Watteyne <[email-masked]>
> *To:* Vinayak Hegde <[email-masked]>
> *Cc:* Nalini Elkins <[email-masked]>; "
> [email-masked]" <[email-masked]>; "
> [email-masked]" <[email-masked]>; "
> [email-masked]" <[email-masked]>; "
> [email-masked]" <[email-masked]>; "
> [email-masked]" <[email-masked]>;
> S.V.R.Anand <[email-masked]>; Malati Hegde <
> [email-masked]>
> *Sent:* Monday, May 9, 2016 8:59 AM
> *Subject:* Re: [Mentoring-coordinators] IETF Remote Mentoring : Internet
> Draft Review Teams : 6lo / 6tisch
>
>
>
> Nalini, Vinayak,
>
>
>
> team.

Thomas Watteyne, PhD

www.thomaswatteyne.com