Subject: [Mentoring-coordinators] draft-kompella-mpls-rmr-01 - Comments

From: "Ger, Javier" <[email-masked]>
Date: Sat, 28 May 2016 01:56:55 +0000

Hello Greg,

Thanks again for your time and help. I am sending you comments related to draft-kompella-mpls-rmr-01. Apologies in advance if some question is too basic or not clear enough. Also, since Entropy Labels in SR draft is closed, I am reading the BFD draft and will share my questions during next week.

Hello Nalini, please let me know if I should remove you and mentoring coordinators from the thread or you prefer to continue in cc.

1.    Page 4 - Ring direction. It has only 2 bits. Would they be enough? or Would it be needed some additional experimental bits for future use? Are they already considered on another IGP fields (I did not read drafts related to IGP extensions for RMR).

2.    Page 6 – “A ring node indicates in its IGP updates the ring LSP signaling protocols it supports. This can be LDP and/or RSVP-TE. Ideally, each node should support both.”

Should not SR be also included in the scope (since it is another option for the MPLS control plane)? Or at least some mention about its future inclusion (similar to what is stated for express link in the same Page 6)?

3.    Page 7 – I get confused with the RSVP-TE “reverse call admission control” concept.

Does it mean that BW is not reserved in both directions? If so, what happen with backup or “other direction” path when traffic has to be sent through it (because current has some failure)? Can the CAC reject the request? How it works considering the LSP are multipoint, i.e. the BW is aggregate of all ring nodes that will use this LSP?

4.    Same page as previous comment for “counter-rotating pairs” concept.

Does it mean that there are always a pair of LSPs, one CW and second AC?

5.    Page 8 – I did not understand in depth the proposals for protections and loop avoidance. How can I get further clarification?

6.    Page 11 – Similar to comment #2 for SS and SU field related to SR. Should it be signaled in the IGP?

Additionally, SS and SU have only 2 bits. Are they enough or some extra experimental bit might be needed for future use?

7.    Page 11 – Ring Announcement Phase.

It might be needed to clarify that the MV value is not mandatory (Or is it?), and if not provisioned the lower loopback address will be taken into consideration to elect the Ring Master.

8.    Page 11/12 – I did not understand in depth the timers (T1, T2) and how each node and all of them are going through different phases to elect the Ring Master. General concept is OK, but I think a better explanation about the sequence, including details, would be great. Perhaps a timeline containing events, timers, parameters and its values can help. A state machine is another option.

9.    Page 13 – Ring OAM.

The default hello interval for OAM protocol is defined in 3.3ms. It is not clear the reasons for this value. Furthermore, the amount of lost packets to determine a fault is not defined.

On the other hand, hello interval for the LSP is defined is one second. Again, the reasons for this value might be missing, since it does not allow sub-second reconvergence nor it is defined the number of lost packets to determine a failure.

10.  Additionally, as far as I understand ring direction is a parameter used by IGP to calculate path but it is not directly related to LSP direction, right? I mean, LSP is enabled to go through both ring directions but only one through a link (otherwise there would be loops).

11.  Do you think some clarification might be needed related to overlapping with TI-LFA?

12.  Minor comment. Page 2 – “it is imperative that MPLS handles rings well; this is not the case today.”

I think this sentence is very unspecific and might lead to some confusion. Today MPLS is working in different topologies, including rings, with no issues. This proposal is improving things like redundancy on MPLS layer itself, convergence time, control plane scalability, etc. but it does not mean that MPLS is working “bad”.

I think it is much more precise in Page 5 paragraph “The goals of this document …”

13.  Very minor comments.

Page 9 – “In what follows, we refer to a ring node and a rink link Type-Length-Value (TLV).” rink -> ring

Page 10 - Ring ID 2 -> Ring ID 3  - 3rd Ring ID field on IS-IS Ring TLV Format
Best regards.

Javier Ger
Arquitectura y Tecnología
Gerencia Técnica | Ingeniería
Tel: (+54<Tel:(+54> 11)5530-4531
Cel: (+54 9 11)3926-5017
Hornos 690. CABA, CP C1272ACL
Argentina

De: Gregory Mirsky [mailto:[email-masked]]
Enviado el: jueves, 19 de mayo de 2016 05:31 p.m.
Para: Andrés Balcabao <[email-masked]>; Ger, Javier <[email-masked]>
CC: [email-masked]; [email-masked]
Asunto: RE: Mentor Introduction: MPLS Internet Draft Review Team

Thank you, Nalini.

Hi Andres and Javier,
very good selection of the drafts:

·         RMR promises significantly simplify management of ringy MPLS topologies;

·         applicability of Entropy Label in Segment Routing been extensively discussed as part of the WG LC and the update should be coming;

·         BFD directed … I’m co-author on that. The draft is WFLC-ready but will greatly appreciate your thoughts, questions and we can have the discussion on the MPLS WG list;

·         T-LDP been, AFAIK, through WGLC and we can look through MPLS WG archive for the discussion, comments.

Please share your questions, thoughts on these or any other MPLS drafts. Will be glad to help.

                Regards,
                                Greg

From: Andrés Balcabao [mailto:[email-masked]]
Sent: Thursday, May 19, 2016 12:53 PM
To: Ger, Javier
Cc: [email-masked]<mailto:[email-masked]>; Gregory Mirsky; [email-masked]<mailto:[email-masked]>
Subject: Re: Mentor Introduction: MPLS Internet Draft Review Team

Nice to meet you Greg. It sounds perfect !!!

Regards

Andrés Balcabao
Ingeniería de Backbone IP/MPLS
Virrey Cevallos 422 | C1077AAJ | Bs As | Argentina
Teléfono: 54-11-5031-6354
IPLAN | iplan.com.ar<http://www.iplan.com.ar/>

2016-05-19 16:49 GMT-03:00 Ger, Javier <[email-masked]<mailto:[email-masked]>>:
It works for me Nalini. Thank you and thanks also to Greg.

The following are my choices (order by interest). Anyway, I am willing to start working on any draft the group decides.

•         draft-ietf-mpls-rmr-01

•         draft-ietf-mpls-spring-entropy-label-03

•         draft-ietf-mpls-bfd-directed-02

•         draft-ietf-mpls-app-aware-tldp-03

Regards.

Javier Ger
Arquitectura y Tecnología
Gerencia Técnica | Ingeniería
Tel: (+54<Tel:(+54> 11)5530-4531
Cel: (+54 9 11)3926-5017
Hornos 690. CABA, CP C1272ACL
Argentina

De: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Enviado el: jueves, 19 de mayo de 2016 04:24 p.m.
Para: Andrés Balcabao <[email-masked]<mailto:[email-masked]>>; Ger, Javier <[email-masked]<mailto:[email-masked]>>; Gregory Mirsky <[email-masked]<mailto:[email-masked]>>
CC: [email-masked]<mailto:[email-masked]>
Asunto: Mentor Introduction: MPLS Internet Draft Review Team

Andres, Javier and Greg,

Let me introduce you.

Andres and Javier are forming an Internet Draft Review Team to study drafts in the MPLS WG.

Greg has been involved in MPLS for many years and will be able to guide you.   Thank you, Greg!

I was not able to find a Spanish speaking mentor, unfortunately!

The drafts the team is interested in are:

draft-ietf-mpls-app-aware-tldp-03
draft-ietf-mpls-rmr-01
draft-ietf-mpls-spring-entropy-label-03
draft-ietf-mpls-bfd-directed-02

How I see this proceeding is that the team will select one draft at a time to read and then find 5 questions to pose on the draft.

You may then have a webcast to discuss or do it via email.

Make sense?  Questions?

Thanks,

Nalini Elkins
IETF Mentoring Team

Inside Products, Inc.
www.insidethestack.com<http://www.insidethestack.com>
(831) 659-8360

Visite https://www.cablevisionfibertel.com.ar
__________________________________________
Este mensaje es confidencial. Puede contener informacion amparada por el secreto comercial.
Si usted ha recibido este e-mail por error, debera eliminarlo de su sistema.
No debera copiar el mensaje ni divulgar su contenido a ninguna persona.
Muchas gracias.
This message is confidential. It may also contain information that is privileged or not authorized to be disclosed. If you have received it by mistake, delete it from your system.
You should not copy the messsage nor disclose its contents to anyone.
Many thanks.
__________________________________________

________________________________

No Imprimas Digitalizá

________________________________

ESTE MENSAJE ES CONFIDENCIAL. Puede contener información amparada por el secreto profesional. Si usted ha recibido este e-mail por error, por favor comuníquenoslo inmediatamente vía e-mail y tenga la amabilidad de eliminarlo de su sistema; no deberá copiar el mensaje ni divulgar su contenido a ninguna persona. Muchas gracias.

THIS MESSAGE IS CONFIDENTIAL. It may also contain information that is privileged or otherwise legally exempt from disclosure. If you have received it by mistake please let us know by e-mail immediately and delete it from your system; should also not copy the message nor disclose its contents to anyone. Many thanks.

Visite https://www.cablevisionfibertel.com.ar<br>__________________________________________<br>
Este mensaje es confidencial. Puede contener informacion amparada por el secreto comercial.<br>Si usted ha recibido este e-mail por error, debera eliminarlo de su sistema.<br>No debera copiar el mensaje ni divulgar su contenido a ninguna persona.<br>Muchas gracias.<br>This message is confidential. It may also contain information that is privileged or not authorized to be disclosed. If you have received it by mistake, delete it from your system.<br>You should not copy the messsage nor disclose its contents to anyone.<br>Many thanks.<br>__________________________________________

---

From: <[email-masked]>
Date: Sat, 28 May 2016 03:39:09 +0000 (UTC)

Javier,
Great work!
Please continue to copy me.  I like to keep track of what is going on.   Please drop the mentoring coordinators. Thanks,
Nalini ElkinsInside Products, Inc.www.insidethestack.com(831) 659-8360

      From: "Ger, Javier" <[email-masked]>
 To: Gregory Mirsky <[email-masked]>; Andrés Balcabao <[email-masked]> 
Cc: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>
 Sent: Friday, May 27, 2016 6:56 PM
 Subject: draft-kompella-mpls-rmr-01 - Comments
   
 <!--#yiv2025051247 _filtered #yiv2025051247 {font-family:Helvetica;panose-1:2 11 6 4 2 2 2 2 2 4;} _filtered #yiv2025051247 {font-family:Wingdings;panose-1:5 0 0 0 0 0 0 0 0 0;} _filtered #yiv2025051247 {font-family:"Cambria Math";panose-1:2 4 5 3 5 4 6 3 2 4;} _filtered #yiv2025051247 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;} _filtered #yiv2025051247 {font-family:"Segoe UI";panose-1:2 11 5 2 4 2 4 2 2 3;} _filtered #yiv2025051247 {font-family:Tahoma;panose-1:2 11 6 4 3 5 4 4 2 4;} _filtered #yiv2025051247 {font-family:Verdana;panose-1:2 11 6 4 3 5 4 4 2 4;} _filtered #yiv2025051247 {font-family:"Bookman Old Style";panose-1:2 5 6 4 5 5 5 2 2 4;} _filtered #yiv2025051247 {font-family:Consolas;panose-1:2 11 6 9 2 2 4 3 2 4;}#yiv2025051247 #yiv2025051247 p.yiv2025051247MsoNormal, #yiv2025051247 li.yiv2025051247MsoNormal, #yiv2025051247 div.yiv2025051247MsoNormal {margin:0cm;margin-bottom:.0001pt;font-size:12.0pt;font-family:"Times New Roman", serif;}#yiv2025051247 a:link, #yiv2025051247 span.yiv2025051247MsoHyperlink {color:blue;text-decoration:underline;}#yiv2025051247 a:visited, #yiv2025051247 span.yiv2025051247MsoHyperlinkFollowed {color:purple;text-decoration:underline;}#yiv2025051247 p {margin-right:0cm;margin-left:0cm;font-size:12.0pt;font-family:"Times New Roman", serif;}#yiv2025051247 pre {margin:0cm;margin-bottom:.0001pt;font-size:10.0pt;font-family:"Courier New";}#yiv2025051247 p.yiv2025051247MsoAcetate, #yiv2025051247 li.yiv2025051247MsoAcetate, #yiv2025051247 div.yiv2025051247MsoAcetate {margin:0cm;margin-bottom:.0001pt;font-size:8.0pt;font-family:"Tahoma", sans-serif;}#yiv2025051247 p.yiv2025051247MsoListParagraph, #yiv2025051247 li.yiv2025051247MsoListParagraph, #yiv2025051247 div.yiv2025051247MsoListParagraph {margin-top:0cm;margin-right:0cm;margin-bottom:0cm;margin-left:36.0pt;margin-bottom:.0001pt;font-size:12.0pt;font-family:"Times New Roman", serif;}#yiv2025051247 span.yiv2025051247HTMLconformatoprevioCar {font-family:Consolas;}#yiv2025051247 span.yiv2025051247TextodegloboCar {font-family:"Segoe UI", sans-serif;}#yiv2025051247 p.yiv2025051247HTMLPreformatted, #yiv2025051247 li.yiv2025051247HTMLPreformatted, #yiv2025051247 div.yiv2025051247HTMLPreformatted {margin:0cm;margin-bottom:.0001pt;font-size:12.0pt;font-family:"Times New Roman", serif;}#yiv2025051247 span.yiv2025051247HTMLPreformattedChar {font-family:Consolas;}#yiv2025051247 span.yiv2025051247EstiloCorreo25 {font-family:"Calibri", sans-serif;color:#1F497D;}#yiv2025051247 p.yiv2025051247BalloonText, #yiv2025051247 li.yiv2025051247BalloonText, #yiv2025051247 div.yiv2025051247BalloonText {margin:0cm;margin-bottom:.0001pt;font-size:12.0pt;font-family:"Times New Roman", serif;}#yiv2025051247 span.yiv2025051247BalloonTextChar {font-family:"Tahoma", sans-serif;}#yiv2025051247 span.yiv2025051247EstiloCorreo28 {font-family:"Bookman Old Style", serif;color:#1F497D;}#yiv2025051247 .yiv2025051247MsoChpDefault {font-size:10.0pt;} _filtered #yiv2025051247 {margin:72.0pt 72.0pt 72.0pt 72.0pt;}#yiv2025051247 div.yiv2025051247WordSection1 {}#yiv2025051247 _filtered #yiv2025051247 {} _filtered #yiv2025051247 {} _filtered #yiv2025051247 {} _filtered #yiv2025051247 {} _filtered #yiv2025051247 {} _filtered #yiv2025051247 {} _filtered #yiv2025051247 {} _filtered #yiv2025051247 {} _filtered #yiv2025051247 {} _filtered #yiv2025051247 {} _filtered #yiv2025051247 {} _filtered #yiv2025051247 {font-family:Symbol;} _filtered #yiv2025051247 {font-family:"Courier New";} _filtered #yiv2025051247 {font-family:Wingdings;} _filtered #yiv2025051247 {font-family:Symbol;} _filtered #yiv2025051247 {font-family:"Courier New";} _filtered #yiv2025051247 {font-family:Wingdings;} _filtered #yiv2025051247 {font-family:Symbol;} _filtered #yiv2025051247 {font-family:"Courier New";} _filtered #yiv2025051247 {font-family:Wingdings;} _filtered #yiv2025051247 {} _filtered #yiv2025051247 {font-family:Symbol;} _filtered #yiv2025051247 {font-family:"Courier New";} _filtered #yiv2025051247 {font-family:Wingdings;} _filtered #yiv2025051247 {font-family:Symbol;} _filtered #yiv2025051247 {font-family:"Courier New";} _filtered #yiv2025051247 {font-family:Wingdings;} _filtered #yiv2025051247 {font-family:Symbol;} _filtered #yiv2025051247 {font-family:"Courier New";} _filtered #yiv2025051247 {font-family:Wingdings;}#yiv2025051247 ol {margin-bottom:0cm;}#yiv2025051247 ul {margin-bottom:0cm;}-->Hello Greg,    Thanks again for your time and help. I am sending you comments related to draft-kompella-mpls-rmr-01. Apologies in advance if some question is too basic or not clear enough. Also, since Entropy Labels in SR draft is closed, I am reading the BFD draft and will share my questions during next week.    Hello Nalini, please let me know if I should remove you and mentoring coordinators from the thread or you prefer to continue in cc.    1.   Page 4 - Ring direction. It has only 2 bits. Would they be enough? or Would it be needed some additional experimental bits for future use? Are they already considered on another IGP fields (I did not read drafts related to IGP extensions for RMR).    2.   Page 6 – “A ring node indicates in its IGP updates the ring LSP signaling protocols it supports. This can be LDP and/or RSVP-TE. Ideally, each node should support both.” Should not SR be also included in the scope (since it is another option for the MPLS control plane)? Or at least some mention about its future inclusion (similar to what is stated for express link in the same Page 6)?    3.   Page 7 – I get confused with the RSVP-TE “reverse call admission control” concept. Does it mean that BW is not reserved in both directions? If so, what happen with backup or “other direction” path when traffic has to be sent through it (because current has some failure)? Can the CAC reject the request? How it works considering the LSP are multipoint, i.e. the BW is aggregate of all ring nodes that will use this LSP?    4.   Same page as previous comment for “counter-rotating pairs” concept. Does it mean that there are always a pair of LSPs, one CW and second AC?    5.   Page 8 – I did not understand in depth the proposals for protections and loop avoidance. How can I get further clarification?    6.   Page 11 – Similar to comment #2 for SS and SU field related to SR. Should it be signaled in the IGP? Additionally, SS and SU have only 2 bits. Are they enough or some extra experimental bit might be needed for future use?    7.   Page 11 – Ring Announcement Phase. It might be needed to clarify that the MV value is not mandatory (Or is it?), and if not provisioned the lower loopback address will be taken into consideration to elect the Ring Master.    8.   Page 11/12 – I did not understand in depth the timers (T1, T2) and how each node and all of them are going through different phases to elect the Ring Master. General concept is OK, but I think a better explanation about the sequence, including details, would be great. Perhaps a timeline containing events, timers, parameters and its values can help. A state machine is another option.    9.   Page 13 – Ring OAM. The default hello interval for OAM protocol is defined in 3.3ms. It is not clear the reasons for this value. Furthermore, the amount of lost packets to determine a fault is not defined. On the other hand, hello interval for the LSP is defined is one second. Again, the reasons for this value might be missing, since it does not allow sub-second reconvergence nor it is defined the number of lost packets to determine a failure.    10. Additionally, as far as I understand ring direction is a parameter used by IGP to calculate path but it is not directly related to LSP direction, right? I mean, LSP is enabled to go through both ring directions but only one through a link (otherwise there would be loops).    11. Do you think some clarification might be needed related to overlapping with TI-LFA?    12. Minor comment. Page 2 – “it is imperative that MPLS handles rings well; this is not the case today.” I think this sentence is very unspecific and might lead to some confusion. Today MPLS is working in different topologies, including rings, with no issues. This proposal is improving things like redundancy on MPLS layer itself, convergence time, control plane scalability, etc. but it does not mean that MPLS is working “bad”. I think it is much more precise in Page 5 paragraph “The goals of this document …”    13. Very minor comments. Page 9 – “In what follows, we refer to a ring node and a rink link Type-Length-Value (TLV).” rink -> ring Page 10 - Ring ID 2 -> Ring ID 3  - 3rd Ring ID field on IS-IS Ring TLV Format  Best regards.    Javier Ger Arquitectura y Tecnología Gerencia Técnica | Ingeniería Tel: (+54 11)5530-4531 Cel: (+54 9 11)3926-5017
Hornos 690. CABA, CP C1272ACL
Argentina    De: Gregory Mirsky [mailto:[email-masked]]
Enviado el: jueves, 19 de mayo de 2016 05:31 p.m.
Para: Andrés Balcabao <[email-masked]>; Ger, Javier <[email-masked]>
CC: [email-masked]; [email-masked]
Asunto: RE: Mentor Introduction: MPLS Internet Draft Review Team    Thank you, Nalini.    Hi Andres and Javier, very good selection of the drafts: ·        RMR promises significantly simplify management of ringy MPLS topologies; ·        applicability of Entropy Label in Segment Routing been extensively discussed as part of the WG LC and the update should be coming; ·        BFD directed … I’m co-author on that. The draft is WFLC-ready but will greatly appreciate your thoughts, questions and we can have the discussion on the MPLS WG list; ·        T-LDP been, AFAIK, through WGLC and we can look through MPLS WG archive for the discussion, comments.    Please share your questions, thoughts on these or any other MPLS drafts. Will be glad to help.                    Regards,                                 Greg    From: Andrés Balcabao [mailto:[email-masked]]
Sent: Thursday, May 19, 2016 12:53 PM
To: Ger, Javier
Cc: [email-masked]; Gregory Mirsky;[email-masked]
Subject: Re: Mentor Introduction: MPLS Internet Draft Review Team    Nice to meet you Greg. It sounds perfect !!!    Regards       
 Andrés Balcabao
Ingeniería de Backbone IP/MPLS
Virrey Cevallos 422 | C1077AAJ | Bs As | Argentina
Teléfono: 54-11-5031-6354
IPLAN | iplan.com.ar          2016-05-19 16:49 GMT-03:00 Ger, Javier <[email-masked]>: It works for me Nalini. Thank you and thanks also to Greg.   The following are my choices (order by interest). Anyway, I am willing to start working on any draft the group decides.   ·        draft-ietf-mpls-rmr-01 ·        draft-ietf-mpls-spring-entropy-label-03 ·        draft-ietf-mpls-bfd-directed-02 ·        draft-ietf-mpls-app-aware-tldp-03   Regards.   Javier Ger Arquitectura y Tecnología Gerencia Técnica | Ingeniería Tel: (+54 11)5530-4531 Cel: (+54 9 11)3926-5017
Hornos 690. CABA, CP C1272ACL
Argentina   De:[email-masked] [mailto:[email-masked]]
Enviado el: jueves, 19 de mayo de 2016 04:24 p.m.
Para: Andrés Balcabao <[email-masked]>; Ger, Javier <[email-masked]>; Gregory Mirsky <[email-masked]>
CC: [email-masked]
Asunto: Mentor Introduction: MPLS Internet Draft Review Team   Andres, Javier and Greg,   Let me introduce you.   Andres and Javier are forming an Internet Draft Review Team to study drafts in the MPLS WG.   Greg has been involved in MPLS for many years and will be able to guide you.   Thank you, Greg!      I was not able to find a Spanish speaking mentor, unfortunately!   The drafts the team is interested in are: 
draft-ietf-mpls-app-aware-tldp-03
draft-ietf-mpls-rmr-01
draft-ietf-mpls-spring-entropy-label-03
draft-ietf-mpls-bfd-directed-02   How I see this proceeding is that the team will select one draft at a time to read and then find 5 questions to pose on the draft.   You may then have a webcast to discuss or do it via email.      Make sense?  Questions?   Thanks,   Nalini Elkins IETF Mentoring Team   Inside Products, Inc. www.insidethestack.com (831) 659-8360 Visite https://www.cablevisionfibertel.com.ar
__________________________________________
Este mensaje es confidencial. Puede contener informacion amparada por el secreto comercial.
Si usted ha recibido este e-mail por error, debera eliminarlo de su sistema.
No debera copiar el mensaje ni divulgar su contenido a ninguna persona.
Muchas gracias.
This message is confidential. It may also contain information that is privileged or not authorized to be disclosed. If you have received it by mistake, delete it from your system.
You should not copy the messsage nor disclose its contents to anyone.
Many thanks.
__________________________________________       No Imprimas Digitalizá ESTE MENSAJE ES CONFIDENCIAL. Puede contener información amparada por el secreto profesional. Si usted ha recibido este e-mail por error, por favor comuníquenoslo inmediatamente vía e-mail y tenga la amabilidad de eliminarlo de su sistema; no deberá copiar el mensaje ni divulgar su contenido a ninguna persona. Muchas gracias.    THIS MESSAGE IS CONFIDENTIAL. It may also contain information that is privileged or otherwise legally exempt from disclosure. If you have received it by mistake please let us know by e-mail immediately and delete it from your system; should also not copy the message nor disclose its contents to anyone. Many thanks. Visite https://www.cablevisionfibertel.com.ar
__________________________________________
Este mensaje es confidencial. Puede contener informacion amparada por el secreto comercial.
Si usted ha recibido este e-mail por error, debera eliminarlo de su sistema.
No debera copiar el mensaje ni divulgar su contenido a ninguna persona.
Muchas gracias.
This message is confidential. It may also contain information that is privileged or not authorized to be disclosed. If you have received it by mistake, delete it from your system.
You should not copy the messsage nor disclose its contents to anyone.
Many thanks.
__________________________________________

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 28 May 2016 19:56:04 +0000

Nalini:

The advice your give Greg is up to you. But to me these don't look like stupid questions; they look like questions someone new to the technology might ask, and are appropriately directed to his mentor. I would suggest that the discussion be left between him and his mentor.

Fred

> On May 27, 2016, at 6:56 PM, Ger, Javier <[email-masked]> wrote:
> 
> Hello Greg,
> 
> Tel: (+54 <tel:(+54> 11)5530-4531
> Cel: (+54 9 11)3926-5017
> De: Gregory Mirsky [mailto:[email-masked] <mailto:[email-masked]>]
> Para: Andrés Balcabao <[email-masked] <mailto:[email-masked]>>; Ger, Javier <[email-masked] <mailto:[email-masked]>>
> CC: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> From: Andrés Balcabao [mailto:[email-masked] <mailto:[email-masked]>]
> Cc: [email-masked] <mailto:[email-masked]>; Gregory Mirsky; [email-masked] <mailto:[email-masked]>
> IPLAN | iplan.com.ar <http://www.iplan.com.ar/>
> 
> 
> 
> 2016-05-19 16:49 GMT-03:00 Ger, Javier <[email-masked] <mailto:[email-masked]>>:
> ·         draft-ietf-mpls-rmr-01
> ·         draft-ietf-mpls-spring-entropy-label-03
> 
> ·         draft-ietf-mpls-bfd-directed-02
> 
> ·         draft-ietf-mpls-app-aware-tldp-03
> 
> 
> Regards.
> 
> Javier Ger
> Tel: (+54 <tel:(+54> 11)5530-4531
> Cel: (+54 9 11)3926-5017
> De: [email-masked] <mailto:[email-masked]> [mailto:[email-masked] <mailto:[email-masked]>]
> Para: Andrés Balcabao <[email-masked] <mailto:[email-masked]>>; Ger, Javier <[email-masked] <mailto:[email-masked]>>; Gregory Mirsky <[email-masked] <mailto:[email-masked]>>
> CC: [email-masked] <mailto:[email-masked]>
> www.insidethestack.com <http://www.insidethestack.com/>
> (831) 659-8360
> Visite https://www.cablevisionfibertel.com.ar <https://www.cablevisionfibertel.com.ar/>
> Visite https://www.cablevisionfibertel.com.ar <https://www.cablevisionfibertel.com.ar/>
> _______________________________________________
> mentoring-coordinators mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/mentoring-coordinators <https://www.ietf.org/mailman/listinfo/mentoring-coordinators>

---

From: <[email-masked]>
Date: Sat, 28 May 2016 22:40:19 +0000 (UTC)

Thanks, Fred.
I am sure Greg will do the right thing.  I want to be copied so that I can keep track of if (and how much) activity is going on in a team.  This whole thing is quite new so I want to see how it plays out.
I think that Javier's involvement & later submission to the WG list is a good metric for the success of the mentoring program.   That is why I want to be copied.
Nalini

      From: Fred Baker (fred) <[email-masked]>
 To: Nalini Elkins <[email-masked]> 
Cc: "[email-masked]" <[email-masked]>
 Sent: Saturday, May 28, 2016 12:56 PM
 Subject: Re: [Mentoring-coordinators] draft-kompella-mpls-rmr-01 - Comments
   
Nalini:

On May 27, 2016, at 6:56 PM, Ger, Javier <[email-masked]> wrote:
Hello Greg,  Thanks again for your time and help. I am sending you comments related to draft-kompella-mpls-rmr-01. Apologies in advance if some question is too basic or not clear enough. Also, since Entropy Labels in SR draft is closed, I am reading the BFD draft and will share my questions during next week.  Hello Nalini, please let me know if I should remove you and mentoring coordinators from the thread or you prefer to continue in cc.  1.    Page 4 - Ring direction. It has only 2 bits. Would they be enough? or Would it be needed some additional experimental bits for future use? Are they already considered on another IGP fields (I did not read drafts related to IGP extensions for RMR).  2.    Page 6 – “A ring node indicates in its IGP updates the ring LSP signaling protocols it supports. This can be LDP and/or RSVP-TE. Ideally, each node should support both.”Should not SR be also included in the scope (since it is another option for the MPLS control plane)? Or at least some mention about its future inclusion (similar to what is stated for express link in the same Page 6)?  3.    Page 7 – I get confused with the RSVP-TE “reverse call admission control” concept.Does it mean that BW is not reserved in both directions? If so, what happen with backup or “other direction” path when traffic has to be sent through it (because current has some failure)? Can the CAC reject the request? How it works considering the LSP are multipoint, i.e. the BW is aggregate of all ring nodes that will use this LSP?  4.    Same page as previous comment for “counter-rotating pairs” concept.Does it mean that there are always a pair of LSPs, one CW and second AC?  5.    Page 8 – I did not understand in depth the proposals for protections and loop avoidance. How can I get further clarification?  6.    Page 11 – Similar to comment #2 for SS and SU field related to SR. Should it be signaled in the IGP?Additionally, SS and SU have only 2 bits. Are they enough or some extra experimental bit might be needed for future use?  7.    Page 11 – Ring Announcement Phase.It might be needed to clarify that the MV value is not mandatory (Or is it?), and if not provisioned the lower loopback address will be taken into consideration to elect the Ring Master.  8.    Page 11/12 – I did not understand in depth the timers (T1, T2) and how each node and all of them are going through different phases to elect the Ring Master. General concept is OK, but I think a better explanation about the sequence, including details, would be great. Perhaps a timeline containing events, timers, parameters and its values can help. A state machine is another option.  9.    Page 13 – Ring OAM.The default hello interval for OAM protocol is defined in 3.3ms. It is not clear the reasons for this value. Furthermore, the amount of lost packets to determine a fault is not defined.On the other hand, hello interval for the LSP is defined is one second. Again, the reasons for this value might be missing, since it does not allow sub-second reconvergence nor it is defined the number of lost packets to determine a failure.  10.  Additionally, as far as I understand ring direction is a parameter used by IGP to calculate path but it is not directly related to LSP direction, right? I mean, LSP is enabled to go through both ring directions but only one through a link (otherwise there would be loops).  11.  Do you think some clarification might be needed related to overlapping with TI-LFA?  12.  Minor comment. Page 2 – “it is imperative that MPLS handles rings well; this is not the case today.”I think this sentence is very unspecific and might lead to some confusion. Today MPLS is working in different topologies, including rings, with no issues. This proposal is improving things like redundancy on MPLS layer itself, convergence time, control plane scalability, etc. but it does not mean that MPLS is working “bad”.I think it is much more precise in Page 5 paragraph “The goals of this document …”  13.  Very minor comments.Page 9 – “In what follows, we refer to a ring node and a rink link Type-Length-Value (TLV).” rink -> ringPage 10 - Ring ID 2 -> Ring ID 3  - 3rd Ring ID field on IS-IS Ring TLV FormatBest regards.  Javier GerArquitectura y TecnologíaGerencia Técnica | IngenieríaTel: (+54 11)5530-4531Cel: (+54 9 11)3926-5017
Hornos 690. CABA, CP C1272ACL
Argentina  De: Gregory Mirsky [mailto:[email-masked]] 
Enviado el: jueves, 19 de mayo de 2016 05:31 p.m.
Para: Andrés Balcabao <[email-masked]>; Ger, Javier <[email-masked]>
CC: [email-masked]; [email-masked]
Asunto: RE: Mentor Introduction: MPLS Internet Draft Review Team  Thank you, Nalini.  Hi Andres and Javier,very good selection of the drafts:·         RMR promises significantly simplify management of ringy MPLS topologies;·         applicability of Entropy Label in Segment Routing been extensively discussed as part of the WG LC and the update should be coming;·         BFD directed … I’m co-author on that. The draft is WFLC-ready but will greatly appreciate your thoughts, questions and we can have the discussion on the MPLS WG list;·         T-LDP been, AFAIK, through WGLC and we can look through MPLS WG archive for the discussion, comments.  Please share your questions, thoughts on these or any other MPLS drafts. Will be glad to help.                  Regards,                                Greg  From: Andrés Balcabao [mailto:[email-masked]] 
Sent: Thursday, May 19, 2016 12:53 PM
To: Ger, Javier
Cc: [email-masked]; Gregory Mirsky; [email-masked]
Subject: Re: Mentor Introduction: MPLS Internet Draft Review Team  Nice to meet you Greg. It sounds perfect !!!  Regards    
Andrés Balcabao
Ingeniería de Backbone IP/MPLS
Virrey Cevallos 422 | C1077AAJ | Bs As | Argentina
Teléfono: 54-11-5031-6354
IPLAN | iplan.com.ar      2016-05-19 16:49 GMT-03:00 Ger, Javier <[email-masked]>:It works for me Nalini. Thank you and thanks also to Greg. The following are my choices (order by interest). Anyway, I am willing to start working on any draft the group decides. ·         draft-ietf-mpls-rmr-01·         draft-ietf-mpls-spring-entropy-label-03·         draft-ietf-mpls-bfd-directed-02·         draft-ietf-mpls-app-aware-tldp-03 Regards. Javier GerArquitectura y TecnologíaGerencia Técnica | IngenieríaTel: (+54 11)5530-4531Cel: (+54 9 11)3926-5017
Hornos 690. CABA, CP C1272ACL
Argentina De: [email-masked] [mailto:[email-masked]] 
Enviado el: jueves, 19 de mayo de 2016 04:24 p.m.
Para: Andrés Balcabao <[email-masked]>; Ger, Javier <[email-masked]>; Gregory Mirsky <[email-masked]>
CC: [email-masked]
Asunto: Mentor Introduction: MPLS Internet Draft Review Team Andres, Javier and Greg, Let me introduce you. Andres and Javier are forming an Internet Draft Review Team to study drafts in the MPLS WG. Greg has been involved in MPLS for many years and will be able to guide you.   Thank you, Greg!    I was not able to find a Spanish speaking mentor, unfortunately! The drafts the team is interested in are:
draft-ietf-mpls-app-aware-tldp-03
draft-ietf-mpls-rmr-01
draft-ietf-mpls-spring-entropy-label-03
draft-ietf-mpls-bfd-directed-02 How I see this proceeding is that the team will select one draft at a time to read and then find 5 questions to pose on the draft. You may then have a webcast to discuss or do it via email.    Make sense?  Questions? Thanks, Nalini ElkinsIETF Mentoring Team Inside Products, Inc.www.insidethestack.com(831) 659-8360Visite https://www.cablevisionfibertel.com.ar
__________________________________________
Este mensaje es confidencial. Puede contener informacion amparada por el secreto comercial.
Si usted ha recibido este e-mail por error, debera eliminarlo de su sistema.
No debera copiar el mensaje ni divulgar su contenido a ninguna persona.
Muchas gracias.
This message is confidential. It may also contain information that is privileged or not authorized to be disclosed. If you have received it by mistake, delete it from your system.
You should not copy the messsage nor disclose its contents to anyone.
Many thanks.
__________________________________________    No Imprimas DigitalizáESTE MENSAJE ES CONFIDENCIAL. Puede contener información amparada por el secreto profesional. Si usted ha recibido este e-mail por error, por favor comuníquenoslo inmediatamente vía e-mail y tenga la amabilidad de eliminarlo de su sistema; no deberá copiar el mensaje ni divulgar su contenido a ninguna persona. Muchas gracias.  THIS MESSAGE IS CONFIDENTIAL. It may also contain information that is privileged or otherwise legally exempt from disclosure. If you have received it by mistake please let us know by e-mail immediately and delete it from your system; should also not copy the message nor disclose its contents to anyone. Many thanks.Visite https://www.cablevisionfibertel.com.ar
__________________________________________
Este mensaje es confidencial. Puede contener informacion amparada por el secreto comercial.
Si usted ha recibido este e-mail por error, debera eliminarlo de su sistema.
No debera copiar el mensaje ni divulgar su contenido a ninguna persona.
Muchas gracias.
This message is confidential. It may also contain information that is privileged or not authorized to be disclosed. If you have received it by mistake, delete it from your system.
You should not copy the messsage nor disclose its contents to anyone.
Many thanks.
_________________________________________________________________________________________
mentoring-coordinators mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mentoring-coordinators