Subject: [Mentoring-coordinators] SummaryMentoringIESG2

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 23 May 2016 20:56:29 +0000

> On May 23, 2016, at 9:05 AM, [email-masked] wrote:
> 
> <SummaryMentoringIESG2.pdf>

"Mommy and me"... you might not want to say that out loud to the mentees. BTW, I'd suggest we call them "freshmen" and define the term to mean "has attended at least one and less than five IETFs". Define a "newcomer" as someone attending their first IETF meeting.

There is a park/beer garden within walking distance of the ANA Intercontinental. When we were there last, we had some kind of event there (the social, maybe? I don't recall precisely).

Looking through the draft review, author, finalization, and presentation teams. I think I need to be brought up to speed on your objectives and how you see this playing out.

v6ops just got a note from Edwin Cordero, reviewing a draft in a review team. The review was useful, but pointed out a disagreement that Edwin had with the IPv6 design more than it pointed out issues in the draft. The good news is that it triggered some conversation on the list; the bad news is that he is likely now seen as not-very-clued. My suggestion: before the next review team files a review, let's have a subject matter expert sit down with them.

Regarding author, finalization, and presentation teams - at first blush, That doesn't sound right.

If I view the IETF participant pool as a set of concentric circles, I might see something like the following. I'll number circles from inside to out.

#1: people who have been around and make things happen. In leadership in some way.
#2: people who have been around and make things happen, but not in leadership. Usually draft authors, but may simply be people that are well known and respected.
#3: people that are just starting to write and work on drafts, otherwise similar to #4
#4: people that read drafts, attend meetings and comment, or comment on mailing lists.
#5: people that lurk on mailing lists
#6: people that read drafts and/or RFCs but generally have no idea where they come from
#7: everyone else

There are probably other categories, but you get the drift.

I see the mentorship program as moving people from one ring to the next - usually from #6 to #5 or #5 to #4. Occasionally we get to move someone into #3, but not that often. There is some hurdle they need to get over, and we (hopefully) enable them to do it. I have people I mentor at Cisco that are Area Directors, but that's quite a different story.

BTW, people usually get from #3 to #2 on their own, based on interest and energy. The mentoring program for getting into #1 (leadership) is called "be a co-chair"; sooner or later, you become someone that can mentor someone else, and you might get kicked upstairs.

What "author, finalization, and presentation teams" sounds like is force-fitting a transition from #3 to #2. In my experience, a person might need help authoring their first draft (learning the tools and format, primarily, but maybe getting from "what I want to say" to "saying it"). However, if they have sufficient with-its to accomplish that, they're on their way as long as they have someone they can ask questions of. An example might be draft-szigeti-tsvwg-ieee-802-11. Tim and I work in the same company, and he came to me for help filing a draft. He had what he wanted to say in a Word document. I turned that into an XML and a .txt for him, and filed it when he approved it. He presented it at IETF 93, and I followed up at IETF 94 and 95. He didn't need help presenting the draft, although he has had questions along the way about process.

So - help me out here. What do you have in mind?

---

From: <[email-masked]>
Date: Tue, 24 May 2016 04:08:28 +0000 (UTC)

Thanks, Fred.

My comments inline.
 
Nalini

----- Original Message -----
From: Fred Baker (fred) <[email-masked]>
To: Nalini Elkins <[email-masked]>
Cc: Benoit Claise (bclaise) <[email-masked]>; "[email-masked]" <[email-masked]>; Mirjam Kuehne <[email-masked]>
Sent: Monday, May 23, 2016 1:56 PM
Subject: [Mentoring-coordinators] SummaryMentoringIESG2

>"Mommy and me"... you might not want to say that out loud to the mentees. 

Just a joke.

>BTW, I'd suggest we call them "freshmen" and define the term to mean "has attended at least one and less than five IETFs". Define a "newcomer" as someone attending their first IETF >meeting.

Sure.

>There is a park/beer garden within walking distance of the ANA Intercontinental. When we were there last, we had some kind of event there (the social, maybe? I don't recall precisely).

If you are thinking of this as the mentor /mentee event, I am thinking that this will be the "Locals Lead" event.  This was actually suggested by a discussion with Spencer Dawkins at IETF95.  The idea is that local mentees think of a place that they know of that generally tourists would not. That way, the mentees become the people in the "know".

>v6ops just got a note from Edwin Cordero, reviewing a draft in a review team. The review was useful, but pointed out a disagreement that Edwin had with the IPv6 design more than it >pointed out issues in the draft. The good news is that it triggered some conversation on the list; the bad news is that he is likely now seen as not-very-clued. My suggestion: before >the next review team files a review, let's have a subject matter expert sit down with them.

Absolutely.  I saw the exchange.  Yes, there will be some false starts.  But, now we have learned another lesson.

>I see the mentorship program as moving people from one ring to the next - usually from #6 to #5 or #5 to #4. Occasionally we get to move someone into #3, but not that often. There is >some hurdle they need to get over, and we (hopefully) enable them to do it. I have people I mentor at Cisco that are Area Directors, but that's quite a different story.

>BTW, people usually get from #3 to #2 on their own, based on interest and energy. The mentoring program for getting into #1 (leadership) is called "be a co-chair"; sooner or later, you >become someone that can mentor someone else, and you might get kicked upstairs.

>What "author, finalization, and presentation teams" sounds like is force-fitting a transition from #3 to #2. In my experience, a person might need help authoring their first draft
> (learning the tools and format, primarily, but maybe getting from "what I want to say" to "saying it"). However, if they have sufficient with-its to accomplish that, they're on their > >way as long as they have someone they can ask questions of. An example might be draft-szigeti-tsvwg-ieee-802-11. Tim and I work in the same company, and he came to me for help filing a >draft. He had what he wanted to say in a Word document. I turned that into an XML and a .txt for him, and filed it when he approved it. He presented it at IETF 93, and I followed up at >IETF 94 and 95. He didn't need help presenting the draft, although he has had questions along the way about process.

>So - help me out here. What do you have in mind?

Fred, your circles are very interesting but I am going on what mentees have actually said to me and what I have seen from the Freshmen category that you mentioned above.  I am taking only new people.   There is much to be done on the others in your levels but that is for another day.

So, let me do another set of circles:

#1: people who have a slot for a WG presentation 
#2: people who have written a draft for an idea but it is rough or could use help with structure
#3: people who have an idea for a protocol enhancement but do not know if it is any good or not or where it fits in 
#4: people who have attended an IETF or have interest in a topic but do not know how to get involved

1) The first set, circle #4 is addressed by Internet Draft Review Teams.  This has correlates in your circles as well.  This is probably the largest group of people and will be the biggest "bang for our buck" in terms of pure numbers.

2) The second set, circle #3 "people who have an idea for a protocol enhancement but do not know if it is any good or not or where it fits in", I have had at least 2 -3 mentees at each IETF who fall into this category.  Could even be more.  I think they need help to find out if their idea is any good or not & to build a team.

I envision a webcast where they get 5 minutes to present & two foils.   If people like the idea & want to co-author, great.  If not, then the idea will probably die.  If there are WG chairs, ADs, or experts on the webcast listening, then they can give feedback such as "You should try to present in another WG, etc.".

I mentioned this possibility to a young man at IETF95 (who had such an idea) and he followed me around for about 10 minutes asking when was I going to start this initiative.  (Actually, this is the kind of person I feel that I am working to help.)

These people also could use help building a team of collaborators.  I would also like to have a mentor assigned to help them write the draft.  Some people are quite isolated.  They may be at a University in Ecuador, etc. and have no one else really nearby who can collaborate.

3) Circle #2: "people who have written a draft for an idea but it is rough or could use help with structure".  Again, from conversations with mentees who fall into this category. "I have been struggling with writing a draft & could really use some help".  This is also a useful group for people whose first language is not English & would like help.  (Actually, this could be useful for many people whose speak English also!)

Also, when you have a network of people that you can turn to, then you send your draft to others for private review.  This offering is for people who do not have that network yet.  '

BTW, I am a big believer in networks of support.  This is the idea behind Speed Mentoring as well.  

4) Circle #1: "people who have a slot for a WG presentation".  Also based on conversations with mentees - some who were torn to shreds at a WG. (If they had gone through some of the previous steps, things might not have come to such a pass.)

This is a very important step for a number of people:

a.  People who want to improve their pesentation skills
b.  People who want to improve their presentation
c.  People who want to practice answering "tough" questions

This last one is quite interesting.  I have talked to people in India who are afraid of what will happen when they actually present.  They are not used to aggressively fighting back for their views.  Certainly common to a number of cultures. 

Actually, it is a good thing to practice your presentation in front of others who will ask you the toughest questions that they can.  My daughter just did this for her senior thesis in college.  Just good habits to get into.  But, so many don't.  I see the job of the mentoring program as preparing the mentee for success at the IETF.  Which then results in the IETF getting quality work.

Pls let me know if you want to talk on the phone about this.

Thanks,
Nalini