Subject: [Mentoring-coordinators] Mentoring introductions

From: Wes Hardaker <[email-masked]>
Date: Thu, 12 Jul 2018 03:15:49 -0700

Dear Kevin Borgolte and Fred Baker,

Welcome to the mentoring programme! In this programme we aim to
facilitate knowledge transfer between experienced IETF-ers and new
participants in the community. The IETF is not your typical
organization so some help along the way might help you make your
landing a bit smoother, so you will stay with us longer!

It is my pleasure to introduce you to each other. Fred Baker has kindly
offered to be Kevin Borgolte's mentor for IETF102. Kevin Borgolte has
expressed a specific interest in ACME + partially IPv6.

The mentorship aims to have three parts: 

0. Introduction conversations before the meeting
1. Face to face meeting at the beginning of the meeting
2. Check-in during the week.

It would be great if you could meet early in the week and discuss
questions, interests, and 'how-to-get-things-done' in the IETF,
and perhaps have a follow-up during the week to check-in whether
there are any questions.  Hopefully you'll both have the chance
to attend the newcomer's meet-and-greet on Sunday at 16:00.

You both have the responsibility to make meetings between you happen,
but it would be great if the mentor would take the lead in setting up
the first meeting.

As mentee it would help if you follow your interests within the IETF:
Ask the mentor what you think you need to make the meeting a
success. The mentor is there to help you, but the mentor likely also
knows many things that "you don't know you need to know"!

Good topics of conversation include the IETF toolchain, the meeting
agenda, the IETF app, how to use jabber rooms, the IETF document
datatracker (where all Internet Drafts, Working Group and Research
Group agenda's and RFCs can be found), and more! Much of this info can
also be found in the Tao of the IETF at https://ietf.org/tao .

Specific questions about your favorite topics of interest are wise to
discuss such as: relevant working groups or research groups, relevant
authors, working group chairs and area directors.  You might want to
discuss trending issues in the upcoming meetings (also check the ISOC
"rough guides" in the IETF journal)

Please let us if there is any way in which we can support your
interactions.  Please mail any questions you have to
[email-masked].

Best,
Wes and Niels
Mentoring Program Leaders

---

From: Fred Baker <[email-masked]>
Date: Thu, 12 Jul 2018 10:52:49 -0700

Thanks Wes. Hi Kevin.

What is your schedule coming to Montreal? I will be landing (UA 8338, operated by Air Canada) Saturday around 18:00, and probably be at the Fairmont by 19:00. If you give me your phone number, I can text you when I arrive and we can meet for dinner/drinks. Mine is +1-805-637-0529.

You, I take it, are at UCSB. I live near the north end of Fairview, on Via Del Rey. Yes, I have some exciting photos of this weekend's events and the aftermath. The good news is that my home isn't among the 13 destroyed - Via Del Rey is the road next over, and while we had fire coming through the orchards, we aren't included in the "100 acres destroyed". We had three fire teams working on the house, and they were successful. We did lose a bunch of avocado trees.

Wes says you're interested in ACME (https://datatracker.ietf.org/wg/acme/charter/) and IPv6 (presumably 6man and v6ops). If you're not yet on the lists for those, the charter will tell you how to join, and I would recommend doing so if you plan to be involved in the working groups. The IETF agenda is at https://datatracker.ietf.org/meeting/agenda/. It has ACME meeting for 2.5 hours Tuesday afternoon, but the posted agenda is almost vacuous. I would suggest that you see the attached raw agenda data (which is in a format that helps me in planning my working group agendas), and plan to read the updated working group documents and draft-sheffer-acme-star-request. I think the "main" ACME document listed in the working group agenda is draft-ietf-acme-acme; it would be good to also read that, although it has left the working group and is being discussed by the IESG.

Do attend the tutorials on Sunday, and the Newcomer's reception. I'll be able to introduce you to working group chairs of interest.

6man meets Monday morning, and v6ops (which I co-chair) meets Thursday afternoon and Friday morning. The agenda for each is available from https://datatracker.ietf.org/meeting/agenda/, and I would suggest you become familiar with the drafts listed in them. 

Open to questions in email, but frankly I think we will do just as well to meet in Montreal. We'll be there shortly.

> On Jul 12, 2018, at 3:15 AM, Wes Hardaker <[email-masked]> wrote:
> 
>

---

From: Kevin Borgolte <[email-masked]>
Date: Fri, 13 Jul 2018 19:47:59 -0700

Hi Fred,

thanks for reaching out!

> You, I take it, are at UCSB. I live near the north end of Fairview, on Via Del Rey. Yes, I have some exciting photos of this weekend's events and the aftermath. The good news is that my home isn't…

Funny that you are also from the Santa Barbara area! Glad to hear that
the fire last week didn't affect you too much and that the fire teams
were there to protect your home, it's unfortunate that the avocado
trees didn't survive (who doesn't love avocado?). We live downtown
Santa Barbara (Bath and Micheltorena), so we weren't impacted by this
fire and we ended up support for friends who live on Cathedral Oaks
between Fairview and Patterson and had to evacuate.

> What is your schedule coming to Montreal? I will be landing (UA 8338, operated by Air Canada) Saturday around 18:00, and probably be at the Fairmont by 19:00. If you give me your phone number, I ca…

My schedule coming to Montreal changed quite a bit the last few days,
since I still don't have my laptop back from repair, and I will need
it for my ANRW presentation. I will now arrive with a red-eye on
Sunday morning (7am). Originally, I wanted to be there for the ICANN
DNS Symposium today already, but then had to rebook to arriving
Saturday at 11pm (which also didn't work out because my laptop is only
supposed to be back tomorrow noon, which is why I'll arrive on a
red-eye Sunday morning now). Hence, meeting for dinner on Saturday
won't work unfortunately, but I'd love to meet for
coffee/tea/breakfast/lunch before the Newcomer's tutorial (12:30pm) on
Sunday. Would that work for you? My phone number is +1-805-364-3186.

To give some background on myself: I am a PhD student at UCSB in the
Computer Security group with Christopher Kruegel, Giovanni Vigna, and
previously Dick Kemmerer. I will graduate in September, but I will
stick around academia, and I hope to be more involved with the
practical side of things.

> Wes says you're interested in ACME (https://datatracker.ietf.org/wg/acme/charter/) and IPv6 (presumably 6man and v6ops). If you're not yet on the lists for those, the charter will tell you how to j…

IETF 102 is my first meeting and (hopefully) not my last, I hope to
get involved more. Specifically, I am interested in the work of ACME
because we developed on an additional domain-validation challenge and
published an academic paper on it
(https://kevin.borgolte.me/publications/ndss2018-cloud-strife/). Now,
we want to transition it into practice, since it can solve some of the
trust issues that domain-validation can have. In fact, we reached out
to the working group about it a while ago, when the paper was still in
the draft stage, to understand whether that is something the ACME WG
would interest.

You are correct on my prime interest in 6man and v6ops, I wasn't on
their mailing lists, but I just signed up. Part of my interest here is
better understanding current practices, the overall thought process,
and how it might play into the feasibility of Internet-wide scanning
for IPv6, as it is currently possible for IPv4 (for the academic use
case of Internet-wide measurements).

> 6man meets Monday morning, and v6ops (which I co-chair) meets Thursday afternoon and Friday morning. The agenda for each is available from https://datatracker.ietf.org/meeting/agenda/, and I would…

Will do.

> Do attend the tutorials on Sunday, and the Newcomer's reception. I'll be able to introduce you to working group chairs of interest.

Thanks, that'd be amazing, will certainly do!

> Open to questions in email, but frankly I think we will do just as well to meet in Montreal. We'll be there shortly.

Agreed, it will be less typing and certainly more organic. Looking
forward to meeting you in person and talking more.

Best,
Kevin

---

From: Fred Baker <[email-masked]>
Date: Fri, 13 Jul 2018 23:04:10 -0700

I have a couple of comments inline. Looking forward to lunch on Sunday.

> On Jul 13, 2018, at 7:47 PM, Kevin Borgolte <[email-masked]> wrote:
> 
> Hi Fred,
> 
> thanks for reaching out!
> 

Let's plan on lunch Sunday. I will be giving a talk 9:30-11:00, but available after that. Best place to meet is that standard meeting place at IETF meetings - IETF Registration. Maybe meet there 11:15 r thereabouts?

> practical side of things.

Hmm. You may know Kevin Almeroth or Elizabeth Belding-Royer...

---

From: Kevin Borgolte <[email-masked]>
Date: Sun, 15 Jul 2018 08:14:17 -0400

Hi Fred,

I just arrived in Montreal.

On Sat, Jul 14, 2018 at 02:04 Fred Baker <[email-masked]> wrote:

> Let's plan on lunch Sunday. I will be giving a talk 9:30-11:00, but
> available after that. Best place to meet is that standard meeting place at
> IETF meetings - IETF Registration. Maybe meet there 11:15 r thereabouts?

Sounds good. See you then!

Best,
Kevin