Subject: Re: [MEXT] Question on draft-dupont-mext-dhcrelay-00

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 12 Mar 2008 10:39:03 -0700 (PDT)

Comments inline.

Behcet

----- Original Message ----
From: Francis Dupont <[email-masked]>
To: Vijay Devarapalli <[email-masked]>
Cc: [email-masked]
Sent: Wednesday, March 12, 2008 10:13:04 AM
Subject: Re: [MEXT] Question on draft-dupont-mext-dhcrelay-00

 In your previous mail you wrote:

   Is the draft proposing co-locating a DHCPv6 relay agent with the
   mobile router, while the mobile router is also a DHCPv6 client?

=> yes, locating a DHCPv6 relay agent at any place should be allowed
by a clever wording.

   If yes, why is this better than co-locating the relay agent with
   the home agent? Perhaps I am missing something.
   
=> it is not better as it is not an alternative: I suggest to use
a wording allowing:
 - no relay,
 - a relay co-located with the server at the HA,
 - a relay co-located with the client at the MR,

 - both a relay co-located with the client at the MR and a relay
  co-located with the server at the HA,

[behcet] This is what we have in draft-sarikaya-mext-relay-dhcpv6pd.
A relay co-located with a client requires some standardization as perthe DHC session we had on Monday afternoon. This is to be undertaken byDHC WG.

 - the same but relays using the mobility signaling to encapsulate
  DHCPv6 messages.
So the idea is to introduce maximal flexibility in order to get rid of
DHCPv6 constraits like multicast and link-local, and at a side effect
to get *one* proposal to perform prefix delegation for NEMO, the
condition IMHO to reach a reasonable rough consensus.

[behcet] We tried to avoid co-located DHCP server at the HA. Onlink DHCP server or backend DHCP server would be OK.

[behcet] No DHCP at MR which is a mobile device should also be an option to consider. In this case draft-sarikaya-mext-prefix-delegation in connection with draft-ietf-nemo-prefix-delegation provides the complete solution to perform prefix delegation for NEMO.

_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: Francis Dupont <[email-masked]>
Date: Wed, 12 Mar 2008 20:56:50 +0100

[behcet] This is what we have in draft-sarikaya-mext-relay-dhcpv6pd.
   A relay co-located with a client requires some standardization

=> I don't think it requires standardization as RFC 3315 doesn't mandate
physical links.

   as per the DHC session we had on Monday afternoon. This is to be
   undertaken by DHC WG.
   
   [behcet] We tried to avoid co-located DHCP server at the HA. Onlink
   DHCP server or backend DHCP server would be OK.
   
=> in fact there are 3 possible solutions at the HA:
 - a server
 - a relay and a server
 - a relay with a server on another node in the home infrastructure (with
  perhaps some other relays between the HA and the server, something unlikely
  but possible).

   [behcet] No DHCP at MR which is a mobile device should also be an
  option to consider. In this case draft-sarikaya-mext-prefix-delegation
  in connection with draft-ietf-nemo-prefix-delegation provides the
  complete solution to perform prefix delegation for NEMO.
   
=> I strongly disagree: this has no chance to gain consensus and we want
*one* solution based on what was designed to perform the prefix delegation
in general, i.e., DHCPv6 PD.

Thanks

[email-masked]
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext