Subject: [MEXT] Proposal for new Flow Idenfication option format

From: Conny Larsson <[email-masked]>
Date: Thu, 23 Apr 2009 12:49:41 +0200

Hi Hesham,

As there seems to be multiple proposals for the flow descriptor format I 
believe there is a need for a revised format of the Flow Identification 
option defined in draft-ietf-mext-flow-binding-01.txt.

My proposal would be as follows:

Flow Identification option:
===========================
This option includes information about the type of flow identification
format that follows. Exactly one option MUST be present in the message.

0                   1                   2                   3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Option Type   |  Option Len   |   Format      |               |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Option Type
   TBD

Option Len
   Length of option in octets.

Format
   01   Format type 1
   02   Format type 2

Flow Descriptor:
================
This option identifies a specific flow. There MAY exist multiple
Flow Descriptor options in one Flow Identification option

0                   1                   2                   3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Option Type   |  Option Len   |   Flow Description            |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+                               +
.                                                               .
.                                                               .
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Option Type
   TBD

Option Len
   Length of the Flow Description in octets

Flow Description
   Defined in a separate document per format type

Regards
Conny

---

From: George Tsirtsis <[email-masked]>
Date: Thu, 23 Apr 2009 14:20:43 +0100

Hi Conny,

We have been in intense editing of the Flow Binding draft for the last
couple of weeks and we are going to publish a new version early next
week. In this version we have already created a sub-option for the
flow description so that different types can be defined.

Sorry for the delay, please bear with us.

Thanks
George

On Thu, Apr 23, 2009 at 11:49 AM, Conny Larsson
<[email-masked]> wrote:
> _______________________________________________
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 23 Apr 2009 08:55:52 -0700 (PDT)

Hi Conny,
  All is well but there is no document for Format Type 1 (or 2) depending on how you number them.

Regards,

Behcet

________________________________
From: Conny Larsson <[email-masked]>
To: mext <[email-masked]>; Hesham Soliman <[email-masked]>
Sent: Thursday, April 23, 2009 5:49:41 AM
Subject: [MEXT] Proposal for new Flow Idenfication option format

Hi Hesham,

As there seems to be multiple proposals for the flow descriptor format I believe there is a need for a revised format of the Flow Identification option defined in draft-ietf-mext-flow-binding-01.txt.

0                  1                  2                  3

Option Type
  TBD

Option Len

Format
  01  Format type 1
  02  Format type 2

Flow Descriptor:
================

0                  1                  2                  3

Option Type
  TBD

Option Len

Flow Description

Regards
Conny

_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf..org/mailman/listinfo/mext