Subject: Re: [MEXT] (no subject)

From: Christian Kaas-Petersen <[email-masked]>
Date: Wed, 1 Apr 2009 07:31:59 +0000 (GMT)

The C flag, as defined in draft-devarapalli, means the home agent
shall do various processing, but shall not create an entry in the
binding cache.  However, draft-premec requires an entry in the
binding cache to be created in order to tunnel IPv4 packets.
So, either the semantics of the C flag shall be extended or
another flag shall be defined.  What is your suggestion?

Christian

--- Den tirs 31/3/09 skrev Behcet Sarikaya <[email-masked]>:

> Fra: Behcet Sarikaya <[email-masked]>
> Emne: [MEXT] (no subject)
> Til: [email-masked]
> Cc: "Charles E. Perkins" <[email-masked]>, "Domagoj Premec" <[email-masked]>
> Dato: tirsdag 31. marts 2009 22.19
> Hello all,
>   Regarding
> draft-premec-mext-extended-home-link-01.txt, I noticed that
> this draft is about what I asked Charlie last week during
> his presentation, i.e. sending BU at the home link for
> something other than deregistration. As the draft says in
> Sec. 4.1:
> When the MN returns home to an IPv6-only home network,
> the MN sends ... BU
>   I agree with Vijay that a flag must be defined
> and set for this purpose because normally this is not
> allowed and HA must probably reject such a BU. A flag
> to this end has already been suggested in
> draft-devarapalli-mext-mipv6-home-link-01 as C flag.
>  
> Regards,
>  
> Behcet
> 
> 
>       
> -----Inline-vedhæftet fil følger-----
> 
> _______________________________________________
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext
> 

      Trænger du til at se det store billede? Kelkoo giver dig gode tilbud på LCD TV! Se her http://dk.yahoo.com/r/pat/lcd

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 1 Apr 2009 07:39:05 -0700 (PDT)

Hi Christian,
  I am OK redefining the C Flag for this purpose. If other uses come up they should make their own case, I think.

Regards,

Behcet

________________________________
From: Christian Kaas-Petersen <[email-masked]>
To: [email-masked]; Behcet Sarikaya <[email-masked]>
Cc: Charles E. Perkins <[email-masked]>; Domagoj Premec <[email-masked]>
Sent: Wednesday, April 1, 2009 2:31:59 AM
Subject: SV: [MEXT] (no subject)

Christian

---

From: "Domagoj Premec" <[email-masked]>
Date: Thu, 2 Apr 2009 11:40:13 +0200

Behcet,

In draft-devarapalli-mext-mipv6-home-link-01 the C flag is being defined as
part of the BU and Back messages. Given that draft-premec-extended-home-link
is about registering for the v4 service from the IPv6-only home link, there
is always the IPv4 HoA option included and in this case it may be more
appropriate to define the new flag as part of the IPv4 HoA option. This
would save the flag space in the BU/Back without having disadvantages in the
extended home link scenario.

domagoj

	From: ext Behcet Sarikaya [mailto:[email-masked]] 
	Sent: 01. travanj 2009 16:39
	To: Christian Kaas-Petersen; [email-masked]
	Cc: Charles E. Perkins; Domagoj Premec
	Subject: Re: SV: [MEXT] draft-premec-mext-extended-home-link-01

	Hi Christian,
	  I am OK redefining the C Flag for this purpose. If other uses come
up they should make their own case, I think.
	 
	Regards,
	 
	Behcet

	From: Christian Kaas-Petersen <[email-masked]>
	To: [email-masked]; Behcet Sarikaya <[email-masked]>
	Cc: Charles E. Perkins <[email-masked]>; Domagoj Premec
<[email-masked]>
	Sent: Wednesday, April 1, 2009 2:31:59 AM
	Subject: SV: [MEXT] (no subject)

	Christian

	> -----Inline-vedhæftet fil følger-----

	      Trænger du til at se det store billede? Kelkoo giver dig gode
tilbud på LCD TV! Se her http://dk.yahoo.com/r/pat/lcd

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 2 Apr 2009 07:55:34 -0700 (PDT)

Hi Domagoj,
  You need to indicate to HA that this is a non-deregistration BU sent from the home link. So the correct way is to define a flag at the BU message like the C flag in http://tools.ietf.org/id/draft-devarapalli-mext-mipv6-home-link-01.txt
  Of course HA may also set the C flag in its reply of BA message. I think this was what Vijay was commenting on last week at the mext meeting.
  Yes, IPv4 HoA option has some bits available but these would apply to this option not to the BU message, I think it would be wrong to define this bit there.
  Regards,

Behcet

________________________________
From: Domagoj Premec <[email-masked]>
To: Behcet Sarikaya <[email-masked]>; Christian Kaas-Petersen <[email-masked]>; [email-masked]
Cc: Charles E. Perkins <[email-masked]>
Sent: Thursday, April 2, 2009 4:40:13 AM
Subject: RE: SV: [MEXT] draft-premec-mext-extended-home-link-01

Behcet,

domagoj

    Hi Christian,
    
    Regards,
    
    Behcet

    
    Christian

    > Fra: Behcet Sarikaya <[email-masked]>
    > Emne: [MEXT] (no subject)
    > Til: [email-masked]
    > Cc: "Charles E. Perkins" <[email-masked]>, "Domagoj Premec"
<[email-masked]>
    > Dato: tirsdag 31. marts 2009 22.19
    > Hello all,
    >  Regarding
    > draft-premec-mext-extended-home-link-01.txt, I noticed that
    > this draft is about what I asked Charlie last week during
    > his presentation, i.e. sending BU at the home link for
    > something other than deregistration. As the draft says in
    > Sec. 4.1:
    > When the MN returns home to an IPv6-only home network,
    > the MN sends ... BU
    >  I agree with Vijay that a flag must be defined
    > and set for this purpose because normally this is not
    > allowed and HA must probably reject such a BU. A flag
    > to this end has already been suggested in
    > draft-devarapalli-mext-mipv6-home-link-01 as C flag.
    >  
    > Regards,
    >  
    > Behcet
    > 
    > 
    >      
    > -----Inline-vedhæftet fil følger-----
    > 
    > _______________________________________________
    > MEXT mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/mext
    >