Subject: [MEXT] Fw: New Version Notification for draft-xia-mext-hioptv4-00

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 15 Jul 2009 08:51:27 -0700 (PDT)

Hello All,
  We have submitted a draft on configuring RFC 5555 (DSMIP) hosts using DHCPv4. The need for such a draft was pointed out by our AD in his message at:
http://www.ietf.org/mail-archive/web/mext/current/msg02729.html

Please see the past discussions around March 3, 2009 at http://www.ietf.org/mail-archive/web/mext/current/mail35.html.

  Please send your comments on the list.

Regards,

Behcet

----- Forwarded Message ----
> From: IETF I-D Submission Tool <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> Sent: Sunday, June 7, 2009 3:25:18 PM
> Subject: New Version Notification for draft-xia-mext-hioptv4-00
> 
> 
> A new version of I-D, draft-xia-mext-hioptv4-00.txt has been successfuly 
> submitted by Frank Xia and posted to the IETF repository.
> 
> Filename:    draft-xia-mext-hioptv4
> Revision:    00
> Title:        DHCPv4 Options for Home Information Discovery in Dual Stack MIPv6
> Creation_date:    2009-06-07
> WG ID:        Independent Submission
> Number_of_pages: 8
> 
> Abstract:
> This document defines DHCPv4 options for dynamic discovery of home
> network information in Dual Stack Mobile IPv6.  New DHCPv4 options
> are defined which allow a mobile node to request the home agent
> IPv4/v6 address, FQDN, or home network prefix and obtain it via the
> DHCPv4 response.
>                                                                                 
>   
> 
> 
> The IETF Secretariat.

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 16 Jul 2009 08:16:58 -0700 (PDT)

Hi Marcelo,
  Here is the history behind this draft: You can follow the thread with this subject: 
Proposed RFC editor change for DSMIPv6.
The first mail is by Hesham Soliman at http://www.ietf.org/mail-archive/web/mext/current/msg02713.html on February 28, 2009
Here Hesham suggests using DHCPv4 from the DHCP
Mobile IP Home Agent Option 68.

This was discussed in messages 2720 thru 2724 where people preferred defining a different DHCPv4 option. 
In fact way back in May 2008, at http://www.ietf.org/mail-archive/web/mext/current/msg01375.html
Frank had suggested this and asked this to be a recharter item.

In message http://www.ietf.org/mail-archive/web/mext/current/msg02727.html Jari asked DHCPv6 option defined in hiopt draft http://www.ietf.org/internet-drafts/draft-ietf-mip6-hiopt-17..txt could be used.
Hesham replied in message http://www.ietf.org/mail-archive/web/mext/current/msg02728.html that in hiopt it's assumed to only be present in IPv6-enabled networks and he suggested defining a new option.
Jari replied in http://www.ietf.org/mail-archive/web/mext/current/msg02729.html
that We can easily define an RFC to do this. He asked a draft to be written immediately.
In http://www.ietf.org/mail-archive/web/mext/current/msg02730.html Frank volunteered to help.

From March to June 2009 I think there was some offline communication between Hesham and Frank in which Hesham showed no interest in writing such a draft. Hesham can clarify this point if it is wrong, otherwise silence should be interpreted as acceptance.

We informed Jari offline sometime in May 2009 that we wrote the draft. We submitted the draft on June 7, 2009.

So we believe that enough has been said on this draft and ask the draft to be moved forward.

Regards,

Behcet

----- Original Message ----
> From: Behcet Sarikaya <[email-masked]>
> To: [email-masked]
> Sent: Wednesday, July 15, 2009 10:51:27 AM
> Subject: [MEXT] Fw: New Version Notification for draft-xia-mext-hioptv4-00
> 
> 
> Hello All,
>   We have submitted a draft on configuring RFC 5555 (DSMIP) hosts using DHCPv4. 
> The need for such a draft was pointed out by our AD in his message at:
> Please see the past discussions around March 3, 2009 at 
> http://www.ietf.org/mail-archive/web/mext/current/mail35.html.
> 
> > From: IETF I-D Submission Tool