Subject: [MEXT] Flow bindings in the HA->MN direction

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 22 Jul 2009 21:12:21 +0200

Hi,

There has been a long discussion about the possibility
of supporting the HA to send flow bindings to the MN.

Currently, we don't think there is clear use case for that
(in the sense that the use case doesn't seem to be widely
understood by the WG).

Since there are some WG members that have stated that they
do have a clear use case for this, we would like to suggest
them to present it in the next meeting, to see if we can move
move forward with figuring out if we need to support this
or not.

So, we would like to ask to all those that have stated that
there is a use for this, to contact the chairs in the
case they are willing to make a presentation about this in
the next meeting.

Please note well that the presentation we are asking for is
NOT about the protocols extensions that are needed to send
a flow binding from the HA to the MN.
What we are asking for is a clear use case, that includes
depicting a complete scenario where it makes sense and it is
useful for the HA to send a flow binding to the MN.

If nobody is able to make this case, i guess we will
have to assume that this use case does not exist and
act accordingly.

Regards, marcelo

---

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 22 Jul 2009 22:32:59 +0200

this is not exactly what we are asking for.
What we asked for is that the people that are willing to make such 
presentation, contact the chairs so we can coordinate how to do this.

So, thanks for volunteering, we will wait of there is more people who is 
willing to do this, so we can coordiante.

Regards, marcelo

Frank Xia escribió:
> Hi Marcelo
>
> We will make a presentation on  use cases
> that need HA->MN  flow binding operation.
>
> BR
> Frank
>
> ----- Original Message ----- From: "marcelo bagnulo braun" 
> <[email-masked]>
> To: "mext" <[email-masked]>
> Sent: Wednesday, July 22, 2009 2:12 PM
> Subject: [MEXT] Flow bindings in the HA->MN direction
>
>
>> Hi,
>>
>> _______________________________________________
>> MEXT mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/mext
>

---

From: Frank Xia <[email-masked]>
Date: Wed, 22 Jul 2009 15:50:03 -0500

Hi Marcelo

Here is a  comment on you summary.

BR
Frank

----- Original Message ----- 
From: "marcelo bagnulo braun" <[email-masked]>
To: "mext" <[email-masked]>
Sent: Wednesday, July 22, 2009 2:12 PM
Subject: [MEXT] Flow bindings in the HA->MN direction

> (in the sense that the use case doesn't seem to be widely
Frank=>IMHO, there is clear consensus that HA should
be able to send  flow bindings revocation to MN.

---

From: Frank Xia <[email-masked]>
Date: Wed, 22 Jul 2009 15:27:44 -0500

Hi Marcelo

BR
Frank

---

From: <[email-masked]>
Date: Wed, 22 Jul 2009 23:04:03 +0200

Hi Marcelo,

> (in the sense that the use case doesn't seem to be widely

Correct. I have yet to see a good use case which illustrates the need for
the HA to be involved in creating the flow-bindings.

> move forward with figuring out if we need to support this

I think not :)

-Raj

---

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 22 Jul 2009 23:17:04 +0200

> be able to send  flow bindings revocation to MN.
you are perfectly entitled to have that opinion, but i guess that the 
"designed consensus meters" are the chairs and i am afraid they don't 
share your opinion.
Morevoer, as i stated earlier, it is not clear what the use case or 
application scenario is for such functionality

Regards, marcelo

---

From: Frank Xia <[email-masked]>
Date: Wed, 22 Jul 2009 16:52:51 -0500

Hi Marcelo

See inline...

BR
Frank
----- Original Message ----- 
From: "marcelo bagnulo braun" <[email-masked]>
To: "Frank Xia" <[email-masked]>
Cc: "mext" <[email-masked]>
Sent: Wednesday, July 22, 2009 4:17 PM
Subject: Re: [MEXT] Flow bindings in the HA->MN direction

> application scenario is for such functionality
Frank=>Not very sure what is your point.  Just let me be clear.

As for flow binding revocation,  Hesham
said "Some people mentioned that the HA should be able
to revoke flows on the MN. I'm perfectly fine with that".
http://www.ietf.org/mail-archive/web/mext/current/msg03407.html

Nicolas said "As said in previous emails in this thread, yes,
this is a valid use  case IMHO."
http://www.ietf.org/mail-archive/web/mext/current/msg03399.html

So far, no one is against.

---

From: Hesham Soliman <[email-masked]>
Date: Thu, 23 Jul 2009 10:35:58 +1000

Frank, 

Obviusly not speaking on behalf of Marcelo, but since you're referring to my
statement, I want to explain that my understanding of Marcelo's email is
that it is not related to revokation of flows. He's talking about something
else (installing flows). My email was saying that I'm ok with the HA
revoking bindings, including flow bindings as a simple extension to binding
revokation in general, which is already approved by the WG.

So, if your concern is revokation of flow bindings I don't think you need to
worry. 

Hesham

---

From: Frank Xia <[email-masked]>
Date: Wed, 22 Jul 2009 20:07:37 -0500

Hi Hesham

Thank for your explanation.

IMHO, the goal should be the clarification of  ambiguious
charter which says "
A "Flow/binding policies exchange" solution for
an exchange of policies from the mobile host/router
to the Home Agent and from the Home Agent to the
mobile host/router influencing the choice of the
Care-of Address and Home Agent address. The solution
involves two specifications, one for the policy format
and another for its transport"

It is better to specify which kinds of HA->MN flowing
binding operation are enabled.

BR
Frank

----- Original Message ----- 
From: "Hesham Soliman" <[email-masked]>
To: "Frank Xia" <[email-masked]>; "marcelo bagnulo braun" 
<[email-masked]>
Cc: "mext" <[email-masked]>
Sent: Wednesday, July 22, 2009 7:35 PM
Subject: Re: [MEXT] Flow bindings in the HA->MN direction

Frank,

Hesham

---

From: Hesham Soliman <[email-masked]>
Date: Thu, 23 Jul 2009 13:47:04 +1000

That's a completely different point and that's addressed by the chair's
email. I was referring to the specific quotes you mentioned earlier.

Hesham