Subject: Re: [MEXT] Scenarios for HA to MN Flow Binding -draft-xia-mext-ha-init-flow-binding

From: "Mohana Jeyatharan" <[email-masked]>
Date: Thu, 8 Oct 2009 08:41:35 +0800

Hi Behcet and all,

>From the use cases people have proposed for flow binding work, it is
acceptable that in most cases, the decision about the flow binding rule
is made by the MN. 

But as mentioned in draft-xia-mext-ha-init-flow-binding, the flow
binding rule can originate from HA(be it mandatory or optional).  Bcos
in some cases, the network can decide what is best for it.  Since there
is a valid trust relation ship between HA and MN, the HA can use flow
binding protocol in a reverse way(as quoted in HA-init ID) to sends its
rules to MN.

In addition to the scenarios you have quoted,  I am quoting another
scenario, where the HA can suggest its flow binidng rules and the MN can
use these rules to create its own rules.
****************************************************
Flow binding rules initiated by HA
and their categories

[1]Some are Mandatory flow binding rules-case A
[2]Some are flow binding preferences and UE can decide on the suitable
flow binding rule based on some preference given by the network/HA-case
B
[3]Some flow binding rules are mandatory but to be applied when an event
occurs-Case C 

***************************************************
Case A and Case B scenarios are given together
***************************************************
HA changing default flow policies into default flow binding
============================================================
         +-----+
         | HA  |
         |     |
         +-----+
          /    \
    3G homelink \
   (PMIP)/       \
        /         \ HPLMN
       /           \
     +-----+    +-------+    
     | S-GW|    | ePDG  |
     |     |    |       |
     +-----+    +-------+
         \        /
          \      /
           \    /
            +---+
            |MN |
            +---+
The network entity such as HSS through AAA gives default flow policies
to HA (Voice via 3G and data via other).  The HA changes default
policies 
into default flow binding rules. 
The HA has PMIP binding for the home link and knows the binding for home
link and the access type tied to homebinding.
home binding BID1, foreign binding BID2.

Thus HA initiates default flow binding rule (FID1(voice) BID1.
FID2(data) BID2.
MN generates flow binding rules for uplink and downlink traffic based on
flow binding rules given by HA.   HA given rules can be subset of the
final MN flow binding rules.  

In case A, MN needs to follow these rules strictly.  

In case B, if there is no other external factor influencing the flow
binding rules being set by MN(ANDSF, MNs preferences etc) it will follow
the HA given flow binding rule.
Else it will NACK the HA given flow binding rule and give its own flow
binding rule.  
*******************************************************************
Comments?

Thanks.

BR,
Mohana

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Behcet Sarikaya
> Sent: Wednesday, September 30, 2009 3:45 AM
> To: [email-masked]
> Subject: [MEXT] Scenarios for HA to MN Flow Binding
-draft-xia-mext-ha-
> init-flow-binding
> 
> Hello all,
>   As presented in IETF 75
> http://www.ietf.org/proceedings/75/slides/mext-2/mext-2.htm
> 
> apart from flow binding revocation, we had
> - inter-interface flow movement and
> - default Flow Binding Provisioning
> scenarios.
> 
> Please post any comments on the above or related to the above
scenarios.
> 
> Regards,
> 
> Behcet
> 
> 
> 
> 
> _______________________________________________
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext

---

From: Frank Xia <[email-masked]>
Date: Fri, 09 Oct 2009 15:29:10 -0500

Hi Mohana

Thanks for bringing up pramatic scenarios.
Please check my inline comments.

BR
Frank

----- Original Message ----- 
From: "Mohana Jeyatharan" <[email-masked]>
To: "Behcet Sarikaya" <[email-masked]>; <[email-masked]>
Sent: Wednesday, October 07, 2009 7:41 PM
Subject: Re: [MEXT] Scenarios for HA to MN Flow 
Binding-draft-xia-mext-ha-init-flow-binding

> acceptable that in most cases, the decision about the flow binding rule
Frank=>I would like to say SOME people.  AFAIK, there are also some
people favor HA initiating flow binding.  You can tell from the verbose
discussion.

> binding protocol in a reverse way(as quoted in HA-init ID) to sends its
Frank=>Thank for mentioning our draft!

> use these rules to create its own rules.

Frank=>We presented this use case last IETF meeting.  Many argued  that this 
is about
default policy not binding rule provisioning, and this can be done through 
higher layer
mechnisms other than layer 3 solution.   Of course, I dont agree.  Flowing 
binding
is an operation above layer 3.   The terminologies demarcation in this 
context is
confusing.