Subject: Re: [MEXT] [WGLC] draft-ietf-mext-flow-binding-03

From: "Sundararajan, Jay Kumar" <[email-masked]>
Date: Fri, 9 Oct 2009 10:23:46 -0700

I read the draft and it looks good. Just have a few comments (mostly minor ones):

Comment 1
In page 10, the term "Binding Reference sub-option" is used for the first time before it is defined. It might be useful to say that it will be defined later...

Comment 2
Section 5.2.2.2 says:
"To modify an existing flow binding the mobile node MUST send a binding update with a flow identification option, with the FID field set to one of the FID values already in the list of flow binding entries."

I might have missed something, but in this case, what prevents the HA from sending a failure Status message "135 FID already in use" as mentioned in Section 5.3.2.1:

"If the FID field of the flow identification option is already present in the list of flow binding entries for this mobile node, the home agent MUST reject this flow binding add request by copying the flow identification option in the BA, and setting the Status field to 135 (FID already in use)."

In other words, how would the receiver distinguish between a modify request (which should not fail) and an add request with a used FID (which should fail)?

Comment 3
In Sections 5.3.2.2 and 5.3.3, the "FID not found" Status is set to 135, whereas the table in Page 9 says it is 136.

Comment 4
Section 4.2.2 says "17-32 reserved for Flow Description formats". But the section on IANA considerations says 16-32.

Minor comments:
1. Page 6: "ant-replay" -> "anti-replay"
2. Page 9: Under FID: "an 16-bit" -> "a 16-bit"
3. End of pg 12: "refresing" -> "refreshing"
4. Pg 17: "Mobiles nodes" -> "Mobile nodes"
5. Pg 18: "Status filed" -> "Status field"
6. Section 5.2.4: "bingings" -> "bindings"
7. Section 5.3.2.2: "processes" -> "process"
8. Section 5.3.3: "slow binding entries the, " -> "flow binding entries, the"
9. Section 5.3.6: End of 1st paragraph: there seems to be an extra "when"

---

From: George Tsirtsis <[email-masked]>
Date: Wed, 21 Oct 2009 19:36:04 +0100

Hi Jay,

Thanks for the comments. I think I accepted all of them...see below.

George

On Fri, Oct 9, 2009 at 6:23 PM, Sundararajan, Jay Kumar
<[email-masked]> wrote:
> In page 10, the term "Binding Reference sub-option" is used for the first
> time before it is defined. It might be useful to say that it will be defined
> later...
>
>

GT> I added a pointer to the sub-option definition

>
>
>
> Comment 2
>
> Section 5.2.2.2 says:
>
> "To modify an existing flow binding the mobile node MUST send a binding
> update with a flow identification option, with the FID field set to one of
> the FID values already in the list of flow binding entries."
>
>
>
> I might have missed something, but in this case, what prevents the HA from
> sending a failure Status message "135 FID already in use" as mentioned in
> Section 5.3.2.1:
>
>

GT> Section 5.3.2.1 is wrong. It is a remnant of the older version
when we were indicating ADD vs MODIFY explicitly in the Flow
Identification option. Section 5.3.2.1 will be corrected and the error
code "FID already in use" will be removed.

>
> "If the FID field of the flow identification option is already present in
> the list of flow binding entries for this mobile node, the home agent MUST
> reject this flow binding add request by copying the flow identification
> option in the BA, and setting the Status field to 135 (FID already in use)."
>
>
> In other words, how would the receiver distinguish between a modify request
> (which should not fail) and an add request with a used FID (which should
> fail)?
>
>
GT> As also caught by others, this is another remnant of an older
version, but I will correct all this in the new version. According to
the decisions we made in the last version of the spec, the HA simply
looks at the FIDs in the BU, if it has state for them then this is
modification, if it has no state for them it is an addition.

>
>
>
> Comment 3
>
> In Sections 5.3.2.2 and 5.3.3, the "FID not found" Status is set to 135,
> whereas the table in Page 9 says it is 136.
>
>

GT> fixed, actually I will renumber all of them since we have moved
things about over time.
>
>
>
> Comment 4
>
> Section 4.2.2 says "17-32 reserved for Flow Description formats". But the
> section on IANA considerations says 16-32.
>
>

GT> I will correct it thanks.
> 9. Section 5.3.6: End of 1st paragraph: there seems to be an extra "when"

GT> all of these fixed. Thanks!

> _______________________________________________
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext
>
>