Subject: [MIB-DOCTORS] pls update ianaiftype-mib - references to RFC3635

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Thu, 3 Aug 2006 17:52:33 +0200

Dear IANA staff,

The MIB Doctors are trying to build a references list for the
ifTypes as listed in the ianaiftype-mib at:
       http://www.iana.org/assignments/ianaiftype-mib

As a result we're also closely looking at the above mib module.
We'll report any updates that we believe should be made.

The following update seems obvious:

You currently have:

                   ethernetCsmacd(6), -- for all ethernet-like interfaces,
                                      -- regardless of speed, as per RFC3635
                   iso88023Csmacd(7), -- Deprecated via RFC-draft-ietf-hubmib-etherif-mib-v3  ethernetCsmacd (6) should be used instead
                   iso88024TokenBus(8),
                   iso88025TokenRing(9),
                   iso88026Man(10),
                   starLan(11), -- Deprecated via RFC-draft-ietf-hubmib-etherif-mib-v3  ethernetCsmacd (6) should be used instead

                   .. snip ..

                   fastEther(62),      -- Obsoleted via RFC-draft-ietf-hubmib-etherif-mib-v3  ethernetCsmacd (6) should be used instead

                   .. snip ..

                  fastEtherFX(69),    -- Obsoleted via RFC-draft-ietf-hubmib-etherif-mib-v3  ethernetCsmacd (6) should be used instead
 
                   .. snip ..

                   gigabitEthernet (117), -- Obsoleted via RFC-draft-ietf-hubmib-etherif-mib-v3  ethernetCsmacd (6) should be used instead

AS you can see at
  https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=7187&rfc_flag=0

that RFC-draft-ietf-hubmib-etherif-mib-v3 has been published as RFC3635,
and so I would change the referenc. As a result, the above should change to:

                   ethernetCsmacd(6), -- for all ethernet-like interfaces,
                                      -- regardless of speed, as per RFC3635
                   iso88023Csmacd(7), -- Deprecated via RFC3635
                                      -- ethernetCsmacd(6) should be used instead
                   iso88024TokenBus(8),
                   iso88025TokenRing(9),
                   iso88026Man(10),
                   starLan(11),       -- Deprecated via RFC3635,
                                      -- ethernetCsmacd(6) should be used instead

                   .. snip ..

                   fastEther(62),      -- Obsoleted via RFC3635,
                                       -- ethernetCsmacd(6) should be used instead

                   .. snip ..

                   fastEtherFX(69),   -- Obsoleted via RFC3635
                                      -- ethernetCsmacd(6) should be used instead
 
                   .. snip ..

                   gigabitEthernet (117), -- Obsoleted via RFC3635
                                          -- ethernetCsmacd(6) should be used instead
Bert

_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mib-doctors

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 3 Aug 2006 17:13:26 -0700

Hi -

I thought we previously discussed the question of whether it
made sense to update references, and I thought the conclusion
then was that it was sufficient to leave the pointer pointing
to whever the value was originally allocated.  Or am I remembering
some other discussion?

Randy

----- Original Message ----- 
> From: "Wijnen, Bert (Bert)" <[email-masked]>
> To: "IANA (E-mail)" <[email-masked]>
> Cc: "MIB Doctors (E-mail)" <[email-masked]>
> Sent: Thursday, August 03, 2006 8:52 AM
> Subject: [MIB-DOCTORS] pls update ianaiftype-mib - references to RFC3635
>