Subject: RE: [MIB-DOCTORS] FW: SnmpAdminString for URIs

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Mon, 4 Sep 2006 16:40:59 +0300

I am not sure where the 255 size comes from. I cannot find it in 1630,
1738 (or its successors 4248 and 4266), or 2368. Is there anything else
that makes you 'not sure if this is sufficient'? 

Dan

> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:[email-masked]] 
> Sent: Sunday, August 13, 2006 1:52 AM
> To: Romascanu, Dan (Dan)
> Cc: Randy Presuhn; [email-masked]; Ted Hardie
> Subject: Re: [MIB-DOCTORS] FW: SnmpAdminString for URIs
> 
> On Tue, Aug 01, 2006 at 08:57:54PM +0300, Romascanu, Dan (Dan) wrote:
> > There are two such objects in draft-ietf-sip-mib-11.txt. 
> > 
> > There are not too many other MIB modules in development in 
> this space, 
> > that I am aware about.
> > 
> > However, as draft-ietf-sip-mib-11.txt will be blocked 
> anyway this week 
> > by a DISCUSS (mine), maybe it's the right time.
> > 
> > Does anyone volunteer to propose a TC? 
> 
> The closest TC I am aware of is the following definition 
> copied from the NETWORK-SERVICES-MIB (RFC 2788):
> 
>   -- Uniform Resource Locators are stored in URLStrings.
> 
>   URLString ::= TEXTUAL-CONVENTION
>       DISPLAY-HINT "255a"
>       STATUS current
>       DESCRIPTION
>           "A Uniform Resource Locator represented in accordance
>            with RFCs 1738 and 2368, presented in the NVT ASCII
>            charset defined in RFC 854."
>       SYNTAX OCTET STRING (SIZE (0..255))
> 
> Not sure this is sufficient anymore these days.
> 
> When I needed such a TC in the past, I was reluctant to 
> become dependent on the NETWORK-SERVICES-MIB as a whole for 
> just one TC so putting such generally useful TCs into more 
> appropriate modules will certainly help.
> 
> /js
> 
> -- 
> Juergen Schoenwaelder		    International University Bremen
> <http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 
> 28725 Bremen, Germany
> 

_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mib-doctors

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 5 Sep 2006 11:45:49 +0200

On Mon, Sep 04, 2006 at 04:40:59PM +0300, Romascanu, Dan (Dan) wrote:

> 1738 (or its successors 4248 and 4266), or 2368. 

I am not surprised. As you know, the size 255 is the usual constraint
we traditionally put on all SNMP octet strings since at the end they
must fit into 484 byte SNMP messages. So these what we typically do is
to impose SNMP constraints that do not exist in the managed
technology. :-(

> Is there anything else that makes you 'not sure if this is
> sufficient'?

No. But I am sure once a URN expert reads the description he/she will
have comments I can't even dream of.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany