Subject: [MIB-DOCTORS] MIB Doctor review of draft-ietf-syslog-tc-mib-04.txt

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 7 Jan 2008 11:34:10 +0100

The document is in good shape, it compiles cleanly and passes idnits
checks. 

I have a few editorial comments:

1. I do not believe that it is necessary to carry all the duplicated
text in the MIB module as commented text, as it does not provide any
significant implementation information.

2. It would be good to mention in the TC definition or by using the
REFERENCE clause that the enumerated values replicate the values defined
respectively in tables 1 and 2 of [RFCPROT]. 

3. The document carries the standard security considerations section for
documents defining Textual Conventions. This text states correctly that
the TCs themselves do not introduce security concerns, but in this case
most probably objects defined by using these TCs will. To be on the
strict side I would add a phrase that says 'Objects defined using the
TCs defined in this document may introduce security issues, and the user
of these TCs should read the security considerations section of
[RFCPROT].'

Dan

_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mib-doctors

---

From: "Glenn M. Keeni" <[email-masked]>
Date: Thu, 10 Jan 2008 11:01:51 +0900

Dan,

   Thanks.
   Comments are inline.

> significant implementation information.
I will agree with this.
Are there any other opinions / suggestions on this issue ? > Syslog-WG
> respectively in tables 1 and 2 of [RFCPROT]. 

OK.

> of these TCs should read the security considerations section of

OK.

I will update the document and post a revised draft on the 16th of January.

Glenn

---

From: "David B Harrington" <[email-masked]>
Date: Thu, 10 Jan 2008 02:47:27 -0500

Hi, 

> Are there any other opinions / suggestions on this issue ? >
Syslog-WG

I believe the normative nature of the labels and values, and the
non-normative nature of the mappings to applications, is important
information for implementation and interpretation. If the MIB module
is separated from the document, we want to make sure this information
stays with the MIB module.

Therefeore, I would keep the text about the normative nature of the
labels and values in the MIB module and remove the duplicate text from
the surrounding document, if you are going to remove one of the
duplicates.

David Harrington
[email-masked]
[email-masked]

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 10 Jan 2008 08:54:01 +0100

> the surrounding document, if you are going to remove one of the

If the text is important (and I tend to agree it is), then it should
be in the DESCRIPTION clause and not comments. This also requires to
split the text into the text relevant for facilities and the text
relevant for severities.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Bert Wijnen - IETF" <[email-masked]>
Date: Thu, 10 Jan 2008 10:18:29 +0100

If so, then I would propose to move the text into DESCRIPTION
caluses, and not have them as comment lines.

Bert Wijnen 

> -----Oorspronkelijk bericht-----
> Van: David B Harrington [mailto:[email-masked]]
> Verzonden: donderdag 10 januari 2008 8:47
> Aan: 'Glenn M. Keeni'; 'Romascanu, Dan (Dan)'
> CC: [email-masked]; [email-masked]; 'Sam Hartman'
> Onderwerp: [MIB-DOCTORS] RE: MIB Doctor review
> ofdraft-ietf-syslog-tc-mib-04.txt
> 
> 
> Hi, 
>

---

From: "Glenn M. Keeni" <[email-masked]>
Date: Thu, 10 Jan 2008 19:13:10 +0900

OK. The general consensus seems to be that the commented text be
moved to the DESCRIPTION clause. I will do that.

I will also propose to leave the text in the "Background" section
as it is. It is an important part of the Background. Let me know
if there is disagreement.

Glenn

---

From: "David Harrington" <[email-masked]>
Date: Mon, 21 Jan 2008 12:48:42 -0500

Hi,

As document shepherd, I have reviewed the -05- revision, which
addresses the comments during MIB Doctor review. I believe changes
were not handled as desired.

The description of the normative/non-normatuive nature of each TC
should be in the DESCRIPTON clause of each TC, not in the
MODULE-IDENTITY DESCRIPTION clause. While this is redundant,
applications that display the description clause for an object (and
its  related TC) are not likely to display the description clause of
the MODULE-IDENTITY.

Glenn, can you please put the relevant text in the description clause
for each TC, splitting the text into those parts relevant to
facilities and those parts relevant to severities. When you have done
that, please send me (the document shepherd) a copy of the revised
document for review BEFORE submitting it to the ID editor, so we
minimize the churn in the data tracker, since this document is now
under AD review.

Thanks,
dbh 

> -----Original Message-----
> From: Glenn M. Keeni [mailto:[email-masked]] 
> Sent: Thursday, January 10, 2008 5:13 AM
> To: Bert Wijnen - IETF
> Cc: David B Harrington; [email-masked]; 'Sam Hartman'; 
> [email-masked]; 'Romascanu, Dan (Dan)'
> Subject: [Syslog] Re: [MIB-DOCTORS] RE: MIB Doctor 
> reviewofdraft-ietf-syslog-tc-mib-04.txt
> 
> >>>> text in the MIB module as commented text, as it does not
provide
> >> any
> Syslog mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/syslog
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 21 Jan 2008 19:08:22 +0100

I agree with David's comment and advice. 

Dan

> From: David Harrington [mailto:[email-masked]] 
> Sent: Monday, January 21, 2008 7:49 PM
> To: 'Glenn M. Keeni'; 'Sam Hartman'; 'Tim Polk'
> Cc: 'David B Harrington'; 'Chris Lonvick'; 
> [email-masked]; Romascanu, Dan (Dan); 'Bert Wijnen - 
> IETF'; [email-masked]
> Subject: draft-ietf-syslog-tc-mib-05.txt
> 
> Hi,
> 
> As document shepherd, I have reviewed the -05- revision, 
> which addresses the comments during MIB Doctor review. I 
> believe changes were not handled as desired.
> 
> The description of the normative/non-normatuive nature of 
> each TC should be in the DESCRIPTON clause of each TC, not in 
> the MODULE-IDENTITY DESCRIPTION clause. While this is 
> redundant, applications that display the description clause 
> for an object (and its  related TC) are not likely to display 
> the description clause of the MODULE-IDENTITY.
> 
> Glenn, can you please put the relevant text in the 
> description clause for each TC, splitting the text into those 
> parts relevant to facilities and those parts relevant to 
> severities. When you have done that, please send me (the 
> document shepherd) a copy of the revised document for review 
> BEFORE submitting it to the ID editor, so we minimize the 
> churn in the data tracker, since this document is now under AD review.
> 
> Thanks,
> dbh 
> 
> > OK. The general consensus seems to be that the commented 
> text be moved 
> > to the DESCRIPTION clause. I will do that.
> > 
> > I will also propose to leave the text in the "Background" 
> section as 
> > it is. It is an important part of the Background. Let me 
> know if there 
> > is disagreement.
> > 
> > Glenn
> > 
> >

---

From: "Glenn M. Keeni" <[email-masked]>
Date: Tue, 22 Jan 2008 13:36:03 +0900

David,

The initial intent was to keep the information in the
MIB module. So the MODULE IDENTITY's DESCRIPTION  seemed
to be a good place.  But, I will agree that the DESCRIPTION
of the respective TCs is a better place. [This may lead to
some more duplication of text.]

Glenn

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 22 Jan 2008 10:55:23 +0100

>This may lead to some more 
> duplication of text.]
> 
> Glenn
> 

Yes, but duplication of text is justified in this case as various other
MIB module may import only one TC, or another. 

Dan