Subject: [MIB-DOCTORS] FW: I-D ACTION:draft-harrington-text-mib-doc-template-04.txt

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 12 Feb 2008 14:03:35 +0100

The revised version of the MIB Documents Template I-D was published
yesterday. I plan to send this document to the IESG for approval in the
next 24 hours or so. Please let me know if you see any major reasons not
to do it. 

Dan

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Tuesday, February 12, 2008 2:30 AM
To: [email-masked]
Subject: I-D ACTION:draft-harrington-text-mib-doc-template-04.txt 

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: A Template for Documents Containing a MIB
Module
	Author(s)	: D. Harrington
	Filename	: draft-harrington-text-mib-doc-template-04.txt
	Pages		: 24
	Date		: 2008-2-11
	
This memo contains two annotated templates for IETF documents that
   contain the definition of MIB modules.  It is intended to alleviate
   the work of the authors of such documents, making these more uniform
   and easier to read and review, thus furthering the quality of such
   documents and expediting their publication.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-harrington-text-mib-doc-templa
te-04.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-harrington-text-mib-doc-template-04.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE
/internet-drafts/draft-harrington-text-mib-doc-template-04.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail
readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/mib-doctors

---

From: "David B Harrington" <[email-masked]>
Date: Tue, 12 Feb 2008 09:44:02 -0500

Hi,

I think the latest rev adresses all the major problems that were
raised.

1) The document now contains the template as an appendix rather than
trying to be both the document and the template simultaneously. It
took some work to figure out how to embed an I-D within an I-D and get
it through idnits. (I have not figured out to do the same with xml2rfc
template, only the text versions).

2) Using the cref option in xml2rfc, I was able to generate the
template both with and without inline advice. This was a major debate
point in the reviews. 

3) You will notice the "anchor" in the [TEMPLATE TODO] advice. I am
checking with the xml2rfc experts to see if I can suppress the anchor
from printing. If so, I can fix this during IETF review or AUTH48.
While not pretty, I think we can live with this as is if necessary,
since the editors need to cut out the [TEMPLATE TODO] paragraphs from
the end product anyway.

dbh

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Romascanu, 
> Dan (Dan)
> Sent: Tuesday, February 12, 2008 8:04 AM
> To: [email-masked]
> Subject: [MIB-DOCTORS] FW: 
> I-DACTION:draft-harrington-text-mib-doc-template-04.txt
> 
>  
> 	Filename	:
draft-harrington-text-mib-doc-template-04.txt

> You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 12 Feb 2008 16:08:40 +0100

One note to the RFC Editor should be asking to take out Appendices A and
B. 

Dan

> From: David B Harrington [mailto:[email-masked]] 
> Sent: Tuesday, February 12, 2008 4:44 PM
> To: Romascanu, Dan (Dan); [email-masked]
> Cc: 'Alfred HInes'; 'Adrian Farrel'
> Subject: RE: [MIB-DOCTORS] FW: 
> I think the latest rev adresses all the major problems that 
> were raised.
> 
> 1) The document now contains the template as an appendix 
> rather than trying to be both the document and the template 
> simultaneously. It took some work to figure out how to embed 
> an I-D within an I-D and get it through idnits. (I have not 
> figured out to do the same with xml2rfc template, only the 
> text versions).
> 
> 2) Using the cref option in xml2rfc, I was able to generate 
> the template both with and without inline advice. This was a 
> major debate point in the reviews. 
> 
> 3) You will notice the "anchor" in the [TEMPLATE TODO] 
> advice. I am checking with the xml2rfc experts to see if I 
> can suppress the anchor from printing. If so, I can fix this 
> during IETF review or AUTH48.
> While not pretty, I think we can live with this as is if 
> necessary, since the editors need to cut out the [TEMPLATE 
> TODO] paragraphs from the end product anyway.
> 
> dbh
> 
> > [mailto:[email-masked]] On Behalf Of Romascanu, Dan 
> > (Dan)
> > yesterday. I plan to send this document to the IESG for approval in 
> > the next 24 hours or so. Please let me know if you see any major 
> > reasons not to do it.
> > 
> > Dan
> > 
> > 
> >  
> > 
> > logging in, type "cd internet-drafts" and then "get 
> > draft-harrington-text-mib-doc-template-04.txt".
> > 
> > http://www.ietf.org/shadow.html or 
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > 
> > 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers