Subject: Re: [MIB-DOCTORS] question on InetAddressType/InetAddress

From: Brian Haberman <[email-masked]>
Date: Wed, 28 Jan 2009 13:47:01 -0500

Hi All,
      I have a quick question on this...

Juergen Schoenwaelder wrote:
> On Tue, Jan 27, 2009 at 11:58:01AM +0100, Bert Wijnen (IETF) wrote:
> 
>> While re-reviewing  aprelimenary new version of the mgmd-mib, 
>> I see things like:
>>
>> mgmdRouterCacheAddressType OBJECT-TYPE
>>     SYNTAX     InetAddressType
>>     MAX-ACCESS not-accessible
>>     STATUS     current
>>     DESCRIPTION
>>             "The address type of the mgmdRouterCacheTable entry. This
>>             value applies to both the mgmdRouterCacheAddress and the
>>             mgmdRouterCacheLastReporter entries."
>>     ::= { mgmdRouterCacheEntry 1 }
>>

If I want to restrict this to just IPv4 and IPv6, I thought I could 
define this object as such:

mgmdRouterCacheAddressType OBJECT-TYPE
     SYNTAX     InetAddressType { ipv4(1), ipv6(2) }
     MAX-ACCESS not-accessible
     STATUS     current
     DESCRIPTION
             "The address type of the mgmdRouterCacheTable entry. This
             value applies to both the mgmdRouterCacheAddress and the
             mgmdRouterCacheLastReporter entries."
     ::= { mgmdRouterCacheEntry 1 }

However, smilint gives me warning that InetAddressType objects should 
not be subtyped.  Is my syntax incorrect?

>> mgmdRouterCacheAddress OBJECT-TYPE
>>     SYNTAX      InetAddress (SIZE(4|16))
>>     MAX-ACCESS not-accessible
>>     STATUS     current
>>     DESCRIPTION
>>             "The IP multicast group address for which this entry
>>             contains information. The InetAddressType, e.g.
>>             IPv4 or IPv6, is identified by the
>>             mgmdRouterCacheAddressType variable in the mgmdRouterCache
>>             table."
>>     ::= { mgmdRouterCacheEntry 2 }
>>

If my syntax is correct on the InetAddressType, should I also drop the 
SIZE restriction on the InetAddress object?

>> I have spoken with Brian Haberman (editor of this document) and my
>> understanding is that he is firm in stating that they only want to
>> allow IPv4/IPv6 addresses.
>>
>> So that is why he/they put the SIZE(4|16) in the InetAddress Syntax.
>> If such is the case, then I feel one might as well (in fact I think
>> it is better) put InetAddressType (ipv4,ipv6) as subtype for the
>> AddressType.
> 
> Yes, if they want to restrict things to IPv4/IPv6, they should do this
> via the enumeration since the size restriction still allows e.g. DNS
> names with 4/16 characters.
> 
> I hope they also by intention disallow scoped addresses... Otherwise,
> the size restriction needs to be changed or removed completely.

While scoped addresses are allowed in the protocol messages, they do not 
require a scope index since the addresses are also indexed by the 
ifIndex (as pointed out by Dave Thaler).

Regards,
Brian
_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mib-doctors

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 1 Feb 2009 13:19:24 +0100

> not be subtyped.  Is my syntax incorrect?

The syntax is correct. A warning is just a warning; if you know what
you are doing, then you choose to ignore the warning.

> ifIndex (as pointed out by Dave Thaler).

So in this case, the SIZE restriction seems to be valid.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mib-doctors

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Mon, 2 Feb 2009 10:46:38 +0100

Agree
  ----- Original Message ----- 
  From: Juergen Schoenwaelder 
  To: Brian Haberman 
  Cc: MIB Doctors (E-mail) 
  Sent: Sunday, February 01, 2009 1:19 PM
  Subject: Re: [MIB-DOCTORS] question on InetAddressType/InetAddress

  /js