Subject: [MIB-DOCTORS] Proposal for revised IESG statement about copyright text in MIB and PIB modules

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 5 Mar 2009 14:32:37 +0100

This is basically copying the existing statement and replacing with the
appropriate updated copyright notice. 

Does this work? 

Dan

                     Copyright statement in MIB and PIB Modules
   
    Many people/tools extract the MIB or PIB modules out of our
    RFCs that contain a MIB or PIB module. In most cases they
    remove the copyright information that is part of the RFC.
    This is against the IETF copyright claim.

    People/tools do this not with bad intentions. The reason they
    do not extract the copyright info is because it is not in machine
    readable/parsable form, and they want the MIB or PIB modules to
    feed them into their agents, network management platforms, or
    other MIB or PIB tools.

    In order to ensure that the copyright statement is properly
    preserved and included in extracted MIB and PIB modules, and in
    order to make it easier for people/tools to keep the proper
    copyright when extracting MIB or PIB modules, the IESG has
    agreed with the the RFC-Editor that:

    The RFC-Editor, during the editing process of an RFC that
    contains a MIB or a PIB Module, copies a short copyright
    statement into the DESCRIPTION clause of the MODULE-IDENTITY
    macro of each MIB or PIB Module in the RFC-to-be.

    The copyright statement to be added for a MIB module is:
       
        "Copyright (c) (year) IETF Trust and the persons identified 
         as authors of RFC XXXX.

         This version of this MIB module is part of RFC xxxx; 
         see the RFC itself for full legal notices."

    The copyright statement to be added for a PIB module is:
       
        "Copyright (c) (year) IETF Trust and the persons identified 
         as authors of RFC XXXX.

         This version of this PIB module is part of RFC xxxx; 
         see the RFC itself for full legal notices."

---

From: "David Harrington" <[email-masked]>
Date: Thu, 5 Mar 2009 11:42:43 -0500

Do you want to add a section for XML schemas? for RelaxNG schemas? for
Netmod data models? 

dbh

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Romascanu, 
> Dan (Dan)
> Sent: Thursday, March 05, 2009 8:33 AM
> To: MIB Doctors (E-mail)
> Subject: [MIB-DOCTORS] Proposal for revised IESG statement 
> about copyrighttext in MIB and PIB modules
> 
> 
> 
> _______________________________________________
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 5 Mar 2009 20:04:06 +0100

Maybe later. I would like to start by focusing on the MIB documents
which the OPS area owns or is responsible with their reviews. There are
several documents on the pipe, at least one of them blocked from
publication by this single issue. 

Dan

> From: David Harrington [mailto:[email-masked]] 
> Sent: Thursday, March 05, 2009 6:43 PM
> To: Romascanu, Dan (Dan); 'MIB Doctors (E-mail)'
> Subject: RE: [MIB-DOCTORS] Proposal for revised IESG 
> statement about copyrighttext in MIB and PIB modules
> 
> Do you want to add a section for XML schemas? for RelaxNG 
> schemas? for Netmod data models? 
> 
> dbh
> 
> > [mailto:[email-masked]] On Behalf Of Romascanu, Dan 
> > (Dan)
> > Subject: [MIB-DOCTORS] Proposal for revised IESG statement about 
> > copyrighttext in MIB and PIB modules
> > 
> > 
> > 
> > This is basically copying the existing statement and replacing with 
> > the appropriate updated copyright notice.
> > 
> > Does this work? 
> > 
> > Dan
> > 
> >