Subject: [MIB-DOCTORS] FW: [IPFIX] I-D Action:draft-ietf-ipfix-mib-09.txt

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 10 Dec 2009 15:44:55 +0100

This document is on the agenda of the 12/17 telechat. 

It would be good if the MIB Doctors have a look at it. 

Dan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Thomas Dietz
Sent: Thursday, December 10, 2009 1:58 PM
To: [email-masked]
Subject: Re: [IPFIX] I-D Action:draft-ietf-ipfix-mib-09.txt

Dear all,

This is the new version of the IPFIX MIB with the changes discussed at
the last IETF.

The MIB has now a Observation Domain ID in the ObservationPointGroup
table.
Also the references in this table to the ENTITY MIB and IF MIB were made
clearer. We hope to have a final version now.

Best Regards,

Thomas

-- 
Thomas Dietz                 E-mail: [email-masked]
NEC Europe Ltd.              Phone:  +49 6221 4342-128
NEC Laboratories Europe      Fax:    +49 6221 4342-155
Network Research Division
Kurfuersten-Anlage 36
69115 Heidelberg, Germany    http://www.nw.neclab.eu

NEC Europe Limited           Registered in England 2832014
Registered Office: NEC House, 1 Victoria Road, London W3 6BL

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf

> Of [email-masked]
> Sent: Donnerstag, 10. Dezember 2009 12:30
> To: [email-masked]
> Cc: [email-masked]
> Subject: [IPFIX] I-D Action:draft-ietf-ipfix-mib-09.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> This draft is a work item of the IP Flow Information Export Working 
> Group of the IETF.
> 
> 
> 	Title           : Definitions of Managed Objects for IP Flow
> Information Export
> 	Author(s)       : T. Dietz, et al.
> 	Filename        : draft-ietf-ipfix-mib-09.txt
> 	Pages           : 68
> 	Date            : 2009-12-10
> 
> This document defines managed objects for IP Flow Information Export 
> (IPFIX).  These objects provide information for monitoring IPFIX 
> Exporters and IPFIX Collectors including the basic configuration 
> information.
> 
> Status of this Memo
> 
> This Internet-Draft is submitted to IETF in full conformance with the 
> provisions of BCP 78 and BCP 79.
> 
> Internet-Drafts are working documents of the Internet Engineering Task

> Force (IETF), its areas, and its working groups.  Note that other 
> groups may also distribute working documents as Internet- Drafts.
> 
> Internet-Drafts are draft documents valid for a maximum of six months 
> and may be updated, replaced, or obsoleted by other documents at any 
> time.  It is inappropriate to use Internet-Drafts as reference 
> material or to cite them other than as "work in progress."
> 
> The list of current Internet-Drafts can be accessed at 
> http://www.ietf.org/ietf/1id-abstracts.txt.
> 
> The list of Internet-Draft Shadow Directories can be accessed at 
> http://www.ietf.org/shadow.html.
> 
> This Internet-Draft will expire on June 13, 2010.
> 
> Copyright Notice
> 
> Copyright (c) 2009 IETF Trust and the persons identified as the 
> document authors.  All rights reserved.
> This document is subject to BCP 78 and the IETF Trust's Legal 
> Provisions Relating to IETF Documents
> (http://trustee.ietf.org/license-info) in effect on the date of 
> publication of this document.  Please review these documents 
> carefully, as they describe your rights and restrictions with respect 
> to this document.  Code Components extracted from this document must 
> include Simplified BSD License text as described in Section 4.e of the

> Trust Legal Provisions and are provided without warranty as described 
> in the BSD License.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-ipfix-mib-09.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader 
> implementation to automatically retrieve the ASCII version of the 
> Internet-Draft.
_______________________________________________
IPFIX mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipfix

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Thu, 10 Dec 2009 23:01:15 +0100

I only did a SMICng syntax check.
I get these SMICng errors/warnings in strict checking mode:

E: f(ipfix.mi2), (486,12) Index item "ipfixTemplateObservationDomainId" must be defined with syntax t
hat includes a range
E: f(ipfix.mi2), (596,12) Index item "ipfixTemplateObservationDomainId" must be defined with syntax t
hat includes a range
E: f(ipfix.mi2), (968,12) Index item "ipfixObservationPointGroupId" must be defined with syntax that
includes a range
W: f(ipfix.mi2), (761,12) Row "ipfixExportEntry" does not have a consistent indexing scheme - index i
tems from current table must come after index items from other tables

The third one may indeed need attention. It is this one I think:

   ipfixObservationPointGroupId OBJECT-TYPE
       SYNTAX      Unsigned32
       MAX-ACCESS  not-accessible
       STATUS      current
       DESCRIPTION
           "Locally arbitrary, but unique identifier of an entry in the
           ipfixObservationPointTable. The value is expected to remain
           constant from a re-initialization of the entity's network
           management agent to the next re-initialization.

           This index represents a group of Observation Points.

           The special value of 0 MUST NOT be used within this table
           but is reserved for the usage in the
           ipfixMeteringProcessTable. An index of 0 for the
           ipfixObservationPointGroupReference index in that table
           indicates that an Observation Point is unknown or
           unspecified for a Metering Process cache."
       ::= { ipfixObservationPointEntry 1 }

So it says that zero MUST NOT be used. It sems that you then ought to define
a range that excludes zero as a valid value.

Bert

  ----- Original Message ----- 
  From: Romascanu, Dan (Dan) 
  To: [email-masked] 
  Cc: Benoit Claise ; Thomas Dietz ; Juergen Quittek 
  Sent: Thursday, December 10, 2009 3:44 PM
  Subject: [MIB-DOCTORS] FW: [IPFIX] I-D Action:draft-ietf-ipfix-mib-09.txt

  Dan

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]] On Behalf
  Of Thomas Dietz
  Sent: Thursday, December 10, 2009 1:58 PM
  To: [email-masked]
  Subject: Re: [IPFIX] I-D Action:draft-ietf-ipfix-mib-09.txt

  Dear all,

  Best Regards,

  Thomas

  > implementation to automatically retrieve the ASCII version of the 

------------------------------------------------------------------------------

------------------------------------------------------------------------------

  _______________________________________________
  MIB-DOCTORS mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/mib-doctors

------------------------------------------------------------------------------

  Geen virus gevonden in het binnenkomende-bericht.
  Gecontroleerd door AVG - www.avg.com 
  Versie: 9.0.709 / Virusdatabase: 270.14.102/2556 - datum van uitgifte: 12/10/09 08:36:00