Subject: [MIB-DOCTORS] FW: Last Call: <draft-ietf-mpls-tp-mib-management-overview-05.txt>(Multiprotocol Label Switching Transport Profile (MPLS-TP)MIB-based Management Overview) to Informational RFC

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 28 Nov 2011 16:27:07 +0100

MIB Doctors and OPS-MIB directorate members,

This I-D deserves your attention, please read and send comments to the
last call. 

Regards,

Dan

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of The IESG
Sent: Monday, November 28, 2011 5:07 PM
To: IETF-Announce
Cc: [email-masked]
Subject: Last Call:
<draft-ietf-mpls-tp-mib-management-overview-05.txt>(Multiprotocol Label
Switching Transport Profile (MPLS-TP)MIB-based Management Overview) to
Informational RFC

The IESG has received a request from the Multiprotocol Label Switching
WG
(mpls) to consider the following document:
- 'Multiprotocol Label Switching Transport Profile (MPLS-TP) MIB-based
   Management Overview'
  <draft-ietf-mpls-tp-mib-management-overview-05.txt> as an
Informational
RFC

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action. Please send substantive comments to the
[email-masked] mailing lists by 2011-12-12. Exceptionally, comments may
be
sent to [email-masked] instead. In either case, please retain the
beginning of the Subject line to allow automated sorting.

Abstract

   A range of Management Information Base (MIB) modules has been
   developed to help model and manage the various aspects of
   Multiprotocol Label Switching (MPLS) networks.  These MIB modules are
   defined in separate documents that focus on the specific areas of
   responsibility of the modules that they describe.

   The MPLS Transport Profile (MPLS-TP) is a profile of MPLS
   functionality specific to the construction of packet-switched
   transport networks.

   This document describes the MIB-based architecture for MPLS-TP,
   and indicates the interrelationships between different existing MIB
   modules that can be leveraged for MPLS-TP network management and
   identifies areas where additional MIB modules are required.

The file can be obtained via
http://datatracker.ietf.org/doc/draft-ietf-mpls-tp-mib-management-overvi
ew/

IESG discussion can be tracked via
http://datatracker.ietf.org/doc/draft-ietf-mpls-tp-mib-management-overvi
ew/

No IPR declarations have been submitted directly on this I-D.

_______________________________________________
IETF-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Wed, 30 Nov 2011 12:03:47 +0100

I did a skim of the document.
- It seems to give an in depth overview of the current
   MIB modules in MPLS related space and also it lists
   identified gaps if those MIB modules need to support
   MPLS-TP space.
- it looks to be in reasonable (good enough I guess)
   shape for publication as Informational RFC modulo
   some remarks below.
- I did not go and check all the details and related
   documents. So I cannot claim that I have verified
   all (in fact any) of the statements.
- I wonder if the "may be extended" and "can be
   extended" in the various subsections in section 5
   are intended to mean different things. I think not.
   To me it all sounds like "this could be done, but we
   doubt anyone will do it, or at least not in IETF".
- Section 6 however DOES define what needs to be done
   in terms of new MIB modules, so that is promising.
- I see in sect 6.1.2 that a MEP Identifier TC needs
   to be defined. Is this a similar identifier as the
   MEP Identifier defined in IEEE 802.1ag? Probably not,
   but someone should probably check at the time they
   start developing this MPLS-TP-TC  MIB module.
- sect 6.2.1 sems to want tio place a TC MIN module
   directly under "transmission". I am not sure that is
   the proper place.

So I am not sure how useful my short review is, other
than to say that a document like this (assuming the data
is correct and complete) is helpful for people who need
to implement Network Management systems for MPLS and
MPLS-TP based systems.

Bert

On 11/28/11 4:27 PM, Romascanu, Dan (Dan) wrote:
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors
>

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Wed, 30 Nov 2011 12:25:03 +0100

Dan,

My review of draft-ietf-mpls-tp-mib-management-overview-05.txt
I did not send it to editors or mpls list.
It was a quick review, so that you have some idea of what I looked at.
For a real review, I think it would take a lot of time.
But feel free to use my comments and/or forward them as you see fit.
As long as people realize that it was a quick skim and not a detailed review

Bert
-------- Original Message --------
Subject: Re: [MIB-DOCTORS] FW: Last Call: <draft-ietf-mpls-tp-mib-management-overview-05.txt>(Multiprotocol Label Switching 
Transport Profile (MPLS-TP)MIB-based Management Overview) to Informational RFC
Date: Wed, 30 Nov 2011 12:03:47 +0100
From: Bert Wijnen (IETF) <[email-masked]>
To: Romascanu, Dan (Dan) <[email-masked]>
CC: [email-masked], [email-masked]

Bert

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 30 Nov 2011 15:12:28 +0100

Thanks, Bert. I believe that your 'skim' review is valuable also for the
document authors and broader community. Would you mind sending it to
[email-masked]? 

Regards,

Dan

> From: Bert Wijnen (IETF) [mailto:[email-masked]]
> Sent: Wednesday, November 30, 2011 1:04 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [MIB-DOCTORS] FW: Last Call: <draft-ietf-mpls-tp-mib-
> management-overview-05.txt>(Multiprotocol Label Switching Transport
> Profile (MPLS-TP)MIB-based Management Overview) to Informational RFC
> 
> >     Multiprotocol Label Switching (MPLS) networks.  These MIB
modules
> are