Subject: [MIB-DOCTORS] ianaaddressfamilynumbers-mib versus address-family-numbers

From: Benoit Claise <[email-masked]>
Date: Mon, 19 Nov 2012 16:21:02 +0100

Hi Michelle,

I have a few questions I'm unable to answer.
Brian and I have been looking at address family number, address family 
TC, and the InetAddressType, respectively
- [1] 
http://www.ietf.org/assignments/address-family-numbers/address-family-numbers.txt
- [2] 
http://www.iana.org/assignments/ianaaddressfamilynumbers-mib/ianaaddressfamilynumbers-mib 

- [3]  http://www.ietf.org/rfc/rfc4001.txt

First of all, I can't find the procedure to update [2]
It contains

       REVISION     "9908260000Z"  -- August 26, 1999
       DESCRIPTION  "Initial version, published as RFC 2677."

However, RFC 2677 mentions:
    Any additions or changes to the list of ADDRESS FAMILY NUMBERS
    registered via IANA will be done as they have in the past

Then, we're wondering if [1] should automatically update [2]?
For example, we see some differences for the latest additions in [1]:

       16384    EIGRP Common Service Family                                   [Donnie_Savage]                                2008-05-13
       16385    EIGRP IPv4 Service Family                                     [Donnie_Savage]                                2008-05-13
       16386    EIGRP IPv6 Service Family                                     [Donnie_Savage]                                2008-05-13
       16387    LISP Canonical Address Format (LCAF)                          [David_Meyer]                                  2009-11-12

Or maybe it the top values are experimental, and that's the reason why 
they're not shared?

And third, for the MIB doctors, [3] has not been updated for a long 
time. Is this because [2] is somehow considered as a superset?

Regards, Benoit

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 19 Nov 2012 16:35:19 +0100

> time. Is this because [2] is somehow considered as a superset?

RFC 4001 is about address formats for the IP layer. And so far, it
seems we only have IPv4 and IPv6 as standards-track specifications to
care about. My understanding is that the address family registry has a
much larger scope. As such, RFC 4001 only deals with supset of the
registered address families.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>