Subject: Re: [MIB-DOCTORS] Fwd: Request to add to the MIB boilperplate for "writeable objects"

From: Randy Presuhn <[email-masked]>
Date: Fri, 6 Jun 2014 19:12:26 -0700 (GMT-07:00)

Hi -

>From: Benoit Claise <[email-masked]>
>Sent: Jun 5, 2014 5:01 AM
>To: "MIB Doctors (E-mail)" <[email-masked]>
>Cc: Adrian Farrel <[email-masked]>
>Subject: [MIB-DOCTORS] Fwd: Request to add to the MIB boilperplate for	"writeable objects"
>
>Dear MIB-doctors,
>
>Here is a proposal from Adrian on updating the MIB boilerplate.
>This looks good to me. Any feedback?

The proposal contains two parts.  The first provides a historical
record of the working group's thinking, but is of no help in
implementation or deployment.  The second is purely tutorial.
>From my perspective, each would increase the length of a
specification without increasing its utility.  Consequently,
I believe this change would be counterproductive and should
*not* be adopted.

Randy

>Regards, Benoit
>
>
>-------- Original Message --------
>Subject: 	Request to add to the MIB boilperplate for "writeable objects"
>Date: 	Wed, 4 Jun 2014 17:06:16 +0100
>From: 	Adrian Farrel <[email-masked]>
>Reply-To: 	<[email-masked]>
>To: 	<[email-masked]>
>
>
>
>Hi Benoit,
>
>After the work on the BFD MIB modules and considering the IESG statement on
>writeability, would you consider adding to the MIB boilerplate an optional piece
>of text that says...
>
>====
>The following objects in the MIB modules in this document have write access
>either through read-write or read-create MAX-ACCESS clauses. The level of access
>to these objects have been discussed by the <xxxx> working group and it was
>concluded that write access was beneficial for the following reasons:
>
>- <list of reasons>
>
>- <list of objects>
>
>As with all MIB modules, an attempt to SET or CREATE an object to a value that
>is not supported by the implementation will result in a failure using a return
>code that indicates that the value is not supported.
>
>====
>
>I think this would help to contain and control work on MIB documents in the
>future, and would give the Doctors something to review against.
>
>Please wordsmith to your heart's content.
>
>Ciao,
>Adrian
>
>.
>
>
>

---

From: "ietfdbh" <[email-masked]>
Date: Mon, 16 Jun 2014 15:59:49 -0400

+1

David Harrington
[email-masked]
+1-603-828-1401

> -----Original Message-----
> From: MIB-DOCTORS [mailto:[email-masked]] On Behalf Of
> Randy Presuhn
> Sent: Friday, June 06, 2014 10:12 PM
> To: Benoit Claise; MIB Doctors (E-mail)
> Cc: Adrian Farrel
> Subject: Re: [MIB-DOCTORS] Fwd: Request to add to the MIB boilperplate for
> "writeable objects"
> 
> Hi -
> 
> >writeability, would you consider adding to the MIB boilerplate an
optional
> piece
> _______________________________________________
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors