Subject: [MIB-DOCTORS] Advice on replacing a MIB module

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 21 Jan 2015 10:43:43 -0000

I have a WG that wants to obsolete an RFC containing a MIB module and replace
with a new one with a few mods.

As I understand it this shouldn't be quite so simple because there is a need to
retain versioning information in the field.

What is the best approach?

Currently they have added information to the Revision clause, but I doubt this
is enough.

Should they ask for a new OID?

Thanks for any pointers.

Adrian

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 21 Jan 2015 12:08:56 +0100

Adrian,

it depends on what the change is the WG wants to do:

a) If the WG wants to revise the MIB module adding a couple of
   objects, deprecating some, but the MIB module in general is fine,
   then you do not need a new OID and module name. SMIv2 update rules
   must be followed but then everything will work fine.

b) If the WG concluded that the MIB module is fundamentally flawed and
   needs to be rewritten from scratch, then you may want to go with a
   new module name and OID.

The phrase "replace with a new one a few mods" sounds like a). And yes,
they will most likely have to add a new compliance statement and such
things.

/js

On Wed, Jan 21, 2015 at 10:43:43AM +0000, Adrian Farrel wrote:
> _______________________________________________
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 21 Jan 2015 11:28:34 -0000

Ah, "compliance statement".
Thanks, that'll be the approach.

Cheers,
Adrian

> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:[email-masked]]
> Sent: 21 January 2015 11:09
> To: Adrian Farrel
> Cc: [email-masked]; Alvaro Retana; [email-masked]
> Subject: Re: [MIB-DOCTORS] Advice on replacing a MIB module
> 
> Adrian,
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 21 Jan 2015 09:49:23 -0500

> On Jan 21, 2015:5:43 AM, at 5:43 AM, Adrian Farrel <[email-masked]> wrote:
> 

	There is a well defined procedure for deprecating and old module and upgrading that I like to call The Deprecation Dance. It is first noted in RFC1444 and later in a MIB Doctor Guideline here: http://tools.ietf.org/html/rfc4181

	--Tom

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 21 Jan 2015 15:18:38 -0000

Thanks Tom,

Good pointer.

A

> From: Thomas D. Nadeau [mailto:[email-masked]]
> Sent: 21 January 2015 14:49
> To: Farrel Adrian
> 	There is a well defined procedure for deprecating and old module and
> upgrading that I like to call The Deprecation Dance. It is first noted in
RFC1444 and
> later in a MIB Doctor Guideline here: http://tools.ietf.org/html/rfc4181
> 
> 	--Tom
> 
> 
> >
> > Adrian
> >